IRC channel logs

2020-11-09.log

back to list of logs

<OriansJ>snnw: nice; understandably.
<Darius>my own meta thingy from the archives, if anyone cares for another variation https://github.com/darius/sketchbook/tree/master/metatoo/metametoo
<xentrac>yay meta too :)
<Darius>my opinion is that it's educational but not something i'm tempted to use directly in any other project so far
<Darius>kind of like forth that way
<OriansJ>Darius: it is missing a FSF approved license
<Darius>thought i stuck a license on the whole repo, but ok, thanks for the reminder
<Darius>added gpl3
<OriansJ>thank you Darius and might I say; https://github.com/darius/ichbins is awesome
<Darius>oh thanks! glad you liked it
<OriansJ>indeed I did ^_^
<xentrac>yeah, ichbins is amazing
<Darius>i started on some docs to check in, but am distracted by real-world problems right now
<xentrac>I'm embarrassed to admit I still don't fully understand ichbins tho
<xentrac>I need to go back and study it again
<xentrac>Darius: that's a pretty harsh condemnation of Forth coming from someone who interned at Forth Inc. :)
<Darius>the mid-80s were a different world :)
<xentrac>well, maybe not of Forth, but of using Forth in real life I guess
<Darius>it was a little bit like a more practical smalltalk in that older context
<xentrac>like smalltalk because you had interactive development and hyperlinks to definitions?
<xentrac>and untyped is sort of like dynamically typed I guess
<Darius>interactive development, agile control over the environment, full source to it
<xentrac>and metaprogramming
<Darius>right
<xentrac>so what changed is that Smalltalk became practical? :)
<Darius>and using that access & control was a normal thing to do in that culture
<xentrac>right
<Darius>that kind of development, yes
<xentrac>people in Python get upset when you change the value of 5
<Darius>i think smalltalk/v had recently come out (or some earlier incarnation in a different name?) but really pushed the limits of the pc
<Darius>i never had a chance to play with that, anyway
<xentrac>yeah, and wasn't available for the PDP-10
<fossy>ooooooohhh
<fossy>Darius: which varient of lisp?
<fossy>is it scheme? i think it is
<xentrac>fossy: what, ichbins?
<fossy>yes, ichbins
<xentrac>the name stands for "I can hardly believe it's not Scheme"
<fossy>mhm
<xentrac>;)
<OriansJ>To reduce manually having to spot cases where M2-Planet will generate a binary which will segment fault because the C program initializes a local inside of a Loop; I'm simply going to have M2-Planet display an error message with that context information and halt. (This will result in some "working" programs breaking but will minimize the problem long term)
<xentrac>great!
<OriansJ>patches are up for M2-Planet
<xentrac>yay!
<OriansJ>and the related mescc-tools fixes are now up
<xentrac>congratulations!
<xentrac>hasn't been such an unproductive weekend after all :)
<OriansJ>xentrac: only an hour of coding time is less than ideal
<xentrac>my friend Jeff Barr told me that one of his most productive side project coding years was on Carmen's Headline Viewer
<OriansJ>and a few minor improvements to mes-m2's macro support got squeezed in too.
<xentrac>which he named after his wife, but mostly just called it HeadlineViewer at, I think, her request
<xentrac>Jeff and Carmen are Mormons
<xentrac>so I think that year he had six kids, one of which was a baby and one a toddler
<xentrac>he said he wrote all of CHV in fifteen-minute pieces, which was possible in significant part because he never got up from the chair unless the code was working
<xentrac>but that was the largest piece of uninterrupted time he could manage that year
<OriansJ>writing a standards compliant Scheme in a C subset in 15minute increments. Sounds like a religous challenge.
<xentrac>like doing a pilgrimage on your knees?
<xentrac>well, HeadlineViewer also had some advantages there :)
<OriansJ>xentrac: more like a pilgrimage on one's back
<xentrac>sounds like a porn story about temple prostitutes
<OriansJ>or a world class limbo star
<xentrac>indeed
<xentrac>a very religious one
<OriansJ>So Hermes Conrad?
<xentrac>not familiar. was that Joseph's brother?
<OriansJ>A Futurama reference
<OriansJ> https://futurama.fandom.com/wiki/Hermes_Conrad
<siraben>Hah, compare https://github.com/darius/sketchbook/blob/master/metatoo/metametoo/infix.meta and https://github.com/siraben/meta-yacc/blob/master/arith.txt
<siraben>Pretty much the same
<xentrac>haha
<xentrac>meat grinds like a trick
<siraben>Meat grinds?
<xentrac>great minds
<siraben>Ah
<siraben>At the point where you have self-compilation, it gets real meta real fast. Is my language the "real" one using C is an intermediate language or is C the "real" one? From an philosophical (?) viewpoint it's indistinguishable.
<siraben>Speaking of meta things, is anyone aware of a full implementation of the Futamura projections?
<siraben>Quick search reveals https://github.com/darius/cogen
<Darius>siraben, that's not quite that -- i was taking the tack that it should be more straightforward to write the same thing you get by the third futamura projection, but directly
<Darius>also i'm not sure that version is in a working state -- maybe only the old/ directory?
<Darius>it did work once but it's actually much older than the 7 years ago it was put on github
<siraben>I see
<Darius>that thesis did seem to bear out, at least for that simple first-order sublanguage
<rain1>that's a good question.. where is some working code for futamura
<jelle>not again
<rain1>hey jelle whats up?
<jelle>wrong window :P
<rain1>:)
<Darius>rain1, siraben, i dunno if this exactly answers, but nada amin / tiark rompf on collapsing towers of interpreters sounded relevant and recent
<Darius>and i know you can find the repo
<terpri>rain1, perhaps https://fi.ftmr.info/PE-Museum/SelfApplicablePE.pdf ? ;)
<terpri>labelled "Source Program and Results of Test Runs of Self Applicable PE" on futamara's homepage (https://fi.ftmr.info/); it looks like LISP 1.5 (with handwritten M-expressions in the margins!)
<Darius>i definitely remember listings in the jones-sestoft partial evaluation book
<rain1>it looks like it could be possible to get Similix working
<siraben>Darius: Yeah I recall that talk. I haven't looked into the papers though.
<siraben>Paper: https://www.cs.purdue.edu/homes/rompf/papers/amin-popl18.pdf
<siraben>Fortunately it looks like they have small-step and big-step operational semantics for the translation, however I wish it took a more abstract, perhaps even categorial, approach.
<rain1>I got it working
<rain1>> (similix 'append1 (list '(1 2 3) '***) "append.sim")
<rain1>front-end flow bt sp eod oc rl
<rain1>specializing
<rain1>((define (append1-0 l2_0) (cons 1 (cons 2 (cons 3 l2_0)))))
***pgreco_ is now known as pgreco
<xentrac>nice! congratulations!