IRC channel logs

2020-10-23.log

back to list of logs

<OriansJ`>deesix: well SCM is just an alias for unsigned long (one that I haven't added to cc_* yet but would be trivial to do so.
<ericonr>xentrac: that I don't know. Possibly, with some PIC32? but that's an architecture where C itself is a pain
<OriansJ`>ericonr: well M2-Planet is only 2335 lines of code and written in the same subset it is able to compile.
<OriansJ`>essentially think of M2-Planet as the Maxwell core of the C programming language (structs, arrays, inline assembly and a handful of primitives)
***terpri_ is now known as terpri
<OriansJ`>with approximately 252 lines of c/inline assembly per architecture supported
<OriansJ`>deesix: the big question is M2-Planet still working on AArch64 and do all the tests pass or is there something I broke and need to fix
<OriansJ`>xentrac: what good is a C compiler that can't build itself? Even c500.c (A 500 line C compiler) that can self-host and it can't even support structs.
<xentrac>hmm, I haven't tried PIC32; I thought it was a MIPS?
<xentrac>OriansJ`: SDCC allows you to program your 8051 in C instead of assembly language, which saves you a lot of time when what you want is to program an 8051
<xentrac>especially if you want to use an already existing and validated library routine that happens to be written in C instead of 8051 assembly
<ericonr>it's also the only oss toolchain for some obscure stuff
<ericonr>xentrac: apparently it's MIPS https://en.wikipedia.org/wiki/PIC_microcontrollers#PIC32M_MIPS-based_line
<ericonr>might be doable, then
<ericonr>idk if sdcc actually supports it as a target, tho
<xentrac>don't think so
<OriansJ`>xentrac: well C has an overhead relative to assembly but I guess if the price for additional flash is cheap enough; it gets accepted because assembly programmers are expensive
<xentrac>yeah. also rewriting code for new platforms is expensive
<OriansJ`>absolutely true; where to spend the money on hardware or software? only volume knows
<OriansJ`>ericonr: possibly you were thinking of the AVR32 https://en.wikipedia.org/wiki/AVR32 which at first glimps looks ok but up close is a garbage fire of a design?
<ericonr>OriansJ`: I only knew PIC32 existed and thought it'd be similar to other PICs
<ericonr>I had heard of AVR32 as well, never looked into them
<xentrac>I think AVR32 is a similar scam to the PIC32
<xentrac>hmm, apparently not: https://github.com/torvalds/linux/commit/26202873bb51fafdaa51be3e8de7aab9beb49f70
<ericonr>xentrac: this is the only good linux on avr project: https://dmitry.gr/index.php?r=05.Projects&proj=07.%20Linux%20on%208bit
<xentrac>haha, yeah, that was awesome
<xentrac>I was thinking it would be fun to do something like that with those 3-cent Padauk microcontrollers
<xentrac>maybe with a piezo beeper audio output and capacitive touch sensing input or something
<OriansJ`>personally I hoped that someone would just steal DEC PRISM's integer instruction set as it was a surprisingly clean design (Alpha tooks out the limited byte instructions)
<OriansJ`>it actualy got division half right
***OriansJ` is now known as OriansJ
<xentrac>what was nice about its division?
<OriansJ>it returned exactly the bottom 32bits of the true division result in a specified register
<OriansJ>it also had mult and mulh to get the top and bottom 32bits of a multiply as well
<xentrac>why did you like that especially?
<xentrac>maybe I don't understand how that's different from what IDIV does. except that IDIV returns the remainder too
<OriansJ>xentrac: you get to specify where you want the output and there are no implicit registers
<xentrac>OriansJ: oh, I see
<mihi>fossy, re gigatron.io: I'm pretty sure OriansJ will not like the instruction set (does not have add/sub with carry, no mul/div, not even right shift...)