IRC channel logs

2020-08-24.log

back to list of logs

<dannym>janneke: Wasn't at gitlab yet, no
<dannym>janneke: Good night :)
<janneke>dannym: https://gitlab.com/janneke/tinycc/-/tree/mes-0.23
<janneke>good night! (really!)
<dannym>janneke: Tried current mes-wip on ARM--all tests except two still pass. The two are the ones with unsigned "char". (7r-sign-extend, 7l-struct-any-size-array-simple)
<dannym>janneke: That's because the fix from master has not been merged yet
<dannym>janneke: Should I merge the fix from mes-master?
<janneke>dannym: yes, sure
<dannym>Rebase?
<dannym>Or on top?
<janneke>rebase and reset is fine
<janneke>ah, on top will probably also do -- it will reorder after updating master again
<janneke>i'm a great fan of keeping history linear
<dannym>janneke: It will? With git merge? It detects the merge commit?
<janneke>dannym: i never merge, just rebase
<dannym>Ok I'll rebase then
<janneke>if order is important, then reorder
<janneke>yeah, thanks
<dannym>rebased
<dannym>push: remote rejected
<janneke>i'm using git bisect heavily -- and we're small enogh not to merge, i think
<dannym>push -f: remote rejected
<janneke>yeah, to push to savannah you have to remove it first; push :wip
<janneke>(that's another reason why i push most wip stuff to gitlab first)
<dannym>Uhh
<dannym>Yeah, that sucks
<dannym>I thought it was a guix thing, but all of savannah does that? Weird...
<dannym>So I'll do "git push --delete origin wip" and then "git push" ?
<janneke>oh, i haven't really looked into that or asked -- possibly it could be changed?
<janneke>possibly; i alway do: git push origin :wip; git push origin wip
*janneke looks-up --delete
<janneke>ah right
<dannym>janneke: Well, github has no problem with rewriting history. I guess if you want to have a permanent record of commits to master, it's good to disable it I guess. But doing so for feature branches is ridiculous
<janneke>All listed refs are deleted from the remote repository. This is the same as prefixing all refs with a colon.
<dannym>Ok, pushed to wip
<janneke>thanks!
<janneke>dannym: well, yeah but otoh using a shared repo you have to be a bit careful with --delete ;)
<janneke>dannym: i tried "guix pull" on banana but ended up stealing your latest pull by copying guix current symlinks
<janneke>qemu segfaults and well, could be anything
<bauen1>OriansJ`: would https://github.com/bauen1/mescc-tools-seed/commit/ff04d45cd7f49241c6249870a8200768d99017ac also be of interest ?
<bauen1>one one side it reduces the amount of hand counting necessary by removing jump instructions
<bauen1>but probably increases complexity a bit
<bauen1>if you're interested, i'll take care of applying the change to the M1 and hex0 version
<bauen1>actually no, cmp is a signed compare ...
<bauen1>fixed: https://github.com/bauen1/mescc-tools-seed/commit/26883fbe58fa3b473176a7e5c9e0255e8026f9d2
***terpri__ is now known as terpri
***stikonas_ is now known as stikonas
***terpri__ is now known as terpri
<janneke>dannym_: well, i found why the arm-unknown-linux-gnueabihf-gcc -built tcc, i.e. ./arm-unknown-linux-gnueabihf-tcc segfaults in crt1.c; it needs -marm
<janneke>pushed a squash commit to tinycc
***awilfox_ is now known as awilfox
<OriansJ`>bauen1: reasonable modification but a little tip to remove another jmp and save some more bytes https://github.com/oriansj/stage0/blob/master/stage1/stage1_assembler-1.s#L181