IRC channel logs

2020-05-06.log

back to list of logs

<markjenkinsznc>OriansJ, https://github.com/markjenkins/stage0/tree/disasm_py-wip is sort of at a point now where one might consider it ready to merge, though I'm planning to do a bit more before I PR
<markjenkinsznc>Commits today and yesterday now have this integrated successfully with Knight.py / User_Interface.py
<markjenkinsznc>three noticeable differences from disasm.c: 1) sections that are not recognizable as code or string are not longer IMPROPER_NOP but displayed as data in single quotes '' which can be re-assembled
<markjenkinsznc>those data lines just have #DATA as a comment because the line itself shows the hex
<markjenkinsznc>2) there's priority for disassembling as instruction vs string which is typical default for a disassembler. I think some of the short strings in roms/forth fall victim
<markjenkinsznc>I did bodge away the common case of four bytes of 0x00 mapping aggressively to NOP to allow some strings with a lot of null padding to still be disassembled as string
<markjenkinsznc>hmmm, turns out I didn't have a third compatibility point, but two other notes
<markjenkinsznc>there's a makefile test suite included which shows all roms being successfully disassembled and re-assembled back
<markjenkinsznc>but I've observed some failure cases outside the test suite, a full fuzz test suite is called for before I PR
<markjenkinsznc>closing note b) once we start assembling strings to 1 null pad and leaving instructions on any boundary and dissassembling with --string-null-pad-align 1 it's going to be a problem for Knight.py/User_Interface.py's 0-9-A-F address columns interface because that won't align right for every line any more
<markjenkinsznc>once I do PR, I'm thinking of consolidating my commits to one and having the subsequent history of features come post-merge with pretty much where we are now as a 1 commit starting point
<plasma41>oriansj: http://bootstrappable.org/projects/mes.html lists refers to Stage0 beginning with a 280 byte binary. I had previously read elsewhere that the initial binary was 357 bytes. Has the binary been reduced in sized or am I misremembering the 357 number.
<plasma41>s/lists refers/refers/
<plasma41>s/I had/I thought I had/
<plasma41>s/sized/size/
<plasma41>I clearly can't type properly today.
<OriansJ>markjenkinsznc: sounds great, keep up the good work
<OriansJ>plasma41: there are multiple hex0 bootstrap seeds and they do have different sizes. For example the bios hex0 seed has to be 512bytes in size.
***deesix_ is now known as deesix
***ChanServ sets mode: +o rekado_
***rekado_ is now known as rekado