IRC channel logs

2020-05-04.log

back to list of logs

<janneke>OriansJ: no! ... wow
<fossy>OriansJ: this is exciting, is this a M3-? piece?
<OriansJ>janneke: ?
<janneke>=> "<OriansJ> I am writing a linker to enable a much more powerful assembler ..."
<OriansJ>fossy: yes, right now I am writing the logic to read the various ELF bits required by the linker and then I'll write the bits to write out the final ELF binary. Then I'll do multiple ports with it. Then I'll work on the assembler
<janneke>i admire[d] hex2 and M1 for their simplicity, wondering where this goes
<janneke>sounds exciting
<OriansJ>janneke: this goes to making MesCC and M3-Star able to use The Gnu Assembler in development and only the M3 assembler and linker when bootstrapping
<OriansJ>It'll also allow us to target aarch64, RISC-V and SPARC-V effectively (as they don't have 8, 16 or 32bit immediates)
<OriansJ>plus it'll make seperate segments possible and various other elf features available to us for the first time as hex2 is quite limited in terms of expressing displacemenets
<OriansJ>and assuming MesCC expands to be able to build binutils directly. It then would be able to use binutils directly for the rest of the bootstrap
<janneke>yeah, terriffic!
<OriansJ>hopefully you are ok with my proposed change of plan for MesCC
<OriansJ>as any feature in the gnu assembler you end up using, I'll have to end up implementing
<OriansJ>and getting MesCC building binutils will be a great half-point mark for getting MesCC tools able to build GCC directly.
<janneke>you have been doing some pretty crazy things before; go for it!
<OriansJ>who knows maybe someone will solve writing a C preprocessor in M2-Planet for me before I get to it. Assuming they do minor tweaks in their output M3-Star's Toeknizer could just be only concerned about whitespace.
<OriansJ>one could argue everything I have done in bootstrapping to this point is an example of bats in the belfry wackjob insanity.
<OriansJ>What sort of reasonaable person says: hey I am going to bootstrap GCC after wiring up some transistors on a long dead architecture; right after I hand toggle in some bytes to have a hex monitor and write not 1 but more than a dozen C compilers in assembly; because you know a cross-platform C compiler in assembly is fun to write????
<OriansJ>Now I
<janneke>hehe
<OriansJ>am going to be injesting hundreds of pages of ELF specifications and architecture specific elf sections to implment something to be used exactly once.
<OriansJ>Then I am to write a FULL at&t assembler in C, for not just one architecture but ALL of them
<OriansJ>Then go, hey I clearly like pain and write a full C parser by hand with backtracing to implement a full C macro preprocessor that preserves whitespacing to ensure effectively error codes in the C compiler I am going to wring out of TCC
<OriansJ>Only to have to get back to mes-m2 and have to figure out how to do syntax-case macros in C
<OriansJ>Oh and I have to help bauen1 get a POSIX bootstrapped from nothing to solve the Linux bootstrap problem too
<OriansJ>THen I can write a book called "Evidence of my insanity: a bootstrapping journey worthy of Cthulhu level madness"
<OriansJ>Then like Lennart Poettering, I can spend the next 20 years listening to people tear me a new asshole; because of all the obvious mistakes I made along the way. Along with the people claiming I work for the CIA/NSA/SHiT and this is all an elaborate way to rootkit Linux.
<janneke>Sounds like a plan :)
<OriansJ>^_^ I am glad we are on the same page
<janneke>"there was this other person who also said it was a good idea"
<OriansJ>Yeah, didn't he once plan on writing a scheme interpreter in hex?
<OriansJ>not assembly but like pure hex after seeing a hex assembler written in hex once.
<OriansJ>Only to get blind sided by the crazy guy who wrote that hex assembler after he saw the talk
<OriansJ>who actually wrote a garbage collecting, compacting lisp in assembly and a FORTH and jumped through all of the suggestions until finally saying "fuck it. how bad can it be to write a C compiler in assembly?"
<janneke>this cwazee person, like
<janneke>perfectly sensible engineering
<OriansJ>well he certainly had alot of inspiring help, from a scheme programmer who actually got the Guix bootstrap to shrink repeatedly.