IRC channel logs

2020-03-07.log

back to list of logs

<fossy>Keep sending critisims of the code my way if you have more :)
<OriansJ>odds are if you need to put prepend_string or postpend_string in a loop, there is probably a more efficient way of doing it by just having index variables and walking the strings
<OriansJ>I would recommend breaking the variable functions into a seperate .c file and creating a .h which only has the struct definition and a few commonly shared functions' prototype
<fossy>I was thinking about that, splitting into multiple files
<fossy>I think its a good idea - ill go with it
<fossy>4. Split variable stuff out of kaem.c
<OriansJ>looking at how ->pos is being used; odds are you probably don't even need it in the struct if you just did proper local index variables and the passing of ints where appropriate
<fossy>Yeah, you are right
<fossy>After this refactor I plan to take a bit of a break from kaem, to be honest I dont enjoy working on the same piece of software every day
<OriansJ>possibly add foo=1 ./bin/bar sort of environment variables to the future TODO list
<fossy>Yep
<fossy>Not a blocker for pushing though?
<OriansJ>fossy: completely fair
<OriansJ>not a blocker at all
<OriansJ>the kaem repo is your playground
<fossy>But the multiple variable substitution is a blocker right
<OriansJ>break it to your hearts content
<fossy>I do not enjoy breaking things
<fossy>OriansJ: how do you plan to integrate kaem with mescc tools? As a submodule?
<OriansJ>fossy: yes it will become a proper submodule
<fossy>ok
<OriansJ>with updates when I feel the current kaem commit is good enough
<fossy>righto
<fossy>Take your time, but any further things to make the current commit good enough than those 4?
<OriansJ>create feature branches in kaem's repo when you want your work reviewed before squash and merge
<fossy>Quite reasonable and very normal
<OriansJ>The master branch is your responsibility to keep it clean and working on as many commits as you can
<fossy>From this refactor on, 100% of commits on master will build and past tests
<fossy>(Is my plan)
<OriansJ>fossy: I like it
<OriansJ>and yes, getting those 4 done will make me very happy
<fossy>ok.
<fossy>Once those 4 are done, would you like push, or another reivew?
<OriansJ>and then we can cascade it down into mescc-tools, mescc-tools-seed and finally stage0 if everything is nice and happy
<OriansJ>fossy: push
<fossy>OK.
<fossy>dddddd: if you have more comments I would like to hear them very soon, those "finicky details" would be good to hear
<fossy>(If you have the time)
<dddddd>sure, about EjN or the next one?
<dddddd>I can anotate EjN and send you back and/or do it with the next one (with the 4 points in place)
<fossy>EjN please.
<fossy>unless you would prefer the next.
<fossy>Up to you
<dddddd>In fine doing both. I'll do EjN now.
<dddddd>*I'm
<fossy>Thank you very much.
<dddddd>np (:
<OriansJ>keep up the good work fossy
<fossy>^-^ thank you both, my coding is getting better slowly I think
***roptat_ is now known as roptat
<fossy>dddddd: FYI I broke the builtins.
<fossy>Please ignore the return TRUE stuff, thats broken, im fixing it
<dddddd>return TRUE wrt builtins, ok... I'll skip that.
<fossy>thanks
***ChanServ sets mode: +o rekado_
<fossy>OriansJ: how do you feel the best way to pass both index_input and index_target in and out of a function is? I was thinking a struct
<rain1>hello all
<janneke>hello rain1
<OriansJ>fossy: you might not need to pass both in and out of a function.
<OriansJ>as you can simply know that index_target will be index_target+bytes_processed; which would make those sort of functions a single integer return.
<fossy>O
<fossy>OriansJ: a good point.
<fossy>OriansJ: I think I have found a M2-Planet bug
<fossy>lemme get you a minimal test case
<fossy>hm. maybe not a bug at all
<fossy>can you redeclare the same variable inside a goto, after it has been run once, in normal C?
<fossy>I don't use gotos much, but they were by far the cleanest way to add multiple variable support to kaem, only 5 extra LOC
<fossy>way more trivial than i thought :D
<fossy>wow, kaem is so much faster without postpend chat
<fossy>char