IRC channel logs

2020-01-17.log

back to list of logs

<oriansj>Hagfish: well I would probably guess keyspace enthropy would be a reasonable approximation; however if the attacker has a reasonable guess about the contents of a message, all ciphers save for the one-time pad are vulnerable
<oriansj>The half-finished M1 in scheme is up if anyone wants to run with it (as it is the last piece to finish if one wanted an entirely scheme bootstrap for guix)
<oriansj>now it is harder than ever to segfault mes-m2 (I've started fuzzing)
<oriansj>not that malicious inputs are a concern for mes-m2 but rather so that users never see hangs or segfaults
<oriansj>are (and ...) expressions in scheme supposed to short circuit?
<oriansj>because I am trying to understand why guile has no issue with EOF and string-index in slow-utils/M1.scm but mes-m2 instantly throws an error on it
<oriansj>export MES_PREFIX=../mes-m2; ../mes-m2/bin/mes-m2 -e main -s M1.scm -f foo
<Hagfish>fuzzing? that's so cool
<oriansj>Hagfish: essentially I found a half-dozen ways to sefault mes-m2 and fixed them all; the aim is by the weekend to get all ways a user can crash or hang mes-m2 fixed
<oriansj>I can use MES_MAX_TOKEN and MES_MAX_STRING to really reduce the search space a good bit
<Hagfish>yeah, smart
<Hagfish>i'm wondering when/if the work you (and others) have been doing would count as evidence towards something like this:
<Hagfish> https://awards.acm.org/acm-prize/nominations
<Hagfish>it looks like we missed the 2020 deadline, but there's always next year ;)
<oriansj>well, yes actually Hagfish
<Hagfish>i hope that at least some academic institutions pick up quickly on how fundamental your work is, and offer to co-author papers with you, or invite you to give talks, or maybe even write a syllabus around it
<oriansj>we even would qualify for: https://amturing.acm.org/ but it is unlikely for us to win
<Hagfish>yeah, i think that's the other award i was thinking of
<oriansj>Honestly, the results when we finally succeed are all I need.
<oriansj>I've already picked up the distinction of being the second person to ever write a C compiler in assembly; which is also the first C compiler written in assembly that works on a POSIX (BDS-C only works on CPM)
<oriansj>I'm also the only person to have written a C compiler which runs on bare metal
<Hagfish>those are huge achievements, but each additional achievement in this space has a multiplicative effect, and the whole is then more than the product of its parts
<oriansj>Hagfish: very true; when combined with janneke's work in MesCC and Gash, Matt's nyacc and the guix work. We will collectively change the world of trust in software forever
<Hagfish>it's almost maddening that so many key pieces of technology have been left unwritten all this time, but on the other hand i suppose that the scale of the problem has been too daunting for others to attempt
<oriansj>but janneke and I just said fuckit and we are nearly done
<Hagfish>that's nothing as motivating as someone saying that something is impossible :)
<Hagfish>*there's
<oriansj>or finding someone else on the same path; that you can share the journey with
<Hagfish>yeah, having this community grow has been really encouraging
<Hagfish>i'm glad i got in as early as i did
<oriansj>well some have come and left; we only hope those that stay find some joy in our creations
<Hagfish>the freedom to leave is the ultimate test of how good the community (and exciting the goal) is
<oriansj>exactly
<fossy>and im sad i didnt find out earier
<fossy>but at least I can still make contributions!!
***CORDIC is now known as DKordic
<janneke>oriansj: hehe, that sums it up pretty well
<janneke>although now that we're nearly done, it all just starts...
<oriansj>fossy: you are here now and that is all that matters
<oriansj>janneke: the next cycle of the wheel of reincarnation; for we are but only nearing the end of the scheme only bootstrap of Guix. Then we have to complete mes-m2 and alot of work to finish the hex0->everything bootstrap; then we have the bootstrap a posix from nothing and then bootstrap hardware itself from nothing.
<dddddd>Hi, booters
<oriansj>It would be fun to see 500nm glass lithography used to implement a 486 and/or knight;
<oriansj>morning dddddd
<oriansj>although it would probably be easier to get a RISC-V chip on glass lithography
***ng0_ is now known as ng0
***ng0_ is now known as ng0
<oriansj>well; that is officially the dumbest mistake I ever made in mes-m2
<oriansj>I mistook i = i + i; for i = i + 1;
<oriansj>perhaps I need a better emacs font or perhaps bigger characters
<oriansj>hmmm, I feel that something is happening to passed file pointers in mes-m2
<oriansj>hey dongcarl
<oriansj>how goes the bitcoin guix build conversion?