IRC channel logs

2019-12-21.log

back to list of logs

<fosslinux>oriansj: why does m2-planet exhibit such weird behavior for multiplication?
<fosslinux>eg
<fosslinux>int main () { return 100 * 10; }
<fosslinux>returns 16
<fosslinux>????
<fosslinux>oriansj: oh wait, its because the return code seems to overflow at 255
<fosslinux>probably my shell
<oriansj>xentrac: well honestly, I think I finally figured out why it is so rare for any scheme to have more than one author.
<oriansj>fosslinux: yes your shell truncates error codes per the posix spec. if you do file_print(numberate_number(100*10)); you'll see the correct result. if you use gdb to si the binary generated, you'll see the correct result in the register as well.
<oriansj>I was thinking about the Gigatron CPU and how they implemented a 8bit Harvard Architecture CPU but effectively made it behave like a 16bit Von Neuman Architecture design; I don't think they realize they rediscovered Vertical microcode