IRC channel logs

2019-12-19.log

back to list of logs

<oriansj>fosslinux: did that solve your segfault problem?
<fosslinux>oriansj: im looking at it rn
<fosslinux>havent had a chance yet
<oriansj>fosslinux: well you can always throw code my way if you need help reasoning about how M2-Planet interacts with it
<fosslinux>yep
<fosslinux>i'll throw something in the next half hour or so
<fosslinux>oriansj: ok i have something for you
<fosslinux>it was my erroneous code
<fosslinux>struct MyStruct
<fosslinux>{
<fosslinux> char *array[UNDEF_CONSTANT];
<fosslinux>}
<fosslinux>if you have a random string that is undefined, ie an undefined constant or variable here, that seems to be passed directly to the build_member function which dies
<fosslinux>it kinda makes sense that it segfaults
<fosslinux>but a error message would be good
<oriansj>fosslinux: that would be struct type* build_member(struct type* last, int offset) in cc_types.c
<fosslinux>yeah I found that
<oriansj>and it does have require_match("Struct only supports [num] form\n", "]");
<fosslinux>yes, but that is not triggered
<oriansj>because it attempts to numerate something that isn't a number and it returns zero as the size
<fosslinux>ohhh, I see
<fosslinux>so there's not really a fix
<fosslinux>?
<oriansj>fosslinux: well there is a way to catch that
<oriansj>simply check if i->size == 0 after the assignment and throw an error
<oriansj>easy to fix, I'll have a patch up in one minute
<fosslinux>oh right
<fosslinux>I get it now
<fosslinux>thanks
<oriansj>patch is up
<oriansj>thank you fosslinux for helping me improve M2-Planet ^_^
<fosslinux>oriansj: haha, no problem
<oriansj>fosslinux: also do you like the new REPL behavior in mes-m2?
*fosslinux takes a look
<fosslinux>oh you merged slow_lisp into master?
<fosslinux>oh yes this is much nicer
<fosslinux>oh yay a boot-0.scm
<fosslinux>yes this is so good
<oriansj>fosslinux: I am glad you like it ^_^
***ng0_ is now known as ng0
<`Lion>rain1: this might be one for your archive? https://www.simplethread.com/software-complexity-killing-us/
<real-grue>Do you collect such articles about simpler software/KISS/etc?
<`Lion>not really, but occasionally i search around hoping to find something at least mildly interesting and unusual
<`Lion>but there's a wiki collecting links to articles like that, https://softwarecrisis.miraheze.org/
<`Lion>that i believe rain1 maintains
<real-grue>Here is a good one: https://cr.yp.to/bib/1995/wirth.pdf
<`Lion>ah, good old 1995 :)
<real-grue>Also, from TRIZ: "it is said that we have obtained an ideal system which then has no more existence as a system, but its useful function remains assured. This result is referred to by G. Altshuller: Ideal Final Result".
<rain1>thanks `Lion
<oriansj>found something people here might find interesting: https://www.youtube.com/watch?v=k1hJoalcK68 http://relaysbc.sourceforge.net/