IRC channel logs

2019-12-02.log

back to list of logs

<stikonas>hmm, I think I found a shorter Java bootstrap than Guix uses. Although, I'm not sure if it's worth changing how guix does it, it works after all. I've just managed to get icedtea 7 compiled directly, skipping icedtea 6
<xentrac>congratulations! that sounds pretty worthwhile to me
<xentrac>I mean it means that we can eliminate icedtea 6 from the tcb
<stikonas>xentrac: we'll see... In the end it might not be any quicker... For some reason I was only able to build icedtea-7 with jamvm as VM, and that one failed to build icedtea-8 (but maybe some unrelated issue). Trying to build icedtea-7 with hotspot now from icedtea-7 (jamvm)
<stikonas>and building ecj-4.2.1 with ecj-3.2 was a bit unpleasant, had to patch out some @Overrides. I'm not sure why guix is not hitting this issue...
<xentrac>because the base class didn't have the method being @overridden?
<stikonas>yes, I think old versions of ecj use @Override behaviour from java 1.5
<stikonas>and I think it was changed how it behaves in Java 1.6
<xentrac>oh?
<xentrac>how so?
<stikonas>not too sure, I don't really know Java...
<stikonas>I do know a bit of Groovy but not Java :D
<stikonas>hmm, looks like this issue https://stackoverflow.com/questions/3619036/override-annotation-in-jdk-1-6
<stikonas>well, but early in bootstrap we don't have Java 1.6 available yet...
<xentrac>ah, in Java 1.5 @Override wasn't kosher for implementations of interface methods
<stikonas>yeah, so when I was trying to build icedtea-6 on Gentoo, I was hitting this issue even more
<stikonas>that's why I decided to instead compile ecj-4.2 and then go to icedtea-7
<stikonas>so I don't understand how it worked for guix... which builds icedtea with ecj-3.2...
<xentrac>perhaps if we're patching things in the bootstrap chain to get it to compile, the easiest thing in this case would be to patch @Override to be a no-op
<xentrac>I mean, its only effect is to cause compile errors, right? which is useful when you're developing things but not when you're compiling things someone else wrote
<stikonas>or perhaps some command line options in wrappers are different...
<stikonas>yeah, I think it's just compile time check...
<rekado_>stikonas: I’d be happy to cut out icedtea-6 if it isn’t needed.
<rekado_>I tried splitting up the big icedtea-6 into several independent packages earlier, but then ran out of time.
<rekado_>the goal would have been to only build as little of icedtea-6 as needed to move on to icedtea-7 or later.
<rekado_>is there a reason why you do this on Gentoo and not in Guix which has stronger guarantees about the composition of the build environment?
<stikonas>rekado_: well, it can probably be avoided, but probably more testing is needed
<stikonas>first of all, testing on guix...
<stikonas>at the moment I was testing on Gentoo
<stikonas>I'll see if I can clean up some stuff... but it won't be in the next few days
***ChanServ sets mode: +o rekado_
***xwvvvvwx- is now known as xwvvvvwx