IRC channel logs

2019-11-07.log

back to list of logs

<Hagfish>lol, that "proprietary ..." rant is good enough for a stand-up comedy routine
<oriansj>Hagfish: thank you; all real examples from Fortune 50 companies
<oriansj>janneke: what is weird is how everything passes until define in test008 with this little diff: https://paste.debian.net/1114886/
<oriansj>I am starting to wonder if I should just hijack guile's test suite and simply start getting the tests to pass one by one
<oriansj>well it doesn't look like they have any tests that work in total isolation
<janneke>oriansj: hehe, yes that diff makes symbols no longer unique
<janneke>that is probably what's going on
<janneke>oriansj: yeah, running parts of guile's test suite would be great but that's still quite a big step
<oriansj>janneke: we will need to make tests for every primitive in mes-m2; otherwise I'll just end up breaking more and more things as I go along trying to make mes-m2 pretty
<janneke>oriansj: yes, the stage of testing C primitives is non-existent; that's not helping
<janneke>for the number cells->pointer cells transition in the mes-m2 merge, i wrote some gc inspection code -- not good enough for a real test but it helped me to find bugs
<janneke>oriansj: i found a bug in the mescc-tools-seed build of M1 (and it seems only one); have it isolated, now bisecting the c input further
<janneke>these ascii intermediate stages are so friendly, really great
<xentrac>:)
<xentrac>I think the "internal data is readable" aspect of both Unix and Lisp is a real productivity enhancer
<xentrac>I mean the equivalent of cat /etc/passwd on VMS is a giant hairball
<xentrac>(and also VMS++ of course)
<janneke>oriansj: https://paste.debian.net/1115054/
<janneke>oriansj: actually, the bug report can be much smaller, inlined here:
<janneke>DEFINE LOAD_IMMEDIATE_eax B8
<janneke>LOAD_IMMEDIATE_eax %0x2d
<janneke>LOAD_IMMEDIATE_eax %0x11223344
<janneke>the M1 from mescc-tools-seed: /gnu/store/c48hji88xgi99p0yjf7b0nmnn5zbwz61-m2-planet-boot0-1.4.0-0.1fc2aea/bin/M1 --architecture x86 -f bug.M1 gives:
<janneke>B8 00000000
<janneke>B8 11223344
<janneke>the first instruction should be `B8 0000002D' i.e. the 2d is dropped
<xentrac>\o/
<pder>janneke: it appears that if you change the that line to LOAD_IMMEDIATE_eax %0x2D (note the upper case D), M1 returns the correct results
<pder>The difference in behavior with the bootstrapped M1 and the gcc compiled version is also due to the fact that they both use functions/numerate_number.c but the version of that file in mescc-tools is different from the one in M2-Planet
<Hagfish>great deduction work! these puzzles are beyond me, but i love reading the discovery of their solutions
<janneke>yeah, and a fix is up @ https://gitlab.com/janneke/m2-planet