IRC channel logs

2019-11-06.log

back to list of logs

<tazjin>interesting and somewhat related: https://opensource.googleblog.com/2019/11/opentitan-open-sourcing-transparent.html
<oriansj>janneke: why does init_symbol consume 41 cells?
<oriansj>tazjin: achieves nothing more than what you could get with coreboot+grub+write protect screw for bios
<stikonas>yeah, some parts of that graph they have in that article are still marked as proprietary...
<oriansj>because physical access ==> game over (Anyone can replace chips)
<stikonas>so kind of hard to trust...
<oriansj>probably a short way of saying "wildly unsecure shit here"
<oriansj>because everytime a vendor has said the words "proprietary ..." and we did everything required to get the details; it is always ends up being "horrible crap that doesn't work"
<oriansj>"proprietary encryption" => 32bit DES
<oriansj>"proprietary fraud detection" => randomly select individuals
<oriansj>"proprietary binary hardening" => we turned on a couple compiler flags to drop ELF data
<oriansj>"proprietary recycling method" => we throw that shit in the trash
<oriansj>"proprietary document destruction" => we just put them in a cargo container and ship them to China and then we don't care what happens to it
<oriansj>I really wish that last one was a joke
<oriansj>but it really is not
<janneke>oriansj: init_symbol should only consume 1 + <length of symbol-name>/cell-size cells
<oriansj>well I will be pushing a commit that makes it easier to walk vectors and structs in gdb and when you walk it; it is a mess
<janneke>great! another list of things to clean up :)
<oriansj>patch is up
<oriansj>well I did promise to make mes.c clean enough to be put into textbooks
<oriansj>now vector->list simply becomes changing TREF->TPAIR and list->vector simply becomes changing TPAIR->TREF
<oriansj>I probably broke structs hard doing this but I don't have good tests for structs to avoid breaking it
<janneke>:) :) :)
<oriansj>now we can really simplify the symbol initalization and make symbol lookup much faster