IRC channel logs

2019-09-13.log

back to list of logs

<Hagfish>*bootstrapping intensifies*
<OriansJ>Hagfish: with the goal of letting others contribute in parallel to reduce the load on individual developers. (that way we don't burn out janneke or anyone else here)
<Hagfish>yeah, actually managing the intensity is the hard part
<Hagfish>in a "do-ocracy", it's hard to hold someone back if they have the enthusiasm and the skills, and get really attached to solving a certain problem
<OriansJ>Hagfish: plus everything is now in a state where what was once laughed at as impossible is really close to done
<Hagfish>are there questions about which path is the best to take, or just questions about how hard each step is?
<OriansJ>Hagfish: well, in the end; we now know that writing a simple C compiler is easier than writing a proper lisp
<OriansJ>So, the question is there a best path; I think is answered by saying writing a C compiler in assembler got to the goal faster than anything else
<OriansJ>(Mind you this is coming from a guy who write a classic garbage collected Lisp in Assembly first)
<OriansJ>If we had more assembly programmers and a better base lisp; the answer could easily been quite different
<Hagfish>hmm
<Hagfish>i guess people are welcome to try different designs later, if they want to scratch that itch, and after this first path has shown what's possible
<Hagfish>hopefully showing the proof of possibility will attract more people than the idea itself did
<OriansJ>cc_x86.s being 4395 lines of highly isolated assembly functions and lisp.s being 3414 lines of highly integrated assembly functions.
<OriansJ>indeed
<OriansJ>I hope someone someday comes along and does the entire bootstrap better than I could have ever dreamed
<OriansJ>I just hoped to provie that it was possible and didn't require magic or anything complicated to achieve
<OriansJ>M2-Planet was designed to be understood in less than 30minutes as it is a trivial state machine
<Hagfish>wow, yeah, that's something that someone could think through in their lunch break
<Hagfish>i do think it would be a pity if some later iteration of the bootstrapping project ended up taking all the credit away from the work you've all done already
<Hagfish>like poor old Stallman, telling people to call it "GNU/Linux"
<OriansJ>Hagfish: I expect to be forgotten
<Hagfish>i expect people to write epic poems about you
<Hagfish>the heroes who saved computing
<OriansJ>I never wanted to be famous, only to make the world just a little bit better for everyone who cared about trust and freedom
<Hagfish>yeah, fame is a bad motivation to have, but i want a society that recognises and celebrates the work of selfless people
<Hagfish>anyway, food time
<OriansJ>Hagfish: enjoy
<OriansJ>well this is an absolute puzzle: https://paste.debian.net/1100497/ gets this: https://paste.debian.net/1100498/
<OriansJ>or me assuming guile is able handle (define foo bar) (define bar 3); in that order
<OriansJ>goal for tomorrow morning after I wake up: get hex2 in scheme working-ish
<OriansJ>*good night*
<janneke>OriansJ: that sounds just great
<janneke>the current toolset has enabled us to create a bootstrap path from mescc onwards
<janneke>the M1 and hex2 formats are really helpful and performance of mescc-tools also helps a lot
<janneke>i will be looking at removing all non-scheme tools frome the bootstrap path of mescc onwards except for mescc-tools
<janneke>so your plan is a perfect match, i think
<OriansJ>janneke: I think I can get 70-80% of the speed of mescc-tools in scheme
<OriansJ>Finished first pass of hex2 in scheme: https://paste.debian.net/1100553/ or atleast the bare minimal one required. I should be able to complete the second half tonight and when it is done, you'll be able to find it here: https://github.com/oriansj/slow-utils
<janneke>OriansJ: that's fast!
<janneke>OriansJ: you can probably use read-char (and avoid textual-ports)
<xentrac>OriansJ: your slow-utils plan sounds reasonable to me
<xentrac>congratulations!
<OriansJ>janneke: good call on the read-char; one less dependency to deal with