IRC channel logs

2024-02-23.log

back to list of logs

<imadnyc>hey, I looked at the advice someone gave me here but I still can't figure it out. i have two .scm files, both with package definitions, (say package1 and package 2). I want to pass package2 as an input to package1. I'm doing (load "package2.scm") and passing it as an input to package1, but it says that package2 is an unbound variabl
<imadnyc>how do I pass it in as input?
<cow_2001>daviid: AAAAA~! got guile-cv-0.4 to ,use (cv); (im-load "some.jpg"); => get flooded with pixels
<cow_2001>daviid: HURRAH!
<daviid>cow_2001: nice! now, if you configure guile for guile-cv, then it will only display the image size, n-chan and a few of the first channel floats ...
<cow_2001>:>
<cow_2001>now i need to write the guile-for-guile-cv package definition
<daviid>right, then also add the config proposed in the guile-cv manual to your .guile file ...
<cow_2001>oh, and i had to turn off the autocompile of scm to go, and the testing
<daviid>cow_2001: that's not expected - on debian, you just run the autogen/configure/make install danse, which compiles and installs the compiled modules ... it makes no sense to run guile-cv as interpreted code, you'll loose an order of magnitude speed factor ...
<cow_2001>yeah, guix is weird
<cow_2001>maybe it compiles those files when using it
<cow_2001>saves them into a user cache directory
<cow_2001>i don't know
<cow_2001>haven't yet tried it more than the above interactive session code
<mange>imadnyc: Are you just running (load "package2.scm") at the top-level? That won't define anything, but if package2.scm ends in the package definition then you can just use the (load "package2.scm") form as the input itself. Like: (inputs (list (load "package2.scm")))
<daviid>cow_2001: i am prety sure guix experts will get you in the right direction ... but as a guix user who has installed guile-cv, (use-modules (cv)) should not compile any of the cv modules, all should have been pre-compiled ofc ...
<imadnyc>mange: Oh, i see. I thought the load just brought it into scope. Thanks!
<imadnyc>hey, sorry to keep asking questions, but I'm getting this error when trying to build this package, and I'm not sure where to pull the dependency from. The package defintion : https://paste.debian.net/1308294/ , and the error is that it can't find 'gtk-update-icon-cache'. I always thought that this was part of gtk+ no? What am I missing?
<peanuts>"debian Pastezone" https://paste.debian.net/1308294
<imadnyc>Obviously i didn't update the description yet
<mange>Don't worry about asking questions. That's part of why we're here! That said, I don't how to answer your question. I know guix has a glib-or-gtk-build-system, which presumably does something?
<imadnyc>I tried enabling it, but nothing happens. I want to include the error too but debian paste says I'm spamming. It's in the postinstall.py of meson build, the first step of the install phase. In the nix counterpart, there's no need to modify installphase, so I'm kind of confused
<imadnyc> https://github.com/NixOS/nixpkgs/blob/f433c05d56393df721d791029402f676d262c399/pkgs/applications/terminal-emulators/blackbox-terminal/marble.nix , the comment says that gtk3 has gtk-update-icon-cache, and everywhere else on other distros like arch it also has it.
<peanuts>"nixpkgs/pkgs/applications/terminal-emulators/blackbox-terminal/marble.nix at f433c05d56393df721d791029402f676d262c399 ? NixOS/nixpkgs ? GitHub" https://github.com/NixOS/nixpkgs/blob/f433c05d56393df721d791029402f676d262c399/pkgs/applications/terminal-emulators/blackbox-terminal/marble.nix
<mange>It looks like it's in the bin output of gtk+, so you'll need to add that to your inputs.
<imadnyc>Thanks, it worked! How did you find out that it was in the bin output btw
<mange>I ran "guix build gtk+" and had a look in each of the outputs.
<imadnyc>damn, the build failed because the gtk version is too low lmao. I think I have to edit the files manually so it accepts a lower build version
<porcupirate>Guix, I'm trying to find the issue that removed mono. I want to understand why it was removed. Did it simply become too old?
<mange>Maybe this one? https://issues.guix.gnu.org/55026
<peanuts>"potential prebuilt binaries in the Mono package" https://issues.guix.gnu.org/55026
<jackhill>imadnyc: sorry, I'm late to the party, but you may want to check out and help test the gnome-team branch which has a gtk update
<podiki>anyone start seeing this on reconfigure: ;;; Failed to autoload make-zlib-output-port in (zlib):
<podiki>;;; no code for module (zlib)
<dale>In system-config.scm, is there a way to refer to the installed path of a file from a package? If I mention git in the packages list, and I am setting up nginx to use git-http-backend via fcgiwrap, how do I know the installed path of git-http-backend?
<dale>Ah, scrub that; it is under /run/current-system/profile.
<nckx>That's true, but using file-append would be much more idiomatic.
<nckx>Relying on /run/current-system/bin symlinks is an implementation detour. But it works.
<nckx>sneek: later tell dale https://logs.guix.gnu.org/guix/2024-02-23.log#090119
<sneek>Will do.
<peanuts>"IRC channel logs" https://logs.guix.gnu.org/guix/2024-02-23.log#090119
<futurile>Morning all
<nckx>Morns.
<nckx>reedm: Did you load the bcachefs module (i.e. is bcachefs in /proc/filesystems)? You shouldn't need bcachefs-tools just to mount file systems, although you might need to use 'mount -i' for reasons I don't remember. Guix bcachefs boot code just calls mount(2), after all, and even handles multi:device file systems just fine.
<sneek>Welcome back hako :D
<ayatsfer>hello, are there multiple versions of rust available? I believe current one on guix is 1.73.0 (stable) but I need +1.74.0 (also stable)
<janneke>ayatsfer: there's a 1.74.1 on the rust-team branch
<janneke>ACTION is not sure what the status of rust-team is, tho
<kotet>Today, I mistyped and entered 'guix package -d'. To my surprise, all past generations were deleted without even a confirmation prompt. Is this the intended behavior? The help message says that it should "delete generations matching PATTERN", and I think it's reasonable to think that no pattern was provided in this case, so no generation should be deleted. Besides, it seems very easy to mistype accidentally.
<kotet>Also, string->generations in ui.scm doesn't handle the empty string case. It seems more consistent with the syntax to specify generations that '..' would be the pattern to delete all former generations, and an empty string would just not be a valid pattern.
<futurile>kotet: definitely sounds like a foot-gun. Anything on issues.guix.gnu.org about this?
<kotet>Not exactly for that, I think. This is related but not the same case https://issues.guix.gnu.org/19978
<peanuts>"It's too easy to accidentally delete all generations" https://issues.guix.gnu.org/19978
<kotet>Yes, but it's not exactly the same issue. As the issue I mentioned is very simple, should I send a patch in case it's deemed helpful?
<ayatsfer>janneke: I see
<ayatsfer>maybe it is possible to change the version of the rust package instead?
<janneke>ayatsfer: i don't believe that you can skip a version in the rust bootstrap
<janneke>possibly you can add a version
<nckx>sneek later tell kotet Making -d's PATTERN mandatory (as the lack of [] already implies) certainly sounds sensible.
<sneek>Will do.
<dariqq>anyone got an idea why during "guix build -e '(@@(gnu packages commencement) glibc-mesboot)' --target=i686-linux-gnu " (getcwd) returns #f which causes everything to break? Withouth the cross compilation everything is fine.
<janneke>dariqq: dunno, but i do know that using --system=i686-linux works
<dariqq>yeah, found that out as well. but i am trying to test whether something else can be cross compiled and it fails at glibc-mesboot.
<dariqq>and it is so odd. someone mentintioned yesterday that (getcwd) should error out instead of returning #f (maybe a problem with the bootstrap guile pacakge?) . But the weird thing is that it only errors when evaluating cflags in setenv and not cppflags (which also calls getcwd) before that
<ayatsfer>is there any alternative builder to the cargo-build-system? I don't want to specify the crates in guix
<ayatsfer>for a package.scm that lives in the same repo as the source code of the rust app
<futurile>ayatsfer: no there isn't. I don't know if you can import it and use the capabilities without getting the crates. Efraim is really the expert.
<efraim>i'm not really here, about to run out again. 1.75 is available on the rust-team branch which should be merged as soon as CI says it's good. I suppose you could do something like 'guix import crate -r the-app-name' and plop into the package.scm in the package any extra crates you need, but I guess if you vendored the crates in the app then you wouldn't need to specify them.
<ayatsfer>thanks for the info check
<ayatsfer>as for rust version, I just downgraded a crate that was trying to get 1.74>
<futurile>oh using the 'guix.scm' in the project dir is a good idea, as that can pull in any package - nice idea
<futurile>should have thought of that heh
<old>hey how can I get ca-certificates?
<old>nvm got it
<jackhill>Hi Guix: any arm/pine mavens around? I'm in need of some pointers about how I might debug https://issues.guix.gnu.org/69279
<peanuts>"Can't build pine64 image on x86-64-linux host" https://issues.guix.gnu.org/69279
<graywolf>Hello, if I am getting ` no binary for interpreter `sh' found in $PATH', what package do I need to add into native-inputs to get it?
<graywolf>(during patch-shebang phase)
<civodul>graywolf: hi! you can add ‘bash-minimal’
<graywolf>civodul: aah, that works, thank you :) for some reason I though bash-minimal is added automatically :confused:
<graywolf>When exactly are timestamps for files put into /gnu/store reset? Is there up to the build system? I do see reset-gzip-timestamps phase, but no phase for reseting the files.
<graywolf>Is that left to the build system*
<graywolf>Context: I am writing a test for package using guile-build-system, and getting lot of `source file ... newer than compiled', and unsure how to tackle it.
<nckx>graywolf: Pretty sure it's done by the daemon when it interns (copies to the store) the build output. That would be after *all* Guile code has finished running. I didn't look it up, but anything else would IMO be weird.
<nckx>Meaning nothing should be reset during any part of your build.
<nckx>Maybe a missing HOME (for .cache) instead of a literal timestamp mismatch?
<graywolf>nckx: Nope, it looks like guile-build-system first produces .go files, and then copies over the .scm files.
<graywolf>IIRTSR
<graywolf>(If I Read The Source Right :D)
<nckx>Ah, 'a bug' :-p (...IIUUC).
<graywolf>nckx: Right, so 1. swapping the parts does fix this 2. it would be world rebuild right?
<graywolf>Is there a guile-team branch to sent the patch to?
<nckx>No, there's no Guile team. This would fall under the core team, and I'd put the change on core-updates if it rebuilds the world.
<nckx>But you can just submit a bug report with a patch and let others discuss that part, you needn't care.
<graywolf>Ok, will do that. Thanks.
<nckx>Thanks for debugging!
<flypaper-ultimat>jackhill: h
<flypaper-ultimat>jackhill: yeah, i goot a fix
<flypaper-ultimat>jackhill: lemme put it in a pastebin
<flypaper-ultimat>jackhill: https://paste.debian.net/1308373/
<peanuts>"debian Pastezone" https://paste.debian.net/1308373
<graywolf>My patch is at "Investigate" QA status, however I am not sure how `while setting up the build environment: a `powerpc-linux' is required to build `/gnu/store/7i88inc8vb3rsxvky020sc8vbzr5bnj2-guile-bootstrap-2.0.drv', but I am a `x86_64-linux'' is my fault :/
<graywolf>How do I resolves this error?
<graywolf>Patch in question: https://issues.guix.gnu.org/69276
<peanuts>"[PATCH] gnu: libtorrent-rasterbar: Update to 2.0.10." https://issues.guix.gnu.org/69276
<graywolf>(the ^ looks like first error in the log I managed to find)
<jackhill>flypaper-ultimat: many thanks! I can confirm that works. Will you propose a patch?
<jackhill>I guess that still leaves the separate cross-compile problem
<graywolf>> Your IP address has been flagged as a source of spam and is blocked from Meetup.
<graywolf>So much for signing up for the patch review party I guess :/
<civodul>uh, would be nice to use a Mobolizon instance instead
<graywolf>ACTION was so happy he managed to identify all the fire hydrant on fifth try
<ieure>graywolf, https://retro.social/@ieure/111973569363805775
<peanuts>"cop ululation: ""To continue, please verify that you're a human"
<graywolf>ieure: That profile picture is something else
<ieure>graywolf, It's a crop of the cover of a jazz album.
<ieure>Called "Relax with my horns." But I found the mildly overbearing vibe of cropping it down to "Relax" to be really choice.
<ieure>*really fine choice
<graywolf>As someone with light coulrophobia I agree it definitely is "a choice" :D
<graywolf>ACTION is having hard time deciding if jazz clown is better or worse than normal clown...
<ieure>A true story from my actual life is that I was once asked to change my Slack avatar at work shortly after starting a new job because it was upsetting some people who didn't like clowns.
<ieure>I agree that clowns are horrible, but I'm fascinated by the horribleness.
<ulfvonbelow>a cousin of the 'bile fascination' phenomenon?
<ieure>I have no idea what that is.
<graywolf>Been there (in my case anime character). Starting new job in April, so I am a bit curious how it will go there
<graywolf>ulfvonbelow: is that the pimple popping trend?
<ieure>ulfvonbelow, Hm, I suppose so.
<ieure>I changed the work avatar to a ventriloquist dummy with a saucy expression and that was, somehow, better than the clown. alright.
<ulfvonbelow>not sure, "bile fascination" is a phrase usually used to describe an odd interest in something that the person in question finds repulsive
<graywolf>Ah, I see.
<graywolf>Was not aware
<ieure>It's more of an uncanny valley thing, I think. Medical mankins, reborn dolls, clowns, people looking sad underneath effusive masks... love all that stuff.
<ulfvonbelow>I think the pimple popping trend is more related to an interest in things labeled "satisfying to watch"
<ieure>To be clear, I merely find these things fascinating, I don't, like, have a basement full of them or something.
<graywolf>sure sure
<flypaper-ultimat>jackhill: one of these days i need to properly figure out how to submit a patch, but if you know how to do it, you can just steal it.
<flypaper-ultimat>jackhill: and submit one.
<flypaper-ultimat>jackhill: also looking at https://data.guix.gnu.org/repository/1/branch/master/package/u-boot-pine64-lts/output-history?output=out&system=x86_64-linux&target=aarch64-linux-gnu , there is a build one for --target=i686-linux-gnu on commit 73d8e5a9352304a5192b22e04ef022234488e0da , which was a month ago . The one you linked in your bugreport was for build for x86_64 which is admittedly kinda useless :P the gawk-mesboot for that commit
<flypaper-ultimat>still fails with --target=aarch64-linux-gnu.
<peanuts>"guix.git - GNU Guix and GNU Guix System" https://git.savannah.gnu.org/cgit/guix.git/commit/?id=73d8e5a9352304a5192b22e04ef022234488e0da
<flypaper-ultimat>jackhill: weird, now that i've gotten the substitutes once from the above commit, i'm no longer asked to build gawk-mesboot for aarch64-linux anymore, and i can just build it. also after a guix gc.
<flypaper-ultimat>jackhill: ah, that was that because it was only the bootloader, it tries to make gawk-mesboot for the image i think?
<podiki>lilyp: would you want a patch to update cairo for gnome-team? or should i put it on mesa-updates? (haven't made said patch yet)
<lilyp>what else is depending on it currently?
<lilyp>(i.e. on you updating cairo)
<jackhill>flypaper-ultimat: I'm happy to prepare a patch (or answer your questions about sending one). I'm less familiare with all this arm and u-boot stuff (as well as curiass)
<podiki>lilyp: i don't think i have anything in particular in mind, was going to start on libdrm, vulkan, mesa for mesa-updates and saw cairo has new version after all these years
<lilyp>cairo is downstream from vulkan, is it?
<lilyp>or mesa in general
<podiki> https://gitlab.freedesktop.org/cairo/cairo/-/blob/master/NEWS i think only dropping xml surface is noteable though they said no one uses it
<peanuts>"NEWS ? master ? cairo / cairo ? GitLab" https://gitlab.freedesktop.org/cairo/cairo/-/blob/master/NEWS
<podiki>mesa depends on cairo via wayland->graphviz->pango
<podiki>and cairo depends on libdrm
<podiki>so i figure it could fit with mesa-updates, but i guess is in the the gnome-team scope technically
<podiki>I think libdrm is the largest in terms of rebuilds between cairo, mesa, vulkan
<FJolleJagt>Hey, I'm just getting started with Guix and I'm struggling to get icedove to open links in the browser. Clicking links opens a blank tab in my default browser (chromium) rather than the actual link. xdg-open works correctly when called from the command line. Any suggestions for how to debug this?
<podiki>well cairo and libdrm nearly the same, probably all but a few packages shared in their dependents
<lilyp>tough call – I wouldn't want yet another world rebuild as we're closing off, but YMMV depending on how long you plan for mesa
<lilyp>imho doing it on mesa side gives us all the gnome benefits "for free" anyhow
<podiki>mesa time will mostly waiting for build farm. though I need to see the work to include the new nvk (improved nouveau essentially) in mesa. there's some extra dependencies and rust needed. i know this was done on someone's channel already, so i'll see if they have a patch that can be ready soon
<podiki>I'll have to send the cairo patch (once I do it) anyway for comments, so yeah, let's not further hold up gnome-team then
<podiki>i'll cc gnome-team when i get to sending it and we can see if there are other opinions
<podiki>(but i'll base the patch off of master; not that it should make a difference here)
<lilyp>yeah that's fair, but between the stall of gnome-team and emacs native-comp I really ought to finish some of my work
<podiki>i'm obviously not procrastinating real work by doing this, no not at all....
<podiki>guix appreciates the work so thank you!
<flypaper-ultimat>jackhill: great! i dont think its an arm problem though it looks more of a cross compilation / gawk-mes. gonaa catch some z's. I've been searching for whats the commit that would forces this gakw-mesboot build , and so far it seems to be between commits 42be8fa56 (2023-11-18, which asks for gawk-mesboot) and 560cb51e7b (2023-08-09 which doesnt.)
<jackhill>yeah, I just mean I'm less familar with how we manage all the different u-boot configurations
<Kabouik>I am getting a libusb issue with some Python code I execute in a Python shell in emacs. I have libusb and python-libusb1 installed from guix package manager, and libusb1 installed from pip. Any ideas?
<Kabouik>OSError: libusb-1.0.so.0: cannot open shared object file: No such file or directory
<Kabouik>I am wondering if it may be related to Guix since I didn't have that issue in a Debian VM on a Windows machine earlier today.
<flypaper-ultimat>jackhill: i might continue the binary search further tomorrow, but if i don't then you know at least where i left of. the strategy i've got is `guix time-machine -q --commit=COMMIT -- system build pine64.scm --target=aarch64-linux-gnu` and checking if it ask for gawk. (this can probably be automated somehow but w/e, time for bed) (Also not an an arm expert by any means, just happened to buy a pine recenlty because of apparently good
<flypaper-ultimat>guix support, so i had recently solved this problem)
<jackhill>flypaper-ultimat: I appreciate the pointers
<graywolf>What is the way to inherit from package and modify the phases? I cannot use the usual (modify-phases %standnard-phases)...
<civodul>graywolf: look for ‘substitute-keyword-arguments’
<graywolf>civodul: looks nice, thx
<Kabouik>I'm really blocked with this libusb issue when using Python.
<podiki>Kabouik: why libusb1 from pip? it is not in guix?
<podiki>likely something from pip won't be able to open a library because it will probably try something like a dlopen for /usr/lib/... for example
<Kabouik>I probably installed it because python-libusb1 from Guix did not solve my issue, and now I have all versions installed
<podiki>on a guix system? i would just use guix packages to simplify things
<Kabouik>The thing is my program uses some pip installed library too (Yoctopuce), there's no package for it in Guix and I'm in a hurry so I used the pip package
<podiki>you could also try guix import pypi yoctopuce -r (just has that single package, dunno if that helps)
<podiki>perhaps try setting LD_LIBRARY_PATH to be the /gnu/store/...libusb.../lib directory?
<podiki>(a hacky workaround, but likely if you just use pip it won't find guix libraries otherwise)
<Kabouik>Weirdly I can't even uninstall the pip libusb1 now, it complains about something read-only in the gnu store. I'm even surprised it's aware of the gnus tore.
<podiki>probably from a pythonpath being set? was this in a virtualenv?
<Kabouik>Nope I'm not using a virtualenv
<podiki>i think that would have been helpful to keep things separated, but probably not help your libusb issue
<podiki>on its own
<podiki>anyone have issues with backspace and the line not updating in emacs eat with a pure shell? do i need to set TERM or some terminfo?
<Kabouik>Yeah, I am trying to uninstall the pip libraries now but am surprised that they are even installed in the /gnu/store, it's not clear to me why.
<Kabouik>However the thing that I need to solve in a hurry is the libusb issue, so if you believe separating things wouldn't help on that front, I may postpone it
<podiki>they are not installed into /gnu/store (root only can write there). probably it is confused and seeing the guix python libraries via env
<podiki>well unfortunately looks like a bit of a mess right now, so i would try to reset as it is unclear what python libraries are being used
<Kabouik>That would explain why it cannot uninstall them
<podiki>do we generally set a buildtype? e.g. to "release" (for meson build system). updating cairo and seems to default to "debugoptimized"
<Kingsy>any stumpwm users in here? how come the guix package doesnt get shipped with the contribs?
<podiki>i do use stump (well did, trying out hyprland currently)
<podiki>contribs are packaged separately, individually i believe
<podiki>i was just using a local git checkout of the upstream repo with my own addition as well
<Kingsy>I don't see them in guix search, what is the package called?
<Kingsy>podiki: basically I want to try and use a generic config across guix and debian, so I don't want to start adding a module-dir and stuff, things that are guix only
<podiki>well you can use a module dir for both guix and debian, both to a local checkout for instance (that's what i did, same dotfiles on arch and guix)
<podiki>but just search for the particular module you want; not all are packaged i think
<podiki>eg sbcl-stumpwm-swm-gaps is one
<Kingsy>ahh yeah I see them thanks. hmm perhaps I might try hyprland, I absolutely hate that I need a display manager its doing my head in, at least if I use hyprland I can use greetd. what it like so far for you? is it tiling?
<podiki>it is tiling
<podiki>note we dont have it packaged but there is a channel with it. once i get mesa-updates in i think we can add it (newer libdrm)
<podiki>but auto tiling. i like the eye candy potential but of course miss lisp :(
<podiki>i guess you can manually tile too? haven't learned the details yet
<Kingsy>got you. yeah tbh I don't think I can leave stump behind. been using it for a while and I like it. I'll just have to put upwith a really ugly display manager. do you know if you can change the theme for slim?
<podiki>i haven't tried. honestly i only ever see the displaymanger once a few weeks when i reboot. but yeah, in the past did prefer just startx. presumably that could be done here but maybe needs some things to be decoupled to more easily drop displaymanagers
<Kingsy>podiki: yeah I looked into that for a while, I did get xinit worknig, and it did load stump. but all the fonts and stuff were all messed up, as soon as you load in slim everything looked good.
<Kingsy>to be honest I hvae been doing setup on guix for days and I just want to start using it! :D
<podiki>probably how it loads the env to run X, would guess you'd have to add some stuff
<podiki>but what's the fun in that! :)
<podiki>i would get the base level you need to be able to do stuff and then tweak. i say this as one that loves to endlessly tweak and improve (or "improve") things
<marcc>Heya, are there any LSPs out there for Guile?
<marcc>I use Kakoune instead of Emacs, but I'd love editor feedback while coding
<Kingsy>podiki: yaeh thats where I want to be, my main problem is xfce4-terminal isnt saving its settings.. ever seen this before?
<podiki>i haven't used that terminal, but i guess i would look where it tries to save. maybe it relies on some env variable that isn't set. i would hope it just uses XDG standards, but maybe it is trying to write where it can't (like where the bin is located, in /gnu/store) which would be a bug on our end to fix
<Kingsy>podiki: one final thing, what is the default module dir for stump do you know?
<podiki>i don't know off hand. i've always set it manually
<Kingsy>no worries. thanks!
<lilyp>marcc: https://issues.guix.gnu.org/60286
<peanuts>"[PATCHES] Add guile's implementation for scheme-lsp-server" https://issues.guix.gnu.org/60286
<Kingsy>podiki: what terminal emulator do you use? jus curious
<podiki>Kingsy: termite for a long time, then that was dropped (but i think a live fork exists), then kitty, then i tried to update it and couldn't so tried alacritty, and now trying foot (for wayland)
<Kingsy>thanks. was just curious
<podiki>lilyp: do you know how cairo's docs were built? now it wants gtk-doc but that depends on cairo itself. do we have some workarounds?
<lilyp>we have a similar situation with glib. The workaround is to use cairo internally and have it be shadowed by cairo-with-documentation, which adds the doc output
<podiki>that's new on gnome-team branch?
<lilyp>that's already on master
<lilyp>(it might be that master uses the old doc infrastructure, though)
<podiki>oh you mean the glib situation, and should copy that for cairo
<podiki>?
<podiki>(since i don't see cairo-with-documentation on master, just glib, fontconfig, at-spi2-core -with-documentation)
<lilyp>Yes, I mean you should copy the pattern.
<podiki>thanks!
<podiki>somehow the previous cairo had html docs anyway, maybe it used something else when there's no gtk-doc or just used pregenerated html?
<Kingsy>podiki: have yo also noticed, that in guix, when you hover your mouse over the statusbar in stumpwm it turns into a big X, why? feels like I am missing a package to do with a mouse theme or somethng
<podiki>i never used stump's modeline. but probably you need to set the xroot cursor in general
<podiki>as in "xsetroot -cursor_name left_ptr"
<podiki>it is just showing the default for Xorg, so you need to set it. that's just stump (or other WM) in general
<Kingsy>ahh of course, jsut curious, because we don't have startx with guix, do you do this in the stump config? or is there a "guix" way?
<podiki>guix way might be with guix home? i do everything in my dot files, just started using a little of guix home for some services but haven't moved over