IRC channel logs

2024-01-28.log

back to list of logs

<gnucode>also, I am trying to build guix from source. "guix pull" is not working for me (I've already submitted a bug report about that).
<gnucode>sneek later tell nckx Do you have an XMPP account?
<sneek>Will do.
<gnucode>so I am trying to build guix from source so that I can update my guix system. (I'm running this on a T400).
<gnucode>git pull; guix shell -D guix --pure; make clean; autoreconf -fvi; ./configure; make
<gnucode>make fails with guix-cookbook.ko.texi:571 @menu reference to nonexistent node `Setup'
<gnucode>What am I doing wrong?
<gnucode>my guix source is on the master branch.
<gnucode>And the latest commit was a few hours ago.
<SquircleSpace>civodul Heh, I got the hint :) . No promises, but I am investigating. I started reading the source for git’s signing verification logic today. I guess guix’s git authenticate source is up next
<gnucode>well I'm reading the manual about how to build from source...
<gnucode>looks like I missed some things.
<gnucode>I actually just ran git clone $guix-src again...and I am currently building from that.
<csepp>quick q: where do i find these shared libraries? libstdc++.so.6 libgcc_s.so.1 (I'm trying to package Ghidra as a binary)
<samplet>csepp: They are in the lib output of GCC.
<redacted>Anybody have experience running minetest? minetestserver doesn't run in the VM I'm experimenting with
<redacted>It can't find the game "minetest"
<redacted>It works find on my foreign distro installation atop arch
<freakingpenguin>Hey all. I have a wireguard config that uses PostUp and a subcommand to fetch a key from password store, but I get `sudo: command not found` when starting the service. wg0.conf looks (mostly) like this: https://paste.debian.net/1305494/
<redacted>The hash on the directory is the same in both places, so it's the same software.
<freakingpenguin>I tried adding sudo to the system packages, but that's still a no go so presumably shepherd services are more isolated.
<redacted>Ah, nevermind! It looks like the minetest subgame path needs to be set.
<redacted>Or so I thought
<redacted>actually that's exactly the issue
<redacted>now I just need to figure out how to set environment variables for a shepherd service
<redacted>How can I get the path to a package programmatically using its name
<redacted>?*
<redacted>I think I've seen it done before, but I can't remember the invocation
<podiki>path meaning in the store? see gexps
<podiki> https://guix.gnu.org/en/manual/devel/en/html_node/G_002dExpressions.html (often #$packagename but usually preferred things like search-input-file
<podiki>see also https://guix.gnu.org/blog/2021/the-big-change/ for examples (or of course in the guix code)
<podiki>redacted: ^
<redacted>ah, cool. thanks!
<redacted>Ah, dangit. So I need to send the environment variables when the service runs, but the inputs will only be available to search at build time
<redacted>And minetest-data is unexported. hmmmm
<redacted>Typically these environment variables are set in the user's profile.
<redacted>But I'm making a service
<redacted>Looks like I can get a package's inputs with (package-inputs), but (search-input-file) takes a string apparently.
<roran>GUIIIIIIIIIIIIIIIIIIX
<podiki>redacted: search-input-file will search the package inputs for the given file
<podiki>redacted: see https://guix.gnu.org/en/manual/devel/en/html_node/Build-Utilities.html
<adanska>Hi Guix!
<efraim>o/
<adanska>o/
<efraim>finally on rust-1.73 on aarch64 on berlin
<reflog>what do i need to do to be able to compile c from the command line? i installed gcc-toolchain and run gcc myfile.c
<oriansj>reflog: gcc $source_file -o $desired_binary (not much more is required as binutils should have been installed as well)
<snape>hi, how can I grep the output of guix system?
<snape>say if I want to find out the pid of a container
<snape>(maybe there's a better way?)
<snape>seems there's some messing around with the outputs
<civodul>on the maintenance.git repo, we need to do a hard reset, but we cannot force-push nor delete the tip
<civodul>so i’ve temporarily fixed the problem on ‘master2’, which rekado created (i think?)
<civodul>and now will ask for help on #savannah to fix ‘master’
<janneke>civodul: ty!
<podiki>has anyone looked at this? (maybe the author is here?): https://fishinthecalculator.me/blog/secrets-management-with-sops-guix.html
<burley>I'm looking to get started with Guix System, but don't have a compatible wifi card among my three spare thinkpads kicking around. Is there a guide anywhere on how to set up Guix non-free?
<burley>The only thing I've found so far is a github page that's several years old and fairly sparse
<superkamiguru>Hello all, am working on trying to package something for Guix, and am running into a strange issue. During the build process I am receiving the error "undefined reference to `BZ2_bzCompress'". Looking into it, I should just need to add bzip2 to the inputs for the package, but I still receive the error. Any ideas on how I might be able to
<superkamiguru>troubleshoot this?
<civodul>maintenance.git is back to life :-)
<janneke>yay \o/
<civodul>i guess we still need to reconfigure overdrive1, right?
<janneke>that would be nice :)
<civodul>ACTION looks
<superkamiguru>is there anything I would need to add to a package definition to use gexpressions? I already added "#:use-modules (guix gexp)" but am still getting a unbound variable error for it
<apteryx>is anyone having this with the "IceCat is already running, but is not responding.", when opening URLs from Emacs (or elsewhere?)
<podiki>not currently, but seen such things when a browser has left some processes behind (needing a killall or similar)
<podiki>or maybe it didn't clean up something in /run or similar?
<ieure>Looks like issues.guix.gnu.org is down, is this known? Returns a 502.
<reflog>hello. i installed gcc-toolchain but when i try to compile a simple hello world c program i get errors like: unknown type name __gnu_va_list. any idea what im doing wrong?
<ieure>Anyone have an example of a working home-redshift-service-type? I enabled it, but it crashloops because it can't access Geoclue2. If I enable geoclue2 in my operating-system services, `system reconfigure' fails to build dbus-system-services.drv.
<ieure>These are my services: https://paste.debian.net/1305581/
<ieure>And this is the build error: https://paste.debian.net/1305582/
<ieure>Okay, hmm, looks like %desktop-services already includes geoclue, so adding a second one to the operating-system services is probably the source of the problem. But it doesn't explain why home-redshift-service-type can't talk to the one that's supposedly there.
<tex_milan>Hello, anyone using qutebrowser on sway? No troubles with: Could not find the Qt platform plugin "wayland" in "" ? I have qtwayland installed and QT_QPA_PLATFORM="wayland"
<mekeor>tex_milan: https://yhetil.org/guix/ZaWKPdl-7c_fR6gW@guix-xps/
<mekeor>this seems to be a nice URL to read the message thread: https://yhetil.org/guix/ZaW1PpKDN1DYzlRm@guix-xps/t/#mc5340f9518b46a3138550649e9083147d4ec4de1
<tex_milan>mekeor: Thanks!
<mekeor>question. how guix can i use guix to create a website that serves the texinfo-manuals of many free-software-projects? i'd appreciate any ideas.
<civodul>mekeor: one thing that might be useful is something like ‘static-web-site-service-type’: https://git.savannah.gnu.org/cgit/guix/maintenance.git/tree/hydra/modules/sysadmin/web.scm
<civodul>it’s used on Guix infra to publish the Guix manual
<mekeor>civodul: i rather wonder how i can use the info-manuals that guix-packages come with.
<apteryx>I'm trying to play the Music3.ogg file from the lugaru game; works fine in icecat, but ogg123 produces noise; any idea whyÉ
<apteryx>?
<civodul>weird, no idea
<civodul>how about mpv for instance?
<apteryx>works fine too
<civodul>janneke: overdrive1 eventually reconfigured but…
<civodul>grub-install errored out:
<civodul>“Could not delete variable: No space left on device”
<civodul>“/gnu/store/pzzri1w9rqbg45lh9v8blnr92kqdslhg-grub-efi-2.06/sbin/grub-install: error: efibootmgr failed to register the boot entry: Block device required.”
<civodul>i think that’s because the EFI NVRAM is kinda dead on that machine
<ieure>civodul, Guessing your EFI variable storage is full.
<civodul>not sure
<civodul>lemme check
<civodul>nope efivarfs and /boot/efi are fine
<civodul>efibootmgr show just 4 entries
<civodul>i’ve had problems several times already with that machine’s BIOS
<civodul>it’s ok but it won’t reboot next time without manual intervention…
<civodul>but anyway, you should be able to log in, janneke
<mekeor>i wonder if i could manipulate/clone gnu-build-system so that (1) they do not build the project but only its manuals; (2) it not only builds a .info-manual but also html-manuals.
<Zambyte>Hi, I am trying to run alsa-scarlett-gui, but I keep running into the following error: Settings schema 'org.gtk.gtk4.Settings.FileChooser' is not installed
<Zambyte>I tried running env GSETTINGS_SCHEMA_DIR=$GUIX_ENVIRONMENT/share/glib-2.0/schemas alsa-scarlett-gui inside guix shell gtk+ alsa-scarlett-gui, but getting the same issue
<Zambyte>Any recommendations?
<Zambyte>The application looks like it should be able to simulate a Scarlett, so it should be testable without actually having one
<mekeor>Zambyte: maybe it's a bug in the package definition. maybe it needs something like this?: https://git.savannah.gnu.org/cgit/guix.git/commit/gnu/packages/engineering.scm?h=699ae7f5da5a2bfe5112fc7a1bdd4c25227bd4bd
<Zambyte>mekeor: Yeah that is what I was thinking, but I think if it's just setting the environment variable I should be able to get it to work by setting it properly
<Zambyte>I can try defining a package with that set though to see if that works
<apteryx>is it possible to strace a program running in gdb?
<apteryx>I get strace: attach: ptrace(PTRACE_SEIZE, 30507): Opération non permise
<apteryx>even as root
<mekeor>apteryx: fsbot ! (chatgpt?) says: “You can use the "set follow-fork-mode child" command in gdb to automatically attach strace to child processes”
<mekeor>yes, i use /msg fsbot ! this as llm
<civodul>apteryx: nope, a process can only be ptrace(2)’d by at most one process, so either gdb or strace
<civodul>looks like we have an important patch set here: https://issues.guix.gnu.org/68524
<civodul>i’m not really knowledgable about these UEFI things, but would be nice to get feedback from people
<Zambyte>Nice, I set the GSETTINGS_SCHEMA_DIR to be based on the gtk package input, and now it works. I will send a patch :)
<Zambyte>thanks mekeor
<mekeor>Zambyte: gtk+, i guess?
<mekeor>Zambyte: great, looking forward for your contribution :D
<Zambyte>mekeor: It might have been the difference between using the gtk and gtk+ package, but gtk is already specified as a dependency, so I tried that first and it worked
<davidh38>hey everyone,
<mekeor>cool
<mekeor>davidh38: hello :)
<davidh38>I just installed awscli, but when I try to reason it with awscli or aws, it  says: command not found. Why is it not in the path?
<mekeor>davidh38: does it work when you start a login shell? (i think you can do so with `$SHELL --login`)
<davidh38>mekeor nope, unfortunately not
<ieure>davidh38, The program is, for some reason I do not understand, installed as "awscliv2"
<ieure>I mean, it's obviously superficially because there's an awscli 1.x package in Guix as well as 2.x. But I don't know why you'd want to change the binary name vs. put the version you want in your profile or whatever
<ieure>IMO this merits a bug report and/or patch.
<mekeor>davidh38: it's called awscliv2 and awsv2
<ieure>Also, in general, when some Guix package doesn't meet my expectations like this, I usually run `guix build THE-PACKAGE-NAME' and go rummage around in that directory in the store to see what's what.
<davidh38>mekeor that is true, how did I not see that ?
<davidh38>ieure yes, good idea thank you, I think I am not confident enough to do that.
<davidh38>ieure
<mekeor>ieure, davidh38: yes, in this case, this is a nice way to list the package content: tree $(guix build awscli)
<davidh38>oh sorry, I taged you right
<mekeor>(you need `guix install tree` before)
<davidh38>nice thank you guys, I learnt a lot today, this community is so helpful
<podiki>hi guixers!
<mekeor>hi podiki :)
<podiki>any idea why i can't reach some server from a guix system but can from my network on another (non guix) machine? my guix network setup has nothing, just dhcpd no other issues with network
<podiki>hi mekeor!
<podiki>how might i diagnose? (the tricky thing, I'm not sure what the server is exactly, will have to check some logs)
<davidh38> nice, that the awscli is open source btw
<mekeor>davidh38: for concerns, see https://yhetil.org/guix/87il474ytd.fsf@rekahsoft.ca/
<mekeor>podiki: is it a domain or an ip?
<mekeor>gotta go, i should sleep, have been sick too long. sorry. goodbye :)
<podiki>sneek: later tell mekeor rest up and hope you feel better soon!
<sneek>Will do.
<PotentialUser-47>Hey all, I just wanted to ask what version of the linux kernel does Guix use?
<Zambyte>PotentialUser-47: linux-libre 6.7.2 is the latest shipped by Guix
<PotentialUser-47>is this guix 1.4.0 or latest? Sorry I'm new to this
<zamfofex>Latest, you shouldn’t extensively use Guix from the numbered releases.
<PotentialUser-47>Okay thank you. I have all of my parts to build my new PC and I plan on switching over to gnu/linux
<PotentialUser-47>Looking forward to keeping things libre