IRC channel logs

2023-07-23.log

back to list of logs

<hwpplayer1>hi people !
<hwpplayer1>I am about to switch to GNU Guix from Ubuntu. What should I need to take care of ?
<ulfvonbe`>why do unbound variable errors never seem to have an associated line number or backtrace?
<hwpplayer1>What are the system requirements of GNU Guix ?
<hwpplayer1>I have a Pentium CPU 4 GB RAM and 500 GB HDD
<hwpplayer1>And by default is GNU Guix %100 free as in freedom ?
<nckx>hwpplayer1: That it is. As for i686 (32-bit Intel), it's supported, but you'll encounter strictly more bugs than on x86-64.
<nckx>I hope that's honest without being FUD :)
<hwpplayer1>What does FUD mean ?
<hwpplayer1>Okay
<hwpplayer1>Understood
<hwpplayer1>Talk to you later bye for now
<nckx>sneek: later tell hwpplayer1: Sorry, didn't mean to ghost you.
<sneek>Okay.
<ulfvonbe`>so I'm trying to do some rust packaging, and I get this error:
<ulfvonbe`>error: failed to select a version for the requirement `cipher = "^0.4.4"`
<ulfvonbe`>candidate versions found which didn't match: 0.4.3, 0.2.5
<ulfvonbe`>wait nvm
<ulfvonbe`>just realized it only allows for minor-version upgrades, not downgrades
<squeaktoy>Where can I see what's inside desktop-packages?
<squeaktoy>I can't do startx because it says connection refused or something
<squeaktoy>Maybe I'm missing some service or package
<fries>hi guix chat. so, lets say in this hypothetical situation, that a program has multiple outputs with different binaries that use the same install command. but, the first output has libraries that the other outputs depend on. do you know how you can make that binary see those libraries inside another output. kind of like depending on a library from a main output.
<ulfvonbe`>squeaktoy: haven't heard of desktop-packages, but there is %desktop-services
<ulfvonbe`>see "info guix 'X Window'"
<ulfvonbe`>more specifically, the 'xorg-start-command' procedure
<ulfvonbe`>or if the thought of using info is just too unbearable, https://guix.gnu.org/en/manual/devel/en/html_node/X-Window.html
<ulfvonbe`>fries: sounds like you want an rpath modification
<fries>ulfvonbe`: oh! how would i do a rpath modification in guix?
<ulfvonbe`>probably passing (string-append "-Wl,-rpath=" #$outputs:<outputname> "/lib") to something that sets cflags
<ulfvonbe`>I guess something like #:make-flags (list (string-append "CFLAGS=-Wl,-rpath=" #$output:<outputname> "/lib")) maybe?
<squeaktoy>ulfvonbe`: what is [config]?
<ulfvonbe`>from context, I would assume it's an xorg-configuration
<squeaktoy>but I have none!
<ulfvonbe`>so make one
<ulfvonbe`>it's documented right above xorg-start-command in the manual
<ulfvonbe`>er, rather, right before set-xorg-configuration, which is right above xorg-start-command
<ulfvonbe`>oh, also, the [] means it's optional
<squeaktoy>how do I add extra-config?
<squeaktoy>idk what the syntax is to add lines to the config
<ulfvonbe`>and the defaults are probably fine, unless you've got a fancy keyboard layout or need some weird custom configuration
<ulfvonbe`>(xorg-configuration (extra-config (list "this line comes first\n" "this line comes next\n")))
<squeaktoy>/etc/config.scm:128:2: error: (xorg-start-command): invalid field specifier
<squeaktoy>does xorg-start-command reside in services?
<squeaktoy>or in operating-system/
<ulfvonbe`>nope, it returns a file-like object.
<squeaktoy>So where does it have to go?
<ulfvonbe`>I guess you would add it to your packages field?
<ulfvonbe`>I don't know if that accepts general file-like objects or only packages
<ulfvonbe`>you might need to define a little package that puts it in (string-append #$output "/bin/startx") or something like that, not sure
<ulfvonbe`>or you could just extend special-files-service-type to put it in a well-known place
<ulfvonbe`>hmm, looking at the documentation for that field it does seem like it's just for packages
<squeaktoy>I'd like to know how to make use of this xorg-start-command thing
<squeaktoy>sx does work but my keyboard and mouse freeze up
<ulfvonbe`>Well, it's a file-like object that, when lowered, becomes a program in the store. You probably want it in your PATH, and the way to do that globally is to add it to thy system profile. But the system profile wants packages. So you have two options: either make a dummy package whose output contains it, or put it somewhere fixed in the filesystem like /usr/bin/startx with special-files-service-type
<ulfvonbe`>personally I think the former approach is better, though still ugly
<ChocolettePalett>Speaking of Xorg, I personally found this guide useful, in my opinion:
<ChocolettePalett> https://lists.gnu.org/archive/html/help-guix/2018-07/msg00080.html
<ChocolettePalett>Note the step where you have to install additional packages, such as xf86-input-libinput
<ulfvonbe`>squeaktoy: here's an example of how you might do that: https://paste.debian.net/1286676/
<juliana[m]>hi, when running guix shell -CF guile I get the error message "ldconfig: /lib/libguile-3.0.so.1.6.0-gdb.scm is not an ELF file - it has the wrong magic bytes at the start." Is this a known bug? a cursory glance at https://issues.guix.gnu.org suggests not
<squeaktoy>why is my kernel not updating to 6.4?
<squeaktoy>I did guix pull and guix system reconfigure but it doesn't upgrade the kernel
<ulfvonbe`>did you specify 6.4 in the (kernel ...) field?
<ulfvonbe`>it looks to me like (gnu packages linux) has linux-libre bound to linux-libre-6.3
<ulfvonbe`>but linux-libre-6.4 is also defined
<squeaktoy>so how do I switch to it?
<ulfvonbe`>include (kernel linux-libre-6.4) in your operating-system form
<squeaktoy>but then I'd have to update that line when 6.5 comes out right?
<ulfvonbe`>yes. I don't think we have a 'linux-libre-latest'.
<nckx>Yes. Because the default is 6.3.
<nckx>That's the answer to ‘why is my kernel not updating to 6.4?’, too.
<ulfvonbe`>if you really want to live on the bleeding edge, you could iterate over the exported symbols in (gnu packages linux) and find the linux-libre with the highest version
<squeaktoy>How do you see what the default version is?
<nckx>sneek: later ask lfam Why's linux-libre held back ATM?
<sneek>Okay.
<nckx>squeaktoy: echo '(@ (gnu packages linux) linux-libre)' | guix repl
<nckx><yes. I don't think we have a 'linux-libre-latest'.> No need. Use (specification->package "linux-libre") which always prefers the highest version.
<nckx>Or just trust the package maintainer to have a reason not to make 6.4 the default.
<podiki[m]>cuirass looks stuck, no new derivations in a few days and workers status shows lots of builds but i think it is frozen
<podiki[m]>clicking on an active build shows e.g. 3+ days active
<viaken>For different packages with overlapping binary names, what's the preferred method of handling the conflict?
<zamfofex>I think the order in which you specify the packages matters. (I think packages coming first have precedence.)
<ulfvonbe`>rust legitimately makes me think we need propagated-native-inputs
<ulfvonbe`>rust-ring-0.16 requires perl to build, and so does everything that uses it
<nckx>Cursed.
<viaken>zamfofex: I meant from a packaging standpoint. If I want to contribute a package, but it's got a binary name that overlaps with a different packages....just leave it to the user to sort out?
<zamfofex>viaken: Depends on the circumstance, I’d imagine, but I’d say yes.
<nckx>viaken (now there's a name from another time): Yes.
<zamfofex>(“Yes” on most cases, I mean.)
<nckx>As for method: just ordering, for now. E.g., ‘guix shell’ will prefer the rightmost package. In manifests, it's the leftmost. Variety is the spice of life.
<viaken>Certainly makes the packaging easier
<viaken>nckx: Know me from elsewhere?
<squeaktoy>herd still doesn't want to properly shutdown
<nckx>I have no idea wherefrom.
<squeaktoy>it keeps waiting on a process still
<nckx>#!?
<squeaktoy>also the new kernel also panicked
<squeaktoy>let's run memtest
<nckx>Not that I was active there, but IIRC you were.
<nckx>bayfront is slow to respond to narinfo polls.
<viaken>nckx: That'd be it! Nice to see another #!er around.
<nckx>Lol. Just dropped my laptop and the network card must have dislodged. That'll be for tomorrow...
<nckx>It didn't even land that hard. 💀
<nckx>viaken: Likewise! I'd chat more with a proper keyboard.
<nckx>'Night Guix.
<ulfvonbe`>today I learned that in cargo, optional dependencies are mandatory
<ulfvonbe`>there's been an open issue about it since 2017... https://github.com/rust-lang/cargo/issues/4544
<apteryx>stumbled on that too in the past; it's silly
<apteryx>ACTION can't reliably find the oldest commit 'guix-timemachine' ought to be able to travel to
<PotentialUser-27>hi, guix pull doesnt seem to want to update my installed applications like web browsers, email clients etc. Any ideas on what the issue might be? It doesnt give me any errors it just says nothing to be done
<pret7>guix package -u
<pret7>(also did that message send twice?)
<PotentialUser-27>oh its just guix package -u? Im sorry i havent used guix in a while, thought it was pull but i guess that just refreshes the sources or whatever. And that message only showed once for me
<pret7>yep! I think it also updates the host guix itself.
<pret7>you'll have to update whatever profiles you have separately with guix package -p <PROFILE> -u
<pret7>I wonder if there's a way to update all profiles together
<PotentialUser-27>thank you
<pret7>😃
<efraim>gexp->derivation is 'built' without network access, right?
<mobius_>curious as to why "clear" doesn't work in the terminal. i just always assumed it was part of gnu coreutils
<efraim>it's part of ncurses
<mobius_>ahhh, that would explain it. thanks
<efraim>I suppose if you wanted to you could add an alias for clear to 'guix shell ncurses -- clear'
<mobius_>well ctl + l works so not a big deal
<efraim>or I suppose you could compute it ahead of time using guix-home ("clear" . ,(file-append (specification->package "ncurses) "/bin/clear"))
<minima>hi, i have this home service definition https://bpa.st/CKWA where i use local-file to copy a bunch of local files over to home-xdg-configuration-files-service-type
<minima>i was wondering if there's any built-in facility to recursively include all files from a given folder (each one copied to the XDG destination with its own name) in one go
<minima>instead of using local-file a number of times against each individual file
<minima>i suppose it wouldn't be difficult to simply map over the files, but i wondered if there's any idiomatic way of doing this
<geri>heyo
<pjals_fox>hiya, do you have a question?
<geri>yes!
<pjals_fox>nohello.net
<geri>trying to set up quicklisp and --script breaks while --load works, which is kinda weird
<geri>wonder if anyone knows about it
<geri>pjals_fox: i usually stay after to chill too :(
<geri>but alright
<geri>let me rephrase - i made a thing that uses alexandria and quri and when i try to run the file, --script breaks not knowing how to load alexandria while --load works
<geri>both installed with guix
<geri>well, it works if i load sbclrc manually and install packages via quicklisp
<nckx>Hullo.
<geri>hi-hi
<nckx>_S|||||||||||||||||||||||||||||||||||||||||||||||||||||||||||Hullo.
<atuin>hi
<atuin>is it normal that guile `(module-filename)` return a relative path? What
<atuin>What
<nckx>geri: If you don't get an answer here, file a bug.
<atuin>what's the way to get the full path?
<nckx>canonicalize-path
<atuin>that makes the module load to fail, I have tried already
<atuin>i am using `guix home -L path reconfigure -n myconfig.scm`
<geri>what are you trying to do with module-filename?
<atuin> Let me explain from the beginning
<atuin>I have made a custom channel for my packages which i keep in git, i have also a repo for the home / system configuration. The custom channel defines some functions to get patches for the packages i need. I have a home config that uses a packages from that channel that i want to add into the home configuration. What i want to achieve is basically to be able to test the config using the channel locally (passing -L) to guix home
<atuin>but seems that when loading the module that defines the package (a custom version of stow) i get a relative path for the module, so canonicalize-path fails telling me it does not exist
<atuin>seems the info for the module file is lost (current-filename) returns #f as well
<geri>i only know that (current-filename) returns #f when used in repl
<atuin>yeah, something happens when using guix
<atuin>anyway I will try to use an env variable when testing locally and test if it works without -L
<atuin>thanks
<geri>worst case just replace your channels file temporarily with your channel and test, i think it shouldn't break unless you do home/system reconfigure
<nckx>When I use (current-filename), it turns every subsequent error into ‘ice-9/eval.scm:191:35: In procedure scm_to_utf8_stringn: Wrong type argument in position 1 (expecting string): #f’. Merely using it. Hard-coding its return value makes everything work again. It's wonky.
<geri>for my use-case canonicalize-path always betrays me as well
<nckx>So if (canonicalize-path) fails, doesn't that imply that (module-filename) is not relative to (getcwd)?
<geri>my use case is exactly using relative paths
<geri>and thats when it breaks
<geri>also stupid question - how to read a string from guile xd
<nckx>As in, from the user? (read-line (current-input-port)) ; from (ice-9 rdelim)
<nckx>ACTION away.
<geri>yeah, that
<geri>thank
<geri>kinda funny its not available by default
<dgr>how to debug /builder for `/gnu/store/k8sjx83k8xnjzarpsddjn0hj8vg6gwln-texlive-font-maps.drv' failed with exit code 1 ?
<dgr>
<nckx>Read the output.
<nckx>Or share it here using paste.debian.net.
<efraim>cbaines: do you remember my terrible idea to store my base64 encoded gpg encrypted password in my home-config? I finally got it working
<bovid-19>Hi guix!
<nckx>ACTION moos.
<bovid-19>I am running SBCL (Common Lisp) though Sly on Guix System. I assumed the correct way to load a system was `(require :system-name)'. This seemed to work so far, but now I tried to load `mito' without success (--> `Don't know how to REQUIRE MITO.'). `sbcl-mito' is installed. I also tried inside `guix shell sbcl sbcl-mito'.
<dgr>nckx: https://paste.debian.net/1286710
<nckx>Oh, that was general advice, I don't use use TeX. If that output doesn't mean anything to you, I'd file a bug at bug-guix at gnu dot org, including a command to reproduce that error.
<dgr>nckx: not sure I know enough about guix to file a meeningfull bug
<dgr>the command was as generic as guix upgrade can be
<nckx>Just mention ‘guix upgrade’ and include your list of packages (guix package --list-installed) with the error log. That's meaningful!
<Z572[m]>ACTION uploaded an image: (127KiB) < https://libera.ems.host/_matrix/media/v3/download/mozilla.org/b8c8a53f9c21d5d9cafb52691e22ecc4650bcd7a/image_2023-07-23_21-26-37.png >
<Z572[m]>hello,i make plasma desktop work,see https://debbugs.gnu.org/64798
<nckx>dgr: …and the output of ‘guix describe’ just to be complete.
<nckx>Z572[m]: Wow, thanks.
<dgr>Z572[m]: many thanks, have seen a post on mastodon.
<zamfofex>Z572[m]: Oh wow, I just woke up to this! That’s amazing. It must have taken quite a while to get everything working right, thank you!
<squeaktoy>Hey I just ran the guix install script on gentoo but it says guix command not found after the installer
<squeaktoy>and the docs aren't very clewr on how to set up guix for a non-root user
<nckx>/usr/local/bin not in $PATH?
<squeaktoy>it is
<squeaktoy>but there's no guix there
<nckx>Spooky.
<dgr>nckx: looks like guix install texlive-scheme-basic helped as sugested in https://issues.guix.gnu.org/64783
<nckx>squeaktoy: What does the install script output look like?
<squeaktoy>idk
<nckx>dgr: Well found.
<squeaktoy>it asked me to install an SELinux pokicy
<squeaktoy>but zi don't havr selinix
<squeaktoy>damn I can't type
<nckx>You have /sys/fs/selinux/policy, so the script asks.
<nckx>I'm more interested in why ‘ln -sf "${var_guix}/bin/guix" "$local_bin"’ would silently fail with set -e.
<nckx>ACTION downloads themselves a gentoo. 🐧
<nckx>squeaktoy: Any update on that guix-install.sh output?
<squeaktoy>nope
<squeaktoy>It still broken and idk hoe to fix it
<nckx>Why won't you share the output?
<squeaktoy>Basically I want to compile non-guix kernel becauae linux-libre still kernel panics but I can't compile a kernel on a system that keeps crashing
<squeaktoy>So I want to install guix on gentoo so I can try compiling it thete
<squeaktoy>thrre
<squeaktoy>sorry I'm on my phone rn
<pjals_fox>Why won't you share the output?
<nckx>For reference, I downloaded a Gentoo VM live ISO, built QEMU to run, and tried running guix-install.sh on that VM, using ‘sendkey’ to send half of the keystroke because key handling is broken somehow. After all that trouble, I ended up with a (AFAICT) perfectly working /usr/local/bin/guix in $PATH.
<nckx>So it's rather frustrating when the response is ‘IDC, it's broken, fix it’.
<squeaktoy>i said idk not irc
<squeaktoy>idc
<squeaktoy>I'm tryint to log it right now
<nckx>Not giving any more info sent the IDC message.
<pjals_fox>please give us the logs
<pjals_fox>atleast a picture of it, anything, please
<nckx>Vertical video is fine too, if it's legible.
<nckx>ACTION tries pulling the Gentoo'd Guix before throwing away the VM.
<ulfvonbe`>have we fixed the guix test failures yet?
<ulfvonbe`>namely package->bag and "texlive->guix-package, meta-package"
<janneke>ulfvonbe`: https://issues.guix.gnu.org/64760#1
<squeaktoy>I'm trying to get wgetpaste to log the output
<squeaktoy>but it's kinda hard
<nckx>An image is fine too.
<squeaktoy>and I can't log conventionally because I'm on my phone remoting into my computer
<squeaktoy>and an image is useless brcause I use big fonts
<podiki[m]>nckx: do you have cuirass access? can you poke it? (looks stuck for days now, at least according to dashboard)
<nckx>I can restart it.
<nckx>By Cuirass you mean ci.guix.gnu.org?
<nckx>podiki[m]: Restarted.
<nckx>It's doing stuff to things: https://ci.guix.gnu.org/workers
<podiki[m]>yes
<podiki[m]>thanks
<podiki[m]>the workers have been like that though, with build times of ~3-4 days now
<nckx>Things are appearing & vanishing though.
<squeaktoy> https://ttm.sh/Bf4.png
<podiki[m]>yeah, thanks
<nckx>podiki[m]: Really like this?
<nckx>OK!
<squeaktoy>here's a screesnhot
<ulfvonbe`>janneke: thanks!
<nckx>squeaktoy: Thanks.
<podiki[m]>i thought just CI was behind a few days but seemed like all the jobs were stuck (or at least showing that, no idea what was going on behind the scenes)
<nckx>squeaktoy: You'll have to systemctl stop gnu-store.mount (IIRC), then rm -rf /gnu /var/guix .
<nckx>systemctl stop guix-daemon to be safe, although it shouldn't matter much.
<nckx>podiki[m]: ‘Only’ build jobs or evaluations too?
<podiki[m]>evaluations didn't show anything new for several days, worker status all the random ones i clicked had the super long build times still in progress
<squeaktoy>I don't have systemd
<nckx>Duh.
<podiki[m]>didn't realize the worker status looked stuck until later but now seems more like it is moving again
<nckx>My bad.
<nckx>‘rc-service guix-daemon stop’, I guess.
<squeaktoy>there's no process at all with guix in its same
<squeaktoy>name
<nckx>I wonder just how broken your installation was :-/
<squeaktoy>* rc-service: service `guix-daemon' does not exist
<nckx>Does /etc/init.d/guix-daemon exist?
<nckx>ACTION remembers very, very little of OpenRC.
<podiki[m]>nckx: either way, thanks! (hoping to merge in the mesa updates when things are caught up/see if another rebuild is needed)
<squeaktoy>nope
<squeaktoy>there's no guix-daemon
<nckx>Nuts. We'll definitely need to see the ‘log’ (output) of the guix-install.sh script, after removing those left-overs above.
<nckx>ACTION has to go now, though. TTYL.
<janneke>ulfvonbe`: well, thank jpoiret ;)
<ulfvonbe`>I'll thank you both
<ulfvonbe`>can't apply the patches locally if I don't know about em
<janneke>+1
<janneke>ACTION really likes sharing stuff
<squeaktoy>what files does guix-install.sh change?
<nckx>It patches /home/*/.bashrc /root/.bashrc and creates /gnu /var/guix and service file(s) in /etc.
<nckx>Oh, and the /usr/local symlinks to the guix binary and manual.
<squeaktoy> https://ttm.sh/Bfk.png
<squeaktoy>here's a better log
<squeaktoy>I removed /gnu
<gabber>well that's not good
<nckx>Aha.
<gabber>squeaktoy: when did you remove /gnu? also: it asks you if SELinux policy installation is required -- you answer yes, but semodule is not found..
<nckx>Seems simple: if /sys/fs/selinux/policy, invoke semodule, semodule doesn't exist, and errors are fatal.
<nckx>gabber: To be fair, it's implying that the policy is required, not asking whether it is.
<gabber>what/who is /it/ in that statement?
<nckx>The script.
<gabber>i don't interpret it that way. but it does presume users know what it is and how to check whether it is needed
<gabber>might be worth checking for the existence of /sys/fs/selinux(/policy) in guix-install.sh and (only?) then asking that question
<ncd>GUIIIX.
<nckx>gabber: It *does* check for that, but /sys/fs/selinux does not imply semodule being installed.
<nckx>So we just add a command -v semodule and we golden.
<nckx>AFAICT.
<itd>There is no built-in authentication between cuirass and remote-workers. Anyone able to connect to cuirass's backend-port can pretend to be a remote-worker. Correct?
<itd>Also, I'm confused by cuirass-remote-worker-configuration's public-/private-key. It's not clear to me how to generate them. (But empty files seem to work as well.)
<itd>Looking at the Guix/cuirass docs, I failed to understand that without a reachable log-port the remote-workers are unable to send build logs to cuirass (despite being able to communicate via backend-port).
<itd>It would be nice not to see "Could not find machine information using Zabbix." on the remote-worker machine page, if the %zabbix-url parameter is #f (the default).
<itd>Re channel authentication [0], I'm using a patched cuirass (i.e., reverting that commit). Seems to work. This is fun. :) [0]: https://logs.guix.gnu.org/guix/2023-05-18.log#084857
<apteryx>if someone is interested helping me to narrow down the oldest commit at which 'guix time-machine' can travel, I'm using this simple test: guix time-machine --commit=4c91332cced67bd7b9034035fb2b02c5728509a7 -- shell hello -- hello
<apteryx>currently the oldest commit which succeeded for me was 4c91332cced67bd7b9034035fb2b02c5728509a7, from Nov 13 21:43:45 2021
<apteryx>less than 2 years old
<apteryx>past that I'm getting a lot of '%environment-options unbound variable' errors
<apteryx>maybe touching a long range of commits, not sure
<apteryx>it's a nice little game to kill the time if you are bored ;-)
<apteryx>and when we are satisfied having nailed the "oldest commit we can travel to", I can update #64746 with it
<janneke>ACTION looks...
<atuin>I am getting this when running `guix home reconfigure`: `GC Warning: Repeated allocation of very large block`. Any idea where to start to debug it?
<apteryx>oof, that's a Guile warning, I think
<atuin>yeah looks like the guile GC
<atuin>maybe i can profile the guix command somehow
<apteryx>I think asking in #guile would be a good idea
<atuin>yeah thanks
<apteryx>you could try to isolate the exact procedure/code that triggers it
<apteryx>then at the REPL there are some profiling commands
<apteryx>,help profile
<squeaktoy>gabber: I ran the installer and answered no on the selinux thing before and same result: borked install
<apteryx>but none about memory allocation
<atuin>apteryx thanks, I will try it
<nckx>squeaktoy: …output…? 🥺
<nckx>There is nothing to be debugged in ‘borked install’.
<squeaktoy>iirc it's literally the same output as selinux yes but without the command not found
<apteryx>janneke: thanks but beware, it's very time consumming ^^'
<apteryx>consuming*, even
<apteryx>sometime time-machine seemingly hangs too
<squeaktoy> https://ttm.sh/Bfo.png
<squeaktoy>herr's log
<nckx>Thanks. Please, share these by default. It really helps.
<nckx>Even when it doesn't look like it.
<nckx>squeaktoy: I got called away, but pushed two bugfixes (https://ttm.sh/Bfo.png made it quite obvious what was happening). Could you download the script again, remove any old Guix left-overs, and try again?
<ulfvonbelow>is there a hard one-package-per-commit rule, or could multiple packages be added in one if they're highly interrelated (for example, package A depends on package B, which inherits from A)
<nckx>There's a hard ‘no broken commits’ rule.
<nckx>Most other rules are squishy.
<singpolyma>The commit message format rule will be hard to follow with more than one package touched in a commit though
<nckx>How so?
<singpolyma>nckx: oh? You think there's a way to make it work? I defer to you obviously, that was just my strong impression of the format
<nckx>I was just curious.
<nckx>Any rule in particular?
<nckx>The body is extremely flexible, in its own way, and I'd just write ‘gnu: Add A and B.’ as the title.
<takev[m]>Is there a recommended workflow for testing out new services? I have a system definition that that I have been running as a container, but it feels like there is probably a better way through the repl or something.
<squeaktoy>nckx: which file does the installer modify to customize the Bash
<squeaktoy>also how does guix modify /gnu/store from a user account?
<ulfvonbelow>privileged daemon does it on their behalf
<nckx>I gave a (possibly non-exhaustive) above.
<nckx>Just glancing at the script, it patches /home/*/.bashrc /root/.bashrc, and creates /etc/profile.d/zzz-guix.sh
<nckx>The bashrc is just to customise the prompt in Guix environment. /etc/profile.d is where the important profile loading happens.
<nckx>squeaktoy: Any more luck with the new & improved™ guix-install.sh?
<nckx>I wish cURL defaulted to HTTPS so we could just ask people to ‘curl guix-install.sh’. Big boss move.
<mirai>was linux-libre-6.3.13 always this large? (104.0 MiB)
<Kabouik_>Hey, guix pull complains because there's no space left on my device, but df -h / says 11GB are free. I know it's not much, but that should be enough right?
<nckx>Which device?
<nckx>There's also df -i, and maybe reserved blocks (I don't remember if df includes or excludes them).
<Kabouik_>Erm, it's my Droidian phone
<Kabouik_>df -i shows only megabytes, free or used, is that expected? This is an encrypted partition, maybe that breaks df -i calculations?
<nckx>It's not expected. It should show inodes. Even on my system without ‘real’ inodes, it shows a fictitious number. Maybe Droidian is… different.
<nckx>11GB is definitely enough.
<Kabouik_> https://youtu.be/9HgFUDR66pw sorry about it being a pic and not a pastebin, but the whole point of my guix pull is to upgrade foot to 1.15.1 which will support text selection by touch. Anyway, maybe my mistake is to run df -ih, h probably messes up when combined with i.
<Kabouik_>Sorry, wrong url paste
<nckx>mirai: Sounds expected to me?
<Kabouik_>A funny paste by the way.
<nckx>Note that's the entire module collection, System.map, etc.
<nckx>My sizes are even higher: https://paste.debian.net/plainh/850cb137
<Kabouik_>Anyway df -i shows ~58% in use
<gabber>nckx: how come your patches from today/earlier are dated a week ago?
<nckx>Fakery.
<nckx>Kabouik_: What is the error output of ‘guix pull’?
<gabber>so.. intentional behavior?
<nckx>Yes.
<nckx>Git Privacy Guard™.
<zamfofex>gabber: Git commits are just a file with a reference to a data and a hash reference to a parent commit and a file system tree. You can put any date you want on any commit.
<nckx>Aha, but GPG signatures.
<zamfofex>“Git commits are just a date and a hash reference to […]”
<zamfofex>(is what I meant)
<nckx>(There are also 2 ‘dates’ attached to a single commit, only one of which is shown by default.)
<squeaktoy>nckx: it werks noe
<squeaktoy>now
<squeaktoy>I wonder what was wrong
<nckx>ACTION squeks.
<squeaktoy>yay
<nckx>squeaktoy: https://git.savannah.gnu.org/cgit/guix.git/log/etc/guix-install.sh
<nckx>(‘8 days ago’ is now.)
<Kabouik_> https://0x0.st/HepK.txt nckx
<gabber>nckx, zamfofex: i know how the commit messages work :) i just wondered whether nckx did it on purpose (and then, why -- for they only just patched the install script today)
<gabber>:q
<squeaktoy>How is 8 days now?
<nckx>Fakery.
<squeaktoy>like what is this time machine
<nckx>I'm stuck in guix time-machine, send help, and a fine single malt.
<squeaktoy>malteser
<nckx>gabber: Anyway, privacy is the only reason.
<nckx>Weirdoes gonna weird.
<zamfofex>On a different note: I wish I could have some idea about what to work on for Guix so that I could be more helpful.
<squeaktoy>support for /boot
<zamfofex>Usually I’m good at working on things that matter to me more so than on things that don’t matter to me. 😄 My general interests (related to Guix) are (i) the Hurd, (ii) WebAssembly, and (iii) helping bring npm packages to Guix.
<zamfofex>At some point, I also investigated bringing C# and .NET packages to Guix, but that didn’t go very far.
<nckx>Kabouik_: I assume builds happen in /tmp on this system. Is /tmp a separate mount?
<nckx>Because of the truncated backtrace, there's not much more to go on.
<squeaktoy>What does WASM have to do with Guix?
<nckx>guix pack --target=wasm
<zamfofex>squeaktoy: There is (little) interest in bringing a WebAssembly target to Guix.
<Kabouik_>No it's a single partition nckx
<nckx>Damn.
<Kabouik_>I'm guix pulling again. I don't see in which parallel world this would suddenly work, but I haven't come up with something marginally smarter yet.
<ncd>Is there the equivalent of "delete-word" in readline that actually means "go back to the next space MANE CMON MANE PLEASE"
<zacchae[m]>Can anyone point me to an email server setup on guix? I tried ddg, google, src.ht, etc. and came up dry...
<zacchae[m]>Yes I know gmail/outlook will blacklist any email I try to self-host, but that is all the more reason to self-host...
<zacchae[m]>I think all I need is exim so long as I stick to maildir, but I'm not too sure. Would like to see a working example