IRC channel logs

2023-05-29.log

back to list of logs

<rekado>sammm: thanks for the report about the logging
<rekado>no idea what happened on bayfront; the service was still running
<rekado>I restarted it
<efraim>perhaps it's related to the shepherd bug? the one where restarted services don't actually stop and start again but hold file descriptors?
<sammm>rekado: np!
<PaulePanter>Hi. How can I run the precompiled guix binary as an unprivileged user?
<PaulePanter> https://ftpmirror.gnu.org/gnu/guix/guix-binary-1.4.0.x86_64-linux.tar.xz
<PaulePanter>It has /gnu/store/… hardcoded in the shebang line and an unprivileged user is not allowed to create these directories.
<janneke>PaulePanter: See https://guix.gnu.org/manual/en/html_node/Binary-Installation.html
<janneke>you cannot install on a foreign distro (in this way) without root privileges
<PaulePanter>janneke: That’s what I feared. Thank you for the confirmation.
<civodul>janneke: congrats on the native GNU/Hurd boot!!
<civodul>jpoiret, janneke: BTW, while we're at building a custom libc, we should configure it with --enable-pt_chown: https://issues.guix.gnu.org/59616
<janneke>civodul: thanks! phew, that initial "guix system init" support and "second boot" problem took me two days of hacking!
<janneke>ah, that would be a nice fix to have
<civodul>woow
<civodul>actually, i saw you had two GRUB menu entries
<civodul>did you managed to get one Guix not step on the other's toes?
<janneke>no, guix system init /hurd steps on linux's toes
<janneke>but i follow that by a guix system reconfigure, that adds menuentries for everything in /hurd/boot/grub/grub.cfg ;-)
<janneke>(there is still quite some room to smooth-out the experience ;)
<guixfren>Is there any work being done on updating to Gnome 44?
<guixfren>I wonder if this could be a good opportunity to start contributing? It's work to do but I don't believe it should be that difficult (hopefully anyway)
<janneke>guixfren: i guess you could look into the gnome-team branch
<janneke>i'm sure the gnome team would appreciate some help
<lambdanil>janneke: I'll see if I can figure something out, I'm not very familiar with the GNU way of development which is currently the biggest barrier of entry for me
<lambdanil>(to clarify, I'm guixfren on another nick)
<janneke>ah! ;-)
<ieugen[m]>hi, I would like to learn more guix and my target for this is to try to update lokke package that seems to be old.
<ieugen[m]>Is there a guide on how to update the package and build it locally?
<ieugen[m]>I did try and failed https://github.com/lokke-org/lokke/issues/24 .
<lambdanil>there's a couple of ways to go about this
<lambdanil>You could go ahead and make a separate definition - copy the definition found with "guix edit lokke", put it in a new file, import the necessary modules, then you can finally go ahead and try switching the source tree and messing with the build.
<lambdanil>you can build it locally with guix build
<ieugen[m]>I guess my question can be summarised as: After cloning guix repo, updateing lokke commit id, how can I build the package ? is cd guix ; guix build -L . -K lokke enough?
<efraim>ieugen[m]: you'll want to follow the instuctions about building from git first https://guix.gnu.org/en/manual/devel/en/html_node/Building-from-Git.html
<efraim>then afterward it'd be `cd guix; ./pre-inst-env guix build lokke'
<ieugen[m]>I ran guix build -f gnu/packages/guile-xyz.scm lokke and it said that lokke is not a package. And it's true: (define-public lokke
<ieugen[m]>it does return a (package ... ) though
<jlicht>ieugen[m]: The -f flag should refer to a file that evaluates to the package expression. If you just want something that works _now_, put 'lokke' (sans ') on the last line of the file
<jlicht>Don't commit that though ;-)
<janneke>ACTION is trying another approach to resurrect native builds on the Hurd
<janneke>instead of adding gcc-boot0/hurd to avoid the gratuitous coreutils-boot0 dependency, let's try to build coreutils-boot0...
<janneke>it seemed such an easy fix to add gcc-boot0/hurd, but it's used in more places than %boot1-inputs, as jpoiret pointed out...
<Parnikkapore_m>ieugen: the -f means you want to install the package that the file *evaluates to*. It doesn't work with the stuff in gnu/packages/
<Parnikkapore_m>"-L ." sounds like it might work, although I don't know for sure.
<ieugen[m]>thanks, I guess I a trying to find how people rebuild packages from guix when they change versions?
<ieugen[m]>what is the workflow
<Parnikkapore_m>Apparently the official workflow is to build Guix with the source tree, then use the newly-built Guix. The chapter in the Guix manual should guide you through it.
<Parnikkapore_m> https://guix.gnu.org/manual/en/html_node/Building-from-Git.html#Building-from-Git
<Parnikkapore_m> https://guix.gnu.org/manual/en/html_node/Running-Guix-Before-It-Is-Installed.html
<Parnikkapore_m>it's also the workflow I personally use when updating packages
<ieugen[m]>thanks, I will give it a go
<ieugen[m]>running `guix build -L . -e '(@ (gnu packages guile-xyz) lokke)'` gives me the same error as I got with -L . lokke .
<ieugen[m]>I think I have to do things ina a gux shell, from guix source
<ieugen[m]>Parnikkapore 😁: I did follow the steps, but during make I get an error when building the .ru info .
<ieugen[m]>make[2]: *** [Makefile:5146: doc/guix.ru.info] Error 1
<ieugen[m]>Also, I got more context from your method pjals `;;; note: source file ./gnu/packages/pkg-config.scm` `Unbound variable: $PKG_CONFIG_PATH`
<ieugen[m]>(running on Debian, not inside guix shell - I can't make inside shell because of info/texi compilarion )
<efraim>have you run bootstrap and configure yet?
<ieugen[m]>it's an env path for pkg-config - used when building software (during ./configure phase I think)
<ieugen[m]>thanks, I think I will need to get more familiar with guix and pay the price of reading the contribute docs.
<ieugen[m]>thanks for your pointers
<janneke>terribly slow progress building coreutils-boot0
<janneke>first, need -Wl,-rpath -Wl," (assoc-ref %build-inputs "libc") "/lib"
<janneke>now IGNORE_UNUSED_LIBRARIES_CFLAGS= to get rid of -Wl,--as-needed
<janneke>jpoiret: doe we have a bug open for broken hurd native compilation?
<janneke>jpoiret: i've just built coreutils-boot0, i'm opening a bug with patch so that "people" may discuss
<ytc>could someone please explain what is purpose of declaring the packages in the home profile? i don't see those packages in my PATH variable if i didn't install them with "guix install" but wrote it in home-environment's 'packages' field.
<ieugen[m]>I got that version of lokke but it's very old
<ieugen[m]>right now I am trying to run guix from source in container and when I make it make[2]: *** [Makefile:5146: doc/guix.ru.info] Error 1
<ieugen[m]>I don't know how to skip them either
<ieugen[m]>I've added the output here for who is interested https://paste.debian.net/1281408/
<dcunit3d>if i reply to a help-guix mailing list with nnimap in guix with help-guix@gnu.org in the CC field, will that appear in the mailing list? i've already posted to the list, but i was having trouble with gnus last night. the mails are showing as sent in my webmail
<dcunit3d>here's the headers: https://0x0.st/HbzB.txt
<dcunit3d>oh, nvm. sorry to bother y'all. i'm just not sure what is supposed to happen or whether i've configured things correctly.
<ieugen[m]>I copyied guix.es.texi over guix.ru.texi and guix.zh_CN.texi . Also cp guix-cookbook.de.texi guix-cookbook.ko.texi
<ieugen[m]>this made the build pass and move forward
<ieugen[m]>s/pass and//
<ieugen[m]>can someone else confirm the issue ?
<ieugen[m]>I have managed to build updated lokke locally
<ieugen[m]>It seems
<ieugen[m]>I added the diff here https://github.com/lokke-org/lokke/issues/24 .
<janneke>ACTION builds gcc-boot0 for the hurd, `guix build hello' still hangs
<janneke>moving forward manually through commencement...
<janneke>is there some trick to find a dependency cycle?
<f9>hi people
<f9>i have important thing to tell you all
<f9>nvidia sucks
<f9>thanks for attention
<efraim>janneke: are there other spots where gcc-boot0 is brought in explicitly? or inherited from?
<efraim>I saw the typo in (let-system (syttem target) but then you reverted it
<efraim>ACTION is looking at janneke/wip-hurd
<efraim>libstdc++ maybe, before zlib-final
<efraim>and gcc-final
<janneke>efraim: thanks, i haven't tried those
<janneke>ACTION tried ... https://paste.debian.net/1281419/
<janneke>yeah, libstdc++ also hangs
<janneke>there seems to be a problem with %boot2-inputs
<janneke>ah, sure both glibc-final and gcc-final hang
<efraim>it has gcc-boot0-wrapped
<janneke>yeah, that also hangs
<janneke>crap, this worked 3y ago, why don't we have this under test?
<efraim>what if you unrevert using gcc-boot0/hurd for gcc-boot0-intermediate-wrapped and gcc-boot0-wrapped, but without the typo?
<efraim>861c4de08990ca4c54b6bcca54aec3f63b6ed175, but with system instead of syttem
<janneke>ACTION goes to try that
<civodul>anyone has an opinion about LUKS2 support in GRUB: https://issues.guix.gnu.org/55723 ?
<civodul>would be nice to move forward
<janneke>ACTION fixes the typo
<janneke>hmm..
<janneke>In procedure string-contains: Wrong type argument in position 1 (expecting string): #<procedure system (#:optional _)>
<janneke>so it seems that `letssystem' doesn't work here
<janneke>*let-system
<janneke>oh wait' another typo!
<janneke>ACTION is consistent in their typos...
<efraim>ACTION goes afk for a bit
<davidl>nckx: thanks for the link. A possibility is to keep a TODO.org file in the git repo (TODO-headers like PROPOSED, IN PROGRESS etc.), I wonder what you would think of that? Although I don't really wanna suggest more work to current maintainers, and it might not be worth it in the end. Though it might also be a base for GSOC projects, maybe funding, etc.
<janneke>these new gnulib stackoverflow tests are terrible
<janneke>many gnu packages suffer
<janneke>i found they fail for riscv, and it seems they fail for the hurd too
<f9>good night everyone
<janneke>okay...so mig-boot0 also hangs, while bison-boot0 and flex-boot0 build...
<apteryx>ACTION has missed enough meetings thanks to https://bugzilla.mozilla.org/show_bug.cgi?id=1817004; slaps a TZ environment variable in their config
<janneke>gnumach-headers-boot0 builds...
<efraim>I'd check the with-boot0 %boot0-inputs
<apteryx>hm, do we have a service that can be extended to set environment variables globally (e.g. in /etc/profile) ?
<janneke>aahhh, mig has changed to using git-fetch!
<janneke>it's our (jpoiret and mine) own fault after all
<janneke>i guess
<efraim>wait, it's the same %boot0-inputs for flex-boot0 and with-boot0!
<janneke>grap
<janneke>*cra
<janneke>p
<apteryx>ah, thanks nckx, https://lists.gnu.org/archive/html/help-guix/2020-12/msg00238.html
<janneke>ACTION goes to create a mig tarball
<efraim>oh, I completely skipped over that commit
<efraim>I wonder if you could pre-seed the source. not that it'd really help
<janneke>ah wait, we already did this loop, we can use a savannah tarball and add autoconf-boot0
<janneke>great!
<mwette>This is crazy (fun) using guile to configure an OS.
<mwette>I'm getting error in config.scm. I want to remove network-manager-service-type, but getting error that it's not defined. Do I need a user-service-module? If so, what?
<davidl>nckx: on a related note with the libreplanet page. It has things like vscodium as a suggestion, and it would probably be useful to keep a note somewhere in like a TODO.org file of the javascript situation for that and similar issues with some other software, like for example licensing issues with ZFS or veracrypt.
<apteryx>snippet to extend the session-environment-service-type with extra global environment variables: https://paste.debian.net/1281426/
<janneke>jpoiret: headsup, i've reverted your mig patch and upgraded it to the latest savannah tarball
<janneke>and added autoconf-boot0, automake-boot0, ...but still struggling there...
<mirai>mwette: you need to use (modify-services …)
<mirai>and perhaps (use-module (gnu services networking))
<mirai>or (use-service-module networking), whichever you prefer
<cbaines>this morning I think we had 80%+ substitute availability for 5 architectures
<cbaines>although now it's only just over 80% for x86_64-linux
<jlicht>cbaines: eudev perhaps?
<cbaines>indeed
<mwette>mirai: Thanks! -- I did manage to try those, and have a modify-services, copied from the web somewhere. Chasing other issues now.
<jpoiret>janneke: oh, which mig patch?
<jlicht>it's not even a functional change. Perhaps we can still have weekly/
<jlicht>or even monthly 'disruptive' days, were stuff like this can just be pushed.
<jlicht>s/were/where
<mwette>What's the syntax to remove a service within modify-services? (network-manager-service-type => ???)
<mirai>ah right
<jlicht>mwette: (modify-services %base-services (delete mingetty-service-type))
<janneke>jpoiret: ah, just your package upgrade
<mirai>iirc it would be (modify-services %... (delete the-service-type))
<mirai>^^what jlicht said
<mwette>jlicht: thanks - just found that in the manual
<jlicht>(adapt for %base-services/%desktop-services and service-type, of course)
<mwette>got it
<jlicht>janneke: I'm imagining you going "Eureka!" about every 20 minutes today :-)
<janneke>jlicht: :0
<janneke>:)
<mirai>apteryx: turns out there's already a ipv6-address? predicate in gnu/services/base.scm
<mirai>(it's insufficient since it uses inet-pton but nonetheless)
<apteryx>I think that's where my version started from
<apteryx>based on Ludo's advice
<mirai>ah ok, I happened to see it while I was looking for syslog service
<janneke>aaarghh
<janneke>cpu.symc:83:43: error: 'mach_port_name_t' undeclared (first use in this function)
<janneke>omg, with-boot0 does some "magic" that breaks my inputs
<janneke>*wo0T* guix build hello no longer hangs -- jpoiret !
<janneke>guess we'll find out where it breaks in a while
<elevenkb>Has anyone had trouble building network-manager in the last couple of days
<elevenkb>?
<janneke>ACTION goes to cleanup wip-hurd
<elevenkb>sorry it isn't network-manager but modem-manager.
<elevenkb>There is a problem getting substitutes for network-manager from bordeaux.
<dcunit3d>elevenkb: i can't stay for long, but i'm getting a 404 on network-manager
<elevenkb>dcunit3d: same
<elevenkb>modem-manager's tests are failing too.
<elevenkb>that's probably why network-manager is 404'ing. it depends on modem-manager which doesn't build.
<janneke>hmm, our hurd bootstrap binaries might be too old...
<janneke>error: unknown type name 'long_natural_t'
<janneke>error: unknown type name 'rpc_long_natural_t'
<ekaitz>efraim you have mail: I need to solve this asap
<ekaitz>it's supposed to be just a minute and then we can get to work
<efraim>ekaitz: sent the email just now
<ekaitz>efraim: thanks!
<ekaitz>efraim: when is your project ending? june?
<efraim>Not sure exactly
<ekaitz>just for everyone to know what are we talking about: I got more funding from NlNet + NGI assure to work on the RISC-V bootstrapping
<efraim>ACTION heads back to bed
<ekaitz>this time we are going to work as a team
<ekaitz>good night efraim thanks for being that fast
<jonsger>lechner lilyp btw, updating eudev resulted in 4229 dependent packages to be rebuilt
<janneke>why oh why do people keep inventing new names for "int" "long" "unsigned" etc?
<mirai>they should have picked something like Ada if they were looking for strong typing
<janneke>well, ada doesn't even bootstrap, so i cannot take that seriously
<mirai>ACTION is unaware of the bootstrap section of guix
<janneke>the ada compiler is built using--only exists because of--some binaries magically produced in the past
<mwette>janneke: What are you trying to do? nyacc can replace random C typerefs.
<janneke>mwette: i'm working to resurrect the native guix build on the hurd
<janneke>nyacc is awesome, no problems there ;-)
<mwette>ty; nyacc/lang/munge-base.scm(expand-typerefs)
<janneke>new types got introduced somewhere (glibc, gnumach, ...?) and now new sources do not build anymore with our bootstrap binaries
<janneke>jpoiret: made some progress, but it looks like we need new bootstrap binaries for the hurd
<janneke>in glibc-intermediate, i get
<janneke> 19239 Floating point exception| /gnu/store/99pfm62kgkl0z5d7aswaixdbxj9bffi0-mig-1.8+git20230520/bin/../libexec/migcom -subrprefix __ -prefix __ -header /tmp/guix-build-glibc-intermediate-2.37.drv-0/build/hurd/hurd/tioctl.__h -server /dev/null -user /dev/null
<janneke>so yeah...
<janneke>resurrecting the native build is going to take some effort still, but for now
<janneke>ACTION -> zZzzz
<elevenkb>i love inferiors y'all's.
<oriansj>elevenkb: well what about it do you like best?
<elevenkb>gee, mostly that when packages break I have an alternative to waiting for them to be fixed.
<elevenkb>oriansj: I'm a linux n00b, so it's not like I can just debug a failed package build quickly.
<oriansj>well, not everyone should be experienced in every package
<elevenkb>oriansj: the thing I don't like about them right now though is that they don't let me download substitutes.
<oriansj>and yes, I agree guix should do just a little more testing prior to pushing packages into main
<elevenkb>like I already have the package in the store but... I have to rebuild it so it seems.
<oriansj>well I am one of the #bootstrappable crazies, who disable substitutes and always build from source
<elevenkb>oriansj: good on you! what is your build machine, I'm curious?
<elevenkb>I can't imagine building on my laptop. A 10yr old i5-4308U with 8GB of RAM.
<oriansj>an IBM x200 that has been libreboot'd running Guix
<elevenkb>wild.
<oriansj>my compute needs are simple
<elevenkb>maybe i should actually try that one day. :p.
<elevenkb>i use sway and emacs pretty much. i'm still clinging to firefox for youtube mainly.
<elevenkb>otherwise i use nyxt for my browser.
<oriansj>well if you like, my setup procedures are readily available: https://git.sr.ht/~oriansj/System_setup/
<elevenkb>thanks.
<dcunit3d>oh wow nyxt 3 is available. i've been looking forward to C-x C-b in the browser
<oriansj>elevenkb: you might find yt-dlp quite helpful for reducing your web browser needs
<elevenkb>oriansj: thanks.
<dcunit3d>nice