IRC channel logs

2023-05-13.log

back to list of logs

<katco>i'm doing something weird and trying to include a generated scheme file in the store (i.e. `(include "/gnu/store/my-packages.scm")`) with a list of packages into a module for packages. it's working in the repl, but when i do `guix build -L . my-package` i get an exception (and guix build isn't telling me what it is). does anyone have an idea of how i would get something like this to work?
<lilyp>katco you probably need a directory or otherwise (copy-file #$my-file somewhere)
<katco>lilyp: sorry, i don't understand, can you expound? `include` takes in a file-name. is the directory for some other purpose?
<katco>oh, maybe you're referring to the `-L` flag? i'm within a valid module in `$PWD`, and that's the module that is calling `(include "/gnu/store/my-packages.scm")`.
<lilyp>point being your build container probably doesn't see the file
<lilyp>even if, include by filename is not the right way to go for packaging things
<katco>yeah, obviously. this is for work and will never see the guix repository, and it's one of the reasons it's so weird.
<katco>i'm trying to remember: does the build container need to be able to see the included file where the package definition is?
<superkamiguru>Does anyone know where I could reference for adding a service that runs a mount script on startup? I looked through simple-service but am a little confused
<apteryx>I think you could make your own one-shot service
<apteryx>shepherd service
<apteryx>but I don't have an example at hand
<superkamiguru>Ok, I will look into one-shot services! thank you!
<superkamiguru>So I have a shepherd service written but my guix system reconfigure keeps failing. Is there something obviously wrong with my service?  paste.debian.net/1280131
<apteryx>sneek: later tell civoldul strange, inspecting the jami tests by hands, everything seems fine
<sneek>Got it.
<apteryx>sneek: later tell civodul inspecting the jami tests by hands, everything seems fine
<sneek>Will do.
<apteryx>sneek: later tell civodul at any rate it's just the tests which are failing :-/
<sneek>Okay.
<ngz>Hello. Do you know where is the `warning' function in Guile? It doesn't look Guix specific but I can't find the right module.
<next4th>ngz: it's in (guix diagnostics)
<ngz>Ah.
<ngz>Thank you.
<jpoiret>hi guix
<jpoiret>ngz: you can use a guile repl for this, `,m (whatever module uses warning)` to get in the context of that module, then `,apropos warning`
<jpoiret>superkamiguru: you should remove the #$ around the command line, and each argument should be in its own string
<ngz>jpoiret: Nice to know. Thank you. Anyway I it seems I cannot use `warning' in a (guix build xxx-build-system) module.
<lilyp>ngz yeah you'd typically raise an exception or simply format a message to the output port
<ngz>I used (format (current-output-port) "warning: look out behind you!"), but I don't know if that's state-of-the-art.
<jpoiret>ngz: yes, you should only use (guix build ...) modules in there, with rare exceptions
<jpoiret>I would rather use (current-error-port), but not that in format you can replace (current-output-port) by #t (yes, shortcuts!)
<jpoiret>note *
<ngz>I meant (current-error-port) indeed.
<ngz>My brains failed me when I typed the port name.
<soundmodel>does Guix make any reference to BSDs?
<soundmodel>because yesterday I was debating whether to go back to FreeBSD or try Guix
<soundmodel> https://www.reddit.com/r/GUIX/comments/ce2kkx/comment/etzss18/ 4 years ago
<jpoiret>soundmodel: Guix hasn't been ported to BSDs
<soundmodel>but I was confused why it targets Linux in the first place
<soundmodel>because it could bridge the gap between them
<soundmodel>if this became a popular project
<lilyp>if you want to port guix to bsd you'll probably encounter some problems with the kernel and libc
<lilyp>it aims to be a gnu system after all
<soundmodel>yes but I think BSD is fundamentally better OS
<soundmodel>so I don't understand why such projects targets Linux
<lilyp>what do you think is better about BSD? the kernel or the userland?
<soundmodel>because I interpreted Guix to be an "universal operating system"
<soundmodel>that it's purposedly designed rather than a hobby projected converted to mainstream OS
<soundmodel>project*
<soundmodel>I'm not an expert, but I've read that the code is higher quality
<soundmodel>and it also has some newer features
<carmenshea[m]>soundmodel: Does BSD offer you a specific tool or work flow that cannot be found elsewhere?
<soundmodel>no I just like the license and that I believe it has been made by smarter people than Linux
<soundmodel>and I thought that it lowers the appeal of Guix
<soundmodel>that it's based on Linux
<carmenshea[m]>soundmodel: why not try the full guix system in a vm?
<soundmodel>but it cannot alter the design decisions inherent to Linux already
<Guest503`>I think in the long term Guix should primarily run on GNU Hurd, which seems more smartly designed than Linux
<Guest503`>There's a GNU/Hurd vm already
<soundmodel>that I've not tried
<soundmodel>but Wikipedia says: "When the Linux kernel proved to be a viable solution, development of GNU Hurd slowed, at times alternating between stasis and renewed activity and interest.[4]"
<soundmodel>so maybe Linux is some sort of economical decision
<jpoiret>Guest503: *currently broken though
<rekado>I wonder if pyproject-build-system has a bug when it comes to using configure-flags
<jpoiret>soundmodel: Linux is the more widespread kernel for hobbyists I would say, so I guess it was a natural choice at the beginning
<soundmodel>yes but I thought that such project could lead people elsewhere
<jpoiret>I don't think anyone would be opposed to Guix having support for BSDs, but that requires quite some work
<soundmodel>that's why I think such flagship project would fit to the imago problem of BSDs
<soundmodel>rather than strengthen the use of Linux
<jpoiret>well, that's not the goal of Guix, the kernel is just a tool here
<soundmodel>but obviously it becomes fixates to the choice of kernel?
<soundmodel>fixated*
<jpoiret>it's just the simplest, and you have to keep in mind that choosing a more niche kernel would have brought less contributors over the years
<soundmodel>initially yes
<soundmodel>but it could also change the popularity of things
<jpoiret>it doesn't, anyone is free to add BSD support, it just takes time that contributors would like to spend elsewhere
<soundmodel>okay so then we'd probably need to know the essential parts of the project
<soundmodel>so that in theory it can be built on BSD
<soundmodel>yes and that's probably the case driving for the Linux compromise
<soundmodel>but I think it's a path that will be worse later on because the ground is looser
<jpoiret>you'd need to port the daemon on BSD, that's the first step I guess. Then, you'd also need to add support for FreeBSD syscalls wherever Linux syscalls are used, and add support for having a different libc per-system
<soundmodel>BSDs don't e.g. have problem of multiple incompatible distros
<jpoiret>wdym by this?
<soundmodel>no I didn't think one'd need to port it
<jpoiret>I'm not sure you can download a binary built by some BSD and run it on another BSD without fiddling around
<soundmodel>but just implement essentially the same thing using BSD
<soundmodel>I believe you can as long as you are using FreeBSD and not NetBSD or something
<soundmodel>but as it has only three major distros that are separate in design
<soundmodel>then it's much easier than with Linuxes
<soundmodel>not flatpak mess etc.
<jpoiret>rather it's exactly the same as linux, but with less distros
<soundmodel>and 1st class support for clang
<soundmodel>and plenty of modern unix features because it's extended unix
<lilyp>which modern unix features exactly?
<soundmodel>e.g. ZFS
<lilyp>you mean the "fuck the gpl" file system?
<soundmodel>yes I do think BSD is a nicer license also
<jpoiret>clang can be used to build linux
<soundmodel>yes but with that it's more about the question of how much bloat Linuxes already carry
<soundmodel>I also liked that fact that if your hardware is not the newest then BSDs can run possibly with 20-30% less resources.
<soundmodel>with nearly the same features
<soundmodel>and that it's a coherent OS
<soundmodel>whereas Linux is mainly a kernel
<jpoiret>Looks like you might want to run a BSD then
<soundmodel>but these were just reasons why Guix could've made sense on BSD
<Guest503`>if you like FOSS, I don't understand why you would want to help people make proprietary software? aren't the benefits of foss software clear? bsd license enables to make fundamentally bad software
<soundmodel>no but it allows also integration of commercial interest without limiting free software
<soundmodel>whereas GPL explicitly bans commercial sotware
<soundmodel>in practice
<next4th>yeah, Linux is a kernel, GNU is not. I think Hyperbora BSD re-license OpenBSD code to GPL?
<soundmodel>but tbh I'm not sure what Guix offers over BSDs in the first place
<soundmodel>I was just interested in the idea of an universal operating system
<soundmodel>because of how most Linuxes suffer from incompatilibities
<soundmodel>incompatibilities*
<next4th>when Hyperbora BSD is a thing, i think Guix will make sense on there :\
<Guest503`>most of the copyleft software does fine though, even without being backed by big corporations. take guix for example
<indigo-oce>git is failing to pull anything --  git: 'remote-https' is not a git command. See 'git --help'
<madage>was there ever a glibc 2.34 on guix?
<madage>I'm getting a strange error message: https://paste.debian.net/1280146
<jpoiret>madage: have you updated all your profiles?
<indigo-oce>what's the latest guix commit that successfully builds for you... I'm getting a 'provile.drv' fails to build... I just want something that works so it could be older
<jpoiret>indigo-oce: what's the log?
<madage>jpoiret: you mean if all users have already upgraded?
<madage>no, no actually
<madage>but this user profile has and it's on the same commit as the system
<indigo-oce>jpoiret https://paste.debian.net/1280147
<indigo-oce>jpoiret does that tell you anything useful?
<indigo-oce>jpoiret ohh... I think I know the issue...
<madage>ah but the software I'm torifying has not been upgraded, I'm carrying it from an older installation since it has been dropped from guix
<indigo-oce>is there a guide to remove gdm from guix?
<indigo-oce>(nvm I'll see if i can figure it out... I tried a while ago to no avail)
<jlicht>hey guix!
<mekeor[m]>hi guix
<mekeor[m]>indigo-oce: idk. maybe it's part of desktop-services by default?
<indigo-oce>mekeor[m] it is, and it's very annoying... no idea why anyone would use it... it's caused so many bugs and doesn't display colors properly on my screens (some screens are yellow, some are red, and none display all the colors)
<indigo-oce>it really shouldn't be there by default... you should have to select your dm in your config.scm
<jpoiret>madage: that's the reason I think
<jpoiret>that piece of software might be trying to load some libs from the profile which are compiled with glibc 2.35 while this one was built with 2.33. Thus the glibc 2.35 never gets loaded, causing the error
<jpoiret>indigo-oce: you can (delete gdm-service-type) from the services
<jpoiret>using (modify-services ...)
<indigo-oce>trying that now (building linux takes a while)
<soundmodel>ah https://www.hyperbola.info/ I had not heard about
<soundmodel>I thought hyperbola was a Linux distro
<soundmodel>looks interesting
<soundmodel>well there are two separate projects
<soundmodel>but the rationale behind the BSD variant is here https://www.hyperbola.info/news/announcing-hyperbolabsd-roadmap/
<indigo-oce>using (modify-services %desktop-services (delete gdm-service-type)) in services list doesn't remove it for me (I just rebooted and it took longer to activate (I was in the middle of logging in to tty when it came on) but it's still there)
<indigo-oce>I see file-system-/var/lib/gdm in 'herd status'
<Kabouik>A quick question about substitures: when a prebuilt package is available for an architecture on the substitute servers, is it because it was cross-compiled by the servers themselves, or do they become available to everyone once one user compiled them for the arch on their own device?
<Kabouik>I suspect the latter would be a security risk, but just asking, as I'm not sure how this all works.
<madage>jpoiret: any tips on getting around this? I mean, besides creating + maintaining a channel with this piece of software?
<chomwitt_>is there a package with xorg ISO 10646 fonts ?
<Kabouik>Any ideas on what is wrong there? I did it twice, got the error twice: https://hastebin.skyra.pw/evagegajap.bash
<madage>like some linker env var?
<madage>or rather, is this expected on guix? such as using '--do-no-upgrade [package]' is bound to break in the long run?
<mfg[m]>bordeaux seems to throw 502s for me, doe sit work for anyone else?
<mfg[m]>Also: the package in question is emacs-queue (it's a dep). guix weather emacs-queue tells me it's available on ci.guix, so why does the error lead to guix throwing an exception and exiting? It should just try another mirror and only exit when none work
<cbaines>mfg[m], it's down at the moment, hopefully it'll be back online within 30 minutes
<mfg[m]>Ah, okay :)
<Kabouik>mfg[m] I am having the same error, see just above
<Kabouik>With just guix pull.
<Kabouik>Thanks for the info cbaines!
<cbaines>the --fallback option should get Guix to continue, even if it fails to substitute something
<Kabouik>--fallback didn't help for me (still getting a 502), I'll wait a bit
<foxfromabyss>thanks @grim` that helped :)
<Kabouik>Is the server back online? I am still getting 502.
<user_oreloznog>Kabouik: same here
<cbaines>not yet, it's still reconfiguring (running the guix testsuite at the moment)
<user_oreloznog>Ah OK :)
<cbaines>bordeaux.guix.gnu.org should be back online now
<chomwitt_>where can i find /var/log/syslog ?
<next4th>chomwitt_: those files (message, debug, secure, etc.) under /var/log/ are written by syslog.
<chomwitt_>next4th, you mean i must enable a service ?
<next4th>yes, by default guix system has a 'syslogd' shepherd service running.
<chomwitt_>indeed i see syslogd running
<next4th>that should be fine
<chomwitt_>but why one message that i see in /var/log/messages would appear in my tty1 while working ? (in a desktopless system)
<next4th>where the output from? they may not send it to syslog
<iyzsong[m]>cbaines: i have got coordinator agent running on my riscv64 vf2, next is try connect it to the bordeaux right? my net to bordeaux is very slow though...
<chomwitt_>but i see it my /var/log/messages : vmunix [864.448737] xpad 1.4:1.0 xpad trying sending out packet , usb_submit-urb failed
<chomwitt_>the same message appead in my tty1
<cbaines>iyzsong[m], yep, I'll send you the details via email
<chomwitt_>s/appead/appeared
<cbaines>the slow connection shouldn't be a problem though, the machines I host have a very slow connection too
<iyzsong[m]>okay, thanks 🚀
<mfg[m]>chomwitt_: tty1 also is the default console, right? so some messages end up there, if you find that annoying try working on tty2. You should not have these messages there.
<chomwitt_>mfg[m], can i make a system change to see at boot the tty2 ?
<chomwitt_>or change the ''console'' tty?
<mfg[m]>I also remember that there were some things going on with shepherd, where some messages managed to escape it's redirection and ended up in console. But i'm not sure if this has been fixed in the meantime
<chomwitt_>i see a couple of messages also in my tty1's login prompt
<mfg[m]>i don't know the precise syntax, but console is a linux parameter, i.e. console=/dev/ttyAMA0 (don't use that tho, this is serial)
<chomwitt_>sth about not finding a firmware
<mfg[m]>Do you see these messages roght after boot?
<chomwitt_>yes!
<mfg[m]>Ah this is normal then
<chomwitt_>always the same two messages
<mfg[m]>maybe agetty has an option to clear the screen before asking for username and password, this should be an option of agetty-service then
<chomwitt_>but a couple of times like today i saw a message in my tty1 while working
<next4th>yeah, i see those too, unless you 'quiet' the kernel, it will output message to tty1
<next4th>that's expected, kernel will output message when something happends
<mfg[m]>afaik linux will always log to dmesg and console
<Kabouik>Thanks cbaines!
<chomwitt_>mfg[m], next4th so i will try to search in kernel boot options and agetty options
<mfg[m]>though i didn't know you can use quiet :D
<chomwitt_>by console we mean just a tty that kernel uses for output or there is more ?
<mfg[m]>console means the parameter that gets passed to linux when the bootloader starts it
<mfg[m]>it is literally 'console='
<chomwitt_>mfg[m], i see. cool
<chomwitt_>so it could be even a printer like in the old days.
<chomwitt_>just the primary output stream of the kernel ?
<mfg[m]> https://guix.gnu.org/manual/en/html_node/operating_002dsystem-Reference.html
<mfg[m]>here look for the kernel-arguments field
<mfg[m]>i think this is what you need
<mfg[m]>i guess you could also use a printer, yes :D
<chomwitt_>mfg[m], i read your link. are there somewhere examples to see of various system config settings ?
<chomwitt_>as i see it is there a logic in presenting in the user a tty in the same tty that we wont to use as kernel console ?
<chomwitt_>s/presenting/presenting a login tty
<mfg[m]>if your use case is to only work headless in tty1 then i think it's actually a bad choice, but most users start a graphical session so they won't actually notice
<chomwitt_>also i wonder (a tty tangent question) if i want a certain tty to have different permissions can i do (should i do) that in the config.scm ?
<cbaines>iyzsong[m], I'm having gpg problems emailing you, the public key I got from Savannah has some expired subkeys
<mfg[m]>i don't know what you mean with "permissions for a tty" but the agetty service can be configured differently depending on which tty it is running.
<iyzsong[m]>cbaines: oh, let me check my key
<chomwitt_>mfg[m], i mean like chmod g+wr /dev/tty7 for example
<mfg[m]>as for config examples, here is mine: https://paste.debian.net/1280155/ this may help you, but i'm not sure. Other os configs can be found with google i suppose
<mfg[m]>chomwitt_: what does that do? I mean i don't see why i would want to directly write to a tty device.
<chomwitt_>ACTION likes to think of a login manager's gui session as an option that you can add on top or in parallel of a gui-less interaction not in conflict with it..
<chomwitt_>mfg[m], i needed to start X
<chomwitt_>start X without startx or xinit
<chomwitt_>as a user i mean . and X wanted to access tty7
<chomwitt_>i wonder how xinit grabs tty7...
<Altadil>Hi, is there a way to check if guix is correctly getting substitutes from a "guix publish" server on the LAN ?
<chomwitt_>mfg[m], thanks for your config examples
<iyzsong[m]>cbaines: my gpg keys should be updated now
<mfg[m]>chomwitt_: okay i see, i don't know how you would accomplish that
<mfg[m]>in my config you can see, that i run different processes depending on which tty i'm on, so my default session on tty1 starts my graphical session, but tty2 is without gui and tty3 is without gui and doesn't use my normal shell (which is zsh)
<jlicht>Does anyone have a link to their dotfiles for setting up piem/public inbox for the guix mailing list?
<cbaines>iyzsong[m], I've emailed iyzsong@member.fsf.org now
<iyzsong[m]>got it, thx
<cbaines>I'm busy for the rest of today but do let me know how you get on, and I'll catch up replying to emails later :)
<iyzsong[m]>cbaines it's building now!
<iyzsong[m]>np, thank you
<muradm>hello guix
<muradm>6bc3e3f9ba commit by switching cups package to cups-minimal in cups-configuration broke "find printer" with "Unable to execute ippfind utility: No such file or directory"
<muradm>ippfind is not included in cups-minimal
<muradm>are users supposed to explicitly set normal cups in cups-configuration?
<next4th>muradm: the commit message said it fix a serious issue which prevents user from login.. does install cups as a system package make "find printer" useable?
<next4th>may report a bug to the mail list (bug-guix)
<muradm>next4th: yeah, looking at commit and #63198 issue.. i don't understand the issue "loop on authenticating my user".. it was working before just fine
<muradm>next4th: it is not worth adding cups as system package. better to override (cups-configuration (cups cups) ...)
<next4th>okay, you can try that, in the worst case (described in the issue) it should be the same situation (not able to add printer), i thougt it will prevents normal users from login (which seems wrong).
<muradm>still i wonder what does it mean "loop on authenticating my user".. i suppose that would happen if user trying to manage printers not in group lp
<muradm>if it is so, then it is not worth it switching to cups-minimal as default
<muradm>next4th: issue does not mention that "it prevents login"
<next4th>yes, i guessed from the commit message :\
<muradm>yeah, commit message whole another story, authenticating where?
<next4th>i think you can reply to #63198 with the "right fix", i don't use cups so not sure.
<civodul>comrades, the Shepherd 0.10.0 is in the house!
<sneek>Welcome back civodul, you have 2 messages!
<sneek>civodul, apteryx says: inspecting the jami tests by hands, everything seems fine
<sneek>civodul, apteryx says: at any rate it's just the tests which are failing :-/
<civodul> https://lists.gnu.org/archive/html/guix-devel/2023-05/msg00180.html
<civodul>🐑
<jpoiret>🎊
<jpoiret>i'm trying to build a new hurd with glibc 2.37. Let's see where we go. I'm also getting rid of the hardcoded i586-pc-gnu that's everywhere, so that we can try x86_64 in the future :)
<jpoiret>I wonder how we can provide a different libc for hurd in the future, if that works
<jpoiret>and we really have to convince upstream to make some actual releases with compatibility notes!
<civodul>jpoiret: hey! why 2.37 actually, since it pre-x86_64-gnu?
<iyzsong[m]>🐑 cheers for hurd
<indigo-oce>using this still fails to remove gdm...
<indigo-oce> (modify-services %desktop-services
<indigo-oce>            (delete gdm-service-type)
<indigo-oce>            (delete gdm-file-system-service))
<jpoiret>civodul: just to get a newer Hurd, not the most recent one
<jpoiret>indigo-oce: can you post the relevant part of your config at paste.debian.net?
<indigo-oce>jpoiret https://paste.debian.net/1280167/
<civodul>jpoiret: yes but maybe we can have that without a libc upgrade?
<civodul>jpoiret: once upon a time, we did use a different libc variant for the Hurd: see commit 2d546858b139e5fcf2cbdf9958a17fd98803ac4c
<civodul>we can do that if needed, but it's best avoided
<jpoiret>civodul: Hurd really needs a newer libc since september
<jpoiret>that's why I chose versions that were a little older than that when trying to build Hurd back then
<civodul>jpoiret: oh right
<civodul>this is all so confusing :-)
<jpoiret>basically i'm now just praying that a newer set of commits for everything will just work™
<jpoiret>(highly unlikely, but I really don't know how to debug the current failure)
<janneke>"<jpoiret> and we really have to convince upstream to make some actual releases with compatibility notes!"
<janneke>
<janneke>+1
<janneke>(including their rump kernel fu)
<Guest19>since cups is now openprinting, it doesn't find my hp envy network printer. can someone help me out?
<Guest19>i have configured cups as it is and only activated the web interface.
<GNUtoo>hi, is btrfs inside LUKS inside LVM supported / supposed to work?
<jpoiret>GNUtoo: it should be yes, but you need to specify LUKS before LVM in the mappings
<GNUtoo>ok thanks
<jpoiret>make sure to use LUKS1 for now
<jpoiret>LUKS2 support should come with the upcoming GRUB2 release
<GNUtoo>Yes, I have to use a /boot for now because I don't have grub yet
<GNUtoo>*a separate /boot
<GNUtoo>Guest19: I'm not familiar with Guix cups setup but the web interface can also add printers. Though you might need to install some additional drivers if your printer is absent from the list of supported printers in the web interface.
<GNUtoo>jpoiret: I think that there is some LUKS2 support in the last release but if I recall well it's incomplete, like it doesn't support the default LUKS2 settings (it probably lacks a cipher or hash or scheme)
<jpoiret>yes, grub-install doesn't detect and include the crypt modules for luks2
<jpoiret>support in the next release is by yours truly :)
<GNUtoo>wow nice
<Guest19>GNUtoo well, I don't even know which drivers.  It worked out of the box before and now not. hp-setup doesn't even support network discovery and I don't know why.  For now I just use a Fedora VM since I do not have the time to fiddle it out.
<civodul>jpoiret: you rock!
<GNUtoo>If drivers are needed, they will likely be in hplip, but that's probably for older printers
<civodul>hey ho! thoughts on 'guix style -S arguments'? https://issues.guix.gnu.org/63320
<Guest19>hplip is already in cups included as from the docs
<GNUtoo>ok, so it should be ok then
<jpoiret>guix cross compilation really is terrible
<jpoiret>it's been running for 40mins+
<jpoiret>civodul, janneke: well well well. Still getting the same hang with everything from ~december
<jpoiret>and glibc 2.37
<janneke>jpoiret: crap
<jpoiret>on the upside, I've removed some more of the hardcoded --host=i586-pc-gnu
<janneke>nice
<jpoiret>I don't know who we could ask for help though
<jpoiret>one thing I noticed is that the debian packaging appears to have a couple of patches applied on top for some reason
<janneke>yeah, i remember trying many glibc and hurd patches before to get the previous hurd to boot
<janneke>it's terrible
<Kabouik>Is there a way to skip the "check" stage in guix install, or is it part of the package definitions and therefore mandatory? I'm installing more than 350 packages and installing/compiling just about 5 of the took more than two hours.
<Kabouik>Admittedly cmake is a large one and took a long time alone, but there are other big ones coming in the rest of the list.
<guixfren>Does anyone here have experience with Guix + SELinux?
<guixfren>as in Guix on a foreign distro with SELinux
<guixfren>I have already read the docs and installed the policy but it's not enough
<guixfren> https://unix.stackexchange.com/questions/665599/how-to-allow-guix-daemon-to-remount-in-selinux
<guixfren>I got to the state described here
<muradm>hello guix
<muradm>apteryx: #63198
<lfam>Why is `git rebase` asking for my GPG password now
<janneke>not a fast-forward rebase?
<bjc>#63261 could use comments if you don't like the gpg thing
<bjc>it's closed, but still open for discussion
<lfam>It's fine, but how can I turn it off
<lfam>It seems to be overriding my .git/config
<ennoausberlin>Hi. I have packages in two distinct private channels. How can I specify that channel one knows about packages from channel two?
<bjc>i added a patch to etc/git/gitconfig which comments it out
<bjc>but you're going to have to live with that in your git log forever
<bjc>(i don't think it's fine, in case that's not clear) =)
<lfam>Where was the original change discussed?
<bjc>dunno
<bjc>i only found out about it by going through the commit logs
<lfam>It was on display in the bottom of a locked filing cabinet stuck in a disused lavatory with a sign on the door saying ‘Beware of the Leopard'.
<lfam>So, does this mean you can't even do exploratory Guix development without a GPG setup?
<lfam>I guess, I don't even understand what's going on. My .git/config has gpgsign=false, but it still seems to be required. How does that work?
<janneke>ACTION is using git config extensions.worktreeconfig true, together with
<janneke>git config --worktree commit.gpgsign false, on scratch worktrees
<janneke>anyway, that used to work up till recently
<lfam>I'm sure this was discussed, it would be helpful if anyone could help me find the discussion
<lfam>I see, it uses the gitconfig include path mechanism
<bjc>lfam: one of the steps during make calls ‘git config’ to include ‘etc/git/gitconfig’ in your local config, so that's how it gets included
<bjc>and yes, it means you need a gpg key to do just about anything
<janneke>there is the after-the-fact https://issues.guix.gnu.org/63261
<bjc>or patch it out. which feels bad as a first commit =)
<lfam>Can't say I love it
<lfam>Still looking for discussion
<bjc>i don't remember seeing it on the ml. there might have been some in irc that i missed
<janneke>worktree config still works fine, fwiw i always had gpgsign = true in my .git/config
<bjc>i hate working with gpg, and the thought of having to use it all the time fills me with dread
<ennoausberlin>Say, I have created a channel and there is a module defined as (define-module (public-guix packages public-guix) ... with packages defined with (define-public ...
<ennoausberlin>How can I include packages from the above module into a second channel using use-module?
<lfam>bjc: Yeah, I fear it will turn away a large number of would-be contributors
<bjc>i think with slightly more pushback on it, apteryx would be open to reverting that part
<bjc>i love the rest of the patch, just the gpg thing is a bit much
<lfam>Alright, I'm still just trying to get up to speed on the process. It's a really big change, there must have been a consensus
<lfam>Well, I sent an email asking for a pointer to the discussion. I have to go for now
<jpoiret>i'm surprised you can't just override that directly though
<jpoiret>I would've guessed included files have lower precedence
<lilyp>does anyone know which program is putting salt into everyone's $HOME?
<jpoiret>wdym salt?
<lilyp>a literal file called salt
<jpoiret>lilyp: ENOENT :)
<lilyp>well i've rm'd it for like the 5th time already, so ENOENT here as well
<singpolyma>touch salt && chattr +i salt and see what crashes?
<oriansj>well normally I'd suggest grep -iR salt /gnu/ but that is too short of a search term; does it occur randomly? and if so, you can log what processes are running round the time which it occurs.
<jpoiret>uhmmmmm, my hurd vm is booting
<jpoiret>wow!! I poked around with all the default translators and servers and it's booting now! Don't know exactly which was needed
<jpoiret>sshd cannot bind (probably because of the netdde changes) but I could login as root
<jpoiret>civodul, janneke
<jpoiret>that with the one we have on master right now
<janneke>jpoiret: \o/
<janneke>...poked around with the default translators?
<jpoiret>yes, the ones we set-up on boot before calling mach-defpager
<janneke>ah, right
<jpoiret>i was looking at the differences we have with Debian's
<janneke>oh my...
<bjc>if you ever have the time, i would love a wee guide to getting the hurd started
<janneke>jpoiret: looking forward to your patch(es)
<Guest71>Hi #guix,
<Guest71>I've recently installed Guix on Fedora and I am quite happy how well it works.
<Guest71>But I've a question. Is there a package, that provides the javac command?
<bjc>openjdk?
<Guest71>It only seems to install the JRE (Java Runtime Environment).
<jpoiret>janneke: okay so I think I figured out what the problem was and you're going to laugh
<janneke>or cry?
<jpoiret>so we set-up some devices and translators early on, by using the servers under /hurd/...
<jpoiret>but i noticed that uhhhh. We symlink the gnu/store/....-hurd/hurd/ directory only after that 😳
<jpoiret>I wonder how it was working before
<janneke>that's in (set-hurd-device-translators), right?
<jpoiret>yes
<janneke>oh my
<janneke>that's...weird -- how did that ever work?
<janneke>so, you move the symlinking up before the setup-translators call?
<jpoiret>yes, that's it (maybe some translators I've added also help, haven't tried with only that change yet)
<mfg[m]>Guest71: you may need the jdk output, so openjdk:jdk, this should also include things like jshell
<janneke>jpoiret: changing only the order of the symlink does not seem to help here
<janneke>so you must have made another change that is essential
<jpoiret>yes, that might be true
<jpoiret>i'll try to figure this out tomorrow, as well as getting netdde to work
<jpoiret>i'm thinking we could start looking into breaking up the big hurd package into a lot of smaller packages containing each different server
<jpoiret>or libraries
<Guest71>mfg[m] That solved the problem. Thanks!
<Guest71>But why though?
<Guest71>Because packages can have multiple outputs.
<euandreh>I have a (file-system-mapping ...) for a container that maps /run/current-system/locale
<euandreh>but now this directory points to other parts of the store
<euandreh>it is a "locale-multiple-versions" type (I guess some packages depend on different versions of glibc)
<euandreh>i'll try to put something like (single-locale-directory ...) instead of the literal string /run/current-system/locale
<euandreh>so that the file-system-mapping works back again
<civodul>jpoiret: yay!! well done!
<civodul>jpoiret: we don't use netdde though, do we?
<civodul>we use the in-kernel rtl8139 driver to communicate with VMs
<chomwitt_>i see mingetty running and in gnu/store i can see the man pages exist, but $ man mingetty says no manual entry for mingetty
<Michal_Atlas[m]>Hello Guix, I'm trying to init a Guix system on a lvm-cached volume, and it seemed to go well up until the reboot when apparently the dm_cache kernel module is needed, and it doesn't seem to suffice to use the kernel-module-loader-service? Am I out of luck? Do I have to compile my own kernel with the module inside to boot like this? Or am I missing some option somewhere?