IRC channel logs

2023-01-07.log

back to list of logs

<gnucode>Also, once I had set up the linode, I could not login as root. Nor could my non-root user do anything as sudo, because his password had not been set.
<gnucode>So all I had to do was log into the server via linode's graphical console (as root) and run "passwd" & "passwd joshua". Then all was well.
<lechner>gnucode / thanks for that guide from me, too. i used it back in April and filed a bug with a few small suggestions but am not sure they seem so relevant anymore #55105
<bugtitle>[PATCH] Guix on Linode update <https://issues.guix.gnu.org/55105>
<bl0rt_tmp>gnucode Thanks, I'm going through all the steps now. Can you avoid the sudo issue by running visudo at some point before you finish, or does that not work with guix SD?
<bl0rt_tmp>whoops, just saw your followup
<gnucode>:)
<lechner>bl0rt_tmp / passwd is probably all you need
<gnucode>lechner: Nice additions in that patch.
<lechner>gnucode / i'm not sure why they seemed to warrant an update at the time, but okay
<lechner>no one's picked them up, anyway
<gnucode>Those changes should probably be included in guix proper...
<gnucode>just out of curiosity why did swap-devices need to change the syntax?
<nckx>It used to be a list of strings, so you could only say ‘please use these devices/files as swap space’, nothing more.
<nckx>See <https://git.savannah.gnu.org/cgit/guix.git/commit/?id=9685c0637decec77880cec65547a2e57c300761a>.
<bl0rt_tmp>gnucode: I'm a little confused about the step '("root" ,(local-file "janedoe_rsa.pub")', do I really need to save my ssh public key somewhere on the server if it's already in .ssh/authorized_keys?
<vivien>Oh no! If I want to make p11-kit use the meson build system, I have a circular dependency within (gnu packages tls) too! p11-kit -> meson, meson -> openssl (in (gnu packages tls)).
<vivien>I could also take openssl out of (gnu packages tls), but the git log is MUCH longer than that of meson
<vivien>There are pages for (gnu packages tls), but then I also have to look at (now deleted) (gnu packages gnutls)
<vagrantc>yeah, circular dependencies ... are nasty
<vivien>That’s the only solution I see though. If I take p11-kit out of (gnu packages tls), then I have to somehow take gnutls out too because it depends on gnutls
<vivien>That’s not even a circular dependency between packages
<vivien>That’s a circular dependency between guile modules
<vivien>That’s very very stupid, we only have enough problems with package circular dependencies
<vivien>we already have enough problems*
<gnucode>bl0rt_tmp: you probably need it there.
<gnucode>When you guix system init you'll need it.
<gnucode>But try without and see if you can log in.
<LuminousPath>For the cargo build system, is it normal for cargo to recompile everything during the install phase?
<LuminousPath>Trying to write a package for WASM-pack and there’s a default feature that activates a feature in an upstream package (rust-openssl-sys) that’s patched out of the package by guix
<LuminousPath>And like I can just turn that off by default by sending cargo the `—no-default-features` flag in build and test
<LuminousPath>But I can’t do that in the install phase and it tries to build an Incompatible feature and errors out
<LuminousPath>I wonder if I should try and replace the install phase, or patch that line out of the cargo.toml myself
<LuminousPath>I’m new to guix and scheme so I’m curious if people generally try and avoid inline patching source if they can
<bjc>patching source is very common in guix, and pretty easy to do
<bjc>i don't know how cargo-build-system works, so i can't really answer your question, but my gut says that patching the .toml file will be the easiest and least error-prone way to do what you want
<LuminousPath>That is exactly what I was hoping to hear lol
<kitty1>yo, hows it goin?
<lfam>Howdy
<lfam>I'm wondering if anyone can help me figure out why my Cuirass job is not registering any new derivations: https://ci.guix.gnu.org/jobset/kernel-updates
<lfam>Is there any way I can run this "by hand" to get more output than what is in cuirass.log? Or how should I approach debugging this?
<lilyp>LuminousPath: yes, we sadly have to do as cargo demands with cargo-build-system. There is work on developing a better one (antioxidant-build-system), but IIRC it's not ready yet.
<rekado>moving java bootstrap stuff to a new module is quite difficult because of module cycles
<rekado>running “make” only works when java.scm is already compiled
<vivien>I wish we could have 1 package for 1 scm module
<vivien>Maybe we could organize the (gnu packages) directory so that it is not flat, and have (gnu packages java stuff1), (gnu packages java stuff2)… and then a big (gnu packages java) that would re-export everything but the bootstrap packages?
<vivien>Or isolate the bootstrap stuff in (gnu packages java bootstrap stuff1), (gnu packages java bootstrap stuff2) … and have the real thing in (gnu package java stuff1)
<vivien>Maybe what I’m saying is meaningless
<vivien>I’m trying to get gnulib into guix (https://issues.guix.gnu.org/60358) but now I’m wondering whether it was a good idea to put it in (gnu packages build-tools) and not in its own module. I mean, gnulib is used by a lot of projects, and so it’s reasonable to predict that it will be very deep in the dependency chain at some point
<bugtitle>[PATCH] gnu: Add gnulib. <https://issues.guix.gnu.org/60358>
<PurpleSym1>vivien: I learned the hard way that Guile has a hard limit on number of concurrently loaded modules (about 8000).
<vivien>:(((
<PurpleSym1>But I agree that one module per package would be a reasonable way to split things. I mean: haskell-xyz has 600 packages, python-xyz more than 1000 and compilation times for each of them are hitting multiple seconds on a fast machine.
<vivien>To be fair, that would be even slower if we had 1600 more one-package files
<vivien>But the compilation time seems like a very small issue if we can’t properly bootstrap packages because they are blocked by module circular dependencies
<PurpleSym1>I was assuming it would be easier to parallelize builds if modules are independent.
<vivien>Oh absolutely
<PurpleSym1>Ohwell, back to my edit-make-build cycle of haskell-xyz.
<unmatched-paren>Hello, guix. :)
<vivien>What about we created a code generator that would scan through all modules, order them by dependency (look at #:use-module (gnu packages thing)), and then generate a module pack? That would be 1 huge module, but at least we could have 1 package per file in the source.
<vivien>And we could actually detect circular dependencies because the sort would explicitely fail
<tex_milan>Hello, I have question about guix packages and hot it is done when an application uses its data in /usr/share/APPLICATION folder. Does the recipe has to change the application to use guix path? The same applies also for libraries that are dynamically loaded?
<unmatched-paren>tex_milan: if the data is immutable, then yes, change it to #$output/share/APPLICATION
<unmatched-paren>if the data is mutable, you have a profoundly borked application on your hands :)
<tex_milan>unmatched-paren: thanks. it will be my application, so data will be immutable :)
<unmatched-paren>tex_milan: shared libraries should simply be installed to #$output/lib
<tex_milan>unmatched-paren: I was asking about dependencies, I met one rust application that dynamically loads libEGL library.
<tex_milan>it tries /usr/lib/... with obviously fails.
<unmatched-paren>tex_milan: ah, then patch it to point to #$(this-package-input "mesa")/lib
<paul_j>Morning guix!
<unmatched-paren>paul_j: hello!
<paul_j>I was trying to resolve an issue yesterday where starting the guile interpreter and entering a simple expression [eg ( + 2 3) ] would return the result [$1=5], then report "Fatal Error: glibc detected an invalid stdio handle" followed by "Aborted", and returning to the shell prompt.
<paul_j>Since then, I have removed some cruft from my system and home configuration files, run "guix gc", reconfigured the system and then home and rebooted. The problem still exists in the window manager, in an st shell. I get the same result in a urxvt shell. When I switch to a different console and log in without the X environment, everything works as expected. I am look for ideas where to look next to resolve this. I am running guix system,
<paul_j>and everything is upto date.
<paul_j>There was a suggestion this could be related to environment variables - here are the environment variable currently declared: https://paste.debian.net/1266413
<festerdam>Hey, I'm trying to reinstall guix from a blank state on a foreign distro, since it somehow got messed up. How do I remove the /gnu/store? sudo rm -rf /gnu doesn't work.
<festerdam>It tells me it's a read-only file system.
<nckx>Unmount it.
<nckx>After stopping the daemon.
<nckx> /gnu/store is the real location, but it's bind-mounted over *itself* read-only, to prevent accidental modifications. The daemon 'peeks under' that bind mount to manage items.
<festerdam>Thanks! For some reason the dæmon wasn't stopped.
<nckx>OK now I never want to spell daemon any other way.
<nckx>ACTION configs the ligs.
<bjc>i'm gonna need a bigger font
<nckx>ACTION recommends font-google-noto. It's the yugest.
<bjc>i have it, but i'm using iosevka for most stuff because all the cool kids like it
<bjc>but the æ character is basically illegible. it looks like a backwards s with two lines through the middle
<ecbrown>hic hæc hoc
<ecbrown>yeah that's pretty dreadful with iosevka 20
<paul_j>Ok - reference my problem with guile earlier: if I remove ~/.guile, then everything works as expected. I don't believe I have ever edited this file, so I would be interested in the contents of other ~/.guile files. Here is mine: https://paste.debian.net/1266422
<paul_j>What is in yours?
<nckx> https://paste.debian.net/plainh/72f56fe4 but the default one should, of course, not break in this way.
<paul_j>nckx: Thanks. On the basis that this doesn't seem to be a well reported issue, I suspect there is something else in my configuration which is causing the problem. How can I confirm what the default contents should be?
<nckx>But yours looks like the default?
<nckx>It's set here: https://git.savannah.gnu.org/cgit/guix.git/tree/gnu/system/shadow.scm#n185
<paul_j>Mmmm... strange it is then. I'll keep digging and see if I can find out what is actually causing the problem. That it is only a problem in X windows (dwm and stumpwm) might provide clues. I'll try one of the full desktop environments (like xfce) and see what that does.
<tex_milan>anyone using python-selenium? having trouble with it... `browser = webdriver.Firefox(executable_path="icecat", capabilities={'browserName': 'icecat', 'marionette': True, 'acceptInsecureCerts': True})` fails with selenium.common.exceptions.WebDriverException: Message: Service icecat unexpectedly exited. Status code was: 0
<civodul>ACTION sends patch adding '--with-version'
<civodul> https://issues.guix.gnu.org/60629
<bugtitle>[PATCH 0/3] Add '--with-version' package transformation <https://issues.guix.gnu.org/60629>
<ecbrown>oh this is magnificent
<bjc>anyone around who can help me get hacking on shepherd? the readme assumes you're working from a tarball, rather than a git checkout
<bjc>‘guix shell -D shepherd -- autoconf’ works, but trying to run configure afterwards produces: configure: error: cannot find required auxiliary files: install-sh config.guess config.sub
<bjc>oops, sorry, autoconf doesn't work: guix shell: error: autoconf: command not found
<bjc>i got a configure script earlier from a manifest i made by hand that had autoconf/automake in it
<mirai>tex_milan: change the path
<mirai>the icecat package comes with the webdriver
<mirai>but I think it's under a different name
<rekado>do you have any recommendations on how to trace module cycles?
<son0p>hi, I'm trying to configure the keyboard-layout, I can't find the supported layouts, the manual mention "share/X11/xkb directory of the xkeyboard-config package" but I can't find that directory, I have looked for in .guix-profile/share and .guix-home/profile/share
<vivien>Module cycles are so annoying
<vivien>That’s not an answer I know
<son0p>oh, sorry I had not installed the xkeyboard-config pagkage
<vetrivln>Hello, I compiled emacs master branch with (inherit emacs-next) and configure "--with-native-compilation=aot"; Now on loading my config it returns a `ld: cannot find crtbeginS.o` on evaluating (require 'with-editor)
<vetrivln>Any idea what causes this?
<vetrivln>Full error message: https://bpa.st/BORTG
<mroh>vetrivln: what does "M-x describe-variable native-comp-driver-options" give?
<vetrivln>nil
<rhn>hi! how do I log in to a GuixSD Docker container? I managd to build one and run in podman, but it doesn't seem to have any console yet
<civodul>bjc: try "autoreconf -vfi"
<vetrivln>mroh: the problem is probably that patch-compilation-driver no longer works
<vetrivln>because the default value is changed
<vetrivln>in master branch
<civodul>rekado: i would do (resolve-module whatever) at the REPL and look at the backtrace
<vetrivln>a temporary workaround would be to find the locations manually
<vetrivln>but i have no idea what is #$(this-package-input "foo")
<vivien>Does the maximum number of modules in guile increases with 3.0 module inlining?
<vivien>increase*
<bjc>civodul: working for now, though i did have to add "gettext" to my manifest for autopoint. i confess, i don't know why ‘guix -D shepherd’ isn't working for me, but i can try to figure that out later
<civodul>bjc: that's because the shepherd package is built from a tarball, not from a checkout
<bjc>ok
<civodul>we should add a manifest.scm
<bjc>assuming i can get this working, would you like a manifest.scm that can be used?
<bjc>that answers that =)
<rhn>okay, podman exec + adding /var/guix/profiles/system/profile/bin/ to PATH seems to get me somewhere
<drakonis>hmm, perhaps the guix landing page could use something more informational than videos
<civodul>drakonis: what do you have in mind?
<tex_milan>mirai: browser = webdriver.Firefox(executable_path="/gnu/store/vwml4z06mq1qfyc8mmkz8lnrknzznvi3-icecat-102.5.0-guix0-preview1/bin/geckodriver") => selenium.common.exceptions.SessionNotCreatedException: Message: Unable to find a matching set of capabilities
<tex_milan>mirai: maybe version incompability between selenium a icecat?
<drakonis>civodul: maybe written versions of the videos?
<drakonis>a discussion was taking place elsewhere and someone brought up that the instructional videos could've been articles
<civodul>the top of the page does link to actual text though
<drakonis>yeah i mentioned that.
<drakonis>i've arrived late to the discussion as it took place while i was away from my computer
<drakonis>i'll be back with some concrete feedback when possible
<civodul>heh sure :-)
<rhn>how do I find the name of the service? guix edit: error: ssh-daemon: unknown package
<civodul>rhn: try "guix system search ssh" for example
<civodul>and "guix system edit openssh"
<rhn>civodul: thanks! now how do I get rid of nano :P?
<civodul>rhn: remove it from the 'packages' field of your OS :-)
<civodul>i think it's in %base-packages
<civodul>so you can (delq nano %base-packages)
<rhn>I hope $EDITOR works
<rhn>I'm not going to stay in the shell too much once I set it up anyway
<drakonis>civodul: the message in question
<drakonis>drakonis: I'm missing an equivalent to "Everyday use of GNU Guix" in text form (judging by the title) there's lots of things on that page, but nowhere a "gentle introduction to guix concepts", not even anything like a tutorial, which IMO should be front and center "try it out" goes to "download" and leaves me cold
<civodul>drakonis: yeah, that makes a lot of sense to me
<drakonis>cool.
<civodul>so yes, we should link to Features.html (or similar) and Getting-Started.html
<civodul>something along these lines
<drakonis>we don't exactly have anything for that just yet, now do we?
<drakonis>the introduction in the manual isnt particularly serviceable as a feature list
<civodul>yeah, it's outdated and too technical
<civodul>we do have this: https://guix.gnu.org/manual/en/html_node/Getting-Started.html
<civodul>that's a start i guess
<drakonis>that would serve, yeah.
<drakonis>but it is written under the assumption that you're going to follow every hyperlink to other sections of the manual
<drakonis>which in itself isnt a bad thing
<drakonis>if you're going to make something standalone you're going to need to add some more information
<superkamiguru>So I am trying to get docker running on my guix install, and have everything working except the net.bridge.bridge-nf-call-iptables sysctl option.
<drakonis>plus it deals with basic guix operations, none of the system management ones come into play here
<superkamiguru>When I try to set it with modify services the sysctl service fails to start. Do I need to have something else enabled for net.bridge options to work?
<drakonis>definitely has room for improvements
<drakonis>it should be fine to open up a issue for tracking documentation improvements, right?
<civodul>drakonis: sure; try to keep it focused and actionable
<civodul>just noticed that the manual has "System Troubleshooting Tips" before "Getting Started", uh
<drakonis>fair enough
<ecbrown>./pre-inst-env guix shell emacs --with-version=emacs=28.1 -- emacs -Q -nw --batch --eval '(message emacs-version)'
<ecbrown>28.1 (hosanos)
<ecbrown>pretty darned sweet civodul
<rhn>how do I find the definition of a service? things it provides, things it requires?
<ecbrown>small comment: repeated invocation needs to re-download source code
<rhn>best I found is gnu/store/bv2qjwhm3zzl2ymgb93fx5ih62y853bl-shepherd-ssh-daemon-ssh-sshd.scm but it's clearly generated from something else
<civodul>ecbrown: heh, glad you like it :-) and yes, it redownloads because it can't know in advance what it's gonna get
<ecbrown>cool. also, it hits a snag if one is too aggressive back in time, e.g. back to emacs 27.2
<ecbrown>perhaps definition changes too much?
<civodul>oh yes, that's "at your own risk"
<civodul>rhn: "guix system search" shows that info
<civodul>there's also "guix system extension-graph" and "guix system shepherd-graph", depending on what you're looking for
<rhn>nice, thanks! somehow I missed that when I looked there
<rhn>a-ha! found the workaround: dummy-networking-service-type
<rhn>so, uh, can I give a dummy filesystem to "guix system reconfigure"? there's no need for that when I'm in docker
<old>Anyone has a quick operating-system recipe to prevent any suspending of a desktop?
<old>I don't know why, but my main computer keep getting suspend in deep state after locking my gdm session for a few minutes
<old>Like it was suspended dues to laptop lid closed on battery ..
<civodul>rhn: i think so, or you could just as well regenerate the docker image instead of using "reconfigure" inside of it
<rhn>I want to learn the guix tools in the container, and I guess fighting odd breakage is just an excuse to learn more :P
<civodul>heh
<mirai>old: configure gdm
<mirai> https://paste.centos.org/view/0f6edc0d
<attila_lendvai>mirai, i get "extraneous field initializers (auto-suspend?)", even though i'm fully pulled. why on earth? i checked the code, and it's there in the guix repo...
<attila_lendvai>maybe i should reconfigure once without it, and only enable it afterwards?
<mirai>this assumes that you're using some kind of desktop service
<attila_lendvai>i am, it's a standard laptop (used as a server)
<mirai>and notice the modify-services
<rhn>so I included the file that contains (define dummy-networking-service-type ...)
<rhn>the include is: (use-modules (gnu system linux-container))
<rhn>but when i put it under services, I get: error: dummy-networking-service-type: unbound variable
<mirai>attila_lendvai: do you have (inherit config) right after gdm-configuration?
<rhn>what am I doing wrong?
<attila_lendvai>mirai, i tried to add this to an already working config (yes)
<mirai>very strange
<mirai>I'm not aware of any updates to that service
<mirai>can you paste your config?
<mirai>rhn: is that variable exported?
<attila_lendvai>old, if it's a laptop, you may want this, too: https://paste.centos.org/view/0976f1e1
<attila_lendvai>ACTION first investigates it, and tries the hypothesis that it's a bootstrapping issue
<rhn>mirai: thanks!
<mirai>yw
<old>attila_lendvai: It's a tower. My laptop works fine as expected
<old>I was looking to something maybe kernel wise to prevent any type of suspend/hibernation
<old>my tower must be up 24h a day
<daviid>old: is this desktop 'tower' using gdm?
<old>yes
<old>I've changed switch off "Suspend when laptop lid is closed" in gnome-tweak to see if that was the problem
<daviid>ok, then you ne3ed to disable an option or switch to lightdm, which i did, because i was horrified the gnome team made this change without 'any warnings' and i was managing remotely, few servers ... that day, a few y ago now was a total disaster for me and a all bunch of researchers ...
<daviid>old: it is a gdm option, not a user option
<daviid>but i highly recommend you switch to lightdm, and stilluse gnome as a desktop if you wish ...
<old>Eeeh what did they do?
<old>Quick recipe for changing to lightdm?
<daviid>i switched to lightdm :) - but let me see if i cn find the setting, i think others here also know ...
<daviid>just install lightdm, remove gdm and restart
<daviid>the services, no ned to reboot
<attila_lendvai>daviid, it's to "comply with EU legislation"... [further comments are self-censored]
<old>Btw I said I use gdm, but I don't have the gdm-service-type in my config
<old>I suppose it's gdm
<old>by default
<old>pgrep confirms
<daviid>old: config are in /etc/gdm3 [or the corresoinding guix dir ...]
<old>So just adding a (service lightdm-service-type ...) should suffices?
<daviid>attila_lendvai: do you know what option we need to set to avoid 'auto sleep' mode in gdm3 confs files?
<attila_lendvai>daviid, scroll up just a little for the guix config. otherwise: https://askubuntu.com/questions/1168830/how-to-disable-screen-power-saving-in-gdm3-login-screen
<daviid>old ^^
<daviid>attila_lendvai: tx
<old>daviid: I get [+630.45s] DEBUG: Seat seat0: Failed to find session configuration default
<old>with lightdm
<old>after good authentication
<old>And lightdm shows "Failed to start session"
<old>I will try with auto-suspend? #f instead for GDM
<mirai>old: if you're using gnome service type it automatically pulls gdm service
<mirai>daviid: a reboot is needed
<mirai>since it also controls the login manager
<old>I ended doing: (modify-services %desktop-services (gdm-service-type config => (gdm-configuration (inherit config) (auto-suspend? #f))))
<attila_lendvai>mirai, FTR, my error was that i was doing the pull+reconfigure in a `sudo -s` shell, as opposed to a `su -` one.
<zacchae[m]>mirai: I don't think that is right. gdm comes from %desktop-services normally. I have a config with (modify-sernices %desktop-services (delete gdm-serice-type)) AND (service gnome-service-type) which results in no gdm
<mirai>does gnome not imply %desktop-services
<mirai>oh, maybe it doesn't
<mirai>then yes, it's part of %desktop-services
<the_tubular>Anyway to run docker rootless on guix system ?
<daviid>old: ok, as i don't use guix, i would edit the /etc/gdm3/greeter.dconf-defaults - as suggested by the link, it has the options commented, and explains tose ... i never had that problem with lightdm ...
<KarlJoad>In my OS config, how can I specify a package output? I want the utils output from the bind package.
<KarlJoad>Avoiding specification->package, if I can.
<daviid>mirai: both my exp and the blog suggest a service gdm reload; restart is sufficiant
<daviid>i never reboot remotely manaed servers unless forced to ...
<mirai>there's no gdm service to reload though?
<mirai>do you see it under herd status?
<daviid>mirai: just stop and restart, or just restart gdm is enough, no reboot is, ime, needed, fortunately -
<stikonas>the_tubular: do you mean podman, not docker?
<the_tubular>No, I meant docker
<stikonas>hmm, no idea about docker then... Haven't used it for some time now
<the_tubular>Me neither, I also used to use podman, but it's pretty borked on guix and relys on systemd way too much.
<the_tubular>But it seems to be possible : https://docs.docker.com/engine/security/rootless/
<stikonas>though the guide still uses systemd user services
<stikonas>so you might end up running into the same problems
<bjc>i have podman working on guix, but not rootless
<bjc>iirc, the guix version is/was too old when i last tried rootless, like 4 or 5 months ago
<the_tubular>Can you bind port to your host bjc ?
<bjc>i don't know, i wasn't using it that way
<the_tubular>There was a bug when I used it not so long ago that I couldn't share a port with my host.
<the_tubular>The interface doesn't get created AFAIK
<bjc>i do have these lines still in my config:
<bjc> (service cni-dhcp-service-type)
<bjc> (service podman-network-service-type)
<bjc> (service lxd-service-type)
<bjc>
<bjc>iirc, cni is for rootless, so can probably be ignored
<the_tubular>You got rootless working ?
<bjc>no
<the_tubular>bjc does podman update works ?
<the_tubular>I might reinstall it and test it some more
<bjc>i don't know what “podman update” is
<bjc>you mean ‘pull’?
<the_tubular>No, update
<the_tubular>It updates images and restart containers using it
<the_tubular>I think they also made podman clone
<bjc>ah, then i don't know. my container use is pretty simple, honestly, so i'm probably not the best person to ask about most things
<rhn>yay, I can ssh into my podman container :)
<rhn>still can't reconfigure, it's failing on some firmware update
<Gooberpatrol66>when i try to build the kernel with CONFIG_KASAN=y, the build fails with no error message
<rhn>what's the command to remove an arbitrary derivation from the store?
<raghavgururajan>rhn: `guix gc --delete [derivation]`
<rhn>thx, gonna try this
<rhn>okay, how do I list all things that depend on the derivation?
<rhn>I want to minimize my image
<rhn>...guix core really pulls in poppler?
<Aurora_v_kosmose>Where does Guix even get test-assert from?
<nckx>rhn: No, but it does pull in libxau & two copies of xz & gzip :) Ooh, and two different point versions of Guile. The good news is, it just about fits on a 650-MiB CD.
<rhn>okay, then how do I get rid of poppler :P? guix gc doesn't really help me ditch cruft recursively
<nckx>Does anyone here experience infinite lock-ups with btrfs? Or am I just lucky again?
<rhn>and I'm not ven sure if I'm reading the output right
<nckx>I didn't mean that nothing else is pulling in poppler, just that it's not the guix package proper.
<rhn>it's in guix-manual
<rhn>I'm only exploring guix to put it on the Turris router, so being able to ditch cruft is a make-or-break condition
<nckx>What's cruft?
<rhn>anything graphical
<lilyp>well, you better drop texlive from po4a then, have fun
<jpoiret>if you use `guix size $(readlink -f ~/.guix-profile)` and `guix size $(readlink -f ~/.config/guix/current)` you can check out what's actually needed by your profiles
<nckx>‘guix size …guix-manual.drv’ is taking forever… so far.
<nckx>I forgot about (guix self), I was looking at the ‘guix’ package.
<jpoiret>why is po4a kept as a reference
<nckx>Good thing these things have 8 GiB of storage.
<nckx>jpoiret: Is it?
<jpoiret>it's not, i just checked
<nckx>OK, just checking. It's required to build guix-manual (guix graph --path po4a poppler, rhn) but shouldn't be needed afterwards.
<nckx>If you want this installation to be self-hosting, building packages on your router like a normal individual, you'll have to customise how Guix itself is built. If not, you'll merely have to define a good number of other custom packages that don't build whatever's considered ‘cruft’.
<nckx>Since there's no meaningful definition of cruft, and Guix isn't Gentoo, that level of customisation's not currently a goal.
<mirai>I guess what they meant to say is a "guix subset suitable for embedded systems"
<mirai>think of openwrt
<nckx>My point is everyone defines that differently.
<jpoiret>that and if you use substitutes you don't have that problem
<nckx>Oh cool, aarch64 ‘guix-other-archs’ substitutes are back.
<nckx>ACTION buggers off to see why PPC64s aren't.
<nckx> https://ci.guix.gnu.org/build/325057/details yay