IRC channel logs

2021-09-19.log

back to list of logs

<rekado>PurpleSym: the static pandoc is a bit hacky, but it’s necessary in order to dramatically cut the closure size for pandoc (and packages using it like rmarkdown).
<rekado>it uses package-closure to collect all transitive Haskell inputs
<rekado>that’s probably how it gets the wrong GHC somehow
<GNUtoo>hi, is it easy to build some go software locally in Guix?
<GNUtoo>I've a build failure with "guix build matterbridge --with-latest=matterbridge" and I don't really know how to fix it
<GNUtoo>ah scratch that, I meant with updating matterbridge to the lastest version within guix sources
<GNUtoo>The "guix build matterbridge --with-latest=matterbridge" somehow fails to download the tarball while the latter has a different error
<GNUtoo>I've some "go install [...] failed with stats 1, but not much clue about the cause
<GNUtoo>It says that though: "src/github.com/42wim/matterbridge/bridge/vk/vk.go:15:2: found import comments "github.com/SevereCloud/vksdk/v2/api" (account.go) and "github.com/SevereCloud/vksdk/api" (store.go) in /tmp/guix-build-matterbridge-1.22.3.drv-0/src/github.com/42wim/matterbridge/vendor/github.com/SevereCloud/vksdk/v2/api" but it doesn't tell if it's an error
<brettgilio>nckx what is the nick of the blake, the person who was looking for me yesterday?
<iskarian>GNUtoo, you may need to use an older version of Go
<iskarian>Ah, nevermind, I misread that
*GNUtoo is trying to add it as dependency somehow but I don't really know go
<iskarian>Try `guix import go -r github.com/42wim/matterbridge'
<iskarian>wait...
<GNUtoo>I'm doing that for the dependency here
<iskarian>ah, the current matterbridge vendors everything
<iskarian>how did that get committed?
<GNUtoo>What's wrong? the lack of dependencies?
<iskarian>yeah, according to go.mod, there's about 30 dependencies, and they're all bundled in 'vendor'
<GNUtoo>Here I was trying to update it first and then look at that later on
<iskarian>Ha! Let me take a look and see if I can find the issue with the update
<GNUtoo>Is the way to go something like rm -rf vendor and adding the dependencies?
<GNUtoo>And the reason of why it got commited is that I probably mentioned this potential problem too late in the review process
<GNUtoo>btw, for github.com/SevereCloud/vksdk you need to disable tests
<GNUtoo>It assumes that it runs in a git tree
<iskarian>Here's an issue for it: https://github.com/42wim/matterbridge/issues/1551
<GNUtoo>ohh
<iskarian>Looks like it needs Go 1.16 or up (which we have), but it still shows the same error for me using Go 1.16. Hmmmm
<GNUtoo>go build in matterbridge works in Parabola at least
<GNUtoo>It has go 2:1.17.1-1
<iskarian>Yeah, same error with go 1.17
<GNUtoo>Same here even with propagated inputs for that package
<GNUtoo>Maybe we need to unvendor that package first?
<iskarian>Well, as an easy fix you can just substitute* account.go and/or store.go and remove the comments next to the first line
<iskarian>that's... vendor/github.com/SevereCloud/vksdk/v2/api/account.go
<GNUtoo>Thanks
<GNUtoo>:q
<GNUtoo>oops
<GNUtoo>Hmmm it probably needs to be done on all vendor/github.com/SevereCloud/vksdk/v2/api/*.go
<GNUtoo>Thanks a lot for the help
<iskarian>No problem
<iskarian>It's odd; the documentation says "import path checking is disabled for code found within vendor trees"
***califax- is now known as califax
<iskarian>Hmmm, after editing the manual, I'm getting "no htmlxref.cnf entry found for ..." warnings
<guix2021>web
<guix2021>Web, file:////home/.../xxx.html can't be open
<guix2021>instead, it is downloaded...
<guix2021>Hi
<guix2021>for Web browser installed with guix 1.3 ,loal html file ( file:////home/.../xxx.html) can't be open, instead , it is downloaded
<guix2021>for Web browser installed with guix 1.3 ,local html file ( file:////home/.../xxx.html) can't be open, instead , it is downloaded
<guix2021>How to open the local html file in gnome Web ?
<drakonis>shouldnt it be file:///home/.../xxx.html?
<drakonis>you can try icecat instead
<guix2021>you mean to use another web browser
<guix2021>to replace default gnome Web ?
<guix2021>typo, it is "file:///home/.../xxx.html"
<guix2021>you could try to test it, in your gnome Web...
<char>Is there a good way to figure out which inputs are needed to be native-inputs?
<iskarian>char, think about if you were cross-compiling, native-inputs would be anything that needs to be able to run on the compiling machine
<iskarian>inputs, on the other hand, would be anything that needs to be able to run on the machine the program will run on
<moshy>nckx: WildMidi support now appears to be compiled in. But now I receive the following when it tries to play a Midi file
<moshy>Debug: WildMidi Failed: WildMidi: Could not find configuration file.
<moshy>was told fluidsynth is a better option, but might have to wait until 0.7 for player to release
<PotentialUser-35>If you have lvm on luks, do you just have the lvm-device-mapping after the luks-device-mapping in mapped-devices? or is there something else you need to add?
<nckx>sneek: later tell brettgilio: cybe rsyn, one word.
<sneek>Got it.
<PurpleSym>rekado_: “a bit hacky” is an understatement… I can build it now after filtering “ghc-next” as well, but the daemon reports: cycle detected in the references of `/gnu/store/a0wcf4bcw8xr24zwys0idah2gvbpprwj-pandoc-2.14.0.3' :/
<PotentialUser-35>Is there way to boot guix on luks2 or is that just not supported?
<rekado_>PurpleSym: have you figured out what the cycle is?
<PurpleSym>Absolutely no idea, rekado_. Only the pandoc binary has any greppable references and they’re itself, glibc, bash-minimal, pandoc-lib, gcc, lua, gcc-lib.
<PurpleSym>And zlib.
<PurpleSym>(Here’s the full output: https://paste.debian.net/1212333/)
<geex3>PotentialUser-35: looks like it uses "open --type luks" by default and u would need to copy and modify to --type luks2
<dissoc>is it possible to have sound working in a guix environment --container ?
<nckx>geex3, PotentialUser-35: Don't do that (yet)! You'll be on your own, at the very least, and it may well break boot.
<Kimapr[i]>hello, i'm trying to run some services in `guix environment` containers but i noticed that when killing the process (with `kill`'s default, SIGTERM), the processes inside the container continue running, which is not what i want. how do i make them terminate too?
<nckx>If you're aware of the risks (mainly to your free time‌ :), you can convert LUKS1 to LUKS2 (and back) in-place as, long as it started life as 1.
<Kimapr[i]>looks like sending a SIGINT instead achieves the desired result
<nckx><knowing nothing 'bout 'tainers> …weird?
<Kimapr[i]>however, i'm using runit's runsv to run the container, which always sends TERM when shutting down a service (but it does have a separate command to send an INT)
<derby>Hi All. I found the following problem while trying to install guix (standalone) on qemu. Did you know? For this reason you have provided the version for qemu? https://paste.pics/cc74119a4b65cf7bda5754fe4be637cc
<nckx>derby: That doesn't look like a QEMU issue. Was /dev/vda already partitioned (as GPT) when you started the installation?
<nckx>If you boot with BIOS, or UEFI in legacy CSM mode, and provide GRUB with a GPT-formatted drive, it needs a BIOS Boot partition of roughly a megabyte to be able to install.
<nckx>The installer could warn if it encounters a drive without one in BIOS mode.
<nckx>However, if you partition vda from scratch, it should create one.
<derby>nckx no. He did it all. I just set up full disk encryption. It set the first partition to about 2MB if I remember correctly.
<nckx>Could you send a bug report to bug-guix at gnu dot org, derby, and include the steps (command line, URL of installer image used, menu choices) needed to reproduce this?
<nckx>I can try to reproduce it this evening.
<derby>if it helps, I can repeat the installation and save the screenshots
<nckx>If you have the time.
<nckx>Thanks! Gotta go.
<derby>nckx, no, no, thanks to you! :D
<raingloom>heyyy folks, could someone help with setting up jupyter? i'm running into an internal server error thing.
<derby>this time the installation was successful but does not find the encrypted disk https://paste.pics/99b7a9d4b9833f47d89bf0e717225b09
<derby>nckx this is the default configuration done (like the previous one) https://paste.pics/0d54d04cb2e7cb82095f3a6d03044395
<apapsch>Hi guix! Geisers M-. works if I do C-c C-a (Switch to REPL and current module). Can geiser do the module switching automatically when I switch to another buffer?
<pkill9> how do you install guix to a system that's already running?
<pkill9>i think some people do that
<pkill9>if i do that it says /gun/store is read only so that won't work
<pkill9>unless i unmount it
<pkill9>and don't worry about the risks of data loss, I have that covered
<pkill9>kinda doing it in a sandboxed environment
<apapsch>pkill9: installing guix in a system that has guix running? sandboxing calls for chroot or linux container
<apapsch>bind mount /gnu/store and /var/guix
<apapsch>pkill9: in the hetzner cloud rescue system I was able to initiate guix installation, even while / is mounted read-only. something along the lines:
<apapsch>mount /dev/sda1 /mnt; cd /mnt; mkdir alt-store; mkdir /gnu; mount --bind /mnt/alt-store /gnu
<apapsch>well, / was not read-only but had very little space
<TechnologyTim>Hello, I have a noobie question about guix. How do you install the Whisker menu in XFCE ? Because when I install it, it doesn't appear in the widgets menu ?
<pkill9>TechnologyTim: have you logged out and in again? if you havne't that might help
<apapsch>pkill9: and I had to apply this little patch to the guix install script: https://paste.debian.net/1212353/
<moshy>TechnologyTim: You'll need to set it up in /etc/config.scm, then sudo guix system reconfigure /etc/config.scm
<TechnologyTim>moshy: Oh, ok. Didn't think about that. Thanks :)
<moshy>you'll want to add a line saying: (specification->package "xfce4-whiskermenu-plugin") under the packages section
<TechnologyTim>Thanks I'll try it right away. Thanks for the help ;)
<moshy>yw. this may also apply to other xfce plugins, but haven't tried them all
<TechnologyTim>Yeah, that makes sense. I'll probably try it on some more plugins
<moshy>you may also want to add "sound" under use-services-modules if you also intend to run audio playback apps
<moshy>service*
<TechnologyTim>Yeah, that's a good tip. Thanks again !
<roptat>hi guix!
<psypops>hi roptat :)
<derby>bye
***KE0VVT is now known as Beigeinator
***Beigeinator is now known as KE0VVT
<pkill9>how do you find out what triplet your current systme is?
<pkill9>system*
<nckx>pkill9: ’gcc -dumpmachine’
<efraim>unless you wanted (nix-system->gnu-triplet (%current-system))
<apapsch>hello, adherents of the Perfect Setup. I'm now trying to hook into geiser-guile mode to call geiser-mode-switch-to-repl-and-enter, but it feels like I'm missing something, as Geiser chapter 1.1 Modus operandi says "Every time you switch to a different file, you're switching namespaces automatically"
<apapsch>guix manual boasts about M-. (geiser-edit-symbol-at-point), but it doesn't work out of the box and the effort required to make it work seems quite counterintuitive
<cybersyn> /join #scheme
<brettgilio>thanks, nckx
<sneek>Welcome back brettgilio, you have 1 message!
<sneek>brettgilio, nckx says: cybe rsyn, one word.
<brettgilio>Appreciated
<attila_lendvai>so, while building, $out is pointing straight into a /gnu/store/somehash... directory, and the files are under the user:group of the builder. when the check phase runs, some files are unreadable for the app that i'm packaging (Idris2). i assume it's because they are chowned to root:root only in a later phase? but i don't see where. any hints how i can make sure everything in $out is readable?
<attila_lendvai>this may be because the files are installed by idris itself? when i ls -l the directory, permissions and user/group is all question marks
<attila_lendvai>hrm, or this is only an issue when i try to debug this after entering a --keep-failed state? and i'm looking at a different problem? but i cannot chown them, as the store is read only... any hints to look at?
<apapsch>attila_lendvai: ls -ln shows numeric uids
<attila_lendvai>apapsch, oh, i see now that the relevant directory doesn't have g+x on it
<apapsch>this is on guix system? Uids change when you reorder services in operating-system
<attila_lendvai>or o+x for that matter
<attila_lendvai>apapsch, i'm just doing a `guix build -f mypackage.scm`
<podiki[m]>I've had to add a phase to make all files writeable for some packages (to prevent a permission denied error)
<apapsch>hmm, ok, I don't know enough internals :-)
<attila_lendvai>so, the issue is: files are installed into $out by the app itself, and with the wrong permissions. maybe i'll just chmod -R in a phase after 'install
<podiki[m]>i.e. add a phase with
<podiki[m]>(lambda _
<podiki[m]> (for-each make-file-writable (find-files ".")))
*attila_lendvai tries
<podiki[m]>so maybe something similar you can do
<podiki[m]>(error I was getting was in install phase, but added a phase after unpack and that worked for my error)
*attila_lendvai has found the place in Idris that creates the dirs, and it uses S_IRGRP instead of S_IRXGRP
<efraim>Perfect Setup reminds me I need to add the vim version
<nckx>efraim: <unless you wanted> …that was… plausible… erps.
<nckx>Goes to show I've had entirely too little time to Guix and too much $other_stuff getting in the way.
<apapsch>nckx: surely $other_stuff without leaving emacs. with the webkit widget there's now no need to leave fullscreen. actually ditch the window manager ;-)
*nckx still resists using WebKit.
<nckx>Although this week the local bus company added their site to the ‘why test on anything but Chrome?’ shamewall.
*nckx tried eww; didn't work.
<muradm>nckx: how do you do guix profiles, if you do, without leaving emacs? :)
<iskarian>morning Guix! What's new?
<apapsch>eww uses shr.el "simple html renderer", which means it's doomed when it comes to non-static websites
<apapsch>to me text browsers and other "simple" engines look like a battle against windmills
<nckx>Oh, yeah, I do my browsing in Firefox, to be clear. eww is *great* on a rescue system (no need to include {e,}links :o) but is, regrettably, doomed.
<nckx>muradm: Hm, not, sorry.
<nckx>s,Firefox,&/IceCat,
<pkill9>except for gemini browsers
<nckx>I KNEW IT
<nckx>I knew someone was going to pipe up with the Gemini.
<efraim>nckx: The other gcc one-liner I've used recently is: gcc -E -dM - < /dev/null | grep riscv
<efraim>needed to figure out how to determine riscv64 in macros
<apapsch>ah, the great gopher never died, it seems :-)
<nckx>😄
<pkill9>lol
<nckx>RE5007: Fine, I admit, I give up, I don't get it.
<nckx>Is it ‘reboot’ (and if so, who hurt you in 1337); do you just really like restoring chimneys to their original historical condish; what.
<RE5007>lol
<nckx>arg.
<RE5007>I just try to pick a "random" username for every service. The day I set this username I saw one of those "oomer" memes with the phrase "I have to RESOOT!" with a drawing of Klaus Schwab.
<RE5007>Don't read too much into it.
<efraim>TIL you can't create a hurd-raw image on riscv64-linux
<nckx>RE5007: Cool! And I haven't been misreading it all this time, after all.
*nckx ~> foodz.
<nckx>efraim: That's… cool, but the need for a redirect (and hence a shell) irks me in ways hard to describe.
*nckx ~> now really foodz.
<admas>What's the best way have packages installed that come from hacking Guix source tree? Should I be making a Guix channel from a fork of the Guix repo?
<dstolfa>admas: you could, or you could just do ./pre-inst-env guix package -i ...
<dstolfa>it's preference :)
<admas>Can you use pre-inst-env with a manifest file?
<dstolfa>i would assume so, yes
<admas>Thanks! I'll try that out.
<itd>Hi. Why does `guix system reconfigure` (re-)start some shepard services but not others? E.g., a change in `cuirass-configuration` does not restart cuirass, but the output mentions that `ntpd has been started`. Thanks.
*itd gets confused by `(name "my-name")` [1. example: 1]; which seems to work. Because [2] states `name` should be a symbol and `(symbol? "my-name")` is `#f`. [1]: https://guix.gnu.org/en/manual/devel/en/html_node/Continuous-Integration.html [2]: https://guix.gnu.org/cuirass/manual/html_node/Specifications.html
<maximed>itd: Does (name 'my-name) work as well?
<maximed>Possibly Cuirass should be adjusted to: (a) raise an error if a string is used instead of a symbol, or (b) change the documentation to indicate both are allowed
<muradm>gnu/packages/admin.scm (shepherd): #:configure-flags '("--localstatedir=/var") any idea why?
<itd>maximed: yes, it appears to work (didn't notice any issues so far)
<maximed>itd: Maybe sent a patch implementing (a) or (b) or a bug report
<itd>ok, thanks
***Xenguy_ is now known as Xenguy
<maximed>apapsch: afaik, uids don't change by mere reordering, but they can change after removing the service and adding it again
<maximed>it's a known bug
<nckx>efraim: <but the need for a redirect> That was a very nckx way (sorry) to say ‘thanks! I've added that to my snippet list’ ☺
<lilyp>what's bad about webkit tho?
<nckx>God, remember the *Kit year…
<nckx>It came after the *-ng era.
<nckx>What's it now? I haven't followed.
<lilyp>I think now is the rust-* decade
<nckx>Tru.
***xgqtd is now known as xgqt
<voroskoi[m]>if I create my own channel where should I put the patch files to `search-patches` to find them? I always get `patch not found` errors
<iskarian>voroskoi[m], you would typically make your own 'search-patches'
<slyfox>having a patch in the same directory as a .scm file should work
<iskarian>Are we no longer using staging?
<iskarian>(because of improvements in feedback from CI/GDS?)
<roptat>iskarian, I think we're still using it?
<roptat>why do you think we're not? We're focused on core-updates right now, but that doesn't mean we can't use staging if it makes sense
<iskarian>Ah, so we are. It was last merged in february; I thought it was supposed to be a quicker-turnaround than core-updates
<GNUtoo>iskarian: btw, about matterbridge, I tried rm -rf vendor && go build on Parabola and it worked, so that looks promising, but I didn't find a way to partially remove one dependency from vendor/ and keep the other
<GNUtoo>As I could build github.com/SevereCloud/vksdk under Guix and that I still have issue after the substitute I was wondering if the way to go was to unvendor for that lib and step by step unvendor for more and more libs
<GNUtoo>s/btw/hi/
<iskarian>GNUtoo, yeah, it's pretty much all-or-nothing with vendoring
<GNUtoo>ah ok I see
<iskarian>it's a bit of a hack, but you could add a phase after 'setup-go-references which moves 'vendor' to a temporary location 'orig-vendor', then creates a directory union of 'orig-vendor' and $build-path/src in 'vendor'
<iskarian>s/setup-go-references/setup-go-environment/
<GNUtoo>ohh good idea
<GNUtoo>I could even probably rm -rf vendor and copy things back in place
<GNUtoo>or rm -rf part of it only
***sneek_ is now known as sneek
<iskarian>Ah, yeah, what I'd do is in a snippet, remove 'vendor/this/package/is/an/input'
<GNUtoo>or did you meant that source code and build directories have to be separated with go?
<iskarian>setup-go-environment creates /tmp/guix-build-whatever/src, and copies the source of all inputs into it, so you'd have src/github.com/somebody/package and so on (this is using GOPATH mode)
<iskarian>all go inputs*
<iskarian>and your package is unpacked in, for example, src/github.com/whomever/matterbridge
<GNUtoo>oh wow
<GNUtoo>Thanks a lot
<iskarian>:)
***Xenguy_ is now known as Xenguy
<civodul>sneek: later tell mbakke hi! you mentioned a problem with the bit-field change in base32.scm; is there a bug report about it?
<sneek>Got it.
<jab>hey guix people! I thought I am super impressed with racket's gui-easy library I must say. I should probably try to play with guile-gi a bit more too...
<vivien>jab, you must eval (use-typelibs ("GdkPixbuf" "2.0")) before Gtk
<vivien>If you want to go with guile-gi :)