IRC channel logs

2021-09-18.log

back to list of logs

<nckx>lilyp: ‘We tried it at home and it worked on *both* Ubuntu laptops! Ship it!’
<lilyp>Pfft, obviously not. Let's also check with Greg, who uses Mint.
<dstolfa>nckx: not only did it work on the one ubuntu laptop, but the kubuntu laptop too!
*nckx nods. Sometimes you just want to quit ().
<rekado_>now I have all the libs but it crashes with this error: Fontconfig error: Cannot load default config file: No such file: (null)
<rekado_>bah.
<nckx>dstolfa: So you're saying it's operating-system agnostic?
<nckx>Wow.
<dstolfa>indeed.
<rekado_>guess i’ll have to build this from source
<rekado_>oof
<dstolfa>nckx: i have OS-agnostic ansible scripts too. they work on RHEL, alma, rocky and oracle linux
<rekado_> https://github.com/keyboardio/Chrysalis
<dstolfa>very very portable
<lilyp>On a more serious note, I think "most Linux machines" means "Debian and Fedora, maybe also Gentoo and Arch"
<lilyp>obviously x86 :)
<the_tubular>Can guix fetch rpivate git repositories ?
<the_tubular>I'm planning for guix-home and there are some configs I'm not ready to make available to anyone yet
<pkill9>nice, it built on my vps
<dstolfa>lilyp: on one hand i understand it, time constraints and all that... but on the other hand :-(
<lilyp>I mean, we already have a format that's known to work on most* Linux distros, and that's called source code.
<lilyp>You can even make it binary through compression :)
<dstolfa>well eh, not really... you could easily depend on something that some distros don't ship
<dstolfa>it's not that easy sadly
<lilyp>remember we don't need all distros, but most*
<dstolfa>and then you have to take into consideration of supporting just linux vs supporting other operating systems as well
<lilyp>do *BSD offer a convenient binary format?
<dstolfa>ELF that is different from the linux one :')
<dstolfa>(so not really
<lilyp>Well, AppImages are also ELF, but different
<lilyp>Hmm
<dstolfa>and of course, with subtle differences in libc and the likes
<lilyp>Come to think of ELF, has someone written a serious application targetting DWARF bytecode yet?
<dstolfa>what would you consider "serious"?
<lilyp>dunno, let's start with something simple: ed
<lilyp>or maybe just cat
<dstolfa>i mean, debuggers use DWARF extensively, i'm not sure if ed/cat would need to
<dstolfa>unless you mean implementing ed in DWARF's weird state machine thingy
<dstolfa>that would be, uh, interesting :)
<lilyp>the latter, implementing some serious tool completely as DWARF bytecode
<lilyp>maybe send out some emails from it while I'm at it
<dstolfa>lol
<dstolfa>git send-email... IN DWARF
<lilyp>dwarf send-email
<lilyp>--nigerian-prince
<nckx>r u ok
<lilyp>just throwing out some random ideas late at night
<lilyp>should probably go to bed
<attila_lendvai>is anyone running macos in a vm under guix? if so, what are th outlines of a working setup? which virtualization, viewer, etc...?
<attila_lendvai>ouch, sorry for the repeated question, this wasn't the terminal... maybe i also should go to bed... :)
<lilyp>dunno about macos, but I once ran the other evil OS in qemu
<roptat>\o/ just built kotlin-0.8.84, I'm getting closer, though it's slow progress :)
<jonsger-laptop>:)
<nckx>I've spent too many years in Schemeland.
<nckx>I read ‘macros’ thrice and wondered what the hell you were on about.
<brettgilio>cybersyn nckx I'm here :)
<sneek>brettgilio, you have 1 message!
<sneek>brettgilio, cybersyn says: "blake says hi! shoot him an email at blake atch sweatshoppe dotorg"
<brettgilio>and alive
<lilyp>Well, running macros in a docker container can be problematic at times, so I usually use guix deploy to run them over the cloud.
<nckx>brettgilio: \o/
<brettgilio>I'm sorry for my inactivity
<nckx>Glad to hear that. No need to apologise.
<brettgilio>work and school have been.... blech
<nckx>Life… finds a way [to get in the way sometimes].
<brettgilio>I'm always a /msg away too :)
<brettgilio>I have IRC on my phone
<brettgilio>good to see you all for this brief moment before I head to dinner!
<nckx>I run all my lambdas serverless; I use a laptop instead.
<nckx>brettgilio: I'd never /msg someone unprovoked, but good point. Enjoy.
<brettgilio>Well, you are all friena.
<brettgilio>Friends.*
<brettgilio>So, go for it!
<dissoc>how do i run a gui app with guix environment containers?
<dissoc>anyone have an example?
<pkill9>expose /tmp/.X11 or something
<dissoc>i was doing that. but i took it out and now it works. so i guess i got it
<dissoc>i had to share xauthority
<iskarian>Is there a way to remove an implicit input from a package (not a gnu-build-system package)?
<nckx>Good night, Guix…
<brettgilio>iskarian can you put the recipe in a paste and let me know what youre trying to remove? I assume by implicit you mean from a closure that was inherited?
<iskarian>night nckx!
<iskarian>brettgilio, it's a bit more complicated than one package. I'm having the build system add an implicit input, but I'd like that implicit input to also use the build system.
<iskarian>I can filter it out by name, but that seems hacky.
<brettgilio>im still confused what you mean by implicit, do you mean an input inherited from another package?
<iskarian>by implicit I mean: an input added in LOWER
<iskarian>I'll share a paste, but I'm not sure it'll help.
<brettgilio>Oh I see what you mean now
<brettgilio>I had to do some refreshing on our build system toolchains
<brettgilio>yeah, idk the best method :)
<iskarian>Darn
<brettgilio>there is a scheme procedure though
<brettgilio>package-with-c-toolchain, but I think what youre wanting is more complex than just that
<iskarian> https://paste.debian.net/1212195
<iskarian>Yeah, I see package-with-explicit-inputs, but that's for gnu-build-system AFAICT
<iskarian>There's package-mapping and package-input-rewriting, but they don't seem to let me replace with #f
<brettgilio>Sorry I can't be of more help here
<iskarian>No worries :)
<brettgilio>Good luck!
<singpolyma>Is there any way to use (source (local-file but specify a hash? Or alternately to use (source (origin (method git-fetch but fetch from a local directory?
<singpolyma>What I'm *actually* trying to do: build a package locally from source I have locally, guix archive --export the build, scp the archive to a server, guix archive --import on server, install the package without building anything and without copying the source to the server (just the package description)
<iskarian>singpolyma, I haven't used it personally, but this sounds like "guix copy"
<iskarian>or perhaps "guix deploy", but I'm even less familiar with that one.
<singpolyma>Oh sure, guix copy vs guix archive it's the same result. I'm only using guix archive to work around https://debbugs.gnu.org/cgi/bugreport.cgi?bug=50613
<singpolyma>The core thing here is that I need guix install to know from just the package description that it has everything in store already and does not need to download or build anything. This only works if the package description has a hash of the source
<singpolyma>which local-file does not provide
<iskarian>Hmmm. Have you just tried using a directory path as the URL for git-fetch? Or even "file://path/to/repo"?
<singpolyma>yes, that doesn't work because guix build runs in a chroot or something
<iskarian>Ah, that's right
<iskarian>well, no, that shouldn't affect git-fetch I don't think
<singpolyma>I added an (invoke "ls" "/" in the git fetch code and it showed not /home at all, for example
<singpolyma>I had to put git-fetch into recursive mode to even get access to cat or ls anyway, heh, so definitely running in some environment
<iskarian>I know you can use --with-source or --with-git-url on the command line and use a file path
<iskarian>It's a bit of a sideways solution, but you could set up a local git server
<iskarian>like, just with git: https://git-scm.com/book/en/v2/Git-on-the-Server-Setting-Up-the-Server
<singpolyma>True
<iskarian>okay, so I have solution for you singpolyma! On your build machine, run `git daemon --base-path=/path/to/dir/with/repos /path/to/dir/with/repos'; in each repo you want to serve, `touch .git/git-daemon-export-ok'; then in git-fetch, use "git://localhost/my-repo"
<iskarian>the remote shouldn't need to be able to access the build machine for this
<singpolyma>Thanks! Not ideal, but better than nothing :)
<acrow>singpolyma: I think you might also want to look at guix pack, https://guix.gnu.org/en/manual/en/guix.html#Invoking-guix-pack
<acrow>Maybe that's more than you require bc I think I read that you are just moving from guix to guix.
***califax- is now known as califax
<singpolyma>Is there an equivalent to guile -e for guix? I know there is guix repl, but I just want to run an expression in an interpreter that knows how to load all the guix internal modules
<singpolyma>(non interactively)
<the_tubular>Is there a package for Emacs application framework ?
<the_tubular>I'm looking for a full feature browser for emacs
<the_tubular>I spotted this : https://github.com/emacs-eaf/emacs-application-framework
<iyzsong>singpolyma: guix repl can run a script file, or something like: guix repl <(echo '(pk ...)'), or: ehco ... | guix repl /dev/stdin
<singpolyma>iyzsong: Oh! So it can! Ok, cool
<apteryx>eh; 'guix pull: error: cloning builder process: Invalid argument' on a buildroot os
<apteryx>I guess that's because no user namespace is not enaled for its kernel
<apteryx>that's workable using the --disable-chroot argument of the guix-daemon
<iskarian>apteryx, do you happen to know who would know which packages actually use the guile bindings of gnutls?
<muradm>morning guix
<brendyn>I notice we aren't using libglvnd in Guix with mesa. I'm wondering if that is something we should do? I'm updating KDE frameworks and it became needed by plasma-framework
<brendyn>but adding i as an input there seems odd. maybe it should be a propagated input of mesa?
<be>Hi, first time using Guix distro. I wanted to use `gtk-launch`, so I ran `guix install gtk+` and I can see hidden in the store there is a binary for `gtk-launch` now, but for some reason it is not linked in `~/.guix-profile/bin/` (other applications are linked there no problem). Am I supposed to manually create a symlink, or did I do something wrong?
<RRRRedEye[m]>no manually
<be>I see, thank you!
<RRRRedEye[m]>be: you can let guix make it by `guix install gtk+:bin`
<be>Perfect, that worked :)
<jonsger-laptop>3k commits left on bisecting https://issues.guix.gnu.org/50566
<brendyn>do we have no GeoIP.h?
<jonsger-laptop>where should it come from?
***iyzsong- is now known as iyzsong
<dale`>Doing the basic thing of git-fetching guix, 'guix environment guix', './configure', and find that configure fails because PKG_GUILE(3.0) looks for a guile.pc but there is only a guile-3.0.pc in the $PKG_CONFIG_PATH directory. Does anyone know a quick way to proceed, and is this a reported issue?
<pinoaffe>hi guix! I want to make a guix channel that, when added to your channels.scm, causes an additional guix importer to be available from the command line - is there a better way to do this than to monkey-patch the variable "importers" in (guix scripts import)?
<pinoaffe>or, alternatively, could one alter import.scm in such a way as to permit extension?
***iskarian is now known as Guest522
<apteryx>not sure what this means: guix substitute: error: TLS error in procedure 'handshake': Function was interrupted; trying to `guix pull` from an underpowered arm box
<dale`>I'm seeing TLS errors all over the place; it is a real pig of a show-stopping bug. I'm trying to work it out myself, but if anyone has any hints for me that would be really great.
<kozo[m]>I had a few devices seeing the TLS errors. I ended up having to wipe and image them to fix it
<apteryx>this is from 1.3.0, on a bare bone buildroot OS
<apteryx>the rootfs is also on NFS; not a typical install :-)
<dale`>My rootfs is also on NFS; I'm PXE booting a diskless machine. But the error also shows up on foreign installs.
<apteryx>is this even occurring when pulling from a recent Guix? I'm pulling from 1.3.0
<apteryx>s/even/also/
<dale`>Bang up to date, from the head of the GIT repository.
<apteryx>iskarian: don't we have a guile-gnutls package?
<apteryx>ah, seems they come with the gnutls package nowadays
*apteryx has to run
<PurpleSym>rekado: I’m updating all Haskell packages from stackage, but I can’t build pandoc, due some weird error: guix build: error: reference to invalid output 'static' of derivation '/gnu/store/izjwd1wnf3w3brcjjazy5dj91brdgd4i-ghc-next-8.8.4.drv'
<PurpleSym>What was the idea behind a static pandoc?
<zamfofex>PurpleSym: Maybe I’m off, but I think the error is talking about a ‘static’ output of the “ghc-next” package, rather than of Pandoc.
<PurpleSym>Yeah, probably, zamfofex. But I don’t understand why 8.8.4. I’m using GHC 8.10.
<lilyp>but what's the ghc-next package saying?
<lilyp>if you're (inadvertently) trying to mix ghc-8.10 with ghc-next-8.8 the warning would make sense
<jonsger-laptop>uff. bisecting on core-updates-frozen is hard
<moshy>Hi guix. I'd like to request a change for https://git.savannah.gnu.org/cgit/guix.git/tree/gnu/packages/easyrpg.scm at line 109. wildmidi is now available, so it can be commented out and build using support with said package
<moshy>*no longer commented out
<civodul>sneek: later tell yoctocell i just realized that "git tag xyz" is non-interactive
<sneek>Will do.
<iskarian>morning Guix!
<iskarian>Does anyone know which packages actually use the guile bindings of gnutls?
<cybersyn`>hiya guix, hope you don't mind me cross posting here, but #guile has been a bit quiet. I want to port a program from chez to guile, and I'm wondering if anyone has written a blog post or written a tool that might help swiften my journey?
<PurpleSym>sneek: later tell yoctocell It seems the cabal importer does not support the elif statement. Is that correct? I’m trying to import lukko from stackage, but it fails with Syntax error: unexpected token : elif (at line 91, column 2)
<sneek>Got it.
<hjklambda>Does having a service extending service another one that I don't have in my system config pull it?
<lilyp>hjklambda: yes, see instantiate-missing-services
<hjklambda>lilyp: thanks!
<makx>Scanning the generated tarball for blobs...
<makx>building of `/gnu/store/ipsjbyfcbdjbc3bd7dpqbyic4nwpwvbn-linux-libre-5.13.18-guix.tar.xz.drv' timed out after 3600 seconds of silence
<makx>@ build-failed /gnu/store/ipsjbyfcbdjbc3bd7dpqbyic4nwpwvbn-linux-libre-5.13.18-guix.tar.xz.drv - timeout
<makx>party people, how important is aarch64 for you?
<maximed>maybe the ‘scanning ...’ script could be modified to output a line for every N files it has scanned?
<maximed>That way, the guix daemon wouldn't think it has hung
<maximed>(hanged?)
<Bumblehorse>When deleting system and profile generations for garbage collection with 'guix gc' ist there a pattern that can specify to delete all but the 2 most recent generations?
<sneek>Bumblehorse, you have 1 message!
<sneek>Bumblehorse, nckx says: “expected string `Derive(['” is clear evidence of file system corruption. Some file systems (notably ext4) truncate files when you crash. You should run ‘guix gc --verify=contents,repair’ which is a best-effort fsck for the store. If the file system isn't taking good care of the data that Guix gives it, there's only so much Guix can do.
<nckx>Honestly, since I wrote that I'm no longer 100% sure that Guix doesn't have some very subtle (and rare!) problem in that area.
<pkill9>does anyone know what could be causing this disk image to fail building? https://paste.debian.net/plain/1212296
<civodul>d'you know that 'generic-git' updater's in the house? \o/
<civodul>thanks iskarian & yoctocell!
<iskarian>important to note that it just allows checking for updates right now!
<civodul>right! but the rest is coming along too :-)
<pkill9>civodul: do you have any idea why disk-image build is failing? https://fossandcrafts.org/hack-and-craft/
<pkill9>wrong link
<pkill9> https://paste.debian.net/plain/1212296
<iskarian>Yes it is :)
<civodul>pkill9: i was looking at your link and no, idk; are there messages from U-Boot above?
<nckx>moshy: Thanks! Done. Pull & check whether it does what you need it for.
<dissoc>what needs to be installed for 'org.gtk.Settings.FileChooser' crashes?
<dissoc> 'org.gtk.Settings.FileChooser' not installed
<nckx>dissoc: More a guess, but gsettings-desktop-schemas?
<dissoc> nckx: that didnt seem to fix it
<nckx>Pity.
*nckx -> zzz
<dissoc>it's a package that i wrote. is there something likely missing?
<dissoc>am i supposed to do anything special for gtk?
<pkill9>civodul: no, that's all the output
<civodul>pkill9: hmm, maybe try to get feedback from the u-boot-savvy folks
*civodul looks around
<civodul>maybe emailing bug-guix is the best way to achieve that
<civodul>including the OS config you used
<dissoc>what device are you making this image for?