IRC channel logs

2021-08-22.log

back to list of logs

***xgqtd is now known as xgqt
<kraai>The package description of ledger-agent seems to be wrapped incorrectly. Is there a way to fix it?
***namtsui_ is now known as namtsui
<apteryx>GNUtoo: hello! you need to unquote the parameter values
<apteryx>from the REPL: `(#:tests? (let ((system ,(or (%current-target-system) (%current-system)))) (string-prefix? "x86_64-linux" system))) -> $2 = (#:tests? (let ((system "x86_64-linux")) (string-prefix? "x86_64-linux" system)))
<iskarian>sneek: later tell zacchae[m]: I think efraim is also working on go cross-compilation :)
<sneek>Will do.
<iskarian>sneek, botsnack
<sneek>:)
<efraim>sneek: later tell vagrant come join us in #guix-risc-v :)
<sneek>Welcome back efraim, you have 1 message!
<sneek>efraim, lfam says: Okay, let me know how I can help
<sneek>Okay.
<efraim>yeah, i put the go cross compilation on hold while I was working on getting ... something to import correctly (I think from guix/utils)
<iskarian>efraim, in cross compilation does anything in the actual build process change other than setting GOOS/GOARCH/CC_FOR_TARGET/CXX_FOR_TARGET/PKGCONFIG_FOR_TARGET?
<EdLin>I seem to be having problems booting the guix OS, I've blacklisted pcspkr, removed my wifi card so it won't stop when there isn't blobs, but it now stops at udev.
<EdLin>I tried it within ventoy first, but now I've dedicated another USB key to it and it still won't finish booting past an early stage from the USB key
<EdLin>anyone awake here?
<bost>atw sneek: thanks for that response to my 'partial function application' question. JFTR `(use-modules (srfi srfi-26)) (map (cut * 2 <>) '(1 2 3 4))`. And (repeating) see also https://srfi.schemers.org/srfi-26/srfi-26.html
<sneek>bost, you have 1 message!
<sneek>bost, atw says: I've seen https://srfi.schemers.org/srfi-26/srfi-26.html used to that end, though it's not exactly `partial`
<haugh>I love cut!
<bost>I'd like to my Guile Scripts it portable across my Linux and Guix machines. How should the hashbang look like? I found a 6 years old discussion https://logs.guix.gnu.org/guix/2015-11-01.log#165627 I guess things changed in between..., right?
<bost>I'd like to have
<efraim>iskarian: here's the patch I have ATM https://bpa.st/D4VQ/raw
<efraim>looking at it I'm not sure what part I didn't like
<efraim>oh, that's what it was, I'm not passing (guix utils) correctly somewhere
<leoprikler>bost: nope, only reliable shebang still is #!/bin/sh
<leoprikler>if you want to do something else, you need to package your script
<bost>leoprikler: Ok thanks. (Well then I need to learn how to package stuff)
<efraim>sneek: later tell lfam the go cross-build error I was seeing is this: go install: cannot install cross-compiled binaries when GOBIN is set
<sneek>Will do.
<efraim>sneek: botsnack
<sneek>:)
<pkill9>does anyone know of any work done on packaging python-adblock?
<pkill9>this could be wrapped into the qutebrowser package and then would have adblock-style adblocking
<pkill9>where it blocks elements instead of basic hosts
<pkill9>probably is it uses a mixture of rust and python
<pkill9>well it's a wrapper over a rust library
<zacchae[m]>So, I tried making a minimal arm64 image (without syncthing), and it crashed saying that the most likely problem is that the disk ran out of space when it was building linux-libre. The disk in question is 32 GB so I doubt that. However, when I check it with fdisk, it says the two partitions are each <5GB. Is fdisk not reliable for a failed image write, or do I need to specify something in order for the entire disk to be used?
<sneek>Welcome back zacchae[m], you have 1 message!
<sneek>zacchae[m], iskarian says: I think efraim is also working on go cross-compilation :)
<zacchae[m]>iskarian: oh neat, though if I understand correctly, I should be able to install syncthing on the arm device so long as I make the image raw-efi and volitile
<GNUtoo>apteryx: thanks a lot, I'll try as soon as the current compilation finishes
*GNUtoo tried the unquote at another place before, like ,(%current-target-system) if I recall well
<vldn>what is the best way to submit version bumps with little adjustments to the package?
<vldn>via mailing list?
<vldn>i updated sway to 1.6.1
<GNUtoo>The manual has a section on sending patches
<GNUtoo>The neat thing is that the patch tracking system also works by mail
<GNUtoo>So it looks like a mailing list and the usual tools for sending patches to mailing lists work
<GNUtoo> https://guix.gnu.org/manual/en/guix.html#Submitting-Patches
<GNUtoo>And the bug and patch tracking web interface is available here: https://issues.guix.gnu.org/
*GNUtoo has a hard time to find it each time, so I bookmarked it
<GNUtoo>vldn: and for the commit message I typically copy the ones that already do something similar
<vldn>ty :)
<slyfox>Oh, i'm surprised './pre-inst-env guix refresh -u sway' does not work as is.
<vldn>needs new meson version > 55 and wlroots etc.
<vldn>and seatd as input
<slyfox>*nod*, it also has some guix-specific failure: https://dpaste.com/3H77REPG6.txt
<vldn>setting meson-55 to meson-next could be enough
<vldn>1.6.1 works so far fine for me :) no bugs and old bugs from 1.5.1 are gone
<vldn>so far i'm very happy
<vldn> http://ix.io/3wFQ if someone is interested, if i have enough freetime the next days i'll make a patch :)
<vldn>(really ugly package, too much modules etc, but works :D)
<muradm>hi guix
<bost>It looks like the 'disk-image' gone missing: `guix help system | grep -c disk-image` return 0.
<bost>Does anyone have an explanation for that?
<GNUtoo>bost: maybe it's because it has been replaced by guix system image
<GNUtoo>ah indeed it's gone here too
<GNUtoo>s/maybe//
<GNUtoo>The thing is that you now have to select an image type, 'guix system --list-image-types' list them
<GNUtoo>for instance if you want a standalone image that works in a vm, you can use qcow2 for instance
<bost>GNUtoo: I though the same but I get an error when I try `guix system image`.
<bost>GNUtoo: and also for `guix system image --image-type=iso9660` and `guix system image --image-type=iso9660 my-os.scm`
<GNUtoo>AFAIK the later one is supposed to work
<GNUtoo>So the error will tell what ig going wrong
<GNUtoo>(like some package failing, no more space, etc)
<muradm>can one use "make -j8" on guix source tree? does it speed up things?
<slyfox>i think it allows running guile in parallel to build .go files out of .scm (bulk of the time)
*GNUtoo didn't check if that speeds up things but it's supposed to work once you run ./bootstrap.sh and configure --localstatedir=/var like explained in the manual
<bost>GNUtoo: I have a guix in a VM and I'd like to create a bootable USB and install it on my machine along the other OSes I have already.
<bost>GNUtoo: and I found https://guix.gnu.org/manual/en/guix.html#Building-the-Installation-Image and https://othacehe.org/the-guix-system-image-api.html
<bost>GNUtoo: but the 'disk-image' seems to be gone so I'm stuck. Ugh.
<GNUtoo>bost: what's the error
<bost>GNUtoo: `guix system image --image-type=iso9660 my-os.scm` leads to 'guix system: error: failed to load 'my-os.scm': No such file or directory'
<bost>
<GNUtoo>ah that's because there is no file named my-os.scm in the current directory
<GNUtoo>You're supposed to create that file
<GNUtoo>There are up to date examples in the manual or in guix source code
<GNUtoo> https://guix.gnu.org/manual/en/guix.html#System-Configuration
<GNUtoo>This has several examples
<GNUtoo>but it's not for building the installer image
<GNUtoo>it's for building complete systems
<GNUtoo>for the installer I think there is a shortcut
<muradm>slyfox: thet is what expected, just wander if guile can handle that and does things in parallel
<GNUtoo> https://guix.gnu.org/manual/en/guix.html#Building-the-Installation-Image
<GNUtoo>You probably need to get that gnu/system/install.scm
<GNUtoo>from the guix source code
<GNUtoo>So you need to clone guix with 'git clone https://git.savannah.gnu.org/git/guix.git'
<slyfox>muradm: i'm using 'make -j4' for a few years and had no problems with it
<muradm>if one ever did guix pull, gnu/system/install.scm can be found in ~/.cache/guix/checkouts/....../gnu/system/install.scm
<muradm>no need to clone guix again
<muradm>slyfox: ok, will try that on next iteration.. thanks
<vldn>:q
<bost>GNUtoo: muradm: Thanks for telling me where to get the install.scm from
<muradm>./pre-inst-env guix build <package> is there any way to force rebuild of package?
<GNUtoo>muradm: I'm not sure, maybe with --rounds=2
<bost>You know, the sentence 'Have a look at gnu/system/install.scm in the source tree' doesn't really help. Source tree of what? And how to get it? - that's not really clear.
<muradm>i want to run ./pre-inst-env guix build --rounds=2 my-package
<muradm>GNUtoo: no, that does not do
<GNUtoo>Maybe there is a bug then
<muradm>bost: source tree of guix, as it was mentioned, if you did ever run "guix pull" in your vm, it is literally pulling the source tree of guix also
<muradm>so ~/.cache/guix/checkouts/....../ where dots is a long directory name, mine is ~/.cache/guix/checkouts/pjmkglp4t7znuugeurpurzikxq3tnlaywmisyr27shj7apsnalwq/
<bost>muradm: I meant the explanation in the manual is too vague.
<slyfox>does './pre-inst-env guix build --check my-package' do what you need?
<muradm>that is where you can find source tree of guix which used by "guix ...." commands by default
<bost>muradm: It'd be great to add there: "Run `find ~/.cache/guix/checkouts -name install.scm` to find the install.scm"
<muradm>slyfox: yeah, --check started building, thanks, let's see how it finishes
<GNUtoo>Nice, maybe the manual needs to be updated for adding --check
<muradm>bost: that file you need to find for you reference, normally your *.scm files should be prepared and managed by you i think, at least this is my understanding
*GNUtoo probably didn't pay enough attention when sending patches as he just checked if the 2 "builds" were the same, not what it did before
<muradm>once you get used to "look at guix source" that questions will be gone :)
<muradm>bost: i.e. just look in install.scm but have your own my-install.scm based on install.scm for instance, because if you will want to change/customize something, you won't be able to do it on ~/.cache/guix/checkouts/...
<muradm>also after "guix pull" whatever is under checkout may/will change without your control
<muradm>so once you used "gnu/system/install.scm" next time it might be different thing
<muradm>just keep in mind that every system you seed with guix, you need a scheme file for it under your control, since it is your system
<muradm>be it installation media, your laptop, cloud server or whatever
<muradm>that is how guix works, you declare your system in my-system1.scm and then ask guix to make it
<muradm>in some or another way depending on what is inside my-system1.scm
<vldn>mhh is there a possibility to add reallife examples to the docpages, or some additional info that is not bound to a function programmatically?
<apfel>hi there, ci.guix.gnu.org seems to be down, i know there is some mastadon status overview, but i cant find it right now. I just want to know what is going on and when it will be up again.
<muradm>also having issue with accessing ci.guix.gnu.org
<bost>muradm: Oh this is crazy. It doesn't work against a simple copy of the install.scm. `guix system image -t iso9660 install.scm` returns 'guix system: error: failed to load 'install.scm': No such file or directory'. It seems like the install.scm must be inside a git repository. E.g. `cd ~/.cache/guix/checkouts/<...>; guix system image -t iso9660 gnu/system/install.scm`
<bost>muradm: or `git clone https://git.savannah.gnu.org/git/guix.git; cd guix; guix system image
<bost> -t iso9660 gnu/system/install.scm`
<vldn>@apfel http://ix.io/3wGd
<vldn>ci.guix.gnu.org is online for me
<vldn>and substitutes are pulled correctly
<vldn>okay no pulling for me anymore, can someone confirm?
<bricewge>CI seems down here also, as well as data.guix.gnu.org
<muradm>no pulling yet
<htsr>even guix.gnu.org seems to be down
*the_tubular paniks
<vldn>website down too for me, but ci.guix.gnu.org answers to ping
<vldn>lets wait, maybe patch day :D
<drakonis> https://lists.gnu.org/archive/html/guix-devel/2021-08/msg00091.html neat.
<donc>is it just me or is guix.gnu.org down?
<muradm>donc: not only guix.gnu.org, not you only
<roptat>looks like berlin is down? bordeaux is still online though
<vldn>possible to set bordeaux via channel-with-substitutes-available?
<vldn>@ roptat
<Noisytoot>guix substitute: warning: while fetching https://ci.guix.gnu.org/nar/lzip/gm9h9j42gwgd395hpdk43rxaqypjx7lk-guix-core: server is somewhat slow
<Noisytoot>guix substitute: warning: try `--no-substitutes' if the problem persists
<Noisytoot>guix substitute: error: connect*: Connection timed out
<Noisytoot>substitution of /gnu/store/gm9h9j42gwgd395hpdk43rxaqypjx7lk-guix-core failed
<Noisytoot>guix pull: error: corrupt input while restoring archive from #<closed: file 7f967720ba80>
<Noisytoot>it seems to be down
<Noisytoot>How can I use bordeaux.guix.gnu.org for substitutes?
<vldn>sudo guix-daemon --build-users=guixbuild --substitute-urls="http
<vldn>s://bordeaux.guix.gnu.org"
<vldn>sudo guix-daemon --build-users=guixbuild --substitutes-urls="https://bordeaux.guix.gnu.org"
<vldn>and right before sudo herd stop guix-daemon
<vldn>*substitute
<roptat>if you've updated recently, you're already using bordeaux along with berlin (ci)
<roptat>well, unless you have a custom value in your os declaration
<roptat>or you're on a foreign distro, the systemd unit is not updated automatically
<muradm>roptat: how recent?
<Noisytoot>roptat, I was one commit behind on Guix System (without a custom value), but it wasn't falling back to bordeaux
<Zambyte>Is the guix website offline? I can't seem to reach it
<lfam>Indeed it seems to be unresponsive
<sneek>lfam, you have 1 message!
<sneek>lfam, efraim says: the go cross-build error I was seeing is this: go install: cannot install cross-compiled binaries when GOBIN is set
<lfam>It looks like all the infrastructure is down Zambyte, including the substitute server
<dzho> https://guix.gnu.org is timing out for me
<pkill9>I'm having networking issues getting substitutes too
<iskarian>Hello Guix :)
<Zambyte>Hello iskarian!
<moshy>Guess it's time to make coffee while everything builds. It's like loading from tapes all over again
<pkill9>now we nee dP2P substitutes
<vldn>doesn't bordeaux work @pkill?
<pkill9>bordeaux?
<vldn>2nd substitute server
<pkill9>do you mean berlin?
<vldn>bordeaux.guix.gnu.org
<pkill9>ah ok
<pkill9>nice that worked
<pkill9>ty
<vldn>yw
<pkill9>hmm it seems not to have many substitutes
<vldn>:( haven't used it either but someone said it is working
<pkill9>hmm actually doesn't seem to be working for me
<pkill9>i think i just stopped it trying to use normal guix substitute server so it stopped timing out
<pkill9>yea it's buidlign the world for me
<pkill9>guix build hello --substitute-urls=http://bordeaux.guix.gnu.org
<pkill9>it tries to build that, also same with tmux and linux
<iskarian>They may be offline
<pkill9>do I need to authorize it like the normal guix servers?
<vldn>yeah
<vldn> (q #7D602902D3A2DBB83F8A0FB98602A754C5493B0B778C8D1DD4E0F41DE14DE34F#)
<vldn>look on the website for instructions
<vldn> http://bordeaux.guix.gnu.org/
<pkill9>ah that would explain it
<pkill9>now it works :)
<qyliss>Does https://issues.guix.gnu.org/ seem down for anyone else?
<qyliss>I'm on hotel wi-fi so entirely possible it's just me
<podiki[m]>main guix site, issues, substitute server all seem down since this morning (for the last 5 hours or so?)
<qyliss>oh yes, I see people talking about it half an hour ago
<qyliss>okay, as long as its known :)
<moshy>Anyone happen to have trouble with xfce4-whiskermenu-plugin? Got it installed but it doesn't appear as a selectable panel item
<pkill9>ci.guix.gnu.org is back up
<podiki[m]>I think ci.guix.gnu.org is back up
<podiki[m]>along with rest of guix
<podiki[m]>woop!
<podiki[m]>and bootstrappable.org (coincidence or is it hosted by guix?)
<efraim>it's hosted by guix
<podiki[m]>makes sense! glad we are all up again
<pkill9>i dont get why guix keeps compiling new stuff on reconfigure as root when i haven't run guix pull as root
<pkill9>and i've only made minor changes to the system configuration file
<dzho>oh, good.
*dzho has grabbed the iso now
<podiki[m]>I've never run guix pull as root, should I? i just use sudo guix system reconfigure as needed
<podiki[m]>or should that be sudo -E?
<podiki[m]>and it picks up things I've pulled, like when adding a package I needed in system
<iskarian>efraim, do you think it makes sense to keep the Go "tests" output? It includes toolchain tests, but it's not actually usable unless you create a directory union with "out" and "tests" and then set GOROOT to that union directory.
<Zambyte>Hi, I'm trying to set up cgit, but I'm not quite sure how I can "overload" values from %cgit-configuration-nginx, I'm pretty new to lisp in general :D This is what I have so far if anyone can help: https://dpaste.com/DE9AATBMJ
<iskarian>Zambyte, you can do (nginx-server-configuration (inherit %cgit-configuration-nginx) ...) where ... are the values you want to override
<Zambyte>Hm, this is what I get when I try to do that: guix system: error: Invalid value for field nginx: #<<nginx-server-configuration> listen: ("80" "443 ssl") server-name: ("git.mysite.tld") root: #<package cgit@1.2.3 gnu/packages/version-control.scm:914 7f92f5de38c0> locations: (#<<nginx-location-configuration> uri: "@cgit" body: ("fastcgi_param SCRIPT_FILENAME $document_root/lib/cgit/cgit.cgi;" "fastcgi_param
<Zambyte>PATH_INFO $uri;" "fastcgi_param QUERY_STRING $args;" "fastcgi_param HTTP_HOST $server_name;" "fastcgi_pass 127.0.0.1:9000;")>) index: ("index.html") try-files: ("$uri" "@cgit") ssl-certificate: "/etc/letsencrypt/live/mysite.tld/fullchain.pem" ssl-certificate-key: "/etc/letsencrypt/live/mysite.tld/privkey.pem" server-tokens?: #f raw-content: ()>
<iskarian>Zambyte, did you replace `%cgit-configuration-nginx` with `(nginx-server-configuration ...)`?
<iskarian>Hmm, I'm not familiar with services...
<iskarian>It looks like nginx takes a `nginx-server-configuration-list`
<iskarian>perhaps it should be `(nginx (nginx-server-configuration-list (nginx-server-configuration (inherit %cgit-configuration-nginx) (listen '("80" "443 ssl")) ...))`
<iskarian>rather, `(nginx (nginx-server-configuration-list (list (nginx-server-configuration (inherit %cgit-configuration-nginx) (listen '("80" "443 ssl")) ...)))`
<iskarian>Yeah, that seems right.
<Zambyte>I think so, trying it right now :)
<Zambyte>weird, I can't figure out where nginx-server-configuration-list is defined. It's saying it's an unbound variable
<Zambyte>It's not define-public'd in cgit.scm :\
<Zambyte>or exported
<iskarian>oh, it's the syntax for define-configuration
<iskarian>it just means that it's a list
<iskarian>so `(nginx (list (nginx-server-configuration (inherit %cgit-configuration-nginx) (listen '("80" "443 ssl")) ...))`
<iskarian>I did say I'm not familiar with services :p
<Zambyte>That did not give me any errors and is building. Thank you! :)
<doncatnip>iskarian: https://gist.github.com/doncatnip/ca561aba7ca0b0dfc545981850243b44
<doncatnip>maybe you can make use of it .. its a config i use for a vm of one of my projects
<iskarian>doncatnip, thanks, examples are always helpful :)
<Noisytoot><pkill9> i dont get why guix keeps compiling new stuff on reconfigure as root when i haven't run guix pull as root
<Noisytoot>substitute servers were down
<Noisytoot>(ci.guix.gnu.org, not bordeaux.guix.gnu.org)
<pkill9>that doesn't explain why it's trying to build/download new derivations
<pkill9>it should already have all derivations required to build the system, since I haven't updated the revision of guix and I've already got everything in order to build current system
<dstolfa>pkill9: that's really odd, do you always reconfigure as root, or did you perhaps reconfigure as another user last time?
<muradm>hi guix
<drakonis>hullo
<muradm>#49969 updated, minor fix for pam-mount configuration verbosity, also default greetd package is now greetd-next