IRC channel logs

2021-01-30.log

back to list of logs

<donotshake[m]>Newb question: Where do I find what exactly the %base-packages refers to?
<lfam>It's here, donotshake[m]: https://git.savannah.gnu.org/cgit/guix.git/tree/gnu/system.scm?id=784048c27b90e32814f6d06363f94fb3f9bf0a6d#n825
<donotshake[m]>Much appreciated, thank you.
<lfam>You're welcome!
<lfam>I'm trying to add this lint checker: https://paste.debian.net/1183301/
<lfam>However, it fails like this: https://paste.debian.net/1183302/
<lfam>I'm struggling to figure out what's wrong
<lfam>If I could figure out *where* it's failing, I might be able to continue
<lfam>This pattern of (string->uri (git-reference-url (origin-uri origin))) is used elsewhere, so I think that's okay. It makes sense to me anyways
<lfam>And then (uri-scheme uri) should also work, assuming it got a Guile URI
<lfam>But, IIUC, the backtrace doesn't say which part failed
<lfam>I think I got it
<xelxebar>$ guix package --with-commit=nyxt=2-pre-release-4 -n -i nyxt
<xelxebar>The following package would be upgraded:
<xelxebar> nyxt 2-pre-release-5 → git.2-pre-r
<xelxebar>Something is chopping off that version string O.o
<lfam>Looks like a bug xelxebar!
<lfam>Wow, there are really a lot of emails coming from the patch tracker without a "from" address
<lfam>It says "From: guix-patches--- via <guix-patches@gnu.org>"
<apteryx>bavier[m]: yes, we should fix it! (the incomplete texinfo support)
<dissoc>is there a way to manually run the certbot service command?
<Bumblehorse>I can't seem to get port-columns and lines to wrok porperly. For example I open a file for input and output that only contains the string "cats". I then evaluate (use-modules (ice-9 textual-ports)) and use (set-port-column! *PORT* 2) but when I use (get-char) on the port it returns the first character #\c.
<Bumblehorse>port-column returns the same value that I set with (set-port-column!)
<Bumblehorse>Oh crap this is #guix, not #guile... sorry
<vagrantc>no true harm done :)
<lfam>dissoc: Do you mean, to use certbot manually?
<dissoc>lfam: i just wanted to test the certbot manually instead of waiting for mcron to run it. i ended up just finding the job file via ps and manually running it but it failed for some reason
<lfam>Okay
<dissoc>never mind. just got it to work
<lfam>Great!
<sundbry>Hello fellas, how can I export guix user profiles from one machine to the other? It this currently supported?
<sundbry>I see this thread is active right now https://issues.guix.info/45919
<sundbry>I have a new computer and want to copy all my packages over
<ryanprior>sundbry: yeah I was going to say you're in luck, that feature should land soon!
<sundbry>the .guix-profile/manifest format looks like its not importable yah
<ryanprior>Right now there's no slick automated way to do it yet, but the basic flow is: on your existing machine you run `guix package --list-installed` and then on your new machine you run `guix package --install ...`
<ryanprior>sundbry: No, that manifest file is not the same as manifests that you can install. It's an overloaded term in Guix unfortunately.
<sundbry>ahh ok looks like I will have to run that and clean up the output from guix package --list-installed to script it
<sundbry>Thanks @ryanprior
<ryanprior>You bet, happy hacking :)
<sundbry>Alright I've got another question, regarding GRAFTS: https://guix.gnu.org/manual/en/html_node/Security-Updates.html
<sundbry>The document says that grafted packages must have the same length name and version. What if I have a package that has only a --configure-flags change? no change in version. I can't add a "-1" to the version string?
<sundbry>(I want to graft jemalloc for some flags to support java-rocksdb and it causes a rebuild of the world practically)
<ryanprior>You can do that, but it makes it ungraftable. The reason is that grafts use binary-level patching to avoid rebuilds, which means that pre-calculated offsets can't change.
<sundbry>ok and if I keep the same version I get a warning about ambiguous package versions
<ryanprior>Add "-1" to the end of the version and now we've got to recalculate the offsets to account for 2 more bytes :)
<sundbry>its kind of a catch-22 in this scenario I think
<sundbry>The configure flags in question, without them will crash any process that calls dlopen(libjemalloc.so)
<sundbry>on jemalloc 5+
<ryanprior>Possibly you kept around the previous package definition and added a new one, which would lead to an ambiguous version warning.
<ryanprior>You could resolve that by removing the previous package definition you aren't using anymore.
<sundbry>But I need to keep it around so I can instruct guix to graft it?
<sundbry>I am trying to avoid triggering a rebuild of the world
<sundbry>Rigtht now it's named 'jemalloc-5.2.1' I could call it 'jemalloc-5.21a' 'jemalloc-5.2-1' noone of these are ideal of course? What would be advisable for something that could land upstream? Since I want to contribute my java-rocksdb package
<sundbry>I suppose I will just do 5.2-1 that seems to make the closest compromise
<ryanprior>I think that would work. I can't say whether it would be accepted upstream, I'm not a committer.
<ryanprior>java-rocksdb would be a great package to have though
<sundbry>or a separate package entirely perhaps. jemalloc-dynamic-safe-5.2.1 then when we actually upgrade jemalloc we can get rid of the duplicate package
<sundbry>when we are ready to rebuild everything
<sundbry>yes it took a long time to get this sucker working... lol
<apteryx>is there only 2 maximum remote build slots when offloading?
<ryanprior>That sounds doable ^^ we have a core-upgrades branch that we use to stage patches that require rebuilding the world, and we batch them to do it all at once.
<apteryx>sundbry: there's 'guix copy'
<apteryx>I think if you provide an absolute profile to it it'll copy the closure of the profile over
<apteryx>guix copy $(realpath ~/.guix-profile) --to=your-remote
<ryanprior>Ooh cool, I did not know guix copy worked with profiles.
<apteryx>untested :-)
<sundbry>the man page doesn't say anything about actually installing the packages tho
<apteryx>just seem to recall it was possible
<apteryx>right, it'll just copy them to the remote store
<apteryx>then you need the actual list of packages *and* run the install command from the very same Guix revision
<ryanprior>Ah like "okay all copied, if you wanna actually use them you're on your own"
<apteryx>*and* without grafts? it's tricky to get it right
<ryanprior>But then when you go to install the packages it should have less work to do than if you had to download & build everything yourself
<apteryx>it's probably much easier to setup your machine A as a substitute server
<apteryx>configure your machine B to use it as such
<apteryx>then from the same Guix install a manifest of your packages or a list of them
<apteryx>and it'll fetch them from machine A automatically
<raingloom>heyyyy, i have an openimageio patch that i needed to build Blender but it's uuuuh. well, my machine can't handle building it. Blender that is.
<raingloom>could someone build and test it? (and then maybe send me the package coz i wanna do some art :D )
<leoprikler>Is there a way to get in contact with someone who moderates/spam filters the MLs?
<jmarciano>how do I solve: /gnu/store/6rn4l3h0p9x0m615pp1ynlv9v0743kl3-guix-1.2.0/libexec/guix/guile: symbol lookup error: /gnu/store/gpv8zbls7vqbimaaq4dvl69an5ayy38b-libgit2-1.0.1/lib/libgit2.so: undefined symbol: SSL_CTX_set_options, version OPENSSL_1_1_0 -- after installation of guix binary?
<jmarciano>I think that this instruction does not work: https://guix.gnu.org/manual/en/html_node/Binary-Installation.html#Binary-Installation - under "Otherwise, you can still start the daemon manually with:" -- as daemon does not dettach itself
<jmarciano>I think it requires & on the end of the line: ~root/.config/guix/current/bin/guix-daemon --build-users-group=guixbuild
<jmarciano>Another issue is that ./guix-install.sh supports (so I guess) only systemd and openrc, but I think I have openrc, yet it failed to find the files and shows errors that it cannot start from /etc/init.d/guix-daemon if I remember well
<jmarciano>but script could manually start daemon in that case
<PotentialUser-48>Hello
<PotentialUser-48>Friends how do I solve this problem?
<PotentialUser-48> http://paste.debian.net/1183336/
<jmarciano>well, I have tried many times with installation of guix binary on Hyperbole, it is basically not useful due to: undefined symbol: SSL_CTX_set_options, version OPENSSL_1_1_0 --
<jmarciano>it fails due to dependencies
<jmarciano> http://paste.debian.net/1183338/
<cbaines>jmarciano, something's wrong with the libgit2 you've got, the ldd output should look more like https://paste.debian.net/plain/1183339
<cbaines>jmarciano, did you download a substitute for libgit2, or did you build it?
<cbaines>PotentialUser-48, what's the problem? I don't know about /gnu/store/mjmn2yhsy6g20csciyl2w3blrssq35yj-openimageio-2.0.13.drv so I can't try building it myself. How was this derivation generated?
<jmarciano>cbaines: I have just installed guix binary
<jmarciano>so I cannot do anything more than that
<jmarciano>Yes, I expect that type of output, so that libgit is self-contained
<jmarciano>like not depending on other packages
<jmarciano>I mean on host system packages
<cbaines>jmarciano, OK, what options are you running the guix-daemon with?
<jonsger>how do people split PDFs per page on guix?
<jmarciano>cbaines: ~root/.config/guix/current/bin/guix-daemon --build-users-group=guixbuild &
<cbaines>jmarciano, OK, and what user is it running as?
<jmarciano>as root
<cbaines>hmm, that should be OK
<cbaines>jmarciano, what do you get if you run: md5sum /gnu/store/gpv8zbls7vqbimaaq4dvl69an5ayy38b-libgit2-1.0.1/lib/libgit2.so.1.0.1
<jmarciano>51ebe592eeef8e155a12d40382e1a8d8
<cbaines>right, that's the same as me... I wonder if there's something odd with your environment then
<PurpleSym>Is there any trick to getting teeworlds running? I fixed the audio loading issues, but it’s just showing a black screen now. Maybe an OpenGL/SDL2 issue?
<cbaines>jmarciano, do you have LD_LIBRARY_PATH set?
<jmarciano>No
<jmarciano>actually now when I do ldd, I do not see those problems, all is pointing to /gnu
<jmarciano>yes, in user space I have LD_LIBRARY_PATH
<jmarciano>OK now when unsetting that variable I cannot move forward
<jmarciano> https://paste.debian.net/1183341/ shows what is happening
<cbaines>jmarciano, hmm, I'd perhaps try running guix pull as root, and then restarting the guix-daemon
<jmarciano>aha
<jmarciano>I am doing it
<jmarciano>if I install package as root, is it available to users automatically? Or I need to install it as user?
<cbaines>PurpleSym, I can get to the menu at least, although I don't hear any audio. Do you not see anything at all?
<cbaines>jmarciano, typically, each user, including root has separate profiles, so they only see packages installed in their own profiles
<cbaines>jmarciano, of course, everything is in the same store, so this is just about what environment variables are set
<PurpleSym>cbaines: Nope, the window disappears after the audio starts (I fixed the audio). I have a AMD GPU, maybe there’s drivers missing?
<PurpleSym>(foreign distribution, btw)
<cbaines>PurpleSym, I'm testing with Intel integrated graphics. If you run it from a terminal, do you see any relevant output in the terminal?
<PurpleSym>cbaines: No errors, as far as I see.
<PurpleSym>But if it works on Intel this must be a GPU issue.
<PurpleSym>extremetuxracer works, so it could be an SDL2 issue.
<leoprikler>I don't think it's much related to configuration: `guix build teeworlds`/bin/teeworlds works for me (NVidia card)
<leoprikler>Also Guix system, but that should hardly make a change when running directly from the build directory
<PurpleSym>Well, supertuxkart is working too (in windowed mode). Strange :/
<PurpleSym>Ah yeah, teeworlds now works in windowed mode.
<leoprikler>perhaps it's an issue with going fullscreen?
<nly>roptat: how to do .onion resolution with unbound?
***janneke_ is now known as janneke
<PotentialUser-48> http://paste.debian.net/1183345/
<PotentialUser-48>Hello
<PotentialUser-48>Friends how do I solve this problem?
<PotentialUser-48>cbaines, !?
<cbaines>PotentialUser-48, did you see the questions I asked?
<PotentialUser-48>cbaines, I do not understand what you mean (I do not know much about Guix)
<cbaines>PotentialUser-48, OK, could you share what output you get when you run guix describe https://paste.debian.net/
<raghavgururajan>Hello Guix!
<nckx>Sup Guix.
<nckx>jonsger: qpdf. Or pdfarranger if you crave the GUI.
<PotentialUser-48>cbaines, ?
<PotentialUser-48>`guix pull`
<PotentialUser-48>`guix package -u`
<cbaines>PotentialUser-48, I don't understand what you're asking?
<cbaines>putting that aside, it does look like openimageio fails to build, since an update to pybind11
<cbaines>I've filed a bug about the issue https://issues.guix.info/46188
<aecepoglu[m]>A plugin (written in Rust) for a text editor. Should it go into 'text-editors.scm' or elsewhere (like how emacs has a file of its own)
<cbaines>aecepoglu[m], probably in text-editors.scm, assuming that's where the text editor the plugin is for is defined
<rekado>I successfully reconfigured my i686 on staging (haven’t rebooted yet, though)
<rekado>tried upgrading my packages but znc fails to build
<rekado>I also need to build gst-plugins-good from source
<rekado>also: beets and htop
<jonsger>nckx: oke, thx :)
<jmarciano>cbaines: alright, after guix pull as root, it started working for user
<jmarciano>great to have system that works on top of other system independently
<PotentialUser-48>cbianes: Why do I have that problem?
<PotentialUser-48>I did not do anything to cause damage...
<PotentialUser-48>I had no problem before.
<cbaines>PotentialUser-48, a change was introduced 4 days ago which broke openimageio
<iyzsong>PotentialUser-48: not you, but the latest guix have that problem (unable to build blender because openimageio failed to build).
*iyzsong AFK
<PotentialUser-48>Oh, Thanks
<rndd>hi everyone! how i can edit /etc/hosts ?
<mdevos>rndd: search for "/etc/hosts" in the manual, section "‘operating-system’ Reference"
<mdevos>rndss: for creating a file-like object, "plain-file" will probably suit your purposes
<mdevos>There's an example in the manual, see %facebook-host-aliases
<adfeno>Hi there, how to get lua package's Equivalent of “-dev” files mostly seem in distros such as Trisquel ? I want to get the files needed to build a local project that is using pkg-config.
<mroh>nice pkg name `guix show stuff` ;)
<raghavgururajan>nckx: Hey glad to see ya o/
<apteryx>why is the --max-jobs implicitly set to 2 for remotes when offloading?
<adfeno>Ah, I found the files I needed
<adfeno>under Lua's derivation path + /lib/pkgconfig
<civodul>apteryx: is it?
<raghavgururajan>apteryx: I think Makefile and/or make sometimes pass 'jobs' arguments.
<rndd>mdevos: thank you
<rndd> how many users have "stuff" in their packages's name 0_o?
<nixo_>hi! guix pull seems to be broken (at least, it is for me)
<nixo_>I get: (exception unbound-variable (value #f) (value "Unbound variable: ~S") (value (rust-dirs-2.0)) (value #f))
<nixo_>(-builder for `/gnu/store/zlij12n2xlfqvvf22c0rq0cpn6z5fmc0-guix-package-cache.drv' failed to produce output path `/gnu/store/c5jhqqpvs8bfn3a9wnl5nq52pac71zn8-guix-package-cache')
<raghavgururajan>leoprikler: Is this correct for rlottie-for-telegram-desktop? (git-version "2.4.4" revision commit)
<leoprikler>oof, it seems telegram has 2.5.8 now
<raghavgururajan>Okay I will update
<raghavgururajan>leoprikler: Shall we clean-up and push by today?
<pineapples>This Telegram thing got out of hand
<ngz>cbaines: Hi. I'm currently building the latest release of openimageio. Then I'll try to build blender and blender-2.79 in order to check if this is sufficient to fix them.
<ngz>It might take a while, tho.
<leoprikler>rlottie upstream version seems to be 0.1, but there is a 0.2 as well
<leoprikler>can you try checking if telegram builds against 0.2?
<raghavgururajan>Oh I meant for libtgvoip
<raghavgururajan>No, samsung/rlottie vanilla is different from desktop-app/rlottie
<cbaines>ngz, sounds good, I had a little look at building a newer openimageio, but just bumping the version to the latest one failed to build, I think due to new dependencies that were missing
<leoprikler>well, duh, but it might happen, that there's some actual compatibility
<ngz>I'm currently at 80% into build
<ngz>so far so good.
<ngz>My CPU is going to burn when building blender =/
*raghavgururajan just realised that he has to change commit and hash for telegram desktop's git-fetch inputs, all over again
<raghavgururajan>May be not. Some could be unchanged.
<raghavgururajan>leoprikler: okay. I'll try.
<leoprikler>tgvoip seems to be 2.4.4 + patches according to configure.ac
<ngz>cbaines: openimageio built. Now heading to blender@2.79
<raghavgururajan>leoprikler: So (revision "88") and (git-version "2.4.4" revision commit)?
<leoprikler>if there's been 88 commits since and that's what you're trying to indicate, go for it
<raghavgururajan>Yep!
<htgoebel1>kwayland stopped building between 8b555442 and 68dd78e2e - see <http://ci.guix.gnu.org/search?query=kwayland>: some test is failing. Curiously I get a different test error.
<htgoebel1>Any tips how to debug/fix this kind of issues?
<mothacehe>nixo_: hey, it should be fixed, you can run "guix pull" again.
<mothacehe>civodul: hey! looks like the recent shepherd service commit is breaking reconfiguration on berlin: https://paste.debian.net/1183356/
<raghavgururajan>How to build a hidden-package?
<nixo_>mothacehe: wonderful it did work, thanks!
<ryanprior>raghavgururajan: I think you can build it by defining a trivial non-hidden package that depends on it. Probably possible to do it via the guix repl as well but I'm not so handy with that.
<htgoebel1>raghavgururajan: Something like guix build -e '(@ (gnu packages maths) the-hidden-package)' could do the trick. see
<ngz>cbaines: blender should now be fixed. Testing blender-2.79b
<raghavgururajan>ryanprior, htgoebel1 Thanks!
<civodul>mothacehe: ouch!
<civodul>lemme see
<civodul>mothacehe: should be fixed now!
<civodul>lemme know if anything's wrong
<civodul>we have an "upgrade-services" system test, but it didn't catch this because it works at the later below
<civodul>*layer
<civodul>mothacehe: https://ci.guix.gnu.org/workers is impressive!
<civodul>did you use (guix status) to get build completion info?
<civodul>it's going to make a big difference to have this info available
<mothacehe> civodul: thanks for the fix, I'll reconfigure berlin :)
<mothacehe>glad you like it :) No, it's built upon the remote building mechanism. A message is sent by every worker just before starting the build and on build completion. The database is updated accordingly, and this page is just a nice representation of the database status.
<civodul>looking at /workers, i see that -127 was marked as building julia-adapt, but it was in fact (attempting to) build/substitute julia
<mothacehe>there's no need for (guix status) as each build triggers a new build-derivation RPC
<civodul>for build completion though?
<mothacehe>oh
<civodul>like -123 currently has a progress bar showing it's almost done with 'guix'
<mothacehe>no it's based on the duration of the last successful build with the same job name
<mothacehe>currently a package build can trigger the build of some of it's input, making this duration a bit inconsistent
<mothacehe>but in the future I'll implement "BuildSteps" as Hydra does
<mothacehe>it should fix this problem
<civodul>nice!
<mothacehe>spamming F5 to check progress bar completion is kinda addictive
<civodul>i confirm :-)
<civodul>will "guix publish" still have build logs to provide?
<civodul>when you run "guix build --log-file icecat --no-grafts", say ;-)
<mothacehe>oh I guess it wont, I have to find a way to fix it.
<mothacehe>on the overdrive front, I have played with wireguard, it seems like a nice workaround. However, it needs an open UDP port on berlin, I sent a mail to sysadmins about it.
<jonsger>mothacehe: oh that looks nice
<mothacehe>jonsger: thanks, it's largely inspired by the opensuse monitor you sent me
<mothacehe>even though they have nicer colors than I do for now
<jonsger>yeah, the similarity is not overlook-able :)
<jonsger>is it a feature that the evaluation numbers aren't counted +1, they look now like the number of commits or so
<mothacehe>the commits that did not trigger new evaluations are incrementing the evaluation primary key
<mothacehe>that's a difference between sqlite and postgresql
<jonsger>ah, thats fine...
<mothacehe>they have different behaviours on rollback more specifically
<mothacehe>maybe I can do somethin about that
<jonsger>it feels super fast now
<civodul>mothacehe: re VPN, we'll see; i suspect it's going to take time before the port is opened
<mothacehe>you mean the web interface ?
<civodul>is there an SSH tunnel kind of hack we could come up with in the meantime?
<mothacehe>civodul: the nice point is that once this one is opened we won't need any more port opening
<hwpplayer1>hi Guix
<civodul>mothacehe: ah true
<civodul>well, we'll see!
<civodul>hi hwpplayer1
<lfam>I'm going to merging staging into master this weekend
<lfam>If it goes well on my computer I'll push
<mothacehe>yes if rekado can give me an estimation of how long it could take, I'll think about an SSH based work-around
<civodul>lfam: i've reconfigured my system on staging, too (but haven't rebooted yet)
<lfam>You should try it and let me know how it goes :)
<civodul>mothacehe: i guess it depends on the availability/workload of the admin team
<hwpplayer1>I am focused on GNU Emacs and WM
<civodul>lfam: yup, i'll reboot soonish and we'll see :-)
<civodul>i have a childhurd in my config, which makes it quite demanding
<civodul>so if that works, that's good
<civodul>(and it does work)
<raghavgururajan>leoprikler: The upstream bug shouldn't be a blocker right?
<leoprikler>nope, just curious
<raghavgururajan>Cool!
<apteryx>lfam: I'll try reconfiguring my machine with staging right now
<apteryx>that's new: guix system: warning: mapped-device '/dev/sda2' may not be mounted by the bootloader.
<apteryx>not sure what that's about
<apteryx>it comes from 'system: Allow separated /boot and encrypted root.'
<apteryx>didn't even know this was possible; cool!
<apteryx>OK, apparently the warning above is because "Only devices specified by uuid are supported."
<apteryx>A hint would help :-)
<emsyr>Hi everyone. For sometime now I cannot reconfigure system cause kwayland.drv fails during check phase. Is there a way to skip the check phase? For "guix install" there is the --without-tests=[] option but there is not such option for "guix system reconfigure". Thanks.
<civodul>emsyr: hi! indeed, this option is not available for "guix system"
<civodul>did you report the kwayland build failure?
<emsyr>civodul not yet. I'm trying to see if there is a workaround. For "guix package -u" it worked but not for "sudo guix system reconfigure".
<emsyr>civodul not yet. I'm trying to see if there is a workaround. For "guix package -u" it worked but not for "sudo guix system reconfigure".
<civodul>emsyr: kwayland also fails to build locally?
<emsyr>civodul yes, the derivation is being built locally and it fails during the check phase.
<emsyr>civodul it can be installed only with the --without-tests=[] option so as check phase is skipped.
<shcv>how do I install the zfs modules? If I install the zfs package it just gives me the cli tools
<shcv>there are some patches on an email thread that make a service definition, but they don't seem to be merged yet
<luis-felipe>I'm reporting some bugs to Jami upstream, and they ask me to run "journalctl --since "24h ago" | grep dring".
<luis-felipe>What would be the equivalent in Guix System?
<mdevos1>zhcv: idk the specifics of zfs, but the usual way of using features implemented by unmerged patches is applying them to your local git clone, then using that patched guix (with ./pre-inst-env guix system reconfigure etcetera)
<mdevos1>luis-felipe: probably some file under /var/log
<luis-felipe>Also, how do I check the version of the ring daemon. Their instructions say: "/usr/lib/ring/dring -h"
<luis-felipe>mdevos1: I'll check there, thanks.
<civodul>luis-felipe: there's no Jami service in Guix System, so no equivalent to the journalctl command
<mdevos1>luis-felipe: maybe start Jami, run gnome-system-monitor and look where the dring location is located?
<mdevos1>luis-felipe: I wonder what Jami upstream hopes to find. The daemon is run as the same user as the Jami application, right?
<apteryx>luis-felipe: we should add one :-)
<luis-felipe>mdevos1: I think so, yes.
<mdevos1>So why would any information end up in a system log file? Perhaps ...
<mdevos1>Perhaps some thread encountered an ‘illegal instruction’, in which case some information about dring would end up in the output of "sudo dmesg"
<mdevos1>(or sudo dmesg -k, don't remember the exact command)
<mdevos1>(Pure speculation, though, and I'm assuming the Linux kernel here.)
<luis-felipe>civodul, mdevos1: thanks, I'll just omit that information from the bug report.
<luis-felipe>mdevos1: I could get the exact version of the Jami Daemon with your instructions, thanks.
<luis-felipe>Being a GNU package, it's sad that Jami works better in Android than in GNU.
<leoprikler>Is Jami really a GNU package tho?
***MidAutumnHotaru8 is now known as MidAutumnHotaru
<luis-felipe>leoprikler: That's what they say. "Jami, a GNU package"
<luis-felipe> https://jami.net/
<shcv>how do you include files in the system disk-image? E.g. .emacs.d and other dotfiles
<bandali>leoprikler, yes
<jlicht>hey guix!
<fnstudio>anyone that can point me to a guix-packaged guile project, that i can use as an example for packaging? it's for a simple project, so i suppose something that makes use of guile-build-system?
<luis-felipe>fnstudio: I have a couple of definitions like that for personal packages. See https://paste.gnome.org/p7l2giejy
<luis-felipe>fnstudio: The first package is just a guile library. The other package is a CLI program.
<luis-felipe>fnstudio: The "source" fields of these packages point to private repositories, so you should change the values according to your needs.
<luis-felipe>fnstudio: Or check Guix repository for more examples. For instance: https://git.savannah.gnu.org/cgit/guix.git/tree/gnu/packages/guile-xyz.scm
<fnstudio>luis-felipe: this is great! thanks so much!
<fnstudio>luis-felipe: actually the pastebin link seems broken
<luis-felipe>fnstudio: Yeah. Try this https://paste.gnome.org/p0vjuilwb
<fnstudio>uh, maybe it's because i'm not logged in?
<luis-felipe>It shouldn't fail. I'm not logged in either.
<luis-felipe>I failed again.
<luis-felipe>I'll use debian's...
<luis-felipe>fnstudio: https://paste.debian.net/1183391/
<fnstudio>cool, works now - thanks luis-felipe, very helpful
<luis-felipe>no problem
<lfam>Hey efraim
<efraim>lfam: hi
<lfam>I'm going to try merging staging later tonight
<efraim>Did I see civodul tested the childhurd process?
<lfam>I think (?). He said that "it does work" but it wasn't clear to me if he meant that it worked on staging or not
<efraim>I just ran the build instructions from (gnu system examples bare-hurd) to make sure that worked, and fixed a couple of packages
<efraim>that was a few days ago though
<lfam>I didn't notice but somebody pushed some commits to staging yesterday