IRC channel logs

2020-12-28.log

back to list of logs

<msdfgs>Thanks again dftxbs3e! It turned out to be a simple fact a dodgy copy of the image file. But having instructions really helped find the silly thing I was doing.
<buenouanq>savannah's down or something now
<bandali>re savannah, things look fairly normal to me, at least as of now. perhaps try again :-)
<malaclyps>I am thinking through a guix packaging question here, and I hope people don't mind me talking it through here, because more experienced folks may be able to see the answer quicker than I do!
<malaclyps>so I'm packaging up wlrobs, which is a plugin for OBS https://hg.sr.ht/~scoopta/wlrobs
<malaclyps>it conveniently installs the plugin into /gnu/store/blahblawlrobs/lib/obs-plugins which gets mapped into ~/.guix-profile/lib/obs-plugins which also has symlinks to a bunch of other obs plugins when obs is installed
<malaclyps>I thought that obs would spot it here, but it doesn't -- which makes me think that the packaged obs doesn't check ~/.guix-profile/lib for anything.
<malaclyps>Would a guix package normally have to be patched to check in ~/.guix-profile , or is that something that is magically done behind the scenes?
<guix-lvm>have anyone tried LVM with guix?
<guix-lvm>I wonder how should config.scm look
<baconicsynergy[m>hi guixsters! I've missed you all.
<baconicsynergy[m>I'm going to be rebuilding a server and I'm thinking of coming back to GuixSD :)
<baconicsynergy[m>It's been a little over a year I think. I'm sure much work has been done since then
<malaclyps>okay, it seems like most plugin-supporting packages either use an environment variable or patch the source (or both?). I guess I can set an environment variable in <guix-profile>/etc/profile, though I need to look up how to do that. OBS doesn't, I think, look at an environment variable for its plugin path, but it should not be too hard to add.
<malaclyps>so I guess these environment variables are called "search paths", and you can spit them out with guix package --search-paths. But, hmm, where are they set?
<malaclyps>I see now in the manual there is a "search-paths" and "native-search-paths" options in the package definition, which makes sense. It says they conform to the search-path-specification but that is never mentioned again... Let's look at the source, I guess!
<malaclyps>looking at guix/search-paths.scm which seems promising :)
<ride>I'm trying to install guix onto a hard drive that is connected to a system with guix on a foreign distro. I do not have the command `herd` and I am wondering which package it comes from.
<ride>Okay, it is a part of Shepherd. Can I not run `herd start cow-store /mnt` since I am not using it as an init system? I get the following error.
<ride>error: connect: /var/run/shepherd/socket: No such file or directory
<malaclyps>ride, i am not an expert, but you may need to start shepherd before herd commands will work.
<ride>malaclyps: Is it possible to run shepherd on a foreign distro?
<malaclyps>ride, i don't know (though I don't see why not). I am not sure how the cow-store service works, however
<malaclyps>huh, most of these packages define a native-search-paths, not a search-path which is surprising -- I'd assume by analogy to native-inputs that native-search-paths would just be used when building.
<malaclyps>(ride, I'm mostly talking to myself here about a packaging problem I'm working through)
<dftxbs3e>hello, how would you disable #:parallel-build? on a package conditionally without affecting the package definition's hash when the condition isnt met?
***davidpgil is now known as Guest58502
<marusich>Hello Guix!
<sneek>Welcome back marusich, you have 1 message!
<sneek>marusich, guix-vits says: thank you.
*marusich feels that karma.
<marusich>How do you tell if a debbugs bug is open or closed? I can never tell when I'm looking at the web UI, and for the life of me I have never figured out how to answer that question.
<marusich>example: https://debbugs.gnu.org/cgi/bugreport.cgi?bug=45252
<vagrantc>Done: Chris Marusich <cmmarusich <at> gmail.com
<vagrantc>seems to indicate it is closed
<marusich>Oh, OK.
<marusich>So consider this one: https://debbugs.gnu.org/cgi/bugreport.cgi?bug=26645
<marusich>I suppose the lack of any status indication means it's opeN?
<vagrantc>guess so.
<vagrantc>with debian, you can usually go read the bottom few posts as one of them will be the message that triggered the closure
<xelxebar>[14:26 <bdju> ryanprior: thank you for writing that blog post!] What blog post are we talking about here?
<ryanprior>xelxebar: https://www.ryanprior.com/posts/try-guix-package/
<ryanprior>I wrote a function to update the timestamps, it's not working and I'm frustrated. Is there a way I can get a debugger into this build and poke around?
<ryanprior> https://github.com/ryanprior/guix/blob/master/gnu/packages/vlang.scm#L156-L165
<ryanprior>The build completes, and when it does, all the lovely files have the exact same timestamp.
<ryanprior>I added in some (display) debugging and it looks like it's doing the right thing, eg: updated timestamp of /gnu/store/0lzc02wvx91z3c42dy1xn5l7zcvfnqk3-vlang-0.2/bin/cmd/tools/vdoctor
<ryanprior>But then when I go list files in that directory, vdoctor has the same timestamp as vdoctor.v
<ryanprior>My suspicions at this point are:
<ryanprior>1) utime does not actually change the last-modified time of a file at all and I need to use a different function; or
<ryanprior>2) something else is resetting all my timestamps afterwards
<ryanprior>I tried deleting the "reset-gzip-timestamps" stage and that has no effect.
<ryanprior>The docs for utime have me pretty convinced it's the right function and that I'm invoking it correctly.
<ryanprior>So I really suspect there's something that overwrites the modified times for files in my package. I'm gonna stop messing with it for now because I've double-checked everything I can think to and it looks right to me
<ryanprior>If anybody has ideas please ping me
<lafrenierejm>Any suggestions for managing VSFTPD in Guix System? Is it recommended to run it under xinetd?
***sneek_ is now known as sneek
<malaclyps>i guess native-search-paths means search-paths that also add values from other packages in the same profile (this is just a guess)
<malaclyps>ryanprior, are you trying to change the timestamp of files that are in the store (i.e. /gnu/store ?). I think that files are only put there by the guix daemon, and it clears the timestamp on all those files.
<ryanprior>shit
<ryanprior>Is there an option to not clear them, or should I submit that as a feature request?
<ryanprior>So here's the issue: in the tools directory there are a bunch of tool sources. If you run a tool, it checks to see if the executable is already built and is newer than the source. If not, it builds it.
<ryanprior>I ensured that we pre-build all the tools, but because the tools aren't newer than the sources, it's trying to re-build them at runtime, which of course fails because at that point the directory is read-only.
<malaclyps>ryanprior, I think it happens here: https://git.savannah.gnu.org/cgit/guix.git/tree/nix/libstore/local-store.cc#n329 (not helpful, just trying to make sure I got it right)
<ryanprior>So I need to change the modified times of the binaries in the store such that they are newer than the sources.
<malaclyps>i think you might have to just patch it so that it doesn't do that
<malaclyps>i too am exploring the exciting world of patching a package
<ryanprior>Oh I already patch it a bunch =D
<ryanprior>But I'm trying to be minimal
<malaclyps>yeah, that's quite the package definition! i get the feeling vlang is kind of in a world of its own
<malaclyps>NOT THAT THERE'S ANYTHING WRONG WITH THAT
<ryanprior>lmao yeah they have a lot of their own stuff that's kinda parallel to Guix, their build system bootstraps from a relatively small seed, their dependency management is source based and collects everything into a directory and deduplicates
<ryanprior>so v kinda creates a neat enclosed ecosystem, as long as you do everything in v you get these nice properties. but I also want to make it work nicely with the Guix ecosystem
<slogman>How do I prevent the dhcp-client-service from overwriting resolv.conf?
***apteryx is now known as Guest33950
***apteryx_ is now known as apteryx
<davidl>janneke: thats why I also tried to install gptfdisk which also fails.
<davidl>janneke: sry, old message. Thanks for the dh advice, it worked. However, it only says 1.4GB still despite reconfigure increasing the size, and restarts.
<Rovanion>How long after sending an email to guix-patches@gnu.org can I expect a reply from debbugs? I can't see the patch in https://issues.guix.gnu.org/ either.
<leoprikler>Rovanion: if it's your first time, it will be moderated, which can take some time
<leoprikler>if not, you should get a reply from the tracker rather quickly, but there have been times when email delivery was slow
<Rovanion>First timer here.
<janneke>davidl: can you share your config.scm/snippet?
<xelxebar>Rovanion: Welcome :)
<janneke>i'm using (disk-size (* 12 1024 (expt 2 20))) ;12GiB
<leoprikler>why not (expt 2 30)?
<Rovanion>xelxebar: Thanks! Got two more patches in store, one mor doc tidbit and one package.
<janneke>leoprikler: good point
<efraim>I apparently did something right. I was able to boot into enlightenment/wayland from sddm today.
<dftxbs3e>marusich, hello!
<cybersyn>hi Guix! I'm having an issue I'm trying to solve in Guix System: guix is saving the store to my root partition, but I want it to be saved to my home partition. here is my file system declaration:
<cybersyn> (file-systems (append
<cybersyn> (list (file-system
<cybersyn> (device (file-system-label "root"))
<cybersyn> (mount-point "/")
<cybersyn> (type "ext4"))
<cybersyn> (file-system
<cybersyn> (device (uuid "1FE8-A470" 'fat))
<cybersyn> (mount-point "/boot/efi")
<cybersyn> (type "vfat"))
<cybersyn> (file-system
<cybersyn> (device (file-system-label "home"))
<cybersyn> (mount-point "/home")
<cybersyn> (type "ext4")))
<cybersyn> %base-file-systems))
<cybersyn>what is the solution to get the guix store to begin writing to my home directory?
<roptat>I think you'd have to mount your home partition as /gnu?
<roptat>also please refrain from pasting more than 5 lines on irc, use paste.debian.net for instance for that
<cybersyn>oh really? I don't think I saw anything in the documentation instructing this
<roptat>it's just proper IRC etiquette :)
<cybersyn>but perhaps i was looking in the wrong place
<cybersyn>got it :)
<cybersyn>is there a section of the documentation you'd recommend reviewing?
<roptat>actually there are two possibilities: either you change the location of the store, or you mount another partition on /gnu
<cybersyn>changing the location of the store and then reconfiguring seems to be preferable, as /gnu is already populated
<cybersyn>i've read the basic reference, and am working through the "detailed nodes" reference now. but its been difficult to find a solution to this.
<dftxbs3e>janneke, hey! since you've done quite some bootstrap stuff, do you think it will be possible to just replace bootstrap binaries for PowerPC 64 bits once we find a way to make them reproducible? I would really like to have the freedom to do just that afterwards.
<roptat>there isn't one easy solution: there doesn't seem to be an option to do that
<roptat>also, changing the store location will prevent you from using substitutes
<roptat>well, at least substitutes that don't use the same store location
<roptat>the only way to change the location of the store, is at build time, when building guix
<roptat>so I would create a new guix package that inherits from guix and adds --with-store-dir=/home/store to the configure flags, and reconfigure your system with it, reboot and reconfigure again (so the new daemon can populate the new store)
<roptat>oh they left :/
<roptat>so I would create a new guix package that inherits from guix and adds --with-store-dir=/home/store to the configure flags, and reconfigure your system with it, reboot and reconfigure again (so the new daemon can populate the new store)
<roptat>but again, the second reconfigure will be very long, because you won't get any substitute from the guix build farm
<janneke>dftxbs3e: as long as you don't merge them in guix that's no problem at all
<janneke>...to officially upload non-reproducible binaries, ehm that sounds unwise
<dftxbs3e>janneke, I mean if we can't solve the reproducibility issues.. we have no GCC experts at our disposal now, it's been stuck for years because of that literally, there was some messages with Ludo and Efraim on the ML to say that some non-reproducible binaries were uploaded for other archs before
<dftxbs3e>I'm doing one last attempt with --cores=1
<efraim>for aarch64 I delayed guile from 2.0.13 (or 12) to 2.0.14 since that one was reproducable. I think I ended up with 3/5 reproducable, which was more than the previous architectures.
<dftxbs3e>The reproducibility issue seems really far and wide, it seems related to ELF section offsets changing from build to build
<cybersyn`>ropat: thank you! glad to know a solution
<dftxbs3e>(all binaries are affected in the GCC tarball)
<janneke>oh, that's terrible
<dftxbs3e>janneke, what is? :-)
<janneke>all binaries affected...
<dftxbs3e>ah yes..
<dftxbs3e>You understand me well!
<dftxbs3e>janneke, I have diffoscope somewhere.. let me dig it
<janneke>dftxbs3e: iwbn to try with a small binary and see if readelf helps
<dftxbs3e>efraim, marusich, seems --cores=1 does not have any effect on cross compilation
<dftxbs3e>janneke, well seems it doesnt happen on gcc-ranlib so "all" binaries was a bit of an hyperbole, it happens to many binaries :-)
<dftxbs3e>janneke, https://drop.infini.fr/r/WKANYbBpgV#lSXXleDAN2rW6BfMP1LWy4KUU+jTbfEv58+EKB/ekxY= - have a look, the diff is 88KB.. lol
<dftxbs3e>for gcc itself
<dftxbs3e>readelf output
<dftxbs3e>two gcc tarballs: https://drop.infini.fr/r/4wt__jyEgQ#9AFPEr5Qijc4JDzXSjysPhywyIRIjb+P+Al/vtTZs+o= and https://drop.infini.fr/r/jYnZLbFmhm#384nXbwtQZ4H4sbILN49B/tuKa3oAEdbZ0KM2lxlLFI=
***chrislck_ is now known as chrislck
<Rovanion>Do I have to restart Guix System after adding gvfs to config.scm as suggested here? https://unix.stackexchange.com/a/626439/27761
<Rovanion>Or is there another way to start the service?
<roptat>herd restart <the-service> should work
<roptat>except there's no service involved there, right? packages should already be available without a reboot
<Rovanion>Yeah, the post only mentions a package in code. Thunar still wont recognise that gvfs is installed.
<Rovanion>(sudo)? herd restart gvfs; says there is no service named gvfs.
<roptat>yeah sudo, but there's no service for gvfs, so of course you can't restart it
<Rovanion>Is there a way to list which services exist? Tab completion doesn't seem to do it.
<roptat>herd status
<roptat>sudo*
<roptat>those are shepherd services
<Rovanion>Thank you!
<roptat>which are a subset of guix services
<roptat>but gvfs is just a package, not even a guix service
<bandali>hey roptat, did you see my message here the other day?
<roptat>bandali, no I didn't
<bandali>roptat, i basically mentioned http://savannah.nongnu.org/task/?15757#comment12 in case you didn't get/see the replies on savannah
<roptat>ah let me reply
<roptat>ok, done, thanks for the reminder :)
<bandali>cheers, and thank you as well :-) i'll get to reviewing them over the next few days
<roptat>Rovanion, maybe the issue is that gvfs needs some sort of environment variable, that would explain why you have to reboot
<roptat>I've installed thunar and thunar-volman, and I already had gvfs in my system configuration; it works and doesn't display any error message
<raghavgururajan>Hello Guix!
<raghavgururajan>It appears some thing is worg with python stuff. The application udiskie and terminator does not start after recent guix pull.
<raghavgururajan>both given python related errors.
<Rovanion>roptat: Hmm, yeah that could be it. I always dislike having to reboot, its one of the things I enjoy not having to do on Linux.
<efraim>does anyone have a snippet to list packages which specifically have a package as an input? I'm looking for direct inputs, not the output from 'guix refresh -l foo'
<rekado>efraim: fold-packages can do that for you
<efraim>rekado: thanks
<rekado>bah, I’ve been trying to package r-mathjaxr, but instead of the bundled minified mathjax JavaScript I wanted to build it from source.
<rekado>I have no idea what I’m doing.
<efraim>rekado: debian implemented something in perl https://sources.debian.org/src/mathjax/2.7.9+dfsg-1/debian/
<efraim>might help
<rekado>unfortunately it doesn’t
<rekado>this is for 2.x; version 3.x is very different
<rekado>their packer and combiner stuff is roughly equivalent to our use of uglify-js / esbuild
<rekado>Debian take the pre-built JavaScript files from https://github.com/mathjax/MathJax instead of the sources at https://github.com/mathjax/MathJax-src
<rekado>I’ve built the TypeScript stuff already (with a few patches and deletions) and try to build the components next, but I can’t easily tell if the output makes sense.
<apteryx>do we have a docbook2html command in one of our packages?
<apteryx>apparently on debian it's in docbook-utils
<janneke>dftxbs3e: i cannot seem to download those urls...
<janneke>dftxbs3e: if it's in the elf headers of the executable, have you checked if the object files just before linking, are reproducible?
<gnutec>Tip: guix install sicp :D
<dftxbs3e>janneke, these URLs need JavaScript for download, it's client-side encrypted and you cannot disable it, they're the only easy Free Software file hosters I know, and it's client-side encrypted because it saves them from hosting legal risk
<dftxbs3e>janneke, I'd have to check that.. not so easy, finishing tests with --cores=1 for now
<profmakx>weird, why is guix trying to downgrade from 5.10.1 to 5.9.12?
<gnutec>profmakx, What? Do it another time.
<ces>Anyone can help with nouveau? I have the xf86-video-nouveau installed, but i don't know how to make it work with xorg correctly
<gnutec>ces, Are you using Guix System?
<ces>gnutec, yes
<gnutec>ces, Wait...
<ces>ight
<raghavgururajan>ces, if your using guix system, the display-manager service should start xorg along with the available drivers.
<raghavgururajan>*if you are using
<ces>I don't know if i am using that service thou
<ces>I'll check
<raghavgururajan>ces: You can include the driver in xorg-configuration.
<raghavgururajan> https://guix.gnu.org/manual/en/html_node/X-Window.html#X-Window
<raghavgururajan>There is a field called drivers
<ces>I'm checking it out
<raghavgururajan>gnutec might have a better idea :-)
<ces>raghavgururajan, i don't use a dm, and there don't seem to be a xorg service...
<gnutec>ces, What problem you have? Guix System take configuration of the X Windows to it self. So, no more xorg.conf.d or /etc/X11 like in Ubuntu.
<gnutec>ces, if we look to the guix.pdf, there is some instruction about it that can help you.
<raghavgururajan>ces, https://bin.disroot.org/?0d0bacba83639268#GYyn5fKcXfwKHDEBeiSKnF6vUXRNPStczHxxLw5527cg
<raghavgururajan>You have to include that in (services field of config.scm
<raghavgururajan>ces, If you are looking to establish a desktop setup, you config.scm should look like 'desktop setup' example at https://guix.gnu.org/manual/en/html_node/Using-the-Configuration-System.html#Using-the-Configuration-System
<gnutec>raghavgururajan, (driver '("driver 1" "driver 2" "driver n")) that is interest.
<gnutec>raghavgururajan, *(drivers ..
<raghavgururajan>Oh I missed a quotation
<raghavgururajan>leoprikler, o/
<raghavgururajan>sneek, seen nckx?
<sneek>nckx was in #guix 17 days ago, saying: jackhill: ppc64 == ppc64be(-only)?.
<leoprikler>Having rough days with my internet lately. raghavgururajan, o/
<dftxbs3e>raghavgururajan, worrying :-/ - but it's just vacation period so maybe not
*raghavgururajan missed nckx
<ces>gnutec & raghavgururajan, i'll try rebooting to see if it works
<raghavgururajan>Cool!
<dftxbs3e>hey can few people here create a single-core x86_64 VM and run a GNU Guix build command?
<dftxbs3e> https://debbugs.gnu.org/cgi/bugreport.cgi?bug=41669;msg=98 - follow these instructions, if you can, please and thanks!
<ces>Sooo, tried set-xorg-configuration, but it started gdm, which failed (i don't use a dm) so i had to roll back. Is there any way to set xorg settings without a dm? Maybe just a per user config would work, but i don't know of such a thing
<ces>perhaps, i can start xorg with some argument?
<raghavgururajan>ces: Can you share your services part of your config.scm?
<ces>Yes, one moment...
<ces> https://paste.debian.net/hidden/e8dfc479/
<ces>raghavgururajan, in the link i just send
<leoprikler>ces: set-xorg-configuration IIRC supposes you use the %desktop-services, which include gdm-service-type
<cbaines>I think the Guix services Xorg stuff revolves around using some display manager, I'm not sure an alternative approach has been written yet
<cbaines>I wonder if there's an open issue about this
<leoprikler>I think you will want to modify-services this
<leoprikler>For the record, which DM do you use?
<leoprikler>sddm?
<ces>leoprikler, none
<ces>I just run xinit
<raghavgururajan>ces: You are using %desktop-services, which includes gdm
<ces>I remove it to my knowledge
<leoprikler>yep
<raghavgururajan>ces: Ah, can your comment-out the removal of gdm part of the code and retry with set-xorg-config ...
<raghavgururajan>*can you
<leoprikler>I don't think they want to use gdm tho.
<ces>I probably could, but i prefer not to use gdm, and it breaks my bluetooth, so yea, as leoprikler just said
<raghavgururajan>Ah, ces, can you try replacing with slim-service-type?
<gnutec>ces, hope you create a backup of config.scm
<leoprikler>ces: set-xorg-configuration has a second argument tho, which is the service-type to base things on
<ces>gnutec, it's in git so it should be cool
<leoprikler>If you (handle-xorg-configuration do-nothing-service-type), you should be a-okay
<leoprikler>[you have to input your own do-nothing-service-type tho]
<ces>loeprikler, i just got exited for such a service type to already exist
<leoprikler>wdym?
<ces>nvm, i'll try to see if i can get it working
***ece1 is now known as ece
<leoprikler>ah wait, my bad, the syntax is (handle-xorg-configuration do-nothing-configuration do-nothing-service-type)
<raghavgururajan>cbaines: Where do I find public key of bayfront?
<drakonis> https://git.savannah.gnu.org/cgit/guix/maintenance.git/tree/ here?
<drakonis> https://git.savannah.gnu.org/cgit/guix/maintenance.git/tree/hydra/keys
<cbaines>that looks right https://git.savannah.gnu.org/cgit/guix/maintenance.git/tree/hydra/keys/guix/bayfront.guix.info-export.pub
<raghavgururajan>Thanks!
<raghavgururajan>In this part of the manual (https://guix.gnu.org/manual/en/html_node/Getting-Substitutes-from-Other-Servers.html), where should be the location of key.pub file?
<gnutec>Bye!
<leoprikler>raghavgururajan: you can put it anywhere. You could even describe it as a file-like object if you absolutely must
<raghavgururajan>Okay, I put it under /etc
<raghavgururajan>(local-file "/etc/foo.pub")
<leoprikler>for example
<raghavgururajan>cool
<apteryx>is anyone here familiar with the cpan importer? I'm trying to figure out if it's possible to import https://metacpan.org/pod/release/DMEGG/SGMLSpm-1.03ii/SGMLS.pm
<atom`>What is the (if any) "Guix way" of adding groups to the system? Trying to add my user to the "usb" and "plugdev" groups in /etc/config.scm, but they apparently don't exist by default
<raghavgururajan>atom`, operating-system configuration of config.scm
<raghavgururajan>oh you did it already and didn't work?
<atom`>raghavgururajan: I'm getting "guix system: error: supplementary group 'plugdev' of user 'atom' is undeclared" when trying to add that group to the list of user groups
<atom`>When running "guix system reconfigure /etc/config.scm"
<raghavgururajan>atom`, The error seems that those group names does not exist or not provided by any service or packages.
<atom`>Yes. Sorry if my question was not clear. I'm asking how to add the group to the system such that I can add the user to the group in a "portable way" (I'm guessing this should be done from /etc/config.scm).
<raghavgururajan>atom`, Is there a sepcific reason you are looking those specific group names?
<raghavgururajan>Names might differ across distros
<atom`>I cannot get my FIDO U2F device to work. Looking at wikis for other Linux distros being a member of these groups seems to be necessary
<raghavgururajan>Ah, groups are made available to system via services. For example, when you have tor-service-type, the group 'tor' is made available. You can then add any user to that group, by appending the group name in groups list of that user in config.scm.
<atom`> https://lists.gnu.org/archive/html/guix-devel/2020-01/msg00425.html suggests needing to be member of the plugdev group. https://wiki.gentoo.org/wiki/Pam_u2f#Authorizations suggests having to be member of the usb group.
<raghavgururajan>atom`, regarding 2-factor authentications, you might need specific udev-rules.
<atom`>I see. Perhaps the problem is unrelated to groups though. I have manually added the udev rule and confirmed it is there. The device also appears correctly in dmesg
<raghavgururajan>I see. You might also need PAM rules
<raghavgururajan>atom`, can you try adding group-names "netdev"
<atom`>To my user in the config?
<raghavgururajan>yeah
<atom`>I will give it a try
<raghavgururajan>I have these => "wheel" "netdev" "audio" "video" "lp" "cdrom" "tape" "kvm" "tor"
<atom`>I see I actually was in the netdev group before when I ran Guix SD. Perhaps that is it.
<atom`>raghavgururajan: Do you get an error if you run "pamu2fcfg -d -n"?
<raghavgururajan>I do not have that program
<atom`>Ah ok.
<atom`>Does U2F work in Icecat for you?
<raghavgururajan>Unfortunately, I have not setup U2F
<raghavgururajan>atom`, I am optimistic about netdev group.
<raghavgururajan>IIRC, there is something usb-mode-switch
<raghavgururajan>*something called
<raghavgururajan>I think user has to be in netdev group for that
<atom`>I added my user to the netdev group and reconfigured the system, but it still does not work. I will try to restart the system and see if that fixes it.
<atom`>I'll let you know how it goes :)
<jonsger>does someone know if there is a way to force launch a program via Xwayland in a wayland session?
<raghavgururajan>atom`, Any luck?
<atom`>raghavgururajan: Unfortunately it still does not work.
<raghavgururajan>oh :(
<raghavgururajan>I have one last idea, (service usb-modeswitch-service-type)
<raghavgururajan>atom`, ^
<kingcons`>Hey folks. My load-path is different when I launch emacs from stumpwm vs a term. My bashrc should be sourcing all profiles as recommended in the cookbook. Any idea why I might be seeing a difference? (Term sees the profile's site-lisp, stumpwm launched does not)
<atom`>The command I asked about earlier gives the output "USB read rc read 64
<atom`>USB rc -2
<atom`>Unable to generate registration challenge, error in transport layer (-2)", might be some permission related issue
<atom`>raghavgururajan: I will give that a try as well
<raghavgururajan>Ah, might be.
<ngz>efraim: Thank you for fixing my mistake!
<raghavgururajan>atom`, It appears that 'plugdev' is only needed for using pmount. Not sure if pmount is used in guix.
<atom`>raghavgururajan: Still doesn't work unfortunately. I will contact Nitrokey to see if they know what might be wrong. Thanks for all your advice!
<raghavgururajan>atom`, Cool! Sorry that it didn't turn out well.
<kozo[m]>Greetings, how would I modify my config.scm to add (--listen=128.0.0.42:1234) to the guix-daemon?
<kozo[m]>or just open a port?
<kozo[m]>nmap localhost shows 22 is open due to the openssh service
*kozo[m] sent a long message: < https://matrix.org/_matrix/media/r0/download/matrix.org/kKXAoxWkJDYhxPWZSxCbdKCd/message.txt >