IRC channel logs

2020-10-03.log

back to list of logs

<xelxebar>Having trouble building the package `newsboat'. It's erroring out with: `rustc -vV` (signal: 7, SIGBUS: access to undefined memory)
<xelxebar>Would someone mind sanity checking for me on their local machine?
<lispmacs[work]>holy bananas, 3700 rust dependencies
<lispmacs[work]>xelxebar: I am trying now
<lispmacs[work]>but looks like I've got to download 3700 rust dependencies first
<bdju> http://ix.io/2zxR anyone know what would cause all these segfaults? could it be one thing causing it for several programs? mostly it's qnetworkaccessm, which I suspect is related to quaternion, but I also notice pavucontrol in there
*raghavgururajan + zopiclone = 😴
<xelxebar>lispmacs[work]: Yeah... it's somewhat ridiculous. Thanks!
<xelxebar>sneek: Tell efraim: Hey, just a quick ping. Any news on what happened with your pine64 board?
<sneek>efraim:, xelxebar says: Hey, just a quick ping. Any news on what happened with your pine64 board?
<xelxebar>sneek: Later tell efraim: Hey, just a quick ping. Any news on what happened with your pine64 board?
<sneek>Got it.
<lispmacs[work]>xelxebar: I didn't have trouble building it with the guix build command, but I'm not quite 100% if it was using a substitute or not. This is from guix commit 23dc21f05b54ef63daaea9eb301cfddbc4c82ddb
<lispmacs[work]>I'd look into it more but I need to leave work now.
<lispmacs[work]>I used -M 1 option also
***allan is now known as Guest72214
<xelxebar>lispmacs[work]: Cheers, mate. At least now I know it might be a local issue.
<Guest72214>Hello, I am trying to create a package for the video editor olive, but I am running into an issue during the build process. The error I receive is "lrelease error: unexpected tag <html> at /tmp/guix-build-olive", but I am not too sure what that refers to. Any thoughts?
<Guest72214>error: https://paste.debian.net/1165720/
<Guest72214>code: https://paste.debian.net/1165721/
<apteryx>is it me or emacs-guix's 'M-x guix-edit' is broken since some time (perhaps with the Emacs 27 upgrade?)
<apteryx>Guest72214: not sure! Perhaps an actual problem in the source? This error here was similar, and it seems it was a valid problem in the DTD: https://github.com/translate/pootle/issues/5418
<apteryx>in the XML structure not validating the Qt ts file format DTD, I mean.
<Brendan[m]2>apteryx in what way is it broken
<Brendan[m]2>mine says no repl for buffer
<ryanprior>dogg.... one of my last dependencies to package for Hugo is gocloud.dev....... but it alone has 40 dependencies
<ryanprior>40 /direct/ dependencies, some of which look ominous like "github.com/Azure/azure-sdk-for-go"
<Brendan[m]2>Calibre 5 is on python3 woohoo
***sneek_ is now known as sneek
***apteryx is now known as Guest68452
***apteryx_ is now known as apteryx
<cbaines>Does anyone object to the deletion of the r-updates branch? https://git.savannah.gnu.org/cgit/guix.git/log/?h=r-updates
<cbaines>I think it's out of date, it looks like rekado last pushed back in April
<cbaines>I'm guessing wip-gnome3.34 is no longer relevant as well
<cbaines>I've deleted wip-rails, as Guix has a ruby-rails package in master now
<janneke>=> https://lilypond.org/janneke/guix/hurd-substitutes.gif
<Brendan[m]2>i thought that meant it was substitutes for lilypond running on the hurd
<janneke>almost
<mfg>how did you record that gif janneke?
<jonsger>janneke: so does lilypond.org already run on a childhurd machine :P
<janneke>mfg: M-x gif-screencast
<janneke>jonsger: same answer as for Brendan[m]2: almost
<jonsger>:) nice progress, I'm a little impressed...
<mfg>janneke: thank you :)
<janneke>mfg: yw
<janneke>jonsger: thanks ;)
<mfg>python-shapely fails to build with the message "Could not find library c or any of its variants" i guess it means libc? https://ci.guix.gnu.org/build/1711583/details seems to suggest it should be working?
<mfg>guix time-machine is a really nice feature btw! are there any "standard" procedures if searching for a commit that broke a package? something like a time-machine bisect?
<civodul>mfg: not yet! but it's been suggested a few times, would be nice!
<civodul>janneke: great video :-)
<civodul> https://toot.aquilenet.fr/system/cache/media_attachments/files/001/733/991/original/0896d01b019874c5.mp4?1601718960
<mfg>civodul: thanks for the info :)
<janneke>civodul: nice, thanks :-)
*janneke couldn't resist
<Brendan[m]2>why is there no char->string ?
<janneke>Brendan[m]2: there is list->string and make-string
<Brendan[m]2>oh ok
<civodul>Brendan[m]2: there's also 'string', which is essentially what you call 'char->string'
<civodul>no shortage of string constructors :-)
<Brendan[m]2>i see i see
<mfg>is something with ci.guix.gnu.org?
<mfg>nvm it's normal again :D
<halfdann>Hi all! I'm making good progress on defining my first Guix package - but there are a few questions I still have. Hope this is the right place to ask
<Brendan[m]2>yayaya
<halfdann>Is it possible to "source" a shell script in a build-phase, to set a list environment variables? The project I'm building declares a list of env vars that way that have to be set during build
<Brendan[m]2>you could run (invoke "./script")
<Brendan[m]2>that might work
<halfdann>it's not an executable and it just exports variables, I tried running (invoke "source ./script") but that doesn't seem to work
<mfg>if there aren't to many vars in that file, why not (invoke "export VAR=VALUE") for all of them?
<civodul>halfdann: you cannot "source" it strictly speaking because the build phase are not executed by a shell
<civodul>*phases
<mfg>okay then i gues my idea is also impossible :D
<civodul>you could do something like (invoke "sh" "-c" ". ./script; make")
<mfg>what kind of information is stored in the database in /var/guix/db? I read the schema file - it only saves metadata of the store?
<halfdann>Ok that makes sense. (invoke "export VAR=X") doesn't seem to work, I guess because it's not a shell
<Brendan[m]2>but you can do (setenv "VAR" "X)
<halfdann>but I can try to use (invoke "sh" "-c" ". ./script; ...") to execute the configure command of the cmake-build-system
<mfg>so you need to set Variables for cmake?
<mfg>if those variables are for configure then you could also use :#configure-flags
<halfdann>Brendan[m]2: that would work I think, but there is some shell logic (grep sed / grep) involved in the definitions. I could copy that to scheme though
<halfdann>mfg: maybe putting them in configure flags will work, I'll give it a shot. not sure yet where these variables are used in the build process. thanks!
<raghavgururajan>Hello Guix! 🤢
<janneke>hello raghavgururajan!
*raghavgururajan tried 'Steamed Apple Juice' from Starbucks for first time, early in the morning, and puked. 🤮
<nckx>Warm apple juice is pretty hurl-worthy also good morning everyone.
<raghavgururajan>o/
***lxsameer is now known as Guest22587
<str1ngs>apple juice or apple cider?
<roptat>mh... my gitolite settup is broken, I set GIT_CONFIG_KEYS in the rc file (from the git config, but also tried overriding the file manually), but it doesn't seem to be able to see it...
<roptat>so everytime I try to update the setup, it keeps telling me FATAL: git config 'core.sharedRepository' not allowed
<cbaines>roptat, assuming you're using the Guix service, is the RC file being created correctly?
<cbaines>Looking at my own configuration, I use a (plain-file ...) for the RC file, and that contains GIT_CONFIG_KEYS => '.*'
<nckx>Huh.
<nckx>I think I finally figured out why I took so long to warm to issues.guix: its colour coding of open (green) and closed (red) issues taxes my reptile brain.
<roptat>cbaines, yes, the generated file contains GIT_CONFIG_KEYS => '.*'
<leoprikler>it is not alone in that choice tho
<leoprikler>github also has green for open and red for closed and i think gitlab too
<nckx>Nutz.
<leoprikler>okay, blue for closed on gitlab
<cbaines>roptat, what do you have in the ENABLE list in the RC file?
<nckx>It makes sense in isolation when you're writing .open/.closed CSS at 2 a.m., but staring at a bright-green ‘yay! errors!’ lights is weird, and the ones popping out in red are... fixed? Anyway, never mind, I'm just happy to know what was bothering me.
<cbaines>roptat, I think you might need 'git-config' in that list https://github.com/sitaramc/gitolite/blob/master/src/lib/Gitolite/Rc.pm#L598-L599
<roptat>I have it already
<roptat>here is my current rc: https://paste.debian.net/1165774/
<nckx>Is anyone using Guix System with 1GB of RAM and enjoying it? If so, how much extra swap does your enjoyment cost?
*nckx rediscovered a forgotten free VPS with only 10 gigs of rotating storage and unsure whether to install Guix System or some BSD.
<cbaines>roptat, hmm, I'm unsure why it doesn't seem to be working. Although I'm not trying to set config values through the gitolite.conf file
<cbaines>roptat, why do you want to set core.sharedRepository?
<raghavgururajan>str1ngs: Juice
<raghavgururajan>nckx: Just checking, do you receive my direct messages?
<nckx>Oh. Yes. Just not notified.
<raghavgururajan>Cool, wanted to ask you about emails.
<rekado>cbaines: feel free to remove it!
<raghavgururajan>Free VPS 🤩 ? Gimme gimme gimme
*raghavgururajan is looking to self-host bitwarden
<cbaines>rekado, great, I'll go ahead and delete the r-updates branch then
<raghavgururajan>nckx: May be (if you are okay with it), you can use that VPS to host pastebin for guix?
<raghavgururajan>nckx: Regarding your RAM question, two years ago, I tried running guix (bare setup) in a VPS with 1 CPU + 256MB RAM. It booted and ran well.
<nckx>Well that blew up. To everyone PMing me about teh free veps: sorry, it was a special offer. But black friday's coming up folks, just keep your eyes open and you'll have five if you want to.
<raghavgururajan>Which provider?
<nckx>BuyVM.
<nckx>raghavgururajan: All right, guess I'll give it a go. Ran GuixSD with 256MB some 5 years ago. Guix-related operations (esp. guix pull) were best run during lunch but did eventually return. I thought RAM requirements had ballooned since then.
<nckx>Thanks.
<raghavgururajan>Np!
<raghavgururajan>So BuyVM's DirectAdmin is a free software?
<nckx>Absolutely not.
<nckx>I wouldn't pay to use it. 🙂
<raghavgururajan>Just read it. It was free as in money, for existing customers. *poop*
<nckx>If you want a host that uses exclusively Free software, (a) good luck (b) look for e.g. Webmin or ISPconfig.
***jonsger1 is now known as jonsger
<raghavgururajan>1984hosting uses free software for almost everything. I used them before.
<nckx>Or ProxMox.
<morgansmith>so I want to get into hacking org mode for emacs but our package is for elpa, and building from source is pretty different. Now there are a billion things that depend on org and I'd like them to work with a source built package. Should I try to replace our org package with a source version or is there a nice way to make an org-next thingy?
<nckx>raghavgururajan: Sure. There was an implicit ‘in this price category’ that should have been explicit.
<nckx>1984 is great, used them before, do recommend.
<raghavgururajan>Also gandi I think. There was no cPanel while I setup my nextcloud.
<raghavgururajan>IIRC, vikings.net is working on full-blown free software enviroment. Like even using RYF-certified hardware.
<raghavgururajan>*hosting environment
<nckx>raghavgururajan: You seem to be talking about a system where cPanel is used to install software onto a ‘managed VPS’?
<raghavgururajan>yeah, where php and ftp is configured.
<nckx>vikings.net is down.
<nckx>It's also a very mixed bag. I'd love to recommend them but as it stands, ‘it depends’, and that's only because of the Freedom...
<raghavgururajan>Seems like gandi has their own admin software. The interface load with LibreJS. So free software I guess.
<raghavgururajan>You mean mixed bag, for shared/managed hosting?
<nckx>raghavgururajan: I'm not talking about managed VPSes though. If your provider's control panel can install software onto your VPS (madness) I agree that its freedom is important. For me, it's like a web shop: great if it's free, but not my problem if it isn't.
<nckx>I haven't bought shared or managed hosting this millennium.
<raghavgururajan>Ah yeah.
<raghavgururajan>But I read that gandi doing it differently.
<raghavgururajan>Quoting from website:
<nckx>All I need from a panel is the reboot button and an rDNS text field and that's always worked with LibreJS, so the rest is the provider's problem.
<raghavgururajan>Our hosting solution is built a little differently as each instance has its own private Linux container (LXC). The reason for doing this is to guarantee you the best possible performance for your websites, to guarantee this performance in the long run, and to securely isolate your hosting environment from other customers.
<morgansmith>Oh dear, 1984hosting has guixsd 0.16.0. How old is that? I joined after 1.1.0
<raghavgururajan>IIRC, usual shared/mnaged hosting doesn't run in containers, they share everything.
<raghavgururajan>morgansmith: It was me. I sent it to them to make it available. It was 2 years ago.
<nckx>morgansmith: They'll happily update that if you ask.
<morgansmith>Will do!
<nckx>I just hope none of the 1.1 bugs affect their machines.
<nckx>(The bugs affect only the installer, so if that works it's fine.)
<morgansmith>so about my new org package (which I've now completed). Is there a nice way to superseed a package? So that if I add an emacs-org-next package I can force everyone to use that in their inputs instead of emacs-org?
<civodul>morgansmith: there's 'deprecated-package'
<nckx>You can't force it, but you can suggest it with deprecated-package.
<nckx>Eventually it will be forced when the old name is removed...
<morgansmith>Ya but like org-next would be used for developers of org only, and everyone else should still use org because that's stable
<morgansmith>maybe I'll just replace org with a definition that can build from source so I can just change the commit using our --with-git-commit stuff...
<nckx>So you want Guix to read minds? Or suggest different deprecations based on whether the user/package is ‘using’ emacs-next? I don't see how that's possible.
<nckx>Or that ‘org’ should only be installed by users, but never an input to packages which should always use ‘org-next’?
<morgansmith>I just don't want to replace org and mess it up again like I did emacs-next...
<morgansmith>I wanted something like guix package -m testmanifest.scm --with-package=emacs-org=emacs-org-next
<nckx>It's still not clear to me exactly what you want, but it sounds like the solution is a social one (add org-next; implore the brave to test it on the ML or whatever) rather than technical.
<nckx>Yes, any interface to Guix's package input rewriting should handle that.
*nckx clocks out for the day; evening all.
<morgansmith>nckx: Take care!
<ryanprior>morgansmith: I think that might be a good use case for the guix-potluck proposal (https://issues.guix.gnu.org/26645)
<ryanprior>For when you want to have test packages for devs that live outside the Guix tree
<ryanprior>Hasn't been any movement on Potluck since 2017 though
***lxsameer is now known as Guest90812
<roptat>cbaines, core.sharedRepository ensures the repository is read-only for the group, instead of nothing
<roptat>it allows me to use git-daemon, and allows gitile to work
<cbaines>Ok, I'm not sure what's going wrong :(
<roptat>actually core.sharedRepository is set now, for some reason
<roptat>but the hook still fails with the same error, and does not allow me to add other keys :/
<roptat>can you share your config? maybe I'll be able to figure something out
<janneke>i'm doing: ./pre-inst-env guix build python-minimal --without-tests=python-minimal guix -dn
<janneke>in an effort to build python-minimal without tests
<janneke>it shows two python-minimal derivations, one with #:tests #f, and one with #:tests #t
<civodul>oh, interesting
<civodul>hmm could you try with --no-grafts?
<janneke>it also shows that libxslt-1.1.34.drv, e.g, depends on python-minimal-wrapper, that depends on the #true version :-(
*janneke tries
<janneke>civodul: ouch!
<janneke>adding --no-grafts gives a backtrace
<janneke>ice-9/boot-9.scm:1669:16: In procedure raise-exception:
<janneke>Unrecognized keyword: #:tests?
<janneke>
<civodul>oops :-)
<janneke>the cool bits here is: guess the OS that i need this for ;-)
<janneke>*are
<civodul>i think tests pass! i think it built it on my laptop yesterday
<civodul>anyway "guix build guix --without-tests=python-minimal -n --no-grafts" doesn't crash for me
<janneke>oh, i'm tooo impatient
<civodul>(on x86_64-linux)
<civodul>it's fine too without --no-grafts
<janneke>ah, good
<janneke>yes, i see, thanks!
<janneke>ah, but adding --no-grafts rebuilds world; i'll retry and be patient ;)
<civodul>ah!
<civodul>but can you still make it crash?
***sneek_ is now known as sneek
<janneke>this crashes: guix build python-minimal --without-tests=python-minimal-wrapper -dn --no-grafts python
<janneke>(i didn't mean to run this, it was a typo)
<ryanprior>What's an unreasonably long patch series to send? Ballpark?
<ryanprior>Context: I'm at 59 new packages already in my Hugo effort.
<ryanprior>I realized yesterday that one of the remaining deps I'll need to package has 40 deps, of which I estimate ~20 aren't in Guix yet.
<ryanprior>So that's pushing the number of patches up to ~80.
<ryanprior>Is that in the ballpark of a merge-able patch series or should I start strategizing to break this up into multiple series?
<cbaines>Thinking about it from the perspective of those reviewing them, I'd perhaps send batches of however many patches you think is reasonable
<kmicu>[Jokin’] I’m not aware of any CVS against Hurd so if I keep staying inside childhurds I should be immune against non‑targeted attacks on my systems. amirite?
***Guest90812 is now known as lxsameer
***allan is now known as Guest79882
<Guest79882>Hello, I am working on packaging a software at the moment, and it fails during the install stage. I am trying to install it system wide, but it gives me a permission denied error. Why is that?
<roptat>are you creating a guix recipe, or insatlling a binary outside of guix?
<ryanprior>Guest79882: in a Guix package you need to make sure you're installing it into the %output directory.
<roptat>Guix has no notion of a global "system wide" location, each package is installed in its own directory under /gnu/store
<ryanprior>Guest79882: in order to maintain a controlled environment for deterministic, reproducible builds, Guix does all packaging operations in a sandboxed environment
<roptat>so if it's a package, you use %output, (or in a phase, (assoc-ref outputs "out"))
<ryanprior>Trying to install to a system-wide directory will result in permission denied because the sandbox is enforcing where the build can read and write.
<ryanprior>You might find that surprising and think "that's gotta violate the POSIX standard" and indeed it does! Guix does not follow POSIX so you've gotta relearn a lot of system organization stuff.
<jlicht>ryanprior: POSIX -> FHS, by any chance? Otherwise I am confused now too :-)
<roptat>yeah, FHS
<ryanprior>jlicht: I thought FHS was part of POSIX but I take it from your responses I've probably made a bad inference at some point
<roptat>Guest79882, so if it's a recipe, you can always post it in paste.debian.net for instance, and post the link here, and we'll be glad to help!
<jlicht>Met my pedantry-quotum for the weekend, nice. How goes the Hugo undertaking, ryanprior?
<ryanprior>jlicht: 59 packages down, I'd estimate another ~25 to go
<Guest79882>ryanprior and roptat, thank you! Here is the code: https://paste.debian.net/1165793/
<ryanprior>Up next is `gocloud.dev` which is the Google Cloud SDK for Go, and it in turn depends on the AWS Go SDK and the Azure Go SDK, so it's gonna be a bear of a package.
<jlicht>good luck, I hope it's more fun to package than the Azure python CLI tooling
<ryanprior>I mean, Python has a pretty good Guix importer in my experience
<ryanprior>Go doesn't have an importer so I've written out all 59 packages by hand (with help from some custom Emacs macros)
<jlicht>that sounds a lot less fun, to be honest :P
<ryanprior>jlicht: if you are interested in speeding the effort along, it would be really helpful to have somebody proofread the existing package definitions
<roptat>Guest79882, I imagine -DSYSTEM_INSTALL=1 tries to install to /usr and such? ignoring guix's own flags, like DESTDIR etc?
<ryanprior>I've been churning them out and suspect that I might have put the wrong license on some, or forgotten to update the package description, etc
<roptat>or maybe it's trying to install to something like /gnu/store/.../bin/... but doesn't create the bin directory first?
<jlicht>ryanprior: I've never worked or packaged anything relating to Go, but I can have a look at licensing/description and functional testing etc :-)
<roptat>(or whatever directory structure it wants)
<roptat>Guest79882, can you also give us the exact error? You probably have a backtrace?
<ryanprior>Reading these packages ought to give you a nice intro to what Go packaging looks like! There's a few gotchas but it's mostly not bad.
<Guest79882>@roptat here is a paste of the build log: https://paste.debian.net/1165795/
<roptat>Guest79882, ah nevermind, I copied your code and tried to build, I get the issue too (obviously ^^)
<roptat>so it's actually trying to install to the directory of obs
<roptat>but we can't have that: obs is installed in its own directory under /gnu/store, and noone is allowed to change it
<ryanprior>My Hugo-related packages so far are at https://github.com/ryanprior/guix-packages/blob/master/testing/hugo.scm
<roptat>so we have to look at the CMakeLists.txt to see how it installs things, and why the destination ends up being in obs's store path, instead of obs-gphoto's own store path
<roptat>looking at it, it looks like it installs the plugin in LIBOBS_PLUGIN_DESTINATION
<ryanprior>And for anybody who wants to critique, I would very much appreciate hearing feedback and you should feel free to open an issue in that repo
<roptat>it's not defined anywhere though, so I guess it's actually defined in obs
<jlicht>ryanprior: how did you decide which versions of each dependency to package? Just the latest stable release, or does 2020-Go have normal dependencies with actual versioning now?
<ryanprior>My intention has been to package the latest stable version of each package that matches the /major/ version needed by Hugo.
<roptat>so maybe replace LIBOBS_PLUGIN_DESTINATION with ${CMAKE_INSTALL_PREFIX}/lib/obs-plugins in a phase, before building
<roptat>(you'll find plenty of examples of substitute* in the guix repo)
<ryanprior>That may come back to bite me later and I need to go back and downgrade some packages to get Hugo to build. But I'm hoping it won't come to that.
<Guest79882>Thank you roptat! I had been looking at the code in the guix repo and it has been enourmously helpful.
<ryanprior>Go does support versioning packages, you can check the `go.mod` file in a repo to see deps & versions requested.
*roptat is trying to build his own software with guix, and it's surprisingly resistant ^^'
<roptat>I forgot about the part where it pulls a big jsonld file from the net to generate a huge scheme file from it
<roptat>thanksfully I had an undocumented flag that uses a bundled version of the jsonld file instead
<jlicht>ryanprior: do you want one issue per perceived issue, or rather one issue for just my nitpicks?
<ryanprior>jlicht: either way is fine, if you put them in one big issue please format them as a checklist so it's easier for me to track progress addressing them.
<ryanprior>fwiw the GitHub green kitchen tile backsplash will reward you more if you open more issues
<jlicht>I have no clue what you are talking about, and am not quite sure if I want to :P.
<ryanprior>oh lmao if you go to github.com/yourusername it'll show a tiled history of your "contributions" and it counts each issue you open as a contribution, but adding to a previous issue doesn't count
<helaoban>brand new to guix and I'm having trouble installing elixir, it's failing with ''replace-paths' phasebuilder for `/gnu/store/nyl5zllwxcj6qzysckpypxmcggr50kcw-elixir-1.10.4.drv' failed with exit code 1'
<helaoban>not sure where to start with this.
<helaoban>here is the tail of the build log: https://paste.debian.net/plain/1165798
<roptat>probably because git is not in the inputs set of elixir, I wonder how this was pushed...
<roptat>ok, here's the culprit I think: a749caa74e2a44a37d3a4af06cf4c18f9e463fbb
<ryanprior>Dang helaoban that looks busted asl glad you brought it up
***jess is now known as j
<roptat>helaoban, it should be fixed in a3e26863146ffc100ced3600bfc49814d04ae643, you can run "guix pull" to get that version
***Citrouille is now known as ping
<helaoban>ryanprior, roptat: wow that was a super quick fix, working on my end, thanks guys.
<ryanprior>helaoban: we appreciate your input, holler any time something feels off!
<helaoban>what's the general philosophy on pinning dependencies for a project in a guix profile, e.g. if my project needs python 3.7.4 specifically, and the current guix version is 3.8.2? Do I have to create my own package definition? Are there aany 3rd-party repos that host definitions of older package versions, similar to ubuntu's PPAs?
<helaoban>ryanprior: will do.
<cbaines>helaoban, Guix has multiple versions of some packages, although in the case of python, it looks to currently just have 2.7 and 3.8
<jlicht>helaoban: there is a guix-past channel, but it doesn't seem to contain your specific version of python. If there is a good reason to support both python 3.7.4 and 3.8.2, it can go to guix proper; I think we have done that before for lts + latest stable releases of software as well
<cbaines>I think this general issue of older versions is where channels can also be really useful
<cbaines>There's a channel with multiple versions of coq if you're in to that https://framagit.org/tyreunom/guix-coq-channel :)
<civodul>oh nice
<civodul>there's also Guix Past, for the things of the past!
<civodul> https://gitlab.inria.fr/guix-hpc/guix-past
<jlicht>helaoban: If guix did at some point offer the version of python you need, you could also use inferiors for that. The update to python 3.7.4 happened with commit 680bc34da on master.
<ryanprior>I'm interested in building a tool for the Guix data service to let you browse all past versions of a package in Guix and helps you set up inferiors to use them.
<ryanprior>In some communities where pinning specific versions of a package is considered critical for support reasons, the current model of eagerly updating packages wouldn't fly at all. Such a tool could make it feasible to give a list of packages and specific versions and get back a ready-to-go list of inferiors to make it happen.
<pineapples>Hi! I'm documenting my code, and I've found myself unable to figure out what are the rules for deciding whether to use quotation marks or double semicolons
<civodul>ryanprior: that'd be nice
<civodul>as a first step, a client of the data service would be great
<roptat>helaoban, you can also use inferiors to get packages from the past, although they are built as they were in the past, including with vulnerable libraries for instance
<roptat>but basically you could pin your versions to a specific guix revision if you want to do so, and mix multiple revisions too
<helaoban>cbaines, jlicht, civodul: ok so it looks at least for now this falls on the community to fill the gaps, and it doesn't look too dificult to setup a channel for a bunch of older version of python3.
<helaoban>civodul: what's the criteria for inclusion of python versions in the guix-past channel? It looks to be only python2 right now.
<civodul>helaoban: like the README notes, it's for software typically older than Guix itself
<civodul>stuff you can't reach with "guix time-machine"
*civodul -> zZz
<civodul>night!
<helaoban>ryanprior: the thought is being able to granularly specifiy everything you need to run your app in a manifest file and just distribute that over vcs, and anybody should just be able to pull it and recreate it exactly.
<jlicht>helaoban: for that you should be able to use guix time-machine + a channels.scm file in your repo
<helaoban>jlicht: ah cool, let me go back and read more of the docs before pestering you guys some more :)
<gnutec>Hello! I try to create a account in Wechat but say "Page not found". Is this about Trump and China stuff?
<jlicht>helaoban: don't worry, asking never hurts
<rekado>gnutec: we really can’t help you with that.
<helaoban>gnutec: not sure what you're talking about, you're probably in the wrong channel, but in any case a judge stayed the order to ban wechat, so it should still be working in the US.
<jlicht>gnutec: I don't think guix has anything packaged relating to Wechat. Are you talking about a website?
<rekado>(wechat is the Chinese app to be all apps; it’s usually only used on phones and does everything from monitoring you, facilitating and initiating payments, chat, etc)
<jlicht>I mean, if it does all of those things, it does reduce the proprietary software you are dependant on to just 1 piece of software :^)