IRC channel logs

2020-10-01.log

back to list of logs

<roptat>rebuilding the ocaml world after an upgrade of dune...
<GNUtoo>hi, do I need the lastest guix to build guix?
<Brendan[m]2>Not strictly. I don't know what the oldest version known to work is. I think its expected that you can use the latest versioned release to build the latest commit
<GNUtoo>Thanks, I'll try to see if that fixes my issues.
<ryanprior>You can build guix without having guix at all, so the answer is definitely no.
<stikonas>some distros even provide guix packages, e.g. on Gentoo you can add overlay with guix ebuild
<roptat>GNUtoo, some older versions of guix might not give you all the dependencies you need with "guix environment guix" but you can always add them with --ad-hoc
<stikonas> https://github.com/trofi/nix-guix-gentoo/blob/master/sys-apps/guix/guix-1.1.0.ebuild
<GNUtoo>Thanks, I've done guix pull and I'm now doing guix package -u, so I'll retry right after
***catonano_ is now known as catonano
<DrimysWinteri>hello
<DrimysWinteri>How can I set nyxt as my default web browser?
<GNUtoo>Some desktop environment settings enable to do that
<GNUtoo>Alternatively man xdg-open probably has some pointers
<GNUtoo>like it lists some other command lines tools that might to it in the "SEE ALSO" section
<GNUtoo>ah it still fails
<GNUtoo>I did:
<GNUtoo>./bootstrap
<GNUtoo>./configure --localstatedir=/var
<GNUtoo>make
<GNUtoo>and I got that:
<GNUtoo>[ 0%] LOAD guix/ci.scm
<GNUtoo>ice-9/eval.scm:293:34: Value out of range 1 to 4294967295: 2305843009213693951
<GNUtoo>As the environment I did that:
<GNUtoo>guix environment --pure guix --ad-hoc coreutils findutils which
<GNUtoo>I also did that with bash --norc as it tries to read my bashrc that has software that isn't present in that chroot
<GNUtoo>I tried without --norc before but not with the lastest guix (guix pull ; guix package -u)
*GNUtoo retries in a new shell to be 100% sure that the new software is used
*GNUtoo justs need to send a very very simple patch but needs to test it
<GNUtoo>btw, is it a good idea to package the v1.1.0 guix installer in a distribution?
*GNUtoo did that and forgot to ask before to see if there could be any issues, but it's probably not worse than the state of Guix in Parabola right now where guix doesn't build with i686 for instance.
<GNUtoo>I'll try with more deps
<GNUtoo>guix environment --pure guix --ad-hoc coreutils findutils which help2man git strace autoconf automake gettext texinfo graphviz help2man guile guile-gcrypt gnutls guile-sqlite3 guile-git guile-json zlib make guile-ssh lzlib lbzip2 libgcrypt sqlite gcc-toolchain
<GNUtoo>Would it be a good idea to add a line like that to copy-paste in the manual?
<GNUtoo>In any case here's the build output just in case: https://paste.gnutoo.cyberdimension.org/guix/build-01-10-2020.txt
<GNUtoo>it's with 'guix environment --pure guix --ad-hoc coreutils findutils which help2man git strace autoconf automake gettext texinfo graphviz help2man guile guile-gcrypt gnutls guile-sqlite3 guile-git guile-json zlib make guile-ssh lzlib lbzip2 libgcrypt sqlite gcc-toolchain
<GNUtoo>;
<GNUtoo>s/;/'/
<apteryx>GNUtoo: what are you attempting to do? Define a environment that is able to build current Guix from guix 1.1.0?
<GNUtoo>I'm doing two unrelated things:
<GNUtoo>(1) packaging the guix installer script => DONE, no issues here
<apteryx>(from a 'guix environment guix' environment where the guix package was at 1.1.0?)
<GNUtoo>(2) Just build guix master
<GNUtoo>I need to test 1 small patch before sending it
<apteryx>for (2), I don't know what are your constraints, but the simplest path if you already have a guix version available would be: 'guix pull' (refreshes your guix packages collection to include a not too old 'guix' package), then 'guix environment guix --pure' should be sufficient.
<GNUtoo>ok, I've done guix pull already
<GNUtoo>so I'll try just guix environment guix --pure
<GNUtoo>I've again the same issue
<GNUtoo>ice-9/eval.scm:293:34: Value out of range 1 to 4294967295: 2305843009213693951
*GNUtoo will try the same on x86_64 (here I tried it on i686)
<Brendan[m]2>It's interesting that its a prime number 2^61-1
<GNUtoo>hmmm I tried on another computer that didn't have guile-json installed and it seems that configure takes the host guile
<GNUtoo>configure: checking for guile 2.2
<GNUtoo>configure: found guile 2.2
<GNUtoo>I've tried to make it use Guix's guile 3.0 without success
<GNUtoo>checking whether Guile-JSON is available and recent enough... no
<GNUtoo>configure: error: Guile-JSON is missing; please install it.
<GNUtoo>I get that with guile-json
<PotentialUser-43>i have a GZ FILE FOR FPING WHICH MEANS THAT I NEED A GNU UNZIP UTILITY TO EXTRACT FPING.EXE FILE????
<guix-vits>PotentialUser-43: `gzip --decompress file` ?
*Brendan[m]2 finally got the bird out of his chimney
<Brendan[m]2>back to coding
<PotentialUser-43>WHICH UTILITY WOULD I USE TO UNZIP MY gz FILE????
<PotentialUser-43>UNZIP 6.0 HAS VULNERABILITIES!!!!
<PotentialUser-43>WOULD i USE GNU GUIX????
<guix-vits>PotentialUser-43: gzip
<guix-vits>Why `guix system build /home/vits/guix/configuration/configuration.scm` swears "guix system: error: failed to load '/home/vits/guix/configuration/configuration.scm': No such file or directory"?
<guix-vits>The file exists, and if i `cd guix/configuration; guix system build configuration.scm` it's working.
<PotentialUser-43>GNU GUIX IS A GNU NZIP UTILITY????
<guix-vits>PotentialUser-43: ?
<PotentialUser-43>PSACHIN DO YOU KNOW HOW TO UNZIP A GZ FILE????
<PotentialUser-43>KORI WHAT WOULD YOU USE TO UNZIP A GZ FILE????
<psachin>PotentialUser-43: gunzip FILE.gz
<g_bor[m]1> [guix-vits](https://matrix.to/#/@freenode_guix-vits:matrix.org): hmm... is it possible that there is a permission problem?
<guix-vits>g_bor[m]1: IDK, looking.
<guix-vits>~/guix, ~/guix/configuration is 'vits users rwxr-xr-x'
<guix-vits>ls -lh /home
<guix-vits>No, i can read those.
<PotentialUser-43>WHAT WOULD YOU USE TO UNZIP A GZ FILE????
<guix-vits>g_bor[m]1: can U use the relative paths with `guix system build`? If yes, then it's my setup issue.
<g_bor[m]1> [guix-vits](https://matrix.to/#/@freenode_guix-vits:matrix.org): from you previous message it looks like you can.
<g_bor[m]1>As you said it works from the same directory.
<g_bor[m]1>Also it looks like the one with absoule path was not working for you...
<g_bor[m]1>Am I missing something?
<guix-vits>...
<guix-vits>g_bor[m]1: It just started to work. Am sorry, IDK what it was.
<PotentialUser-43>CAN I USE GNU GUIIX TO UNZIP A GZ FILE????
<guix-vits>PotentialUser-43: Only if Stallman permits, and not on sundays.
<guix-vits>g_bor[m]1: Wait, please.
<guix-vits>g_bor[m]1: It worked with abs. name from ~/guix/configuration.
<guix-vits>Now i `cd`, and it fails again.
<guix-vits>`pwd` --> /home/vits
<guix-vits>g_bor[m]1: I suspect the error do not mean that the config-file do not exist, but that's (local-file "file") throws the error.
<g_bor[m]1>Hmm... might be, but then that error message is very misleading.
<g_bor[m]1>Can you test this with a config without local file, and file a bug report about the error message if this is really the case?
<guix-vits>g_bor[m]1: Yes
<g_bor[m]1>Thanks.
<g_bor[m]1> [PotentialUser-43](https://matrix.to/#/@freenode_PotentialUser-43:matrix.org): like others said, you can do that using: gunzip file.gz
<guix-vits>g_bor[m]1: #43736
*guix-vits interesting, if i use macro, will local-file inside it receive a "literal string"?
<Brendan[m]2>yes. macros are code transformers that occur before evaluation
<guix-vits>Thank U. https://paste.debian.net/1165375
<guix-vits>7.7 G-Expressions: "When RECURSIVE? is true, the contents of FILE are added recursively;"
<guix-vits>What does it mean?
<nckx>guix-vits: That the full contents of FILE are added if it's a directory, or that its permissions are kept if it is not.
<nckx>Have a great morning, Guix o/
<Brendan[m]2>i kinda dont care that directories are also files and just find it confusing ;)
<guix-vits>nckx: Thank U. Dir --> store. OK.
<guix-vits>o/
<Brendan[m]2>anyone else find the guix-scheme-mode totally borks the entire file with its auto indenting
<guix-vits>+1
<guix-vits> https://paste.debian.net/1165380
<civodul>Hello Guix!
<civodul>has anyone been following along the _FILE_OFFSET_BITS threads?
<Brendan[m]2>Hi
***apteryx is now known as Guest98209
***apteryx_ is now known as apteryx
<janneke>hello civodul!
<civodul>hey janneke & all :-)
<janneke>i've been actively trying to avoid all 64bit offset/open weirdness...
<efraim>I've been reading along. been wondering offhand if that could be contributing to my ppc bootstrapping weirdness
<efraim>does anyone know which architecture Mark used to bootstrap armhf? I know I used x86_64 for aarch64, so there shouldn't be any _FILE_OFFSET_BITS weirdness there
<civodul>efraim: bootstrapping was done through cross-compilation
<civodul>so i think it's unaffected
<mbakke>civodul: if you haven't had enough _FILE_OFFSET_BITS threads yet, the upstream discussion (linked from Dannys glibc patch) is also interesting: https://bugzilla.kernel.org/show_bug.cgi?id=205957
<mbakke>unfortunately it ebbed out
<mbakke>efraim: it should not make a difference for bootstrapping unless you run parts of it on a 64-bit kernel (i.e. ppc64 or qemu-binfmt)
<civodul>mbakke: thank you
<civodul>i guess i'd like to hear someone say "don't worry, it's nothing serious" :-)
<mbakke>civodul: you can follow a link to glibc bugzilla from the kernel bugzilla where Florian says "this issue affects various variants of file system pass through only" if it's any consolation :-)
<civodul>i'll have to ponder whether it qualifies as consolation :-)
<PurpleSym>civodul: Shall I create a formal bug report for yesterday’s guix-daemon/guix authenticate issue?
<jlicht>hey guix!
<janneke>hi jlicht
<jlicht>hey janneke! I showed some collegues a childhurd recently, and they acted as if I showed them a unicorn, so thanks for that experience :-)
<jlicht>s/collegues/colleagues
<janneke>jlicht: beautiful!
<civodul>PurpleSym: yes, that'd be nice! a short summary of the problem
<civodul>i'm posting patches that should help with that
<civodul>PurpleSym: https://issues.guix.gnu.org/43737
<PurpleSym>Will do and verify the patches fix the issue.
<GNUtoo>apteryx: Brendan[m]2: I still didn't manage to build Guix, but I sent a mail to the guix-devel mailing list for that so hopefuly I'll manage to get that working at some point.
<GNUtoo>Thanks for all the help yesterday.
*GNUtoo will be back later
***rekado_ is now known as rekado
<mroh>don't be evil, the first patch merged with "Copyright © 2020 Google LLC" ;)
<civodul>:-)
<civodul>rumor has it that they're planning to replace Android with Guix System
<civodul>and consequently abandoning Fuschia for the Hurd
<civodul>(joke aside, it's nice to see people contribute as part of their job)
<mroh>we should tell phoronix.com about this rumor, at least next 1.april ;)
<civodul>heheh
<civodul>that'd keep them busy for a while ;-)
<mroh>^^
<leoprikler>where is the Google LLC patch, what did I miss?
<mroh>5627bfe45c
*civodul applies tbb upgrade, fearfully attempts to rebuild all dependents
<Brendan[m]2>What's LLC?
<civodul>"limited liability company"
<civodul>many jurisdictions have things like that
<Brendan[m]2>If we wanted to change the license of guix, i guess we'd have to ask google for permission somehow
<civodul>we'd have to ask all copyright holders
<Brendan[m]2>yeah thats what i mean
<civodul>except if we change to GPLv4 or AGPLv3, for instance
<Brendan[m]2>i didn't know it could be redistributed as agpl also
<Brendan[m]2>is that like the gpl saying your allowed to upgrade the gpl to be an even more free gpl if you want?
<civodul>"even more free" :-)
<civodul>but yeah, there are provisions
<Brendan[m]2>for a certain definition of free
<leoprikler>IIRC the AGPL does not restrict your GPL freedoms and is therefore compatible with it
<Brendan[m]2>i thought it additionally removes the freedom to not share the code under some SaaS circumstances
<leoprikler>Yeah, but that's not a freedom in GPL terms
<leoprikler>In GPL terms "free to redistribute" means, you must distribute (if you do) in a way, that receivers can also exercise the essential software freedoms.
<leoprikler>In the AGPL "some SaaS circumstances" counts as distributing
<jonsger>mroh: we had at least some patches from SUSE (looks around ^^) and redhat folk hang around in IRC :P
<civodul>mroh: indeed!
<civodul>and openSuSE hasn't switched PMs yet
<jonsger>PMs?
<jonsger>ah package manager
<mbakke>jonsger: do you know where to find the OpenSUSE spec file for Guix?
<mbakke>on the topic of other package managers, I'm amazed that RPM still does not support source checksums: https://github.com/rpm-software-management/rpm/issues/463
<jonsger>mbakke: https://build.opensuse.org/package/view_file/devel:languages:misc/guix/guix.spec?expand=1
<mbakke>jonsger: that was fast, thanks! :)
<jonsger>although I didn't maintained it properly the last months as I'm not able to build rpms on Guix :P
<mbakke>heheh :-)
<jonsger>but I'll switch back to openSUSE with my laptop, so I can maintain it ^^
<hulten>Since recent, 'guix package' doesn't like installing packages in combinationation with an upgrade like this: 'guix package -u -i conda'.
<hulten>Should options be combined in a different manner? Can I get the right syntax from the manual?
<rekado>hulten: “-u” takes an argument
<rekado>so if you want to combine them do “-u . -i …”
<hulten>Oh I see, then the manual should be updated, because it says the argument is optional.
<hulten>Thanks anyway, it works of course. :-)
<hulten>rekado: '.' is the regex for a single character (at least for sed, awk &c.). What's the philosophy that '-u .' works?
<hulten>Concerning my documentation suggestion on '-u': I see that '.' is only needed if more arguments follow... I'm pondering a bit over if this is clear/unambiguous from the manual...
<Brendan[m]2>well, every package name contains at least 1 of some character, so that means its a match?
<hulten>Brendan[m]2: Yes, you're right!
<hulten>No need for '.*' or something (was thinking of substitution patterns).
<hulten>Okay, I pondered about 'guix package -u -i'. Since the syntax is 'guix package -u [regex ...]', and '-i' could be a regex, I guess the documentation needs no update. Nevermind.
<morgansmith>hello guix!
<jlicht>o/
<morgansmith>I'm kinda upset that bug 43277 is stagnating :/
<morgansmith>part of me wonders if there is a better way of handling bugs. it seems super easy for them to get forgotten, even when they have solutions posted in them
<apteryx>morgansmith: that one about emacs-next? I've been meaning to take answer to the thread.
<morgansmith>ya :D
<apteryx>I'm also of the opinion that some duplication of the search path code may be better in this case.
<morgansmith>:D but do you think reuse of the copy is good?
<civodul>morgansmith: what's missing exactly? why isn't your patch applied?
<civodul>among the 40+ committers, quite a few are die-hard Emacs hackers
<civodul>it's a pity we can't get our act together
<apteryx>FWIW it's the reason I revived 3 years-old commit here: http://issues.guix.gnu.org/43627
<apteryx>after people complained the update from Emacs 26 to 27 was not seamless (had to logout and login to refresh the EMACSLOADPATH variable, which contains version specific entries).
<apteryx>and after emacs-next got broken because it's easy to forget to wrestle the search-path in emacs inherited packages
<civodul>ok
<civodul>well anyway, i don't understand why discussion stalled, looks as if every had moved to vim :-)
<apteryx>morgansmith: I'm reviewing it right now. Will try to get it merged before an hour or so, if I don't find a problem with it.
<morgansmith>:D
<apteryx>sorry for the delay!
<jlicht>FWIW, I don't think 5 days is 'stagnating'. (Alternatively, we need a word for stuff that has been stagnating voor multiple years. 'Fossilizing' perhaps?)
<morgansmith>Maybe I'm just impatient :P
<apteryx>no you're not, it's OK to ping us as we do forget things.
<apteryx>can't we keep using version-major+minor instead of string-splitting on #\- ?
<apteryx>ah, it's because the this-package of emacs-next expands to a git-version produced string
<apteryx>and you want to strip the commit part
<efraim>Speaking of vim I'm still working on getting searchpaths to work with it
<efraim>Do you need version-major+minor+patch?
<efraim>We got that a month ago(?) but I haven't found a case for it yet
<allana>Hi guix! Any dnsmasq users here? I'm looking for an example config to base mine off of. I thought that I got it working, but from the logs I see that it is failing ot start: "failed to create listening socket for 127.0.0.1: Address already in use"
<apteryx>efraim: you mean: version-major+minor+point ? looking at it
<apteryx>that also raises an exception if the version becomes a normal release version such as "27.1" :-/
<apteryx>but I think this being emacs-next, it's likely to stay on unreleased commits, so that's fine.
<roptat>hi guix!
<apteryx>I'll add a not next to the version field.
<apteryx>note*
<guix-vits>roptat: Hi roptat. "<allana> Hi guix! Any dnsmasq users here?"
<zimoun`>civodul: What is the point of nscd? (#43744 guix-install.sh) I have not installed so do I miss nice features?
<civodul>zimoun`: https://guix.gnu.org/manual/en/html_node/Application-Setup.html#Name-Service-Switch
<civodul>now i wonder if anyone ever read this :-)
<apteryx>efraim: this does what I want: (or (false-if-exception (version-major+minor+point %version)) (version-major+minor %version))
<zimoun`>civodul: thanks! I have read it :-) But since it am not sure to understand, I’ve skipped it.
<efraim>point, patch, I can never remember which one is in guix
<civodul>rekado: "guix offload status" says it can't connect to .158, does that ring a bell?
<vldn>hi :) how can i add a directory to the gnu store?
<civodul>hi vldn! you never add/delete/modify files in the store directly
<civodul>instead, everything happens via "guix" commands
<civodul>for example, "guix build hello" will add /gnu/store/...-hello-1.2, unless it's already there
<rekado>morgansmith: it’s not necessarily that patches are forgotten about, but that there’s a limited number of people doing review.
<rekado>I’m one of those people and currently I’m not able to do any review whatsoever
<vldn>yes i know (former nixos user) i have a directory and want to add this files via guix command but what is the proper way?
<rekado>it’s not a software problem but a people problem.
<civodul>vldn: "guix download" probably, though that's for flat files, not directories
<rekado>zimoun`: especially on foreign distros you may need nscd; the short explanation is that nscd provides a *service* rather than a binary library for name lookups. This allows software that is binary incompatible with the host system to still look up names.
<vldn>mh maybe via archiving them first?
<rekado>in the early days we were not able to run the Guix-installed Emacs at the MDC because user names from Active Directory couldn’t be found, so Emacs would complain.
<rekado>with nscd running, however, Emacs can talk to it (via the glibc) and get the user name, even though the binary cannot load the SSSD modules directly.
<zimoun`>rekado: thanks for explaining.
<zimoun`>and the “hidden” feature of Mumi is really cool! :-)
<roptat>guix-vits, I don't use dnsmasq
*guix-vits o-la-la
<apteryx>civodul: I had that question but haven't had time to research if we have code paths doing such thing yet: combining profiles search paths. The question is what would happen to a profile search path ordering, which is often important, as for Emacs (first the user installed libraries, next the Emacs installed libraries, so they can be overriden).
<apteryx>having the ordering expressed at a higher level such as with the append-separator? field for this http://issues.guix.gnu.org/43627 would allow deriving a combined search path when the extra separator would still appear at the end of the combined search path.
<apteryx>where*
<rekado>zimoun`: which hidden feature…?
<zimoun`>rekado: browse all the GNU issues. :-)
<apteryx>can someone attempt to build emacs-next? the git-fetch fails for me here: Failed to do a shallow fetch; retrying a full fetch... -> error: RPC failed; HTTP 504 curl 22 The requested URL returned error: 504 -> fatal: the remote end hung up unexpectedly
<apteryx>which is strange, because fetching the remote manually works.
<apteryx>morgansmith: ^^
<civodul>apteryx: yes, profile search paths can be combined: guix package -p PROF1 -p PROF2 --search-paths
<apteryx>ah, the savannah repo really does die on a fresh 'git clone'... Hmm.
<apteryx>this fails in the same way for me: git clone https://git.savannah.gnu.org/git/emacs.git/
<apteryx>civodul: thanks! I'll test with that command.
<jonsger>fwupd got the concept of channels, so hopefully there will follow a free software only channel/repo :)
<rekado>zimoun`: oh, yeah, that one. I thought I accidentally broke it when I moved more and more features to local databases instead of using guile-debbugs, but eventually copying *all* of the raw debbugs data brought it all back again :)
<civodul>thoughts on recording package transformations in profiles? https://issues.guix.gnu.org/43614
<zimoun`>civodul: what is a POLA wrapper? (from #43614)
<rekado>principle of least authority (?)
<rekado>so probably a wrapper that has or grants access only to a limited (and well-known in advance) set of resources.
<zimoun`>rekado: thanks.
<civodul>yes, exactly
<civodul>it's a discussion that's been going on for some time
<jlicht>civodul: I also pinged ambrevar, as I recall him having thoughts and/or hopes for this feature
<jlicht>In unrelated good news, skopeo now supports guix-generated docker images
<civodul>what's skopeo?
<luis-felipe>guix install emacs-racer fails with this error: https://paste.gnome.org/pigzxnzmn
<luis-felipe>I'm using guix 97e98e2
<jlicht>civodul: a lot of things, but to me it's the tool that allows me to share docker images I built using guix, without having to install docker (or store the docker images twice, once in the store and once in my docker daemon)
<apteryx>morgansmith: closed!
<rekado>jlicht: that’s good to know! I was always annoyed by the fact that I need to load the image before I can push it to docker hub, storing it twice as a result.
***jonsger1 is now known as jonsger
<jlicht>rekado: exactly! now you can skopeo docker-archive:/$(guix pack -f docker hello) <some-docker-url-to-push-to>
<jlicht>that archive might another slash or two, for good measure, but you get the idea
<zimoun`>jlicht: thanks! Really cool! Howver, “guix install skopeo” does not seem working out-of-the-box. It complains about /etc/containers/policy.json. Is it expected?
<jlicht>zimoun`: I think there are still some rough edges indeed, I remember needing to pass `--insecure-policy'.
<morgansmith>apteryx: :D I'm so happy! No more "--do-not-update emacs-next" for me!
<jonsger>if our CI would be as fast as mozilla archive, ui ui...
<apteryx>morgansmith: thanks for the fix!
<zimoun`>jlicht: for testing, I copied the default-policy.json to /etc/containers/policy.json. Well, something minor to fix, or not! :-) Cool tool! Thank you!
*morgansmith tries to forget that I introduced the bug
<civodul>jlicht: that looks nice!
<jlicht>zimoun`: you should also be able to simply `--policy <path-to-policy-file>'
<civodul>perhaps we need a cookbook entry for this skopeo thing
<civodul>because sharing Docker images is a common need
<vldn>is it possible to install network-manager without whole GNOME? :D
<morgansmith>(modify-services (remove (lambda (service) (eq? (service-kind service) gdm-service-type)) %desktop-services)
<morgansmith>that gives me all the normal desktop services without gnome stuff
<morgansmith>I'm not 100% certain if that's what you're talking about though. Maybe I do have a bunch of gnome stuff installed and I just don't know :P
<vldn>seems like it and you just disable the gnome login manager gdm
<vldn>but i will try :)
***progval is now known as pinkieval
<morgansmith>I think you're supposed to use slim if you don't want gdm. I'd rather use startx but that requires you to jump through a bunch of hoops. If you also really want to use startx you can check out my config here: https://github.com/MorganJamesSmith/dotfiles/blob/master/.config/guix/config.scm
***progval is now known as pinkieval
<zimoun`>About nscd, does the configuration file need more than the default (more or less ‘info libc "Name Service Switch"’)?
<civodul>zimoun`: the defaults should be fine
<zimoun`>civodul: ok, thanks.
<vldn>is it possible to add a textfile via Definition in operating system?
<vldn>like with-output-to-file
<g_bor[m]1>Hello guix!
<g_bor[m]1>The outreachy project list is now finalized.
<g_bor[m]1>The contribution period begins on monday.
<guix-vits>vldn: (guix gexp) has local-file, plain-file, program-file.
<g_bor[m]1> [guix-vits](https://matrix.to/#/@freenode_guix-vits:matrix.org): +1
<guix-vits>vldn: 7.7 G-Expressions (basically (local-file "filename")).
<civodul>g_bor[m]1: woow already, nice!
<vldn>guix-vits i used (local-file “/etc/sway“ “test“) right above my operating system Definition and in runs without an error but the file is not created
<guix-vits>vldn: it copied /etc/sway as /gnu/store/hash-test
<guix-vits>What are U want to achieve? I thought U want to use some file as a config for a service or so.
<vldn>yes
<vldn>i want to create a config file in /etc/
<vldn>that i can use like sway -c /etc/sway.cfg
<vldn>with a Definition within config.scm
<guix-vits>vldn: there was something i do not know how to use, a etc-service-type.
<guix-vits>but for sway, U can place the config in ~/.config/sway/config
<vldn>yes i know but how can i create the config file declarative in config.scm?
<roptat>in the service list, add an etc-service-type that declare that file
<roptat>try this: (define sway-config (local-file "/etc/sway" "test")) and in the list of services (simple-service 'sway-config etc-service-type (list `("sway" ,swap-config)))
<roptat>although this will override the content of /etc/sway, so maybe not what you want
<roptat>the local-file finds the content of /etc/sway and brings it to the store. Then the etc-service-type symlinks that store item to /etc/sway
<roptat>if this is for the same system, it won't work, but if it's for guix deploy and remote systems don't have /etc/sway, it'll work
<joshuaBPMan>Hey Guix! Just curious, is guix currently using the guile dhcp client?
<civodul>hey joshuaBPMan! which Guile DHCP client?
<joshuaBPMan>civodul http://git.savannah.gnu.org/cgit/guix/dhcp.git/tree/
<civodul>ah, there was a GSoC project but it didn't produce working code
<joshuaBPMan>civodul ahhh. May I ask guix wants a dhcp client in guile for?
<joshuaBPMan>why guix wants*
<civodul>actually there's much more code than i remembered, weird
<civodul>2015, time flies...
<civodul>joshuaBPMan: having a DHCP client in Guile is interesting because it gives us finger control over network management
<joshuaBPMan>I suppose so. There should be a new blog post coming by the way. It's just the new addition to the cookbook about running guix system on a linode.
<civodul>great!
<civodul>i wonder if we should decommission guix-blog@gnu.org
<leoprikler>Shepherd 1.0.0 will include a DHCP client, mcron, and a mail reader out of the box, just like systemd.
<joshuaBPMan>civodul that does sound pretty cool. Though I'm not certain what the ramifications of having finger control is.
<joshuaBPMan>I didn't know systemd had a dhcp client. Also why the mail reader?
<civodul>leoprikler: that's the idea, but it's even better because we can fearlessly load code dynamically in PID 1 :-)
<civodul>the mail reader is a joke
<civodul>the rest is also a joke, but more plausible
<nckx>civodul: I heard about it for the first time ~3 days ago, so, perhaps.
<joshuaBPMan>civodul I actually like guix-blog@gnu.org. I submitted a blog post there the other day, and Ludo gently said to me "I'm not sure if this blog post should point to your blog. " He also had some other edit recommendations that I'm glad aren't public. He was very civil and courteous. :] :]
<leoprikler>Shepherd 1.0.0 will also include a config file reader, that compiles to Tree-IL
<nckx>joshuaBPMan: OK! Sounds good. (and of course he was, it's civodul.)
<joshuaBPMan>leoprikler another joke?
<leoprikler>Possibly.
<leoprikler>There were plans to have a systemd service/etc file compatibility layer. Obviously compiling them as if they were Guile code is something entirely different though.
<joshuaBPMan>leoprikler It would also be cool to be able to specify user services in config.scm.
<joshuaBPMan>I would like to specify them in my user section.
<leoprikler>I'm kinda mixed on that
***ChanServ sets mode: -b *!*@*.hot-chilli.net
<leoprikler>I do prefer to be able to edit user services as user, but I'd like to have shepherd running without needing to start it in .profile or elsewhere
<leoprikler>maybe have pam-shepherd that starts a service as soon as a user logs in
<roptat>leoprikler, don't forget the DNS client
<joshuaBPMan>leoprikler I'd be game for that. I've heard PAM can be quite a pain to use...
<leoprikler>let's be real and have Webherd by release 2.0.0
<leoprikler>compiling WebAssembly to Guile bytecode and back
<joshuaBPMan>haha.
<joshuaBPMan>Why not a shepherd keyring
<leoprikler>serving system services as HTML5 apps
<leoprikler>over the internet
<leoprikler>using super secure 5DES encryption
<leoprikler>(that's 2 more than 3DES)
<leoprikler>Hmm, I think by shepherd 4.0 we'll be able to adopt some of GNOME's versioning stuff and also have Shepherd as a complete desktop environment (maybe sans Emacs, but hopefully Nomad will serve as a replacement)
<leoprikler>but don't forget, that shepherd 4.0 is not shepherd 4
<leoprikler>We won't have that until at least shepherd 4.6
<joshuaBPMan>haha
<leoprikler>We will need our own fork of webkit by then, though.
<roptat>but it'll be in guile
<joshuaBPMan>leoprikler how about we write our own html render-er? webkit is overbloated
<joshuaBPMan>roptat as a serious question....How performant could could be make an HTML render-er in guile? No-where near as performant as webkit right?
<leoprikler>Nah, trust me, Mes will be able to compile C++-24 by then.
<joshuaBPMan>hahaha.
<raingloom>heya! could someone please merge or close my yggdrasil patches? it's been in limbo for months.
<raingloom>a new yggdrasil version even came out in the meantime. so. should i send new patches with the newest versions of everything?
<leoprikler>Depends. If Guile rolls out native compilation one day (pinky promise) and you get full memory access through (system ...) eliminating the need for a GC for your implementation, you should be able to get same-y performance.
<leoprikler>raingloom: How much did Yggdrasil change since your patch went into limbo?
<joshuaBPMan>raingloom what is yggdrasil ? I don't have commit access. Also, I feel sorry for the developers...having to manually look through all those patches. I should really sit down and try to apply those patches myself and just comment if the patches work. That would probably help.
<leoprikler>If there's a new version, sending a patch for that might revitalize the thread enough for someone to care ;)
<raingloom>leoprikler: not that much, seems to mostly be a bugfix release.
<joshuaBPMan>leoprikler That would be cool to get native compilation. I also like how racket is doing "typed racket."
<leoprikler>not really vibing racket's syntax for that tho
<joshuaBPMan>leoprikler Do you know of a better syntax?
<leoprikler>I'd prefer GOOPS if it had return type annotations, but I really want something that works with records, perhaps like ice-9 match but without field enumeration
<leoprikler>my ideal prototype would be (define ((function <return-type>) (arg1 <type1>) (arg2 <type2)) ...)
<raingloom>re: racket types: how's about https://docs.racket-lang.org/cur/ ?
<joshuaBPMan>leoprikler ok. Makes sense
<leoprikler>sadly, this clashes a little with ice-9 optargs
<leoprikler>not optargs, currying
<leoprikler>but I'd be willing to nest some lambdas for that
<PotentialUser-54>Greetings, how would I go about calling /etc/guix/machines.scm instead of having a list of machines in my guix deploy file?
<civodul>hi PotentialUser-54!
<civodul>these files are not interchangeable
<civodul>one returns a list of <build-machine>, whereas the other returns a list of <machine>, with different purposes
<PotentialUser-54>OK, thank you Civodul
<civodul>now, if these happens to be the same machine, you could have a common source (a module) that can produce both
<civodul>*machines
<rekado>raingloom: feel free to ping us earlier when you think your patches were forgotten
<raingloom>rekado: i hoped sending the new patches with the docs would be enough. usually there was other stuff being discussed here and i didn't wanna interject.
<zimoun`>civodul: well, with the guidance of SWH folks, it is possible to find the revision of a svn repo… but it is not straightforward (explained in #43442). The save request seems doable. However, the cooking from vault is still mysterious to me…
***amfl_ is now known as amfl
<civodul>zimoun`: good, there's hope!
<zimoun`>yeah and the cooking seems to work too. Now there is some work to implement… but it seems doable, at least for the package mpfi on inria’s forge. ;-)
<jonsger>how can I find out which characters I need to escape in a substitute statement?
<nckx>Any regex tutorial that deals with extended regexes. Then the basic Guile string escapes: \ → \\ and " → \" .
<jonsger>so I always need two "\" for escaping or?
<nckx>If you're escaping at the regex level, yes.
<civodul>roptat: could you add a test for the recent opam importer changes? :-)
<bdju>anyone here use the Quaternion matrix client? I'm curious how I can give it a dark theme.
<bdju>I also can't seem to give Dino a dark theme without exporting an environment variable to set one while launching it, even though I have one set for my system and other programs like pcmanfm respect it
***jess is now known as j
<bdju>speaking of forgotten stuff, I mentioned it some days ago here, but Sway is really in need of updating. there's breakage between Sway/Grim where they disagree on rotation because the Grim version is too new for the Sway version. a Sway update will fix it. I have been unable to screenshot things on my portrait monitor for weeks now. It grabs the complete wrong area and the rotation is wrong as well
<bdju> https://issues.guix.gnu.org/42923 this WIP patch to update Sway exists but there was a problem with it and it hasn't had activity in some time now
<bdju>my work-around has been to move my whole workspace to my landscape monitor to screenshot stuff, but this changes line-length in some programs and is also just annoying
<bdju>it's possible I'm the only Sway user on Guix with a rotated monitor for this to have gone unfixed so long
<nckx>Interesting. I just realized that, while I often use my laptop in portrait mode, I never take screenshots that way.
<nckx>Probable, yes.
<bdju>the change was something to do with different wayland compositors disagreeing on rotation before, so then some updated to all match, and so we have grim with that change but not sway with that change on guix now
<bdju>a very interesting issue