IRC channel logs

2020-09-26.log

back to list of logs

<shcv>if you make a guix system definition without specifying a kernel, what does it do?
<shcv>e.g., could I install the kernel separately, and just leave that part out?
<leoprikler>afaik guix defaults to some linux (usually latest, but not always)
<leoprikler>I'm not sure if (kernel noop) would be a good idea
<vagrantc>shcv: i've run Guix System on a handful of arm/arm64 boards
<vagrantc>a bit rough around the edges ... you really want a good amount of ram
<vagrantc>and disk i/o
<shcv>interesting; what's it need the ram for?
<vagrantc>just running "guix pull" it a fairly expensive computational process
<shcv>hmm
<vagrantc>had an install on a pine64+ with 2GB of ram, which is pretty much just like the sopine
<shcv>maybe using a different workflow, pulling, packing, and deploying from a different pc
<vagrantc>i did run it briefly on a wandboard solo with 512MB of ram, and it swapped just running guix pull
<shcv>ouch
<vagrantc>substitutes are often not available for arm or aarch64, so you end up compiling a lot of the time
<vagrantc>so for all those reasons, i wouldn't try Guix System on anything less than 2GB of ram
<shcv>k
<vagrantc>you can do offloading to a more powerful machine to build substitutes, or build system images on another machine ... that somewhat works around the various problems
<vagrantc>lately, i've mostly run guix on a pinebook pro, rockpro64, novena and veyron-speedy ... all of which have ~4GB of ram
<shcv>offloading makes sense; is it possible to offload the pull though?
<leoprikler>IIRC pull pulls from CI just as well as normal packages if it can
<shcv>since my RPi's are booted from microSD cards anyway, maybe I could just stick them into my laptop briefly to do the guix pull whenever I want to update them
<shcv>possibly with PRoot or something
<zimoun`>sneek tell later rekado: Is it expected that issues.guix.gnu.org serves also Emacs, Guile, name-GNU-it bugs? For example http://issues.guix.gnu.org/40000 or any bug number.
<sneek>later, zimoun` says: rekado: Is it expected that issues.guix.gnu.org serves also Emacs, Guile, name-GNU-it bugs? For example http://issues.guix.gnu.org/40000 or any bug number.
<leoprikler>sneek later ask rekado Is it expected that issues.guix.gnu.org serves also Emacs, Guile, name-GNU-it bugs? For example http://issues.guix.gnu.org/40000 or any bug number
<sneek>Okay.
<leoprikler>I would hazard a guess, that bug numbers are shared between packages, so you can't really filter out non-Guix ones ;)
<zimoun`>yes, but somehow emacs-debbugs does.
<leoprikler>well, so does the main page
<leoprikler>it's just that it doesn't complain if you manually enter a number that's not associated with guix
<leoprikler>not sure how emacs-debbugs handles that
<zimoun`>I agree, issues.guix.gnu.org is better than debbugs.gnu.org or bug.gnu.org. So I am happy. ;-) My question is: is it expected? :-)
<leoprikler>ik, that's why I forwarded it
<leoprikler>just gave my own opinion on it as I did
<str1ngs>vagrantc: did you get x11 to work on your rockpro64? it segfaults for me. sway works though.
<str1ngs> vagrantc got my pinephone to boot though. https://bufio.org/images/pinephone-guix-09-13-20.png \o/
<vagrantc>str1ngs: haven't tested video output on anything butthe pinebook pro
<vagrantc>(and pinebook)
<str1ngs>I hear ya.
<vagrantc>shcv: it can offload parts of "guix pull" but there's an initial part that has to be done locally ... i'm not familiar with the internals of guix enough to say more than that
<raghavgururajan>
***amfl_ is now known as amfl
<nalaginrut>Is there an easier way to install Guix in a different mount point? I created a large partition, and mount it to /gnu, however, I have to patch guix-install each time. The problem is the `mv /tmp/guix-XXX /gnu`
***catonano_ is now known as catonano
<roptat>nalaginrut, hm... can you report this as a bug to bug-guix@gnu.org? or to guix-patches@gnu.org if you can provide a patch to the installer script to make it handle both cases (when /gnu exists and when it doesn't)
***jonsger1 is now known as jonsger
<nalaginrut>roptat: ok
<nalaginrut>how can I use `guix build` for a local project?
<nalaginrut>I've written guix.scm
<nalaginrut>ah, I see, guix build -f guix.scm --with-source=../git-directory
<roptat>if your repo has build artifacts, this can lead to issues
<roptat>it's probably better to run "make dist", then use --with-source=...tar.xz
<nalaginrut>roptat: but I can't generate configure, since guile is in guix environment
<nalaginrut>hmm...without mirror, I can live with 13KiB/s ...
<bdju>so, what's the deal with the warsow package? warsow-qfusion sounds like just the engine, not the game... the wikipedia article for warsow said they made their assets all CC BY-SA back in 2012, so I would think it'd be fine to package the whole thing normally.
<iyzsong>nalaginrut: there has a mirror at: https://mirror.guix.org.cn
<marusich>iyzsong, is there information somewhere on what files need to be rsync'd where in order to provide a mirror?
<marusich>I know you can run "guix publish" and serve from a machine's store, but I never really did figure out what files you'd have to copy if you wanted to serve it over a dumb server like nginx or apache or something
<nalaginrut>iyzsong: nice to know it
<iyzsong>marusich: i don't know. this mirror is a nginx cache proxy, and not run by me.
<marusich>ah, i see
<marusich>if it's just that, then i know how
<marusich>what i don't know is how to prepopulate a mirror with a bunch of build artifacts
<nalaginrut>iyzsong: then how to set this mirror to my config?
<iyzsong>maybe a mix, not sure... https://github.com/guix-china/guix-china-maintenance/blob/master/nanjing/web.scm
<iyzsong>nalaginrut: you need start guix-daemon with '--substitute-urls=https://mirror.guix.org.cn'
<iyzsong>nalaginrut: in the system config, like this (at end of the file): http://paste.debian.net/1164731/
<nalaginrut>iyzsong: nice, it works, thank you very much!
<iyzsong>sure :)
<nalaginrut>this mirror is a big thing for me to go further
<dongcarl>Hi all, I currently instantiate a container environment from a manifest file, which contains packages that will populate my profile. I'm wondering what the best way is to have a package exist in the container, but not be overlayed into my profile. This is particularly useful when there are multiple toolchain packages in a manifest, where they will
<dongcarl>cause a lot of weirdness.
<dongcarl>My naive thinking: derive a hidden package
<wleslie>I'm sorry, you have a profile in your container, and a profile for your user, and a manifest; and the manifest describes both these profiles?
<dongcarl>wleslie: I have a custom manifest file, which I run `guix environment --container --manifest` on, and I would like a few packages in that manifest to not exist in the profile inside the container, does that make sense?
<dongcarl>I don't want to remove those packages from the manifest, because I want them to be available in the container, but just not in the profile in the container
<dongcarl>profile as in $GUIX_ENVIRONMENT
<raghavgururajan>Hello Guix!
<wleslie>I see. I don't have a better idea, sorry.
<Elephant454>Hey, so I was having some trouble getting SDDM and Sway working. I'm getting weird issues with Emacs not being able to find things. It can't find dictionary files, it can't find DBUS sessions, and none of teh XDG directory paths seem to be set. Any ideas on how I can go about fixing this?
<apteryx>sneek: later tell civodul nice doc addition about the childhurd service!
<sneek>Got it.
<FennecCode>🤔
<apteryx>Elephant454: you may need to simply re-login into your session?
<Elephant454>I don't know if I've tried logging out and re-logging in yet, but this happens every time I boot my computer
<apteryx>ok, so it probably won't help
<apteryx>what does 'env | grep XDG' returns in a fresh terminal emulator?
<apteryx>crucial XDG ens are set directly in /etc/profile
<apteryx>envs*
<guix-vits>Elephant454: elogind-service-type is in services?
<Elephant454>Unfortunately I'm away from my terminal at the moment
<Elephant454>Er, not that, but in Gnome and not in a position to switch to Sway. I'll let you both know if that works
<wleslie>I'm trying to get the source checkout on my local machine working. `guix environment guix ; ./bootstrap ; ./configure` leads to "Guile-JSON is missing; please install it."
<wleslie>I've tried configuring from `guix environment guix guile-json` instead, but I get the same error
<wleslie>what do I need to do?
<leoprikler>--ad-hoc guile-json?
<leoprikler>perhaps also guix after ad-hoc
<wleslie>sounds good
<wleslie>thanks
<peanutbutterandc>Hey there everyone
<peanutbutterandc>Does anybody here use aegisub?
<wleslie>I also need guile development packages, but I can't seem to find them in the package list. how to I get these?
<wleslie>headers etc
<wleslie>maybe I need to specify guile explicitly :P
<Brendan[m]2>Is VSCode libre software?
<peanutbutterandc>Brendan[m]2, Vscodium is!
<peanutbutterandc>Brendan[m]2, https://vscodium.com/
<Brendan[m]2>it says its a binary distribution
<wleslie>hmm, this did not help
<leoprikler>wleslie: yep --ad-hoc guile is a de facto requirement if you plan on having $GUILE_LOAD_PATH set
<Brendan[m]2>would it required any significant new dependencies in order to be added to guix?
<peanutbutterandc>Brendan[m]2, It appears to be the case that while vscode's source is MIT licensed, the binary distribution from MS isn't. But if you package vscode in guix it would be a 'clean' build (with out MS's stuffs). But vscodium changes the icons and branding and stuff. It's like firefox and ice-cat. Except this firefox (vscode) has quite a lot of shady stuffs.
<Brendan[m]2>citation needed on the shady stuffs
<peanutbutterandc>Also, if anybody has the time, please do look at this: https://issues.guix.gnu.org/43628 I am at my wit's end regarding the matter.
<Brendan[m]2>i mean, any proof that there is anything bad
<peanutbutterandc>Brendan[m]2, telemetry. lol. Just a sec please
<Brendan[m]2>i know libre software folks may be very quick to say its bad, i dont want to make false claims
<leoprikler>IIUC vscode™ is based on vscode and bakes in the telemetry and stuff, no?
<peanutbutterandc>I understand. I used vscodium instead of vscode just because it was a separate build by independent folks. I don't trust MS all that much (says someone who still uses Github).
<peanutbutterandc>But here: https://en.wikipedia.org/wiki/Visual_Studio_Code#Data_collection
<leoprikler>peanutbutterandc: not using aegisub, but I'll try it on Guix system to see what goes wrong
<peanutbutterandc>leoprikler, Thank you very much! (And you're working on guix-android thingy. I'm following your gitlab RSS. Tsukundere seems very interesting.
<leoprikler>Except I'm not working on guix-android ;)
<leoprikler>If you want an example for Tsukundere, you'll find one in the Lisp Game Jam. I sadly can't package it for GNU Guix proper, because it's only open source, not free as in free speech :(
<peanutbutterandc>leoprikler, Agh! I am again confusing you with someone else. Dang it. But hey, I'm still following your gitlab RSS and tsukundere seems like it's a great thing. (I would like to learn game/visual-novel dev someday).
<wleslie>hmm, I've `git clean` in this `guix environment guix guile guile-json` and re-run bootstrap, and now that fails `possible undefined macro: GUILE_MODULE_AVAILABLE`
<peanutbutterandc>leoprikler, could I have a URL please? (I'll be searching around in the meantime)
<leoprikler>If you don't find it right now, wait until the entries are public. I'd rather not advertise it here.
<peanutbutterandc>Okay
<leoprikler>I had a look at aegisub and as expected it does produce audio correctly in Guix system
<peanutbutterandc>leoprikler, could you please try `guix environment --pure --ad-hoc aegisub`?
<leoprikler>`guix environment -E DISPLAY -E XAUTHORITY -E 'XDG_*' --pure --ad-hoc aegisub -- aegisub-3.2`
<leoprikler>works as intended
<leoprikler>I think this might be a problem w.r.t. Guix ALSA vs. System ALSA
<leoprikler>You might want to try a union-build in which you copy stuff recursively instead of symlinking them
<peanutbutterandc>leoprikler, I installed espeak using guix and it produces sound. So does kdenlive (installed via guix)....
<peanutbutterandc>the issue is that aegisub is looking for the .so files in the wrong place. It is looking for it somewhere which isn't even in the input list
<leoprikler>be warned, that symlinks may get resolved by the build system
<wleslie>with apologies for the ansi escapes; this is me trying to bootstrap: https://bpa.st/JX6A
<peanutbutterandc>leoprikler, I have looked at the union build separately (as a stand-alone package) and went into the /gnu/store and everything seems to be just fine there
<peanutbutterandc>to my eyes, atleast.
<leoprikler>still try union-build/copy and copy-recursively instead of symlink-relative
<leoprikler>[union-build/copy is union-build with symlink replaced by copy-recursively]
<leoprikler>If it still complains then, we can fairly certainly say, that it's not aegisub
<peanutbutterandc>leoprikler, is there any package that uses union-build/copy?
<leoprikler>no, you'll have to (define union-build/copy [copypasta union build, replace symlink with copy-recursively])
<leoprikler>wait, I'll try to simplify it a bit
<leoprikler>ah, wait, it's easier than I thought
<peanutbutterandc>#:symlink copy-recursive ?
<leoprikler>yep
<peanutbutterandc>making the change rn
<wleslie>cleaned up: https://bpa.st/5C2Q
<peanutbutterandc>leoprikler, Still the same issue. I have a feeling it might have something to do with the pkg-config rules and stuff
<leoprikler>that may very well be the case
<leoprikler>you could try removing alsa from the inputs and directly adding pulseaudio
<leoprikler>btw. i don't see them using pkg-config for alsa, instead they have AC_CHECK_LIB([asound], ...)
<wleslie>`guix pull` made it happy :P
<jlicht>hey guix!
<Brendan[m]2>found typo Additionaly (one l) in the manual, can someone with the ability to update the manual fix that up?
***mmohammadi98121 is now known as mmohammadi9812
***mmohammadi98124 is now known as mmohammadi9812
<mihi>Hello :) Would it be possible to apply some kind of compression to the downloadable "latest guix Hurd" image? Any compression should get it down to <15% and it would make me download new version more often whenever I break the filesystem of my vm :)
<mihi>by the way, I think I found why my Hurd VM randomly locks up while building packages in a 'guix pull': I now added a few hundred megs swapfile, swapon::ed it and since then it is running for around 12 hours building stuff without locking up :-)
<mihi>still hope that even on my old crappy laptop I will someday manage to finish the pull and reconfigure it so that I don't have to monkey-patch my resolv.conf after every reboot. And maybe get some editor built that is not cat or sed.
<mihi>but I read you are working on running childhurd on ci server - so we can get substitutes at some point?
<mihi>And another question: Given I have a "hosed" ext2 image with Hurd in it (hosed as that even running "guix" complains about some missing files: Is there a way I can mount this in a guix hurd and test the store (against its hashes?) which packages are fine so that I can guix publish them to make the next try faster?
<mihi>s/in a guix hurd/in a guix linux/
<mihi>reason the filesystem is hosed: deadlock in ext2 driver and then fsck went berserk. But something is still fine as the system still boots.
<mihi>(so something like dism /offline /restorehealth, but not on Windows but on Guix, and I'm fine if it deletes all packages that do not match their hashes)
<civodul>hi mihi!
<sneek>civodul, you have 1 message!
<sneek>civodul, apteryx says: nice doc addition about the childhurd service!
<civodul>i thought the image was already compressed
<civodul>if not i agree we should do it
<civodul>note that childhurds are volatile, so it's not useful to run "guix pull" in there
<civodul>as for substitutes: we're working on it!
<mihi>compressed it is about 175 MB, uncompressed 1.5GB
<civodul>yeah
<mihi>I'm not running it as a childhurd, but converted it to .vdi and run it as native VM in VirtualBox (on Windows).
<mihi>childhurd would mean I run a VM inside a VM
<zimoun`>Brendan[m]2: “ag Additionaly doc/*.texi” does not report any match. Could you indicate where you read the typo? Which version of the manual?
<janneke>mihi: ah, compression would be good -- no idea; maybe ask mothacehe later
<mihi>got to go - will be reading the logs later
<janneke>mihi: in development, i have been using guix copy to save built items to the host
<janneke>and pick them up as substitutes on a next build
<civodul>janneke: i have a fix for the cross-built guile-lzlib!
<civodul>but i realized i don't have commit rights to that repo, i'll ask mothacehe
<roptat>hi guix!
<pinoaffe>hi guix! I am trying to package https://github.com/mbriggs/emacs-pager , I think I need to add a phase that will copy the ruby script so it'll show up in PATH, can anyone point me to an example of how to add a phase from another build system to a package definition?
<roptat>I'm trying to migrate from framagit to my own server, and I'm having some troubles setting up everything. I've added the gitolite service, so I can use git with ssh, which is good
<roptat>however, I can't find a way to allow anonymous clones
<leoprikler>pinoaffe: many packages in emacs-xyz do that to some extent
<roptat>i tried adding a git-http-nginx-location-configuration and a fastcgi service, but the repo is not found
<roptat>the repo has a git-daemon-export-ok file
<leoprikler>have a look at e.g. emacs-howm, emacs-pdf-tools, emacs-libyaml, emacs-telega…
<morgansmith>so I download a thing.tar.gz and a thing.tar.gz.sig but gpg --verify thing.tar.gz.sig just says: Can't check signature: No public key. How do?
<morgansmith>the internet matrix tells me to "gpg --kerserver blah --recv-keys key", but I don't know how to determine what to put for key
***ChanServ sets mode: +o civodul
<pinoaffe>leoprikler: thanks!
<civodul>morgansmith: you'd specify the fingerprint of the key in question
<civodul>the one that appears in the error message of "gpg --verify"
<morgansmith>gpg: key 91738F73E1B768A0: no user ID
<morgansmith>I tried that, didn't work
<morgansmith>ok, I got it. I just kept trying different keyservers
<morgansmith>They where in keyserver.ubuntu.com and not my first 5 choices
<morgansmith>Thanks civodul :D
<civodul>yw!
<civodul>keyservers have become unreliable...
<morgansmith>I've literally never used them :P
<morgansmith>(don't tell anyone I'm one month into a university security course on this stuff)
<civodul>:-)
<raghavgururajan>Hello Guix!
<roptat>yeah \o/ it works
<roptat>apparently a permission issue, not sure I can set that for new repositories
<roptat>mh.. a combination of setting the group for fcgiwrap, and the umask in gitolite might work
<roptat>anyway, https://git.lepiller.eu/guile-netlink/manual/html_node/
<roptat>enjoy :)
<guix-vits>roptat: So one can use the guile-netlink to command a netfilter?
<mfg>if i want to contribute a package and it needs a patch, i have to add it to gnu/local.mk?
<mfg>also: is it necessary to add a copyright notice? what does it mean if i don't add one?
<morgansmith>You can add a copyright under a pseudonym. I don't know if it has significance in free software beyond street cred
<roptat>guix-vits, not yet
<guix-vits>mfg: If U will omit copyright, then Reviewer will add it, or ask U to do so.
<mfg>I see. So less work if i just add it :D
<roptat>mfg, yes you have to add it to gnu/local.mk
<roptat>otherwise it won't be shipped in guix tarballs
<mfg>thx roptat
<guix-vits>+1
<roptat>guix-vits, for now I'm focusing on rtnetlink, which will allow us to replace the static-networking-service-type and improve networking support in guix containers
<roptat>then probably netfilter, but it's much more difficult because I can't find any good documentation on the expected datastructures
<roptat>the best I have is a go implementation of a small subset of it (unless it's actually very limited and that's all there is to it)
<morgansmith>plz add support for defining a static network with both ipv4 and ipv6 at the same time on one interface
<roptat>yes, that's the plan
<morgansmith>:D
<roptat>for now guile-netlink is very limited, all it can do is fetch information about a link by its id
<roptat>mh... probably by name too, if i find out how
<morgansmith>configure: error: ncurses development package is not installed
<morgansmith>Are the dev files and dynamic files just in the ncurses package?
***mmohammadi98120 is now known as mmohammadi9812
<morgansmith>ok, so it's looking for ncurses6-config instead of ncursesw6-config? Why don't we have an ncurses6-config?
<civodul>roptat: re guile-netlink, woohoo!
<civodul>there's even a manual
<civodul>time for presents it seems :-)
<civodul>morgansmith: ncurses6-config is presumably part of the "ncurses" package, is it not?
<morgansmith>civodul: nah, we only got ncurses6w-config.
<civodul>oh
<peanutbutterandc>Question: How do I figure out the mirror:// url for a download? Particularly sourceforge. Is this a well defined protocol?
<civodul>peanutbutterandc: it's not a protocol, it's just a placeholder that (guix download) replaces with the actual URL
<civodul>you can try "guix build -S some-package-on-sourceforge --no-substitutes" to see how that works in practice
<civodul>also, "guix lint" probable suggests you the right mirror:// URI
<civodul>*probably
<peanutbutterandc>civodul, I see. Thank you, Mr. Courtes. It's just that I've been quite tired of guessing and tweaking the url over and over (and most of them not working). I will try the guix lint method then.
<civodul>yw, and remember you're very much encouraged to omit "Mr" :-)
<peanutbutterandc>I am only 24, and from a culture that doesn't address it seniors with names. And you are the creator of guix. So, I am afraid you'll have to excuse me, sir. Also, you're awesome, again.
*raghavgururajan --> Zopliclone --? zzZ o/
*janneke is afk for a bit
<roptat>civodul, I'm still trying to find out what user/group is trying to run git-http-backend exactly
<civodul>janneke: uploaded! https://ftp.gnu.org/gnu/guix/bootstrap/i586-gnu/20200326/
<civodul>roptat: i would expect cbaines to be the one who knows about Git-related services :-)
<roptat>ha, it worked! it was indeed fcgiwrap, but my changes to /var/lib/gitolite seems to be overriden (or I forgot to add access to groups)
<roptat>so you can clone https://git.lepiller.eu/git/guile-netlink if you want to see the code!
<cbaines>I have https://paste.debian.net/plain/1164768 in my config, I don't know if that's relevant
*civodul surprised to read "sir" and "awesome" on the same line
<civodul>hi cbaines!
<cbaines>I think because /var/lib/gitolite is the gitolite users home directory, some permissions stuff takes place on activation
<cbaines>civodul, hey :)
***mmohammadi98128 is now known as mmohammadi9812
<roptat>cbaines, I managed to make it work, I have fastcgi run as fcgiwrap:git, and my repos are owned by git:git, with read-only access to the group
<roptat>(I set umask to 0027)
<roptat>the only issue is that /var/lib/gitolite is owned by git:git and is 700
<cbaines>Right, that paste might help with that, as it changes /var/lib/gitolite to 750
<roptat>ah right, thanks :)
<civodul>should chmod be done in the gitolite activation?
<cbaines>maybe, if it's a frequent requirement to change the permissions, maybe it should be part of the service configuration
<civodul>cbaines: if that's what it takes to make it work out of the box, we should do it
***daviid is now known as Guest65431
<morgansmith>is there a good way to remove lines in a file in guile based on a regex? Like remove all lines that start with "git"
<guix-vits>(begin (port-filename p) (close p)) ; How's that that close() executed first?
<guix-vits>OK: (begin (local-file (port-filename port)) (close port)) do not work. It working if (port-filename port) moved out of 'local-file'.
<cbaines>guix-vits, local-file is some special syntax, as it captures the current source directory
<guix-vits>cbaines: Thank U.
<jlicht>hey guix!
<civodul>howdy jlicht!
<jlicht>exciting stuff with the input-rewriting-on-steroids! :-)
<badair>After I check out the guix repo, how do I actually _do_ the "Reduced Binary Seed Bootstrap" such that I don't use any substitutes?
<sys2>badair: not sure about that specifically... but you can disable substitutes by using modify-services in your system config and setting use-substitutes? to #f: https://guix.gnu.org/manual/en/html_node/Base-Services.html
<sys2>here's an example: https://github.com/Phant0mas/Guix-on-Hurd/commit/cd6f6c22fb581e5ef2aa88f5e9c14a4c54a071c3#diff-8a671d0add70f460b6d01b5fa785ebb8R5380
<badair>Does disabling substitutes imply bootstrapping?
<badair>sys2: thanks for the example!
<sys2>badair: cheers :)
<sys2>badair: I don't think so... I'm not sure how to answer that part of your question
<roptat>badair, yes, as long as you never used a substitute before
<sys2>awesome!
<roptat>the reduced bootstrap means guix starts from a set of binaries and has definitions for other packages, until you reach the package you want
<roptat>the build farm already performed the bootstrap for you, so if you request substitutes, you'll get substitutes that have been bootstrapped in this way
<roptat>if you want to build everything yourself, from the reduced set of binaries, you just disable substitutes completely
<roptat>it'll be very long though
<badair>roptat: Thanks!
<mihi>janneke, thanks. I guess I have to learn what Guix consideres an "item". Can I for example tell it "copy everything you built during the last pull"?
<mihi>Also, I think I had the misconception that Guix knows the hashes of the resulting binaries (like some other Reproducible Builds projects do it), but it seems that hash is "only" the hash of the inputs. So something like check whether packages are corrupted in store is not as trivial as I thought...
<mihi>(which also means that a compromised substitutes server will not be noticed immediately - correct me if I am wrong here)
<roptat>mihi, there's "guix build --check" and "guix challenge" that can mitigate that a bit
<peanutbutterandc>Question: Is there a way by which, using `guix repl`, I can figure out where a package will end up, once it's built? Say, something like (package->ends-up-as hello) -> /gnu/store/actual-hash-hello ?
<peanutbutterandc>(and without actually building the package)?
<roptat>peanutbutterandc, with package->derivation maybe?
<str1ngs>sneek: later tell luis-felipe . hello I did test nomad with gnome-shell on guix system. And I'm not able to replicate the dash issue. is it possible it just replaces emacs in the favorites stack? Let me know if you are still effected by this.
<sneek>Okay.
<peanutbutterandc>roptat, It returns a procedure that takes a 'store'.... what would I do now? I have tried supplying "/gnu/store" as store before. Didn't work. (I know that isn't what I'm supposed to input.)
<str1ngs>terpri: nomad is backend/platform agnostic. it just so happens it use webkitgtk as the reference implementation. here's a screenshot using qtwebengine for example. https://bufio.org/images/2020-09-18-215517_2048x2110_scrot.png
<roptat>I think it's monadic
<roptat>peanutbutterandc, try this: (derivation-outputs ((package->derivation hello) (open-connection)))
<str1ngs>terpri: I would also gladly use a a firefox as a embedded render if mozilla made suck a thing possible outside of the realm of xulrunner.
<roptat>you'll need (guix store), (guix derivations) and (guix packages) as well as the module in which the package is defined
<str1ngs>terpri: s/suck/such must have been a Freudian slip :P
<peanutbutterandc>roptat, Oh wow! Super awesome! I'm going to do some serious jumping-through-hoops-in-my-package-definition with this one. (Pretty sure it won't be accepted into the gnu distribution now.)
<peanutbutterandc>Thank you very much!
<roptat>yw :)
<roptat>although if it's for a package definition, inputs are defined in phases, and you can use them like that (suppose you have a "hello" input): (assoc-ref inputs "hello") -> gives you the output of the "hello" input
<peanutbutterandc>roptat, I have something that is a far larger behemoth than just that: I essentially need to set the --plugin-dir=the-/gnu/store/-path-to-something-that-will-build-after-this-package. Here: https://issues.guix.gnu.org/43628
<peanutbutterandc>roptat, Hmmm... question, how do I extract the 'path' from that? o.O what is the output a type of? o.O
<guixy>Hi guix
<guixy>Is there a good way to list the contents of a package object?
<guixy>I'm debugging some tests. It says these are not eq?
<guixy>#<package foobar@0 tests/scripts-build.scm:35 7fca81ed0820>
<guixy>#<package foobar@0 tests/scripts-build.scm:35 7fca81ed08c0>
<guixy>I'm guessing that hex is an address?
<guixy>Must be... it keeps changing every time I run the test.
<roptat>guixy, try with equal?
<roptat>peanutbutterandc, no idea
<roptat>peanutbutterandc, and I don't know if what you're trying will work: the plugin's hash will depend on the recipe of alsa-lib, so you might end up with a dependency loop there
<guixy>roptat, yes. I tried all eq? eqv? equal?
<guixy>eq? eqv? and equal? all eval false.
<roptat>oh... and they're the same package?
<guixy>They should be except for maybe the address.
<guixy>One is processed from the other, but nothing is done to it.
<roptat>no idea then, sorry
<guixy>It should just be a clone.
<rndd>hi everyone! (add-to-list 'yas-snippet-dirs "~/path/to/guix") dont work for me, i had to manuall load (add-to-list 'yas-snippet-dirs "~/path/to/guix/etc/snippets") to work with snippets
<rndd>also i tried to apply created patch but got error "error: patch fragment without header at line 19: @@ -24733,3 +24733,25 @@ web development.")"/ maybe somebody had same problem
***allan is now known as Guest23640
<mroh>rndd: (add-to-list 'yas-snippet-dirs "~/path/to/guix/etc/snippets") should work.
<rndd>mroh: ye, i got it, maybe this is the reson to update "the perfect setup"?
<rndd>ohhh
<rndd>no
<rndd>i'm sorry, my bad
<rndd>this information in perfect setup
<rndd>0_o
<peanutbutterandc>roptat, It did do the job for me. Here: https://github.com/peanutbutterandcrackers/guix-packages/blob/master/aegisub.scm (aegisub, as in the gnu distribution, does not play sound in foreign distros right now, but this one does)
<peanutbutterandc>Thank you very much for your help.
<peanutbutterandc>Also, if anybody does have the time, please do take a look at: https://issues.guix.gnu.org/43628 Now that I have resolved the issue, I would like suggestions regarding where and how the changes are best incorporated into the gnu system. Do I patch just aegisub? Or alsa-lib? But what about the other outputs of alsa-plugins. And is it even okay to (open-connection) to the store in a package definition? (Probably not)
<peanutbutterandc>But for now, I ought to sleep. Good Night!
<leoprikler>sneek later ask peanutbutterandc did you test Julien's .asoundrc? If so and it didn't work, then fine.
<sneek>Will do.
<leoprikler>sneek later tell peanutbutterandc Your hack can probably be made a little nicer by using (assoc-ref %build-inputs "alsa-plugins:pulseaudio"), but it still remains a hack around a somewhat different problem. Perhaps you might want to contribute towards documentation regarding the use of ALSA/Pulseaudio on foreign distros.
<sneek>Will do.
*luis-felipe is trying out games packaged for Guix.
<luis-felipe>I liked "Project: Starfighter". I usually don't like these kinds of games, but this one has story at least.
<sneek>Welcome back luis-felipe, you have 1 message!
<sneek>luis-felipe, str1ngs says: . hello I did test nomad with gnome-shell on guix system. And I'm not able to replicate the dash issue. is it possible it just replaces emacs in the favorites stack? Let me know if you are still effected by this.
<str1ngs>luis-felipe: hello I did test nomad with gnome-shell on guix system. And I'm not able to replicate the dash issue. is it possible it just replaces emacs in the favorites stack? Let me know if you are still effected by this.
<str1ngs>o.O
<luis-felipe>str1ngs: I don't have Emacs in my favorites.
<str1ngs>luis-felipe: what is the nomad version? guix show nomad
<rekado_>sneek: later tell zimoun issues.guix.gnu.org has *access* to all GNU Debbugs bugs. It doesn’t include them in the search, nor does it index them. But it can show them all. I think that’s a feature, not a bug.
<sneek>Welcome back rekado_, you have 1 message!
<sneek>rekado_, leoprikler says: Is it expected that issues.guix.gnu.org serves also Emacs, Guile, name-GNU-it bugs? For example http://issues.guix.gnu.org/40000 or any bug number
<sneek>Got it.
<luis-felipe>When I installed nomad, I had Emacs open. When the installation finished, I ran "r" in GNOME's Alt+F2 command box and then Emacs identity was changed to nomad's
<rekado_>sneek: later tell zimoun issues.guix.gnu.org could refuse to show them, but I think that would be a needless limitation.
<sneek>Got it.
<rekado_>luis-felipe: maybe report on #nomad-browser
<luis-felipe>str1ngs: 0.2.0-alpha-100-g6a565d3
<rekado_>(oh, str1ngs is here)
<luis-felipe>rekado_: Didn't know it existed, sorry.
<str1ngs>luis-felipe: ahh maybe I misunderstood what dash was. let me see if I can replicate this. 0.2.0-alpha-100-g6a565d3 looks right.
<rekado_>luis-felipe: no worries! Just trying to be helpful :)
<luis-felipe>str1ngs: I really don't know the exact name of that part of the interface. It is that vertical bar to the left when you open the Activities view.
***rekado_ is now known as rekado
<luis-felipe>That bar contains your favorite applications but also the applications that are running.
<str1ngs>luis-felipe: I will try to replicate this now. though I use i3 myself so forgive my ignorance :)
<luis-felipe>It's fine. Let me know if I can help you with more information.
<str1ngs>I think possibly it's not useing the desktop file which would be more ideal. see how it says .nomad-real
<rekado>.nomad-real is just the target of the wrapper that sets environment variables
<str1ngs>though in the left bar I do have emacs and nomad
<luis-felipe>Yes
<str1ngs>I think maybe gsettings-desktop-schemas should probably propergated
<str1ngs>luis-felipe: r restarts gnome-shell it seems?
<luis-felipe>Yes I run it when I install new packages, so that their icons appear in the list of applications.
<str1ngs>luis-felipe: I still can't replicate this seems. emacs was running then you restarted gnome-shell and then emacs was replaced by nomad. does that should right?
<luis-felipe>str1ngs: Yes the Emacs icon and name was replaced by nomads. And only in the dash panel. In the list of applications that you see when you click on the nine dots button, Emacs is listed normally.
<luis-felipe>str1ngs: And if I log out and back in again, the problem remains.
<str1ngs>luis-felipe: do you have frequent or all selected?
<luis-felipe>All
<luis-felipe>Oh, but there is another abnormal thing in the list of all apps: even though nomad is not running, having Emacs running will mark nomad as running instead of Emacs.
<luis-felipe>In GNOME, you can see a blue mark below the icon of an application to indicate that it is running.
<luis-felipe>Speaking of Web browsers, I have had to switch between three web browsers in Guix to survive the pandemic.
<luis-felipe>And I had to borrow and Android once.