IRC channel logs

2020-06-29.log

back to list of logs

<NieDzejkob>pkill9: maybe their build system is different
<ngz>lfam: OK. Thank you.
<NieDzejkob>mbakke: I located your commit for updating to GCC 7 and noticed that you also update gcc-objc and gcc-objc++. Should these get bumped in unison too? If so, it might be a problem that gcc-objc only goes up to 8, likewise for gcc-objc++
<mbakke>NieDzejkob: oh, were they removed? probably should set them to GCC 8 then
<NieDzejkob>mbakke: haven't investigated why they aren't there, assumed that they just weren't created like with gfortran
<NieDzejkob>mbakke: did you find a relevant commit?
<mbakke>NieDzejkob: ah right, let's create 9 and 10 variants for those as well as gfortran first (on master) :-)
<NieDzejkob>OK. Not sure what your timezone is, but I think I'm gonna end it here for today. Do you want to create these variants, or would you rather have me do it?
<mbakke>NieDzejkob: happy for you to do it ;-) it's too late to hack for me too.
<Gooberpatrol66>Has anyone gotten JACK working on guix system?
<NieDzejkob>Gooberpatrol66: there's been some mentions of JACK here, you might want to search the logs (logs.guix.gnu.org)
<lfam>I found this with Google: https://www.alexandrostheodotou.com/setting-up-jack-on-a-guix-system.html
<lfam>There is also likely some info in our mailing list archives
<pkill9>yea i have Gooberpatrol66
<pkill9>a while back i had been using it as virtual guitar amp
<Gooberpatrol66>pkill9: did you have to disable pulseaudio?
<pkill9>yes, so that JACK can take control of the audio device
<Gooberpatrol66>pkill9: how did you do that?
<pkill9>by killing pulseaudio
<Gooberpatrol66>pkill9: if i do that it restarts
<pkill9>but you cna also use pasuspender which will temporarily kill it
<pkill9>hmm
<pkill9>try pulseaudio -k
<Gooberpatrol66>ok if I do that as myself and root pulse is still running for user "gdm"
<jcob>Hey I'm a newb and I'm trying to build xdg-desktop-portal-gtk. I managed to build xdg-desktop-portal, but I dont have any clue what installing dbus services looks like in guix
<jcob>does anyone know what definitions i can look at for packages that install dbus services?
<NieDzejkob>I'd try grepping for dependencies on dbus, maybe
<jcob>hmm.. I looked through the definition of dbus itself and I couldnt find any services defined
<jcob>but that may be my newbieness. Ill try to get further along in the build and give a more specifc error if i run into one
<wdkrnls>the services are in the services.scm file.
<wdkrnls>(or directory)
<jcob>share/dbus-1/services? yayy
<wdkrnls>... was just offering that if you might have been getting services and packages confused.
<wdkrnls>see gux/gnu/services/dbus.scm for example
<wdkrnls>(in the guix source code)
<jcob>booting into my guixsd virtual machine. Whereabouts in there would I find that?
<jcob>ls
<jcob>oops sorry
<wdkrnls>(well, I git clone'd from the savannah repo to see examples of service definitions)
<jcob>ahh, so its in the guix source itself.
<NieDzejkob>wdkrnls: I think a dbus service might be a different thing than a guix/shepherd service
<NieDzejkob>it's an IPC mechanism, after all
<jcob>sorry if this is an RTFM question but.. how to you add a package definition to your guix configuration? The hello world example stops at just installing a package from a source file
<wdkrnls>you can do guix package -f pkg-srcfile.scm but to make it work for next update you would want to create a channel or send it upstream to guix.
<wdkrnls>I may be confused about what you are looking to do. if you just want to reference it in config.scm, there is a (packages) slot in the operating-system definition.
<jcob>the first thing you said answered the question i had
***jonsger1 is now known as jonsger
***jonsger1 is now known as jonsger
<pkill9>NieDzejkob: i got springlobby running, i added gcc to wxwidgets inputs
<pkill9>so my guess is guix uses a different version of gcc in gnu-build-system and cmake-build-system
<GuixNewbie8128>Q: How do I create a reproducible guix environment (not profile)? There is no option to input a channels file, only a manifest file.
<pkill9>GuixNewbie8128: you can run `guix time-machine --commit=<guix commit> -- environment ...`
<GuixNewbie8128>Thanks! Does running "guix time-machine" always download from the Internet?
<pkill9>not if you've already got that guix revision
<pkill9>e.g. if guix has built it (downloaded or compiled)
<GuixNewbie8128>That is what I would expect, but running "time guix time-machine -C channels.scm -- describe" multiple times takes over three seconds. What else could explain the slow performance?
<ryanprior>vagrantc: any progress getting Guix into Debian since April? Is there any opportunity for me to help push that along, or is it out of our hands?
<pkill9>GuixNewbie8128: that's just guix, it's kinda sluggish
<pkill9>compared to most commands
<pkill9>why does `guix graph wxwidgets` not show gcc? i thought it would be there
<pkill9>hmm maybe because it's a hidden package
<pkill9>yes, i can see it in type 'references'
<NieDzejkob>pkill9: I don't think it's about hidden packages, it's just that some dependencies (those inserted by the build-system, to be exact) are implicit. you can see them with guix graph -t bag
<NieDzejkob>jcob: it's just scheme code, so you could also define a package in your system configuration file if you really wanted to (something like (define my-pkg (package ...)), and then use it in the (packages) field or pass it as an argument to some service...), but workflow-wise, channels are a better answer most of the time
<NieDzejkob>(also, if your package is generally applicable (i.e. not something like "dwm but with my custom compile-time options"), we'd really appreciate if you submitted it for inclusion into Guix - that way, others will be able to easily benefit from your work :D)
<procra>I am installing guix on a machine with linuxMX however the first time that i do a "guix pull" it give me an hash mismatch with the icu4c source code. I don't know if i should edit the expected hash (and how to do it) or if i should download the source code somewhere else
<apteryx>any ruby users in here?
<GuixNewbie8128>When creating a guix environment, running `(list (channel
<GuixNewbie8128> (name 'guix)
<GuixNewbie8128> (url "https://git.savannah.gnu.org/git/guix.git")
<GuixNewbie8128> (commit
<GuixNewbie8128>Q: When creating a Guix environment, running 'guix describe -p $GUIX_ENVIRONMENT -f channels' prints an empty list. Why is this so?
<apteryx>procra: that's annoying. Let me see if I can reproduce the problem
<apteryx>procra: perhaps you could get around this situation by using substitutes, if you don't mind using these.
<NieDzejkob>procra: Could you paste the full error message? (paste.debian.net or similar) The hash for icu4c@66.1 matches for me
<apteryx>for me as well, using a slightly dated master (~3 days)
<apteryx>I got this message running 'guix build -S icu4c --check': warning: rewriting hashes in `/gnu/store/zmwl3q4gwn6fwqgi6x3389w28g540lsi-icu4c-67_1-src.tgz'; cross fingers
<apteryx>not sure what it's about, git grep tells me it happens in the daemon.
<NieDzejkob>GuixNewbie8128: the channels format is the machine-readable version of what's shown for an argument-less call to 'guix describe'. In other words, it only works for profiles managed by 'guix pull', such as ~/.config/guix/current
<NieDzejkob>is this just a curious question, or are you trying to accomplish something?
***familia_ is now known as familia
<raghavgururajan>sneek, later tell nckx: https://bin.disroot.org/?10d777310f409ba8#7BSRf9hY9bCZfEJEaMZ12PXGxFYTzDZmrxFEaoq4Q3ZZ
<sneek>Got it.
<procra><NieDzejkob> This is the full error https://paste.debian.net/hidden/502c4162/
<NieDzejkob>which package provides LLVM's lld?
<jackhill>NieDzejkob: Thanks for looking at qdirstat! I think I've learned some stuff from your review. Hopefully I didn't cause you or the patch author too much additional work.
<nckx>Morning, Guix.
<sneek>nckx, you have 1 message!
<sneek>nckx, raghavgururajan says: https://bin.disroot.org/?10d777310f409ba8#7BSRf9hY9bCZfEJEaMZ12PXGxFYTzDZmrxFEaoq4Q3ZZ
<efraim>morning
<janneke>hello efraim!
***apteryx is now known as Guest39931
***apteryx_ is now known as apteryx
<civodul>Hello Guix!
<xelxebar>Hello, civodul :)
<alextee[m]>we dont have https://github.com/jarun/Buku ! will package it soon
<efraim>I can make go use the go-cache if I don't let it use the pre-built go pkg directory but I can't get it to use the pkg directory from packages other than go
***rgherdt_ is now known as rgherdt
<civodul>hey ho!
<civodul>sneek: seen zimoun
<sneek>I think I remember zimoun in #guix 3 days ago, saying: nckx: it depends on the size of your house. ;-).
<mjw>That is a good final quote. Works in almost any context :)
<civodul>heh :-)
<leoprikler>Well, the context may depend on the size of your house.
<civodul>that's a funny feature of sneek's
<civodul>heheh
<mbakke>janneke: the Rust test suite needs to run GDB Python scripts, do you think it's reasonable to add Python to 'gdb-minimal'?
<janneke>mbakke: dropping python was my main reason for creating gdb-minimal...
<leoprikler>Wouldn't "gdb-for-rust" which is gdb-minimal + python be a better option?
<mbakke>lol, I see :-)
<leoprikler>(or just use full-blown gdb)
<leoprikler>unsure how fat guile support is
<janneke>leoprikler: we figured that adding guile support is free on guix
<leoprikler>oh, right, so gdb-minimal already has guile? neat
<janneke>yeah...so mainly thinking closure/dependency-wise
<janneke>guile is mostly python, if you remember to put some parens in the wrong spot
<civodul>soon maybe GDB will support Guile 2.2/3.0!
<civodul>review for that is a bit draining, i sympathize with those who've had to endure tedious reviews here
<civodul>(i just hope it wasn't that tedious :-))
<mbakke>civodul: that's great :-)
<mbakke>janneke: you can even run Python scripts on Guile, using 'python-on-guile'!
<civodul>oh, Python-on-Guile-in-GDB sounds like a killer feature, too!
<civodul>surely we can convince'em to remove CPython support
<janneke>yeah!
<efraim>I'm done bashing my head against reusing go artifacts, now to bash my head against reusing rust artifacts
<mbakke>efraim: heh :/
<jonsger>we don't have something like coredumpctl yet?
<jonsger>so how does folks collect coredumps?
<civodul>jonsger: the "normal" way
<civodul>so by default in $PWD
<civodul>but then there's /proc/sys/kernel/core_pattern
<civodul>is that what you meant?
<jonsger>civodul: when I start a programm, say foo via a DE or dmenu (in my case), what is PWD?
<civodul>i suppose $HOME
<civodul>but yeah, i see what you mean
<civodul>there are cases where it's not so obvious
<civodul>and that's presumably why things like coredumpctl exist
<civodul>well, future work?
<jonsger>I guess
<jonsger>thats my most or maybe only missed feature from systemd world :P
<NieDzejkob>efraim: as in, getting rid of the #:cargo-inputs scheme?
<jcob>Hi fellows, so
<jcob>1. How would one add package definitions to the guix repo locally on their computer? guix edit sksksk.scm takes me to a readonly file
<jcob>2. I want to add services to shephard. Where do I put that code?
<jcob>thanks
<alextee[m]> https://pypi.org/project/mypy-extensions/
<alextee[m]>anyone know why i can't fetch this with pypi-uri ?
<efraim>NieDzejkob: that's the plan
<NieDzejkob>good luck :P
<NieDzejkob>if that doesn't work, there's always #42049 to ease the pain a bit
*raghavgururajan peeps in o/
<jonsger>jboy: `guix edit` is missleading, it should be name `guix view` as you can look at the read-only package definitions on your system. To actually add package definitions you need to check out the git repo and work on that...
<jcob>that makes sense.
<jcob>If you check out the git repo how do you configure guix so that it uses your fork?
<jcob>slash uses your local repository
<NieDzejkob>you can use a file:// url in /etc/guix/channels.scm
<NieDzejkob>but for the most part ./pre-inst-env suffices
*jboy waves
<NieDzejkob>also, ./pre-inst-env guix edit actually lets you edit
<jcob>Ok pre-inst-env! uhh... what exactly is that
<jcob>ahh its from building guix from source (?)
<jcob>can I do that without reinstalling guix ;.l
<jcob>;.;
<nckx>Yes.
<raghavgururajan>jcob, https://guix.gnu.org/manual/en/html_node/Building-from-Git.html#Building-from-Git
<raghavgururajan>nckx o/
<nckx>raghavgururajan: o/ https://ci.guix.gnu.org/jobset/wip-desktop has been ‘In progress’ for > 5h now. Keeps the suspense up.
<raghavgururajan>nckx: Yay! No fail cheers me.
<mbakke>janneke: I was able to cross-build Python for Hurd with this snippet: https://paste.debian.net/1154363/
<civodul>woohoo!
<narispo>aye!
<narispo>it's awesome to see gpg verification on guix pull as well!
<jcob>Hey I have a question. for some reason make check fails on the test channel-news, one entry. I'm pretty sure that I followed the installation instructions correctly...
<jcob>does anyone know what could cause this?
<jcob>This is on a "foreign distro"
<jcob>NVM I think i figured it out. I think it has to do with locales
<mothacehe> /me finally sent linux modules compression patch to review
<jcob>:D
<zimoun>civodul: Hackathon draft pushed. :-)
<civodul>hey
<civodul>thanks, zimoun!
<nckx>Does anyone know a GUI PDF viewer that lets me rotate arbitrary pages & save the document?
<civodul>mothacehe: .ko compression, yay!
<nckx>bert berterfs.
<mothacehe>civodul: I hope it will make the image fit the 1.4G limit for the tests :)
<mothacehe>which would mean that except for the shepherd issue, installation tests should be ok
<civodul>nice!
<civodul>can we pretend the shepherd issue didn't exist?...
<civodul>:-)
<mothacehe>Then I'd like to add a test overview page to Cuirass, with nice red and green boxes!
<civodul>ah yes
<civodul>note that we can run "guix weather -m etc/system-tests.scm"
<mothacehe>civodul: hehe, that's my strategy for now :p. I will try to fix it after summer holidays.
<civodul>but due to baking it's not that good
<civodul>alright :-)
<janneke>mbakke: \o/ that's great!
<nckx>mothacehe: Thank you! /me tests.
<webstrand>I'm thinking of using guix; but I need LXD (or some other system-level container runtime), is there any package for it, even unofficial?
<stikonas>webstrand: there is docker
<roptat>and guix containers
<stikonas>I'm trying to use "guix pack --relocatable --relocatable gcc-toolchain gnupg" and it doesn't work because of collision, gcc-toolchain has executable (not a folder!) called sbin which causes collision. Any ideas how I can install both of them together?
<MSavoritias[m]1>would lxd work or is it just not contributed yet?
<stikonas>The error I'm getting is: guix/build/union.scm:144:11: union-build: collision between file and directories ((files ("/gnu/store/rgyjhfkb5sxcyy362i3bshh80v6giq2c-gcc-toolchain-10.1.0R/sbin")) (dirs ("/gnu/store/i1339a5cj1y53z3zgny2wls47kxzy48r-gnupg-2.2.20R/sbin")))
<webstrand>I think it's just not contributed yet, it should work fine if LXC does
<webstrand>I'd write the package myself, but I'm not familiar enough with guix
<roptat>it doesn't seem to be in guix yet
<MSavoritias[m]1>ok. thank you
<roptat>but yeah, we have lxc
<NieDzejkob>webstrand: you could always get more familiar ;)
<roptat>stikonas, sounds like a bug
<NieDzejkob>the documentation on this part is quite good
<stikonas>roptat: ok, I'll open an issue a bit later...
<stikonas>I would expect gcc-toolchain to ship with sbin folder too, not sbin file
<jcob>christ on a cracker, does pre-inst-env have no prebuilt binaries?
<jcob>(substitutes)
<jcob>ive been waiting for over thirty minutes for "guix build hello" to finish
<webstrand>NieDzejkob: That's what I'm hoping to do, I just need to find a way to be productive on guix while I learn it. Otherwise I'll be forced back to a distro I'm familiar with
<roptat>have you enabled substitutes?
<jcob>uhh how do you do that. also facepalm
<malaclyps>good morning guixen
<roptat>depends on how you installed guix, but basically "guix archive --authorize < the-key"
<fps>jcob: it's described in the manual [not being snarky, just too lazy to look it up]
<roptat>where I need to check where "the-key" is located
<roptat>etc/substitutes/ci.guix.gnu.org.pub
<jcob>fps I found it thank you
<roptat>jcob, that needs to be done as root
<civodul>stikonas: could you report a bug about the gcc-toolchain collision issue you mention?
<roptat>civodul, just built gcc-toolchain, there's an issue with etc, sbin and var being symlinks to glibc's store path
<stikonas>civodul: yes, I can do that
<jcob>When I try to do pre-inst-env guix archive, i get "no code for module (gcrypt hash)" :(
<NieDzejkob>jcob: is that in a guix environment guix?
<jcob>im glad you can't see my face right now
<jcob>because its not
<stikonas>civodul: https://debbugs.gnu.org/cgi/bugreport.cgi?bug=42127
<stikonas>I mentioned those symlinks to glibc store path too in the bug
*NieDzejkob attempts packaging LLD
<alextee[m]>don't we already have it?
<alextee[m]>i thought it was the linker clang uses
<civodul>stikonas: cool, thanks!
*civodul is in a writing mood, working on a post about authenticated channels
<janneke>cool, go civodul!
<civodul>:-)
<NieDzejkob>alextee[m]: looks like it takes ld from $PATH
<alextee[m]>oh
<MSavoritias[m]1>how much are the applications in guix sandboxed? It doesnt seem to be selinux running or and i cant find firejail
<MSavoritias[m]1>I know that they are by their nature filesystem sandboxed but does that make selinux or firejail reduntant?
<NieDzejkob>MSavoritias[m]1: you can run high-risk programs in a container quite easily with guix environment --container
<MSavoritias[m]1>i know that guix has easy container capabilities and its one of the nice things :)
<MSavoritias[m]1>i was more wondering about the defaults
<MSavoritias[m]1>like what sandbox guix does without any user interaction
<NieDzejkob>are sandboxes by default a thing on GNU/Linux?
<MSavoritias[m]1>a good question. I know that Fedora has Selinux and Unbuntu has AppArmor by default
<MSavoritias[m]1>but I havent read to my knowledge a distro that actively wants to pursue sanboxing or containerzing applications
<MSavoritias[m]1>they deem Flatpak and Snap for that
<jcob>this is strange to me: when i do `guix environment guix` it makes a different environment from `guix environment guix guile`
<jcob>very odd to me... because isnt guile one of guix' deps?
<jcob>Ok yall so even with guix environment guix guile guile-gcrypt
<jcob>sudo ./pre-inst-env guix archive --authorize gives me the following error
<jcob>no code for module (gcrypt hash)
<jcob>anyone have any clue what that could be caused by?
<NieDzejkob>jcob: you don't need ./pre-inst-env to authorize, that's system-wide
<NieDzejkob>the git repo is not a separate installation of guix
<NieDzejkob>you still share the daemon, for example
<stikonas>jcob: no, guile is not a guix dep, guix depends on guile-3.0-latest
<NieDzejkob>also, guix environment guix guile gives you the *dependencies* of guix and guile
<NieDzejkob>you want --ad-hoc to actually add a package
<NieDzejkob>also, when you're combining guix environments with sudo, you probably want sudo -E
<jcob>oh thank god, its downloading the substitutes. I was just being a moron then
<jcob>I let it build three versions of gcc before I stopped it
<jcob>on a 10 year old potato computer
<NieDzejkob>mbakke: what's the status on #41601? it kinda feels like that wording just took another victom
<NieDzejkob>victim*
<jcob>So if you want to contribute to the guix project repository directly... do you have to rebuild guix every time you update one of the package definitions?
<jcob>(in the guix source)
<NieDzejkob>as in, "make"?
<NieDzejkob>no
<NieDzejkob>./pre-inst-env guix will load the source files if they're newer than the compiled code
<NieDzejkob>with the caveat that this takes time
<jcob>ok good. thanks!
<NieDzejkob>so if many files got modified since the last compilation (say, because of "git pull"), you want to run "make" again to make pre-inst-env fast again
<mbakke>NieDzejkob: I was not entirely happy with the wording myself and decided to meditate on it a bit... the solution did not reveal itself yet though :P
<NieDzejkob>mbakke: understandable. BTW, I'm looking at %generic-search-paths in (gnu packages gcc) and I'm wondering whether that CPATH should be C_INCLUDE_PATH
<mbakke>NieDzejkob: it should not, the explanation is in the comment above
<mbakke>"'CPATH' is the only one that works for front-ends not in the C family."
<janneke>i love it when code is self-explanotory
<janneke>*explanatory
<NieDzejkob>ah, somehow I misread that. Sorry.
<NieDzejkob>another weird thing I noticed is that there's no way to use any of the versioned gfortran packages because they're hidden and there's no gfortran-toolchain-N
<NieDzejkob>ah, there's also a comment explaining that
<NieDzejkob>-_-
<NieDzejkob>still, wouldn't it make sense to at least remove the old versions?
<mbakke>NieDzejkob: oh, we should probably un-hide those
<mbakke>does not hurt to have them around, does it? :)
<NieDzejkob>;; Provide the Fortran toolchain package only for the version of gfortran that
<NieDzejkob>;; is used by Guix internally to build Fortran libraries, because combining
<NieDzejkob>;; code compiled with different versions can cause problems.
<NieDzejkob>it might hurt...
<mbakke>oh
<jcob>Hi friends,
<NieDzejkob>o/
<jcob>howcome when I do ,m (gnu packages ssh), then do openssh-sans-x , it says possibly unbound variable openssh sans x :(
<jcob>o/
<NieDzejkob>jcob: works for me in 'guix repl'
<jcob>oh ok. I had done only `guile`
<NieDzejkob>that's weird, it also works for me in 'guile', although the ,m takes longer...
<jcob>furthermore it doesnt work for me in guix :(
<jcob>unbound variable again, even in guix repl
<NieDzejkob>maybe you could paste the entire session?
<jcob> http://ix.io/2quH
<mbakke>jcob: what is your 'guix --version'?
<jcob>I just ran guix pull but I'll give you my guix version in a second
<jcob>1.1.0
<mbakke>jcob: right, that means your PATH is wrong, you should have ~/.config/guix/current/bin as one of the first entries
<jcob>sadly, my path looks like this:
<jcob> http://ix.io/2quJ
<jcob>so node comes before guix but beyond that guix is first
<NieDzejkob>what does `type guix` say?
<NieDzejkob>also `which guix`
<jcob>guix is hashed (/home/jacob/.guix-profile/bin/guix)
<NieDzejkob>right. guix is not supposed to be in your profile
<NieDzejkob>i.e. don't do guix install guix
<jcob>oh really
<jcob>damn :( thats the only way I could get emacs-guix to work on ubuntu
<jcob>alright... time to guix remove guix I suppose (?) then hopefully which guix will return something differetn
<NieDzejkob>yeah, guix remove guix
<NieDzejkob>I don't use emacs-guix, but somebody else here probably does...
<mbakke>jcob: you can also just move ~/.config/guix/current/bin before ~/.guix-profile/bin in PATH
<mbakke>did you use the installer script? I recall a bug report along these lines
<jcob>yup, I used the installer script
<mbakke>jcob: to use emacs-guix with the "current" guix, you probably have to set up GUILE_LOAD_PATH and GUILE_LOAD_COMPILED_PATH manually to point to the current-guix profile
<jcob>changing guile load path was not enough :(
<jcob>oooh wait you mean to the config directory. makes sense
<jcob>Yeah still unfortunatley the following:
<jcob>GUILE_LOAD_PATH=$HOME/.config/guix/current/share/guile/site/2.2GUILE_LOAD_COMPILED_PATH=$HOME/.config/guix/current/lib/guile/2.2/site-ccache
<jcob>is not enough
<bdju>I think I'm just gonna remove next browser from my system so I can go back to applying manifests. bug #42018 in case anyone has time to take a look. wasn't my main browser anyway so I'll live without it.
<mbakke>jcob: did you export those variables too?
<mbakke>jcob: I think those have to use "guile/3.0" by the way, not "guile/2.2"
<jcob>o/
<rndd>hi everyone! is there any way to "freeze" packages which installed in my user to text file?
<jonsger>rndd: what should end up in the text file excactly?
<rndd>jonsger: packages names
<rndd>is there something for this task in guix?
<jonsger>e.g. guix package -I | awk '{print $1}' > file.txt
<rndd>hmmmmm
<cbaines>rndd, I think what you're looking for are called manifests
<cbaines>this blog post might be helpful https://guix.gnu.org/blog/2019/guix-profiles-in-practice/
<cbaines>it also links to this part of the cookbook https://guix.gnu.org/cookbook/en/html_node/Guix-Profiles-in-Practice.html#Guix-Profiles-in-Practice
<rndd>cbaines: thanks, i will read
<rndd>also, is there any good example of packaging npm aps? 0_o
<jonsger>rndd: we don't have a build system for npm packages yet, AFAIK
<rndd>hmmmm
<rndd>is there any example of packaging java aps?
<rndd>o_o
<janneke>what about "node-build-system"?
<rndd>janneke: maybem don't know. it would be great to have an example of package to copy paste
<janneke>see gnu/packages/node-xyz.scm
<janneke>the problem is that node packages often cannot be built from source
<NieDzejkob>at least, not without importing the entire npm jungle
<janneke>for java, there is the ant-build-system, examples e.g. in gnu/packages/java-graphics.scm
<rndd>janneke: sorry, don't undetstand, what means "cannot be built from source" ?
<rndd>you mean packackes are distributed in binary form?
<rndd>*packages
<janneke>rndd: i'm being vague, sorry, because i don't remember the details
<janneke>the problem is bootstrap loops
<janneke>if you walk an package's dependency chain, you'll often find it has more than 1000, or even 5000 dependencies
<rndd>0_0
<janneke>the dependency graph has loops, it's not acyclic
<NieDzejkob>mbakke: cross-compiling hello for hurd fails with gcc 9 during configure, the error "i586-pc-gnu-ld: cannot find -lgcc_s". Any idea what could be going wrong?
<mothacehe>janneke: trying to test your latest serie, but many substitutes are missing even though they should be available.
<mothacehe>Something must still be wrong in the ci config
<janneke>mothacehe: ouch, you mean x86_64 substitutes?
<janneke>(we don't have Childhurd VMs running yet)
<mothacehe>yes substitutes for the x86_64 cross image building :)
<janneke>NieDzejkob: is that on current master?
<janneke>mothacehe: i've been working all day to try invalidate all our cross-built packages; i found that some brokenness in hurd-core-headers prevents us to build nghttp2 natively
<NieDzejkob>janneke: no, it's on my WIP on top of c-u where I bump gcc to version 9
<janneke>NieDzejkob: oh wow, work on the Hurd is going on everywhere
<janneke>mothacehe: i haven't sent that patch/fix yet for review, as i want to make sure it actually works and doesn't break anything (apart from invalidating most of commencement for the hurd)
<mothacehe>ok, so that's not what's causing my substitutes problem, but I'll have a look when you'll send that to review :)
<janneke>mothacehe: you're on latest master, right?
<mothacehe>yup
<nilsirl[m]>Hi, I can't see numbers in icecat (installed using `guix install`)
<rndd>nilsirl[m]: i had same problem
<rndd>i fixed it installing fonts
<nilsirl[m]>rndd: which fonts should I install? And also how do you install fonts? I know in nixos, you have to use `fonts.fonts`
<nilsirl[m]>Is there something equivalent in guix? Or is `guix install` enough?
<lfam>`guix search fonts`, and then `guix install the-fonts-you-want`
<rndd>nilsirl[m]: i'm not sure this is wright. i just "guix install font-google-noto"
<rndd>and after logout and login fonts are ok
<mbakke>NieDzejkob: maybe something fishy with CROSS_LIBRARY_PATH? dunno
<mbakke>NieDzejkob: can you paste the build log somewhere?
<mbakke>NieDzejkob: did you try --target=aarch64-linux-gnu?
<mbakke>mothacehe: could it be that the substitutes haven't been "baked" yet? if you are the first unlucky person to request them, you'll get a 404 while guix-publish creates the NARs in the background
<mbakke>I've been wondering whether we should hack Cuirass to automatically request a substitute for built items
<mothacehe>mbakke: oh, forget about that, could be! But looking to the sqlite database, the recent hurd builds are (-2) scheduled.
<mothacehe>I suspect cuirass, once restarted, fails or chokes resuming old builds
<jcob>Hello fellow guix users,
<jcob>I updated to the latest version of guix. now when I run `guix system vm-image`, I get the following:
<jcob>guix system: error: wrong number of arguments for action 'vm-image'
<jcob>This is different from earlier behavior and from what was described in the docs. would anyone be able to explain that?
<jcob>thanks
<jcob>explain what you're supposed to do to fix that* sorry didnt mean to soudn bitchy
<jcob>havent had much sleep :(
<mbakke>jcob: you need to pass a config file to the vm-image command
<roptat>jcob, guix system vm-image some-config.scm
<jcob>tyty. Ok. So when I do that, it tries to launch Qemu, and fails, because I dont have the perms for it
<jcob>but I want a qcow file, not qemu
<jcob>Can you still get a qcow file?
<mbakke>jcob: are the guixbuilderNN users member of the 'kvm' group?
<jcob>err what does NN stand for there? and no.
<jcob>I haven't added any users to the kvm group
<jcob>(i usually just use sudo)
<lfam>You'll need to use KVM for this. Either add the guixbuilder users to the kvm group or change the permissions of the /dev/kvm file to 666
<lfam>The NN stands for the numbers in the guixbuilder usernames. Like "guixbuilder01", "guixbuilder02", etc
<lfam>Did it used to work to run `guix system vm-image`? Just like that with no other options?
<jcob>Yes, that used to produce an image
<lfam>Do you know what config.scm file it used? Or what kind of image it was?
<lfam>I don't think it was supposed to work that way
<mbakke>jcob: I filed a bug about missing permissions on /dev/kvm: https://issues.guix.gnu.org/issue/42129
<jcob>ty mbakke. However I can understand /dev/kvm being inaccessible to users
<jcob>I only know about it by grepping through my shell history: it made this fileguix-system-vm-image-1.1.0.x86_64-linux
<jcob> it made this file: guix-system-vm-image-1.1.0.x86_64-linux
<jcob>and I just cp'd it to /tmp and used qemu to launch it
<GuixNewbie>Q: Does anyone know why "guix time-machine" is slow and perhaps how to speed it up? e.g. `guix time-machine -C channels.scm -- describe` takes over three seconds.
<lfam>jcob: Did it have a desktop environment? Or was it just on the console?
<jcob>desktop environment
<jcob>lxde
<lfam>GuixNewbie: In general, Guix commands can be pretty slow because Guile is not that fast. Work is being done to speed it up
<jcob>oh or maybe I just downloaded it and am misremembering
<jcob>I didnt really sleep last night sorry
<lfam>That filename looks like something downloaded from our web site
<lfam>No worries
<lfam>There are example config.scm files in our Git repo that you can adapt if necessary: https://git.savannah.gnu.org/cgit/guix.git/tree/gnu/system/examples
<jcob>:D
<jcob>sooo... "our web site". I'm guessing you're a guix maintainer?
<lfam>No, just somebody who thinkgs of Guix as like "we"
<lfam>:)
<jcob>ahh nice
<lfam>I've been contributing for several years now
<jcob>well you wouldn't have happened to have heard of the issues with dbus/xdg-desktop-portal/flatpak right?
<lfam>And did some work regarding documentation of the vm-image stuff, so I notice when people have trouble with it. I'm glad mbakke filed that bug report, it should help a lot in the future
<lfam>I'm not familiar with those issues
<jcob>ah dang. thats the issue I'm trying to solve
<jcob> https://github.com/flatpak/flatpak.github.io/issues/333#issuecomment-633741434
<jcob>It hasn't been too hard so far to package up xdg-desktop-portal and xdg-desktop-portal-gtk. However I need to figure out how to get it all to connect over the dbus
<jcob>I think (but would not swear to it) that that stuff works in nix, so I think it should be possible in guix
<jcob>and if it is, then the last barrier to me being able to use guix (being able to use software that chokes on guix' file layout) would be gone and i could finally ascend
<lfam>Right
<lfam>It's likely there's no technical barrier but I'm not very familiar with the issues. Usually it's more that work needs to be done adding support and communicating why the work is important and how the proposed solution is correct
<lfam>The communication part can be harder sometimes
<jcob>haha yes
<lfam>I mean, a lot of us are computer programmers so we can speak easily to the computer :)
<jcob>but I have to say so far, from what I see, I think that conservative approach has lead to a damn fine OS
<lfam>Thanks :)
<lfam>There's a long list of bugs to fix and features to add but I think the progress so far has been amazing
<jcob>It helps that its all written in scheme and can be easily accessed in emacs ;)
<lfam>Yeah people seem to love that :)
<janneke>so i've heard :)
<NieDzejkob>mbakke: aarch64-linux-gnu gives the same error. Here's the build log for hurd: https://termbin.com/jj7a
<NieDzejkob>and here's the config.log: https://termbin.com/ovpyp
<NieDzejkob>master includes the same things in $CROSS_LIBRARY_PATH
<mbakke>NieDzejkob: there are a number of tricks to make libgcc_s.so visible in gcc.scm, I guess one of the substitutions are either ineffective, or a new one needs to be added
<NieDzejkob>I guess I finally a good time to make substitute*
<NieDzejkob>I'll finally make*
<NieDzejkob>why are ' and enter so close ;-;
<mbakke>...fail hard on error? :-)
<NieDzejkob>yeah
<NieDzejkob>I'm multitasking too much
<NieDzejkob>mbakke: WDYT about #42132?
<mbakke>NieDzejkob: OK by me, but would like to hear civoduls opinion :-)
<jcob>Aight. I think I'm really close to solving my issue.
<jcob>I want to add a dbus service to the login session message bus
<jcob>if anyone knows how they could help me in that regard id be very happy
<NieDzejkob>sneek: later tell civodul: mbakke and I would like to hear your opinion on #42132 :)
<sneek>Got it.
<zimoun>mbakke, NieDzejkob: about #42132, I remember #38436 and then #38636. Well, the packages have been hidden by a7c75b8dbf and removing them could be another option at the time. So I will be interested to know the rationale. :-) If it discussed here, could you please report back in #42132? :-)
<bdju> https://scholar.social/@Cyborgneticz/104429366356135117
<bdju>wrong chat, sorry
<NieDzejkob>zimoun: there's been some discussion in this channel before, but I summarized that in the commit message. Thanks for the relevant bug#s!
<zimoun>NieDzejkob: by "before", you mean today? BTW, I think it is a good idea to remove them. :-) Or maybe to move them to the channel guix-past. ;-)
<NieDzejkob>zimoun: yeah, about 5 hours earlier