IRC channel logs

2020-06-28.log

back to list of logs

<roptat>maven-surefire-plugin done, only one plugin left!
<roptat>and maven-jar-plugin done, all that's left is integrate the maven-build-system on my branch, document it and send the whole thing to guix-patches \o/
<mbakke>roptat: amazing work, looking forward to try it out :-)
*mbakke wants to package libGDX and ultimately Pixel Dungeon
<mbakke>*shattered pixel dungeon
<mbakke>that reminds me, I have another game that I should send for review
*spudpnds gets ready to install Guix SD. Lucky for me I have a number of nice Haswell machines around, which seem pretty well supported.
***familia__ is now known as familia
<nilsirl[m]>Hi, I'm running `guix system reconfigure` on a config file that hasn't changed since the last time I ran `guix system reconfigure` and I get an error about "cannot convert wide string to output locale". here's the log: https://paste.debian.net/1154174, Thank you for the help
***calher is now known as KE0VVT
<lfam>nilsirl[m]: The root of the problem is in that locales warning
<lfam>Have you run `guix pull` since the last time you reconfigured?
<lfam>It would be helpful to see the full config.scm too
*vagrantc guix pulls on an old overdrive1000 that hasn't booted in over a year ...
<roptat>arg, there are errors that weren't there before, I'll need to take care of them before I send my patch series...
<bdju>did the tor browser button get removed?
<nilsirl[m]>lfam: Here's my config.scm: http://paste.debian.net/1154180, it's just the one generated by the graphical and I added a user (which I have censored the name of in the pastebin), I tried commenting the line `(locale "en_GB.utf8")` and that didn't help. I also followed the hint given by almost (if not all) `guix` commands (about the locale), and it hasn't seemed to change anything.
<nilsirl[m]>Also yes, I ran guix pull before the last reconfiguration (I'm not 100% sure), and I ran it again
<nilsirl[m]>So it has been run at least once without change the error
<nilsirl[m]>*chaing
<nilsirl[m]>*changing
<lfam>Had it been a while since the last `guix pull`?
<nilsirl[m]>well I installed guix on this VM today so...
<roptat>is there a way to change the order in which patches are applied with git?
<lfam>Hm
<roptat>I noticed I introduced a package before one of its dependencies
<lfam>roptat: You can use interactive rebase
<roptat>oh I see, I can reorder everything
<LarryTheCow>nilsirl[m]: Do you get the same issue if you use en_US.utf8?
<nilsirl[m]>lfam: Because the error was telling me to set the value of `GUIX_LOCPATH` to `$HOME/.guix-profile/lib/locale`, I looked inside of this directory and found that there wasn't `en_GB.utf8` inside of it: http://paste.debian.net/1154195,
<nilsirl[m]>So I set (using `export`), `LC_ALL` and `LANG` to `en_US.utf8`, and ran `sudo guix system reconfigure /etc/config.scm` and it worked!! As I was writing this, LarryTheCow found the solution as well.
<bdju>my sound broke in icecat. pavucontrol doesn't even list it under playback when I have a video playing
<lfam>nilsirl[m]: You should remove the glibc-utf8-locales package and use the glibc-locales package
<lfam>The names are confusing and we'll probably change them soon
<lfam>Unless you are okay with the en_US locale, that is
<vagrantc>is there strong reason to not make each locale a separate output?
<vagrantc>then people could install only the locales they want
<nilsirl[m]>vagrantc: I should probably shut my mouth considering my total lack of everything when it comes to guix, but maybe if you do this:
<nilsirl[m]>(operating-system (locale-definitions (cons (locale-definition (name "en_GB.utf8") (source "en_GB")) %default-locale-definitions)))
<nilsirl[m]>btw, if anyone can knows that this work, please confirm it because I have absolutely no clue if that can work.
<roptat>success! my hello world package builds with the maven build system
<atw>!!
<roptat>not sure if the maven-build-system is good for anything else, but at least it can build one package ^^
<pkill9>anyone know what file provides ‘inputStream’?
<pkill9>C++ function i think
<pkill9>i think this software I'm trying to build is missing an include
<pkill9>oh i think it's a custom function
<pkill9>fixed the errors with some monkey patching woo
<cjpbirkbeck>hello; i'm trying guix system in a virtual machine, and i keep getting an error that locale isn't installed. installing it with either as my user or as root doesn't seem to work.
<lfam>sneek: later tell vagrantc: It's a good question. The most recent discussion on the subject is here, please chime in: https://lists.gnu.org/archive/html/guix-devel/2020-03/msg00260.html
<sneek>Okay.
<rekado_>I installed the new pre-push hook which runs “make authenticate”
<rekado_>“make authenticate” fails on my own commits; says it couldn’t authenticate it due to a missing-key-error
<rekado_>never mind, I had to reset my checkout of the keyring branch
<raghavgururajan>Hello Guix!
<raghavgururajan>sneek, later tell nckx: Danny asked me to ask you for a server log of the evaluation.
<sneek>Got it.
<nckx>raghavgururajan: https://www.tobias.gr/wip-desktop-fail/ One can also find them in berlin:/var/log/cuirass/evaluations/.
<sneek>Welcome back nckx, you have 1 message!
<sneek>nckx, raghavgururajan says: Danny asked me to ask you for a server log of the evaluation.
<raghavgururajan>nckx: Thanks!
<nckx>I just added the only successful one (14579.gz) for possible comparison, but all 3 failures just… stop.
<nckx>The truncation may not indicate an actual failure at that point though: curl https://www.tobias.gr/wip-desktop-fail/14582.gz | gunzip gives you ‘unexpected end of file’, i.e. the compression was aborted, not necessarily the processes logged.
<nckx>Did a rust bootstrap on master ~yesterday just… go away?
<janneke>nckx: yesterday someone changed the gdb package, triggering a rust rebuild
<janneke>that was fixed by mbakke not soon after
<nckx>Hah, that explains things.
<nckx>We'll never know who.
<janneke>hehe
<LarryTheCow>Had I not read that I would've waited for icecat to finish compiling
<nckx>LarryTheCow: You're our mascot now!
<roptat>Hi Guix!
<janneke>guix refresh --list-dependent nghttp2@1.40.0
<janneke>Building the following 3626 packages would ensure 8585 dependent packages are rebuilt
<janneke>wtf?
<janneke>hmm, it seems that curl leaks into some build system
<janneke>hmm, how does gcc-toolchain depend on nghttp2
<janneke>oh, there was a guix graph trick for that, right?
<cbaines>guix graph --path I think
<janneke>ah right...but hmm, no path
<NieDzejkob>make sure to use the bag graph
<NieDzejkob>it's probably an implicit dep
<NieDzejkob>(also, this is why nghttp2 has a graft right now ;)
<janneke>eh, i'm confusing myself
<janneke>so, guix build gcc-toolchain@7 => store file names
<janneke>guix environment --ad-hoc gcc-toolchain@7 ==> building nghttp2
<mbakke>janneke: guix environment runs various "profile hooks" which calls out to high-level packages like gtk, man-db, etc
<janneke>oww, crap!
<janneke>mbakke: yeah...that makes some sense
*NieDzejkob looks at disk space usage on bayfront
*NieDzejkob decides to attempt gcc bump on their own machine
<bdju>anyone else ran into broken sound in IceCat recently?
<NieDzejkob>sound is playing fine in my IceCat right this second, but I'm not sure when I last restarted my browser
<NieDzejkob>the system itself has 42 days of uptime, so...
***jonsger1 is now known as jonsger
<jonsger>NieDzejkob: it depends on the video/audio format
<janneke>hmm, let me look into nghttp2 build failure then :-P
*janneke hoped to postpone that ;)
<NieDzejkob>mbakke: The comment above (define-public gcc) tells me to update gcc-toolchain too, but it's defined using gcc-final, so it doesn't look like that actually needs updating. Is the comment out of date, or am I missing something?
<mbakke>NieDzejkob: oh, it's probably out of date indeed, though gcc-toolchain-{7,9} will need updating
<NieDzejkob>mbakke: ah, I see now. I was thinking I could go to GCC 10, but now I see that gfortran only goes up to 9. Is this a mistake, or is there a reason there's no gfortran-10?
<janneke>hmm, openssl fails to build shared libraries
<janneke>omg, another home grown build system :-(
<mbakke>NieDzejkob: probably just that no one has added gfortran-10 yet
<mbakke>janneke: are you doing a native bootstrap on GNU/Hurd now?
<mbakke>NieDzejkob: I think many packages don't work with GCC 10 yet, going through GCC 9 will likely be less painful, but no strong opinion
<janneke>mbakke: yeah, something like that
<janneke>we're almost ready to add Childhurd VMs to some build nodes
<janneke>but for that to work, we "need" guix gc
<janneke>and guix gc fails (probably the nix daemon)
***familia_ is now known as familia
<janneke>so we need to do some native debugging
<bdju>NieDzejkob: I'm at 17 days uptime and sometime yesterday a browser restart took out my sound, both in and out. sites can't use my mic anymore and videos can't play back audio. weirdest thing.
<bdju>I was messing with the MOZ_ENABLE_WAYLAND variable, not sure if that's related or not.
<janneke>hmm, no shared ssl libraries on the Hurd!
<NieDzejkob>gcc-9.3.0.tar.xz.drv takes impressively long to build
<atw>well the upside of leaving my computer on overnight to rebuild rust is that I read scrollback now and I know that it wasn't actually necessary??
<mbakke>atw: rebuilding rust should never be necessary if you have substitutes enabled
<cacsr>I want to send a profile of a user of my personal computer to the server to test and build it. What should I do?
<NieDzejkob>cacsr: maybe guix copy --to=server `realpath ~/.guix-profile`
<NieDzejkob>not sure what you want to accomplish
***terpri_ is now known as terpri
<cacsr>sending 90 store items (1,168 MiB) to '10.0.100.1'...
<cacsr>NieDzejkob: This is not the operation I want.
<cacsr>Is there any utility that can get the content in the profile and write it as manifest.scm?
<mbakke>cacsr: there is a 'manifest-to-manifest' script floating around the interwebs, one incarnation here: https://lists.gnu.org/archive/html/help-guix/2019-07/msg00131.html
<NieDzejkob>cacsr: profiles managed imperatively aren't really reproducible. You can't really do better than guix package -I and massaging the list of names into a scheme file
<janneke>maybe we should consider deprecating interactive profile management
<cacsr>...
<NieDzejkob>"..."?
<mbakke>"how do I install a package with Guix? just open a file and type (map specifications->manifest ...) -- and make sure to version control it!"
<cacsr>mbakke: You are right.
<cacsr>I will try to do this.
<janneke>mbakke: yeah, just maybe the script needs to be integrated
<mbakke>cacsr: pro tip: if you want a poor-persons CI for a list of packages, you can run 'guix time-machine -- build --no-grafts -m manifest.scm' in a loop :-)
<Gamayun>Saluton guix!
<janneke>it could make sense to experiment interactively and then update the result in your manifest
<mbakke>janneke: and maybe store a representation in $profile/manifest.scm ? :P
<janneke>mbakke: yeah, usable profile provenance
<cacsr>22:02 < mbakke> cacsr: pro tip: if you want a poor-persons CI for a list of packages, you can run 'guix time-machine -- build --no-grafts -m manifest.scm' in a loop :-)
<cacsr>22:02 < Gamayun> Saluton guix!
<cacsr>22:03 < janneke> it could make sense to experiment interactively and then update the result in your manifest
<cacsr>22:03 < mbakke> janneke: and maybe store a representation in $profile/manifest.scm ? :P
<cacsr>sorry, I pressed my keyboard wrong........
<apsadpa>Are substitutes available for aarch64?
<mbakke>apsadpa: they should be, yes
*mbakke checks with 'guix weather -s aarch64-linux'
<apsadpa>Oh didn't know about that command, neat!
<apsadpa>Also can I setup a "build host" from an amd64 machine in QEMU or something?
<cacsr>This will be very slow.
<mbakke>apsadpa: yes, look into the 'qemu-binfmt-service-type' and enable '(guix-support? #t)'
<apsadpa>The reason I'm asking is I am planning to install Guix on postmarketOS on the pinephone. I doubt this phone can do much compiling on its own..
<cacsr>If you use qemu user mode will be improved.
<apsadpa>mbakke: Thanks will look into that
<mbakke>the build farm consists of a mixture of native aarch64 machines and x86_64 machines with QEMU user-mode emulation
<NieDzejkob>huh. Is mesboot stuff supposed to be in the closure of gcc-toolchain?
<mbakke>NieDzejkob: it should not
<NieDzejkob>well, it is. On master :/
<NieDzejkob>`guix graph --type=references gcc-toolchain | xdot -` says that glibc-2.31-debug brings in gcc-cross-boot0 for some reason
<NieDzejkob>/gnu/store/vx0x26r5q7z99rih8k1mxyf2bih3vnpc-gcc-cross-boot0-7.5.0-lib/lib/gcc/x86_64-guix-linux-gnu/7.5.0/include is the referenced path
<janneke>guix system: error: open-file: No such file or directory: "/var/guix/profiles/system-1-link/parameters"
<janneke>hmm, some provenance missing somewhere
<janneke>hmm, --save-provenance is just not enabled by default for disk-image...
<apsadpa>Where should I put the GUIX_PROFILE, GUIX_LOCPATH etc. for the root user (on another distro)?
<NieDzejkob>apsadpa: shouldn't they get set automatically by /etc/profile.d/guix.sh?
<apsadpa>Following this https://guix.gnu.org/manual/en/html_node/Binary-Installation.html there is no mention of such a file
<NieDzejkob>apsadpa: hmm, I don't know. guix-install.sh created it for me
<apsadpa>Ahh I see. Maybe /etc/profile would work?
<_pm>Hi All, I am reading through guix code to understand how it does atomic modification of files and I came across the function 'with-atomic-file-output' http://git.savannah.gnu.org/cgit/guix.git/tree/guix/utils.scm#n705.
<_pm>I have the following question - why in the exception handler close-port of temp file happens *after* deletion of the temp file and not before?
<nckx>_pm: With the big caveat that I don't have time to peruse the code: it's common on unix to create a (temp) file, open it, then immediately delete it so that nobody else can see (or open) it. As long as you keep a file descriptor, it's a real file you can use at will and the OS won't delete it.
<nckx>It sounds like what you describe.
<_pm>nckx: Thank you. I think that explains it. I did not know this.
<pkill9>do the gnu-build-system and cmake-build-system use different gcc compiler options? I get this error when running a program:
<pkill9>Fatal Error: Mismatch between the program and library build versions detected.
<pkill9>The library used 3.1.0 (wchar_t,compiler with C++ ABI 1011,wx containers,compatible with 3.0),
<pkill9>and your program used 3.1.0 (wchar_t,compiler with C++ ABI 1014,wx containers,compatible with 3.0).
<pkill9>this is when manually compiling, might fix it when built in build system
<NieDzejkob>pkill9: is this a package that's already in Guix? I don't think there's a reason to say "a program" instead of naming said program...
<pkill9>no it's not, it's springlobby
<lfam>I'm going to do one more self-review today and if goes well I'll push my fix for <https://bugs.gnu.org/40832>
<lfam>This will graft alsa-lib
<NieDzejkob>mbakke: hello built without any issues with GCC 9
<NieDzejkob>I'm gonna have it build git-minimal now
<mbakke>NieDzejkob: yay \o/
<mbakke>NieDzejkob: did you have to do any changes apart from changing the 'gcc-final' and 'gcc' variables to use GCC-9?
***dddddd__ is now known as dddddd
<pkill9>how do i specify gcc version in cmake-build-system?
<pkill9>as in, replace the package
<civodul>hey!
<civodul>pkill9: often you can just add the gcc version you want to 'native-inputs'
<mbakke>that is likely to cause a build failure due to conflicting GCC headers on CPLUS_INCLUDE_PATH though, we should fix that on core-updates somehow
<NieDzejkob>mbakke: not gcc-final, https://termbin.com/xcqt
<NieDzejkob>huh, the build for git-minimal is building guile-3.0.2 again. I thought that was done already...
<NieDzejkob>anyway, any suggestions for other key packages to check after git-minimal?
<mbakke>NieDzejkob: neat diff :-)
<mbakke>NieDzejkob: try building other GCC versions, i.e. 4.9 or 5, that can be a challenge sometimes
<NieDzejkob>mbakke: if that works, what then? push it and see what CI does?
<mbakke>NieDzejkob: also check './pre-inst-env guix build --no-grafts bootstrap-tarballs' and cross-compiling with './pre-inst-env guix build --target=i586-pc-gnu hello' (ideally also a -linux target such as aarch64-linux-gnu) :-)
<pkill9>why does guix not keep old versions of boost around?
<NieDzejkob>we don't keep around old versions of most packages. Why is boost special?
<NieDzejkob>(you can always use guix time-machine, y'know...)
<pkill9>dunno
<pkill9>hmm, cna you use an inferior package in a package definition?
<pkill9>can*
<pkill9>sadly the time machine doesn't always work
<NieDzejkob>you could also bring the boost version you need back from the past
<pkill9>could you add it to a guix environment/
<NieDzejkob>you can put package definitions in a manifest
<pkill9>oh yea
<rekado_>pkill9: https://github.com/BIMSBbioinfo/guix-bimsb/blob/master/bimsb/packages/variants.scm#L251
<pkill9>ooo sweet thanks
<pkill9>would there be any benefit to guix trying to build stuff in parallel?
<pkill9>as in, multiple packages at the same time
<lfam>Guix can already do this
<lfam>The --cores and --max-jobs arguments control it
<terpri>it does it by default, in fact
<NieDzejkob>weird, builds seem to take much longer to start on core-updates than they do on master
<NieDzejkob>and for this package all the deps are ready already, too, so it's not like it's doing a lot of work in the dependent packages
<pkill9>anyone know how to fix this error?
<pkill9>Fatal Error: Mismatch between the program and library build versions detected.
<pkill9>The library used 3.1.0 (wchar_t,compiler with C++ ABI 1011,wx containers,compatible with 3.0),
<pkill9>and your program used 3.1.0 (wchar_t,compiler with C++ ABI 1014,wx containers,compatible with 3.0).
<pkill9>trying to compile springlobby
<pkill9>think it's wxwidgets that's the problem
<NieDzejkob>pkill9: I think the library and program are being compiled with different -std flags in CXXFLAGS
<NieDzejkob>build for bdb fails due to some issue with atomics, borrowing patch from Arch Linux
<thomassgn>any of you have an android 10 device and know how to transfer files from it to a guix system?
<bdju>I'm on LineageOS and I can use sftp or rsync from the Termux app
<bdju>LineageOS but also Android 10 I mean
<pkill9>thomassgn: adb is usually used
<thomassgn>ah, that would work yes. Thanks.
<pkill9>adb pull </path/on/android>
<ngz>mbakke: nice job for packaging ufoai.
<ngz>mbakke: I agree it is not reasonable to try packaging any 2.5.X release.
<pkill9>it's not setting it
<pkill9>and wxwidgets doesn't set it
<fps>thomassgn: i use syncthing on android and linux to have shared folders for some things..
<fps>oh and on windows, too. it's a neat little program
*mbakke wonders what font I need to make Emacs render Ludos cat glyph in https://issues.guix.gnu.org/issue/42111
<ngz>mbakke: gnu-unifont
<mbakke>huh, I do have that installed
<leoprikler>you need some magic to make stuff render in that font though
<leoprikler>(set-fontset-font t 'unicode font nil 'prepend)
<ngz>I don't have that in my config.
<civodul>mbakke: i actually don't know either :-)
*civodul tries "guix install font-gnu-unifont"
<civodul>hmm doesn't seem to help
***sneek_ is now known as sneek
<ngz>Odd. Note that I am in a foreign distro.
<ngz>But Emacs is from Guix
<ngz>On another topic, where do you think a stenography engine should go?
<pkill9>NieDzejkob: the nix package doesn't change any of the cmake flags though https://github.com/NixOS/nixpkgs/blob/84cf00f98031e93f389f1eb93c4a7374a33cc0a9/pkgs/games/spring/springlobby.nix
<lfam>ngz: If it uses images, I would put it in the image module. And likewise for other formats
<ngz>lfam: I meant stenotyping, sorry
<ngz>I thought stenography was equivalent.
<lfam>Ah
<ngz>(not steganography)
<lfam>I think it could use its own stenotyping module
<lfam>I misread your original question as steganography. A stenography module would be appropriate here