IRC channel logs

2020-03-13.log

back to list of logs

<genghis-sean>hey #guix! I'm trying to build a disk image of the installer from source to debug an installer issue I'm seeing.
<genghis-sean>So I'm running `guix system disk-image` on a non-Guix system to generate an iso9660. I ran it without root access and got access denied on the KVM kernel module.
<genghis-sean>When I tried the same command with sudo I get "no code for module (gnu installer)"
<genghis-sean>btw the full command I ran was `sudo -E guix system disk-image --file-system-type=iso9660 gnu/system/install.scm --fallback
<nckx>genghis-sean: Most systems (Guix System certainly) have a ‘kvm’ group to manage KVM access.
<genghis-sean>Yea I figured there was some way I could tell sudo to do the right thing, but I wondered if anyone here has experience building installers on non-Guix systems
<nckx>Yeah, finding gnu/system/install.scm is… touchy, for some reason. I think it needs to be in GUIX_PACKAGE_PATH.
<nckx>genghis-sean: Nope, no experience.
<genghis-sean>Well I don't have GUIX_PACKAGE_PATH set so maybe I should try that
<nckx>Try adding yourself to the kvm or equivalent group (and making sure it's taken effect, e.g. logging out & in again) before sudo.
<nckx>s/before/before resorting to/
*nckx → afk but will return to see how far you got.
<genghis-sean>I don't see kvm in /etc/group so maybe I don't have that kernel module
<genghis-sean>I find that hard to believe because I've used a kvm flag on qemu commands before
<lfam>Does /dev/kvm exist
<lfam>?
<genghis-sean>yes
<lfam>I make this work on Debian with a simply terrible hack. `chmod 666 /dev/kvm`
<lfam>The 666 should communicate that this is a bad idea
<lfam>It won't persist across reboots
<lfam>It's weird that your system doesn't have a KVM group
<genghis-sean>that sounds gross, but I borked my GuixSD install and want to chase this installer bug I'm hitting
<lfam>The other option is make the Guix code not try to use KVM by figuring out where this QEMU invocation is and removing the part that says '-enable-kvm'
<lfam>But then it will be very slow
<genghis-sean>apparently that's a thing https://unix.stackexchange.com/questions/526377/no-kvm-related-group-but-module-exists
<lfam>What distro are you on?
<genghis-sean>ubuntu
<lfam>Well, the "right thing" is to follow those instructions about setting up the group. Or find out how it's supposed to be done on ubuntu
<genghis-sean>I just set up the group, but at the end it says "to chmod it to 660 to prevent you from having to restart"
<genghis-sean>here goes nothing haha
<genghis-sean>hmm, it failed instantly with the same error
<nckx>Wait a sec. Isn't it *guixbuilder* trying to KVM?
<nckx>And indeed: grep kvm /etc/group
<nckx>kvm:x:984:nckx,guixbuilder01,guixbuilder02,guixbuilder03,guixbuilder04,guixbuilder05,guixbuilder06,guixbuilder07,guixbuilder08,guixbuilder09,guixbuilder10
<genghis-sean>I tried adding the builder users but I still get the error. I'm going to try rebooting to see if that helps.
<genghis-sean>rebooting seems to have helped. It hasn't failed yet. I'm going afk for a bit. Thanks for the help :D
<Blackbeard>I don't the see the Vera Fonts License in licenses.scm
<Blackbeard>What should I do
<Blackbeard>Summit a change or use it as a new license
<Blackbeard>Or use BSD it is BSD like
<Blackbeard>With a string
<Blackbeard>non-copyleft
<nckx>genghis-sean: Restarting guix-daemon would probably have sufficed, but yay!
<nckx>Blackbeard: (license:x11-style "file://LICENSE-or-like-whatever" "Bitstream Vera License")
<nckx>Blackbeard: If you feel like writing another patch, this seems like it could use some consolidation: font-bitstream-vera itself uses ‘fsdg-compatible’ instead for what seems to be the same licence. There are enough users to justify adding it to licences.scm with or without your package.
<Blackbeard>nckx: oh I see
<Blackbeard>I am a bit confused about the license in this package because it is Vera Font license but it seems like there is also Bitstream Vera Font license
<Blackbeard>I am checking if they are the same
<Blackbeard>Or it is like MIT licenses
<nckx>I don't know & IANAL & all.
<nckx>Hence the need for some clarification 😛
<Blackbeard>nckx: I had to add like 8 licenses 😂
<Blackbeard>Who knew that contributing a package definition would require legal work
<nckx>Yeesh kebab.
<Blackbeard>I added as much as I could find
<Blackbeard>I think this is more than normal because it is a game
<Blackbeard>Seems like most packages use one or two
<nckx>Blackbeard: Yep, basically. Games tend to pull more and different kinds of things together.
***jonsger1 is now known as jonsger
***MightyJoe is now known as cyraxjoe
<apteryx>leoprikler: we've had a reply from some Emacs folks about the issue that needed to be workaround with (require 'autoload): http://bugs.gnu.org/39823
<apteryx>it has to do with the new lexical scoping that is enabled by default on Emacs 27.
<leoprikler>Yep, thought so.
<apteryx>eh, you could have mentioned it earlier ;-). I hadn't thought about this.
<apteryx>by the way, had you or someone given it a shot to just switch our current emacs-build-system to Emacs 27 instead of 26? Wondering how bad the transition would be, or how painless.
<leoprikler>I've helped some people who tried and the patch I sent was a result of that.
<leoprikler>I don't know what other problems may lurk beyond.
<apteryx>OK!
<bandali>apteryx, leoprikler, so we do need to (require 'autoload) for emacs 27 and onwards?
<leoprikler>As far as I read it, yes.
<leoprikler>I'm not sure how Emacs is supposed to bind variables it does not yet know about with lexical scoping.
<bandali>apteryx: hello?
<bandali>yeah.. i'm not sure either
<seepel>Hello there, what are my best options if I need a newer version of an existing package?
<bandali>hi, kind of depends on the package. one option is to send a patch for bumping the version of the package in guix.git
<Blackbeard>Hello
<Blackbeard>What's a good tutorial for git
<bandali>or you could clone guix.git and make the change locally without sending a patch for it. you'd then have to point the 'guix channel to your local clone
<Blackbeard>I added a second game to games.scm
<bandali>alternatively, you could add a new channel and write a new package definition, and (inherit ...) from the original package but change the fields you need
<Blackbeard>But now i need to delete it to do my patch
<Blackbeard>For the first game
<bandali>Blackbeard, hey, if you mean for sending patches specifically, try https://git-send-email.io
<bandali>if you committed that change to master, if you like you can "revert" it
<seepel>bandali: The packages I'm looking at is python-botocore and python-s3transfer
<Blackbeard>I only used git for my own stuff so never had to merge conflicts
<bandali>Blackbeard, actually, a "reset" would probably be better
<Blackbeard>I commuted to branch :)
<bandali>Blackbeard, committed to which branch?
<Blackbeard>games branch
<Blackbeard>One that I created
<bandali>seepel, hm, haven't heard about or used either of those. do you wanna try cloning guix.git, bumping the versions, and sending a patch? see the guix manual section on contributing
<Blackbeard>I also created tests
<Blackbeard>To apply the patch
<seepel>bandali: Happy to!
<bandali>seepel, great! let me know if you have trouble finding the contributing section in the manual
<bandali>Blackbeard, ha. you could just create a new branch, based off of master, and work there
<bandali>or, if you don't need your current games branch anymore, delete it, and create a new one based off of master again
<bandali>seepel, https://guix.gnu.org/manual/en/html_node/Contributing.html
<seepel>Along the same lines I'm trying to use pip and despite the errors about incompatible versions, at the end pip complains about a read-only file system because obviously it is pointing into /gnu/store. I probably didn't realize I had to configure something, does anyone know what I'm missing?
<bandali>hm, i don't think you're supposed to mix in pip when using pypi packages from guix? i'm not sure though. i think you'd install all your dependencies from guix rather than from pypi using pip, etc
<seepel>Hmmm, I have a number of packages I need to install for work that are on our own private artifactory
<bandali>i'm not sure then. maybe check the guix cookbook and/or the manual for any relevant info on python packages? or try asking again when there are more people around
<bandali>another possibility is to package those private packages in a guix channel
<Blackbeard>bandali: will my changes disappear in every branch?
<Blackbeard>So if I add widelands to games.scm
<Blackbeard>And then I add barriage to games.scm
<Blackbeard>But each in its own branch
<Blackbeard>Will each branch have only its own game?
<seepel>bandali: I'm not opposed to going that route, though I _just_ managed to get guix running, so I was hoping to be able to follow our normal new machine procedure.
<leoprikler>If you do it like that then each branch will only have its own game.
<doyougnu>Hi all, Im super interested in guix, coming from NixOS, I do a lot of Haskell development, does guix have a good haskell story?
<leoprikler>but nothing keeps you from merging your branches or rebasing them
<bandali>Blackbeard, depends on which commit/branch each of those branches are based upon. if each one is based on master, then yes each of those branches will contain only the new game you added as a commit in that branch
<bandali>like leoprikler alluded to, it doesn't *have to* be like that though; depends on what you want
<seepel>We also all get macbooks, I'm kind of experimenting with getting our environment up and running in guix on my personal machine to see if it might be viable to install on a company purchased device.
<bandali>hey doyougnu, i like to think we do :-)
<bandali>seepel, right. if yo really do need to use pip, look around in the manual or cookbook, or try asking again later when someone more knowledgeable than me about python in guix is around :-)
<seepel>bandali: Thanks for the advice! I suppose help-guix@gnu.org might also be appropriate :)
<Blackbeard>I see
<Blackbeard>Ok so I think I did changes to the indentation that I should not
<seepel>doyougnu: I've just gotten guix system up and running, and I've _almost_ found everything I need, so I would be surprised if you couldn't get a good haskell environment up. If you use emacs or vim, then you're probably going to be good to go. Is there any software you particularly worried about being missing?
<Blackbeard>So I reset this time to be safe
<bandali>seepel, sure! don't hesitate to ask for help/advice there if you like :-)
<bandali>Blackbeard, alrighty
<Blackbeard>Ohh yes changes go back and forward
<doyougnu>seepel: I'm only really worried unrelated software, e.g., firefox, but I figure I can package that myself. I just wanted to ask here before taking the dive. IMHO it seems that guix has a much better documentation and packaging story than nix
<Blackbeard>Nice
<WildWilly>Hi everyoneç
<seepel>doyougnu: I'm a firefox fan myself, there is IceCat which is firefox with all non-free bits and pieces pulled out (as far as I understand). But I've been using the ungoogled-chrome package for my web browser because it comes with more batteries included
<WildWilly>I have installed Guix and everything is working so far, except that every time that I try to change the display resolution my user logs out.
<WildWilly>Currently using dddm with gnome and xorg
<doyougnu>seepel: interesting, tbh i never considered that an option because I make too much use of containers even though Im sure there is a way to mock these in un-googled chrome
<doyougnu>how do you handle proprietary drivers? I'd like to run this on a macbook and the broadcom driver has been a continual source of pain
<leoprikler>can someone please explain me why search-paths does not change the environment variables of `guix environment`?
<guix-vits>Hi Guix.
<seepel>hi
<Kimapr>oof, yesterday the computer desided to halt when i was installing guix
<Blackbeard>from the shepherd manual
<Blackbeard>6.1 Coding standards
<Blackbeard>About formatting: Use common sense and GNU Emacs (which actually is
<Blackbeard>the same, of course),
<Blackbeard>😂😂😂
<Blackbeard>Beautiful
<seepel>bandali: Looking through the documentation on contributing, but I'm a bit confused about where package definitions are actually stored?
<bandali>seepel, in the https://git.sv.gnu.org/cgit/guix.git repo
<bandali>if you mean where in the repo, in the gnu/packages/ directory
<bandali>to see a package definition, you could something like `guix edit emacs' from terminal, which will open the file containing the package "emacs" in this case in your editor
<Blackbeard>seepel: what type of package are you contributing?
<Blackbeard>a patch or a new package
<guix-vits>doyougnu: possibly like this https://guix.gnu.org/blog/2019/creating-and-using-a-custom-linux-kernel-on-guix-system/
<guix-vits>idk.
<seepel>Balckbeard: There are a few python modules that I would like to update the version of
<Kimapr>oof, the installation starts all over again
<seepel>And now I feel foolish for not finging the gnu/packages directory...
<Kimapr>i mean, system initialization
<seepel>*finding
<Kimapr>i'm doing manual install
<seepel>Kimapr: which step of the install? I'm new here, but I imagine the parts that were actually downloaded/built successfully won't actually be redone
<nckx>Kimapr: But subsequent ‘guix system init’ runs will be much faster in general, since much less will be built and/or downloaded.
<nckx>So, yeah, what seepel just said.
<Kimapr>system crashed on "copying to /mnt" stage
<Kimapr>so everything is downloaded
<Kimapr>but it's redoing it again
<nckx>If you rebooted, then yes.
<seepel>Since the channel seems to be more active than the last time I asked this, does anyone know if there is an easy way to configure the openvpn service with a .ovnp file?
<Kimapr>i guess it's not remembered across restarts
<nckx>Kimapr: No.
<nckx>That would be fragile and probably not worth the effort.
<seepel>Kimapr: That seems an unfortunate time to crash :(
<nckx>What caused it?
<Kimapr>i guess the browser
<nckx>Browser crashing your kernel. Much 2020.
<Kimapr>no
<Kimapr>browser freezing up the system
<Kimapr>forcing me to restart
<Kimapr>that obviously killed qemu
<nckx>Odd.
<Kimapr>with guixsd installer running
<Kimapr>i think that's a vulnerability of Xserver or even Linux kernel itself
<Kimapr>because nothing should be able to freeze the system if it hasn't overbig nice level
<nckx>seepel: There's no ‘here, take this .ovpn file and do stuff’ option. You need to manually apply the settings in that file to your openvpn-server-configuration. Not all options are supported (the openvpn-server-configuration exposes only a subset of what a random .ovpn file can contain).
<nckx>There was someone in here last month with a similar ‘my VPN gave me this file, now what’ question, but I forgot their name. Maybe roptat remembers.
<seepel>nckx: Thanks, would there be any interest in adding such a thing to service? (I'm also not sure who here are maintainers)
<seepel>Running openvpn manually with the config works for me at least :)
<nckx>We're all maintainers in that sense. Seriously. I suspect it would be accepted if someone proposed a patch.
<seepel>Good to know, if I ever find time that is...
<nckx>Many other services have a ‘just take this .conf file please’ option. I usually prefer that option. But I don't use or know the first thing about OpenVPN.
<seepel>I assume the service just executes openvpn under the hood? In which case it is just a simple --config flag
<nckx>Almost certainly.
<raghavgururajan>nckx I wanted to show you this: https://store.vikings.net/x220-x230-installation-service
<guix-vits>.ovpn can hook the scripts (one i saw writed to /etc/resolv.conf); hairy thing it is?
<guix-vits>Hi raghavgururajan.
<guix-vits>*wrote
<raghavgururajan>nckx It's coreboot. No libreboot yet. But close.
<raghavgururajan>guix-vits o/
<nckx>raghavgururajan: I've read that before (the starred ‘Available Options’ drop-downs are great). Note the conspicuously missing ‘-T’ anywhere, though.
<nckx>Still, I wonder what they'd say if you asked/sent them one. I've done neither.
<nckx>raghavgururajan: Thanks for sharing!
<raghavgururajan>nckx I believe, is x230 is possible, then x230-t also possible. They share same chipset. only cpu will ultra-low power variant.
<raghavgururajan>nckx No mention!
<nckx>I assume it's possible. But there are many more horror stories about the X230T than the X230.
<seepel>guix-vits: I'm not sure about that, but it does sound hairy...
<raghavgururajan>I see.
<nckx>Including one that merely connecting an external reader to the chip can brick it. Is that true? I have no idea. But I have no intention of finding out.
<nckx>That said, Vikings know what they're doing.
<nckx>Most of the time.
<raghavgururajan>nckx Hmm. I have no idea about that too. But you could ask them if they can flash x230t.
<nckx>(And by ‘brick it’ I mean ‘damage components on the motherboard’.)
<nckx>Yeah, I guess.
<guix-vits>"Install Trisquel: 45eur; Clean the laptop (biohazard level): 45eur" -- `--pedanticlih`
<guix-vits>request of an option: "I'm swear there is no proprietary OS!": 100eur -- `-Wlazy-uselich`
<guix-vits>*userlich
<guix-vits><3
<raghavgururajan>guix-vits Were you referring to vikings?
<guix-vits>(Yeah, I guess: +13.37eur)
<guix-vits>nckx: the options on the right is truly great, indeed.
*nckx → 😴, good night all.
<guix-vits>why `guix search X` no loger shows a hint about `less` (behavior outside Emacs doesn't changed)?
<Blackbeard>seepel: hey sorry I had to reboot
<Blackbeard>You can usually find stuff with grep
<Blackbeard>grep -iR Python-package .
<Kimapr>also: installing through qemu turned out to be easier
<Kimapr>i found 0 tutorials on how to chainboot an iso file from grub
<Kimapr>tutorials i found boot linux + initrd
<Kimapr>not the grub from iso
<genghis-sean>I found this thing which proved useful for me https://www.linux.com/tutorials/how-rescue-non-booting-grub-2-linux/
<guix-vits>Blackbeard: maybe -r (-R seems to enter an infinity loop in /sys, for example)?
<genghis-sean>I went through the motions of a manual guixSD install (which definitely taught me some things)
<guix-vits>Kimapr: https://help.ubuntu.com/community/Grub2/ISOBoot
<guix-vits>one can mount iso with `loop` and navigate its contents.
<genghis-sean>but now I'm stuck on what is a pretty arcane error to me
*guix-vits restart
<genghis-sean>guix-system: error: corrupt input while restoring archive from #<closed: file 7f462e168cb0>
<Blackbeard>guix-vits: oh. Didn't know that
<genghis-sean>I think I may have messed up the luks file system mapping in my config.scm
<genghis-sean>Now that I've got the word "corrupt" in the error message I wonder if I should reformat the partitions before running guix system init again
<seepel> jjjjjjhe.pgjyy.yy.ypbgxxndibgyeu.ubtyetkxppu
<seepel>Sorry for spilling my yubikey in your irc channel...
<Kimapr>i got this error
<Kimapr> https://i.imgur.com/WDMhmbL.png
<Kimapr>i don't understand what happened
<guix-vits>Kimapr: when booting after the installation?
<Kimapr>no
<Kimapr>when installing
<guix-vits>Kimapr: from VM?
<brendyyn>my emacs is launching with these warnings, even with -Q, and it breaks loading my config Warning: Lisp directory '/home/b/.guix-profile/share/emacs/site-lisp/guix.d': No such file or directory
<Kimapr>yes, from vm
<brendyyn>i notice that guix.d isn't isn't there and everything is in the parent directory
<brendyyn>just wondering if this is a known bug?
<Kimapr>okay, now i have an idea
<Kimapr>i'll install bare-bones.scm instead of modified lightweight-desktop.scm
<Kimapr>to speed up the installation
<guix-vits>Kimapr: you can also try to install guix on-top of your HDD's OS, and run guix system init from there.
<Kimapr>but that isn't an option
<Kimapr>because guixsd installation image has a partition table
<Kimapr>and i don't want to lose my partition table on hdd
<guix-vits>Kimapr: https://guix.gnu.org/manual/en/guix.html#Binary-Installation
<guix-vits>No, its a tarball
<Kimapr>ah
<Kimapr>guix not guixsd
<guix-vits>brendyyn: afaiu, it's a On-Top installation?
<guix-vits>brendyyn: https://guix.gnu.org/manual/en/guix.html#Emacs-Packages
<brendyyn>Guix SD
<brendyyn>this issue just appeared after updating
<Kimapr>hmmm
<Kimapr>that option looks appealing
<guix-vits>brendyyn: i can be wrong, but: civodul mentioned that in IRC.
<brendyyn>guix-vits: He mentioned this emacs problem?
<guix-vits>brendyyn: someone, actually IDremember..
<Kimapr>how to install a i386 guixsd with x86_64 guix?
*guix-vits `guix pull` `guix package -u`
<brendyyn>guix-vits: looks unrelated
<guix-vits>Kimapr: you sure that you need i386, not i686?
<Kimapr>i don't know
<guix-vits>Also tarball for i686 should work on x86_64 system.
<Kimapr>whatever x86_64 is backward compatible with
<Kimapr>anyone knows where i can get system configuration scms of installation iso
<Kimapr>except that iso
<Kimapr>i have no idea how to mount it
<guix-vits>Kimapr https://guix.gnu.org/manual/en/guix.html#Building-the-Installation-Image
<guix-vits>Kimapr: This file: https://git.savannah.gnu.org/cgit/guix.git/tree/gnu/system/install.scm
<guix-vits>brendyyn: i'd updated my non-dev guix. Emacs works. Do you've any more data about this error?
<Kimapr>found it: http://git.savannah.gnu.org/cgit/guix.git/tree/gnu/system/examples
<brendyyn>guix-vits: If you open a terminal and run emacs -Q, do you see any warnings?
<guix-vits>Kimapr: Aren't configs should be a .scm?
<Kimapr>well yeah but they look good inside
<Kimapr>they look like configs*
<Kimapr>and considering they are templates, because some values always need to be tweaked
<guix-vits>brendyyn: `emacs -Q` opens emacs. Closing emacs not show anything in console. But i use emacs-no-x
<brendyyn>Kimapr: the definition of the install image is in the git repo under gnu/system/install.scm
<Kimapr>but i already have an install image
<Kimapr>and found the configs needed in git tree
<brendyyn> https://paste.debian.net/plain/1134739
<brendyyn>maybe its my env, lemme see
<brendyyn>i see. I may simply need to log out and log back in again to refresh my environment
<guix-vits>Kimapr: yes; actually i'd used a lightweight-desktop.scm (.tmpl there) for the initial install. You're right. But it's not an "installation iso config", it's a "from installation iso config", btw.
<Kimapr>but isn't that what i need
<Kimapr>i don't need an installation iso
<Kimapr>i want a working guixsd
<guix-vits>Kimapr: my bad.
<Blackbeard>guix-vits: I use emacsclient -c
<Kimapr>guix is so cool
<guix-vits>Blackbeard: thanks, i'd not spotted -c
<guix-vits>brendyyn: i'm just started `emacs --daemon` and seen some messages, but all of them said "... done", no "Warning: ...". i'd not seen any messages before.
*guix-vits using new knowledge about -c
<guix-vits>great.
<drgibbon>hello, new to Guix, are there any hassles with having an encrypted home dir? As in, can I enter my password just once (say at the X11 login manager)?
<Blackbeard>@freenode_guix-vits:matrix.org: I use emacs --fg-daemon
<Blackbeard>drgibbon: I can't tell. I use an external encrypted hard drive and only Mount it when I need it
<Blackbeard>My main drive is not encrypted
<raghavgururajan>Blackbeard: I believe drgibbon is concerned with encrypted home dir, not encrypted drive/partition. :-)
<jf-guix-user>Hey folks. I'm having trouble configuring an nginx service to depend (shepherd requirement) on another service (custom certificate generation). Could someone provide me with a simple/clear example?
<Blackbeard>raghavgururajan: that's why I said I can't tell :)
<Kimapr>is it possible to run cow-store on a foreign distro?
<Kimapr>i'm out of space on system partition and guix system init can't do anything
<civodul>Hello Guix!
<civodul>g_bor[m]: what's the timeline for GSoC?
<civodul>i'm thinking a project on performance monitoring of Guix and one on performance monitoring of a Cuirass-based build farm would be great
<Kimapr>i figured out a solution for my problem - move /gnu to a bigger partition and mount --bind it back
***jonsger1 is now known as jonsger
<raghavgururajan>Blackbeard: Cool!
<brendyyn>One thing I've noticed that package managers on GNU/Linux tend not to do is inform the user that they may need to reboot or re-login again after an update. Other operating systems often do this, or even do it to much.
<brendyyn>I'd also like a `guix system reconfigure` where the new system isn't available until one reboots
<Kimapr>:(
<Kimapr>
<Kimapr>\builder for `/gnu/store/mfdwymv23dp2k1i39jp0a9v4by7k8sk5-etc.drv' failed with exit code 1
<Kimapr>build of /gnu/store/mfdwymv23dp2k1i39jp0a9v4by7k8sk5-etc.drv failed
<Kimapr>View build log at '/var/log/guix/drvs/mf/dwymv23dp2k1i39jp0a9v4by7k8sk5-etc.drv.bz2'.
<Kimapr>cannot build derivation `/gnu/store/4khikkb6vi7r1k6j0v3ngya5kwkpg1i0-system.drv': 1 dependencies couldn't be built
<Kimapr>guix system: error: build of `/gnu/store/4khikkb6vi7r1k6j0v3ngya5kwkpg1i0-system.drv' failed
<Kimapr>
<Kimapr>installing guixsd with guix on foreign distro
<Kimapr>got that error
<Kimapr>and it also keeps complaining about this
<Kimapr>
<Kimapr>guile: warning: failed to install locale
<Kimapr>hint: Consider installing the `glibc-utf8-locales' or `glibc-locales' package and defining `GUIX_LOCPATH', along these lines:
<Kimapr> guix package -i glibc-utf8-locales
<Kimapr> export GUIX_LOCPATH="$HOME/.guix-profile/lib/locale"
<Kimapr>See the "Application Setup" section in the manual, for more info.
<Kimapr>
<Kimapr>okay nice
<Kimapr>ran this with --verbosity=100
<Kimapr>found this:
<Kimapr>In procedure stat: No such file or directory: "/gnu/store/xml1s9r9vp98amhyyn3q85p5xls3nivf-tzdata-2019a/share/zoneinfo/Uzbekistan/Tashkent"
<Kimapr>seems like it can't understand my timezone
<drakonis>see if you got the path correctly
<sneek>Welcome back drakonis, you have 1 message!
<sneek>drakonis, nckx says: Do it yourself: rclone@1.51's been available for a month. :-/ Pull once in a while, will ya.
<Kimapr>okay, so i should have put "Asia/Tashkent" and not "Uzbekistan/Tashkent"
<drakonis>hmm, i see.
<drakonis>yes
<Kimapr>cool. that could be something much more serious
<Kimapr>and hard to fix
<guix-vits>Pity that the SBC and its accessories isn't packed up together. Only the metal case arrived today.
<guix-vits>brendyyn: Is emacs working now?
<brendyyn>guix-vits: Yes thanks
<brendyyn>guix-vits: it was just my environment needing to be refreshed
<apteryx>are desktop notifications in icecat working for someone else?
<apteryx>can't seem to enable them for mattermost, using the ratpoison WM
<guix-vits>apteryx: i'm see now that my decision to delay the setup of notifications for my box was a wise one.
<apteryx>guix-vits: I think it used to work. Might be just some privacy plugin interaction.
<janneke>/join #libreplanet
<janneke>
<janneke>b
<janneke>huh?
*janneke just uploaded a lightning talk
<leoprikler>how do I set curl SSL certs in guix again?
<guix-vits>leoprikler: reset (WDYM)?
<leoprikler>not "reset", it just appears as if libcurl doesn't read SSL_CERT_DIR and SSL_CERT_FILE
<leoprikler>and I'm trying to reverse-engineer some nasty stuff through mitmproxy
<rekado_>leoprikler: users of libcurl are supposed to do this by themselves.
<rekado_>leoprikler: that’s why every user of libcurl does it differently
<rekado_>libcurl itself only accepts a default location at compile time.
<rekado_>years ago we agreed to patch libcurl so that it looks up SSL_CERT* variables instead of using a fixed default location
<rekado_>but a patch never came to be
<leoprikler>ahh well, I found a workaround by guessing
*lfam builds latest webkitgtk
<Kimapr>
<Kimapr>copying to '/mnt'...
<Kimapr>populating '/mnt'...
<Kimapr>bootloader successfully installed on '/boot/efi'
<Kimapr>
<Kimapr>yay!
<guix-vits>Kimapr: good. But why i686?
<Kimapr>to be able to boot on more pcs
<Kimapr>it seems to install x86_64
<nckx>lfam: Thanks for following up on the Bluez non-event.
<Kimapr>is it possible to change architecture after installation?
<nckx>To be clear: I prefer a non-event to an event any day.
<lfam>nckx: There are still patches we should cherry-pick, right?
<lfam>I mean... does anybody's bluetooth work on Guix...
<lfam>But still
<nckx>lfam: How so? Mine always has.
<nckx>lfam: Which patches (I'm still reading)?
<lfam>Oh, I never tried. I figured all the drivers would be nonfree. I sent two patches as alternatives: one, a full update. two, cherry-picking the bug fixes
<lfam>If you are using bluetooth on Guix, please test my patch that just cherry-picks the upstream patches
<lfam>If you have the time
<nckx>Okido. Will do after dinner.
<lfam>Thanks nckx
<guix-vits>Kimapr: my old desktop box from 2009 was x86_64; are you sure you can encounter an i686?
<Kimapr>yes
<Kimapr>i did right now
<Kimapr>tested with another laptop/netbook whatever
<Kimapr>it is i686
<Kimapr>okay i'll try to boot into guix on this machine
*Kimapr leaves
<guix-vits>i686 laptop. I'm probably were a youth.
<guix-vits>cu
***catonano_ is now known as catonano
<Blackbeard>guix-vits: my libreboot x60 can only boot into 32 bits
<sneek>Welcome back Blackbeard, you have 1 message!
<sneek>Blackbeard, guix-vits says: Join background `--daemon` side, Blackbeard!
<ngz>efraim: I think commit e80d1c1992fb60c492520d61f3a3d1fef65cfdf2 you made a few hours ago is wrong: ``word'' is not equivalent to @code{word} in Texinfo.
<anadon>Hello, all.
<abralek>hi
<eivindst>Hi. How can I get rid of "substitute: guile: warning: failed to install locale" whenever I use 'guix package'? This is on a foreign distro.
<rekado_>eivindst: make sure that in the daemon’s environment GUIX_LOCPATH is set to a valid location. Check your guix-daemon service script.
<eivindst>rekado_: I have tried setting GUIX_LOCPATH for the daemon, but still see the same error. I am using OpenRC (Gentoo), so I added 'GUIX_LOCPATH=/var/guix/profiles/per-user/root/guix-profile/lib/locale' to '/etc/conf.d/guix-daemon' which should set the environment variable for the daemon from my understanding.
<apteryx>hmm, in mattermost my time is 1 hour off (earlier), even with resist.fingerPrinting set to False. Ideas?
<rekado_>eivindst: does the directory exist and contain a versioned sub-directory with locales?
<eivindst>Yep. When I 'ls' the folder I can see it contains a single folder '2.29' containing various locales.
<rekado_>eivindst: please check that the running daemon does in fact use glibc 2.29. You can use ‘guix gc -R /gnu/store/…guix-daemon…’ to get a list of references.
<apteryx>lfam: my bluetooth works fine on Guix
<apteryx>I'm using a USB adapter from thinkpenguin
<eivindst>rekado_: Running 'guix gc -R /gnu/store/*guix-daemon' I do find '/gnu/store/...-glibc-2.29' in the output.
<rekado_>eivindst: hmm, I’m running out of ideas. Is LANG or any of the LC_* variables set?
<eivindst>rekado_: LANG is 'en_US.utf8' (I checked, and the same locale exists in GUIX_LOCPATH if that should matter) as per host distro config. No LC_* variables are set.
<davidl>Im running guix pull and it starts updating gcc-7.4.0 which is available as a substitute and all kinds of other stuff - any ideas why this is happening? I have specified --substitute-servers="url1 url2" to guix pull but to no avail.
<davidl>guix pull --substitute-urls="https://mirror.guixsd.org https://mirror.hydra.gnu.org https://ci.guix.gnu.org https://ci.guix.info https://berlin.guixsd.org" this starts building very many things, including gcc-7.4.0 which is available on hydra
<Blackbeard>davidl: is this guix system or binary?
<Blackbeard>In top of another distribution?
<davidl>Blackbeard: GuixSD
<Blackbeard>davidl: when was your last guix pull?
<davidl>Blackbeard a while ago lemme check
<davidl>I vaguely remember something about a pgp key update for subs served from ci.guix.gnu.org but couldnt find info yet, could it be that I need new authorization keys?
<nckx>davidl: How do you know that gcc-7.4.0 is available?
<davidl>nckx it's on hydra.gnu.org
<nckx>Time to clean out that big list of obsolete names, all you're doing is overloading berlin. https://ci.guix.gnu.org is the only name in that list that makes sense.
<nckx>The public key (not GPG key) for berlin is #8D156F295D24B0D9A86FA5741A840FF2D24F60F7B6C4134814AD55625971B394#
<nckx>is that in your /etc/guix/acl?
<davidl>Blackbeard: actually just 12 days ago: c1febbbf94ee794d7a97dbde12102634f2b13529
<Blackbeard>davidl: you can also wait a few hours to do a guix pull maybe later you won't build as much
<davidl>nckx: it is not there
<nckx>Aha!
<nckx>It's available as ./etc/substitutes/berlin.guixsd.org.pub in guix.git.
<nckx>sudo guix authorize < that
<nckx>If you don't use any other substitute server than the one above, remove /etc/guix/acl first.
<nckx>Anything it contains will be obsolete.
<nckx>* guix archive --authorize
<davidl>nckx: Ill try that
<nckx>In general: just because *a* GCC 7.4 is available on CI, that doesn't mean the current one is. They may be many old GCC 7.4s on CI that are of no use to you.
<davidl>nckx: yep that key was probably the reason
<nckx>Great.
<davidl>thanks
<nckx>davidl: A pleasure. Don't forget to remove the obsolete aliases to ci.guix.gnu.org from your system configuration. Either they're dead or you're asking the same server for the same thing 5 times.
<nckx>None of them look dead which is probably worse 😛
<pmikkelsen>hello guix! Do you think it would be a good idea to try and port the guix package manager (not the entire system), to one of the BSDs? I am an OpenBSD user who have used GuixSD for a long time a few years ago.
<davidl>nckx: url's cleared out!
<nckx>Ta!
<nckx>pmikkelsen: That can never be a bad idea.
<nckx>pmikkelsen: Does the OpenBSD kernel do any Linux emulation? I've only used FreeBSD.
<pmikkelsen>No it does not
<nckx>Then it's still a great idea but not a quick & easy one.
<pmikkelsen>If someone would like to mentor me I will happily apply for this years GSOC, but I don't know if this is somewhat off topic compared to the suggestions already proposed. :)
<Blackbeard>pmikkelsen: I know that guile works on OpenBSD so that's a start :)
<Blackbeard>Hahaha not that I can help much with that
<pmikkelsen>It sure does, but the latest version is not yet ported :=
<Blackbeard>pmikkelsen: I think you would need to port guile too
<civodul>rekado_: what (guix docker) implements is really the OCI format, right?
<civodul>i wanted to make sure this was an accurate claim
<civodul>and comments actually refer to the OCI spec: https://github.com/opencontainers/image-spec/
<civodul>but also to https://github.com/docker/docker/blob/master/image/spec/v1.2.md
<civodul>vim fails to build on arm: https://ci.guix.gnu.org/log/dnv53k70cr8ryk0qq1i6p62wcygd23id-vim-8.2.0343
<civodul>ideas on how to fix it? skip tests? :-)
<civodul>efraim maybe?
<Formbi>hello
<Formbi>I'm trying to package gccemacs in Guix
<Formbi>someone else made this: https://debbugs.gnu.org/cgi/bugreport.cgi?bug=40045
<Formbi>and I made this: https://termbin.com/o3n5
<Formbi>and an error the same as this one pops up: https://gcc.gnu.org/bugzilla/show_bug.cgi?id=87808
<Formbi>do you guys have an idea how to make it work?
<nckx>lfam: OK, so which patch should I test, exactly?
*lfam looks
<Formbi>edit: this is the thing I made: https://termbin.com/5x2o
<lfam>nckx: https://debbugs.gnu.org/cgi/bugreport.cgi?bug=40044#8
<nckx>‘Why is—’ oh, webkitgtk.
<lfam>You can turn off the furnace for a while
<civodul>heheh
<nckx>lfam: My magic mouse persists in its magical mousey ways 👍
<nckx>I iz the furnace.
<nckx>I haz the coroner.
<nckx>Whee.
<leoprikler>I just found out something interesting about channels.
<drakonis>do tell
<leoprikler>Let's say, I'm trying to mimic Guix' layout.
<leoprikler>That is, I want to have etc/news.scm, fancy-name/packages/foo.scm, etc.
<leoprikler>Now if I try to do that, Guix chokes on news.scm
<drakonis>so, i take that some pieces aren't treated equally?
<leoprikler>Alternatively, one could copy Guix' build-aux/build-self.scm
<leoprikler>But in that case, one doesn't have name available..
<leoprikler>Thirdly, one could set fancy-name as subdirectory
<leoprikler>but then the names no longer line up
<civodul>leoprikler: you can set some parameters in .guix-channel
<civodul>for example, the name of your news file, the directory of your modules, etc.
<leoprikler>If i set the module directory to fancy-name, then the output tree will have guile/$VERSION/packages without fancy-name.
<leoprikler>I would have to create an additional directory on top