IRC channel logs

2020-03-09.log

back to list of logs

<Blackbeard>sirgazil: hey :)
<sirgazil>Hey
<Blackbeard>sirgazil: did you solve the file problem
<sirgazil>No
<sirgazil>But someone on the mailing list seems to have a patch for Thunar.
<Blackbeard>sirgazil: ah good :)
<sirgazil>Blackbeard: https://lists.gnu.org/archive/html/guix-devel/2020-03/msg00131.html
<mroh>I send a patch to 25201@debbugs.gnu.org is that enough or do I need to do more to get that fixed?
<NieDzejkob>mroh: When adding a new file, add it to gnu/local.mk too. Also, I don't think the patch file name should contain the bug number.
<mroh>ok
<Blackbeard>sirgazil: ah nice
<sirgazil>I can run the test suite of a python thing with "python -m pytest" in the source, but invoking the same thing in the Guix package definition results in build error (https://paste.gnome.org/pxjyxnayf).
*sirgazil is frustrated (time to take a break)
<nly>does anyone use guitarix? the tuner seems to be not worknig
<guix-vits>Hi Guix.
<nckx>o/
<Blackbeard>:)
<Blackbeard>is it expected for a game to build on armhf?
<Blackbeard>mine failed :/
<Blackbeard>trying with i686 now
<guix-vits>sirgazil: ? https://github.com/microsoft/vscode-python/issues/6548#issuecomment-537709176-permalink
<sirgazil>guix-vits: Thanks for the link.
<guix-vits>in Foreword of sicp package: "(at most {1 {1\over2}} feet)." is displayed. Is this a bug (seen both in M-x info and info)?
<NieDzejkob>Blackbeard: does the error look expected? You can label the package as x86-only like xf86-video-intel
<Blackbeard>NieDzejkob: it succeeded with I686, x86_64 and aarch64 :)
<Gooberpatrol66>jackhill: it appears guix-devel requires a membership to post. how can I gain access so I can ask for help with the package I wrote?
<NieDzejkob>Gooberpatrol66: it doesn't require membership, it's just that the first post needs manual approval
<Gooberpatrol66>ah ok
<NieDzejkob>you can subscribe here if you want, though: https://lists.gnu.org/mailman/listinfo/guix-devel
<guix-vits>NieDzejkob: a typo is in Manual#Contributing : http instead of https for contributor-covenant.org
<NieDzejkob>guix-vits: Thanks! Do you want me to add a Reported-By line in the commit?
<guix-vits>NieDzejkob: if this is an easy procedure!
<Sleep_Walker>I'm having problem with running `guix pull` from clean 1.0.1 installation - is it known problem?
<Sleep_Walker>build of /gnu/store/yc1dgyl6cx0h4irf4x9c99y39333akm9-guix-package-cache.drv failed
<Sleep_Walker>and log with contains just
<Sleep_Walker>(repl-version 0 0)
<Sleep_Walker>Generating package cache for '/gnu/store/qcfldax4bq5cc3ypx8cby9p2zzhya9v2-profile'...
<Sleep_Walker>(exception unbound-variable (value #f) (value "Unbound variable: ~S") (value (nss)) (value #f))
<guix-vits>Sleep_Walker: is this a "Graphical" or "Manual" installation?
<Sleep_Walker>guix-vits: it's guix package on openSUSE
<Sleep_Walker>not GuixSD
*guix-vits with Russian accent "ahh foreigner :)"
<civodul>Hello Guix!
<Blackbeard>hello :)
<guix-vits>civodul: Sleep_Walker can't pull on fresh install on-top of openSUSE, above; is this a known issue?
<civodul>dunno, is there a bug report?
<Blackbeard>I am trying to package the game blobwars
<Blackbeard>this is my definition
<Blackbeard> https://paste.debian.net/1134096/
<Sleep_Walker>civodul: I was just checking if there is some known problem - it fails on `build of /gnu/store/yc1dgyl6cx0h4irf4x9c99y39333akm9-guix-package-cache.drv failed` with pretty short log http://ix.io/2dNo
<Blackbeard>the readme says to only use 'make' and 'make install'
<Blackbeard>but I am having this error
*Blackbeard sent a long message: < https://matrix.org/_matrix/media/r0/download/matrix.org/dbDBDiJvQONJYLvmQgRpRhMp >
<NieDzejkob>Blackbeard: is that all output? I'd rather you posted too much than too little
<Blackbeard>ok one moment
<Blackbeard> https://paste.debian.net/1134097/
<guix-vits>Blackbeard: https://git.archlinux.org/svntogit/community.git/tree/trunk/PKGBUILD?h=packages/blobwars
<guix-vits>Archmen tribe use s|-Werror||
<guix-vits>in your first post: "all warnings treated as errors"
<NieDzejkob>You can replicate that with (add-after 'unpack 'werror-begone (lambda _ (substitute* "Makefile" (("-Werror") ""))))
<Blackbeard>guix-vits: oh what is werror
<civodul>Sleep_Walker: if you have channels apart from the official one, the error could come from there
<Blackbeard>ok thanks :)
<Sleep_Walker>civodul: thanks! I believed I wipe whole installation before reproducing but I indeed forgot this one
<guix-vits>Blackbeard: if compiler notices something "unusual" but not "wrong" within the code, it can emit an "warning". Good programming practice is "treat all warnings as errors"; so this flag is exist.
<Blackbeard>guix-vits: ah I see :)
<Sleep_Walker>and I got pulled
<Blackbeard>ok now I have another problem that I think arch is solving too
<Blackbeard>mkdir -p /usr/games/
<Blackbeard>mkdir: cannot create directory ‘/usr’: Permission denied
<Blackbeard>i think arch is solving it like this
<Blackbeard>make DESTDIR="${pkgdir}" BINDIR="/usr/bin/" install
<NieDzejkob>you can't install to /usr, you need to install to the output
<Blackbeard>but what is the proper directory
<NieDzejkob>in your case, you want no DESTDIR and BINDIR of (string-append (assoc-ref outputs "out") "/bin")
<Blackbeard>ahh with (assoc-ref %outputs "out"
<Blackbeard>right?
<NieDzejkob>yeah, though it's usually preferred to get outputs as a real argument with (lambda* #:key outputs ...)
<Blackbeard>like this
<Blackbeard> (add-before 'install 'make-install-dirs
<Blackbeard> (lambda* (#:key outputs #:allow-other-keys)
<guix-vits>ps: even Debianians strip off the "Werror" there: https://sources.debian.org/src/blobwars/2.00-1/debian/patches/make-release/
<guix-vits>NieDzejkob: above my flood ^, please...
<Blackbeard>ok I think I failed :)
<Blackbeard>but it is 3:20 am so I'll keep trying tomorrow
<guix-vits>Blackbeard: https://src.fedoraproject.org/rpms/blobwars/blob/master/f/blobwars.spec
<NieDzejkob>Blackbeard: before you go, could you post the new package definition and error?
<guix-vits>there is sed's "fix-pak", whatsnot it is...
<Blackbeard>NieDzejkob: oh I was ssh-ing into my desktop and I already turned it off :(
<guix-vits>Blackbeard: cu tommorow, then.
<Blackbeard>Good night everyone :)
<janneke>hello Guix!
<civodul>hey janneke!
<janneke>hello civodul :)
<jonsger>guix-vits: what is the excact problem on openSUSE?
<guix-vits>Sleep_Walker: ^ (jonsger: idk, some pull error.)
<Sleep_Walker>jonsger: just mine PEBKAC
<jonsger>PEBKAC?
<guix-vits>jonsger: https://en.wiktionary.org/wiki/PEBKAC
<jonsger>ah :)
<Sleep_Walker>I thought I wiped whole guix installation and left channels file in - and it was my source of trouble
<Sleep_Walker>so good news is there is no issue
<janneke>haha, my efforts to create a smaller qemu footprint are somewhat feeble, qemu has not been ported to the Hurd
<civodul>oh
<civodul>you should talk to youpi about that, youpi commits to both
<janneke>ah, good -- i tried to build everything natively, to avoid solving cross build problems :-|
<janneke>hmm, what's with this `-pc' in i586-pc-gnu that is sometimes mandatory (for cross-mig, apparently)
<PurpleSym>How can I resolve package conflicts? guix is telling me to upgrade the conflicting packages at the same time, but that’s what I’m doing (via a manifest).
<guix-vits>PurpleSym: Can you share which packages is in conflict?
<DamienCassou>hi everyone
<DamienCassou>is there a way to generate a value for the PATH variable from a list of dependencies? I would like to use `wrap-script` to setup the PATH of a bash script. I could use the PATH that is current while the package builds, but this contains more things than necessary (e.g., GCC)
<civodul>dftxbs3e: i got a bounce from your email address ("spam detected" :-/)
<PurpleSym>guix-vits: Here’s the output: http://paste.debian.net/1134101/ jupyter-zpid is from a channel I maintain.
<NieDzejkob>DamienCassou: Yeah, you could do something like (wrap-program the-program `("PATH" ":" prefix ,(map (lambda (dep) (assoc-ref inputs dep)) '("foo" "bar" "baz"))))
<guix-vits>PurpleSym: IDK, but entries for python-mistune has different hashes.
<DamienCassou>awesome, thank you NieDzejkob
<PurpleSym>guix-vits: Yep, the question is: Why?
<PurpleSym>The only difference is in mistune.cpython-37.pyc and it’s literally the hash of its own /gnu/store directory that’s different.
<NieDzejkob>I'm trying to set up offloading onto my Debian machine, but ssh with a command directly on the commandline doesn't run a login shell, which means it doesn't read /etc/profile.d/guix.sh which sets the relevant env vars. As a perhaps related problem, I get a protocol error from guix offload test: https://paste.debian.net/1134102/
<NieDzejkob>is there a way to update /usr/local/bin/guix on a foreign distro? the equivalent on Guix System would get updated on a reconfigure
<civodul>NieDzejkob: you would run "guix pull" as root
<civodul>since /usr/local/bin/guix points to root's profile
<guix-vits>PurpleSym: did you customized anything in python-mistune, or mistune.cpython-37.pyc is packaged inside of jupiter-zpid?
<NieDzejkob>civodul: oh, I thought I was running some old version because the commit ID is different, but it's just that someone pushed a commit between my pull as user and as root
<NieDzejkob>PurpleSym: Maybe there's a python-mistune in both Guix and your channel?
<raingloom>if i need multiple source files for a package, i just use a list of origin objects, right?
<civodul>raingloom: 'source' cannot be a list, but you can add extra origins as inputs
<raingloom>civodul: thanks!
<civodul> https://usesthis.com/interviews/katherine.cox-buday/
<jboy>oh cool, that isn't even the first mention of Guix in usesthis interviews: https://duckduckgo.com/?q=guix&sites=usesthis.com&ia=web
*rekado_ started packaging ROOT
*rekado_ waits for that custom LLVM build that’s part of the ROOT build…
<PurpleSym>guix-vits: No. NieDzejkob: No, it’s pulled in from the main channel.
<guix-vits>NieDzejkob: is hash of propagated input dependends on "caller"?
<guix-vits>python-zpid's (channel) need python-ipython https://git.savannah.gnu.org/cgit/guix.git/tree/gnu/packages/python-xyz.scm#n5628
<guix-vits>python-jupyterlab (guix) need python-nbconvert https://git.savannah.gnu.org/cgit/guix.git/tree/gnu/packages/python-xyz.scm#n7929
<guix-vits>both use (propagated-inputs with python-mistune
<PurpleSym>That shouldn’t be a problem, both *could* use the same version of python-mistune.
<PurpleSym>(I mean: the same build)
<guix-vits>could, but somehow they don't; if "caller" can change output of propagated-inputs? idk.
<NieDzejkob>PurpleSym: Could you try `guix environment --ad-hoc python-jupyterlab@1.2.6 jupyter-zpid@1.0.0`?
<guix-vits>btw, both packages are new: i'd recently pulled, and guix search returns '' for both...
<guix-vits>or something like that.
<NieDzejkob>PurpleSym: it would also help if we could see your channel
<PurpleSym>The channel is here: https://github.com/leibniz-psychology/guix-zpid
<PurpleSym>NieDzejkob: Strange, `guix environment` works.
<PurpleSym>And `guix environment --ad-hoc -m <manifest>` works too.
<civodul>hello PurpleSym! good to see you here :-)
<PurpleSym>Hey Ludo :)
<rndd>hi everyone! could anybody help? i wanna try i3wm on my laptop. so, i dont know how to change my config.scm to install and apply i3... where i can found information about possible functions and arguments fo config.scm?
<NieDzejkob>rndd: info "(guix)System Configuration"
<rndd>NieDzejkob: thank you! found DE declaration examples in manual but there is nothing about window managers =|
<guix-vits>btw: if one running `reconfigure` as not-root, is "Permission denied" error is OK?
<NieDzejkob>rndd: you only need a login manager or whatever it's called, like gdm or slim, and the window manager, either listed as a package or installed into your user's profile
<NieDzejkob>guix-vits: Permission denied is the expected result of running reconfigure as non-root.
<NieDzejkob>it won't break anything, but it also won't have the effect it would if you reconfigured as root
<guix-vits>NieDzejkob: thanks.
<rndd>NieDzejkob: thanks
<civodul>mbakke: so, given <https://issues.guix.gnu.org/issue/39988>, we can go for 2.2.7 in core-updates if you want
<civodul>i'm working on that bug but i don't know how long it'll take
<civodul>on the financial cost of CI: https://lwn.net/SubscriberLink/813767/d73c19618965b95a/
<jonsger>using some dedicated machines at Hetzner should be much cheaper for them...
<civodul>heh
<civodul>also Guix/Nix would allow them to share build resources efficiently
<civodul>as opposed to having lots of mostly idle machines
<civodul>janneke: re Hurd, oh!
<civodul>you know what, i started going through my guix-devel backlog yesterday and didn't manage to get very far
<civodul>turrible!
<anadon>civodul: Before I leave for a bit, last Thursday and Friday I ran into failures for `guix pack --format=squashfs ...` on CentOS7 related to "guix/scripts/pack.scm". Adding the "--no-recovery" option helped one kind of failure from replicating on the command line, but the guix command still fails.
*anadon smoke bombs
<civodul>anyone knows if there's a bug report for what anadon writes about?
<civodul>nckx maybe?
<dftxbs3e>civodul, hey, what do you mean? I don't spam
<civodul>dftxbs3e: free.fr bounced my message saying "spam detected"
<dftxbs3e>civodul, oh... well I can't do anything about that :-/ - free.fr is my isp
<civodul>"to bounce" is intransitive in the real world, but you see what i mean
<civodul>yeah i know
<dftxbs3e>civodul, email the postmaster?
<civodul>there's been abuse related to GNU, so perhaps that's the aftermath
<civodul>well, i'm busy :-)
<dftxbs3e>civodul, sure :-) - well in the mean time, email me with lle-bout at zaclys.net
<dftxbs3e>civodul, oh.. I think I misunderstood. Is it related to: "You have been unsubscribed from the Guix-commits mailing list"?
<dftxbs3e>Maybe an RSS feed would be more appropriate for this mailing list
<civodul>this may be related
<civodul>probably messages from guix-commits@gnu.org kept bouncing, so mailman eventually unsubscribed you
<dftxbs3e>civodul, makes sense. I'll email the postmaster.
<NieDzejkob>civodul: I think there's a thread on -devel
<civodul>ah ok
<anadon>OK, now I'm back.
<NieDzejkob> https://lists.gnu.org/archive/html/guix-devel/2020-03/msg00053.html
<civodul>anadon: i was saying i haven't read the discussion above
<civodul>i'll get to it
<civodul>but! if anyone else beats me at it, that's even better :-)
<anadon>Coolio
<anadon>I had to reboot my system -- kernel updates and time change.
<dftxbs3e>civodul, sent. Hopefully they're not too busy or spammed to even read and handle the situation.
<dftxbs3e>I'm not sure postmaster@free.fr is even read.
<dftxbs3e>With millions of customers.. and dozens of millions of email addresses over the years, it's got to be hard.
<civodul>yup
<dftxbs3e>civodul, maybe considering that not many people know how email actually works and what postmaster even is, they wouldnt receive that many emails.
<rekado_>hmm, the tensorflow team removed what little cmake support there was.
<rekado_>it can only be built with bazel now.
<rekado_>which means it cannot be built with Guix
*rekado_ shakes head
<anadon>What would be involved in adding the bazel build system?
<guix-vits>anadon: Bazel written in Java; Finding some Java-hackers may be involving, probably.
<anadon>Gross. Why is it that as time wears on I more and more dislike Java?
<anadon>I suppose the first step would be to package bazel.
<janneke>anadon: maybe because you didn't dislike it enough initially ;)
<guix-vits>"I read a book about Java, and found it an elegant further development from C. But I have never used it." -- Guess Who?
<NieDzejkob>Ken Thomson?
<mroh>dennis ritchie?
<guix-vits>no...
<guix-vits> https://stallman.org/stallman-computing.html :P
<guix-vits>Btw, even through i was warned that Java and JS is differ, but make such menues in HTML seems to be a lot of work: https://alpinelinux.org/
<nckx>Good morning, Guix o/
<dongcarl>Morning!
<anadon>Good morning
<nckx>civodul: Nope. anadon: Any progress debugging the singularity?
<anadon>Alas, none. I'm more working on Guile fluency before I dig in and make a mess. Also going through my calc textbook, next draft on a paper, and actual work.
<rekado_>Packaging Bazel is a serious multi-month project.
<rekado_>40+ Java non-trivial packages.
<rekado_>many Java packages cannot be built directly from source as they depend on some pre-built jars.
<rekado_>and then actually using Bazel: how could we make it *not* download very specific versions from the internet?
<rekado_>we would not be able to reuse any of the packages provided by Guix.
<rekado_>it’s a mess
<guix-vits>:trollface: but Java's platform-independency!
<rekado_>Java is fine
<rekado_>the Java culture is the much bigger problem.
<guix-vits>TensorFlow and Bazel are both from Google; logical, btw. Anyway in meantime, i'm suppose one can create /usr/local ..?
<rekado_>we *do* have a tensorflow package
<rekado_>it’s just that newer versions are going to be difficult to provide via Guix.
<rekado_>and no, installing this manually is rarely an option
<guix-vits> https://docs.bazel.build/install.html:
<guix-vits>window.location.replace("/versions/master/./install.html" + window.location.hash);
<guix-vits>"Trust us!" :)
<guix-vits>cu
<anadon>Still better than Gradle, I suppose.
<anadon>Should someone open a ticket with bazel about building offline and in a way compatible with guix?
<Blackbeard>Hello guix :)
<rekado_>anadon: I already asked them if there’s a lighter variant of Bazel that doesn’t depend on 40+ jars. They said no.
<rekado_>they did not seem to follow my claim that it’s very difficult to build from source when nobody builds jars from source.
<rekado_>so… maybe someone could discuss this with them, but I prefer not to do this myself.
<bavier>I'm so happy we have a 'nyancat' package now
<anadon>Did you point them to https://reproducible-builds.org/ ? If they're not in compliance, they're going to get left behind.
<anadon>rekado_: ^
<civodul>anadon: some of the developers were present in past R-B summits
<civodul>so they are somewhat receptive, but maybe not enough
<anadon>Reading over the FAQ, I don't think they actually understand the concept.
<anadon>The whole "prove it" part of reproduciblilty seems missing.
<civodul>well Bazel itself is a good tool for reproducible builds
<civodul>it's not very different from Nix/Guix AIUI
<civodul>but when you use a pre-built binaries, there's no build to reproduce, so you're fine :-)
<anadon>>_>
<NieDzejkob>I'm still having problems with offloading onto my Debian machine
<NieDzejkob>I made my bashrc load /etc/profile.d/guix.sh and now "ssh z guix repl" doesn't complain about locales
<NieDzejkob>I also made sure I'm using the most recent guix daemon on both machines
<NieDzejkob>and I'm still getting the error: guix offload: error: failed to connect to `#<input-output: channel (open) 7f6509c11940>': Protocol error
<NieDzejkob>I found this thread on help-guix, nothing there: https://lists.gnu.org/archive/html/help-guix/2019-01/msg00282.html
<NieDzejkob>it's weird, the #<input-output: channel> is supposedly the result of (build-machine-name machine)
<rndd>hi everyone! does anybody here use dwm with guix?
<NieDzejkob>rndd: I use ratpoison, does that count?
<anadon>NieDzejkob: I'd suggest something if I knew. Sorry :/
<NieDzejkob>After some print-debugging, I determined that the problem is in remote-daemon-channel's call to open-remote-pipe*
<rndd>NieDzejkob: maybe. so my question is about modifying config.h (that is the basic way to configure dwm - the idea is about recompiling whole dwm when you want to change, for example, frame fize). So, i need to put my config.h inside project source and recompile how i can to do it with guix ?
<NieDzejkob>rndd: do you use a manifest for your profile?
<NieDzejkob>(both answers are ok)
<rndd>NieDzejkob: nope
<NieDzejkob>wait, does dwm go into the system config or user's profile
<rndd>NieDzejkob: no, just made this package as system in config.scm
<NieDzejkob>rndd: you could define a custom package in your config.scm like this: https://paste.debian.net/1134163/
<NieDzejkob>(untested :P)
<NieDzejkob>if that works I might submit a patch to provide a function for this
<rndd>NieDzejkob: that's cool, but how i can write in scheme -> download my git repo with dot files and copy config.h from here? =/
<rekado_>rndd: you probably wouldn’t do this in a system configuration. But if you absolutely want to do that you could use guile-git, or spawn any process (such as ‘git clone’) with ‘(system* …)’
<NieDzejkob>rndd: better solution: put the config file in your git repo
<rndd>ok, thanks for suggestions
<NieDzejkob>(BTW, the config doesn't have to be in /etc)
<Blackbeard>Packaging is hard :(
<Blackbeard>Or complex
<rekado_>Blackbeard: it is!
<jackhill>Blackbeard: I suppose if it were easy we wouldn't need to collaborate on a project to wrangle it all :)
<jackhill>what are you working on currently?
<rekado_>if only there was a set of tools to automate most of the common steps. We could perhaps call this ‘autotools’.
<rekado_>the most annoying packaging tasks I encountered were always those that didn’t stick to conventions or tried to reinvent them.
<jackhill>I've had the same experience
<Blackbeard>The game blobwars
<Blackbeard>It is the third game
<Blackbeard>I package
<Blackbeard>I tested widelands in different architectures
<Blackbeard>Took me mostly all of yesterday to do it
<Blackbeard>Today I am testing barrage
<Blackbeard>I wanted to send package definitions on the weekend
<Blackbeard>But it is not just writing it and compiling it
<Blackbeard>I didn't know that :(
<Blackbeard>But I think having more games will be a nice addition
<Blackbeard>I can't think of much 'work' stuff to package. Everything I need is already there
<NieDzejkob>there's always https://libreplanet.org/wiki/Group:Guix/Wishlist
<Blackbeard>NieDzejkob: oh nice
<Blackbeard>Here I am packaging games when people already have needs hahah
<bavier>Blackbeard: to be fair, many of the entries on the wishlist are for things that are difficult to package at the moment
<mbakke>nckx: the libinput update causes 700+ rebuilds (see libinput-minimal)
<nckx>Hmph.
<nckx>Is there any way to track these things yet?
<nckx>I have a file with ‘things that guix refresh -l lies about’. It's on another machine.
<nckx>Ideas welcome.
<nckx>mbakke: Re: your thing, I thought of that exact thing when I saw the original thing this morning. No, I thought to myself, you're being silly and paranoid.
<mbakke>heheh :)
<NieDzejkob>is there a way to get all packages that inherit from a specific package?
<nckx>Not AFAIK. That's the problem.
<NieDzejkob>we could add a special field to guix records
<NieDzejkob>like the location one
<cbaines>has anyone seen something like this? http://paste.debian.net/plainh/2dd52209
<NieDzejkob>Is Guix System required for offloading?
<cbaines>building /gnu/store/jis9853b5djlf6fxgfqhyd5vffwplmla-module-import.drv...
<cbaines>while setting up the build environment: executing `/gnu/store/50f18mlbj915vydqmm6nyvkh2b23vmf0-guile-2.2.6/bin/guile': No such file or directory
<nckx>NieDzejkob: I've suggested that (and have an ancient implementation rusting around somewhere). But it's not a pretty concept and Ludo' wasn't wild about it.
<nckx>NieDzejkob: Not by design.
<NieDzejkob>But by accident? :P
<nckx>NieDzejkob: As in, I won't say ‘it works!’ because I don't know, but it ‘should’ 😉
<mbakke>I wonder if Guix is smart enough to track the rebuilds per origin.
<mbakke>Unfortunately this does not work: guix refresh -l -e '((@ (guix packages) package-source) (@ (gnu packages freedesktop) libinput))'
<nckx>Hm. Interesting approach.
<NieDzejkob>nckx: well, from my short experience, it doesn't :/
<mbakke>"expression does not evaluate to a package"
<NieDzejkob>you will see my frustrated calls for help if you scroll up a screenful or two
<nckx>NieDzejkob: What happens?
<nckx>Ah.
<nckx>Sorry I was just summoned here by libinput, haven't read any backlog.
<NieDzejkob>yeah, I understand
<Blackbeard>bavier: yes I see that now :/
<NieDzejkob>the TL;DR is that guix offload test fails in assert-node-can-import with guix offload: error: failed to connect to `#<input-output: channel (open) 7f35de0400a0>': Protocol error
<mbakke>NieDzejkob: what does 'guix offload test' say? Can you ssh to the target machine using the credentials from /etc/guix/machines.scm ?
<NieDzejkob>mbakke: https://paste.debian.net/1134185/
<mbakke>NieDzejkob: is guile-ssh installed for the offloading user, and GUILE_LOAD_PATH set up?
<NieDzejkob>at the slave?
<mbakke>NieDzejkob: indeed... I looked at my offloading setup, and the 'guix-offload' user has only three things in ~/.guix-profile: guile, guix (!), and glibc-locales.
<mbakke>NieDzejkob: it also sources ~/.guix-profile/etc/profile from .bashrc
<NieDzejkob>hmm, I'll try installing gui... oh of course that's it
<mbakke>:-)
<NieDzejkob>the source code I was reading was invoking guile -c to open the connection
<NieDzejkob>soooooo
<NieDzejkob>it's a different error now :P
<mbakke>progress!
<NieDzejkob>guix offload: error: unknown error while sending files over SSH
<NieDzejkob>how do I make it print the whole exception and not only the message
<NieDzejkob>I ran it in the REPL, the exception doesn't help
<NieDzejkob>oh wtf adding guix to the profile made it work
<NieDzejkob>even though `ssh z guix repl` was working before
<mbakke>Huh, I thought you did that already?
<NieDzejkob>I thought "huh, there's already a guix in the ~/.config/guix/current profile, I don't need that, I'll try with just guile for now"
<NieDzejkob>so, idk why, but adding guix to the profile made guix offload test say "guix offload: '192.168.1.50' is running GNU Guile 3.0.0"
<NieDzejkob>no, wrong copy paste
<NieDzejkob>before guix in profile: using guile 3.0.0; after: using guile 2.2.6
<NieDzejkob>if my master node goes to sleep during a long offloaded build, will that be a problem?
<NieDzejkob>or can I suspend it and rest assured that icecat or whatever is compiling on the build slave?
<mbakke>NieDzejkob: I believe the builds will get killed after some timeout.
<NieDzejkob>hmm, okay. What about --keep-failed? I remember reading that it will automatically imply --no-offload
<NieDzejkob>Is there a way to make it keep the build directory at least on the slave?
<Blackbeard>How can terminus or any other font can be added to the installer
<Blackbeard>When I installed Guix I had trouble with the fonts being a small
<Blackbeard>Not the installer per se, sorry the USB because I used the console
<mbakke>NieDzejkob: there is no way to pass the --keep-failed flag to the remote (in fact --keep-failed implies --no-offload)
<mbakke>I occasionally ssh to the remote and 'guix build -K /gnu/store/...-foo.drv' if I don't want to build and investigate locally
<NieDzejkob>okay, I guess I'll just start the most painful builds through ssh
<NieDzejkob>speaking of which, rust@1.40 is doing some shenanigans that makes ld-wrapper generate an incomplete rpath
<mbakke>NieDzejkob: incomplete how?
<NieDzejkob>/gnu/store/g7w8qzw94cd5snmhwx9ankpx3axy0m4d-rust-1.40.0/lib/rustlib/x86_64-unknown-linux-gnu/codegen-backends/librustc_codegen_llvm-llvm.so: error: depends on 'librustc_driver-1040000d6b8afc7f.so', which cannot be found in RUNPATH ("/gnu/store/g7w8qzw94cd5snmhwx9ankpx3axy0m4d-rust-1.40.0/lib/rustlib/x86_64-unknown-linux-gnu/codegen-backends/../lib" "/gnu/store/nsrym6zn3yb4390fazx1gq8rg0m8dhkd-llvm-8.0.0/lib" "/gnu/store/2plcy91lypnbbysb18ymnhaw3zwk8pg1-
<NieDzejkob>gcc-7.4.0-lib/lib/gcc/x86_64-unknown-linux-gnu/7.4.0/../../.." "/gnu/store/ahqgl4h89xqj695lgqvsaf6zh2nhy4pj-glibc-2.29/lib")
<NieDzejkob>the offending .so is in /gnu/store/g7w8qzw94cd5snmhwx9ankpx3axy0m4d-rust-1.40.0/lib
<NieDzejkob>here's my WIP patch, I want to run it with the GUIX_LD_WRAPPER_DEBUG overnight: https://paste.debian.net/1134191/
<mbakke>NieDzejkob: weird! If the build system respects LDFLAGS, perhaps you can try adding that directory through 'LDFLAGS=-Wl,-rpath=...rust-1.40.0/lib' ?
<nckx>Blackbeard: I've already added it, but you need to build your own installer (it's not in 1.0.1) and add fbcon=font:TER16x32 to the kernel command line.
<NieDzejkob>nckx: Thanks! I'll keep your suggestion in mind
<nckx>However, if you use a USB console, it's the ‘host’ machine that sets the font so I don't understand that line and have chosen to ignore it.
<Blackbeard>nckx: ahh I see
<Blackbeard>Well the good thing it is already added
<nckx>Sigh.
<nckx>Blackbeard: It is, but it turns out that it won't affect the installer because the installer knows best and hard-codes a console-font service and font (2 different ones, even: LatGrkCyr-8x16 on TTY2 and lat9u-16 on the others).
<Blackbeard>But can I do 'setfont' afterwards?
<mbakke>I never remember how to cancel a Cuirass evaluation, I should write it down somewhere.
<rekado_>mbakke: better even: let’s add it to the admin interface
<Blackbeard>I can understand the hard coded when starting, I guess it is hard to use a good font for every display out there
<nckx>‘setfont -v latarcyrheb-sun32’ works.
<nckx>Terminus is only available as 16, but this was about size, not prettiness, right?
<nckx>Blackbeard: Anyway, setfont -h will print the font directory as its last line. You can list consolefonts/ yourself to see the available fonts. Some 22px options there if 32 is overkill.
<mbakke>rekado_: that's the best kind of writing it down
<mbakke>nckx: re libinput in particular, making the inheritance more visible could be a UI improvement. E.g. with a comment, or changing the inheritance order.
<Blackbeard>nckx: thanks :)
<Blackbeard>That's really helpful
<raingloom>is there a way to pretty-print a derivation? it's rather hard to debug them when everything is on a single line.
<nixo_>Hi guix, how do I get the path of a plain-file in the system configuration?
<sneek>nixo_, you have 1 message.
<sneek>nixo_, NieDzejkob says: FYI, you forgot to --signoff on the nheko patchstack you pushed. I tried to find an option to signoff by default, but failed miserably, so, uh... be more careful next time ;)