IRC channel logs

2020-01-12.log

back to list of logs

<civodul>language-specific package managers are typically written so that people can enjoy the language regardless of the system they're on (OS, distro, etc.)
<civodul>NieDzejkob: perhaps it's a case where a patch would be easier?
<kmicu>jojoz[m]: let’s imagine Idris chose Guix as language package manager: now we need to learn not only Idris but Guile/Guix too. For example to bootstrap ecosystem wow we not only have Idris dependencies but also Guix dependencies.
<apteryx>hello Guix! Do profiles keep track of which Guix commit (and channels)? they originate from?
<NieDzejkob>civodul: hmm, I'd have to first patch it to something like @XSET@ and then substitute in the real path, but that's a good idea
<raghav-gururajan>apteryx Yep, `guix describe` will do that.
<apteryx>raghav-gururajan: I'm looking for a profile->guix-channel (or at least commit) function
<apteryx>the profile might not have guix available
<raghav-gururajan>Ah I see.
<jojoz[m]>civodul: I mean, you can run Guix on other distros than Guix System. I'm not sure there's a problem
<jojoz[m]>kmicu: But how is that different than having to learn Stack & Stackage for Haskell, and having to learn Cargo & Crates.io for Rust? I'm not sure what you mean about the bootstrap ecosystem. Would users really have to know about that?
<raghav-gururajan>guix not a lang? it uses guile which is a lang.
<kmicu>jojoz[m]: I am not talking about users only. Someone needs to maintain the language and pulling in another language is more work.
<apteryx>guix pack has a --save-provenance option. I wonder if we shouldn't do this by default for every profile generated?
<apteryx>(if it's already done, please enlight me!)
<jojoz[m]>kmicu: Hmm maybe, but would it really be more work than writing a package manager from scratch? Seems like that would be a lot more work for little to no benefit, at least for quite some time until the package manager has matured and become less buggy etc.
<apteryx>ah, commit d40ec4a0d00df08ec4f866467080235f5a9fea87 details the reason why it's off by default, but I need to think more about it to be convinced about it.
<civodul>apteryx: "guix package" saves provenance by default :-)
<civodul>"guix system reconfigure" too
<apteryx>so not every profile are created the same? guix environment ... wouldn't, for example, record such information?
<kmicu>jojoz[m]: When we create a new proglanguge we want to use it and not switch to another ‘less cool’ language to maintain our cool language. I’m not stating that using general purpose pm is not acceptable solution but only that it brings some unpleasant trade‑offs.
<apteryx>I'm pushing a hack to its limit, and need to query the host environment (typically a guix environment) and retreive a Guix channel from it.
***calher is now known as KE0VVT
<jojoz[m]>kmicu: Hmm, I guess that's something to consider
<apteryx>the hack in question currently reads as: https://paste.debian.net/1125647/, and aims to make system testing even faster than what the current, clean implementation allows.
<apteryx>I need to have my guix/prebuilt package inherit from the guix channel that was used to create the environment in which the developper issued "make" :-), so that all the rpaths references for the daemon are intact.
<apteryx>*inherit from guix from the guix channel ...
<NieDzejkob>how do I list transitive propagated inputs of a package?
<apteryx>NieDzejkob: not just propagated, but transitive inputs of a package can be shown using 'guix refresh --list-transitive'
<NieDzejkob>thanks, but I'm specifically after propagated, since that what gets put in the profile
<leoprikler>Well, you *could* walk the propagated-inputs on your own, but who would want to write code for that?
<apteryx>should be fun ;-)
<leoprikler>mhhh tree algorithms
<leoprikler>lets put up some fun challenges like "find the longest propagation chain for package X"
<leoprikler>(i.e. a chain that ends with X as propagated-input)
<apteryx>hehe
<leoprikler>If you like regexps blowing up in your face: `guix environment --ad-hoc gnome -- sh -c 'cat $GUIX_ENVIRONMENT/manifest' | sed -n -e "s/.*(\"/\"/p" | grep -v '[/)]' | sed -e "s/\"//g" | grep "^[a-z]" | sort | uniq`
<leoprikler>(replace gnome with whichever package)
<NieDzejkob>leoprikler: thanks!
<NieDzejkob>it's a wonderful ugly hack :D
<leoprikler>If all you have is regular expressions…
***wxie1 is now known as wxie
<NieDzejkob>I can disable suspend-on-lid-close by setting (ignore-lid? #t) in my upower-configuration, but is there a more temporary solution?
<leoprikler>GNOME settings perhaps?
<NieDzejkob>oh, I'm not using GNOME, just slim+ratpoison
<NieDzejkob>also, even that doesn't seem to work (after reconfigure + herd restart upower-daemon)
<NieDzejkob>maybe it's not upower that's doing this, how can I tell what process is initiating a sleep state?
<NieDzejkob>eh, I guess I'll just keep the lid open
<leoprikler>does slim have its own power settings?
<apteryx>NieDzejkob: you can probably just echo some value to some system fs somewhere -> /sys/, but need to research
<wdkrnls>NieDzejkob: I made this note to myself a few months ago: "elogind-inhibit --what=handle-lid-switch --mode=block -- sleep 30d"
<wdkrnls>(maybe doesn't work for what you want :/)
<wdkrnls>It did inhibit suspend on lid closing for me back then.
<nckx>Morning, #guix.
<raghav-gururajan>nckx o/
<raghavgururajan>test
<nckx>pong
<raghavgururajan>Folks! During boot, I always see this error: "ntpd[635]: kernel reports TIME_ERROR: 0x41: Clock Unsynchronized". What should I do?
<nckx>raghavgururajan: Nothing. It's just an informational message from ntpd that ‘happens’ to contain the uppercase string ERROR :-/ Unfortunate design choice, no question. https://paste.debian.net/plain/1125661
<raghavgururajan>nckx Phew! thanks.
<nckx>sneek: later tell DootNoot You can include any custom Xorg configuration (in xorg.conf syntax) using the extra-config field of the xorg-configuration record. Which is often used as the value for the xorg-configuration *field* of your display manager, so you get something like https://paste.debian.net/plain/1125662
<sneek>Got it.
<nckx>sneek: Consume botsnack.
<sneek>:)
<raghavgururajan>nckx How about this error: "No RAPL sysfs present".
<raghavgururajan>* "THD engine start failed".
<nckx>raghavgururajan: Those are both CPU features, right? Maybe something like upower trying and failing to use them?
<nckx>raghavgururajan: My CPU supports it, so I get: intel_rapl_common: Found RAPL domain package
<nckx>Is that the same module name as precedes your error message?
<raghavgururajan>yes, it precedes
<nckx>I also don't have the THD error but it seems to be the ‘thermald engine’. Is that correct?
<nckx>Does it say ‘unsupported CPU model’ by any chance?
<nckx>If so, there's nothing you can do besides disable thermald.
<nckx>(Opinion: too many people use thermald because they think it's important, but it's not unless your laptop was badly designed to begin with or you don't have/want fans to cool your system.)
<raghavgururajan>Yes, it is thermald engine. I use to get additional error message "Unsupported cpu model, use thermal-conf.xm file or run with --ignore-cpuid-check". I enabled that ignore flag in thermald and stopped getting that error message again. But I still continue to get that RAPL.
<raghavgururajan>nckx Mine is X200-T.
<nckx>Well, yeah, because your CPU doesn't have it and you've asked thermald to continue normally 😛
<raghavgururajan>So I assume it is useless to run thermald for my CPU??
<nckx>What thermald feature do you use? Have you confirmed that it actually has an effect?
<raghavgururajan>I thought it prevents over-heating. I haven't faced that situation (yet).
<nckx>Yeah, you don't really want to ‘test’ that situation if you don't have to, I understand. But that makes it hard to give you any factual information. I'm convinced most people run thermald in placebo mode anyway, because they read the description and then think they need it. Your CPU will downclock or shut down if it overheats, thermald is more for situations where you want to override the built-in limits (e.g. to keep the fans spinning up at all on a me
<nckx>dia box and/or don't care about performance and/or you're paranoid).
<nckx>s/spinning/from spinning/
<nckx>s/a me/a home/ why can't I type oh right coffee brb.
<nckx>raghavgururajan: Also note the first sentence here: https://wiki.debian.org/thermald .
<raghav-gururajan>nckx Sorry, I got disconnected.
<nckx>logs.guix.gnu.org my friend.
<raghav-gururajan>Oh yes! Just a sec.
<raghavgururajan>nckx I see. I don't wanna override any built-in limits and I didn't know that CPUs have that downclock mechanism. So cool! I'll remove thermald. :)
<raghavgururajan>Thanks!
<efraim>I have (several) poorly designed laptops that overheat
*raghavgururajan is also having coffee. Cheers nckx!
<efraim>Only sandy bridge and later doesn't help me, I don't think I have anything that new
<nckx>raghavgururajan: If you're worried about overheating I'd install a temperature monitor applet (or hack something manually based on lm-sensors, which is what I did), then keep an eye on that whenever you load your CPU for long periods of time until you're satisfied that your CPU/firmware/laptop design does the right thing. I'd personally trust that much more than a thermald that says your processor is unsupported: what if it detects overheating and is unable to
<nckx>actually tell your CPU to do anything about it? That's worse than bad.
*nckx still feels like half a traitor for going with a (non-Librebooted) X230T instead of X200T but the SL9400 was simply a deal-breaker ☹
<raghavgururajan>nckx You are right, it would be worse.
<nckx>Plus I get this thing called a management engine, which is probably something really cool.
<nckx>Still, fellow-Thinkpad-tablet-owner high-five.
<raghavgururajan>nckx My X200-T has SL9600 (2.13 GHz).
<raghavgururajan>nckx High Five!
<raghavgururajan>IME is non-free and is a backdoor right?
<raghavgururajan>*IME --> Intel Management Engine
<str1ngs>IME is the back door :P
<mroh>IME is a minix (w/o tanenbaum knowing...)
<nckx>raghavgururajan: Interesting, that's not even on my go-to comparison site. Still, even if it's 14% faster than the SL9400, I probably wouldn't be able to live with it… https://www.tobias.gr/sl9400-my7.png
<nckx>raghavgururajan: Yep.
<str1ngs>the irony of most linux kernels being back door-ed by minix
<nckx>True, although kernels were already ‘back-doored’ by SMM on… what, the i486? It's an old tradition.
<nckx>(The backdooring, not Minix.)
<raghavgururajan>nckx I am pretty lucky to get that CPU. X200-T comes with SL9300, SL9400 and SL9600 variants. The last is very rare.
<str1ngs>I'm replacing my x220 with a pinbook pro. I hope I like it ...
<str1ngs>pinebook*
<nckx>str1ngs: Cool. Does Guix System support that?
<str1ngs>I'll find out haha
<raghavgururajan>str1ngs You may like this (https://tehnoetic.com/tet-t400s).
<nckx>raghavgururajan: I wasn't even aware it was an option. ‘Lucky’ as in ‘lucky to find an SL9600 for sale’ or as in ‘didn't even know it was an SL9600 until the unit arrived’?
<raghavgururajan>nckx Both actually xD
<str1ngs>raghavgururajan T series is to large for me . I only buy light and easy to carry. mainly I do most of my work from a high powered workstation.
<nckx>o_o
<raghavgururajan>str1ngs it is slim model in t-series.
*nckx looks at laptop.
<nckx>I'm really out of date if this is ‘large’.
<raghavgururajan>str1ngs the following is in it's description:
<nckx>Last I heard the Technoetical owner was attending the Guix days. Let us all pressure them into shipping Guix System by default.
<raghavgururajan>This is the ideal laptop for those who waver between the X200 and T400: it is much lighter and slimmer than T400 but as powerful, and it has a touchpad, a LED wider screen and an optical unit, when compared to the smaller X200. The T400s is the most modern x86_64 laptop supported by Libreboot! It has been launched one year after the X200(s/T), T400 and T500 and has the same keyboard as the X220 and T
<raghavgururajan>420 models. It is also very rare and the hardest to flash externally with Libreboot, harder than the X200 Tablet.
<str1ngs>techckinally speaking the term might be . I prefer notebooks to laptops
<raghavgururajan>same keyboard as the X220 and T420 models. It is also very rare and the hardest to flash externally with Libreboot, harder than the X200 Tablet.
<str1ngs>raghavgururajan maybe though based on this describption it's not as large as the regular T series
<str1ngs>I think once I get my pinebook I will flash my x220
<raghavgururajan>flash with libreboot?
<str1ngs>right
<raghavgururajan>x220 is not supported by libreboot, yet.
<str1ngs>if not libre then at least coreboot
<raghavgururajan>t400s is the latest device that libreboot supports.
<raghavgururajan>I see.
<str1ngs>minimum if I can remove the pci express white list would be a start
<str1ngs>I think the wifi is pci express
<str1ngs>1200 euro is alot. I can get a X1 carbon for that much :(
<str1ngs>I think I'm just going to move a way from thinkpads and goto arm. they seem more hackable and open
<raghavgururajan>thats's correct.
<raghavgururajan>Technoethical donates part of its income to different free software projecs. We list the donations on the page Technoethical donations.
<raghavgururajan>copy-pasted from site
<raghavgururajan>Also, it is mentioned that t400s is hard to flash.
<nckx>Oh, wow. That is pricey.
<nckx> https://tehnoetic.com/tehnoetic-donations
<raghavgururajan>Hmm, GuixSD should be changed to Guix System. I'll let Tiberiu know.
<nckx>raghavgururajan: Just ‘Guix’.
<nckx>GNU Guix.
<raghavgururajan>Cool!
<nckx>mbakke: Oomph, that texlive update looks like it was ‘fun’. Thanks! (And on to 2020…)
<raghavgururajan>nckx Are you available to process some of my patches? 😀
<nckx>raghavgururajan: Mm… GNOME-related patches? As hinted at before I don't feel comfortable signing off on those, since I don't use GNOME and previous ones introduced some bugs that annoyed people who do.
<nckx>I'm sorry.
<nckx>These need to be reviewed by someone who has the big picture.
<raghavgururajan>nckx Oh I remembered that. I have few libraries.
<raghavgururajan>Cool, no worries.
<nckx>I'll take a look at the ones that don't change any existing behaviour (like new libraries, sure). Likely not until tomorrow though.
***wxie1 is now known as wxie
<raghavgururajan>nckx That would be nice. Thanks so much. :-)
<nckx>raghavgururajan: While you should take them seriously & fix them & always strive to improve & blah blah blah, I hope you haven't been discouraged by the bug reports. It happens. Only (s)he who does nothing does nothing wrong. Just keep improving.
<raghavgururajan>nckx Of course :-) I am not discouraged at all. "Practise makes a man perfect".
<raghavgururajan>or a woman. xD
*raghavgururajan is working on libnma
<nckx>kmicu: But… but… that was my example! I demand that you throw me bearluv too! /s
<efraim>guix keeps on wanting to build mercurial for me
*kmicu ʕノ•ᴥ•ʔノ ︵ ♥❤❣💞 at nckx
<nixo>Hello people!
<nixo>Is there a reason why the python2 package provides the executable "python", while python3 does not?
<g_bor[m]>hi nixo!
<g_bor[m]>there is python wrapper, if you need a python3 input for a package.
<nckx>kmicu: Yay.
<nckx>nixo: Because it turned out to be a very bad idea to have an unversioned executable when your language changes across major versions.
<nixo>nckx: so why not removing "python" altogether?
<nckx>They did.
<kirisime>Who here is familiar with geoclue? I'm looking into it since I can't get GNOME's night light to work with geolocations and others are having trouble with redshift.
<nixo>nckx: guix environment --pure --ad-hoc python2 -- python --version -> Python 2.7.16
<nixo>the same with package python fails
<efraim>Try with python-wrapper
<kirisime>nixo: Use python-wrapper in place of python3.
<nckx>nixo: Yes. It was removed. 😛
<nckx>g_bor[m] already gave you the solution if your package still uses ‘python’.
<nixo>yes, thanks g_bor and efraim :) at first I tought it was a function like wrap-program :D
<g_bor[m]>yw
<mehlon>so I'm trying to setup offloading
<mehlon>do I need to also authorize the public key of my machine in the openssh configuration?
<kirisime>mehlon: Yes, otherwise your build machine will not accept things from your machine.
<kirisime>mehlon: Actually, for ssh, you need to give the correct private key in the machine definition.
<mehlon>oh I see
<kirisime>Mine is set up as (user "kirisime") (private-key "/home/kirisime/.ssh/id_ed2519")
<kirisime>In summary, both of the machines' guixes should authorize each other, and in addition you need an ssh key that will let you log in to any one user on the build machine.
<kirisime>I wonder if it would be stupid to set up a public use build machine...
<NieDzejkob>I would take bets on how long it would take until someone tried to use it for `building' cryptocurrency blocks
<mehlon>lol
<mehlon>that would actually be kinda genius though
<mehlon>but of course Guile is already known to be turing complete
<mehlon>I think docker and github already provide something similar to this that you can use
<mehlon>or you can put it on heroku
<mehlon>so can guix pull be offloaded too?
<kirisime>mehlon: I've heard so but I'm not sure if it's being done or how to do it.
<mehlon>it appears to be offloading by default
<civodul>mehlon: offloading is on unless you pass --no-offload
<mjw>could someone help me with https://issues.guix.gnu.org/issue/38803
<mjw>brett was helping me with it, but I believe he ran out of time
<leoprikler>I'm pretty sure brettg will take care of it once they get back.
<sirgazil>Hi, I want to add log rotation service to my system config, but I'm not sure if I need to import all the modules in this example https://guix.gnu.org/manual/en/html_node/Log-Rotation.html
<sirgazil>or jsut the admin module from gnu services?
<sirgazil>*just
<leoprikler>probably the latter, unless rottlog is somehow defined in mcron
<sirgazil>I don't see anything about rottlog in mcron. I'll try with admin alone and see what happens then.
***ng0_ is now known as ng0
<mehlon>it appears the gnunet package runs tests when building, can this be turned off?
<rekado>mehlon: do you mean to move the tests to the “check” phase instead?
<sneek>rekado, you have 1 message.
<sneek>rekado, nckx says: Lots of duplicate results in Mumi, e.g. <https://issues.guix.gnu.org/search?query=emacs-guix>. Known bug?
<rekado>nckx: the mumi search is the debbugs search; and the debbugs search returns all matching messages, not just matching issues.
<mehlon>ah, I guess there is a check phase
<mehlon>that probably means I can't turn it off with just a command line switch
<NieDzejkob>Is the way I'm getting the list of stuff to add to $PATH here reasonable? https://debbugs.gnu.org/cgi/bugreport.cgi?bug=39102
<leoprikler>Not really.
<leoprikler>or wait, lemme check again
<NieDzejkob>(the inputs argument also contains native-inputs, BTW)
<leoprikler>the way you construct path-ext looks weird af tbh
<NieDzejkob>okay. How would you write this?
<leoprikler>perhaps (map (cute assoc-ref inputs <>) '("awk" "coreutils" ...)
<leoprikler>)
<leoprikler>in lieu of cute you can also write your own lambda
<leoprikler>(that essentially does the same)
<leoprikler>I'm also quite uneasy about (find-files ".")
<leoprikler>Is that really acceptable there?
<hexagonal-sun>Does anyone know how I can access 'intel_backlight/brightness' as a non-root user?
<hexagonal-sun>It looks like I need root permissions to change the backlight
<leoprikler>ah, okay, you have the directory-excursion
<leoprikler>hexagonal-sun: if there's nothing else to help you, you can write a pkexec wrapper for it
<leoprikler>arch wiki also has something on udev rules
<leoprikler>and if it's just about adjusting brightness under X, xrandr can do that
<oriansj>hexagonal-sun: most settings outside of STIG environmentss are user readable.
<civodul>hey rekado!
<civodul>rekado: this makes me wonder: how much of debbugs are we still using?
<g_bor[m]>hello guix!
<g_bor[m]>are we planning a release soon?
<mehlon>oui... release.. the guix.
<hexagonal-sun>oriansj: What's STIG sorry? Also i'm looking to adjust the backlight so it's write access that I need
<g_bor[m]>I believe 39090 should be fixed before.
<mehlon>perhaps when guile 3 is released in a week guix can make a new release as well
<g_bor[m]>Currently the installer does not work.
<oriansj>hexagonal-sun: STIG is a standard for hardening systems usually used in Militaries and intelligence agencies. You will need elevated permissions to alter system wide configurations.
<hexagonal-sun>Oh no I don't need anything like that - just a single-user system.
<oriansj>hexagonal-sun: simply use sudo to alter the file
<oriansj>cat foo | sudo sponge /etc/example works just fine if you have sponge installed; if not here is it's source code: https://paste.debian.net/1125713/
<NieDzejkob>leoprikler: should I submit a PATCH v2 with this instead? https://paste.debian.net/1125714/
<leoprikler>looks better
<leoprikler>in your wrap-program script thing, be a little more consistent, though
<leoprikler>either use wrap-script if it's all scripts or call the variable program
<NieDzejkob>oh, I didn't know wrap-script exists :D
<mehlon>it looks liike the gnunet package is doing a make check even though it has (modify-phases %standard-phases (delete 'check))
<mehlon> http://git.savannah.gnu.org/cgit/guix.git/tree/gnu/packages/gnunet.scm#n276
<mehlon>oh, wait
<mehlon>I think I'm starting to get it
<mehlon>it's doing make check *after* the install phase...
<dadinn>hi all
<mjw>so for hacking on guix itself the manual suggest guix environment guix --pure
<mjw>But I keep stumbling and adding stuff to get anything done.
<mjw>e.g. guix environment guix --pure --ad-hoc less help2man git strace emacs
<mjw>I get the feeling I am doing it wrong
<NieDzejkob>mjw: --pure has a smaller chance of getting messed up by users' settings, but doing it without --pure works just fine too
<dadinn>I am trying to understand the system-config.scm format. It seems to me it is not just static data, as it uses guile functions like `list`. `cons`, and `append` inside the `file-systems` and and `mapped-devices` sections... so I would like to understand how the evaluation is done here
<mjw>NieDzejkob, OK, so the "real" workflow is simply doing guix environment guix and then making sure you have everything you need as "extra" installed with guix install ...
<dadinn>is `file-systems` itself a function? If not how does the `list` and `cons` functions get evaluated under it?
<sameerynho>hey folks, regarding to the graalVM stuff, oracle releases prebuild graalVM distribution. So should i just use the same distribution as a substitude ?
<NieDzejkob>dadinn: operating-system is a struct, file-systems is its field
<NieDzejkob>sorry, s/struct/record/ ;)
<NieDzejkob>leoprikler: hmm, I would have to add guile to the deps to make wrap-script work. I'm torn on the trade-off here...
<leoprikler>then call them programs, ezpz
<NieDzejkob>ok :)
<NieDzejkob>or I could just use cute :D sent a revised patch
<mjw>What is the correct way to indicate parts of a package are under separate licenses and or under some dual license.
<mjw>e.g. I have a package where the main binaries are under GPLv3+, the libraries are dual licensed GPLv2+ or LGPLv3+ and some documentation is under GDFL1.3+
<mjw>sorry, GFDL
<mjw>So for a fedora spec I would say License: GPLv3+ and (GPLv2+ or LGPLv3+) and GFDL1.3+
<mjw>how to express this in a guix package license declaration?
<mehlon>hmm
<mehlon> something like (license (list license:gpl3+ license:gpl2+ license:lpgl3+ license:gfdl))
<paprika>anyone any idea why sudo mount -a is not working?
<mehlon>works for me
<mjw>mehlon, OK, and don't care about subtleties of works under AND or OR dual licenses?
<dadinn>NieDzejkob: I am not familiar with the structs, is `file-systems` a kind of "factory method" to create the struct? If so what is the evaluation strategy, because it is not eager by the look of it
<mjw>mehlon, I am fine with that. The reasons for the dual license are slightly obscure anyway.
<mjw>(Basically the libraries are also integrated into some linux gplv2-only code, which is incompatible with lgplv3+, so it got dual licensed for those silly gplv2-only projects.)
<mehlon>there isn't any sophisticated licensing code in guix (yet?)
<civodul>mjw: so far we simply add a comment to explain whether the list means "dual licensing" or "multiple licenses"
<paprika>any fs requirements, mehlon?
<mjw>civodul, OK, can add it as comment too.
<mehlon>paprika: well, it really depends on when you're doing sudo mount -a and why and what the error is
<mjw>There is also to subtlety that of course the work as a whole cannot be under all the licenses simultaneously (sigh, gpl and gfdl not being compatible...)
<civodul>oh, & hi mjw! :-)
<civodul>yeah
<paprika>there's no error, mehlon, there's just nothing happening
<mehlon>do sudo mount -av
<mjw>civodul, and hi! /me preparing to not look too stupid when going to guix days...
<NieDzejkob>dadinn: operating-system is a macro that looks at each sub-form, file-systems doesn't exist in the environment
<paprika>it says that / is ignored
<paprika>but that's only because /dev/sda3 is already mounted
<mehlon>are you doing a manual installation?
<mjw>(but I have to admit I feel like such a noob, guile is awesome, but, wow, different. I keep stumbling over this whole environment thing... But I will get the hang of it. Eventually...)
<NieDzejkob>dadinn: I think it's translated into some kind of letrec* under the hood
<civodul>mjw: heh, no worries, something that looks confusing to you is prolly something that needs to be improved!
<paprika>mehlon: https://paste.debian.net/1125723/
<civodul>if we manage to confuse die-hard hackers, that's not a good sign ;-)
<mjw>civodul, haha, that would mean lots of stuff. I am so easily confused :)
<mehlon>well I'm unsure what you are trying to do. sudo mount -a simply mounts everything in /etc/fstab
<paprika>my system is already installed btw
<paprika>yeah that's what I thought too
<paprika>hence my confusion
<NieDzejkob>okay, wtf? I did `guix package -r curl:doc curl' and it said "The following packages will be removed: curl:doc, curl"... and proceeded to BUILD curl?
<mehlon>cannot reproduce
<sameerynho>hey folks, if a software authors provides prebuild binary package for their software, can I just download and extract it as the build process ? (I'm trying to create a guix package for it )
<mehlon>sameerynho: yes, but all packages in official guix repo are built from source
<mehlon>so you cannot upstream this package
<sameerynho>mehlon: ok then i have to build it from source
<mehlon>sameerynho: https://guix.gnu.org/manual/en/html_node/Contributing.html
<mehlon>I can't find if there's an explicit rule to build from source, but this is necessary to keep builds reproducible and trustworthy
<sameerynho>mehlon: yeah you have a good point
<NieDzejkob>mehlon: yeah, I have some patches I use locally on curl, but I wouldn't've expected it to build the package when I asked to remove it
<mehlon>who knows, maybe guix is aliased to a secret guix that does things you dont want
<kmicu>mjw: generally code can be under ‘conflicting’ licenses. But cannot say anything specific w/o seeing the code.
<raghavgururajan>leoprikler How do you connect to ZNC using Polari?
<leoprikler>I personally don't. I simply keep Polari open as it's lightweight enough.
<leoprikler>connecting to ZNC *should* be like connecting to normal IRC, but I don't know about passwords in that case
<leoprikler>(IIRC NickServ doesn't exist inside ZNC)
<mjw>Heay, a make check in a freshly checked out and bootstrapped guix gives:
<mjw>error: failed to load 'guix/scripts/pack.scm':
<mjw>ice-9/eval.scm:293:34: no binding `zip' to hide in module (gnu packages compression)
<NieDzejkob>does it persist when you run 'make' again?
<mjw>O wait... I see a warning about something earlier related to an edit I made. bleah.
<mjw>So, sorry, probably just /me forgetting a bracket somewhere
<jojoz[m]>Hi guix!
<jojoz[m]>(Can anyone tell me)/(Where can I read about) how exactly patch-submissions should look? More specifically, is there a specific format for title and message I should follow? Can I define 2 closely related packages in the same commit/patch? Should the patch be sent as an attachment or included in the email body inline?
<mehlon>jojoz: http://issues.guix.gnu.org/
<kmicu>jojoz[m]: more exactly than https://guix.gnu.org/manual/en/html_node/Submitting-Patches.html#Submitting-Patches ?
<mehlon>if one depends on another they should be in the same patch, otherwise you can decide if you send it as one patch or as two
<mjw>yep, that was it. Missing bracket. Doh. Sorry for the noise.
<mehlon>real lisp hours
<NieDzejkob>mjw: so much for a fresh checkout, eh?
<jojoz[m]>mehlon: [re: issues.guix ...] I've seen that page, but it doesn't really tell me anything. I've cloned Guix locally, made the adjustments, run the tests, and staged the changes.
<mehlon>ah, I meant you could look at other patch submissions
<NieDzejkob>mjw: consider installing vim-paredit
<mehlon>forgot to say
<jojoz[m]>kmicu: Yes I read that and learned how to make a patch with `git format-patch`, but it doesn't tell me exactly in what form the patch should be included in the email.
<mjw>NieDzejkob, *sorry* And gash vim? No emacs/geiser?
<mjw>gasp
<jojoz[m]>mehlon: [re: dependency] Yes! The packages are `ghc-llvm-hs` and `ghc-llvm-hs-pure`. `llvm-hs` depends on `llvm-hs-pure`, but both should be public.
<kmicu>jojoz[m]: cuz that doesn’t matter much, feel free to do what you prefer. No need to be perfect on the first try.
<mehlon>there's a 504 gateway error on issues.guix.gnu.org
<NieDzejkob>mjw: I thought you mentioned using vim before, but maybe that was someone else having troubles with matched parens
<jojoz[m]>mehlon, kmicu: Alright, thanks! I looked at https://lists.gnu.org/archive/html/guix-patches/ and noticed that some people attached their patch files, while some included the patch-text inline, and I was confused about what the "correct" way was.
***raghav_gururajan is now known as raghav-gururajan
<NieDzejkob>oh wtf, upower is segfaulting several times a second
<mehlon>I suppose one hasn't been chosen yet
<mehlon>if the patch is somewhat small inline might be easier to process
<mehlon>(at least for me in my web client :3 )
<mjw>NieDzejkob, emacs, but pretty noob with scheme (and no, I don't really know elips either). Not yet in the habit of bracket matching. I get confused easily as, like in this case, the last line just closes everything, including stuff that was opened way above the visible buffer view.
<mehlon>enable bracket highlighting
<mehlon>it's in the top menu
<mehlon>mjw: https://www.emacswiki.org/emacs/ShowParenMode
<kmicu>Smartparens or Paredit are helpful to avoid all those incomplete hugs.
<mjw>That does indeed help
<mehlon>never leave home without it
<mjw>BTW make does produce a lot of warnings. That is why I first didn't even notice the one I caused.
<kmicu>“We prefer to get patches in plain text messages, either inline or as MIME attachments.” so don’t send HTML emails and we should be all happy :)
<jojoz[m]>kmicu: Ok!
<jojoz[m]>Another question, should I put "[PATCH]" in the subject line, or is that added automatically by the system somehow?
<kmicu>If your MUA doesn’t handle that then do it manually “When posting a patch to the mailing list, use ‘[PATCH] …’ as a subject.”
<jojoz[m]>Ok
<kmicu>(No one will be angry if you don’t do that on your first try.)
<efraim>I need to document using vim plugins in guix
<sameerynho>what is the version policy for a tool which is on a rolling base releases ?
<vagrantc>is it git-backed?
<sameerynho>yes
<vagrantc>you could use something like (version (git-version "0" revision commit)) i guess
<vagrantc>not or a datestring ...
<vagrantc>er, or a datestring
<vagrantc>(version (git-version "20200112" revision commit))
<sameerynho>cool thanks
<vagrantc>not *entirely* sure on that, so might want to get a few more answers :)
<vagrantc>or just file a patch and see what happens :)
<efraim>If there's never been a versio
<efraim>Release then we normally use 0.0.0 as the version in git-version
<efraim>I personally like adding a comment also noting the date of the commit
<mehlon>is there a way to make linux use an audio file as if it was a microphone input?
<mehlon>man, cuirass is really unresponsive
<leoprikler>mehlon: for which purpose?
<mehlon>the site itself takes minutes to load sometimes
<mjw>OK. Got my new patch cleaned up. Do I sent it just to @debbugs.gnu.org and/or guix-patches ?
<mehlon>guix-patches yes
<mjw>It is an update to an earlier patch
<KE0VVT>Has anyone used Weston as their main desktop on Guix?
<mehlon>oh
<drakonis>mehlon: try piping it with pulseaudio
<mjw>mehlon, OK, so to both?
<mehlon>wait hold on
<leoprikler>mjw: nope, just patches
*mjw happily listens to the hold music
<mehlon>if you already have a thread that's still open you can respond to that
<mjw>leoprikler, OK, and that somehow connects to the earlier debbugs issue?
<leoprikler>ah, no
*mjw is slightly confused
<leoprikler>in that case, reply to NNN@debbugs.gnu.org
<mehlon>when you sent an email you should have gotten a response from the server that told you the bug number
<leoprikler>NNN being your already existing bug number
<mjw>Maybe I didn't explain correct. So I did sent a patch last year. Sent it to guix-patches. It got a debbugs number and some comments. I now have a refreshed patch with some extra issues fixed.
<mehlon>was the previous patch accepted?
<leoprikler>s/last year/last decade
<mjw>OK, so ONLY to 38803@debbugs.gnu.org ?
<leoprikler>oui
<mjw>mehlon, no. brettgilio had some comments, I addressed those and some other things I found out today through guix lint and friends
<mehlon>at this point I'm not sure
<mehlon>I haven't got much experience in the guix
<mehlon>leoprikler says you should respond to 38803@debbugs.gnu.org so I think thats right
*mjw listens to the master
<leoprikler>btw. it would also be nice to include brettg in that mail
<mjw>and notices that outgoing email hasn't been configured yet...
<mehlon>ah I think you managed to timeout his ping, pretty neat
<mjw>doh. He quickly quit. Sorry Brett! I mean well. Honest!
<leoprikler>if you're using a conventional MUA, "reply to group/everyone" is the right button to click
<mjw>I normally use git send-mail. We will see how it goes :)
<roptat>hi guix!
<mehlon>heyo roptat
<civodul>howdy roptat!
<roptat>I just released a new version of offlate (my translation tool) :)
<roptat>but the gitlab instance it's on is currently down
<roptat>I think it's time for me to contribute it and its dependencies to guix :)
<mehlon>ah speaking of, I heard they shut down framagit
<mehlon>or maybe its temporary
<roptat>it's on framagit, but it's a maintenance operation
<roptat>they need more disks apparently, and they plan for 12+ hours of downtime
<roptat>(starting 2 hours ago)
<roptat>in the long term, they plan to close framagit (they will not allow new accounts in 2021, but have not decided on when to shut the service down completely)
<roptat> https://framablog.org/wp-content/uploads/2019/09/Planning-fr-v2.png
<roptat>or https://framablog.org/wp-content/uploads/2019/09/Planning-en-v2.png if you don't read French :)
<mehlon>not speaking french? on the guix channel? c'est ridiculous!
<oriansj>mehlon: as an American, I am shocked by that behavior; you need to include atleast 3 other languages: Mandorian, spanish and scheme ;-p
<mehlon>lojban, but as a lisp dialect
<mehlon>lisperanto
<oriansj>mehlon: so logjam?
<mehlon>I'm afraid I don't get the joke
<mehlon>:3
<mehlon>all I could find is a computer security vulnerability and "an accumulation of large wood"
*raghav-gururajan is facing issues with their XMPP-IRC bridge. So using ZNC for time-being.
<civodul>roptat: i didn't even know you were working on a translation tool!
<civodul>when are we going to run it at guix.gnu.org? :-)
<roptat>it's not an online tool
<roptat>its goal is to connect to the platform your project uses (or get its repository if it doesn't have a platform), and present an interface for translating its translation files
<civodul>ooh, even better
<roptat>for instance, I use it with guix to download the po from the TP, work on it, and send it back to the TP, without ever interacting with the robot myself :)
<roptat>I also use it to connect to transifex, get yaml files for translating the iD editor (from openstreetmap), and send it back my work when I'm finished
<roptat>in the latest version, I added support for github and gitlab instances: if there is no translation platform, you can download the repo, the tool will find all translatable files, you work on them and at the end you can send a pull request/merge request to the project
<nckx>rekado: That's what I thought, but then they all link to the top message instead of using (say) #anchors. But never mind, as long as it's known it's fine.
<nckx>Bonjour Guix!
<mehlon>heya
<raghav-gururajan>nckx o/
<g_bor[m]>hello!
<g_bor[m]>nckx: I believe I am quite near to the end of this bisect.
<g_bor[m]>I suspect that the add JFS support commit broke something in the installer image.
<g_bor[m]>It will take about an hourc to get the final confirmation, I am now builgin a fresh iso from that commit.
<nckx>Cool. Any idea what? My test was: install system on external image, boot it.
<nckx>What's the error message?
<g_bor[m]>I don't see anything wrong with the commit actually.
<nckx>I'm guessing this is not about the ‘substituter’ error, right?
<nckx>Well, neither do I, but then I might be slightly biased.
<g_bor[m]>Unfortunately it is.
<g_bor[m]>But I can't guess how these are related.
<nckx>WTF indeed.
<nckx>I've never seen that error myself. Does it actually depend on substitutes? Or would that take to long to test?
<nckx>*o
<g_bor[m]>I am not sure yet that this was the commit, but there was only 5 above it with package related stuff, so I am trying my luck with it.
<mehlon>so I'm trying to chroot into alpine linux (armv7l) on guix system
<g_bor[m]>nckx: I did not check actually what happens without substitutes.
<mehlon>I have "arm" in my config for qemu-binfmt, but it still complains that /bin/sh not found
<g_bor[m]>The simplest way to see is that it break the gui install.
<nckx>g_bor[m]: Eh? How?
<g_bor[m]>in the final installation step the guix system init invocation fails.
<nckx>g_bor[m]: We're talking about 8fec416, right?
<g_bor[m]>yes
<g_bor[m]>I know that 1133596 is ok.
<kirisime>"Invalid field specifier" isn't too useful of an error especially at this time of the night.
<nckx>kirisime: ‘Something went wrong :-(’
<mehlon>Oopsy woopy
<g_bor[m]>b307b58 is good
<g_bor[m]>sorry is bad
<g_bor[m]>so either that or the guix update.
<nckx>g_bor[m]: If the error is in ‘guix system init’ itself, could fd88516 have simply pulled in an older bad commit?
<kirisime>I honestly hate guile's error reporting by now. I can infer more from what PHP 5 vomits when things go wrong.
<nckx>I.e. are you bisecting the right Guix?
<nckx>(I really don't know.)
<g_bor[m]>Those are my best guesses.
<g_bor[m]>yes, I am
<nckx>OK 🙂
<g_bor[m]>the most time is consumed because I can't do this in system vm, as it fails because of the read-only store.
<g_bor[m]>so I have to do a full disk-image.
<nckx>I wouldn't personally know how to do this (bisect the guix package, not the building guix) myself without jumping through very tedious hoops involving hash updates &c., 's why I asked.
<g_bor[m]>the error is also transient...
<g_bor[m]>it works for the second time.
<nckx>Hm.
<g_bor[m]>Sorry, I think the I misunderstood your question.
<g_bor[m]>I am actually bisecting the building guix
<g_bor[m]>it does not make sense to me...
<g_bor[m]>I mean that it works the second time.
<g_bor[m]>the shortest way to trigger it is trying to build any gexp with-extension guix.
<nckx>If fd88516 turns out to be the first bad commit (and that seems likely to me at this point), wouldn't you actually have to bisect the ‘guix’ package to find the real first bad commit?
<civodul>g_bor[m]: doesn't "guix build guix" have the same effect?
<nckx>I'm up since 4, it's too late for me to think about matroskaguix ☹
<g_bor[m]>nckx: I will try it.
<g_bor[m]>:)
<g_bor[m]>I guess I will have a bad image soon to try it again.
<g_bor[m]>if fd88516 turns out to be the problem would it make sense to try to update it again, and see if that works?
<nckx>That's probably a good strategy. If it helps, we can basically ignore this obsolete bug, if it doesn't you haven't lost that much time in the grand scheme of bisecting.
<g_bor[m]>ok, I will see.
<g_bor[m]>Thansk for help.
<nckx>No, thank you for your effort.
<nckx>Really.
<g_bor[m]>:) this was biting me, as it turned up somewhere where I was showcasing features...
<g_bor[m]>I hope you can get some sleep soon :)
<nckx>g_bor[m]: I trust you've seen Ludo's recent mail? Looks super relevant.
<nckx>atw: Progress: https://github.com/googlefonts/Inconsolata/issues/42#issuecomment-573449285
<g_bor[m]>I've just seen it falling in :)
<atw>nckx: thanks for the update :) I was a little intimidated when Eli showed in the comments and I still owe an answer 😬
<nckx>Pff. ‘Eli-Zaretskii doesn’t have any public repositories yet’ on GitHub. Obviously some noob, not a Real Open-Source Developer.
<civodul>:-)
<civodul>atw: BTW, did you have a chance to look at the Clojure things the other day?
<atw>civodul: unfortunately not. Please don't count on me for a solution, I just wanted to repro :)
<civodul>atw: ok, np :-)
<wdkrnls>Dear Guix
<wdkrnls>I just updated my system and somehow dmenu_path stopped listing my executables.
<wdkrnls>It's driven by the stest command.
<wdkrnls>stest -flx $PATH
<wdkrnls>That returns nothing for me now.
<mehlon>Guiques
<wdkrnls>stest will generate the list of executables if I give it any particular path, but not $PATH.
<roptat>oh? what's in your $PATH?
<wdkrnls>/run/setuid-programs:/home/wdkrnls/.config/guix/current/bin:/home/wdkrnls/.guix-profile/bin:/home/wdkrnls/.guix-profile/sbin:/run/current-system/profile/bin:/run/current-system/profile/sbin
<wdkrnls>
<roptat>that looks reasonnable
<roptat>I don't have dmenu nor stest (where does it come from?)
<nckx>roptat: dmenu.
<roptat>so indeed, if you give it just one path, it works, but if you give it a :, it shows nothing at all
<nckx>Yeah, I was just going to note the same thing. But I'm using dmenu.
<roptat>from strace, it seems to open $PATH as just one file
<roptat>try to, at least
<nckx>dmenu_path works fine, so the stest ‘failure’ is an unrelated red herring.
<nckx>As opposed to a related red herring of course.
*nckx → 😴
<wdkrnls>Could you be running on $cache?