IRC channel logs

2019-12-09.log

back to list of logs

<snape>well I guess doing something like git-checkout isn't that complicated. It looks like download-svn-to-store is quite the same thing
<dftxbs3e>what is the difference between inputs and native inputs?
<leoprikler>native inputs take the native version when cross compiling
<dftxbs3e>oh
<smithras>dftxbs3e: native inputs can also be garbage collected after the package is built
<dftxbs3e>I see, thank you
<dftxbs3e>Is there a reference to all of these details?
<dftxbs3e>A full explanation?
<leoprikler>basically, it's inputs to the build itself, not for the runtime
<smithras>I think there's something like that in the guix manual, searching for 'native input' might help find the right page
<leoprikler>You can find it in the manual under Gexps
<dftxbs3e>I need to read the entire manual then
<dftxbs3e>I'll give it a FULL read
<dftxbs3e>is it normal that GNU Guix takes 2300MB of memory?
<leoprikler>depending on the situation?
<dftxbs3e>can a missing parenthesis cause this?
<dftxbs3e>Well. Building GNU Hello from scratch
<dftxbs3e>Nothing is being printed to the console
<dftxbs3e>Memory usage just grows and grows, and the process consumes a full CPU thread at 100%
<leoprikler>that's not something that should take huge chunks of memory
<dftxbs3e>3646MB now
<dftxbs3e>Can circular dependencies happen?
<dftxbs3e>Does GNU Guix warn about this?
<leoprikler>they can and I assume you'll go OOM
<snape>good night!
<dftxbs3e>ugh https://gcc.gnu.org/bugzilla/show_bug.cgi?id=56954
***catonano_ is now known as catonano
<dftxbs3e>Unfortunately that bug has won me. I'm out of things to try! grr -- and it's the only thing blocking POWER9!
<apteryx>dftxbs3e: sounds frustrating. Perhaps get a good night of sleep. Always wake up with some vew ideas :-).
<dftxbs3e>apteryx, :-( -- I just wish someone with more GNU Guix experience could help.
<dftxbs3e>Good night!
<apteryx>good night (will look at your bug in case I could help, too!)
<dftxbs3e>apteryx, https://gitlab.com/lle-bout/guix/-/jobs/372982865
<dftxbs3e>I'm afraid it's going to be difficult to test without ppc64le hardware
<dftxbs3e>If ever you get such hardware, I prepared a container image: registry.gitlab.com/lle-bout/guix
<dftxbs3e>You can run guix build hello -K in it
<dftxbs3e>If you have a gitlab account, I can add you as developer to the project so you can use my ppc64le CI builder
<apteryx>OK, thanks. Will start by reading the bug :-)
<dftxbs3e>apteryx, I'm unsure what could be ppc64le specific in that bug though! You could try rebuilding the bootstrap binaries for x86_64 then re-bootstrapping
<dftxbs3e>and disable mesboot or something
<dftxbs3e>or not
<dftxbs3e>What changed since is that bootstrap binaries now build gcc-7
<dftxbs3e>I mean, that bootstrap binaries *are* gcc-7
<dftxbs3e>not for x86, because GNU Mes though
<apteryx>can't qemu binfmt emulate Power9 yet?
<dftxbs3e>apteryx, yes it can, but that's slow :P
<apteryx>I see :-/. I'm afraid I won't be of much use with my X200 here.
<apteryx>but I'll have a peek out of curiosity.
<apteryx>I see. The bootstrap binaries produced on Power used to work to build it (GCC-5), and now broke with the move to GCC 7?
<dftxbs3e>apteryx, they didnt work with GCC-5 because Glibc >2.25 needs GCC-6.2 and later to build
<apteryx>and you needed glibc > 2.25?
<dftxbs3e>apteryx, GNU Guix does
<dftxbs3e>It's not great being stuck with glibc 2.25 forever
<apteryx>agreed
<dftxbs3e>apteryx, also any arbitrary package may require a newer version
<dftxbs3e>such as jamvm-1-bootstrap in java.scm
<dftxbs3e> https://git.savannah.gnu.org/cgit/guix.git/tree/gnu/packages/java.scm#n220
<kolyad>As I am instantiating my system, I am left with the following confounding error `guix system: error: unknown keyword or bad argument`. Hints?
<lfam>kolyad: Please share the command you ran and the config.scm on <https://paste.debian.net>
<kolyad>It appears to be an error in a define-module form. Thanks
<reepca>does anyone by chance have a sbcl 1.5.9 lying around? having troubles getting it to build
<jyscao__>Hi all, if I'd like to submit a new Guix package definition, do I just send an email to guix-patches@gnu.org?
<jyscao__>I joined the mailing list just now
<zig>yes
<zig>git-send-mail format is preferable.
<jyscao__>thanks
<reepca-laptop>So I've got this weird situation where I can move the mouse and the cursor will move, but everything is unresponsive, including the keyboard (pressing num lock and caps lock doesn't turn any of the lights on).
<reepca-laptop>and I see my irc session has apparently timed out
<reepca-laptop>but I can log in over ssh just fine
<zig>how to make reproducible a package that is not?
<leoprikler>zig: figure out which parts are different in each build (e.g. timestamps) and find ways to disable them
<reepca-laptop>the only recent entries in dmesg are http://paste.debian.net/1120315
<civodul>Hello Guix!
<leoprikler>reepca-laptop: is this after the upgrade to gnome 3.32?
<roptat>zig: rebuild the package with guix build foo --check -K, then you can use diffoscope to find where the two versions differ
<reepca-laptop>leoprikler: not sure, I don't believe I have gnome installed, but I can check the current guix's version
<roptat>Once you know, you'll have to find a way to make it reproducible :)
<reepca-laptop>leoprikler: guix package -s gnome shows 3.32.2, but guix package -I gnome shows it's not installed.
<roptat>Usually, it's just a timestamp issue, so you can substitute a fixed date instead, sometimes it's a file system ordering issue, so you just sort the files before passing them to the command, etc
<reepca-laptop>This particular issue has happened several times before, just slowly, once every few weeks or so
<leoprikler>Then it doesn't seem to overlap with anything I've experienced recently.
<leoprikler>just for the record though, what kind of keyboard/mouse are you using (specifically how are they connected to the pc)?
<reepca-laptop>both of them are connected via USB
<reepca-laptop>Hm, it seems that the logged dmesg events are from at least 30 minutes before the problem occurred
<leoprikler>just to be on the safe side, what does guix package -I gnome -p /run/current-system/profile say?
<reepca-laptop>leoprikler: it says nothing
<zig>leoprikler: roptat: thanks I will try diffoscope.
<zig>in the meantime, I am trying to create a relocatable guile program. I just did 'guix pack -R guile-nomunofu'. The generated tarball, contains everything i need, but the GUILE_LOAD_PATH is not setup, the guile that is built still point %load-path to /gnu/store/c7p869wvgaqd03anbvf82w09inw5q1b6-guile-next-2.9.6/share/guile/3.0
<zig>here is the package definition: https://git.sr.ht/~amz3/guix-amz3-channel/commit/4272b51ba152475b00ed51f6207ac4e231abf466
***Noctambulist is now known as Sleep_Walker
<zig>seems like I need to create a small shell program that does setup the compiled path et al.
<leoprikler>zig: that's what one would expect iiuc
<leoprikler>the pack's /gnu/store should be visible as /gnu/store for programs that launch from it
<leoprikler>guile-2.2.6R/bin/guild is an ELF file instead of a script for instance
<zig>I think the ux can be improved somehow, so that guix pack -R generate a shell script that looks like: https://paste.gnome.org/p1lhqcb7x
<roptat>zig, doesn't the pack has a etc/profile somewhere?
<roptat>probably as gnu/store/...-profile/etc/profile
<zig>roptat: yes it has a /etc/profile, but there is no GUIX_PROFILE
<roptat>I think you're supposed to load that etc/profile before running programs from the pack
<zig>what should GUIX_PROFILE points to?
<roptat>/ probably
<zig>github does not accept tarball as a binary release?!
<civodul>zig: the shell script above is not self-contained, though
<civodul>if we wanted to generate single-file archives, we should use the AppImage format i gues
<civodul>+s
<zig>what does it mean to be self contained?
***lurch is now known as optima
<rekado-out>after reconfiguring to the latest Guix System I can no longer reconfigure any other systems
<rekado-out>the final grub-install step now fails
<rekado-out> http://paste.debian.net/1120322/
<rekado-out>and my partition table is gone now
<rekado-out>gparted segfaults...
<rekado-out>(probably because of an error in gdk pixbuf)
<leoprikler>fdisk -l
<rekado-out>fdisk told me that /dev/sda has no valid partition table any more. That's why I wanted to look at gparted.
<leoprikler>hmm, command line parted?
<rekado-out>I think I know what's wrong
<rekado-out>looks like Guix got confused about that external drive I had connected
<rekado-out>Linux must have assigned it /dev/sda
<rekado-out>gotta check why I'm even using /dev/sda instead of something stable
<__c>Good morning, all. I know there's concern about fingerprinting and some of Firefox's behaviours (which, I understand from the Firefox community, are often the result of forces outside of its control). However, there are no licensing reasons that I can see to not include Firefox in Guix. Would Guix accept a Firefox package?
<optima>rekado-out: on that topic: is a possible to use uuids?
<optima>__c, there is icecat already
<optima>Which doesn't recommend non-free addons, and has librejs preinstalled
<optima>also no phoning home
<optima>(and no widevine drm)
<civodul>hi __c
<civodul>ah no, too late :-)
<civodul>rekado_: hope you found a way out! using UUIDs or labels should help
<civodul>well, actually not for grub-i386, hmm
<reepca-laptop>On starting emacs (even without init files) on my laptop it says "Warning: Lisp directory '/home/reepca/.guix-profile/share/emacs/site-lisp/guix.d/debbugs-0.20': No such file or directory", and fails to load any init files. emacs-debbugs@0.21 is installed, not sure why emacs is obsessing about 0.20...
<civodul>reepca-laptop: bah, that's from which commit?
<civodul>there have been several changes in this area over the last couple of weeks
<civodul>maybe apteryx_ can shed some light when they're around :-)
<__c>Apologies for the disconnect, I've caught the other messages via logs. Thanks for the response, optima. While I agree that there is icecat, that doesn't really answer the question of whether Firefox would be accepted.
<civodul>__c: it would have to be discussed
<civodul>at the very least, we'd need to remove references to the Mozilla add-on pages
<zig>re relocatable guile program: to make it work, guile binary must be relocatable. what I did is do guix pack -R guile-next and then guix pack -R guile-nomunofu, and untar everything in the same directory. now it works :)
<civodul>so generally applying some of the things IceCat changes
<civodul>zig: though i'd recommend a single "guix pack" for both, so that the profile is correct
<__c>@civodul Why, though? Other software which can have non-free extensions (e.g. inkscape) aren't treated in this way.
<__c>It's usually understood that having the ability to load a non-free extension is not the same as being non-free oneself.
<civodul>__c: this is to comply with our policy: https://www.gnu.org/distros/free-system-distribution-guidelines.html
<civodul>i'm not aware of issues with Inkscape in that area, what do you have in mind?
<__c>Thanks, reading through now...
<civodul>in short, the answer is not "no", but rather "yes, but..." :-)
<vagrantc>guix challenge --diff=diffoscope ! very cool!
<civodul>hi vagrantc!
<civodul>yeah, i got tired of running it by hand :-)
<vagrantc>i vaguely recall proposing that somewhere ... might be another bug to close :)
<civodul>it seemed like a good hack for the summit
<civodul>oh cool!
<civodul>ah yes, found it: https://issues.guix.gnu.org/issue/35621
<__c>Ah, I see it: "A free system distribution must not steer users towards obtaining any nonfree information for practical use, or encourage them to do so. The system should have no repositories for nonfree software and no specific recipes for installation of particular nonfree programs. Nor should the distribution refer to third-party repositories tha
<__c>t are not committed to only including free software; even if they only have free software today, that may not be true tomorrow. Programs in the system should not suggest installing nonfree plugins, documentation, and so on."
<vagrantc>civodul: bug#35621: Simplify comparing guix challenge results
<__c>Well, I guess the answer is "no" forever, then (barring a huge sea change at Mozilla)
<reepca-l`>civodul: I'm not sure. Have a bunch of upgrade processes running. I think the guix I had when I reported that issue was 4c16ffd383592854e2760004d2df354f85b32e57, but I'm also not sure that the emacs was up-to-date at the time.
***reepca-l` is now known as reepca-laptop
<civodul>__c: so we could provide Firefox as a package, but we'd apply some changes
<civodul>vagrantc: yup, thanks!
<reepca-laptop>on a related note, for testing purposes I ran emacs -Q once and now for some reason emacs wants to start in non-windowed mode by default. The man page lists a -nw option, but I can't find a corresponding -w option...
<__c>civodul: true. It would tend towards Icecat in the limit, though, so I'm not that convinced that the effort is worth it 🤷🏾‍♀️ ... icecat is non-trivial already.
<civodul>__c: yeah, maybe, we'd need to see how much that would give us
<civodul>i'd also be interested in having Tor Browser
<__c>Would it be possible to help someone (i.e. me) to develop a Firefox package? I hesitate to ask because "To establish lasting freedom, just giving users freedom isn't sufficient. It is necessary also to teach them to understand what it means and to demand it", and I'm not sure if such a request messes with that principle.
<vagrantc>civodul: i think tor browser also supports downloading arbitrary potentially non-free extensions
<bdju>I would think that you could make similar changes to the ones icecat does, but based on firefox stable instead of ESR so long as you had enough people to keep up with the releases.
<civodul>vagrantc: right, so that would need to be patched as well
<ng0>civodul: if you (or anyone else) manages to package it, and then reach out to tor's browser team, i think the last email conversation i had with them was public and could be referenced to save some time
<civodul>bdju: yeah, i don't know how much work that'd be
<ng0>depending on how the package ends up, you could clal it torbrowser (with brnading)
<civodul>oh sure, thanks ng0
<ng0>(cursed, i remember too much.)
<__c>civodul: many thanks for pointing me to the right document. It does have some interesting links, too... and it leads me to another question. What about Firefox, if it was packaged WITH a good set of extensions by default?
<ng0>ah, it went to tor-dev not tbb-dev
<__c>For example, I use decentraleyes, privacy badger, unpaywall, etc. Do those behaviour-modifying extensions make it more free?
<__c>Or, free enough to include in Guix?
<ng0>or maybe both.. searching
<nixo_>Hello guix! How do I set mtime from guile?
<nixo_>Or better, how do I fake the time() syscall, or something like that. Julia writes the mtime to its precompiled cache
<nixo_>*mtime -> current time
<janneke>nixo_: (stat:mtime (stat <file>))
<ng0> https://lists.torproject.org/pipermail/tor-dev/2017-March/011993.html -> https://lists.torproject.org/pipermail/tor-dev/2017-April/012200.html -> https://lists.torproject.org/pipermail/tbb-dev/2017-April/000528.html
<nixo_>janneke: thanks, that works, but I realized the mtime is already correct. But julia writes the time inside the object .-. so It's more difficult.. I thought in the build env time is already faked
<ng0>for your reference
<janneke>ah...
<nixo_>janneke: yeah. It compares a file's mtime with the cache **mtime** field written in it, to check decide whether the cache must be updated..
<puoxond>Hey Guix!
<puoxond>How come these two commands produce different outputs?
<puoxond>guix time-machine --commit=9beec21 -- build sdl2 --no-grafts
<puoxond>guix time-machine --commit=a7a4928 -- build sdl2 --no-grafts
<civodul>__c: again Firefox is free software, so no problem there; the issues are mostly the non-free extension repos it links to, AIUI
<civodul>ng0: thanks for the links!
*civodul goes afk
<puoxond>The only difference between the commits is a change to Emacs.
<ng0>__c: one take away from my interaction 2 years ago is that you could check if they have improved the license reporting (in firefox or in torbrowser), there were some undeclared licenses in firefox 2 years ago
*reepca-laptop facepalms. Forgot that emacs packages are listed individually in EMACSLOADPATH, and the profile hasn't been re-sourced, so of course it's still looking for version 0.20...
<nixo_>I hate julia more than ever: faketime "1970-01-01" julia -> segfault
<nixo_>she does not like the epoch
<reepca-laptop>Hm, what's the proper way to get a "like-login" environment? Just running bash -l leaves a bunch of the old environment around, and running env -i bash -l leaves necessary stuff like $HOME unset
<nomr>How do I reduce the load on my system when guixbuilder is thrashing? Usually I would hit ctrl-z on build process to pause it while I want to use system responsively, but here it is just a socket to a daemon =S
<zig>nomr: maybe you can use 'nice' command
<vagrantc>nice level can sometimes affect reproducibility... :/
<raghav-gururajan>jonsger Thanks!
<civodul>puoxond: looks weird! the difference between the two .drv is ibus
<civodul>then gettext
<raghav-gururajan>Folks! For some reason gajim does not opening any window. It runs in background, but no window appearing. I get this log in terminal. (https://bin.disroot.org/?9db4ef816c740284#ArYQWd1cwvMJ1WsGHMxiqcyhCZ3KNoSLJrh1bdg2n7sY).
<civodul>sneek later tell puoxond there's sdl2 -> ibus -> gettext -> emacs-minimal, which is why a7a492899adac5047e4b11c77edd881ac1276c37 leads to different sdl2 outputs
<sneek>Will do.
*civodul dreams of a "guix diff" tool to diff derivations
<civodul>uh org-capture broken here :-/
<civodul>i wonder if this has to do with the EMACSLOADPATH changes
<civodul>org-capture: Capture abort: (void-function org--check-org-structure-template-alist)
<zig>no mention of guix in https://academic.oup.com/bib/article/19/3/537/2769437
<snape>raghav-gururajan: there's a password
<snape>oh no sorry
<snape>it works
<raghav-gururajan>snape no worries
<snape>raghav-gururajan: dunno, maybe you can try to play with the XDG_DATA_DIRS env variable
<raghav-gururajan>snape Okay. It happened right after gnome 3.32 update.
<civodul>zig: a shame ;-)
<civodul>rekado_: the article at https://academic.oup.com/bib/article/19/3/537/2769437 (no Tor) talks about Lisp in bioinfo
<snape>raghav-gururajan: I run Gnome 3.28.2, so I can't help you more I'm afraid...
<zig>that link was found via https://www.reddit.com/r/biolisp/
<civodul>oh, didn't know "biolisp" was a thing
*civodul found the cause of the shepherd crash \o/ https://issues.guix.gnu.org/issue/37757
<civodul>that makes my day
<wingo>civodul: nice!!!
<str1ngs>civodul: I watch a talk once on biolisp. about porting from C++ to lisp and performance. was quite interesting
<sylvainc>cc comment enregistrer son pseudo ?
<zig>sylvainc: /query nickserv help
<sylvainc>zig merci
<jlicht>hey guix!
<jlicht>I was wondering whether I can run guix' system tests while somehow simulating slower hardware (such as bad quality SD cards and/or spinning rust)
<civodul>hey jlicht!
<civodul>i'd expect the kernel to have knobs to slow things down
<civodul>e.g., there's "tc" that can be used to introduce networking delays
<civodul>perhaps there's something similar for disk i/o?
<nixo_>Oh yes, julia now uses the precompiled cache! :) super happy. I've just sent the patches (First time I send them from emacs, hope the format is fine)
<civodul>:-)
<civodul>nixo_: how did you send them in Emacs?
*civodul is stuck with "git send-email"
<nixo_>civodul: In a terrible way:) open the .patch file created by magit, change mode to notmuch-message-mode, add the "--text follows this line--" line and then C-c C-c
<civodul>nixo_: oh, i usually edit the cover letter that way, but then that wouldn't send all the patches, would it?
<nixo_>for me "git send-email" "is not a git command" .-.
<civodul>guix install git:send-email :-)
<nixo_>civodul: Luckily it was just 3 patches: I did it 3 times >.<"
<civodul>heh :)
<civodul>hmm, perl-gtk2 fails to build on master, which breaks youtube-viewer
<nixo_>civodul: started at least 5 days ago I think
<civodul>yeah i guess that's from the "staging" merge
<nixo_>civodul: sorry to bother again, but how do I add git:send-email in the manifest (packages->manifest?) Tryed with (assoc-ref git "send-email") with no luck
<civodul>(specifications->manifest '("git:send-email"))
<civodul>should work!
<sylvainc>Je suis sur une debian oui je sais mais les habitudes ont la vie dur ^^. Je suis full free :) et je cherche un remplaçant a virtualbox
<zig>qemu
<civodul>sylvainc: QEMU fonctionne très bien en effet, et il y a des interfaces graphiques comme GNOME Boxes (j'ai jamais essayé)
<sylvainc>Merci zig && civodul
<nixo_>civodul: yes finally it worked! thanks again
<jlicht>civodul: I guess I can mount things as a loopback device with a pre-defined delay, but it still seems quite involved to make sure you do not trigger unrelated problems (e.g. I want to simulate slow disk i/o for the running test, not the actual test runner)
<jlicht>it's probably easier to just run the tests and an actual slow system instead :-)
<jlicht>s/and/on
<civodul>jlicht: you would enable slow i/o within the guest, not on the host, i guess
<jlicht>thanks! I'll have a look into that then
<jlicht>congrats on finding + solving the shepherd issue by the way
<civodul>thanks!
<civodul>efraim: could you take a look at https://issues.guix.gnu.org/issue/38465 (rust-cbindgen)?
***ng0_ is now known as ng0
<roptat>jlicht, I did something similar for reproducibility : I mounted /tmp as a disorderfs to test for ordering issues in a few instances. If you mount a slowfs on /tmp, you don't slow down guix, but you slow its builds down :) (slowfs is an example, I don't know if it really exists)
<jlicht>roptat: a! disorderfs is exactly like what I'm looking for!
<raghav-gururajan>snape No worries!
<nomr>zig: thanks for reply earlier. I use thrashing to mean operating with memory exhaustion; nice tends to not help too much because most delay is paging in and out
*zig nods
<zig>maybe try to reduce the number of worker?
<nomr>It was a little roundabout to send commands to guixbuilder process but am now having awkward success with kill -s SIGSTOP and SIGCONT. seems there must be a better way though.
<nomr>I have only one worker =S
<nomr>thanks for attention and advice
<alextee[m]>oh new icecat has tor button, nice!
<alextee[m]>it doesnt seem to work though even though it says im connected
<alextee[m]>whatismyip shows me my normal ip
<civodul>alextee[m]: i think you need to have Tor running (using tor-service-type)
<civodul>cbaines: in the data service, would it be possible to click on a failing build and immediately see the commit that introduced the failure?
<alextee[m]>oh
<alextee[m]>it's a bit misleading though saying it's connected. it should say it isn't connected because tor is not running or something
<alextee[m]>probably an #icecat issue
<alextee[m]>is there an example configuration somewhere for tor-service-type that i can copy and modify?
<civodul>alextee[m]: https://guix.gnu.org/manual/devel/en/html_node/Networking-Services.html#index-tor_002dservice_002dtype lacks an example
<civodul>but basically (service tor-service-type) will do
<alextee[m]>thanks!
<snape>civodul: what prevents Cuirass to have that feature implemented?
<snape>we have the build history, and each build is associated to an evaluation
<civodul>snape: i guess nothing, but there's more and more info readily available in the Guix Data Service
<civodul>though cbaines is too shy to mention it ;-)
<civodul>clearly there's some overlap between the two
<civodul>my take is that we should take what's good in each and try to redefine their boundaries from there
<civodul>for example, the Guix Data Service is really good at "data crunching", uses Postgres, etc.
<jlicht>Can I just push fixes for documentation typo's to master?
<roptat>in our own documentation? I'd say yes, it doesn't require any rebuild
<civodul>+1
<civodul>feel empowered!
<snape>civodul: If I remember well, the problem is: to know when a build started to fail, we need to know what is a build
<bavier>hi guix!
<snape>i.e. is gajim-1.13.linux the same kind of build as gajim-1.12.linux?
<jlicht>I wasn't sure whether tiny fixes would send a lot of spam to our translators or anything silly like that
<snape>what is the common thing between those two jobs?
<civodul>snape: right, so you need a package/derivation mapping, for example
<civodul>because generally we think in terms of packages
<snape>yes, and now you'll say: we don't just build packages...
<civodul>yes! :-)
<civodul>so... it's tricky
<civodul>the data service is very much package-oriented i guess
<snape>we could remove the version from the job-name
<snape>instead of ffmpeg-4.2.1.armhf-linux we'd have ffmpeg-armhf-linux
<civodul>yes, though that's still "convention" rather than "semantics"
<civodul>also, it's not possible when there are several versions of the same package
<civodul>but maybe we could do something like in the packages page, which is to disambiguate as needed
<civodul>so we'd have "coreutils.x86_64-linux", because there's just one coreutils
<civodul>and "gcc-7.4.x86_64-linux", because there are several of them
<civodul>that's a simple hack we could do in (gnu ci)
<civodul>snape: here's a disambiguation snippet: https://git.savannah.gnu.org/cgit/guix/guix-artwork.git/commit/?id=497145ef95cfc7548eb7c406d6227104f4b66700
<snape>civodul: sounds like something we could use indeed!
<snape>so the job name would be package-anchor-system
<snape>instead of package-version-system
<alextee[m]>anyone got qemu running in guix? i get Could not access KVM kernel module: Permission denied
<alextee[m]>works without the -enable-kvm
<jlicht>alextee[m]: silly question, but are you in the "kvm" group?
<snape>alextee[m]: you probably need to add the build users to the kvm group
<alextee[m]>jlicht: oh no, thanks. im new to qemu/kvm
<snape>alextee[m]: https://guix.gnu.org/manual/en/html_node/Build-Environment-Setup.html#Build-Environment-Setup
<jlicht>This is on Guix System for me, so I don't know if that'll help you on a foreign distro
<alextee[m]>im on a guix system too
<alextee[m]>hmm why the build users? snape
<alextee[m]>im running qemu as my main user
<alextee[m]>i just added the group in /etc/config.scm
<jlicht>alextee[m]: that should only be relevant if you want your guix build users to do stuff using kvm on foreign distro's
<civodul>snape: exactly; if you're motivated, i happily leave it up to you to fit that in (gnu ci)
<civodul>jlicht: you committed a patch that changes the doc, instead of the actual doc change :-)
<jlicht>civodul: ouch, that is a silly mistake to make. Thanks for catching it though!
<snape>civodul: oh that's when I realize your anchor thing isn't in Guix
<jlicht>What is the easiest way to fix this? I will only be back on my machine later tonight
<snape>well that's the opportunity to add it ;)
<snape>alextee[m]: because I thought you were using 'guix vm' or things like that
<civodul>snape: i guess you could just have it locally in (gnu ci)
<civodul>it was used in the previous version of the web site
<snape>and with that a SQL script that updates all the known job-names
<jonsger1>jlicht: someone needs to remove 0001*.patch. and commit that :)
<alextee[m]>ah i see
<snape>so that we can use that feature right away
***jonsger1 is now known as jonsger
<snape>civodul: I've done a good part of the work already: write that somewhere ;) https://debbugs.gnu.org/cgi/bugreport.cgi?bug=38550
<civodul>snape: nice!
<civodul>note that "anchor" was because it was about computing HTML anchors
<civodul>but here you could use "shortest prefix" or something
*civodul has to go
<civodul>later!
<apteryx_>sneek: later tell reepca-laptop did you guix pull recently? then perhaps relogin or start emacs in a shell where you've source your ~/.guix-profile/etc/profile.
<sneek>Will do.
***apteryx_ is now known as apteryx
***jonsger1 is now known as jonsger
<guix-guest-052>trying to 'guix pull' I get: 'error: symlink: File exists: "/var/guix/profiles/per-user/my-user/current-guix-1-link"'. Any ideas?
<zig>not me, at least. but someone else will for sure.
<guix-guest-052>I should probably mention I did 'guix pull' recently from an old guix version if that helps
<roptat>mh... I think it's due to a change in how guix pull is handled (although the change is already quite old now)
<roptat>note where that link goes to, remove it and try guix pull again
<roptat>you may need to use guix from that location directly if that's where you use guix from, so really note it
<guix-guest-052>roptat I did so let's see how that goes
<zig>may be interesting to you https://news.ycombinator.com/item?id=21701488
<zig>the discussion thread mention nix approach to packaging without mentioning nix and also ocaps stuff.
<PotentialUser-24>Hello!
<PotentialUser-24>Can someone help me?
<PotentialUser-24>Black screen on Penium4 while booting
<apteryx>shouldn't this work? ./pre-inst-env guix environment -C emacs-ert-runner --expose=/gnu
<apteryx>I get: guix environment: error: mount: mount "/gnu" on "/tmp/guix-directory.4EpoO1//gnu": Invalid argument
<apteryx>PotentialUser-24: what can of GPU?
<apteryx>*kind
<PotentialUser-24>GPU is Radeon HD3850 1Gb AGP
<PotentialUser-24>from start in initsplash was modeprobe.blacklist=radeon
<PotentialUser-24>Removed afterwords but didn't help
<PotentialUser-24>Just black screen and nothing ... even no cursor there
<zig>dmesg?
<zig>can you ssh to the box?
<zig>you can boot under a previous configuration inside grub boot menu.
<PotentialUser-24>I don't know....It stuck not far from booting .... so the problem is not in GPU ... a can see a normal resolution
<PotentialUser-24>So it's a LiveUSB ... first start
<jlicht>Are other folks also having issues with reaching savannah's git repo, even using SSH?
<enderby>getting a guix pull
<enderby>Updating channel 'guix' from Git repository at 'https://git.savannah.gnu.org/git/guix.git'...
<enderby>guix pull: error: Git error: unexpected HTTP status code: 404
<puoxond>jlicht: I can't reach it either. Cgit just says "No repositories found". And I get a 404 error when I try guix pull.
<sneek>puoxond, you have 1 message.
<sneek>puoxond, civodul says: there's sdl2 -> ibus -> gettext -> emacs-minimal, which is why a7a492899adac5047e4b11c77edd881ac1276c37 leads to different sdl2 outputs
<puoxond>sneek: botsnack
<sneek>:)
<zig>do you have a swap partition on servers?
<raingloom>having the same issue. is the DDOS attack still going?
<raingloom>(although that probably wouldn't result in a 404... right?)
<alextee[m]>guix system: error: '/gnu/store/18mz2ky7imndk052c12a2j1z148ynwcn-grub-efi-2.04/sbin/grub-install --boot-directory //boot --bootloader-id=Guix --efi-directory //boot/efi' exited with status 1
<alextee[m]>i get this when i reconfigure
<alextee[m]>any ideas?
<alextee[m]>sbin/grub-install: error: efibootmgr failed to register the boot entry: Input/output error.
<dftxbs3e>ehh
<dftxbs3e>git is down :S
<alextee[m]>this is my config.scm: https://paste.debian.net/1120414/
<alextee[m]>and the exact error i get: https://paste.debian.net/1120416/
*nckx came to see if ‘404’ was a thing. It's a thing.
<civodul>hey!
<civodul>so what's the deal with git.sv.gnu.org?
<brettgilio>That is what I'm wondering too
<brettgilio>Not sure.
<nckx>It's slowly counting down to 200
<nckx>like some sick advent calendar.
***ChanServ sets mode: +o nckx
***nckx changes topic to 'GNU Guix | ⚠️ Savannah (‘guix pull’) is still troublesome | 1.0.1 is out! get it at https://guix.gnu.org | videos: https://guix.gnu.org/blog/tags/talks/ | bugs & patches: https://issues.guix.gnu.org | paste: https://paste.debian.net | Guix in high-performance computing: https://hpc.guix.info | This channel's logged: http://logs.guix.gnu.org'
***ChanServ sets mode: -o nckx
<brettgilio>Hey, nckx do you have a name? Curious who you are.
<zig>no.
<brettgilio>Tobias?
<brettgilio>I bet it is Tobias. :)
<nckx>brettgilio: …why?
<nckx>brettgilio: 🙂
<brettgilio>nckx: purely curiosity. Knew the alias but never put the two together.
<nckx>It me.
<civodul>according to https://lists.gnu.org/archive/html/guix-commits/2019-12/threads.html, the latest commit is 24ba2cee2b1671c5dae36bb4cdba139f1fd09023
<brettgilio>So that bug with Ruby static linking can be changed easily (and succeeds on my machine) but it will trigger a 3000+ package rebuild.
<guix-guest-052>roptat thanks for the tip! It worked
<civodul>comrades, git.sv.gnu.org is back!
<roptat>Cool!
<brettgilio>Thanks civodul
<nckx>brettgilio: Right, just read your mail, sorry. Had 0 time for Guix this week(end). That's core-updates stuff that is. If that sounds intimidating: it's not, just ‘git push … upstream/core-updates’ instead of master.
<nckx>civodul: Thanks! What happened?
<brettgilio>nckx: I figured. I just wanted to run it by somebody else before pushing it.
<brettgilio>Thank you
<nckx>brettgilio: I haven't actually looked at the patch yet but thank you for submitting it.
<civodul>nckx: according to #savannah, it's an upgrade that didn't run as smoothly as intended
<civodul>i think a bit of redundancy for our repo would be nice
<brettgilio>nckx: it is just adding the configure flag. No problem. Happy to help
<str1ngs>civodul: have you seen https://radicle.xyz/ which is built on ipfs
***capnick is now known as cap
<civodul>str1ngs: i had seen it and forgotten, it looks very interesting, thanks for the link!
<civodul>cbaines: ↑ :-)
<civodul>it looks like the grail to me, actually
<civodul>was it dustyweb who mentioned it before?
<civodul>anyone willing to make a package? :-)
<str1ngs>for radical?
<str1ngs>err radicle*
<civodul>yup
<str1ngs>I will see what i can do. go packages are kinda hit and miss with dependencies. though because ipfs has essential been packaged maybe most of the work has been done already.
<civodul>it implements a Lisp, it's written in Haskell, and it talks to IPFS, which is written in Go
<civodul>if we could add some Scheme to the mix, that'd be perfect
<g_bor[m]>:) that sounds like fun...
<str1ngs>civodul the haskell api probably uses the ipfs daemon via https://github.com/ipfs/go-ipfs-api so that makes sense
<str1ngs>actually it probably does not need https://github.com/ipfs/go-ipfs-api use use https requests directly on the daemon
<g_bor[m]>btw for go it might be nice to get something like partial source inputs... a lot of times I have see only a few files copied in tree from other go projects...
<str1ngs>i'll see what I can do to package this
<str1ngs>honestly as a contributor to golang I just use ~/go as GOROOT and go mod
<str1ngs>but for repeatability guix is packages is more ideal I guess
<civodul>looks like https://github.com/cryptix/git-remote-ipfs/ could also be useful
<str1ngs>civodul: I looked at that quickly it's not well maintained. and radicle has some features like issues which is kinda nice. but might be overkill
<g_bor[m]>I was thinkin along the lines of creating a projector for origins... something like attaching an additional snippet.
<str1ngs>civodul: now that I think about it https://github.com/cryptix/git-remote-ipfs/ has a lower bar to entry. but I don't think that will work with libgit2 only git proper
<civodul>right
<str1ngs>I guess I'm thinking in terms of channels. if we could have a p2p channel that might be the start of some distributed fallback
<cbaines>civodul, regarding clicking on failing builds in the Guix Data Serivce and looking at when it started failing, that should be possible
<cbaines>though it'll only be accurate to the commit that was pushed, not necessarily the exact commit that introduced the issue
<cbaines>as for Radicle, that looks cool, if a little complicated, I'm just getting comfortable with Git!
<str1ngs>cbaines: that's understandable though it would actually make submitting patches easy for new users
<str1ngs>easier*
<cbaines>I'm all for making it easier to submit patches
*Digit installed guix, and using it on main rig, and enjoying it 9x more than expected... but pity it doesnt want to get hijacked by bedrock, not having the init where expected (and i expect many other things unique too)
<mjw>I got guix installed on top of pureos (a debian derivative) and although it seems to work nicely I quickly hit lots of compile warnings/errors because of ... urgh https://issues.guix.gnu.org/ gives a 502, sorry.
<mjw>Well, the reason is that the guix profile sets CPATH instead of C_INCLUDE_PATH
<mjw>Setting C_INCLUDE_PATH (as in that bug report I found) seems to work perfectly.
<mjw>But when looking at gcc.csm I see it is only done for some gcc versions.
<mjw> https://git.savannah.gnu.org/cgit/guix.git/tree/gnu/packages/gcc.scm#n332
<mjw>^ this is what works
<mjw>But... https://git.savannah.gnu.org/cgit/guix.git/tree/gnu/packages/gcc.scm#n481
<mjw>That is what breaks things with newer GCC versions
<mjw>I looked at the gcc bug, but I don't understand it. Also if I simply use C_INCLUDE_PATH and friends instead of CPATH things do work and I cannot replicate that gcc bug.