IRC channel logs

2019-09-29.log

back to list of logs

<wdkrnls>How do I actually setup a containerized web browser? Is there a community document with examples?
<sneek>wdkrnls, you have 1 message.
<sneek>wdkrnls, nckx says: https://github.com/BIMSBbioinfo/guix-bimsb ?
<wdkrnls>I tried:
<wdkrnls>cd $HOME/my/code/next-env/
<wdkrnls>guix environment --container --pure --network --user=web \
<wdkrnls> --expose=$HOME/.config/next \
<wdkrnls> next
<wdkrnls>
<wdkrnls>I added --ad-hoc before 'next', I think that actually installs instead of just setting up the development tools to work on 'next'
<wdkrnls>I also added dbus. Now it's failing because it can't find next-gtk-webkit.
<mbakke>vagrantc: weird, both epiphany and next "works for me"
<wdkrnls>So in summary, the script is now:
<wdkrnls>cd $HOME/my/code/next-env/
<wdkrnls>guix environment --container --network --user=web \
<wdkrnls> --expose=$HOME/.config/next \
<wdkrnls> --ad-hoc next dbus -- next
<wdkrnls>
<vagrantc>mbakke: i was afraid that would be the case :/
<quiliro>vagrantc: how recent?
<quiliro>$ guix --version
<quiliro>guix (GNU Guix) 9a0f6a3c939a1b6c22798155045b7532b57e9604
<quiliro>i have Epiphany working
<vagrantc>quiliro: didn't work with de3896fb79984d545e7fec0b5e4f1ba37983fbce on master or 60643d1b1930c54789c8262ae68457fe0c85fae0 on core-updates
<quiliro>vagrantc: My new guix (GNU Guix) e038bafe3b86a8b927628d26375d5ffe75119fd9. I do not have those versions
<quiliro>"new guix (GNU Guix)" sounded like a pun!
<vagrantc>apparently... if i do "guix environment --pure --ad-hoc epiphany" it works ... same exact version "guix environment --ad-hoc epiphany" it fails ...
<vagrantc>so there's something in my environment that's breaking it?
<quiliro>how can i know where a package is being downloaded from without downloading it?
<efraim>vagrantc: XDG something messing with it perhaps?
<quiliro>is it possible to avoid dbus?
<chrislck>~/join #guile
<quiliro> https://www.hyperbola.info/todo/dbus-mitigation/
<Dpx82>Hello
<vagrantc>efraim: that seems plausible... will try to debug it a little more in the next days.
***Guest93043 is now known as benny
***jonsger1 is now known as jonsger
<apteryx>uh; to re-run the install tests after modifying the guix tree, It seems I must restart the guix daemon, as the (current-guix) is added to the store using 'add-to-store', which has a comment saying: ;; Note: We don't stat FILE-NAME at each call, and thus we assume that
<apteryx> ;; the file remains unchanged for the lifetime of SERVER.
*janneke finally has guix build bootstrap-binaries working again on core-updates
<mbakke>janneke: wohoo \o/
<janneke>mbakke: could you maybe have a look at #37549, i added 3 silly patches to get there
<janneke>and thanks a lot for your quick review of --target i68-linux, that helped!
*mbakke takes a look
<mbakke>janneke: are those for 'master' or 'core-updates'?
<mbakke>janneke: you could change ((#:make-flags flags)) to ((#:make-flags _)) for clarity, since the variable is not used. Otherwise LGTM.
<mbakke>I'm confused, didn't we just generate new bootstrap tarballs? how did it break so fast? :)
<janneke>mbakke: they are for core-updates
<janneke>mbakke: the bug report was for master, but bootstrap-binaries are not going to work there; mark_weaver and i made several fixes for that on core-updates two months ago
<janneke>mbakke: it broke by going to gcc-7
<janneke>mbakke: yes, using _ is a nice trick, i'll do that
<janneke>also, we moved to bash-5 and mes-0.20 was released where i failed to take care of make-bootstrap; i only made sure that commencement did not see any changes.
<janneke>on core-updates, git describe says: bootstrap-20190815-2065-g737c83f0ff
<janneke>so, 2065 patches happened since we built the new bootstrap binaries 6wk ago :)
<mbakke>janneke: I see, thanks for taking care of it :-)
<janneke>mbakke: :)
<reepca>apteryx: I believe that's referring to the client-side cache it uses to avoid sending the same thing over and over. SERVER refers to the connection to the daemon, which is the data structure that holds that cache IIRC. So to "flush" that cache, you'd close and reopen the connection to the daemon.
<nckx>quiliro: Probably. Why? (That link conspiously lacks a rationale.)
<nckx>*c
<quiliro>nckx: What link?
<nckx><quiliro> https://www.hyperbola.info/todo/dbus-mitigation/
<quiliro>oh!
<nckx>Did the anti-systemd mob get bored and pick another piece of software at random to hate?
<quiliro>nckx: the Hyperbola main dev does not like that dbus take over everything.
<nckx>That's a bingo.
<quiliro>nckx: I don't it is a love or hate issue. I think that services should be used when necessary, not ubiquitously.
<quiliro>nckx: I remember Bingo!
<quiliro>It was fun to see other people play it.
<quiliro>nckx: Thanks for looking at the link.
<quiliro>nckx: It was important to have another opinion.
<quiliro>I would like to have your technical views too.
<quiliro>And everybody else's too.
<quiliro>So as to enrich my knowledge of the subject.
<nckx>‘In packages where D-Bus is required, explore ubus, gio, kio, and QtDBus as possible replacements.’
<nckx>So it's important to note that only D-Bus is horrible; any other IPC bus is fine.
<nckx>quiliro: I'd like to have their technical views. Mine aren't that outspoken either way.
<nckx>and /me got to go now. o/
<civodul>uh, "TLS certificate error: X.509 certificate of 'nvd.nist.gov' could not be verified"
<civodul>anyone else seeing that?
<reepca>civodul: I can access that site fine in icecat currently via https
<nckx>civodul: Yes, earlier today when running the linter, assumed it was a problem with my cert set-up.
<nckx>Haven't looked into it.
<reepca>ah, I get it too when running 'guix lint'.
<quiliro>nckx: I was given this link https://dvdhrm.github.io/rethinking-the-dbus-message-bus/ . But they said they are preparing their own documentation.
<nckx>quiliro: Oh, thank you! I'll read it later.
***slyfox_ is now known as slyfox
<nckx>civodul: Did you get my reply to Kyle about xftwidth? Just checking (DMARC, … ;-).
<civodul>nckx: maybe not! i just applied it locally and replied
*civodul checks debbugs
<civodul>nckx: oh i see, we both addressed the same issue, but differently :-)
<janneke>civodul: thanks for all your great comments, i'll take some more time the coming days to add some of the 2j celebration to it!!!!
<nckx>civodul: Hehe.
<quiliro>Does anyone remember PragmaOS or Infotropique?
<nckx>quiliro: Yes?
<quiliro>I would be interested in something of the sort actually. nckx, Are you the founder?
<nckx>quiliro: Oh no no, ng0 is/was.
<civodul>janneke: heheh, you're *super* welcome!!!!!
<civodul>:-)
<civodul>nckx: yeah i figured it would be faster and less frustration-inducing to make the changes myself
<nckx>You're probably right. I still wonder what happened (maybe nothing at all).
<civodul>yeah, i think 'guix lint' is deterministic :-)
*nckx delegated! \o/ kind of.
<civodul>yeah, wrong target ;-)
<janneke>civodul: thanks, yes -- that kind of enthusiams -- i get it!!!! ;)
<quiliro>what do you think of xenocara?
<quiliro> https://en.wikipedia.org/wiki/Xenocara
<quiliro>It is the default for Hyperbola GNU
<quiliro>Hyperbola GNU/Linux-libre
<tune>I want to put pmbootstrap on the wishlist, but I'm not sure what section it fits under
<tune> https://gitlab.com/postmarketOS/pmbootstrap
<tune>it's part of putting postmarketOS on a device
<nckx>‘The patches for applying this rather important security protection were provided to upstream for the benefit of other Unix-like systems such as Linux, however the care to apply and maintain them has unfortunately not happened to date.’
<nckx>Got to love obscure Wikipedia articles full of shade.
<nckx>quiliro: I'd never heard of it.
<quiliro>nckx: https://www.xenocara.org/ is probably authentic...wikipedia is just propaganda
<quiliro>for wikipedia to be true, it must have all stances and not the "most accepted"
<quiliro>only
<quiliro>is there such an online encyclopedia?
<nckx>Well, that's not true at all (it's called false balance and it's even worse).
<nckx>‘…others say Nazism is just dandy’ is not something we want in an encyclopedia.
<quiliro>why?
<quiliro>it is the position someone has
<quiliro>it is just necessary to point it out
<nckx>It's not relevant to the facts.
<quiliro>If it is a fact or not isn't the privilege of someone else to decide. Every person has a right to think the way they want. Propaganda is something else.
<quiliro>Propaganda establishes the common position.
<nckx>Everybody's free to say things that aren't true, but not in an encyclopaedia. There are always loud people denying the facts (climate change being an obvious example), they don't deserve equal representation in an article about those facts.
<quiliro>or even the elite position as the predominant one.
<nckx>Aanyway, back to Xwhatever: it does seem interesting. How does it relate to ‘rootless X’, of which I know nothing also? 🙂
<quiliro>why would people be allowed to be loud?
<quiliro>nckx: I am a newbie too. My strength is policy.
<nckx>quiliro: Oh. Policy in what?
<quiliro>If everyone is allowed to speak, agreements can be reached. If not, disagreement breaks relationships.
<quiliro>value
<quiliro>values
<quiliro>Of course that speech is a relationship breaker too. but listening to all has never broken relationships.
<quiliro>Only speaking directed to hurt has hurt relationships.
<quiliro>nckx: what I know about Xenocara is that it drops root
<quiliro>providing better security
<quiliro>Xenocara is an Xorg with better development quality and more secure. It goes incredibly fast. It has improved 30% the speed of the system.... (Those are the words of Emulatorman, Hyperbola dev)
<nckx>Anyway, I chose my ‘others say…’ example very poorly. Pointing out that ideologies are still a problem today is very relevant to an article on them. But that has nothing to do with Xenocara or its article.
<nckx>quiliro: Erm. Wow.
<nckx>I'm getting a clearer picture of Hyperbola than of Xenocara this evening.
<quiliro>Hyperbola is libre Archbian! I thought that was funny.
<quiliro>I would rather call it PureBola....
<nckx>Distro naming tip: avoid the substring ‘ebola’.
<quiliro>PuraBola then...
<quiliro>PurAbola
<quiliro>PureOS+Parabola
<quiliro>It would be great to create a Guix LTS
<nckx>I wasn't joking, PureBola sounds… strange in English, even without the ebola reference. HyperPure sounds uninspired but still better. Are you a contributor?
<nckx>(Or policy contributor :)
<quiliro>haha
<quiliro>I support all libre distros. But i have never used Hyperbola. In fact, I introduced the main dev to free distros.
<quiliro>He used to work in Arch.
<quiliro>He moved to Parabola. Then he founded Hyperbola with some other Parabola hackers. Both projects value him a lot. I do too. Very nice guy.
<nckx>Neat.
<vagrantc>yay. the linux-libre-arm-generic 5.2.x kernel boots on the veyron-speedy/asus c201 ...
<vagrantc>although it needs a few configuration options added for namespaces so that guix-daemon works out of the box...
<vagrantc>but i have a patch for that...
<vagrantc>so can maybe kill off the linux-libre-arm-veyron configuration
<nckx>vagrantc: Perfect! I was just committing my 5.3 update, then noticed that I'd ‘missed’ that machine-specific configuration…
<vagrantc>not sure what's missing ... rtc doesn't appear to work
<nckx>vagrantc: I don't understand why namespace options need to be changed, though. From what, to what?
<vagrantc>nckx: from disabled to enabled
<vagrantc>nckx: it uses upstream's defconfig, which doesn't enable namespaces ... and as i understand it namespaces are used extensively by guix-daemon
<nckx>But which ones, and from which configuration did you take them? It couldn't have been a Guix one… right?
<nckx>Ah.
<nckx>Yes.
<nckx>So it's wildly different from 5.2-arm.conf? :-/
*vagrantc rummages around for the patch
<vagrantc>yes
<nckx>Because last time I checked those are far from defconfigs.
<nckx>OK.
<vagrantc>would be nice to get linux-libre armhf working too ... but ... time.
<nckx>Sure.
<vagrantc>my about to be tested fix: https://paste.debian.net/1103312/
<nckx>arm-veyron remaining it's own special thing isn't that bad, I guess, if it's the only thing the person willing to put in the work got to boot. And hopefully it will vanish soon.