IRC channel logs

2019-09-08.log

back to list of logs

<vagrantc>i'm getting a failure happening right after the unpack phase (or maybe during the unpack phase) for a new package i'm trying to build that just is a bunch of test .png files in a tarball.
<vagrantc> https://paste.debian.net/1099428/
<vagrantc>i looked at trivial-build-system but it seemed more complicated than just deleting most of gnu-build-system
<vagrantc>it just basically needs to unpack the tarball to the output, really.
<quiliro>I am a Lisp newbie...would someone explain this expression please:(define-module (bandali packages emacs) [...] )
<rekado>quiliro: this is a module definition
<rekado>it’s the first expression in a module file
<quiliro>rekado: thank you... what is (bandali packages emacs)
<quiliro>?
<rekado>this would be for a file named bandali/packages/emacs.scm
<quiliro>oh
<quiliro>ok
<rekado>(bandali packages emacs) is the name of the module.
<quiliro>thank you very much
<rekado>file name and module name have to match
<bandali>:)
<rekado>vagrantc: if the tarball doesn’t provide a directory at all then the build system might be a little confused.
<rekado>it tries to enter the first directory
<rekado>guess it can’t find that.
<rekado>in that case you may want to try url-fetch/tarbomb
<quiliro>so https://git.sr.ht/~bandali/guix-bandali/tree/master/henry/packages/emacs.scm would have (define-module (henry packages emacs) [...] ) ?
<bandali>yeah
<rekado>if the lookup root directory contains henry/packages/emacs.scm
<rekado>if you specify henry/packages as the root directory, then the module name would just be “(emacs)”
<vagrantc>rekado: tarbomb! that's what i was looking for. thanks.
*vagrantc knew such a thing existed, but didn't know what to look for
<quiliro>so the first element of (define-module [...] ) is the module name and it must correspond to the name of the file it is in?
<rekado>correct, including all directories under the root directory.
<quiliro>thank you...that explain so many things!
<quiliro>So '#:use-module (gnu packages emacs)' means to use the module 'emacs' in 'gnu/packages/emacs.scm' for that definition?
<rekado>it means to use the module (gnu packages emacs), which corresponds to the file at gnu/packages/emacs.scm
<rekado>the module name is not just ’emacs’ but ’(gnu packages emacs)’, because the root is the root of the Guix source repository, which contains the “gnu/” directory.
<quiliro>(define-public emacs [...] ) is in https://git.sr.ht/~bandali/guix-bandali/tree/master/henry/packages/emacs.scm
<quiliro>the module is (henry packages emacs) ?
<quiliro>i get it
<vagrantc>is "guix size" the size of the installed package+inputs+propegated-inputs, or the size of the package+inputs+propegated-inputs+native-inputs ?
<nckx>vagrantc: Neither; it's the size of the package (well, store entry)'s files + that of all the store entries it *refers* to (so all /gnu/store/… directory names embedded in those files), recursively.
<nckx>Where these embedded references come from is at that point irrelevant and not tracked, although as a human it's usually trivial to find out.
<vagrantc>hm.
<malaclyps>So, the manual to %setuid-programs at https://guix.gnu.org/manual/en/html_node/Setuid-Programs.html says ""The setuid-programs field of an operating-system declaration contains a list of G-expressions denoting the names of programs to be setuid-root", and suggests using #~(string-append #$shadow "/bin/passwd")
<malaclyps>but %setuid-programs which is the default set, consists of a bunch of <file-append> objects. I've ended up using " (setuid-programs (cons (file-append sway "/bin/sway") %setuid-programs)) " in my system config which seems to work.
<malaclyps>But I'm curious as to the difference between string-append and file-append in that context. Are they both equivalent g-exps?
<chipb>I'm no help to the actual question, but sway needs to be suid?
*chipb goes to look.
*malaclyps goes to check
<vagrantc>i thought one of the main advantages of wayland was it didn't require setuid/setgid stuff
<chipb>yeah, that's what I thought too.
<chipb>I vaguely remember it might have to do with grabbing input devices though.
<chipb>it does drop privileges early, but only after calling a wlroots setup function.
<chipb>and I got lazy about groveling the next source repo.
<malaclyps>yeah, it works fine without setuid if you use elogind
<vagrantc>hrm. how are one-off licenses specified?
<vagrantc>fsdg-compatible, i guess
<efraim>Or non-copyleft
<vagrantc>all of these require a link to a license, what if the license is just in the file shipped?
<vagrantc>it's very similar to a lot of simple licenses...
<vagrantc>ah, file:/// pointing to packages tree.
<rekado_>roptat: how can I get the pot file for a new texi file? If this is handled by the build system somehow I can’t seem to find it.
<rekado_>(I also couldn’t find it for guix.texi FWIW)
<apteryx>rekado_: isn't Guix non-Posix compliant anyway, given it doesn't follow the FHS
<roptat>Let me check
<roptat>rekado_: it's generated by doc-pot-update in po/doc/local.mk
<rekado_>apteryx: AFAIK POSIX doesn’t mandate the FHS.
<rekado_>roptat: hmm, okay. I have extended that target already, but didn’t get a file out of it. I’ll dig a little. Thanks for confirming.
<rekado_>I’m getting .po files, but no .pot file.
<rekado_>apteryx: https://pubs.opengroup.org/onlinepubs/9699919799/basedefs/V1_chap10.html
<rekado_>(I can’t find /bin/sh in that list, though)
<civodul>hi Guix!
<apteryx>rekado_: there's a part of it about shell and utilities, but I'd need to shell out 856 USD to access the PDF of the standard... eh.
<apteryx>this part: https://www.techstreet.com/ieee/standards/ieee-1003-1-2017?product_id=1989043
<apteryx>civodul: hello!
<rekado_>apteryx: you can access it here: https://pubs.opengroup.org/onlinepubs/9699919799/
<olivuser>Which packages to install to get yt and similar to run in icecat/epiphany? I installed gstreamer, gst-plugins, libmpeg and libmad, but no luck. Unfortunately, I dont even know how to look for those, since "codecs" does not really solve the thing...
<olivuser>That is, I cant find anything by searching for "codecs"
<janneke>olivuser: did you install gst-plugins-good?
<nckx>Yeah, try those. I have -base and -good (and gst-libav for HW acceleration) and have never seen a video that didn't play in IceCat [due to decoder issues, anyway].
<nckx>Hai Guix o/
<olivuser>janneke: yeah I did but it didnt work. nckx, installed base and good, but will try libav.
<nckx>Hm, that shouldn't make the difference though.
<olivuser>Maybe problem wont persist after restart, lets see...
<nckx>In fact, I don't think Guix's IceCat version supports acceleration at all yet.
*nckx tries ‘guix environment --pure … nicecat’; IceCat starts compiling; nckx will not be debugging IceCat today.
<olivuser>nckx: will tell you how things look after restart, pull and upgrade
<apteryx>rekado_: looks like Guix is indeed POSIX, but there (as you also pointed) doesn't seem to be a requirement to provide /bin/sh
<apteryx>thanks for the link!
<apteryx>nckx: I think even upstream Firefox doesn't accelerate videos... there's an upstream bug about it IIRC.
<apteryx>so does Chrome, last time I checked (about 1-2 years ago)
<nckx>apteryx: I read that support was coming soon, but didn't fact check it since I'm not interested in packaging newer FFs. If it comes to IceCat some day, great.
<nckx>It was somewhere on the FF bug tracker.
<nckx>I thought newest Chromiums did but don't use it 😛
<apteryx>can binaries built resulting from a guix package be safe to use *outside* of Guix? I'm thinking of making a libreboot package, and flashing the binary -- but I'm a bit wary of the binary keeping references to /gnu/store and failing to run. It's probably unfounded, but I'd like a 2nd guess-pinion.
<apteryx>unfounded in the sense that libreboot is probably a static binary that is desigend to be self-contained, no matter where it was built -- but I've yet to verify.
<civodul>apteryx: something like Libreboot (or GRUB, or U-Boot) should be fine to use on non-Guix, because these are programs meant to run on the bare metal
<civodul>so definitely "static binaries" since there's no OS at that point :-)
<raghavgururajan>Hello Guix!
<raghavgururajan>How to use both "--dry-run" and "--news" for 'guix pull'??
<rekado_>raghavgururajan: what’s the expected behaviour?
<rekado_>I’m disappointed in Info; I wished we could make the manuals look better in the info reader, especially Scheme examples.
<raghavgururajan>rekado_ I am trying to get information on new and upgrade packages without upgrading my guix.
<raghavgururajan>rekado_ When I do "guix pull --dry-run --news"; the command terminates without any output.
<rekado_>“guix pull --news” prints the news from the most recent run of “guix pull”.
<rekado_>it does not upgrade anything.
<janneke>rekado_: what would you like different in scheme examples?
<janneke>oh wait, you said info reader -- let me have a look
<janneke>hmm, looks similar as in emacs
<rekado_>I like to use variable-pitch-mode for prose, but a monospaced font for code.
<rekado_>I cannot do this in info
<rekado_>there’s also no syntax highlighting in the Info reader AFAICS
<rekado_>there are hard line breaks for paragraphs, and it’s not easy to change that without breaking code blocks and examples, because the markup appears to be unavailable.
<janneke>ah right; those are all not realy scheme specific, maybe someone would want to look at those ideas
<apteryx>civodul: great! This gives me some confidence to press ahead with those plans ;-)
<jbw1222>not fully sure about this, how do i set the nameservers on a system connected by ethernet using dhcpd? from what i gather i have to make a dhcpd.conf and pass it in the system configuration to the service?
<apteryx>hmm... say I reconfigure my system, changing my NTP service to go back from OpenNTP to NTP, then issue 'sudo herd restart ntpd'. Should the old service be killed correctly? Or what is supposed to happen?
<apteryx>In my case, Shepherd attempt to start the NTP ntpd binary, which failed because it tried listening on the same address as the non-terminated OpenNTPD binary.
<janneke>hmm, font-locking through indirect buffers does not work
<janneke>rekado_: ah, that answers my unasked question /me reads cookbook
<Minall>Hello guix!
<sneek>Minall, you have 1 message.
<sneek>Minall, nckx says: Have you read https://github.com/relan/exfat/issues/77 ? This does not sound like something we can safely enable by default (even if other distributions do) unless things have changed (which https://github.com/relan/exfat/issues/132 seems to deny).
<nckx>sneek: You get half a botsnack because I left 2 messages.
<sneek>:)
<janneke>nckx: did you remember to give sneek a snack after the first? ;-)
<nckx>The other one being: don't get your hopes up about upstream kernel exfat drivers, the code submitted by MS is apparently crap, IMO FUSE will be the safest option for the coming year(s).
<nckx>janneke: Oh, so now it's my fault, got it ;-)
<nckx>sneek: Veel noten op je zang, hé, jij.
<Minall>Hello guix!
<Minall>Thanks for the response over exfat, but I made some tests on my device, and it seems to have some problems
<Minall>Maybe that's why it doesn't mount
<apteryx>now I tried a roll-back, and the modified NTP service doesn't seem to be reloaded
<apteryx>hmm
<janneke>nckx: hehe
<janneke>just wondering how intelligent sneek might actualy be ;)
<spk121>hello guilers. What is the best way to draw a plot in Guile. For my GUI project, I'm going to make a plot of memory usage as a function of time.
<spk121>oops, sorry , hello Guixers
<raingloom>hey, i'm running into some issues with sshfs, could that be related to the timing issues discussed on the mailing list?
<raingloom>(getting "connection reset by peer" even though it should definitely be working)
<raingloom>hmm, ok nevermind, it seems to work now..... but i'm not sure it isn't about to break again
<joshuaBPMan>morning guix! Is anyone here brave enough to run bcachefs?
<olivuser>nckx: so I rebooted and did üu
<olivuser>Did pull/upgrade. Still, it doesnt work, unfortunately (watching videos online)
<olivuser>could the problem be that I installed the codecs after icecat and not beforehand?
<olivuser>Also, another question: emacs docview seems to not work. I installed mupdf, ghostscript and imagemagick, but still I cant open a pdf file - all I see is the "underlying" code.
<jlicht>hi guix
<civodul>rekado_: yeah i'm disappointed with Info and the lacks of any plans other than browser + JS
<civodul>syntax highlighting and text reflowing aren't too much to ask from an Info reader, IMO
<janneke>that should not be too much work, at least for the emacs viewer
<civodul>nckx: did you have a chance to see why sergei/dmitri aren't reachable? :-)
<civodul>janneke: we'd need a different input format though
<civodul>since Info is inherently preprocessed text
<janneke>makeinfo could produce a cookie just like it does for images
*janneke added images to info in lilypond times
<civodul>yeah
<civodul>i very much think that (s)texi could be processed live nowadays
<janneke>something like [example code="scheme" ...] ... [example-end ..]
<civodul>ah yes
<janneke>yeah, that would be nice
<civodul>maybe that'd be easier to achieve
<janneke>can emacs do font-lock for a different mode in a part of a buffer?
<civodul>janneke: i think so, because it can do that in Org
*civodul tweaked gnu.org/s/gnulib/manual.css a bit
<janneke>civodul: okay, then it should be pretty doable
<civodul>yay, that alone would be a great improvement
<janneke>i'm not really looking for another extra thing to do atm :)
<civodul>heh :-)
<Marcelo>Getting to know (and installing) Guix for the first time ... Can anyone guide me how to install Portuguese language packages on LibreOffice (libreoffice-l10-pt-br and libreoffice-langpack-pt-BR-x.x86_64) and also how to install translator extension automatic in web browser unglooged-chromium?
<janneke>Marcelo_Lagoa: i do not think we have language packs for libreoffice
<janneke>oh
<Marcelo_Lagoa>Hello.
<Marcelo_Lagoa>I have long been looking for a complete distribution, full of packages, but totally free of proprietary software ...
<Marcelo_Lagoa>I'm getting to know GuiX now and installing it for the first time. On other machines, I have Debian, Slackware and ArchLinux installed. But I was delighted with the GuiX Distribution!
<Marcelo_Lagoa>I need to make some adjustments to the System and I need to ask "novice" questions.
<Marcelo_Lagoa>I want to know if I'm on the right chat channel, or if there's another channel dedicated to GuiX, but one that is geared to simple newbie questions. :)
<vagrantc>Marcelo_Lagoa: sounds like you're in the right place
<vagrantc>if you don't get a response, there's also the help-guix@gnu.org mailing list
<Marcelo_Lagoa>Ok vagrant! Thanks for listening. I am also a newbie when using IRC channels for communication. For the first time I installed pidgin to communicate.
<Marcelo_Lagoa>My questions are simple:
<Marcelo_Lagoa>I need to configure the "Portugues" language pack in LibreOffice and, if possible, an extension for automatic web browser translation (ungoogled-chomium). I don't know how to proceed, because in other distributions the setting for my language was automatic ...
<janneke>Marcelo_Lagoa: i do not think we have language packs for libreoffice
<Marcelo_Lagoa>janekke: On the LibreOffice website there are downloadable packages (libreoffice-l10n-en and firefox-locale-en) In other distributions, I think you just have to download and click on the package to add the language. But as GuiX does a different and isolated installation for each user, I imagine that the way to install is different too.
<Marcelo_Lagoa>janekke: Fixing: where it reads (libreoffice-l10n-en and firefox-locale-en) Consider libreoffice-l10n-pt_BR and firefox-locale-pt :)
<janneke>Marcelo_Lagoa: i have no idea, you could try if it works like that, but you are right: downloading plugins is not reproducible and thus not guix'y; you'd want support from guix and an installable package, an importer maybe
<Marcelo_Lagoa>janneke: Exactly! But since I still don't know how to operate GuiX, I imagine that to install a language pack you need an importer. So is it possible that there is no such feature in GuiX?
<janneke>Marcelo_Lagoa: i had a quick look and did not find anything, but i'm not a libreoffice user and i don't use native language settings.
<janneke>it's not usually so quiet here :)
*vagrantc bangs on some pots and pans
<janneke>haha
*vagrantc has been on an obsessive, er, productive hunting down of diffoscope related dependencies in guix
<vagrantc>i've been wondering if i should send more patches through review, but kind of got on a roll
*janneke has been working on a mes-0.20 release, almost ready to go
<vagrantc>nice!
<vagrantc>i saw nyacc was updated since i last tried building mes on Debian
<vagrantc>updated upstream ... think i was using nyacc 0.94, there's now 0.99
<janneke>mes 0.20 works with nyacc 0.99
<vagrantc>ok, i'll update that in debian then
<janneke>it also works with 0.94, so no hurry
<nickey>hi everybody! i'm trying to build package with cmake. this package has no tests. but I got message about failing "check" phase. how to disable it?
<janneke>nickey: use ... (arguments '(#:tests? #f))
<nickey>janneke: yes, that's what I was searching for, thanks!
<Marcelo_Lagoa>Ok, ok, janneke and vagrantc. I do not have LibreOffice "in Portuguese" in my Guix installation yet, but I will continue looking for the solution. Thank you so much for your attention. I will let you work in peace without diverting your attention. But just one last question (out of curiosity) for the conversation I read here, will soon have an official Debian version working just like Guix (installation of declarative package
<Marcelo_Lagoa>??
<vagrantc>Marcelo_Lagoa: i've been working on packaging guix for debian: https://bugs.debian.org/850644
<vagrantc>you can install guix on top of another distro and use what parts you want from it
<rekado_>vagrantc: don’t worry about review too much, especially when you’re confident about the packages, you’re being productive and happy, and you’ve taken precautions (like “guix lint”).
<vagrantc>rekado_: thanks for the encouragement :)
<vagrantc>my guile skills are still pretty much cargo-culting, so i have plent of doubts :)
<vagrantc>plenty
<vagrantc>but i've kind of learned the set of things i might need for guix packages
<rekado_>in this case cargo-culting is an uncharitable way of saying that you learned by adapting code from existing package definitions. I think that’s exactly what we want :)
<vagrantc>fair enough :)
<nickey>hm... I used guix on my arch installation to build some qt software. It builds now, but uses default qt theme. Is there way to make it use my system qt configuration? fonts, colors, etc
<nckx>civodul: Hi. Home. Minicomming now.
<nckx>nckx@dmitri ~$ sudo herd status → Stopped: - ssh-daemon 🙂
<nckx>Any useful data I can gather before starting it again?
<nckx>I think IPv6 was mentioned as a factor?
<vagrantc>i can't seem able to import some modules into package-management.scm: https://paste.debian.net/1099564/
<vagrantc>lots of unbound variable errors
<nckx>That, unfortunately, is what infinite recursion looks like.
<vagrantc>normally, i'd assume i missed a paren somewhere ... but adding a single use-module line *shouldn't* mess up the balance of the parens
<vagrantc>ah.
<nickey>do anybody use guix outside of guixsd?
<vagrantc>nckx: are there workarounds?
<vagrantc>nckx: i mean, workarounds worth pushing?
<nckx>vagrantc: Hm, #:select? I'm super-tired and brain blah no blerg.
<nckx>I'm also assuming there really is no sneaky syntax error. It *could* be a missing bracket, I'm taking your word that it's not. #:use-module () shouldn't mess that up, no.
<nckx>vagrantc: Pastebin the offending file, perhaps?
<vagrantc>nckx: it's just the one-liner patch against master ...
<janneke>nickey: yes, people do. i started out like that.
<nckx>vagrantc: OK! Would #:use-module ((gnu packages foo) #:select (the-one-package-you-need)) work?
<nckx>nickey: One very large Guix deployment is Guix-on-RHEL.
<janneke>vagrantc: i can reproduce it...very weird at first sight
<nckx>vagrantc: That would be an example of an acceptable work-around.
<efraim>Sneek later tell apteryx I remember now there's a permissions issue with some directory switching between ntpd and openntpd. Unfortunately I don't remember the directory off hand
<sneek>Will do.
<janneke>vagrantc: hmm, comment-out ;; #:use-module (guix build-system android-ndk) in android.scm and the weird error goes
<janneke>so yes, there is probably a recursive import problem
<sirmacik>hey guix
<sirmacik>how to run docker daemon with shepherd?
<efraim>vagrantc: is ghc an input for diffoscope now? IIRC it's intel only until we get it supported on arm
<vagrantc>efraim: oh, it's for the test suite, so it's "optional"
<vagrantc>efraim: it could easily be made conditional
<janneke>efraim: i cannot install guile for armhf-linux from current master, is that right?
<janneke>i mean, i don't get a substitute
<efraim>vagrantc: conditional per arch might be best then
<efraim>janneke: I heard there were no substitutes for it. Unfortunately my aarch64 board is down and I haven't had time to work on it
<efraim>sneek: botsnack
<sneek>:)
<janneke>efraim: okay, thanks. i was hoping you had a commit for me that works (32 bit arm)
<vagrantc>nckx: #:use-module ((gnu packages foo) #:select (the-one-package-you-need)) ... didn't work at least for abootimg
<nckx>vagrantc: As in the same failure?
<vagrantc>nckx: yes
<quiliro>I am using Magit on Emacs...I have characters such as ñ and í correctly rendered on Emacs but on Magit they are shown as ñ and dà . What is the problem?
<vagrantc>in somewhat related news, i'm trying to also add zip to native-inputs, but ("zip" ,zip) conflicts with zip from srfi-1? how do i specify the package rather than the thing from srfi-1 ?
<vagrantc>is there some sort of "import as" functionality?
<quiliro>I am using Guix System with emacs, emacs-magit and git packages installed as user by the way.
<nckx>vagrantc: ,(@ (gnu packages compression) zip) is ‘import from’.
<vagrantc>nckx: thanks!
<nckx>vagrantc: But!
<nckx>I'd much prefer #:use-module ((srfi srfi-1) #:hide (zip))) if possible.
<civodul>nckx: hi! yes, investigations are still underway, but perhaps you can see hints in /var/log/messages?
<nckx>civodul: OK, I'd already restarted SSH anyway.
<nckx>I'm now pulling so I can reconfigure with a ludo (and other sysadmin) accounts.
<nckx>Pulling takes ages on these things but it's been more than a month; seems prudent.
<nickey>Ok. If there are some people used guix on non-guix distros, that's the case: I plan to use guix on few office machines to build our packages from source code on Ubuntu. But resulting binaries are not Ubuntu-looked at all. It uses the default qt configuration, not Ubuntu one. Is there way to fix it? Or the only solution is to recreate Ubuntu ui configuration inside of guix profile?
*janneke runs guix gc --delete-generations=12m
<vagrantc>nckx: ("zip" ,(@ (gnu packages compression) zip)) worked! haven't tried the #:hide approach
<janneke>vagrantc: i think i would try moving diffoscope to its own module and see if that fixes the android import problem
<civodul>nckx: sounds good, thanks!
<janneke>nickey: recreate it inside guix is the way to go; guix is supposed to work as a closed/self-contained system
<nckx>vagrantc: It does work, and it's an answer to your ‘Is there some sort of import from’ in Guile, and it works, but it's also not considered great style. Hence my #:hide suggestion.
<vagrantc>hrm. now that i committed, it doesn't work. hrm.
<vagrantc>nckx: i have no idea how to figure out where srfi-1's zip might be used, but i hear you.
<nckx>That said, I see there are examples of both in the tree, so go with whatever rocks your boat I guess.
<nickey>janneke: that's sad. but thanks.
<nckx>civodul: Can you now SSH into dmitri.tobias.gr:5552?
<janneke>nickey: why is that sad? it means that any guix deployment will always look the same, anywhere. you just might succeed in leaking something from your foreign distro into guix (using environment variables, e.g.), but that means your reproducibility is out of the window
<civodul>nckx: yes i can!
<civodul>but one of them was supposed to be 5551, right?
<nckx>That's sergei (I know, it's unintuitive and unalphabetical, but not worth changing now). I haven't swapped USB ports yet.
<nckx>If dmitri is servicable over SSH, I will.
<civodul>ok :-)
<civodul>actually i can't log in as "hydra" there
<civodul>not by public key
<janneke>vagrantc: if you comment-out "#:use-modules (srfi srfi-1)' and run make, you'll see only `fold' and `alist-delete' are used from srfi-1
<civodul>oh i can log in as myself, nvm nckx
<nckx>civodul: OK, will check out.
<nckx>OK, even better 🙂
<janneke>vagrantc: also, zip is a pretty exotic function, not used very much
<nckx>(hydra is in the user list, so that's not supposed to happen, but probably easily fixed.)
<civodul>nckx: ah but then i can't sudo because i don't have a password
<nckx>Heh.
<nickey>janneke: it's sad because of we will continue using deb-packages for software delivery. I wanted to show my company how we can use guix instead, but it seems like too much work to switch for now.
<vagrantc>janneke: splitting diffoscope into it's own module seems to work!
<janneke>vagrantc: nice
<nckx>civodul: System configuration is in /etc/guix/system.scm for now. I do plan on merging the system configuration back into maintenance once the machines are productive. It just needs some care since they don't share, for example, file system layouts/types with other OverDrives.
<vagrantc>janneke: of course, now i need to figure out what isn't used...
<janneke>nickey: yes, full reproducibility comes with a price, often that's doing more work up front. if you (or your client/company) fully appreciates reproducibility, then it's a more easy price to pay. do you know what must be done to get that same look, is it theming?
<vagrantc>354 passed, 68 skipped ... was originally ~140 tests skipped :)
<nckx>Nice.
<janneke>vagrantc: yes...and very nice
<vagrantc>so, should i split diffoscope out, then?
<vagrantc>not yet done that before
<nckx>vagrantc: Clean up the module imports in both the old and new file (I'd delete most from the new one, then work my way up until it works again, then see which of those can be removed from the old file, if any). Adjust the copyright headers. Then add your new file to GNU_SYSTEM_MODULES in gnu/local.mk. I think that's all…
<nckx>Sounds more complicated than it is, the module dance is just tedious.
<vagrantc>yeah, figured that would be about it.
<vagrantc>i guess i should move trydiffoscope with it
<nckx>Yes.
*vagrantc always wondered why it was in package-management anyways
<nckx>Honestly, I thought that was your choice 😃
<nckx>Since you seem to be the de-facto diffoscope maintaner, for which many thanks, I use it daily.
<nckx>s/the/our/
<janneke>possibly because it uses rpm/dpkg?
<nckx>It uses anything you let it get near to, TBH.
<janneke>but it's a weird place--possibly the wrong place--anyway
<nckx>No coincidence that it ended up with a module cycle.
<janneke>oh, some Ludovic person put it there :)
<janneke>right after adding rpm, the plot thickens
<quiliro>I think my problem with some characters is of the whole desktop...not only of emacs...for example i get this character 】 rendered correctly on emacs but incorrectly on icecas (as a box with the numbers 3011 inside it....and in emacs does not display characters such as 😃 (I see a box with the numbers 01F603)
<nckx>quiliro: All I can say is that 】 renders correctly in my HexChat, termite, IceCat (both in the chrome and on pages), and emacs…
<janneke>could it be a `fc-cache -f' problem?
<vagrantc>nckx: i didn't do the initial diffoscope upload, just started maining it relatively recently
<nckx>My locale is zh_CN.utf8 and I do have All The Fonts installed though, so I'm not the best reference. But I prove that it is possible!
<quiliro>janneke: after several restarts that is still needed?
<vagrantc>nckx: when i noticed it was out of date ... :)
<quiliro>nckx: All the fonts? how many are there?
<vagrantc>nckx: glad to hear it's useful to you! :)
<quiliro>nckx: is it something that will make my core2 machine slow?
<nckx>quiliro: grep font- ~/.config/guix/manifest.scm | wc -l → 33, although my list might be out of date. And not every ‘font-’ package in Guix is a font.
<vagrantc>but yes, diffoscope is rather hungry about dependencies, and rather tolerant if they're not available.
<nckx>quiliro: Fonts in general won't slow down your applications (noticably), but profile generation will be affected: Guix has to build a font index, more fonts = longer indexing.
<nckx>I have ‘font-mathjax’ commented out for exactly that reason: it made profile generation downright pathological, so every ‘guix install’ & friends took ages.
<nckx>Buying an SSD make a big difference too.
<nckx>Me speak English good. *made
<janneke>quiliro: after installing fonts you may have to run fc-cache, it could be that a fancy desktop such as gnome-shell does that for you, i have no idea
<janneke>*fc-cache -f
<nckx>And if /var/cache/fontconfig/ exists, delete it (as root).
<quiliro>nckx: why delete that directory?
<nckx>quiliro: Because it exisiting at all is a bug I haven't tracked down yet.
<nckx>It will break your font rendering, because fontconfig will treat (in fact: prefer) it as valid cache while unable to actually update it with fc-cache, so it will contain lies.
<quiliro>ok...so delete that directory and then fc-cache -f
<nckx>quiliro: Did it exist? Interesting!
<quiliro>it exists
<quiliro>i have not deleted it yet
<quiliro>it has ten elements
<quiliro>i did already run fc-cache -f as janneke advised
<quiliro>nckx: do you need something from that directory i can help with?
<nckx>quiliro: Thanks for the reminder. I see I have it again, too (created 2 days ago). It doesn't break fonts immediately, but if you ever have font problems it's likely that deleting that directory and running fc-cache -r will fix them.
<nckx>quiliro: I don't think so, but thanks for the offer.
<quiliro>i have nine elements of the style [...]-le64.cache-7 and one of name CACHEDIR.TAG
<quiliro>
<nckx>quiliro: Same, 3 .cache-7 files. (CACHEDIR.TAG is just that, a tag that tells e.g. backup software to ignore the directory.)
<quiliro>sudo rm -rf /var/cache/fontconfig
<quiliro>is that correct?
<nckx>Yes.
<quiliro>and fc-cahe -r as user
<quiliro>*fc-cache
<nckx>Yes. That will make any new fonts you've installed ‘visible’ to programmes (you may need to restart them).
<quiliro>is restarting emacs necesary?
<quiliro>😃
<quiliro>i still see that box
<nckx>You'll still need to *install* the right fonts, though. And I don't know an easy way for me to check which font renders 】.
<nckx>I'm sure there's an M-x for that.
<quiliro>i do have that one
<quiliro>but not 😃
<quiliro>i guess it is a problem with all my guix system, not particulaly of emacs
<quiliro>】 i can see on emacs but not on icecat
<quiliro>how weird
<nckx>Ah, that's a disembodied laughing head emoji (https://unicode-table.com/en/1F603/). It shows up for me everywhere *but* emacs.
<nckx>Emacs is just Special, I gave up trying to fix it when the elisp snippets people suggested I add to my .emacs started to exceed ~50 lines.
<quiliro>how about 】 ? does it show on your icecat?
<nckx>quiliro: Yes, as noted above, it shows both when I paste it into my address bar and on a HTML page.
<quiliro>ok...so i could add fonts and get it fixed on icecat
<nckx>But that's a common symbol in Chinese writing, and my locale *is* Chinese, so that might be a factor…
<quiliro>but my problem with ñ or í is weird....because on magit i have the problem but not on other parts of emacs
<nckx>I wish I could tell you which fonts render which characters here, but I don't know of a way to do so.
<nckx>quiliro: Yeah that's just weird. That sounds like a local problem, not a font problem.
*nckx → work a while.
<nckx>*locale…
<civodul>nckx: ok, once we've factorized things, hopefully we can "guix deploy" the whole shebang!
<civodul>until then, good night!
<nckx>Oh yes! That didn't even exist then. Very cool.
<nckx>Good night o/
<rekado>hmm, I just managed to display 😃 in Emacs…
<rekado>but it’s not how I expected it to happen.
<rekado>I selected Font Awesome as the default (which is not a good idea because everything is rendered as boxes) and then switched to DejaVu Sans
<rekado>and that’s when the smiley appeared.
<rekado>this works: (progn (set-frame-font (font-spec :name "Font Awesome")) (set-frame-font (font-spec :name "DejaVu Sans")))
<rekado>but using “DejaVu Sans Mono” instead does not.
<rekado>weird
*rekado —> zzZZ