IRC channel logs

2019-08-05.log

back to list of logs

<Nick832423> https://git.ucode.space/Lukas/idea/src/branch/master/build.xml here is the build file
<Nick832423>what target should i choose and how?
<Nick832423>figured out ...somehow
<Nick832423>no i didnt please help
<atw>Nick832423: I've been skimming the logs but may have missed something. Would you mind summarizing for me what your present problem is? Thanks!
<Nick832423>i want to build IDEA
<Nick832423>and i created this file
<Nick832423> https://pad.riseup.net/p/bZPnKdOV-it5u8GO9Kzi
<Nick832423>dont know how to make it work
<atw>alright, giving it a try now...
<atw>my first impression is that this is a nontrivial piece of software written in Java and as such it will be nontrivial to package. I don't mean to discourage, but I don't think I'll be able to do this.
<Nick832423>i really need it for work
<Nick832423>i mean pkill helped me to get the bins running but i would like to package it
<atw>to be clear, you have it running but not in a very guix-native way?
<Nick832423>yeah.... very hacky
<Nick832423>i thought "its open source, lets package it for guix so other can work with it"
<atw>:) love it!
<Nick832423>sandly im too noob to do that on my own
<atw>I think this may be a hard thing to package, so I just wanna put that out there. Personally, I have things that I want to package that are still too hard for me, and some of them I've kept in the back of my mind for a couple years. So I want to say up front that if this is too hard, you can always come back to it later
<Nick832423>but i want to learn now
<PotentialUser-15>hey does anyone know how well amd gpus work on linux libre? i know there are free drivers. they should work ootb right?
<Nick832423>as a user, i would love to run software without problems
<atw>I have some ideas of what might be amenable to first-time contributors (and other people, please chime in): if the software you're building can be built with one of the existing build systems (https://guix.gnu.org/manual/en/html_node/Build-Systems.html), and most/all of its dependencies are already packaged.
<Nick832423>as a programmer, i would love to keep GuixSD
<atw>that said, back to IDEA -- I'm in the process of using your package definition now. I'll let you know when I know more...
<jfred>Quick question, I've got libhandy building through guix and passing everything in guix lint now. However, I don't have anything packaged that actually uses it, so I can't be sure it works as expected. Would it be advisable to submit what I have to guix now or wait until I also have something that depends on it?
<Nick832423>thank you atw
<atw>sneek: later tell Nick832423 do you see something like this in your guix build output: "[exec] Exception in thread "main" java.lang.RuntimeException: Could not create parent directory for lock file /.gradle/wrapper/dists/gradle-4.10-all/1m1pt0798cerxan3h64dm1dvn/gradle-4.10-all.zip.lck"? If not, could you use a pastebin to share your build output? thanks!
<sneek>Okay.
<atw>jfred: I say go for it! worst case, its inclusion will delayed until its needed :)
<jfred>fair enough!
<apteryx>I was somewhat confused when I read: (bootloader-configuration-bootloader (operating-system-bootloader os))
<apteryx>but operating-system-bootloader returns a <bootloader-configuration>, so now that I get this it fits better in my mind.
<apteryx>but then there is also operating-system-bootcfg in (guix gnu system)
<Marlin[m]>hi guix
<Marlin[m]>how can i use my desktop to build substitutes for my laptop?
<jackhill>Marlin[m]: sorry, I can't stay long, but wanted to give you some answer: look up offloading in the manual: https://guix.gnu.org/manual/devel/en/html_node/Daemon-Offload-Setup.html#Daemon-Offload-Setup
<jackhill>there are other options two, like using `guix copy` to copy over targeded substitutes that exist on your destkop.
<enderby>hi, i keep getting this error: "cc1: error:
<enderby> /home/username/.guix-profile/etc/profile/include: Not a directory"
<enderby> any idea what's up? it's happened for two different installs I've
<enderby> tried to do. I'm using guix on debian
<jackhill>or using `guix publish` on the desktop, and configuring the laptop's daemon to use it as a substitute URL. Hopefully that's enough to get you started.
<atw>dear log maintainer: my link in http://logs.guix.gnu.org/2019-08-05.log#012742 got parsed a little weirdly
<Nick832423>morning, im back
<sneek>Nick832423, you have 1 message.
<sneek>Nick832423, atw says: do you see something like this in your guix build output: "[exec] Exception in thread "main" java.lang.RuntimeException: Could not create parent directory for lock file /.gradle/wrapper/dists/gradle-4.10-all/1m1pt0798cerxan3h64dm1dvn/gradle-4.10-all.zip.lck"? If not, could you use a pastebin to share your build output? thanks!
<Nick832423>atw let me check
<Nick832423>yes
<Nick832423>how do i make this message thing?
<Nick832423>sneek: later tell atw yes i get the same message in the init build
<sneek>Got it.
<Nick832423>:)
***MinceR_ is now known as MinceR
<roptat>hi guix!
<Nick832423>ohaio
<apteryx>Marlin[m]: you could configure your desktop as an offload machine to build substitutes on demand.
<apteryx>it's documented in the manual
<pkill9>how can i access the package description in the build-system's builder code?
<efraim>from the build side or in a custom phase?
<pkill9>from the build side
<Nick832423>hey pkill9 thanks again for creating fhs
<Nick832423>very useful, would love to see this in guix oficially
<Nick832423>i the meantime i tried building IDEA for Guix
<pkill9>cool, so it worked for you Nick832423? i would like to see it in guix officially as well
<Nick832423>i know atw is on it too but maybe you know how to solve this bug
<Nick832423>"[exec] Exception in thread "main"
<Nick832423>java.lang.RuntimeException: Could not create parent directory for lock
<Nick832423>file
<pkill9>my immediate guess is that it's trying to create a directory in /var but your user doesn't have permission to do so
<Nick832423>sudo then?
<pkill9>i would find out what directory it's trying to create and then create it with your user's permissions
<pkill9>what program is causing the error? what ar eyou trying to do?
<Nick832423>running https://pad.riseup.net/p/guix-idea
<Nick832423>with guix build -f
<roptat>Nick832423, if it during the build process, then sudo won't help
<Nick832423>hm
<roptat>because the build process is isolated from the system, it doesn't have access to /var and suc
<roptat>such*
<roptat>you'll have to pass a parameter or patch something so it doesn't try to create that directory
<Nick832423>how do i create a package from a nix code?
<roptat>Nick832423, also I think it just won't work, because the first step of the ant build file is to download gradle
<roptat>you would need to use gradle instead, but we don't have it yet
<Nick832423>oik
<Nick832423>there is a nix package tho
<Nick832423>how do i convert that=?
<roptat>no idea
<Nick832423>:(
<roptat>the only time I looked at a nix package for inspiration, I simply rewrote a few phases in guile, but nothing automatic
<roptat>there's a nix importer, but I think you need a running nix installation for it to work
<roptat>and I really don't know what it does
<roptat>also, nix doesn't have the same standards as guix when it comes to packaging
<roptat>we try very hard to build everything from source, to bootstrap everything
<roptat>this not something java developers are used to (and not only in Java world), so it's very difficult to build anything
<roptat>I'm making progress towards a maven-build-system at the moment, which should help for a lot of java packages, and later for gradle
<roptat>I've already worked on gradle itself too, but I didn't finish it yet, because it depends on scala and kotlin, too languages that are not in guix yet (scala is not bootstrappable, but it might be possible to patch it out of gradle, and kotlin is a bit complicated, but should be doable)
<roptat>it's just going to take time, as I can only work on this on my free time
<xavierm02>why isn't scala boostrapable?
<roptat>because it's written in scala
<xavierm02>hm
<roptat>and the first version of scala 2 was built with a scala 1, which was built using the pico compiler, for which no source is available
<roptat>I'm going for lunch, be back in 1-2 hours
<xavierm02>I wouldve thought that it would'nt be too hard to compile scala to java
<Nick832423>maybe i should switch distros
<Nick832423>i am not as comfy with guix as i used to be
<rekado_>xavierm02: and the scala that was used to write scala was not written in Java, but in Pizza.
<rekado_>Pizza, of course, was written in Pizza.
<rekado_>but the earliest Pizza that we would need to use to make a newer Pizza is non-free.
<rekado_>non-free pizza is the worst.
<efraim>there's really a language called pizza?
<efraim>rekado_: I wanted to ask you about edirect, is edirect the only binary that's supposed to be installed?
<mzan>efraim: in case it was a real question: yes https://en.wikipedia.org/wiki/Pizza_(programming_language)
<efraim>yeah, pizza was a real question
<erudition>The pizza is really nonfree?
<erudition>🍕 🚫
<rekado_>efraim: re edirect: I don’t know.
<rekado_>I packaged this for a colleague. Don’t know how to use it myself.
<rekado_>seemed like it was enough to install just edirect.
<rekado_>at least that’s the only thing my colleague used.
<efraim>As long as they're happy. Seems there's about 30 different scripts in the source tarball
<efraim>I can always ask Pjotr if he needs more of them
<pkill9>eating nonfree pizza means it's you that gets eaten
<rekado_>heh
<roptat>rekado_, I've only found slides that say scala was inspired by pizza, not that it used to be written in pizza though
<roptat>and I think I found a free software implementation of a pizza compiler too
<roptat>but looking at the code, it seemed a bit different from pizza (I don't fully remember why), and the compiler used was called pico
<roptat>I think pico had its own language but its sources were never released
<roptat>ah this: http://lampwww.epfl.ch/~zenger/jaco/
<roptat>"JaCo is written with PiCo, an extension of itself. PiCo maps Java + extensible algebraic types to Java bytecodes. This distribution also contains the base Java compiler JaCo."
<roptat>and it's a bit deceptive because pico file extension is .java
<roptat>but for instance here, https://github.com/scala/scala/blob/5416b938cb44619966d4419f8baa5eaaa274792b/sources/scalac/transformer/Erasure.java
<roptat>I don't think this can be compiled by openjdk
<roptat>the switch case in transform is not correct java code
<roptat>(this is from scala 1.1.0-b0)
<roptat>oh, and https://en.wikipedia.org/wiki/Pizza_%28programming_language%29 says pizza is free software
<roptat> https://contributors.scala-lang.org/t/question-about-building-scala-and-sbt-proper/2811
<roptat>(answer #10)
<roptat>but anyway, it's only used as a library in gradle, because gradle can build scala code. It's a bit tied into gradle, but we should be able to get rid of scala in gradle for now
<rekado_>roptat: later versions of Pizza are free software.
<rekado_>early versions (needed to build later versions) are not.
<rekado_>I only stumbled upon Pizza because it was one bootstrap path to a legacy version of Scala.
<rekado_>(found a reference to Pizza in the legacy repo)
<xavierm02>I just wasted an hour recompiling LyX because my package failed at the last phase, because there was a comma missing somewhere >_<
<xavierm02>But this time I'm even more sure it'll work than last time
*rekado_ tests the Emacs patches by Brian
<apteryx>I'm working on making VMs fully definable through a config file
<apteryx>including the file systems / partitions. This to allow writing tests for my Btrfs subvolume support patch.
<apteryx>currently we have only a hardcoded root partition on ext4 for VMs
<xavierm02>It built!
<mbakke>xavierm02: congrats!
<mbakke>apteryx: awesome! :)
*mbakke wants to have F2FS and XFS support, too
<xavierm02>Alright. My LyX *finally* works!
<xavierm02>Here's the diff: http://dpaste.com/0KNPD9D
<xavierm02>It'd be awesome if some could take a quick look to tell me if there's something I should change before sending that to the patch mailing list
<apteryx>mbakke: should be easy to add after my changes if it succeeds!
<rekado_>xavierm02: nice. It would be good if we could avoid having to set LYX_DIR… when the wrapper is used. Do you know why it is needed?
***chris1 is now known as chrislck
<xavierm02>rekado_: Well without it LyX crashes because it doesn't find that directory.
<xavierm02>rekado_ I'm not sure why
<rekado_>how does it crash?
<xavierm02>rekado_: I think I can remove the LYX_DIR from the wrapper by patching the lyxeditor file, because it has a variable LYXSYSDIRS that contains the common paths for the sysdir.
<xavierm02>(I'm compiling the lyx without LYX_DIR set to get the exact error)
<xavierm02>But I couldn't find a way to avoid setting the QT_PLUGIN_PATH variable. And this seems to be a common problem because many qt apps in LyX use a wrapper
<xavierm02>rekado_: Here is the error http://dpaste.com/0CA3B84 (which appears in a prompt window)
<xavierm02>And the same thing is written in the terminal
<xavierm02>I think that the problem is that it searches a relative path with respect to the binary, and the wrapper and binary are not in the same file. http://dpaste.com/329VSYS https://wiki.lyx.org/LyX/ManPage
<xavierm02>rekado_: Would patching a file to change the "default" sysdir path it searched be considered better?
<jfred>rekado_: thanks for the libhandy merge/modifications! :) I'm still getting used to how flexible guix is, and it's helpful seeing those changes for a package I'm already familiar with
<apfel>hi there, everytime i ran guix system init on a target btrfs subvolume tree i get an error saying that bash-static was not found. guix gc --verify=repair installs it again. But guix system init keeps deleting it... i am confused, how can i debug that?
<raghavgururajan>Hello Guix!
<apfel>ok... i mounted the same subvol which contains the /gnu two times, but this did not work out
<apfel>yea, that fixed it
***xnv is now known as xnv_
<PotentialUser-96>any news on IDEA on Guix?
<Lukas4452>how do i import stuff from nix?
<xavierm02>Lukas4452: There is a nix package for guix, and then you can use nix normally. And there's guix import nix
<xavierm02>sneek help
<rekado_>xavierm02: wrapping the executable in QT_PLUGIN_PATH is fine.
<xavierm02>sneek: tell Lukas4452 There is a nix package for guix, and then you can use nix normally. And there's guix import nix
<sneek>Lukas4452, xavierm02 says: There is a nix package for guix, and then you can use nix normally. And there's guix import nix
<rekado_>xavierm02: I still don’t understand why LYX_* need to be set as soon as you wrap the executable, though.
<rekado_>xavierm02: use “later tell”
<xavierm02>sneek: later tell Lukas4452 There is a nix package for guix, and then you can use nix normally. And there's guix import nix
<sneek>Okay.
<xavierm02>thx
<rekado_>xavierm02: wrapper and binary are not the same file, but they are in the same location, no?
<xavierm02>rekado_: No. There's an extra /lyx2.3 for the binary
<xavierm02> http://dpaste.com/329VSYS
<Sharlatan>Hi, is there already existing gnu/packages/*scm file for Rust packages?
<jackhill>Sharlatan: there is crates-io.scm
<Sharlatan>@jackhill not a loot packages :-D
<jackhill>Sharlatan: yeah. I haven't tried working with Rust packaging yet, but I understand it's still a work in progress.
<jackhill>Is thee something you're interested in packaging?
<Sharlatan>Some small group in Russian Guix comunity is working on packaging now, I'm part of it when have time. There are fiew good once I want to have in Guix such alacritty, exa, rg
<Sharlatan>We have a group in Telegram t.me/gnu_guix_ru
<jackhill>Sharlatan: cool, sounds like fun