IRC channel logs

2019-06-20.log

back to list of logs

<vagrantc>looks good to me
<bavier`>Swedneck: that should work
<Swedneck>thanks
<Swedneck>guix seems promising, hopefully it gets easier to use
<ryanprior>when I run "guix --version" it says "guix (GNU Guix) 0.15.0" - is that the latest?
<vagrantc>that's quite old already
<ryanprior>Okay thanks. How do I update it?
<vagrantc>guix pull
<ryanprior>I last did guix pull a couple weeks ago, I'll do it again
<vagrantc>you might not have guix in your PATH
<vagrantc>and it's using the binary installation instead of what you "guix pull"ed
<ryanprior>I think I do: "type -a guix" yields "guix is /home/ryan/.guix-profile/bin/guix", "guix is /usr/local/bin/guix"
<vagrantc>PATH should probably include /home/USERNAME/.config/guix/current/bin
<vagrantc>huh.
<ryanprior>oh I can try that, why that and not ~/.guix-profile/bin though?
<vagrantc>./.guix-profile/bin/guix --version ?
<vagrantc>oops
<vagrantc>./.config/guix/current/bin/guix
<vagrantc>not the same thing :)
<ryanprior>Okay, weird: "~/.config/guix/current/bin/guix --version" yields "guix (GNU Guix) c6de5afe5c5da34513ea43b041fead30f28f57d4", while "~/.guix-profile/bin/guix --version" yields "guix (GNU Guix) 0.14.0-13.7af5c2a"
<ryanprior>So yeah clearly not the same thing
<vagrantc>newer versions of guix use .config/guix/current
<vagrantc>which now actually has generation tracking, which is really nice if you ever get stuck with a broken guix...
<dongcarl>Is there any documentation on running your own substitute server?
<vagrantc>ryanprior: see /var/guix/profiles/per-user/USERNAME/current-guix*
<ryanprior>Welp, I can't "guix pull" because it crashes. X.X
<ryanprior>It says please report to bug-guix@gnu.org -is there way to check out if this bug is already known?
<nckx>ryanprior: You can try searching on https://debbugs.gnu.org/cgi/pkgreport.cgi?pkg=guix but it's hit or miss whether you chance upon the ‘right’ search terms.
<nckx>Duplicate bugs aren't the end of the world and better than unreported ones, hint hint.
<dongcarl>6:12:15 PM <dongcarl> Is there any documentation on running your own substitute server?
<nckx>dongcarl: No, but it's pretty trivial (just run a guix publish service, see manual).
<nckx>dongcarl: whut
<dongcarl>Oh I see
<dongcarl>sorry just bumping
<nckx>Spooky timing though.
<nckx>G'night!
<dongcarl>Gnite!
<ryanprior>I reported the bug, fingers crossed :)
<vagrantc>ryanprior: 15:10 < ryanprior> Okay, weird: "~/.config/guix/current/bin/guix --version" yields "guix (GNU Guix) c6de5afe5c5da34513ea43b041fead30f28f57d4"
<vagrantc>that commit is pretty recent ...
<vagrantc>ryanprior: you might want to try to pull from that one
<ryanprior>That is the version I used when I found the bugged behavior.
<ryanprior>Just tried it again to confirm it explicitly: "~/.config/guix/current/bin/guix pull" reproduced the bug.
<vagrantc>huh
<Gamayun>Hey guix!
<Gamayun>I have a package with openssl-next as native-input (requires openssl 1.1.x, which should be openssl-next). It builds ok, but when trying to run it segfaults immediately on some interaction with openssl 1.0.2. Running with '--version' also tells me that it's "Using 'OpenSSL 1.0.2p 14 Aug 2018'".
<Gamayun>Anyone have an idea what's going on?
<jackhill>Gamayun: I don't have any great ideas, which package?
<jackhill>native-input would be for the openssl used during the build process. It should be in inputs for a runtime dependency.
<Gamayun>Nextcloud's desktop client, so based off owncloud-client.
<Gamayun>I did try that too, seemingly with the same result.
<jackhill>well, that was my only idea, sorry :) could you post the code somewhere maybe?
<Gamayun>jackhill: https://paste.debian.net/1088579/
<Gamayun>jackhill: Ignore the excess modules... ;)
<Gamayun>Ah, the existing owncloud-client is the same... Although it doesn't segfault, so presumably doesn't require the newer version.
<dongcarl>Does `guix publish` serve up anything that you have in your `/gnu/store`? How does it work?
<Gamayun>dongcarl: As far as I know, yes...
<dongcarl>Thanks
<jackhill>Gamayun: sorry, nothing obvious, and I haven't had a chance to build it myself and see. Good luck!
<Gamayun>OK, thanks! :)
<apteryx>hmm; I get an "input decoding error" on a text file I can readily view in Emacs (configure.in from CGoban), when attempting to "substitute*" stuff in it.
<apteryx>Throw to key `decoding-error' with args `("peek-char" "input decoding error" 84 #<input: configure.in 15>)'.
<apteryx>any idea?
<apteryx>the file uses a multi-byte iso-latin-1-linux encoding
<apteryx>I worked around the Guix/Guile issue by converting the file to UTF8 using iconv
<Marlin[m]>hi guixy frends
<Gamayun>Hmm, running 'guix environment' on my nextcloud package gives me the right openssl version 1.1.1c, so I'm very curious where it gets the 1.0.2p version from...
<PotentialUser-27>is there a function in guile similar to doc in clojure?
<PotentialUser-27>i keep seeing functions i'm not familiar with and would like to pull up a docstring and maybe src at the repl
<Gamayun>PotentialUser-27: Something like ,describe (,d)?
<PotentialUser-27>Gamayun: thanks!!!
<dongcarl>Any way to disable the default sharing of PWD to inside the container for `guix environment --container`?
<mikegerwitz>dongcarl: I had submitted a patch for that probably about a year ago by now, but I haven't had time to revisit it to fix a test issue to have it committed. Until I get around to that, you can just change your directory before running the command. I have scripts that use mktemp(1) and switch to that, for example.
<dongcarl>mikegerwitz: Ah, thanks!
<mikegerwitz>But I'm glad someone else has use for it. Maybe that'll motivate me to give it another look soon.
<dongcarl>:-)
<g_bor[m]>hello guix!
<efraim>hi!
<leungbk>i wrote package defns for https://github.com/chrisdone/hindent just now, and can confirm they work.
<leungbk>there is a haskell library and an emacs extension (and an atom extension that i'm less concerned about). currently, i've got the haskell library packaged the normal way (haskell-build-system) , and the emacs extension is taken from melpa, packaged with the emacs-build-system.
<leungbk>i think this is not ideal since both the haskell library and the emacs extension can be acquired from the same tarball. i am leaning towards using the gnu-build-system and making only a single package definition, ghc-hindent, that happens to take emacs as an input and will have the elisp library put in the appropriate place.
<leungbk>which approach is preferred?
<leungbk>the main thing i don't like about the latter approach is that emacs is required, which is not ideal if you're, say, a vim main
<efraim>if you take a look at translate-shell in dictionaries.scm there's an example of pulling in some emacs-build-system code into another build system
<leungbk>i know, i'm just wondering if this approach is preferred by you guys
<efraim>would people want just the emacs package without the haskell library?
<leungbk>bc of the whole drawback of needing to install emacs for a package that need not actually use emacs (for example, atom users)
<leungbk>no, but the opposite may hold true
<efraim>i wouldn't worry about pulling in emacs as a build dependency, but haskell doesn't build on all systems currently
<efraim>I suppose if you wanted you could put the emacs extension in a separate output but I wouldn't bother, I'd just build it all in one go
<leungbk>thanks, i'll follow your suggestion then.
<g_bor[m]>I have been looking around the bug to allow services to implement a reload action. I was thinking about the issue of having the config file hardcoded on the command line. I belive it could be mitigated by providing a symlink in etc to the current config file, updating it in activation snippet, and starting the service with the symlink in the command line. This would work for most of the services having a useful reload. Do you
<g_bor[m]>see any drawbacks to this approach?
***emyles` is now known as emyles
<emyles>Hullo guix!
<emyles>Is it ok for 'guix gc --list-roots' to have duplicate entries?
<emyles>I meant "return duplicate results?"
<cbaines>emyles, I guess so
<cbaines>I seem to have duplicate entries on the current system I'm using... guix gc --list-roots | sort | uniq -d
<rekado>why though?
<cbaines>I'm unsure, it's mostly the current-guix profiles for my user
<emyles>I've got 2 each of /var/guix/profiles/per-user/myles/current-guix-38-link and /var/guix/profiles/per-user/myles/guix-profile-108-link
<emyles>Trying to 'guix gc -D' something but "it is still alive", so am finding out what refers to it.
<emyles>'guix gc --referrers' shows xdg-mime-database and gtk-icon-themes
***ChanServ sets mode: +o Sigyn
<swedebugia>hello
<Gamayun>swedebugia: Hello! Just out of curiosity, is your nick based on the theologian or the mesozoic conifers, or something else?
<swedebugia>Gamayun, eh. I did not understand the question. It is a contraction of sweden and debug and some ending I found useful :)
<swedebugia>I finally got guix to compile today. It broke for some reason when using guix environment, but now it just compiles without me first entering the environment.
<swedebugia>Does anyone know if I can compile guix in one terminal and in another safely do "git checkout -b new-branch" and start working on something?
<swedebugia>I have the impression that switching branches sometimes changes the compiled *.go files so that when I run ./pre-inst-env guix it displays a lot of warnings.
<cbaines>swedebugia, use git workspaces if you want to use multiple branches concurrently
<swedebugia>cbaines, ok, will have to learn something new then :D
<swedebugia>anyways the compilation broke after 49% loading on a git pull from 15 min ago.
<swedebugia>error: repository-working-directory: unbound variable
<swedebugia>:(
<swedebugia>cbaines, is this workflow advisable: 1) git pull 2) compile guix 3) create worktree and work there.
<cbaines>You'll need to "build" Guix in each worktree
<cbaines>I have a worktree that I use for the master branch
<cbaines>I use other worktrees for branches for specific sets of patches
<cbaines>swedebugia, also, if you have problems running make, I'd recommend removing the .go files, which you can do by running make clean
<cbaines>that often resolves the occasional issues I come across
<swedebugia>cbaines, maybe this comes down to: my PC is too slow for me to want to build guix all the time.
<rekado>the ncbi-vdb package now requires SSE4.1; it won’t build with anything less.
<rekado>Does this mean that we should make it non-substitutable?
<cbaines>swedebugia, hopefully you can avoid building all the .go files all the time
<swedebugia>cbaines, yes. Guix is large now. I remember 2 years ago on the same pc it was way faster to build from scratch.
<swedebugia>cbaines, does "git checkout" touch the .go files? In my mind git should leave them alone when they are not checked in.
<cbaines>swedebugia, it doesn't, but I think it might change the metadata, or contents of the .scm files
<cbaines>which then causes Guile to not use the .go files
<Gamayun>swedebugia: Ah, ok! Whenever I see it, I can't help think Swedenborgia - a genus of conifers found as fossils. ;-)
<Marlin[m]>morning guix
<Gamayun>Hi Marlin[m]
<Marlin[m]>everything alright>
<Marlin[m]>?*
<Marlin[m]>Still on vacation
<Marlin[m]>I'm gathering package suggestions
<civodul>Hello Guix!
<Gamayun>Hey civodul!
<cbaines>civodul, hey :) I was impressed you went for a Guile release on the move!
<civodul>cbaines: pretty fun! :-)
<civodul>that had to be done, and bandwidth was good enough, so...
<swedebugia>Hooray! Guix pull is fast and effective. It took only a few minutes.
<civodul>heh
<swedebugia>Since 2 months I get this error during make on parabola: configure: error: No Guile development packages were found.
<matt`>I'm having trouble installing guix on my computer. I flashed the USB image (one from the manual) to a flash drive. When I boot from it and select manual install i never get a tty prompt
<swedebugia>Maybe it is complaining about the guile from parabola?
<civodul>matt`: weird, what if you do ctrl-alt-f3?
<matt`>civodul: yeah tried that too. unfortunately no go
<rekado>swedebugia: better use a pure environment then with “guix environment --pure guix”.
<swedebugia>rekado, ok, trying now.
<civodul>matt`: you mean it doesn't actually switch to tty3?
<matt`>correct. it's nonresponsive. i see some startup messages but can't do anything from there
<PotentialUser-21>Hi, I was wondering, is there a way to create an environment out of a specific set of channels/guix revision?
<matt`>last message is vt: using tty /dev/tty1 ...
<swedebugia>rekado, did not help unfortunately. The pkg-config in env has a guile-2.2.pc
<rekado>swedebugia: I don’t understand.
<rekado>what Guile is used?
<swedebugia>rekado, probably the one from parabola that is first in path. 2.2.4-2
<rekado>swedebugia: well, what does “which guile” say inside of the pure environment? What does the configure script say?
<swedebugia>rekado, now I removed both make and guile with pacman
<rekado>in a pure environment they shouldn’t matter unless you’re adding them to the environment in ~/.bashrc
<matt`>civodul: i didn't run sync after flashing the usb. think that could be an issue?
<swedebugia>rekado, which says "no such command" one monent
<swedebugia>which guile /gnu/store/wqrvr5b7gq8sxsj4sh4yaqlji5dmy724-profile/bin/guile
<swedebugia>rekado, the configure script says the same I posted earlier no guile dev packages found.
<swedebugia>configure: checking for guile 2.2 configure: error: No Guile development packages were found.
<rekado>what does config.log show?
<jollyjester>hello should guix on guixsd be run with sudo or without
<matt`>jollyjester: without unless you're reconfiguring the system
<jollyjester>ok
<jollyjester>btw there's a message telling me to run guix pull then guix package -u
<jollyjester>but guix package -u does nothing
<swedebugia>rekado, it says that it cannot find the guile-2.2.pc even though it is present in the pkg-config path mentioned in the log also. Would you like the whole file in a paste?
<matt`>jollyjester: hm I'm not actually sure about that. i would imagine that's not an issue but i'm still pretty new to guix myself
<matt`>your original question is in the manual here: https://www.gnu.org/software/guix/manual/en/guix.html#Invoking-guix-package
<swedebugia>rekado, the previous statement about the path was wrong. The path to pkg-config-path in the log does not exist it seems. Hm.
<swedebugia>I'm posting the whole file now for you.
<swedebugia> http://paste.debian.net/1088640/ the pkg-config-path in the output variables is wrong.
<jollyjester>if i want to create a new user and i want my packages to be available to him too
<jollyjester>what do i do
<swedebugia>rekado, ls: cannot access '/gnu/store/19mpkvkms7nwczivf8qlfj6c9vqbsffk-profile/lib/pkgconfig': No such file or directory
<rekado>swedebugia: what is the full output of “env” inside of the environment?
<matt`>jollyjester: have you installed your packages with a manifest file? if so, you can just copy the manifest to the new user and install with that. all the packages are already in the store so it won't rebuild etc
<matt`>if you haven't there should still be a way to determine the packages installed for user 1 and then specify to install those for user2. I think that's done by generating a manifest, but i would have to look into it
<jollyjester>clear: command not found
<jollyjester>what
<swedebugia>rekado, http://paste.debian.net/1088641/ output of env
<rekado>jollyjester: provided by ncurses. Or you could just type Ctrl-L.
<swedebugia>rekado, the invokation pkg-config-path is wrong. Does not exist. running CONFIG_SHELL=/bin/sh /bin/sh ./configure --localstatedir=/var PKG_CONFIG_PATH=/gnu/store/19mpkvkms7nwczivf8qlfj6c9vqbsffk-profile/lib/pkgconfig --no-create --no-recursion
<rekado>swedebugia: one thing that’s weird: it references two environments
<rekado>this is one profile: /gnu/store/y460czfhah18pwvba8d2q6rd11czkn03-profile; and this is another: /gnu/store/wqrvr5b7gq8sxsj4sh4yaqlji5dmy724-profile
<rekado>it may be a good idea to look into your shell init files ~/.bashrc and ~/.bash_profile (if you’re using Bash)
<swedebugia>aha can this be because of fsad? I have that in my bashrc.
<swedebugia>I guess the error is in there somewhere, yes. Thanks for help debugging.
<swedebugia>:D
<rekado>do you source …/etc/profile somewhere in .bashrc?
<rekado>(what’s fsad?)
<swedebugia>rekado, sorry, "fasd", some obscure cli helper I found :)
<swedebugia>rekado, yes I source this /home/user/.guix-profile/etc/profile
<jollyjester>i keep getting No outputs have backlight property
<jollyjester>when using xbacklight
<jollyjester>any way to fix this?
<Marlin[m]>how do u update grub again?
<swedebugia>rekado, now the pure environment seems to only have one profile :D
<swedebugia>rekado, I invoked ./configure manually with the correct pkg-config-path from the env and it passed :) Now make is running :) Hooray!
<rekado>swedebugia: .bashrc should not source .guix-profile/etc/profile because .bashrc is evaluated for *every* shell, not just for login shells
<rekado>this means that you (or “guix environment”) cannot start sub-shells without having the variables set as specified in .bashrc .
<rekado>“guix environment --pure” sets up variables and then .bashrc comes along and overwrites them all.
<rekado>that’s why this should be moved to .bash_profile, which is only evaluated for login shells.
<rekado>(besides: you may want to set the GUIX_PROFILE variable before source’ing etc/profile)
<swedebugia>rekado, ok!
<swedebugia>rekado, so if I understood correctly guix will collide and errors will ensue IF your bashrc contains anything else than internal bash commands (like aliases)
<rekado>no…?
<rekado>you just need to know the effects of putting environment variable declarations in .bashrc
<jollyjester>bruh moment
<swedebugia>rekado, ok. Maybe this being so an essential way for guix to work we should have some sort of troubleshooting section in the manual? I have used gnu and bash for years without, it seems, to understand how environment variables work behind the scenes.
<saslibre>Hello guix!
<quiliro>saluton!
<quiliro>mi babilas kun ERC-o de EMacs-o
<g_bor[m]>Hello!
<Tirifto>Saluton quiliro!
<saslibre>quiliro: saluton! kiel vi fartas
<Tirifto>Kaj aliaj. :P
<quiliro>Tirifto: Mi fartas bone. Ĉu kaj vi?
<rekado>swedebugia: I couldn’t find any mention of environment variables in the manual’s index. It would be good to add this kind of information (or if it’s already there to include it in the index).
<Tirifto>quiliro: Pli-malpli, jes, dankon. Kiel vi, saslibre? (La demanda triangulo estas finita!)
<quiliro>Tirifto: ĉu vi uzas Guix-on aŭ GuixSD-on?
<quiliro>Mi ne estas saslibre. Mi estis kun saslibre la alia tago.
<Tirifto>quiliro: Mi uzas Guix-on sur Parabola. Ne tre vaste; mi nur instalis Icecat-on kaj Aegisub-on per ĝi. Pri la unua mi spertis kelkajn malfacilaĵojn, pri kiuj mi skribu raporton julie.
<quiliro>Tirifto: Ĉu julie?
<Tirifto>quiliro: Mi scias; saslibre ĵus demandis, kiel vi fartas, sed vi responde demandis al mi. Tial mi responde demandis al saslibre, por ke niaj demandoj pri fartoj faru triangulon. :P
<Tirifto>quiliro: Jes; je la sekva monato. Mi okupiĝas pri aliaj aferoj ĉi tiun monaton. Mi planis mian agadon al monatoj. La sekvan mi volas ankaŭ esplori Sĥemon, kaj precipe Guile-on, Haunt-on, kaj Skribilon.
<quiliro>Tirifto: Mi kaj saslibre ankaŭ!
<Tirifto>quiliro: Ĉu vere? Tre mojose! Kion vi planas pri tiuj?
<dutchie>mi trovas ke estas multe da Esperantistoj ĉe Guix
<dutchie>kaj mi demandas min kial
<Tirifto>dutchie: Libera, zorge farita lingvo por ĉiuj homoj bone kunas liberan, zorge faritan pakaĵilon por ĉiuj distribuaĵoj… ĉu ne? ;D
<quiliro>Ni legis la blog-on pri disvolvo programa en Guix-o.
<quiliro> https://www.gnu.org/software/guix/blog/2018/a-packaging-tutorial-for-guix/
<dutchie>Tirifto: certe! sed mi uzis linukson longdaŭre kaj neniam renkontis tiom da E-uloj
<quiliro>Mi pensas ke estas plej facila por la malparolanto angla. Ili povas lerni Guix-on pli rapide
<quiliro>dutchie: Do, tiam estas la horo!
<dutchie>al la fina venk', per Guix!
<quiliro>dutchie: Linux ne estas libera. Ĝi ne trovas Esperanto. Guix estas libera. Do, ĝi trovas Esperanto!
<quiliro>dutchie: Ĉu vi akordas?
<dutchie>oni povis uzi Linukson Esperante antaŭ Guix, mi kredas
<dutchie>mi nur rimarkis ke multe pli da uzantoj de Guix parolas Esperanton
<dutchie>(ol Linukso ĝenerale)
<Tirifto>Hmm… Ĉu Linukso estas tradukata? :o
<dutchie>GNU/Linukson*
<dutchie>mi forgesis ke ĉi-tie estas GNU-ejo
<dutchie>kaj ankaŭ iomete pigras
<jollyjester>clear command not found
<jollyjester>what do i do
<jollyjester>also how do i disable gdm
<dutchie>reset and clear are in the ncurses package
<jollyjester>ok
<dutchie>for gdm, it depends whether you are using Guix System or are running on a foreign distro
<jollyjester>guixsd
<jollyjester>im running that
<jollyjester>dutchie:
<dutchie>i'm not sure about that then, i've only used guix on a foreign distro
<dutchie>from my glances over the docs, maybe there's a service declaration to disable somewhere? otherwise you'll have to wait for someone else to answer
<quiliro>dutchie: search the forum...there are answers regarding your question
<dutchie>my question?
<swedebugia>rekado, ok, I will try writing a draft patch.
<quiliro>dutchie: sorry...i meant jollyjester
<quiliro>My volas la Guixan Akademion.
<xavierm02_>What programs do you use for mails in Guix?
<user_oreloznog>xavierm02: I've used Clawsmail for a while and it worked fine.
***joehillen_ is now known as joehillen
<quiliro>xavierm02_: Vi povas uzi 'Emacs Gnus'-on.
*dutchie uzas na Mutt
<dutchie>sed mi volas havi aerc-on
<dongcarl>Hey all, I've set up a substitute server at http://guix.carldong.io, and testing with `guix weather --substitute-urls=http://guix.carldong.io findutils` seems to work fine
<dutchie>mi komencis difini pakaĵon sed mi ne finis
<dongcarl>However, it seems that when I do a `guix pull --substitute-urls=http://guix.carldong.io` to speed things up, transfers are stuck
<dongcarl>any advice would be helpful
<quiliro>dongcarl: does that exact command work when you replace 'http://guix.carldong.io' with the standard repo?
<quiliro>i do not remember the url... i think it is ci.guix.org but i am not sure
<dutchie>ci.guix.gnu.org
<hulten>guix package -u as normal user ends with an error: connect: /var/run/shepherd/socket: Permission denied
<hulten>Indeed only root has access to /var/run/shepherd/. Is this bad?
<dongcarl>quiliro: Yes the ci substitute servers do work
<hulten>Yes, but indeed the one dutchie names (I remember that exact URL from an e-mail from Ludo').
<swedebugia>sneek_, rekado, patch sent. I ended up adding a new section to Application Setup. :)
<quiliro>dongcarl: then probably it is a problem with your server
<quiliro>`guix weather
<quiliro> --substitute-urls=http://guix.carldong.io findutils` seems to work fine
<quiliro>so it is not your server
<dongcarl>:-/
<hulten>About the "/var/run/shepherd/socket: Permission denied", I forgot to mention that I am using Guix System, upgraded last night.
<hulten>(GuixSD is now called Guix System, right?)
<matt`>how can i get cow-store-service-type into my own custom config? since the provided usb installation image isn't working for me I'm configuring my own but having trouble getting the cow-store to be an available service
<matt`>i tried (use-modules (gnu system install)) but it's not working for me
<str1ngs>matt`: are you installing from a foreign distro?
<matt`>str1ngs: yes, arch
<str1ngs>if that is the case you don't need cow store. since it's only used during installing
<matt`>well i'm trying to install guixsd from a flash drive
<str1ngs>it's used because the ramfs is limited with the installer. which should not be an issue on a foreign distro
<str1ngs>you are booting from the flash drive?
<str1ngs>I guess installing from arch -> flash. then booting and installing from there?
<matt`>yes, but i'm first setting up the flash image bc the provided one just hangs for me
<matt`>yep
<matt`>that's correct
<str1ngs>I mean you can avoid the usb, and just install to the partition on the system you want
<str1ngs>assuming you are dual booting?
<matt`>nope i'm actually fully replacing arch
<str1ngs>how large is your USB?
<matt`>unnecessarily large actually 128GB
<str1ngs>meh, you don't need cow store then
<str1ngs>cow store is only required due to limitation of ramfs on the usb installer
<str1ngs>your usb is a full guix system. so /gnu/store will remain populated anyways
<anon321anon123>Hello everyone! How well wayland supported right now? I am interested especially in sway
<matt`>oh ok great. so skip that, go straight to guix system init and then boot directly from there?
<str1ngs>matt`: right, in fact because you are replacing arch. I not using cow store means the USB's /gnu/store will be persistent. so that if you have problems booting the new OS. you wont need to re download substitutes. and you can recover and init faster
<str1ngs>ans not*
<str1ngs>and not*
<str1ngs>and I think we should rename cow store to cow barn... just my 2 cents :P
<matt`>haha i'd put my vote behind that
<matt`>thanks for the help!
<str1ngs>no problem
<str1ngs>though it might confuse some new users :P
<str1ngs>but if we have cows herds and shepherds ... it's only reasonable to have a barn :P
<matt`>eh i already saw a 'moooh! in the source code. i think it's better to just commit all the way
<matt`>and yeah that too
<str1ngs>aye, full on animal kingdom is my sediment!
<quiliro>dongcarl: did you get error messages?
<dongcarl>quiliro: No, it just gets stuck. I see the GET request in my `guix publish` logs tho
<quiliro>dongcarl: log message files on the client?
<dongcarl>It just says `downloading from http://guix.carldong.io/blahblah...`, and the progress bar moves for half a second, then gets stuck
<dongcarl>ofc the progress bar doesn't even show when I don't supply `--max-jobs=8`
<quiliro>dongcarl: wget http://guix.carldong.io/blahblah...
<quiliro>works
<quiliro>?
<dongcarl>quiliro: Oh... That gets stuck as well...
<dongcarl>Good clue
<dongcarl>I think `guix publish` is broken then?
<quiliro>dongcarl: wget http://guix.guix.gnu.org/blahblah... works?
<xavierm02_>I've got some macro problems: https://paste.debian.net/1088663/
<dongcarl>quiliro: No it doesn't, it gets stuck
<dongcarl>at 64.00K
<xavierm02_>I'm trying to write functions that take a function f and apply it to a field of the os record
<dongcarl>`Length: unspecified [application/x-nix-archive]`
<dongcarl>Header looks good tho
<xavierm02_>But apparently, it returns (user1 user2) instead of (list user1 user2) and idk how to fix it
<dongcarl>quiliro: It seems that `wget 'http://ci.guix.gnu.org/nar/gzip/7j3941iannrngdvgbclyxid12vds5w9i-make-4.2.1'` shows `Length: 614259 (600K) [application/octet-stream]`
<dongcarl>Which is different
<quiliro>xavierm02_: try the guile console with the same commands...maybe
<quiliro>dongcarl: 7j3941iannrngdvgbcl 100%[===================>] 599,86K 1,59MB/s en 0,4s
<dongcarl>quiliro: Right, the normal ci works well, but `wget 'http://guix.carldong.io/nar/gzip/7j3941iannrngdvgbclyxid12vds5w9i-make-4.2.1'` doesn
<dongcarl>doesn't
<quiliro>for me your server stalls at 448K
<quiliro>but ci.guix.guix.org completes the dowload
<quiliro>firewall maybe?
<quiliro>on server, on router, on isp....
<quiliro>dongcarl: on second try after C-c dowload completed correctly
<quiliro>s/dowload/download/
<nckx>dongcarl: Results of curling that file (I don't have wget installed): 633k, 448k, 633k, 320k (and still hanging, the 448k one didn't hang, which is interesting)
<quiliro>i rm the file and download again....now it downloads completely
<dongcarl>Weird... I'm on Google Cloud, and I used iptables to get port 80 to port 8080, could either of those hurt?
<nckx>quiliro: It seems to succeed about 50% of the time.
<dongcarl>quiliro: wow you're having more luck than me...
<nckx>(Sample size: 8 ;-)
<quiliro>dongcarl: never done what you are doing...have no idea
<quiliro>i am just a newbie
<quiliro>i just have the right questions
<dongcarl>Haha yeah, thanks for helping debug
<dongcarl>Now I know it's the server that's the problem, and not the client at least
<quiliro>dongcarl: exactly....but no!
<quiliro>if i can do it...then it is not your server
<quiliro>let me test
<quiliro>i cannot find your command
<dongcarl>`wget 'http://guix.carldong.io/nar/gzip/7j3941iannrngdvgbclyxid12vds5w9i-make-4.2.1'`
<nckx>curl -LI 'http://guix.carldong.io/nar/gzip/7j3941iannrngdvgbclyxid12vds5w9i-make-4.2.1'
<nckx>HTTP/1.1 404 Not Found, Content-Length: 73
<nckx>curl -L 'http://guix.carldong.io/nar/gzip/7j3941iannrngdvgbclyxid12vds5w9i-make-4.2.1' >/dev/null
<nckx>*downloads several 100k on average*
<nckx>dongcarl: HTTP proxy(?) hijinks are definitely afoot.
<dongcarl>huhhhhhhhhhhhhhhhhh
<dongcarl>Dang it google cloud!
<nckx>Or ‘guix publish’ has grown a really weird bug since I last reconfigured mine.
<quiliro>dongcarl: guix pull with your server works for me...it is building
<dongcarl>quiliro: Is it downloading tho?
<Marlin[m]>What are you working on, guix?
<nckx>quiliro: You should try reproducing that a few times though (gc and redownload), it might just be a lucky hit.
<quiliro>dongcarl: yes...but i colud not see any downloads...perhaps i have the packages already dowloaded...i am using guix system
<quiliro>running guix gc, then guix pull with dongcarl's server
<quiliro>nckx: 'guix redownload'?
*nckx has to go celebrate a birthday.
<quiliro>nckx: say happy birthday from me :-D
<nckx>quiliro: Ow, no, I meant just ‘guix gc -d (or what is it nowadays) <the -make store item>’ so it redownloads.
<nckx>o/
<dongcarl>quiliro: I think I know it's the proxy/port 80->8080 hack
<dongcarl>Thanks for your help tho
<dongcarl>I did a wget localhost:8080/blah and it worked fine
<dongcarl>(on the guix publish server)
<dongcarl>so it's gotta be somewhere in the middle
<quiliro>do you still need help?
<dongcarl>quiliro: Nah I think I'll be okay. Thanks so much for your patience!
<quiliro>dongcarl: glad to learn
<quiliro>dongcarl: how did you set up your server? i would like to set mine up too
<dongcarl>quiliro: oh! There’s a guix-publish.service file in the tree somewhere
<dongcarl>So you can use that to have it running!
<dongcarl>You have to import its pubkey on clients though
<quiliro>dongcarl: is there a manual section?
<dongcarl>Invoking guix publish I think
<vagrantc>my nginx cache doesn't work with ci.guix.gnu.org because apparently nginx tries ipv6 addresses regardless of weather there's a route
<vagrantc>and it does round-robin across both ipv4 and ipv6 ... so sometimes you get lucky, and sometimes not :/
<bandali>hi, does anyone build emacs from git with guix for themselves?
<str1ngs>bandali: should not be to hard. just do guix environment emacs. then build emacs as normal
<bandali>str1ngs, right, that’d make sense. that should be great for hacking on emacs
<bandali>now i’m looking into channels
<bandali>so i could learn how to build my own emacs from git and use that, instead of the release version shipped with guix
<str1ngs>though you are probably better off just creating a emacs-git package and inherit from emacs. and use git sources.
<str1ngs>maybe have it replace emacs?
<str1ngs>is replace a thing in guix?
<bandali>thanks, makes sense
<bandali>i was gonna ask :p
<bandali>i’ve definitely seen it in parabola (based on arch), but not sure if guix has it too?
<str1ngs>I guess with emacs-git file names could conflict with emacs should you use both packages
<str1ngs>most autotools you can change the bin names though. but I think replace would work better?
<bandali>hmm i’m not sure? i hadn’t thought of that so far
<xavierm02_>My network-manager doesn't autoconnect to the network. Anyone has this problem?
<nullsix>hello guix, another day nckx helped me put startx to work with special-files. But the common user cant run the special file, indicating lack of permissions. "parse_vt_settings: Cannot open /dev/tty0 (Permission denied)"
<nullsix>i mean, can run, but get that error
<xavierm02_>nullsix: https://www.gnu.org/software/guix/manual/en/html_node/Setuid-Programs.html#Setuid-Programs
<xavierm02_>That should fix it. I'm not sure it's the right way to do it though
***jackhill_ is now known as jackhill
<xavierm02_>nullsix: maybe it's because you try to do it on tty0. Try asking it to be on tty6 or 7
<xavierm02_>try 7. 6 is apparently only for root too (ls -lh /dev/tty*)
<rubic88>xavierm02_: sudo nm-connection-editor
<rubic88>For each connection, select "All users may connect to this network" and save.
<xavierm02_>rbic88: Worked. Thanks!
<nullsix>im tty1, but when i run /bin/startx that happen
<rubic88>xavierm02_: I just figured it out myself a couple days ago.
<nullsix>no go on tty6 either
<xavierm02_>nullsix: try tt7 or 8
<nullsix>cat reach 6+
<xavierm02_>my guix runs gdm on 7 and the session on 8
<nullsix>cant*
<xavierm02_>You mean it doesn;'t list them when you run: ls -lh /dev/tty*
<xavierm02_>?
<nullsix>alt+f6 is the last
<nullsix>that ls displays lots of them
<xavierm02_>nullsix: that's probably because guix only spawns 6 terminals, the next displays exist, they just don't have anything in them
<xavierm02_>(Displaimer: I have no idea what I'm talking about)
<xavierm02_>If you run "sudo herd status", it lists 6 term-tty
<nullsix>i thank you man, but i think its time to give up, i`ve trying to use guixsd for sometime now, with tremendous frustation
<swedebugia>Hi. Does anyone know how to get bash to execute .bash_profile on login?
<swedebugia>It seems to not do that and rekado told me to put variables in that file.
<quiliro>Guix is a system for people that want to learn how it is constructed and takes a lot of investigation
<quiliro>pragmaos was a system that was going to be a nontechnical version of guix system
<quiliro>swedebugia: did you check the forum?
<rubic88>sneek_: swedebugia I put everything in ~/.profile and removed ~/.bash_profile
<user_oreloznog>.
<swedebugia>quiliro, kiu forumo?
<quiliro>swedebugia: la forumo help-guix-a
<swedebugia>ne. mi supozas ke estas pro tio ke en GUI vi jam estas en unu granda sxelo kaj tio signifas ke la terminalaj emulatoroj ne validas iel kiel login-kazo.
<swedebugia>anyone else here working on cryptocurrencies on guix?
<vagrantc>only nominally
<emacsomancer>hello, guix
<emacsomancer>will the ungoogled-chromium package eventually have a binary substitute?
<vagrantc>e.g. occasionally updating electrum/electron-cash
<vagrantc>(and related libraries)
<vagrantc>emacsomancer: it's a very slow build; i gave up building locally and never found it to produce a substitute
<vagrantc>but ymmv
<emacsomancer>vagrantc: I got it to build locally last time. but this time is gets to some part and locks my computer (while still overheating; until I Alt-PrtSc+f at which point it immediately shuts down due to overheating)
<emacsomancer>is there a guide to how to build a package on a different machine?
<vagrantc> https://www.gnu.org/software/guix/manual/en/html_node/Daemon-Offload-Setup.html
<emacsomancer>perhaps my desktop could handle building it.
<emacsomancer>vagrantc: thanks - I'll dig into that
<anon321anon123>Hello everyone, how well does sway works on Guix? I heard that GDM in Guix currently does not support wayland sessions, so what should I pick?
<vagrantc>i've been using sddm and sway
<anon321anon123>vagrantc: can you share your config? If you can of course
<vagrantc>anon321anon123: i should post it somewhere ... not at that computer at the moment
<quiliro>swedebugia: ho...mi komprenas nun... Ĉu modifii .bash_profile-on ne funcias? Ĉu aŭ modifii config.scm-on por reconfigure-o?
<anon321anon123>Also, I heard that Guix for now only support ext4, fat and btrfs file systems if I remember correctly. Will be there any soon support for f2fs?
<anon321anon123>vagrantc: can you send me it via xmpp or email?
<Marlin[m]>hey guix
<ngz`>swedebugia: (about cryptocurrencies) I try to maintain basic tooling around Duniter/G1, but most tools require npm =/
<swedebugia>ngz`, never heard of that one :)
<swedebugia>quiliro, its a bash internal thing that seemingly did not behave as I thought.
<ngz`>swedebugia: G1 is the first (to my knowledge) free (as in freedom) currency in the world. Yay!
<PotentialUser-39>guix refresh gave this https://paste.debian.net/1088680/
<PotentialUser-39>What scopes should I select for a new personal access token?
<Marlin[m]>Hey guix
<Marlin[m]>How can we do startx again?
<Marlin[m]>i remember using xinit once in a way it worked
<Marlin[m]>Any ideas?
<rubic88>emacsomancer: I'm re-attempting ungoogled-chromium again after upgrading my X220 to 16GB of ram. Install has been > 2h25m so far.
<Marlin[m]>ungoogled chromium builds just fine on my main machine
<swedebugia>I really dislike the dev experience I have with Guix. Today I compile from scratch (1h wait) prepared a patch for guix.info in a separate branch, switched back to the master branch and now I have to compile everything again for some reason because of a ABI breakage with the zip bindings. Now I wanted to work on grin but it is untestable as long as git messes the go-files up all the time.
<swedebugia>It would be really nice if every t
<swedebugia>change of branch did not cause the go-files to break.
<rubic88>Marlin[m]: How much memory on your main machine?
<rekado>swedebugia: I recommend using git worktrees.
<rekado>PotentialUser-39: are you trying to update package definitions in Guix? Or are you trying to upgrade installed packages?
<swedebugia>yeah I already got that advice, but I read the manual and it was not clear how it would help.
<swedebugia>if I add a tree I will probably have to compile al go-files for every tree in any case.
<rekado>swedebugia: sure, but no longer when you switch branches.
<rekado>I have worktrees for core-updates, master, staging, and longer-lived development branches.
<PotentialUser-39>rekado: I *think* I would use guix pull to update. It looks like guix refresh tells me what *will* update if I run guix pull. I wanted to view that.
<rekado>swedebugia: for short-lived things I just recompile the changed modules.
<rekado>PotentialUser-39: no, “guix refresh” does not do that.
<rekado>PotentialUser-39: please check the manual for descriptions of what the commands do.
<PotentialUser-39>ah, okay. i'm still going through the manual and am very new to guix :-)
<Marlin[m]><Marlin[m] "How can we do startx again?"> anyone?
<Marlin[m]><rubic88 "Marlin: How much memory on your "> 16 gigs
<swedebugia>I only do short-lived changes. But I do them in separate branches which is probably a really bad idea.
<rubic88>Yeah, it wouldn't compile with 8GB.
<swedebugia>I should probably throw them away when the patch is sent instead. But I don't know how to do that without affecting the go-files. git reset --hard?
<rekado>you can also create the branch *after* you sent the patch
<rekado>and then reset your copy of the master branch with git reset --hard HEAD^ (if it was just one commit)
<swedebugia>but would this not botch my go-files? i have the impression that whatever branch-related command I write the go-files go bad.
<Marlin[m]><rubic88 "Marlin: How much memory on your "> want help with making substitutes? Got 12 threads to spare
<PotentialUser-39>rekado: based on a re-read it sounds like i'm looking for 'guix pull --dry-run'. 'guix refresh' looks for packages which are outdated in the main repo (based on upstream).
<rubic88>Marlin[m]: Thanks for the offer, but I think I'm good. > 90% complete ...
<rekado>PotentialUser-39: “guix pull” is how you upgrade Guix itself and with it the definitions of available packages.
<rekado>“--dry-run” doesn’t perform the upgrade of Guix, but instead it shows you what it will download and what it will build locally to complete the upgrade of Guix.
<rekado>“guix pull” does not, however, upgrade installed packages.
<rekado>it only upgrades Guix itself.
<rekado>to actually upgrade installed packages use “guix package -u” after running “guix pull”.
<rekado>use “guix upgrade --dry-run” to see what it would do.
<Marlin[m]><rubic88 "Marlin: Thanks for the offer, bu"> I mean, for the substitute server :P
<PotentialUser-39>rekado: right...thanks
<vagrantc>Marlin[m]: i think your matrix client interacts with IRC strangely when you quote people.
<vagrantc>Marlin[m]: it's a bit unconventional to repeat the whole thing you're responding to in IRC ...
<Marlin[m]>sorry, sometimes i forget it doesn't work well for irc
<quiliro>Ĉu kio oni devos uzi antaŭ 'sudo guix system reconfigure config.scm': 'guix pull' aŭ 'sudo guix pull'?
<pkill9>what do I pass to 'guix build -s' to build for ARM?
<rekado>pkill9: do you have offloading or the qemu guix service set up?
<rekado>pkill9: what architecture do you want to build for? aarch64-linux or armhf-linux?
<pkill9>rekado: i don't want to do anything complicated, i just wanted to see what file glibc creates for ld-linux, which is different for different architectures