IRC channel logs

2019-04-22.log

back to list of logs

***Piece_Maker is now known as Acou_Bass
***Piece_Maker is now known as Acou_Bass
<apteryx>do we have a package containing libm.so?
<apteryx>oh, openlibm
<nckx>apteryx: But libm is usually provided by glibc.
<apteryx>oh! strange, the python-cffi test suite fails finding it (on core-updates)
<nckx>No idea what openlibm is but it's probably not what you're looking for.
<nckx>Yech. Happy debugging…
*nckx → 😴
<apteryx>nckx: o/
<apteryx>nckx: you're right, comes from the glibc
<apteryx>findable through LIBRARY_PATH on Guix, it seems.
<tune>how do I use haskell stuff on guix? a friend sent me a program
<tune>I have ghc installed but the shebang in the script doesn't work right
<tune>and running ghc on the file doesn't work right
<brendyyn>tune: the shebangs would need to be replaced with references to the store, or the path to your profile
<tune>yeah, is there a standard one to use for haskell stuff?
<tune>#!/run/current-system/profile/bin/bash
<tune>I have this in bash scripts
<tune>but I looked in that dir and didn't see anything called ghc or haskell
<brendyyn>Because current-system refers to anything installed by your os configuration
<brendyyn>you could change it to /home/tune/.guix-profile/bin/ghc
<noobly>anyone here coming from portage?
<kmicu>tune: that's Nix script.
<kmicu>‘#!/run/current-system/profile/bin/bash’ should at least look like ‘#!/usr/bin/env bash’ to work on NixOS and other distros.
<kmicu>(‘Nix script’ in a sense that it assumes Nix(OS) is installed to work properly ;)
<tune>I thought the /usr/bin/env thing didn't work on guix
<kmicu>tune: not out of the box but we can add it https://www.gnu.org/software/guix/manual/en/html_node/Base-Services.html#Base-Services which can be useful when we have a lof of non-Guix friends with ad-hoc scripts.
<kmicu>(Or when we migrated from NixOS to Guix System 😺)
<nckx>tune: Late, but I second the urge to use ‘/usr/bin/env ghc’ in your script and (special-files-service-type `(("/usr/bin/env" …))) in your system configuration. No need to edit all your shebangs to make your scripts less portable ☺
<nckx>Crikey. Building arachne-pnr eats 14 GiB of RAM before I put it out of its misery, and that's with -c1.
<maddo>Blackbeard[m]: sorry, I'm out for Easter and I kinda forgot, will post it after I return tomorrow
<Blackbeard[m]>maddo: i just wanted to say thanks :)
<maddo>haven't done anything lel
<Blackbeard[m]>Groff with MOM is awesome
<Blackbeard[m]>٩(◕‿◕。)۶
<dongcarl>Hey all, wondering what the `system` flag does for `guix environment`
<rendaw>Hello, quick questions if anyone's encountered this stuff. 1. I'm doing `guix system disk-image` with a UEFI bootloader, and grub fails to install (install qemu is using bios) 2. Any way to prevent Guile output from truncating at screen width?
<dongcarl>If I attempt to build for `i686` on my `x86_64`, does that mean that all the binaries in the environment will be `i686` binaries? Or just the compiler suite in the environment will target `i686`?
<nckx>rendaw: ‘export COLUMNS’ in the same environment as guile (weasel words because the truncation might be happening in the client or the daemon) will disable truncation.
<nckx>dongcarl: If you're using --system, the former. You get a native i686 environment. That's also why this trick only works on 64-bit x86, since there you get 2 ‘architectures’ for free ;-) (apart from, like, oh, the cost of decades of backwards compatibility)
<dongcarl>nckx: Ahhhhh makes sense
<nckx>I now read your previous line and see that you're indeed using --system.
<nckx>So yeah, that's no mere cross-compiler.
<rendaw>ncks: Thanks!
*nckx had a wonderfully quiet day with no mail until they became suspicious and checked whether smtpd was running. 😒
<bavier>dongcarl: everything will be i686
<rendaw>nckx: COLUMNS=9999999 didn't work ); but thanks for the suggestion
<rendaw>COLS= didn't work either FWIW
<rendaw>Actually I think the guix process resets the terminal state at some point (running qemu?) - COLUMNS goes back to the old value after running guix (and truncation continues)
<maddo> https://www.talospace.com/2019/04/broadcom-bcm5719-libre-firmware-coming.html
<maddo>TL; DR Talos II NIC libre firmware Soon(tm)
<maddo>(periodical ping about guix being ported to ppc64le)
<nckx>rendaw: My advice was to just ‘export COLUMNS’, not set it 😛
<rendaw>Right, tried `export COLUMNS=` as well
<rendaw>but maybe I'm not reading nuance here
<nckx>Also, guix (or any other command) can't reset variables in your current shell.
<rendaw>That was my impression as well, but since COLUMNS is a pseudo environment variable I'm not ruling it out
<rendaw>I'll try `export COLUMNS` as well
<nckx>maddo: Hooray, another volunteer ;-)
<nckx>rendaw: Hm, perhaps COLUMNS is reset by your shell when it receives the SIGWINCH. But that shouldn't change its export status.
<brendyyn>Does the talos II CPU have built in graphics?
*nckx would volunteer too if they could afford one.
<maddo>I don't own yet a talos tho so... They do offer a free Integricloud remote for developers
<nckx>maddo: whatis Integricloud?
*nckx is browserless.
<maddo>Raptor's own VPS service
<maddo>basically they're offering a free remote VM for every developer who whants to port their software to OpenPOWER
<maddo>*wants
<nckx>Hm.
<nckx>Nice approach.
<ATuin>when running "guix -u ." i get this (among other packages) "emacs-company-lua 0.1-1.0be8122 → 0.1-1.0be8122 /gnu/store/m2n7hxjpysd0kxzsyzjnlqns83ws25yl-emacs-company-lua-0.1-1.0be8122" but nothing is installed
<ATuin>it's a bit confusing
<dongcarl>Hey guys, anyway for me to build a gcc that's tied to glibc 2.27 instead of the latest?
*nckx → AFKBBQFTW
<brendyyn>dongcarl: --with-input perhaps
<dongcarl>brendyyn: Right... I mean in guile instead of on the command line
<dalz>Hi, I have a source in a package definition that needs some tweaks. It is a `local-file`, so I apparently can't use `origin` (and its snippets), and trying to modify `(assoc-ref %build-inputs "source")` in `#:builder` (I'm using `trivial-build-system`) gives me errors (i assume because the source is read-only at that point?). Can someone advise me?
***dddddd_ is now known as dddddd
<nckx>dongcarl: See arcan-sdl in (gnu packages arcan) for a minimal example, except you'd delete glibc and add it again with a different version.
<nckx>(Again, first example I found, probably not the ideal.)
<nckx>(I.e. I don't know if there's a ‘replace’ shortcut, but I don't think it would add much.)
<dongcarl>nckx: Huh...
<dongcarl>I see that gcc has a "property"
<dongcarl>`gcc-libc`
<dongcarl>can I set that property? Or is it read-only
*nckx scoffs.
<nckx>dongcarl: Read-only? This is Scheme!
<dongcarl>I know I know
<nckx>😛
<dongcarl>manual says... `package-input-rewriting`
<nckx>Ah, yes, that's the thing I was vaguely not-remembering!
<ATuin>is there any tool to generate a manifest file from a generation?
<nckx>Maybe the property you found is supposed to be a nicer interface to that, I can't say I'm very familiar with our toolchain innards.
<nckx>ATuin: Not unless I missed something new. Personally I'd write a quick pipeline on the command line [echo "(specifications->manifest (list"; guix package -I … | cut -f1 | sed 's/.*/"&"/'; echo "))", e.g. I wrote that just off the top of my head] or save it to a file if I wanted to run it often.
<nckx>So I'd say a separate tool is overkill but I'm weird.
<nckx>A --format=manifest|recutils|… option, however, if it doesn't yet exist, might be nice if someone™ feels like adding it…? ;-)
<nckx>(Check first whether it was suggested & dismissed, tho'.)
<ATuin>nckx: well, it's overkill sure but i think a flag it's a nice addon and seems like a nice task to learn guile and the api so maybe this week i can try to do it
<nckx>👍
<ATuin>i feel like i need to write some guile code to understand how everything fits :D
*nckx feels like a total wad for the ‘just off the top of my head bit’ but it was meant as ‘even I can duct-tape my way there so it can't be hard’.
<ATuin>np i understand :)
<ATuin>nckx: seems to be there inside the profile "/home/atuin/.guix-profile/manifest"
<nckx>UI of the week: Guess what ‘links --address-preference 4’ means.
<nckx>Correct: ‘Use only IPv6’. (For IPv4, you'd pass ’--address-preference 3’, obviously).
<nckx>ATuin: A voila. I managed to over-engineer the obvious again ;-)
<ATuin>:)
<ATuin>well still seems to be the long format so bit harder to manage in git for example
<nckx>(I've been a manifest user almost from day 0, so can't say I interact much with --list-installed & friends.)
<ATuin>yeah, the manifest thing is a really nice concept
<nckx>At least it looks deterministic (i.e. ‘some sorting was done’).
<nckx>It brought me full-circle to my manually curated world files in my Gentoo/Exherbo days ☺
<nckx>Obviously, even better.
<ArneBab>Can someone help me install gdal with Python support? I need it to finish a paper, but failed for the past few weeks to install it in Guix.
<bavier>ArneBab: looks like you need to add python and python-setuptools inputs and pass `--with-python' to configure
<amz3>ArneBab: last time I tried to use gdal (on another distro) I fallback to another binding library namely rasterio and fiona, ymmv.
<ArneBab>amz3: I need gdal, because I used it in the draft version of the paper, and I need to address the reviewer comments.
<ArneBab>but when I did the draft, I was on Gentoo
<amz3>HTH
<ArneBab>amz3: but still thank you for the hint
<ArneBab>bavier: i’m trying that again now, but i get "__main__.gdal_config_error: [Errno 2] No such file or directory: 'gdal-config': 'gdal-config'"
<ArneBab>gdal-config is a program installed by gdal
<bavier>ArneBab: can you execute the file yourself?
<ArneBab>do you mean when installing the normal gdal package (without python support)?
<ArneBab>when installing the normal gdal, I can run gdal-config
<ArneBab>guix package -i gdal && /home/arne/.guix-profile/bin/gdal-config
<ArneBab>guix package -i gdal && which gdal-config
<bavier>ArneBab: so python can't exec it for some reason, probably
<bavier>or needs some additional path info
<pkill9>is there a way to dynamically add a package path to the sudoers file? i.e. (format #t "~s" "/gnu/store/...-package") where the store path is generated, and the garbage collector adds it as a root
<ArneBab>bavier: yes, and I did not find out how to do that — or to see whether it is present when the python call runs.
<bavier>ArneBab: just a hunch: you may need to patch the '#!/bin/sh' in apps/GNUmakefile; iirc /bin/sh is not available in the build container
<ArneBab>bavier: ah, there’s a 'echo '#!/bin/sh' > gdal-config' in there — I’ll report whether it helps!
***jfred4 is now known as jfred
***jamesrichardson is now known as Guest71617