IRC channel logs

2019-03-28.log

back to list of logs

<apteryx>nckx: luckily you're doing this in the middle of the week ;-)
<apteryx>sneek: later tell civodul yes I'm sure! I've just drop the `memoize' call in the pypi->guix-package method and it revealed the failure I was expecting.
<sneek>Got it.
<apteryx>sneek: later tell civodul I'll try mocking it out, since these are just tests :-)
<sneek>Got it.
<apteryx>might be useful to have a way to globally disable memoization for tests
<apteryx>looking at mock's definition in (guix tests), maybe one could simply use: (module-set! m 'proc replacement), although I'm not sure of the scope of such a call. On the module? Globally?
<apteryx>I tried: (module-set! (resolve-module '(guix memoization)) 'memoize identity) at the top of my test module, but it doesn't seem to cut it.
***atw` is now known as atw
***daviid is now known as Guest62906
***Guest62906 is now known as daviid
<z3t0>hi
***Server sets mode: +cnt
<kmicu>Hi z3t0
<Blackbeard[m]>z3t0: hi ٩(◕‿◕。)۶
<Blackbeard[m]>:D
<Blackbeard[m]>kmicu: hi ٩(◕‿◕。)۶
<roptat>hi guix!
<pkill9>it's funny how you get used to things, Guix seemed sorta revolutionary to me when i first started using it, now i'm just kinda used to it, it's still great though :)
<nckx>I'm married to Guix too.
<nly>Can someone take a look at this build? http://nly.info.tm:9001/log/celestia.org
<nly>package celestia in http://nly.info.tm:9001/guix/packages.scm
<pkill9>lol nckx
<civodul>Hello Guix!
<kmicu>( ^_^)/
<pkill9>hey civodul :)
<efraim>nly: why not use cmake build system?
<nly>oops, thanks
<apteryx>do we have a mean to parse INI in Guix/Guile?
<civodul>not sure
<apteryx>OK, thanks for validating it ;-)
<apteryx>o
<apteryx>regarding our PyPI importer, do we want it to pull in the optional dependencies? Or just the bare minimum to make it work? Also, it'd be possible to add optional "test" or "dev" tagged dependencies to the native-inputs requirements; do we want that?
<apteryx>(currently the PyPI importer just puts everything in propagated-inputs, including optional (+ test) dependencies)
***daviid is now known as Guest31725
***Guest31725 is now known as daviid
<rekado_>apteryx: let’s ignore optional dependencies (because these can be really difficult to satisfy) and add the test/dev dependencies to native-inputs.
<apteryx>rekado_: OK, I'll try that! Thanks.
<roptat>apteryx, you can always write a peg parser for ini :D
<apteryx>roptat: yeah, I've seen the PEG library and it seems fun, but I'll punt for now :-)
<rekado_>can confirm: PEG is fun.
<apteryx>hehe
<shcv>since guix builds are reproducible and support "substitutions", and particularly since building is already managed by a daemon, how hard is it to set up a cluster of guix-daemons to build a bunch of packages for a system in parallel?
<bavier>shcv: pretty easy; it's how guix's build farms work
<bavier>shcv: see 'Daemon Offload Setup' in the manual
<shcv>that's about as easy as I was hoping it would be; not sure how I missed it when I was searching
<shcv>only found the CI stuff, which didn't quite look the same
<shcv>thanks for the info, bavier
<bavier>shcv: np :)
***buffet_ is now known as buffet
<lfam>`guix pull` on a slow machine just finished in ~2 minutes. It's great!
<Blackbeard[m]>lfam: ٩(◕‿◕。)۶
<amz3>#win
<bavier>interesting new tool for nix-env: https://www.tweag.io/posts/2019-03-28-introducing-lorri.html
<bavier>we should consider some of these 'pain points' when working on "guix environment"
<kmicu>Watch out. Many of those pain points are business pain points and do not exist in sustainable environments.
<nckx>Yikes. That ad is unreadable.
<janneke>Hello Guix!
*vagrantc waves to janneke
<Blackbeard[m]>janneke: ٩(◕‿◕。)۶
<nckx>efraim, or anyone really: I pushed an update for reptyr earlier this evening, and the ChangeLog notes that it now supports aarch64 (https://github.com/nelhage/reptyr/blob/master/ChangeLog). Anyone care to test that assertion?
<ngz>Hello. I'm trying to package OpenClonk, and get an error (https://paste.debian.net/1075124/) upon linking executables. I'm open to any suggestion to move forward. :)
<ngz>Apparently, other distributions (e.g., NixOs <https://github.com/NixOS/nixpkgs/blob/2d656a9729739e8ca5486058a76669d0ea4442df/pkgs/games/openclonk/default.nix#L41>) do not suffer from this, as I cannot see any obvious workaround for this kind of problem.
<nckx>efraim: I just saw my inbox. Never mind ☺
*nckx notes the top mail and checks the date.
<ngz>I tried to build from Github instead, with no success.
<ngz>hmm
<ngz>BTW, I think we prefer source tarballs from home instead of Github when possible, but using Github, we can use "guix refresh".
<rekado_>ngz: are you using an old daemon…? The build log looks rather ugly.
<rekado_>ngz: anyway, I think you may have to link with libiberty
<rekado_>-liberty
<ngz>I don't think it's an old deamon. I guix pull from root regularly (assuming daemon comes from there).
<ngz>OK, let's try adding libiberty to inputs and try again.
<rekado_>ngz: make sure that it’ll end up in the list of libraries that the binary will be linked with.
<ngz>Hmmmm
<rekado_>all these @build-log instances in the output make me think that that’s an old daemon
<ngz>How can I check?
<ngz>(and how can I add it to the list of libraries?)
<rekado_>depends on the build system
<rekado_>can we see the package definition?
<ngz>sure
<rekado_>FWIW, powertabeditor had a similar problem, so I patched it to link with -liberty
<rekado_>something like that may be needed there as well.
<ngz>Here it is: https://paste.debian.net/1075132/
<ngz>There are two origins because I tried both source tarball and github repository.
<rekado_>I guess you’ll have to patch this file https://github.com/openclonk/openclonk/blob/c47b7904680aa1e33c4b460d11160a0847ffa907/thirdparty/backward-cpp/BackwardConfig.cmake
<rekado_>so that set(LIBBFD_LIBRARIES ${LIBBFD_LIBRARY} ${LIBDL_LIBRARY}) will have “-liberty” as an additional value.
<ngz>So, that should be: set(LIBBFD_LIBRARIES ${LIBBFD_LIBRARY} ${LIBDL_LIBRARY} "-liberty") ?
<ngz>hmmm maybe simply ${LIBDL_LIBRARY} liberty)
<rekado_>nckx: … is it April yet?
<rekado_>(do I really need to respond…?)
<nckx>rekado_: I really can't tell anymore.
<shcv>how is the downloadable vm image supposed to be used? I didn't quite get the partition resizing instructions...
<rekado_>shcv: it is supposed to be used with Qemu.
<rekado_>ngz: I’m not sure. I’d try the first and then try patching in the absolute file name for libiberty.a.
<rekado_>(as is done in powertabeditor)
<rekado_>ngz: maybe you could even add “find_library(LIBIBERTY_LIBRARY iberty)” earlier and then refer to ${LIBIBERTY_LIBRARY} later.
<rekado_>whichever works, eh?
<shcv>rekado_: yes, and it runs; but it seems to be at 97% full, and I'm not sure what to do about that. It does say to delete and recreate the partition table... I think I broke it when I did that the first time though
<ngz>Sure. I'll take any working solution...
<rekado_>shcv: I’m not sure. What says that you should delete and recreate the partition table?
<shcv>the stuff it tells me after I run and log in as root, though they're directions for if you're running it on a VPS
<shcv>"Set a password; Set up networking; Expand the root partition by 0) recreating the partition with fdisk, 1) reloading the partition table with partprobe, and 2) resizing the filesystem with resize2fs"
<shcv>only, the root partition is first, so I'm not sure it can be resized without wiping the EFI partition...
<rekado_>oh, I see.
<rekado_>I don’t know the answer to this.
<rekado_>sorry.
<shcv>hmm. Guess I'll try with a normal install to a blank disk then
<rekado_>does EFI even matter when you’re using a VM?
<shcv>idk; how would qemu find what to boot?
<shcv>I haven't used it much myself...
<Blackbeard[m]>civodul: ping
<jrandall>is it possible to configure a guix channel so that it only processes a subdirectory of a git repo, or such that it ignores some files/directories when processing the repo? I am trying to set up a channel and it seems like things are getting tripped up by unrelated files in the repo (CI/CD scripts, etc)
***Digitteknohippie is now known as Digit
<civodul>Blackbeard[m]: pong
<civodul>jrandall: not yet, but i think we should add that
<Blackbeard[m]>civodul: hi
<Blackbeard[m]>I was reading about substitutes
<civodul>jrandall: the .guix-channel file could have room for such an option
<Blackbeard[m]>if the only download changed files its implemented
<jrandall>civodul: that would make sense - the rules probably do belong in the repo (rather than in channels.scm, for example).
<Blackbeard[m]>do you think that might lower the difficulty for a peer to peer network of binaries
<ngz>rekado_: adding iberty to the mentioned line got me further. Thank you.
<Blackbeard[m]>because as there will be less duplication
<Blackbeard[m]>it will be faster
<ngz>rekado_: Meanwhile, and totally unrelated, I tried using stepmania with guix environment --pure --ad-hoc stepmania, and could not reproduce the errors you encountered.
<shcv>so, what's the status on KDE support?
<quiliro>my second endeavor to add a package to guix: gramps
<nckx>quiliro: The genealogy software? Nice.
<nckx>I still have a .gramps file on an old hard drive, somewhere. ☺
<quiliro>gramps is a little too much for an amatuer genealogist...but it's like emacs...once you're in, you don't want out
<shcv>how do I start the networking in the live iso? I'm running it in qemu with -net user, etc., but it doesn't seem to be able to download anything
<pkill9>that would be neat Blackbeard[m]
<shcv>nevermind, I think I figured it out
<rekado_>ngz: I still get an error with stepmania on the Guix system.
<ngz>rekado_: OK. If you ever have some spare time for it, please try the workaround I suggested. I cannot test it myself because I cannot reproduce the error.