IRC channel logs

2019-02-16.log

back to list of logs

<Sleep_Walker>thanks, I'm getting a bit closer
<civodul>the repo is back \o/
<dt3>does anyone know where I might find the graphdriver (filesystem?) driver? docker is not starting because it can't find it or overlayfs
<dt3>I must be missing something.. it works on my laptop, but that has gnome installed
<dt3>"Error starting daemon: error initializing graphdriver: driver not supported"
***catonano_ is now known as catonano
<apteryx>Sleep_Walker: at least NetworkManager's OpenVPN plugin is broken at the moment in Guix
<apteryx>I was investigating for a while, but manually starting the openvpn client from the CLI gets me by for now.
<apteryx>I find the imported-modules VS modules arguments of the gnu-build-system highly confusing; the docstring of the `gnu-build' function in (guix build gnu-build-system) says that MODULES is for Guile's native modules, while IMPORTED-MODULES should be used for custom (user defined) ones; yet the defaults for both fields include custom Guix modules... Is this a mistake, or is the docstring wrong?
<Elon_Satoshi>Hello! What does "guix build: error: some outputs of `/gnu/store/blahblahblahblah-someprogram-1.0.drv' are not valid, so checking is not possible" mean?
<Elon_Satoshi>Remember when I was asking how to compile and challenge all packages in the Guix store? I think I just found an elegant way to do that! and it is `guix build --no-substitutes /gnu/store/* & guix build --check --no-substitutes /gnu/store/* && guix challenge`
<apteryx>Elon_Satoshi: nice! I didn't know you could pass store items to 'guix build'
<Elon_Satoshi>apteryx: One thing I'm confused about, guix build doesn't seem to compile anything unless I specify --no-substitutes. Why is tha?
<Elon_Satoshi>that*
<apteryx>does it download the substitutes?
<apteryx>that's what (with) substitutes are for
<Elon_Satoshi>Yes, it downloads substitutes
<Elon_Satoshi>I just tested guix build --check fortune-mod and it compiled something.
<Elon_Satoshi>Going to see what guix build fortune-mod does
<apteryx>OK, so that is expected: substitutes are prebuilt binaries, hence your system deosn't need to compile them.
<Elon_Satoshi>(and I ran guix gc -d /gnu/store/*fortune-mod* to make a clean slate
<apteryx>Elon_Satoshi: if substitutes are available for fortune-mod, it should just redownload it
<Elon_Satoshi>ah
<Elon_Satoshi>that's exactly what it did
<Elon_Satoshi>And when I run guix build --check fortune-mod it compiles it
<apteryx>guix build looks attempts to build a derivation (the build recipe of a package), and if substitutes are available, it's job is reduced to downloading the archive, checking its hash, and extracting it to your store.
<Elon_Satoshi>hmm
<Elon_Satoshi>The problem is, when I run `guix build --check /gnu/store/*` some package gets an error. For instance "guix build: error: some outputs of `gnu/store/*-bash-static-4.4.23.drv' are not valid, so checking is not possible"
<Elon_Satoshi>that's what I got this time
<apteryx>hm, I had this recently, and was wondering too what the invalid really means
<Elon_Satoshi>That's odd. When I run guix `build --check /gnu/store/*-bash-static-4.4.23.drv`, I get the same error. But when I run `guix build --check bash-static` it starts successfully downloading dependencies
<Elon_Satoshi>lemme try running guix build /gnu/store/blahblahblah-bash-static-blah.drv
<Elon_Satoshi>I think that fixes the problem
<Elon_Satoshi>Now I'm curious if running guix build --check on something twice, on the second time whether it will compile that package once more, or not.
<Elon_Satoshi>tested on fortune-mod, yup that compiles it twice
<Elon_Satoshi>You know, bootstrapping won't help if someone infects the GuixSD livecd with a virus that alters source codes
<atw>Elon_Satoshi: you may be interested to know about --rounds, which automates building several times
<Elon_Satoshi>To guarantee that we get a fully verified GuixSD live image, somebody's got to build a huge 3D printed computer that's fully open hardware but just powerful enough to compile and run stage0 on it
<Elon_Satoshi>I wonder if a self-compiling GuixSD image would be possible
<Elon_Satoshi>With a tiny binary written in hex that compiles a bigger compiler into binary and then runs that, etc
<Elon_Satoshi>Just a tiny binary and a bunch of source code
<Elon_Satoshi>Each source code, once compiled and ran, compiles the next source code and runs it
<Elon_Satoshi>But then that's foiled because the machine powerful enough to compile all that code has Intel ME on it, which installs NSA bugs in the sources
<atw>that sounds like some of the bootstrap work that is underway https://github.com/oriansj/talk-notes/blob/master/Current%20bootstrap%20map.pdf
<Elon_Satoshi>ooh
<atw>Elon_Satoshi: your point about ME-freedom is a good one, I wonder how many days it would take an X200 to build the world. Perhaps one of the newer RYF devices can compile quickly? https://www.fsf.org/resources/hw/endorsement/vikings
<Elon_Satoshi>Hmm.... What if there was some kind of verification as part of the compilation process? Can hash checking be implemented in assembly, or whatever language a tiny boostrap hex program can compile?
<Elon_Satoshi>That might make it a little bit harder for malicious firmware to attack
<Elon_Satoshi>Let me know if I'm just talking nonsense about things I don't know about
<Elon_Satoshi>I have only an abstract understanding of such low level things tbh
<atw>likewise :) but it seems like hash-checking early in the bootstrap process could be possible
<Elon_Satoshi>oooohmm
<Elon_Satoshi>Great, so now all we need to do is start with a huge open source turing machine that boostraps some stuff onto a USB drive and then you plug that into a more powerful, but less trusted device and do the rest of the bootstrapping
<Elon_Satoshi>until a neutrino hits a bit causing /dev/urandom to dump windows 10 professional edition onto the usb drive
<atw>lol
<Elon_Satoshi>lol
<Elon_Satoshi>or worse, a butterfly flaps its wing
<Elon_Satoshi>why do i get hyper like this at night
<Elon_Satoshi>not so sure if hash checking would work, an attacker could modify the program to go ahead with compiling the next program even if the hash doesn't match
<Elon_Satoshi>or change the hash to match the modified source
<atw>you would have to receive the hash from a trusted source
<atw>via trusted means
<Elon_Satoshi>you'd have to recieve the source from a trusted source
<Elon_Satoshi>i think that means miles upon miles of punch hole paper to be fed into the huge turing machine so that it can copy it onto the usb drive
<Elon_Satoshi>actually
<atw>if the hash function is preimage resistant, then the source can be received through arbitrary means, I believe
<Elon_Satoshi>we need to use 3d printer to make a better 3d printer, then use that to make an even better 3d printer (I mean reprap is already planning to evolve 3d printers)
<Elon_Satoshi>and then after lots and lots of collaboration and development for who knows how long, produce a fully open source laptop that even comes close to proprietary hardware
<Elon_Satoshi>and then we can trust it to do all the bootstrapping
<Elon_Satoshi><atw> if the hash function is preimage resistant, then the source can be received through arbitrary means, I believe
<Elon_Satoshi>i didn't understand all of that because you actually know what you're talking about unlike me
*Elon_Satoshi starts duckduckgoing
<atw>:) if the source is x and has hash h(x), and you are given h(x), then an attacker must construct malicious source y such that h(y) = h(x)
<Elon_Satoshi>that's called a collision isn't it?
*Elon_Satoshi reads the wikipedia article on preimage attack
<atw>Elon_Satoshi: yes, though "collision resistance" is distinct. In that version, the attacker controls both the "good" and "bad" sources. Trying to find a good article on it that I read...
<Elon_Satoshi>ooh double hashing
<Elon_Satoshi>i just realized some of this bootstrapping will have to be in the BIOS
<atw> https://en.wikipedia.org/wiki/Hash_function_security_summary is great. Note that even MD5 is not yet vulnerable to a preimage attack in practice
<atw>...though it's not the article I'm looking for, which was a tutorial on how to make a pair of programs, one good and one evil, which have the same md5sum
<atw>aha! https://www.mscs.dal.ca/~selinger/md5collision/
<Elon_Satoshi>brute forcing?
<Elon_Satoshi>thanks for the article!
<atw>I suppose that by the pigeonhole principle, brute forcing is guaranteed to find a preimage eventually
<Elon_Satoshi>hmm
<atw>(and by the pigeonhole principle, that is true of any hash function)
<Elon_Satoshi>now I have to wonder, if someone like the NSA has a supercomputer that they use to brute force things like that... if they didn't bootstrap the software on that computer then how do THEY know they can trust it?
***ym555_ is now known as ym555
***catonano_ is now known as catonano
<Elon_Satoshi>when they're after you and you have to be super ultra paranoid
<Elon_Satoshi>guix build --no-substitutes /gnu/store/* && guix build --check --rounds=9001 --no-substitutes /gnu/store/* && guix challenge
<swedebugia>hi, guile-gnome seems to be missing all its documentation
<swedebugia>it also installs into the wrong output folder it seems and thus is not in the load path
<roptat>hi guix!
<janneke>hi roptat!
<roptat>qt applications don't seem to understand my dead keys, although every other application does...
<kmicu>roptat: dead keys?
<kmicu>If there is a problem with the input then could you try ‘QT_IM_MODULE="xim" yourqtapp’?
<roptat>it doesn't change anything
<roptat>I mean keys that are used in combination with others to make accents (^+a = â for instance, but I can't type ^ in the first place in Qt app)
<kmicu>Sounds like ~/.XCompose. That QT_IM_MODULE=xim thing worked for me in the past but I don’t use any Qt apps so maybe that is broken in newer versions too. 🤷
<tune>so no one else is experiencing icecat crashes? aka bug #34454
<tune>might be more to do with x11 or something more generic
<tune>I still have emacs open from before updating and I'm paranoid it'll start crashing if I restart it
<tune>I was pleasantly surprised that qutebrowser seems to work again, though. I installed that so now I have a browser I can use besides the emacs browser
<kmicu>tune: even when the version ater update has some issues we can always execute the previous one working properly ― it’s still in guix store. No need to be afraid in Guix world 😺
<tune>yeah when I first had it I rolled back but I'm worried then I'll end up having to rebuild a bunch of stuff in the future when I update again
<tune>my most recent update looked like it rebuilt almost every package on my system, although that might be another issue
<tune>I'm almost always having to delete a current-guix file before I can update
<tune>and sometimes my user can't upgrade because suddenly root owns ~/.cache/guix
<tune>so then I chown that
<tune>stuff like icecat, rust, qtwebkit, etc. take several hours to build and then my cpu usage is so high it feels like I can't do certain things (e.g. video playback)
<kmicu>Ah you agressively GC to save space? Yeah, that sucks.
<tune>I used to, I don't really anymore
<tune>I'm pretty sure things are not working correctly
<tune>difficult for me to understand what's going on so it just goes unsolved
<tune>I bring some of this up in here occasionally
<tune>I think one or two others have the problem with having to delete a current-guix file before each update. something to do with a migration from an old system that wasn't done properly or something
<tune>but I've changed my symlinks and such properly I believe
<kmicu>If you do not GC then there should be no recompiling at all (unless you override packages in the meantime).
<kmicu>(Something is not nominal for sure on that box. Guix/Nix should remove any worries not generate them.)
<tune>qutebrowser crashed when scrolling down with the keyboard (pressing the j key)
<tune>scrolling with the mouse seems to work fine
<tune>I used the built-in crash reporter but I'm not sure if the problem is with the program itself or something on the guix side
<roptat>ha my issue might be related to this warning: Qt Warning: Could not find a location of the system's Compose files. Consider setting the QTCOMPOSE environment variable.
<tune>I'm trying out stumpwm and it doesn't seem to have a man page or gnu info page. I had to go find an online manual
<nckx>i3 sucks in that regard too.
<kmicu>roptat: that makes sense, it looks like Qt5 moved to that. Qt4 apps should still work with QT_IM_MODULE.
<kmicu>roptat: https://mail-index.netbsd.org/pkgsrc-bugs/2014/01/26/msg053405.html “Qt5 uses hard coded directories and the QTCOMPOSE environment variable to find it's compose files.” so a patch for Guix is required.
<roptat>kmicu, I see, thanks!
<roptat>do you know where that variable should point to, though?
<roptat>and does it mean that I won't be able to use ibus with qt apps?
<roptat>I can't find any file on my system with a name containing "compose"
<tune>I broke my stumpwm prefix key. What's the best way to get back to the guix login screen?
<tune>I tried going to TTY1 and hitting ctrl-c but that didn't end the session. I also tried "pkill xorg" from a tty with no luck.
<kmicu>roptat: usually there is a ‘XCompose’ file in the store (somewhere in X11 locale files) or ~/.XCompose for user defined sequences.
<kmicu>([Joke] As a workaround you could also rewrite that Qt app in GTK or use a TUI/CLI alternative. 😺)
<roptat>well, I'm the developper of that app and I considered gtk at first, but had terrible performance :/
<roptat>it used to work until recently
<quiliro>hello
<quiliro>why does epiphany output an error on https://campus.aprenderlinux.com/
<tune>okay 'sudo pkill slim' worked pretty well
<rekado>quiliro: this host does not seem to exits.
<rekado>roptat: you should still be able to use ibus with qt applications.
<roptat>well, it doesn't seem to work
<tune>wow... had to run "guix package --rollback" 5 times for emacs to stop crashing on start
<tune>If I apply my manifest after rolling back without doing a guix pull can I get back some packages without also getting the broken stuff back?
<tune>like by it using older versions of stuff
<tune>I guess I'll try and find out
<phenoble>Hi #guix
<tune>that didn't seem to work
<pkill9>tune: you can use `guix package --do-not-upgrade=emacs -u` to upgrade everything but emacs
<phenoble>New guix user here. Just installed emacs on a system using guix; on startup it can't find libpcre.so.3 though. Is the emacs package broken?
<pkill9>though you can't use it with a manifest
<tune>icecat and emacs are both affected. it's maybe gtk or something that breaks, although maybe telling one of them not to upgrade can affect their dependencies
<phenoble>(I did a guix pull before, triggering a full upgrade and rebuild.)
<tune>can I tell two packages not to upgrade?
<tune>also not being able to use it with a manifest sounds annoying. I don't get how it would work then
<tune>the manifest is the only way I've installed anything so I wouldn't want to separately keep track of unlisted stuff
<pkill9>you cna specifiy --do-not-upgrade multiple times
<pkill9>for multiple packages
<tune>ah okay
<tune>so I guess that'll upgrade the other things in this current generation but I think I'll still be missing stuff I installed in newer generations
<tune>like I'd just recently installed xmodmap by adding it to my manifest and it's gone from rolling back
<tune>okay I did my upgrade with a couple --do-not-upgrades specified and that seems to have worked fine
<pkill9>yeah
<pkill9>it would be good to make it so that when you use --do-not-upgrade with a manifest, it checks the profile for any packages in both the manifest and your profile and uses the one form the profile instead
<quiliro>rekado: checked that web page on Debian Firefox
<quiliro>rekado: it opens correctly
<quiliro> https://campus.aprenderlinux.com/
<nckx>quiliro: It can't ‘open correctly’ sice it has neither A nor AAAA records.
<tune>pkill9: So how does mixing manifest and non-manifest stuff work? If I install something with guix package -i and then later install my manifest, does the earlier package get removed?
<quiliro>also, i could not install firefox because of a rust compilation error
<nckx>It does not exist.
<quiliro>on i686
<quiliro>nckx: ok...i understand....
<nckx>quiliro: Are you sure the domain you gave to Firefox is exactly the same?
<quiliro>nckx: yes
<nckx>quiliro: I also tried GNU IceCat on the off chance that it's some weird Firefox bug, but it fails properly.
<tune>does anyone have experience with "makeinfo"? the stumpwm docs said I can make an info page out of a file it comes with called stumpwm.texi. I searched for makeinfo and the only result was texi2html, so I installed that but it does not add a makeinfo command.
<pkill9>yeah it does get removed tune
<tune>okay cool
<pkill9>using manifest basically overwrites the profile
<tune>I won't worry about manually installing stuff then if my manifest will correct it all later
<nckx>tune: It's part of texinfo.
<tune>nckx: okay, thanks
<tune>Interesting. So it worked, but it put the .info file in my home directory. Where are the other info files? I'm hoping if I put it in the right spot it will show up in the main list.
<nckx>tune: Might be as easy at looking at ‘echo $INFOPATH’. OTOH, I know info uses a central ‘directory’ that might need to be updated too. Guix does this in a profile hook and won't know about your file.
<tune>hm looks like system profile info stuff is in /run/current-system/profile/share/info
<tune>but I can't copy it there with or without sudo, it says it's a read-only file system
<nckx>tune: Right, but mine lists /home/nckx/.config/guix/current/share/info first.
<nckx>That's writable.
<phenoble>Anyone have an idea of what to do with the error: "/gnu/store/gppr8msvzgxr87psbj3w6hc07lnnzpvx-emacs-26.1/bin/emacs-26.1: error while loading shared libraries: libpcre.so.3: cannot open shared object file: No such file or directory". I just installed emacs as my first non-toy guix package, with this result :/.
<tune>yeah I guess. I was hoping to put it in a system spot because this particular package is in my system profile
<phenoble>Shouldn't guix ensure that all library dependencies are met?
<nckx>phenoble: ...yes. The f.
<phenoble>nckx: the f?
<nckx>What the f indeed!
<tune>nckx: actually that spot gives me the same error
<tune>about a read-only file system
<phenoble>the f I see!
<nckx>tune: Ah, of course, that's a symlink into store territory.
<tune>maybe I should just open an issue suggesting someone add the info page to the package in the next update. it comes with the tex file needed to make it
<nckx>tune: Does adding you home directory to INFOPATH work? That would be too easy, but who knows.
<tune>I was thinking of trying that
<nckx>tune: Oh, it's a Guix package that could have a manual but doesn't install it? Which one?
<tune>stumpwm
<tune>I just had to do "makeinfo /gnu/store/yvdcxss7gyp7gx4nxhp80i5s9iw88wz6-stumpwm-18.11-lib/share/common-lisp/sbcl-source/stumpwm/stumpwm.texi.in"
<nckx>phenoble: I'm guessing this is on a foreign distro and I have 0 XP on those. Sorry.
<tune>I found the file with the locate command
<nckx>tune: Yah, we probably shouldn't ship that .in file at all.
<phenoble>nckx: if by foreign you mean non guixsd, then yes: Ubuntu 17.10
<nckx>tune: Feel like submitting a patch? :-)
<tune>FYI including my home folder in $INFOPATH does work and let me just run 'info stumpwm'
<tune>I'm not much of a programmer, I don't think I'd know what to do for the patch
<nckx>tune: No prob. I'll give it a go.
<nckx>And nice!
<phenoble>nckx: Is this a common issue with guix, when using it on "foreign distros"? I thought these are the exact problems that guix was created to solve.
<phenoble>For I am intending to use it for distro-independent package management.
<nckx>phenoble: I only have experience with Guix-as-a-whole-distro(/lifestyle). But yes, that obviously shouldn't happen™.
<phenoble>I see.
<nckx>It probably means that emacs is looking for that library in an unqualified locatien (i.e. without leading /) but that's just a guess.
<nckx>phenoble: I'd strongly urge you to file a bug report if you have the time.
<nckx>bug-guix@gnu.org
<phenoble>nckx: searching through /gnu/store reveals that there is no libpcre.so.3 version of pcre; only libpcre.so.1
<phenoble>nckx: will do, thanks
<nckx>phenoble: I wonder: does ‘guix environment --pure --ad-hoc emacs -- emacs’ work?
<nckx>^ also mention that in the report, whatever the case.
<phenoble>nckx - that worked.
<nckx>OK, so there's some form of environment (variable) pollution going on. Someone who knows more about Guix on Ubuntu/Debian might know more.
<phenoble>nckx: Are you thinking about my environment i.e. $PATH and $LD_LIBRARY_PATH, or some guix-internal environment configuration?
<phenoble>I would've assumed that by running the daemon as root, the user's environment would not interfere.
<nckx>phenoble: Your user's environment. Something like (but probably not) those variable.
<nckx>*s
<nckx>phenoble: Guix builds packages through the daemon, but they run in your current environment.
<roptat>phenoble, the environment doesn't interfere with what's installed by guix (it's the same whatever host distro you use, either guixsd or ubuntu or whatever)
<roptat>but then, they run in your environment, which can influence the behavior of the installed binaries
<phenoble>Ok, so, well - unsetting LD_LIBRARY_PATH fixed it.
<roptat>cool :)
<nckx>phenoble: Oh. I guess I spoke too soon :-D
<nckx>But... why is it set? And what to?
*nckx has no LD_LIBRARY_PATH set and only ever used it as a debugging hack.
<phenoble>The fact that I have set it, and actually at one point had to set it to get things to run after hours on end of trying, is just why I am here, ... :)
<nckx>Well at least it's better than the alternative, that Ubuntu sets it by default. Phew.
<nckx>Building the stumpwm manual ‘properly’ requires running a whole parallel autotools bootstrap next to asdf-build-system/sbcl. 😒🔫
<nckx>Let's see if we can do it improperly.
<bavier>fun discussion on guix-devel about chromium
<nckx>bavier: Your definition of fun intrigues me and I wish to subscribe to your newsletter.
<nckx>Unfortunately, my mail box is full of chromium discussion right now.
<bavier>heh :P
<nckx>(‘Haven't we been over this... repeatedly?’)
<bavier>I'm personally on the 'innocent until proven guilty' boat
<nckx>Agreed. I hate Chromium with a relish seldom seen, but using bad arguments helps noone.
<Levy[m]>Wasn't it being non FSDG compliant the end of it?
<mbakke>bavier: I'm glad someone gets value out of it! :P
<quiliro>nckx: it fails properly? haha
<quiliro>but why does firefox on debian (without guix) no "fail properly"?
<nckx>quiliro: Well, it is the correct behaviour :-)
<bavier>I trust the liberation work mbakke has done, which imo should be enough for the FSDG until more conrete issue are discovered
<nckx>quiliro: Maybe the domain existed at some point and Debian FF still has it cached. No way to tell from here.
<quiliro>nckx: s/no/not/
<quiliro>it happens with some domains
<nckx>‘[k]dig +short campus.aprenderlinux.com a campus.aprenderlinux.com aaaa’ says ’no such thing buddy’.
<mbakke>Thanks :) Much of this work was really to get QtWebEngine in Guix, but don't tell anyone...
<nckx>quiliro: What happens?
<bavier>mbakke: I kinda assumed it was for that
<quiliro>on the console it is resolved as 190.210.189.166
<quiliro>nckx: it is not resolved on the browser but it is on the console
<quiliro>with ping
<quiliro>that happens with other domains that i cannot remember now....other days I tested them
<nckx>quiliro: $ ping campus.aprenderlinux.com → ping: unknown host
<quiliro>sorry campus.aprenderlinux.com.ar
<nckx>
<quiliro>by the way on other stuff... I found this command: ffmpeg -i input.mp4 -acodec libvorbis -vcodec libtheora -f ogv output.ogv
<quiliro>very useful to stop spreading non-free formats
<quiliro>nckx: could you ping the new domain?
<nckx>You did say you double-checked.
<nckx>Yes, that does exist.
<nckx>Works in IceCat & Epiphany on Guix System. Which browser did you say displayed an error?
<quiliro>Epiphany on GuixSD i686
<quiliro>no 64bit
<quiliro>only 32 bit
<quiliro>and it is not possible to install icecat
<quiliro>because rust is broken every time i try to install icecat
<nckx>God, Epiphany is slow.
<quiliro>it is a dependency
<quiliro>it is?
<nckx>quiliro: Yeah. That's being investigated.
<quiliro>by you?
<quiliro>cool
<nckx>On that page, at least, yes. It's a lot jumpier to scroll than Firefox. First time I've used it, though.
<nckx>quiliro: No, by far more competent individuals :-)
<quiliro>how about icecat?
<quiliro>did you test on the three?
<nckx> https://lists.gnu.org/archive/html/guix-devel/2019-02/msg00050.html
<nckx>Sorry, s/Firefox/IceCat/.
<nckx>I'm on a Guix System so no Firefox for me.
<mbakke>I have a patch for Librsvg 2.44 which requires Rust 1.27.
<mbakke>2.46 will require Rust 1.30.
<nckx>tune: stumpwm now has a manual on master.
<nckx>It's a bit hacky so let me know if something's not quite right.
<nckx>Stuff like ‘### *batch-menu-map* @ select-from-batch-menu’ is supposed to be run through a macro expander, but someone who knows the first thing about sbcl (like, what it even stands for) is needed for that.
<quiliro>nckx: could you open that website on Epiphany?
<nckx>quiliro: > Works in IceCat & Epiphany on Guix System. Which browser did you say displayed an error?
<adfeno>Hi there :D
*adfeno is reading emails about the Chromium unclear freedom status.
<adfeno>I hope my last emails went through all the mailing lists involved
***fanta7531 is now known as fanta7531|away
<quiliro>nckx: it does not work on GuixSD Epiphany on i686
<nckx>quiliro: Epiphany built for i686-linux (but running on a 64-bit kernel) works too.
<quiliro>nckx: that is exactly the case
<quiliro>for me
<quiliro>sorry...no 64 bit kernel
<quiliro>32 bit Guix completely
<quiliro>but on 64 bit machine
<quiliro>is there a way to transform this 32 bit system to a 64 bit system or do I have to reinstall from flash?
<nckx>This machine is too slow to spin up a 32-bit VM. You'll have to debug it on your own, sorry.
<nckx>quiliro: I'd just reinstall.
<quiliro>ok...see you when the new system is installed then! bye
<nckx>quiliro: Have fun/good luck.
<tune>nckx: awesome, thanks!
<nckx>I should have better indicated in the comment that it's missing autogenerated variable lists &c. :-/
<tune>I started upgrading my user profile and then remembered I have stumpwm installed as a system package
<tune>but planning to update asap
<mikadozero>Is the root user the configured the same way as other users?
<phenoble>So I'd like to make the Anaconda python distribution available via guix. I see there's a conda guix package, the package manager that Anaconda uses internally. Is there a guix-y way to do that?
<nckx>mikadozero: Yes. Root isn't special in Guix, just another user.
<nckx>Or do you mean in the OS configuration?
<mikadozero>nckx: Configuring with config.scm and reconfigure.
<nckx>mikadozero: There's a default root user in %base-user-accounts, but it can also be modified.
<mikadozero>I want to change the shell for root to zsh can I do this with:
<nckx>It's just a sane default, nothing special.
<mikadozero>(user-account (name "root") (shell #~(string-append #$zsh "/bin/zsh")))
<mikadozero>reconfigure says error: missing field initializers (group home-d
<mikadozero>irectory)
<mikadozero>What would be the default group and home-directory for root?
<mikadozero>How do I see what is in %base-user-accounts?
<phenoble>So, anaconda is actually a conda package itself that can be installed with it - alongside any other python package one might want from the distribution. Problem solved.
<phenoble>On to the next one: the guix build for conda fails on my system with ... 91 errors.
<phenoble>Is this something I should mail to bug-guix?
<phenoble>Or is there anything I could/should do before?
<mbakke>mikadozero: The root account is defined in gnu/system.scm (search for %root-account).
<mbakke>phenoble: Yes, please report it to bug-guix.
<mikadozero>mbakke: Thanks I will try to find that file.
<kmicu>You add new emails to that Chromium thread‽ Noooooooooooooooooooooooooooooooooo. 😹
<adfeno>kmicu: Hehehe
<adfeno>The elephant in the room must be addressed. :D
<kmicu>There is no elephant only double standards.
<mbakke>kmicu: I'm just trying to stop the FUD and focus on real problems (such as the fact that QtWebKit is horribly outdated and must be removed).
<phenoble>mbakke: done.
<adfeno>mbakke: Well, that is one way to do it indeed :D
<adfeno>s/ do it / do things /
<kmicu>mbakke: thank you for that (even though I don’t plan to use it, thank you for using facts and doing not endlessly talking in not-kind manner).
<mbakke>adfeno: I don't know any other way ;)
<adfeno>Well, I just added another message to that discussion :D
*kmicu [screaming in Darth Vader’s style] Nooooooooooooooooooooooooooo!
<adfeno>Sorry, I had to
<adfeno>bandali: Hey there, thanks for checking the review which was previously at https://directory.fsf.org/wiki/Talk:Chromium
<adfeno>(since now, it was moved to https://directory.fsf.org/wiki/Review:Chromium-REV-ID-1 , but the other talks/comments where preserved, so I had to do a manual redirect/pointer).
<daviid>hello! someone reported on guile-gtk-general (the guile-nome user ML) that in Guix, the guile-gnome package 'is broken', is this true? I find that somehow diffuclt to beleive :) and since I'm not yet using guix, although following guix-devel and this channel, I wish someone here could try ...
<phenoble>daviid: I just successfully built and installed the package on an up-to-date guix on ubuntu 17.10, so it would not appear broken to me.
<daviid>phenoble: thanks, this confirm what I thought
<daviid>*confirms
<daviid>it would be nice if someone would also make a guile-clutter package for Guix, which is not going to be 'a piece of cake', but would be extremelly usefull, imo ...
<daviid>phenoble: could you tell me if you can find the guile-gnome examples, in the just installed version you have?
***lostcoffee is now known as atw
<atw>has anyone had trouble launching graphical emacs recently? specifically, "Fatal error 6: Aborted" and an exit code of 134? I'm going to bisect guix, but I wanted to check first to see if this problem is peculiar to me
<phenoble>daviid: A search for *guile*gnome*example in the guix store returned no results. What are you looking for exactly? I'm not familiar with guile-gnome, less so with its guix-package.
<phenoble>atw: I built and installed the guix emacs package earlier today, and was able to start it without this error. Looks like it's just you. Sorry :-).
<daviid>phenoble: it's ok, I just wanted to confirm that in Guix, examples are not installed (they re distributed here: http://git.savannah.gnu.org/cgit/guile-gnome.git/tree/gtk/examples
<phenoble>daviid: I just searched for some of those files, and they're not in the store. I think you can consider this confirmed.
***raghavgururajan is now known as Guest44876
***raghavgururajan5 is now known as raghavgururajan
<daviid>phenoble: thanks
<jlicht>hey guix!
<bandali>hey adfeno, thanks for that link!
<bandali>i tried downloading the result manget links earlier but no dice
<tune>atw: my emacs and icecat have both been crashin recently
<tune>atw: https://debbugs.gnu.org/cgi/bugreport.cgi?bug=34454
<tune>not sure if it's the same problem
<tune>looks like the emacs crash I'd recorded is fatal error 5, not 6
<adfeno>bandali: Did you have DHT and PEX enabled?
<adfeno>bandali: Re: not being able to download the torrents ^
<adfeno>Because I'm seeding these right now... If all goes right, you might be able to download from me.
<quiliro>hello
<adfeno>Hi quiliro :D
<quiliro>i found no sample config.scm with swap-devices
<quiliro>adfeno: nice to see you!
<adfeno>Nice to see you too quiliro :D
<quiliro>adfeno: thks
<quiliro>adfeno: what are you up to?
<adfeno>Contributing to reviewing or solving the unknown freedom status of Chromium browser.
<quiliro>cool!
<quiliro>i would like to help too...but i am still raw
<quiliro>i can only report errors....most of the time they are mine and not guix's
<adfeno>quiliro: Sorry, I don't understand what you meant by "raw".
<quiliro>adfeno: newbie ....haha
<adfeno>quiliro: Oh I see
<quiliro>not cooked yet!
<adfeno>the issue with Chromium isn't guix-specific
<adfeno>it's actually related to all free/libre system distribuitons.
<quiliro>true
<quiliro>what have you reviewed up to now?
<adfeno>It basically involves checking the top of each of the text files or finding out if the file makes use of JavaScript (this last part is somewhat more advanced check).
<adfeno>quiliro: My progress is at https://directory.fsf.org/wiki/Review:Chromium-REV-ID-1
<quiliro>nice....thank you for helping freedom
<atw>tune: your stacktrace is similar to mine (we diverge a bit after gdk_display_get_event+0x79) but the version of emacs that we are running is identical. I also had some icecat crashes but didn't mention them as I found them less easily reproducible than emacs, which is always crashing on start. What wm are you using?
<bandali>adfeno: not sure, let me try afain
<bandali>*again
<adfeno>quiliro: You're welcome :D
<adfeno>bandali: OK :D
<tune>atw: I'm using awesomewm
<bandali>adfeno: they're both enabled, but transmission is stuck on "Downloading metadata from 0 peers" :/
<adfeno>Did you get the torrent from my last page change?
<bandali>yup
<bandali>ah ok so it just downloaded the metadata
<adfeno>Actually, simply tell me the hash of each torrents you have. So I can compare with mine
<adfeno>Oh, great :D
<bandali>916fd8a45158ff660811a06beb6c3ec258a3b50e and 58727285fc54c76a431b0d273821d61f49f601a9
<bandali>thanks :)
<adfeno>You're welcome :D
<bandali>:D
<bandali>i wonder if my attachment reached the list(s)
<bandali>also, thanks for picking up work on this :)
<adfeno>These reports are big, since the project in review is
<atw>tune: hmm, ok, it would have been a suspicious coincidence if we were using the same wm, but I'm using spectrwm
<bandali>right
<adfeno>bandali: You're welcome, someone has to start it :D
<bandali>_^/
<adfeno>If you like to, you can use LibreOffice Calc to open the .CSV files
<bandali>sure :) i'll probably have a look later tonight
<adfeno>For example, considering the FSD Script Aid report ("chromium.csv") after openning it in Calc, ...
<adfeno>... select the cell below and to the right of the last column label, put the horizontal scrollbar all the way to the beginning of the line ...
<adfeno>... and go to "View" → "Freeze rows and columns".
<quiliro>found how to use swap in a forum message: (swap-devices '("/dev/sdb1"))
<quiliro>gotta reboot...i have to test the installed system
<quiliro>bye
<adfeno>bandali: ... that enables the column labels to be always visible.
<adfeno>To check the files, you can, for each cell in the "Path" column, simply select and copy the cell (Ctrl+C) (no need to edit the text inside), and paste it into a terminal that already has your favorite text editor command typed with a space after it (but not sent to run yet).
<adfeno>bandali: i'll actually add a note in that page, to mark in the "Notes" column an entry with "Continue." phrase so that people know where you left of.
<adfeno>(this is what I did).
<dt3>excuse my ignorance, but won't chromium run into the same problem as firefox? recommending non-free addons?
<adfeno>Yes it does have that problem
<dt3>so it would be forked a la icecat?
<adfeno>Also there is the issue that even if someone patches a non-free software sufficiently to include it into a freee/libre distro, ...
<adfeno>... for people who are unaware of the patches/changes made, these people will think that such software is free.
<adfeno>.. or is OK in it's original distribution form.
<dt3>yeah, I see
<adfeno>dt3: I don't know if it would be forked, as I can't assure it will happen.
<dt3>tbh, I'm not a big fan of firefox's exclusion (or debian for that matter), but it is what it is
<adfeno>From this year on, if I make a change to a software so that it complies with the GNU FSDG, I tend to forward the patches/changes to the original project too.
<adfeno>It's of course my personal preference, as we can't demand contributors to do that.
<dt3>yeah, and worth a shot. good work
<adfeno>and some upstream project have not so nice people
<adfeno>.. specially when they see/hear "G-N-U".
<dt3>I could imagine. does google maintain the chromium releases?
<adfeno>I can't speak much of Chromium, except that it needs to be reviewed for the freedom status, and I can't do it alone
<adfeno>I can't because I hardly know much about the project internals
<tune>I believe there's a fork called ungoogled-chromium that doesn't use the normal addon s tore
<dt3>yeah, definitely, must be a ton of code
<adfeno>dt3 tune: I was informed that ungoogled-chromium only does brand removal
<adfeno>and *some* call-home removal.
<tune>hm I might be mixing up things I heard then
<tune>I remember something about having to download an addon that let you avoid the store
<tune>I haven't used chrom* in many years
<bandali>adfeno: thanks for the tip :) it's been ages since i've used spreadsheet software
<bandali>and it'd be nice if you added that note to the page
<adfeno>bandali: The note about the "Continue." mark? Yes, I already did. :D
***notnotdan is now known as notnotdan[m]
<ArneBab>installing scribus worked now, after guix pull && guix package -u
<quiliro>hello again
<quiliro>successful installation
<adfeno>Welcome back quiliro
<adfeno>Yay! :D
<quiliro>i can make a good installfest now!
<quiliro>free installation...charged certificate :-)
<adfeno>Hehehehe
<quiliro>adfeno: are you currently employed at the FSF?
<quiliro>I am currently learning Emacs org-mode
<quiliro>very interersting
<adfeno>Not yet, although I would like to :D. Currently I am an employee of a public municipal organization that is responsible for defending the consumer's rights according to Brazil's Consumer Protection and Defense Code law.
<quiliro>adfeno: nice!
<adfeno>Indeed it is :D
<adfeno>quiliro: I used to use org-mode, but I no longer do it
<quiliro>they pay you to do good for people....
<quiliro>adfeno: why so?
<adfeno>Agree.
*quiliro is installing emacs-guix now!
<quiliro>why do you not use org-mode?
<adfeno>quiliro: I decided to follow Brazil's federal interoperabilty norms, but also for my personal use. Precisely because they foster OpenDocument Format, the standard used by LibreOffice files.
<raghavgururajan>How can I create a "host-file" ??
<quiliro>oh...i think emacs can export to odf
<adfeno>... for document, slides, and spreadsheets.
<quiliro>raghavgururajan: i have that problem too
<raghavgururajan>Hmm
<quiliro>every time i reboot, /etc/hosts file is overwritten