IRC channel logs

2019-02-03.log

back to list of logs

***daviid is now known as Guest4583
***Guest4583 is now known as daviid
<rekado>hey there
<rekado>looks like I lost my power supply somewhere at FOSDEM
***daviid is now known as Guest3548
***Guest3548 is now known as daviid
<tleydxdy_m>I'm getting errors during installation on qemu, logs shows that gcc segfaulted when building xf86-video-ati
<efraim>If anyone is interested in the microkernel room it's about to start and is pretty empty ATM
<Sleep_Walker>efraim: how big is crowd this year? is it possible to get to rooms? is it possible to visit different rooms? :)
<efraim>Sleep_Walker: I spent all of yesterday in the microlanguages room so I'm not sure
<efraim>Our room didn't have an empty seat all day
<efraim>Sunday is normally smaller
<efraim>s/micro/minimalist
<Sleep_Walker>I am not visiting FOSDEM this year and just watching it online
<Sleep_Walker>I have less interactions but more time for talks :)
<Sleep_Walker>and streams work like charm this year
<tyil>I'm going to FOSDEM for the social aspect, and I'll watch talks when I get back home :p
<efraim>Couple of Guixers here for the Hurd talk
<Sleep_Walker>watching stream :)
<rekado_>I’m having trouble usig gdb with a package that has a “debug” output.
<rekado_>I’m debugging a segfault in ghostscript.
<rekado_>I followed the Guix manual’s instructions on doing “set debug-file-directory ~/.guix-profile/lib/debug” after installing the debug outputs
<rekado_>I also set “directory” to the directory containing the sources.
<rekado_>I set a breakpoint and then run the program
<rekado_>it stops and I’d like to get more information about the code at this point.
<rekado_>so I run “list”, but it says: No symbol table is loaded. Use the "file" command.
<rekado_>okay, so I just did “file /gnu/store/z8lkz16mzvprg6k7vpcwcjmvhp10myzp-ghostscript-9.25/bin/gsc” (that’s the target of “gs”), and it works fine.
<rekado_>*doesn’t* work: it reads the associated debug file, but it claims that there are no debug symbols.
<rekado_>hmm
<Sleep_Walker>isn't symbol-file what are you looking for?
<Sleep_Walker>and is this from debug output? /gnu/store/z8lkz16mzvprg6k7vpcwcjmvhp10myzp-ghostscript-9.25/bin/gsc
<rekado_>I do this: (gdb) symbol-file /home/rekado/.guix-profile/lib/debug/gnu/store/…-ghostscript-9.25/bin/gsc.debug
<rekado_>Reading symbols from /home/rekado/.guix-profile/lib/debug/gnu/store/…-ghostscript-9.25/bin/gsc.debug...(no debugging symbols found)...done.
<rekado_>
<Sleep_Walker>that is right approach IMHO
<Sleep_Walker>is ghostscript build with -g?
<Sleep_Walker>s/build/built/
<rekado_>I’m not sure… I assumed the gnu-build-system would pass it when a “debug” output exists (like it handles the debug link files).
<rekahsoft>Hi all, how can I build a package from the guix repl?
<rekahsoft>I am attempting to debug an issue where when I run a build of a package I run out of memory (possibly due to a circular dependency?)
<rekahsoft>I can't seem to get 'guix build -L $(pwd)/site -e '(use-modules (rekahsoft packages rust-xyz)) rust-autocfg' to work, which would be preferred to using the repl directly. The error I receive when I attempt the 'guix build ...' I mention is 'guix build: error: #<unspecified>: not something we can build'
<rekahsoft>However in a repl when I run (use-modules (rekahsoft packages rust-xyz)) rust-autocfg I see a package object literal
<rekahsoft>When I move the '(use-modules ...) ...' expression to a file I am able to build the package using 'guix build -L $(pwd)/site -f file.scm'. What am I missing here in regards to the usage of 'guix build -e ...'?
<terpri>rekahsoft, -e appears to only evaluate the first expression in the argument, maybe try -L ... -e '(@ (rekahsoft packages rust-xyz) rust-autocfg)' ?
<terpri>rekahsoft, are you by any chance using "guix import" for this rust package? because the crate importer often generates packages with dependency cycles
<apteryx>is there a way to access the list of just "inputs" (not native-inputs or propagated-inputs) inside a build phase?
<atw`>apteryx: is it `package-inputs' or am I missing something (guessing that because I see I've used package-propagated-inputs in the past)
<apteryx>atw`: I've seen this used on the package top level definition before, but not inside the build side (phases) code. I'm not sure how I can refer to the package own's native-inputs. All I've seen is (assoc-ref inputs "input-name"). It seems all the inputs categories are grouped together before being passed as "inputs" to the build system, so information is lost.
<apteryx>I hope I'm wrong :-)
*apteryx is reading the gnu-build-system.scm module
<apteryx>what I want to achieve in the end is wrapping a program with only its inputs (without native-inputs or propagated-inputs)
<atw`>ah, I understand now. yeah, I've seen much the same
<olivuser>Hello everyone. I am still struggling to get streaming to work (youtube and others, basically video playback online). I've tried several feature-packed browsers (epiphany, eolie, icecat), installed a bunch of codecs I believe to be related (ffmpeg, gstreamer, xvid) and then even did a reconfigure in order to have the codecs be part of the system and not only per-profile installation (I'm not sure if that makes sense, that's what I
<olivuser>reckoned). Does someone have an idea how to cope with the problem?
<apteryx>rekado_: the debug symbols are always produced by the gnu-build-system; but they are usually stripped away. This stripping is skipped when a "debug" output is present.
<olivuser>Also, is there a difference in effect when a program (could also be said codec) is installed system-wide versus being installed locally - that is, could it be the source of a problem like the one mentioned above, that a program to be installed (e.g. icecat) doesnt "see" the per-user codecs during install and hence doesnt "take them into account"?
<atw`>olivuser: hello! sorry to hear you've encountered some difficulties. I didn't respond before because I am not perfectly sure how to help fix the problem. What do you see when you try to play a youtube video?
<nckx>Does anyone know which package (?) civodul is using to elide store hashes in live shell output?
<atw`>nckx: guix-prettify-mode?
<tleydxdy_m>Hi guys, I'm getting errors during installation on qemu, logs shows that gcc segfaulted when building xf86-video-ati. I don't really know what's going on.
<nckx>atw`: Possible. I'll try it out. Thanks.
<olivuser>atw`: hej man thanks for your reply. thats a tad different in different browsers. In eolie/epiphany, I see preview icons and the preview, but upon opening the video nothing happens. In icecat, neither icons nor preview are shown (video titles with blank space). When I click on a video it follows the link but I can only see the youtube logo on top - that is it doesnt show even the window frame.
<olivuser>Also in case that matters: I'm using i3wm and havent yet experimented if it works when using gnome instead. Could that do the trick?
<apteryx>nckx: it comes from emacs-guix
<nckx>apteryx, atw`: It works and is rad. Thanks.
<pkill9>olivuser: try installing "gst-plugins-{bad,base,good,ugly}"
<atw`>olivuser: yeah, like I said, I'm not definitely sure what's up. However, I have youtube etc working in icecat. Icecat is installed in my user profile (not system-wide) and I did not have to manually install any video drivers. However, I did have to turn off LibreJS and some other extensions in icecat
<pkill9>hmm actually it works for me and i dont have them installed
<atw`>oh, and I am using spectrwm, so I do not think that i3 should pose a problem
<atw`>pkill9: yeah, I didn't have to do that
<pkill9>olivuser: do any errors show up in the terminal if you run the browser form the terminal and try to view a video?
<olivuser>pkill9: havent yet tried, will try later and come back to you!
<atw`>I think that LibreJS leaves a note in Icecat's JS console, so that might be worth a look
<olivuser>atw`: good idea, will try! pkill9
<olivuser>Do you guys think a guix gc might help as well?
<pkill9>i don't think `guix gc` will have any effect
<pkill9>since that deletes anything in the guix store that isn't in use by anything
*pkill9 's `guix gc` still fails with an Sqlite error :(
<pkill9>s/Sqlite/SQL
<atw`>pkill9: known issue?
<pkill9>yeah it's been posted to the bugs mailing list
<pkill9>it's this error: guix gc: error: executing SQLite statement: FOREIGN KEY constraint failed
<terpri>olivuser, i can reproduce the video errors in both epiphany and icecat with its default settings, fwiw
<reepca>maaan, all the fosdem streams kept happening while I was asleep. Any idea where the recordings will be posted?
<terpri>disabling the default privacy settings on the icecat new tab page seems to circumvent some errors
<terpri>for example playing https://commons.wikimedia.org/wiki/File:Free_Software_Song_at_FSF30.webm in icecat shows a format/mime type error in the default configuration, but works if "block third-party requests" is off
<Swedneck>Is there a rough timeline for guix 1.0?
<atw`>olivuser: along with what terpri said, uBlock origin is the only thing I have enabled on the new tab page
<atw`>Swedneck: https://lists.gnu.org/archive/html/guix-devel/2018-07/msg00322.html was written a while ago
<atw`>I think some of those things have happened. Channels definitely have
<Swedneck>thanks
<Swedneck>i'm also curious whether there are screenshots of the installer
<olivuser>atw`: eventually, I got it to work. I installed the bulk of gst-plugins. Also, I disabled the third-party request-blocker. Unfortunately I dont know if installing the plugins did the job or if it was only disabling the extension. Anyway, thanks, also pkill9 !
<Swedneck>is there a somewhat beginner-friendly way to learn to write a guix package?
<Swedneck>maybe some simple package definition i could read, at least
<atw`>Swedneck: there are a couple of resources on the topic. Might I ask a little about your background?
<pkill9>Swedneck: https://www.gnu.org/software/guix/blog/2018/a-packaging-tutorial-for-guix/
<atw`>also, I couldn't find any screenshots of the installer
<Swedneck>i'm quite comfortable with linux and i can hack together some python/bash scripts
<Swedneck>pkill9: thank!
<Swedneck>is `mirror://` just git?
<atw`>There's also some information in the manual: https://www.gnu.org/software/guix/manual/en/html_node/Defining-Packages.html#Defining-Packages. If you're familiar with e.g. python packaging, then reading the package definition for a python library might make sense
<atw`>Swedneck: "The mirror://gnu prefix instructs url-fetch to use one of the GNU mirrors defined in (guix download)."
<Swedneck>GNU mirrors?
<atw`>so that's going to use HTTP/HTTPS/FTP
<atw`>those are defined here https://git.savannah.gnu.org/cgit/guix.git/tree/guix/download.scm#n50
<Swedneck>ah, so mirrors of the official channel?
<atw`>GNU mirrors, meaning blessed places from which to download GNU software
<atw`>you also mentioned git -- you're right, (origin ...) can also contain information about how to download source code from a git remote ☺
<Swedneck>how do i make `guix edit` use another editor?
<atw`>by setting EDITOR in your shell, I think
<Swedneck>that's already set
<atw`>looking at https://www.gnu.org/software/guix/manual/en/html_node/Invoking-guix-edit.html#Invoking-guix-edit, maybe VISUAL is preferred to EDITOR? What behavior are you seeing and what is your EDITOR set to?
<Swedneck>`guix edit` tries to use emacs (which isn't installed) and EDITOR is set to "vim"
<Swedneck>vim without quotes
<reepca>is EDITOR exported?
<Swedneck>aha, that fixed it
<Swedneck>i was using `set -U` in fish
<reepca>\o/
<reepca>does mariadb eventually pass all the tests if you try enough times?
<pkill9>has anybody tried packaging anbox for guix?
<pkill9>meh it seems to require building a minimal version of the android image itself, which the source is 40GB (and vanilla android sources are 100GB)
<pkill9>don't think i will bother trying to package that lol
<Copenhagen_Bram>How do I cat a file to a pastebin?
<Copenhagen_Bram>guix livecd has neither netcat nor curl
<rekado_>can you not run “guix package -i curl”?
<atw`>rekado_: you beat me to it. Happy FOSDEM!
<nckx>Copenhagen_Bram: Does it have wgetpaste? I might be thinking of another live installer tho'.
<Copenhagen_Bram>nope
<nckx>Welp.
<Copenhagen_Bram>huh
*Copenhagen_Bram runs guix package --no-substitutes -i wgetpaste
*rekado_ wonders why “--no-substitutes” is used
<Copenhagen_Bram>so it will compile instead of binary
<Copenhagen_Bram>oh i guess i'll use binaries
<Copenhagen_Bram>wait no i want to guix challenge everything
<rekado_>oh, right, you wanted to compile everything.
<Copenhagen_Bram>yeah
<Copenhagen_Bram>i also wanted an encrypted root, but i tried it and it wouldn't boot
<rekahsoft>Copenhagen_Bram: when you say you tried it, can you elaborate further on this setup?
<nckx>^ Indeed. That should work, with some minor inconveniences.
<Copenhagen_Bram>sure, that's why i'm installing wgetpaste
<nckx>:-D Good point.
<Copenhagen_Bram>but i'll try to tell you about it
<Copenhagen_Bram> /dev/sda1 is a 2M BIOS boot partition, /dev/sda2 was a LUKS partition containing an ext4 partition
<Copenhagen_Bram>BIOS is Libreboot
<Copenhagen_Bram>config.scm uses grub-bootloader, I added the LUKS partition with mapped-devices
<Copenhagen_Bram>I looked at the example configuration in the manual for an encrypted root, it looks the same except for using EFI
<Copenhagen_Bram>But, when I finished installing and rebooted, I got nothing but the nice artwork of a penguin riding a gnu that this laptop's BIOS came with
<rekahsoft>Copenhagen_Bram: have you booted using EFI before using that laptop?
<rekahsoft>Also curious what laptop you have?
<Copenhagen_Bram>Lenovo thinkpad t400
<Copenhagen_Bram>with libreboot
<Copenhagen_Bram>Do I need an EFI grub to decrypt the root partition?
<Copenhagen_Bram>I've never booted it with EFI, and I'm not entirely sure what EFI is except I thought it was some kind of advanced proprietary bios that I wouldn't need to use settings for with Libreboot
<rekahsoft>Copenhagen_Bram: if you followed the efi instructions for guix it would have instructed you to use the efi grub package, which should have the grub efi loader..however does you BIOS support EFI?
<rekahsoft>What bios are you using?
<Copenhagen_Bram>again, Libreboot
<rekahsoft>Copenhagen_Bram: sorry missed that. I have no experience with libreboot (only have played with coreboot). However looking at its documentation, it does support EFI
<rekahsoft>Awe, and libreboot is upstream of coreboot
<rekahsoft>Interesting
<Copenhagen_Bram>wot
<Copenhagen_Bram>i don't think my libreboot is upstream, i haven't taken the time to take apart my computer to update it
<Copenhagen_Bram>unless there's a way to flash the bios on a thinkpad without taking it apart?
<rekahsoft>Libreboot looks pretty awesome. Thanks for mentioning it Copenhagen_Bram :)
<rekahsoft>Copenhagen_Bram: by upstream I mean it is coreboot with binary blobs removed and it looks like some other enhancements
<rekahsoft>Also there is no way to flash the bios without taking it apart, but I don't think that is necessary here
<rekahsoft>Have you done any bios configuration? Is EFI enabled?