IRC channel logs

2018-12-15.log

back to list of logs

<civodul>vagrantc: 966629a114fd90153784dfdbe5e332e0ac94f1bc should fix it!
<mbakke>Uh oh, there is a SQLite RCE in all versions prior to 3.26: https://blade.tencent.com/magellan/index_en.html
<mbakke>Spoiler alert: We have 3.24.
<rain1>I have git cloned guix
<rain1>im on guixsd
<rain1> https://www.gnu.org/software/guix/manual/en/guix.html#Contributing
<rain1>im following this so that I can modify the packages
<rain1>is it correct that I should do ./configure --localstatedir=/var ?
<rain1>or should I set it to a different directory because i'm working with a git lcone
<rain1>it seems to be working with /var
<mbakke>rain1: "--localstatedir=/var" is correct for GuixSD, yes :-)
<mbakke>You may also want "--sysconfdir=/etc".
<rain1>ah I forgot that one
<rain1> https://paste.debian.net/1055943/
<rain1>so this version bump change seems to work, ./pre-inst-env guix build sqlite was sucessful
<mbakke>rain1: Indeed, I'm testing the upgrade too.
<mbakke>Unfortunately sqlite has ~5000 dependent packages, so updating it will require rebuilding almost the entire distribution.
<mbakke>I wonder how many users there are of the static library.
<rain1>wow that's a lot, but if it has to be done it has to be done I guess!
<mbakke>It may be possible to "graft" the fix, but that may not work for packages that use the static library.
<pkill9>why not?
<mbakke>pkill9: Users of the static library typically embed it at build time. It's not a dynamic reference, which is why it's discouraged.
***jonsger1 is now known as jonsger
<ilya-fedin>Hello! I'm following GuixSD for several months, so far in a virtual machine. The only thing that does not allow me to try it on real hardware is the absence of one of my favorite DE (KDE, Budgie, Deepin). If the absence of Budgie and Deepin can be explained by their relative popularity, then why there is no KDE? Or even LXQt, if there are any technical difficulties...
<wigust->ilya-fedin: no difficulties i guess, somebody just need to package it :-) btw, we have: gnome, xfce, enlightenment
<wigust->mate also presents
<ilya-fedin>wigust-: gnome is a heavy bloatware and the rest is DE with a UI of 2007
<ilya-fedin>But there is another problem: guix refresh doesn't want to work https://pastebin.com/ag02rZcA
<wigust->ilya-fedin: you probably want to set GUIX_GITHUB_TOKEN as the output says ;-)
<wigust->also you could run guix commands without sudo
<wigust->people work on KDE in Guix, so you probably could join them and bring KDE to Guix :-)
<ilya-fedin>But I want to update whole system, not user-wide installed packages
<wigust->ilya-fedin: ‘guix refresh’ updates package recipes. It's a handy tool for Guix contributers. If you want to update the system, then you want to use ‘guix system reconfigure’
<wigust->‘guix system reconfigure’ requires ‘sudo’ indeed.
<ilya-fedin>Thank you. In guix documentation the devil break his leg.
<ilya-fedin>NixOS wiki format much better
<rk4>the unofficial users wiki?
<rk4>i think i like the guix manual slightly more than the nixos manual, format wise, but there's not much in it. guix one i find easier to read
<travan|{or>my experience is that guix has better docs too
<travan|{or>admittedly i’m very new to guix
<ilya-fedin>I ызуте a lot of time trying to find update/upgrade here, but without success http://www.gnu.org/software/guix/manual/en/html_node/index.html
<ilya-fedin>I spent a lot of time trying to find update/upgrade here, but without success http://www.gnu.org/software/guix/manual/en/html_node/index.html
<ilya-fedin>I think manual should have its own search
<wigust->ilya-fedin: well, as work around you could open full manual on one page https://www.gnu.org/software/guix/manual/en/guix.html
<rk4>i wonder how good `info guix`s search is
<ilya-fedin>From the second attempt, I was able to find `guix package -u` in Package Management to update the user-wide installed packages. But I see information about `guix system reconfigure` only in Invoking `guix system`, which is not cleary at all.
<wigust->ilya-fedin: if you know a better place to put it, feel free to share. Unfortunately, I don't remember how hard was it to find when I started to use GuixSD
<wigust->I think it's a good place, because you run ‘guix system init’ during installation and that's why should probably guess :-)
<wigust->Also, guix system reconfigure is mentioned on https://www.gnu.org/software/guix/manual/html_node/Proceeding-with-the-Installation.html
<wigust->which you probably read during installation if you install GuixSD on a hardware
<ilya-fedin>I installed it a few months ago and during that time I did not touch the virtual machine at all, so I forgot it very easily.
<ilya-fedin>It's too strange, but guix system reconfigure compiles something :hmm:
<wigust->well, it could because of 502 on berlin :-\
<vagrantc>so I've made a package definition that feels like an ugly hack to add patches to a source... https://paste.debian.net/1055965/ surely there's a more elegant way of simply adding a patch to the source entry?
<janneke>which part did you add/are you unhappy with? the (source (inherit ..) (search-patches ..)) bit looks OK to me
<vagrantc>janneke: mostly having to define a arm-trusted-firmware-rk3399-source at all ...
<vagrantc>but if that's a legit way to do this, ok.
<vagrantc>it also seems like it's calling make-arm-trusted-firmware twice... once for the -source, and once for the package itself, which seems redundant
<janneke>ah right, i see: you first create a "package" that you don't really need, then extract its source
<vagrantc>right
<vagrantc>i'd like to figure out a way to use the (source ...) produced by "make-arm-trusted-firmware" but simply append a patches section.
<janneke>i see; the point is that the source definition is inside the make-arm-trusted-firmware function
<vagrantc>right
<janneke>you would either have to duplicate the origin/git-fetch/url ... not so great, or
<janneke>or create a new function make-arm-trusted-firmware-source (or arm-trusted-firmware-source?)
<janneke>and use that in both make-arm-trusted-firmware-source and your new package
<vagrantc>hmmm... so maybe using the extra -source "package" isn't so inelegant?
<janneke>eh, i said function, that could probably be a variable (define ...-source (origin ...))
<janneke>i think it's OK
<vagrantc>the other one i'm struggling with is how to properly set PYTHONPATH during one of the build targets: https://paste.debian.net/1055966/
<vagrantc>the build-itb target calls a script that imports a module from python-pyelfutils ... and hard-coding it "worked" for python 3.6 but the switch to python 3.7 broke it ... though it's obviously a bad thing to hard-code
<janneke>i see, you'd want not to use the python3.7 literal string but rather 'python-major-minor' or even python-libdir or so.../me is not a python packaging expert
<janneke>let's see...
<janneke>in python.scm, i see things like this: (version-major+minor (package-version python))
<vagrantc>or maybe add-installed-python-path ?
<janneke>oh, that looks promising
<vagrantc>hrm. but maybe not quite right
<janneke>yeah, computers often want such things exactly right ;-)
*janneke hits assert (i < MAX_STRING); trying to bump bootstrap to mes-0.19pre
<janneke>if only we could have our store paths shorter, using some /usr/ container hack even or so...
<vagrantc>oh, python-pyelftools fails to build now ...
<root____>hi there. i'm struggling a bit with guix sd installation. now sure where i should mount efi partition eg. /boot/efi or /mnt/boot/efi?
<root____>other than that is it normal for guix system init to build packages e.g. xorg gpu drivers?
***root____ is now known as Ajtos
<vagrantc>depends on what config you feed it
<Ajtos>i tried desktop.scm example from /etc/configuration with luks (encryption) part removed before
<Ajtos>i'm typing from guix sd usb media if u can guess
<Ajtos>yesterday i replaced my wifi card with ar5b22 in laptop for blob-free drivers and i'm toying with guix sd
<vagrantc>i would expect a desktop.scm to produce xorg drivers, sure.
<Ajtos>this is my disk http://sprunge.us/KfyaXB and configuration http://sprunge.us/m4JmTL i'm trying to use - still not sure where to mount efi partition
<travan|{or>i
<nckx>sneek: Later tell Ajtos: /boot/efi.
<sneek>Got it.
<rk4>do you have to mount it manually to /boot/efi in the liveusb environment too?
*rk4 is installing on efi for the first time
<tuete>Hey. Anyone having trouble with tmux? For me the buffer does not clear correctly.. I wonder if this is a general bug.
<wigust>tuete: no. ‘bind-key -n C-l send-keys C-l \; run 'tmux clear-history'’ clears everything by hitting ‘Ctrl+l’.
<vagrantc>"guix build guix" is failing tests an aarch64 and thus fails to build ... FAIL: tests/guix-package.sh FAIL: tests/guix-package.sh
<tuete>wigust: does not work :(. Tried a similar binding without success
***root_ is now known as Ajtos
<Ajtos>second atempt at guix sd installation, same outcome: http://sprunge.us/vO7KFb
<sneek>Welcome back Ajtos, you have 1 message.
<sneek>Ajtos, nckx says: /boot/efi.
<Ajtos>mount points: http://sprunge.us/H5cmbe and guix config http://sprunge.us/P7bYEO
<Ajtos>i'm using gnu guix sd x86_64 0.16.0 image, that was dd into usb stick
<Ajtos>did anyone got working installation out of guix system init (official images v0.16)? should i try guix pull before init?
<Ajtos>ouch, wrong time zone name "In procedure stat: No such file or directory: "/gnu/store/8g2wi0i5fgp0ylz99mckhprh25p1zgiv-tzdata-2018e/share/zoneinfo/Europe/Poland"
<Ajtos>will try again
<Ajtos>ok, I've managed to install guixsd with lightweight-desktop.scm and now i'm lost at network configuration - wpa_supplicant and dhclient don't work anymore, seems like networkmanager or something else is in the way. yet nmtui doesn't work either. any hints?
<Ajtos>guix reconfigure isn't working since there is no network and guix is missing some dependecies - circular dependency all the way.
<wigust>Ajtos: what do you mean by nmtui doesn't work?
<Ajtos>i choose card, enter passphrase and it is connecting indefinitly
<Ajtos>i'm guessing that lightweight-desktop.scm is using NM (via desktop services) - i've seen nm package beeing downloaded
<Ajtos>simple question - since mirror picking in guix seems screwed for me (going from 2mbps to 50kbps), it there fast recipe to specify mirror?
<pkill9>Ajtos: you can use --substitute-urls flag to specify substitute urls to use
<pkill9>it will ignore the configured substitute urls
<Ajtos>guix system init --substitute-urls=MIRROR /mnt/etc/config.scm /mnt should work?
<pkill9>yeah
<Ajtos>is there a list of substitute urls/mirros or whatever you call them?
<pkill9>as long as the mirror you are using has been authorized with `guix archive --authorize < pubkey`
<pkill9>Ajtos: there is ufortunately only 3
<pkill9>berlin, ci.guix.info, and mirror.hydra.gnu.org
<pkill9>two of them are added by default
<pkill9>there is work being done to distribute substitutes p2p e.g. through bittorrent
<pkill9>I dunno how much has been done though
<Ajtos>berlin.guixsd.info? i'm from poland, and almost always mirrors based in germany are fastest
<pkill9>yeah that one
<pkill9>if that's the fastest then if you put berlin.guixsd.info in --substitute-urls it will only download from that one
<Ajtos>ci is couldfire based if i'm not wrong?
<Ajtos>pkill9, you have been of great help. sorry for bothering you last time, do you know a way of specifying substitute-urls in config file?
<fps>Ajtos: have you got network already?
<Ajtos>fps, i;
<fps>Ajtos: and if networkmanager is in the way you might try stopping the service
<Ajtos>fps, i could, but i;m
<Ajtos>i'm not so familiar with shepherd
<fps>16:51 < Ajtos> guix reconfigure isn't working since there is no network and guix is missing some dependecies - circular dependency all the way.
<fps>oops
<fps>sudo herd status
<fps>shows me * networking
<fps>sudo herd stop networking
<fps>once you've stopped the networking service you might be able to use dhclient directly
<civodul>Hello Guix!
<fps>yo
<fps>guik
<Ajtos>ok, i'll check that right now - need to reboot this machine, thanks fps
<mbakke>Hello Guixers!
<mbakke>civodul: WDYT about restarting staging with the sqlite update?
<civodul>hello mbakke!
<civodul>mbakke: you mean on hydra?
<civodul>on berlin it should be happening automatically
<mbakke>civodul: Yes, indeed.
<ajtos>something iffy is going on - i can up ethernet intarface and connect via cable to same router, yet i can connect to wifi which i used before (guixsd image vs installtion)
<ajtos>herd stop networking didn't help either
<ajtos>*yet i cannot connect to wifi
<fps>ajtos: and wifi worked in the installer?
<ajtos>yep
<ajtos>ifconfig wlp3s0 up & wpa_supplicant -c someconfig -i wlp3s0 -B & dhclient -v wlp3s0 worked before, when installing
<fps>hmm, that question is out of my league then :(
<ajtos>i'm using ar5b22 wifi card - it has also bluetooth module. maybe installed guixsd is providing something for bluetooth that installer isn't?
<rain1> https://github.com/aconchillo/guile-json/issues/25 im making a hash table reader syntax for guile, if you've got any commenst or suggestions
<rain1>#{ 1 (+ 3 5) x x } creates the hash table of equivalent ((x . 7) (1 . 8))
<rain1>sorry
<rain1>I wrote this in #guix instead of #guile
<cbaines>I'm interesting in how the staging branch is getting on if anyone knows anything?
***rekado_ is now known as rekado
<rekado>cbaines: staging didn’t really make much progress and soon it will be rebuilt because of the sqlite fix.
<rain1>i'm trying to package a game and I got a problem where it builds but does not run, because it can't find libGL.so even though mesa is one of the inputs
<rain1>with strace I can see it searching for the library https://bpaste.net/show/940338ed7a34 but it doesn't look inside mesa
<rain1>How can I add mesa to the list of places it searches in?
<rain1>with ldd i can see that libGL.so is not linked in, it must be loading it with dlopen
<rain1>I found an approach by grepping dlopen
<pkill9>as a temporary workaround you could try running it with the environment variable LD_LIBRARY_PATH=$(guix build mesa)/lib set
<civodul>i noticed that icecat doesn't support webgl, and i wonder if that's related
<rain1>i just did a test, it seems to be searching for libGL.so in various places similar to this
<rain1>I will try to apply the same fix and see if it works
<civodul>yeah it may be that just putting libGL.so in LD_LIBRARY_PATH fixes it
<civodul>i'm curious to see if that works!
<rain1>adding mesa to LD_LIBRARY_PATH doesn't fix it
<rain1>it has libGL error: unable to load driver: i915_dri.so
<rain1>maybe I need to add two paths, mesa/lib and mesa/lib/dri
<civodul>oh
<rain1> LD_LIBRARY_PATH=$(guix build mesa)/lib:$(guix build mesa)/lib/dri
<rain1>same problem with this, oh well!
<rain1> https://bpaste.net/show/9b034117b7f5
<rain1>i think it's a step closer but there are more reasons it doesn't work
<rain1>this is strange, I got this thing built and tried it a few times, it was working. but now when I run it i get errors about alsa - i didn't change anything
<rain1>ALSA lib pcm_dmix.c:1099:(snd_pcm_dmix_open) unable to open slave
<rain1>Playback device open error: No such file or directory