IRC channel logs

2018-12-10.log

back to list of logs

<safinaskar>what is current list of bootstrap binaries?
<samplet>safinaskar: You can find it in “gnu/packages/make-bootstrap.scm”.
<samplet>I see guile, gcc, binutils, glibc, coreutils, tar, gzip, bzip2, xz, patch, sed, grep, gawk, and bash.
<brettgilio>Hey all. Does anybody here know how to build all of the packages in a particular gnu package module?
<brettgilio>such as lisp.scm
<efraim>'grep define-public lisp.scm | cut -f2 -d' ' | xargs ./pre-inst-env guix build '
<apteryx>efraim: there must be a way to introspect a loaded Guile module, to see what are the public variables defined?
<efraim>Probably, but that's what I normally do
<apteryx>efraim: OK :-)
<graton>I wrote a config.scm and submitted it to Pastebin. I'm now trying to download it via wget in a live install so I don't have to manually rewrite it. When I wget it, I get an empty file. What do?
<brendyyn>maybe curl?
<brettgilio>graton: What is the link? Try putting it on ix.io since I think pastebin gives pseudo-urls
<brettgilio>ix.io gives direct urls
<brettgilio>sorry for the delay
<graton>brettgilio: Thanks for the suggestion. I'll try ix.io. I also tried paste.ee and got the same problem.
<brettgilio>graton: I'm sorry you are having this problem. I am pretty sure ix.io should be successful for you since it is plain text only.
<brettgilio>It is the only pastebin-like service I use
<brendyyn>most people here use paste.debian.org i think
<brettgilio>brendyyn: I thought they shut that down
<brendyyn> https://paste.debian.net/
<brendyyn>.net sorry
<graton>I saw a paste on it just a couple of days ago.
<brendyyn>brettgilio: there was a previous one that was shutdown which was like paste.lisp.something i forget
<brettgilio>Ah, I see.
<brettgilio>Well, i'm off to sleep. Good night everybody
<graton>I tried "guix init /mnt/etc/config.scm /mnt" after downloading the config.scm that I wrote earlier, and got an error: "package 'linux@4.19.2' has an invalid input: ("kconfig" "/mnt/etc/kernel.config")"
<graton>(I defined my own custom kernel)
<graton>It's within a "native-inputs" clause.
<brendyyn>looks like the error kinda tells you what's wrong
<graton>Where do I start with fixing it?
<brendyyn>can you post the config ?
<brendyyn>inputs are package types, but you've given it a string
<graton>I'm basing it off of this one: https://gist.github.com/mbakke/c91e0eb3d906efd54c88a70c0e25c390
<graton>It's in a quasiquote, and the second string is the result of an eval due to the comma.
<graton>brendyyn: You there?
<brendyyn>yes im looking
***rekado_ is now known as rekado
<rekado>inputs cannot be strings
<rekado>an input should be a value of type <package> or <origin> (+ a label)
<rekado>e.g. ("kconfig" ,(origin (method url-fetch) (uri "file://where") …))
<graton>rekado: Do I need the sha256?
<graton>Is there a function which can hash a file (like "guix hash") when given a string with its directory from within a Guile file?
<janneke>o/
<cbaines>\o
<graton>For the <origin>'s sha256 field, I currently tell it (sha256 (base32 (system (string-append "guix hash " kernel-config))). kernel-config expands into "/mnt/etc/kernel.config", and "guix hash" then tells me that there is no such file (even though there definitely should be).
<cbaines>graton, sounds like the local-file gexp might be a better fit for what you're doing. What's the context?
<graton>cbaines: Sorry about not responding sooner. I think I got it to work.
<graton>I cut out that part of the kernel configuration and let the default handle it.
<graton>Only problem now is that my computer appears to be compiling a crapton of things. I think I might have accidentally made it compile the kernel from source. Well, at least it'll be fast!
<cbaines>graton, I'm glad to hear it's sort of working :)
<graton>It's just a long stream of lines like "CC /drivers/acpi/acpica/dsargs.o"
<graton>drivers/acpi*
<nckx>graton: Yup, that's the kernel. Nope, it won't be any faster (?).
<graton>nckx: I thought Gentoo was reputed to be faster than most other distros because everything is compiled from source. I suppose that's because the user gets to choose the optimization flags.
<nckx>graton: Heh. Take that with a big grain of bath salts. But yes, Guix aims for the opposite: identical binaries on all systems (of the same architecture). Artisanally home-compiled Guix packages are no -ffaster than any other.
<nckx>If they are, that's a bug.
<nckx>(You *can* customise the build system to use ‘-O3‘ everwhere and rebuild the world every month. Guix won't stop you. But it will probably laugh at you.)
<efraim>instead I choose a couple of programs and I modify them specifically
<sturm>Ow dear. I see that Python 3.6 was upgraded to 3.7 recently, but 3.7 isn't compatible with a number of Django 1.11 codebases I maintain.
<sturm>would the new channels feature be an appropriate way for me to keep my own copy of Python 3.6?
<efraim>it might be the best way to keep a copy of python-3.6 available to everyone, including yourself
<efraim>it seems like it'd be better than just adding it to your GUIX_PACKAGE_PATH
<efraim>anyone know about substitutions in vim? i want to insert a linebreak, s/ab/a\nb/g gets me a^@b
<sturm>Thanks efraim. Do you know if there are docs about what the minimal layout for a channel repo is?
<efraim>i was going to copy https://gitlab.com/mbakke/guix-chromium when i go to set up one
<sturm>thanks
<efraim>for those following along at home, #vim says '\r' and not '\n', and ':help sub-replace-special'
<fps>efraim: isn't $ line end in regexes (and ^ the start), so maybe use those instead of \n :)
<fps>just guessing since i sit at a windows 10 box at work ;)
<efraim>It is the line/word ending, but I wanted to insert a newline, not search for the end of a line
<fps>my thinking was that a newline can be considered equivalent to a line ending followed by a line starting
<fps>but i fired up a vm and indeed it doesn't work in vim
<fps>oh, vim want's \r instead of \n
<fps>s/ab/a\rb/g
<epicmorphism>Hi
<epicmorphism>I was wondering, how should I report an issue with guix, or rather the guix.info web site?
<epicmorphism> http://issues.guix.info is down for me
<epicmorphism>should I send a mail to the mailing list?
<epicmorphism>It is not very clear from the description on the GNU Savannah
<fps>efraim: oh you found that out yourself, anyways.. great.
<efraim>i have 8388 IETF RFC package definitions now
<tune>sounds like ncmpcpp was fixed, but is the package installable yet?
<tune>I'll find out shortly
<trasto>Hello, guix start the system with the file config.scm, not with systemd, runit, openrc ....?
<lfam>trasto: GuixSD uses Shepherd as init: https://www.gnu.org/software/shepherd/
<tilpner>epicmorphism - Ask here!
<trasto>lfam: thanks for the info :)
<tune>ncmpcpp does seem to work now. great
<roptat> https://atlas.ripe.net/measurements/14398555/#!map
<roptat>measurement for mirror.hydra.gnu.org last june
<hals>Will a typical WiFi dongle from Target or Best Buy work with GuixSD? My laptop BIOS blacklists free WiFi cards.
<hals>(and if anyone knows of a guaranteed-to-work free WiFi card for the Thinkpad T400, I'd love to hear about it)
<lfam>hals: In general, you want an Atheros card that supports 802.11n (the latest WiFi spec supported by free software)
<lfam>For example, one of these: https://www.thinkpenguin.com/catalog/wireless-networking-gnulinux
<hals>lfam: Both of the ones that I've tried have been blacklisted by the BIOS. Moreover, I saw a post which said that the 2nd one I brought should have worked.
<lfam>It may be possible to alter your BIOS to support more cards but you can always use a USB dongle
<lfam>The Thinkpad BIOS is extremely restrictive in what it supports. My understanding is that replacing the actual card is not an option unless you are able to alter the BIOS
<hals>Altering the BIOS is an extreme hassle on the T400 (I'm not aware of anything less than full Libreboot, which is much harder with the T400 than, say, the X200 or T60). My 1st question was about dongles.
<lfam>Yes, the dongles should work, but I haven't tried them myself. There is probably previous discussion on the Guix mailing lists help-guix and guix-devel
<lfam> https://lists.gnu.org/archive/html/help-guix/
<lfam> https://lists.gnu.org/archive/html/guix-devel/
<hals>Also, it's supposed to support the Atheros AR5007, but I got an 1802 error (blacklist) when I tried installing it.
<hals>Thanks for the links!
<hals>Is it only the RYF dongle which works?
<lfam>There will be hardware that does not have RYF certification that does work with free software. This is because getting the RYF stamp requires some bureaucratic effort to certify that it only requires free software, so not all hardware applies for RYF
<lfam>I think that anything on thinkpenguin should work
<hals>So definitely nothing from Best Buy then.
<lfam>Looks like there are some Realtek chips that also will work (available on thinkpenguin)
<lfam>I wouldn't rule it out, but it will be harder to know before you buy. The wifi dongle manufacturers don't typically advertise the chipset of their products, and they may even change the chipset without changing their model name
<lfam>I don't know how current or complete it is, but I think that <h-node.org> attempts to catalog computer hardware and whether or not it can be used with free software drivers
<hals>It's amazing how stacked commodity hardware is against free software.
<hals>Looks like I have to order that dongle and go back to something like Debian in the mean time.
<lfam>Agreed, and unfortunately the manufacturer that released the flagship free wifi driver (Atheros) is long gone
<lfam>So, we probably can't expect any free driver support for newer wifi standards in the future
<kmicu>hals: a second-hand TP-Link with a chipset supported by free software will work or the same w/o RYF (which is not a11ble to poorer folks) e.g. https://www.olimex.com/Products/USB-Modules/MOD-WIFI-AR9271-ANT/
<kmicu>hals: also keep in mind that though you will not get support for it here it’s relatively easy to install the mainline kernel and proprietary firmware. Guix(SD) is free software hence we are able to excercise our freedom also in such (unhealthy) ways ;)
<hals>kmicu: I tried this last night. The kernel started compiling and then gave me an error several hours in. I think I'm going to install Debian Testing with Guix atop it for now.
<kmicu>Oh that sucks; on the other hand Guix on a foreign distro also delivers plenty of goodies. Good luck.
<hals>kmicu: Thanks.
<tuete>Hey. I am new to GuixSD. I try to reconfigure the system with guix reconfigure myconfig.scm. But I get an error: guix system: error: symlink: Permission denied: "/var/guix/profiles/system-2-link.new"
<tuete>Do I need to execute this as root? It doesn't say so in the docs.
<tune>system config needs root privileges
<tune>e.g. sudo -E guix system reconfigure /etc/config.scm
<tune>I'm not familiar with having the system config in a different spot
<tune>but I have not read most of the manual
<tuete>Ah, thanks. Yeah, I have the config in /etc as well. I will do it with sudo then. Makes sense that it needs root privileges, but I thought since it is not stated in the manual.. it might be unprivileged