IRC channel logs

2018-08-08.log

back to list of logs

<database>anyone here can help me
<RetardedOnion>can anybody use qutebrowser? i seem to have problems with qtwebengine
<tune>RetardedOnion: it's been broken for me for a couple weeks
<tune>qtwebengine isn't packaged. it's supposed to fall back to webkit, but it isn't for some reason, so it just doesn't work at all
<RetardedOnion>tune: i have heard of some users running it. i thought there might be a workaround
<RetardedOnion>--backend webkit doesnt work as well
<RetardedOnion>qtwebkit is installed
<database>ld cannot find -lc
<database>what to do ?
<pkill9>qutebrowser rejects the original qtwebkit, and accepts only annulen's fork, which has recently been incorporated into the Guix repos
<pkill9>i haven't tried running it though
<RetardedOnion>i did a guix pull just a few minutes back.
<pkill9>oh ok
<RetardedOnion>i will do it again, install qutebrowser again.
<pkill9>it's also a relaly old versiokn
<RetardedOnion>pkill9: just guix pull && guix package -i qutebrowser && qutebrowser. no change
<database>Retarded0nion can you help me
<RetardedOnion>database: no. i am new to guixsd and especially finding libaries is something id imagine to be pretty difficult. well why not statically compiling them?
<database>can't
<database>Retarded0nion: i am learning assembly language
<mbakke>How do you get that error database?
<nckx>database: Are you using the gcc-toolchain package? If not, do.
<database>nckx: i am using ld gor executable file
<database>for*
<database>nckx: i am using 64-bit guixsd and and trying to link 32-bit assembly code using ld and i am also using C functions like "printf"
<nckx>database: Which package did you install to get ‘ld’?
<database>nckx: binutils
<nckx>If ‘binutils’, uninstall it and install ‘gcc-toolchain’ instead.
<nckx>:-)
<database>okay
<database>let me try
<nckx>‘gcc-toolchain’ installs a slightly modified version of ld that can find needed libraries under /gnu/store.
<nckx>I don't think the ‘binutils’ package does that.
<database>ohh maybe
<database>give me few minutes and i will tell you the outcome
<nckx>database: OK. Serious thunderstorm coming this way, however. I might unplug the modem if it gets too bad.
<database>nckx: no problem
<RetardedOnion>nckx: good luck?
<nckx>RetardedOnion: Thanks. Same time last week I was in a tent, on a mountain, in a worse one, like an idiot, so I'll live. Just not very confident about the wiring here...
<nckx>...yeah, I'm going off the grid for tonight. Good luck, database! o/
<database>nature is a father lol:-
<database>okay nckx:
<database>thanks for help
<database>anything about 32 bit libraries nckx:
<Misha_B>is it possible to use xinit to start the X server instead of slim?
<RetardedOnion>Misha_B: yes. slim is included in the base-desktop-services i think
<Formbi>Misha_B: there are some issues with it
<database>Formbi: how to install 32-bit libraies in 64-bit
<RetardedOnion>where do i find %desktop-services?
<Misha_B>if I try to run an application that I downloaded outside the guix system, it says it can't find it
<Misha_B>like say if I download and try and run the standalone firefox, it won't run
<brendyyn>I imagine it won't because guix puts all it's dependencies in a /gnu/store
<brendyyn>where did you get the binary from by the way?
<Misha_B>just from the firefox website
<brendyyn>it might work in a chroot
<Misha_B>when I try to chroot I get the error "chroot: failed to run command ‘/gnu/store/q4b3s9y4i0da36drp7zfq9yqcf43s47v-bash-4.4.19/bin/bash’: No such file or directory"
<brendyyn>i mean a specially setup chroot
<Misha_B>ahh, running ldd some of the dependencies are not found
<brendyyn>Misha_B: I think this is quite difficult to do. You should ask on the mailing list
<Misha_B>do you know which packages 'libgcc_s.so.1', and 'libstdc++' are in
<brendyyn>what command did you run to get that?
<Misha_B>ldd
<brendyyn>in the lib output of gcc
<brendyyn>hmm i added it to the environment but they still aren't found
<Misha_B>it would probably work if I built firefox as a static executable, but I guess you're right the best way would be to have a chroot that mimics using global libraries
<Misha_B>I think maybe I just use guix as a supplemental package manager instead of as the primary os
***siraben is now known as rms
***rms is now known as siraben
<brendyyn>someone trying to impersonate rms?
<siraben>No I was using it to demonstrate a point
<siraben>Unfortunately it broadcast it publicly -_-
<siraben>^the point was to show that another person could be impersonated because they were building a bot to maybe have auto commit abilities
<siraben>And used a whitelist for allowed user names, which made me show that /nick can change the names
<brendyyn>i see
<brendyyn>most people have no idea how irc works. we just connect and use it
<siraben>I'd assume people using IRC already have some sort of a technical know-how, right?
<siraben>In order to connect and use it perhaps
***nonlinear is now known as NB0X-Matt-CA
<database>how to install 32-bit libraries in 64-bit guixSD
<database>how to install 32-bit libraries in 64-bit guixSD ?
<database>anyone is here to help me
<rekado>database: you can use “guix build --system=i686-linux foo” to build the foo package for 32 bit.
<rekado>the “guix package” command does not yet support the “--system” option, but it is not difficult to add it.
<rekado>RetardedOnion: make sure you’re actually using the pulled guix. It is installed to ~/.config/guix/current/bin.
<database>rekado: when i am using c functions in assembly program and during lingking process (ld -o calltest calltest.o -lc) error: cannot find -lc and -lc is importent
<efraim>database: are you using gcc-toolchain?
<database>yes
<database>efraim: but i have both gcc-toolchain as well as binutils
<efraim>ld is in binutils, right? Pretty sure you don't want binutils at the same time then
<database>maybe
<database>yes ld is in binutils
<database>then how i can tell that where my c libraries are ?
<XexonixXexillion>I have a bunch of bash scripts with #!/bin/bash at the top. Is there a program I can call to fix that?
<tune>sed
<tune>I can't tell you the specifics, I don't really use it myself, but it allows editing via command instead of an interactive thing, so you should be able to do something like trim a specific pattern from many files with it
<database>efraim: still there ?
<rekado>database: you only need gcc-toolchain.
<rekado>it comes with the appropriate ld-wrapper.
<database>rekado: i have gcc-toolchain
<database>still ld give error that it cannot find -lc
<XexonixXexillion>so to fix those I'm meant to just run some monstrosity like `sed "s/\\#\\!\\/bin\\/bash/$(echo \\#\\!$(which bash) | sed "s/\\//\\\\\\\\\\//g")/g"` ?
<ngz>Hello. What version of libstdc++ Guix is using with gnu build system? Can I assume it is the same as gcc (5.5.0 at this time), or is it another version?
<database>after installing gcc-toolchin then also ld cannot find -lc
<pkill9>so it wants the 'c' library?
<rekado>database: what does “which ld” say?
<rekado>database: I suppose you’ll also need to install the static glibc
<database>i wrote assembly langauge program and when i am trying to link it along with c library because i used 'printf' in my program "ld gives error that it cannot find -lc "
<database>pkill9: yes
<rekado>database: install glibc:static, i.e. the “static” output of glibc
<database>rekado: name of the package? becasue when i am trying "guix package -i glibc-static" no package found by this name
<database>got it
<rekado>when you do “guix package -A glibc” you’ll see that the glibc packages have three outputs: out,debug,static
<rekado>by default only the “out” output is installed.
<database>ohh
<database>rekado: let me see
<ngz>What version of libstdc++ Guix is using with gnu build system? Can I assume it is the same as gcc (5.5.0 at this time), or is it another version?
<database>rekado: "ld -o calltest calltest.o -lc " "ld: cannot find -lc" after installing staic-glibc
<rekado>database: can you make ld more verbose to see where it looks?
<database>rekado: okay, but can you do me a favour can you tell me the command line for that please
<rekado>database: sorry, I can’t. I’m busy with some package upgrades.
<database>okay
<database>by the way can you tell me how manually add c library
<rekado>what do you mean by “manually add c library”? Add it where? It’s already there.
<database>ohh
<database>right
<rekado>mbakke: on core-updates cups-filters fails to build. It’s probably because of an upgrade to poppler.
<rekado>mbakke: this means I can’t currently build and install gnome.
<rekado>upgrading cups-filters to 1.20.4 did not help
<rekado>need to patch it.
<rekado>fixed
<rekado>mbakke: on core-updates e2fsprogs fails one of its tests (d_loaddump).
<rekado>the test failure is due to a difference in reported blocks
<rekado>d_loaddump.failed shows that it expected a message containing “158/512 blocks” but only saw “156/512 blocks”.
<rekado>looks like this very same failure also exists in the freebsd port; they say “This looks like a very unusual failure and careful investigation into lld’s behaviour is warranted, but for now set LLD_UNSAFE to fall back to ld.bfd so the port continues to build for users using the lld as /usr/bin/ld.”
<rekado>I don’t think this applies to us, but maybe there’s something odd going on with our linker.
<rekado>shouldn’t we upgrade to 1.44.3 (July 10)? We are at 1.43.6 (from August 2017).
<rekado>1.44.3 builds fine.
<database>rekado: output of "ld -verbose" https://paste.debian.net/1037143/
<rekado>database: can you also tell me “which ld”?
<database>rekado: you mean which version of ld ?
<rekado>no, I mean literally the output of “which ld”
<database>rekado: to be honest i don't understand what you are trying to say
<database>i am sorry
<rekado>can you type “which ld” without the quotes on the terminal and press enter?
<database>okay
<database>give me a minute i am booting my system
<database>rekado: "which ld" "/root/.guix-profile/bin/ld"
<rekado>are you doing this all as the root user?
<database>yes
<rekado>can you show me the output of “guix package -I” please?
<database>okay
<database>give me a minute
<rekado>mbakke: cython fails to build on core-updates; pgen is missing.
<database>rekado: https://paste.debian.net/1037148/
<rekado>mbakke: I’m updating cython to 0.28.x now.
<rekado>but since “async” has become a reserved keyword in the new Python there are many more failures.
<rekado>updating python-dbus as well
<brendyyn>SICP talks about how languages should minimise reserved words ;P
<ngz>What version of libstdc++ Guix is using with gnu build system? Can I assume it is the same as gcc (5.5.0 at this time), or is it another version?
<rekado>ngz: have you looked it up?
<ngz>how can I do that?
<ngz>rekado: ^
<lfam>rekado: I updated cython to 0.28.* on the staging branch. It works fine but I didn't wanted it to be built before being deployed on the master branch
<rekado>lfam: I see. I’m currently trying to build GNOME from the wip-gnome-upgrades branch, which is based on core-updates, and sadly many packages are broken on core-updates.
<rekado>originally, we wanted to freeze core-updates two days ago.
<lfam>I saw your core-updates schedule. Does this mean that staging will be delayed until after core-updates or should we work on them in parallel?
<lfam>mbakke ^ ?
<rekado>I don’t know.
<rekado>lfam: I guess in practice we’ll work on them in parallel.
<rekado>for now I’ve cherry-picked your cython upgrade (my upgrade to 0.28.5 had a test failure), and I’ll keep going until “gnome” builds again.
<RetardedOnion>what group do i have to be in to use networkmanager?
<dustyweb>goofy question but
<dustyweb>sudo -E guix reconfigure # uses user installed guix
<dustyweb>sudo guix reconfigure # uses root installed guix
<dustyweb>right?
<lfam>dustyweb: I recommend using `sudo --login` if you reall want to do something *as* root
<dustyweb>lfam: I'm just trying to guix system reconfigure :)
<dustyweb>I had a working setup
<dustyweb>but it was before I switched to guix pull!
<lfam>I don't totally understand the difference (should read the manual again) but `sudo --login` always seems to do the right thing for me
<lfam>If you paste your error messages someone might recognize them :)
<dustyweb>:)
<lfam>RetardedOnion: I'd guess the 'netdev' group
<lfam>RetardedOnion: I don't have any experience with networkmanager, however, and I don't know exactly how it's failing for you :)
<RetardedOnion>lfam: i am. still not authorized to control networking.
<RetardedOnion>i use the applet. just because its easy.
<lfam>Please provide more details :) I recommend pasting the command and full output on <https://paste.debian.net>
<lfam>ACTION wishes for a sophisticated graph viewer of CI build failures 
<lfam>Like, a tree of failed builds
<rekado>dustyweb: “sudo -E guix” is the current user’s Guix, but with super powers.
<rekado>I use this to reconfigure.
<lfam>ACTION starts building mariadb
<lfam>ACTION literally has all day
<dustyweb>rekado: thanks, that's what I thought but wasn't sure :)
<rekado>dustyweb: with the new “guix pull” I think it has become a little easier as you could also just use ~/.config/guix/current/bin/guix directly.
<rekado>lfam: after cherry-picking your cython upgrade commit to core-updates I still get test failures. Maybe that’s because we’re using Python 3.7 on core-updates.
<mbakke>rekado: Do you think we can squeeze glibc 2.28 in? We need to patch many gnulib consumers :/
<mbakke>coreutils 2.30 includes a newer gnulib, but has a test failure.
<lfam>mbakke: Should we start a new evaluation of staging now that mariadb seems to be fixed?
<mbakke>lfam: Yes, I meant to do that earlier. Can you handle it?
<lfam>Sure
<lfam>Okay, it's been scheduled for evaluation
<RetardedOnion>how do i add something to /etc/libvirt/qemu.conf?
<ngz>What version of libstdc++ Guix is using with gnu build system? Can I assume it is the same as gcc (5.5.0 at this time), or is it another version?
<ngz>I didn't find how to check libstdc++ version from, e.g., guix environment.
<pkill9>does anyone know what might cause this error?: Failed to contact configuration server; the most common cause is a missing or misconfigured D-Bus session bus daemon. See http://projects.gnome.org/gconf/ for information. (Details - 1: GetIOR failed: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.GConf was not provided by any .service files)
<pkill9>from searching around, adding `gconf` as a propagated input is supposed to fix it, but it doesn't
<lfam>mbakke: Epiphany's RUNPATH is incorrect on staging, probably due to that meson-build-system change. The RUNPATH should include '/gnu/store/...-epiphany-3.28.3.1/lib/epiphany' but it's missing the final path component
<lfam>mbakke: I can workaround that issue by passing extra_link_args to the epiphany build
<mbakke>lfam: Sounds good, thanks for fixing it.
<mbakke>By the way, we should try cherry-picking the mozjs and polkit update from wip-gnome-updates.
<lfam>I got confused; extra_link_args is a cmake thing, not a meson thing
<RetardedOnion>where do i have to add what to use ovmf in libvirt/virtmanager?
<mbakke>lfam: You can probably pass "-Dc_link_args=...".
<mbakke>Or cplus_link_args, not sure what evince is.
<rekado>fontforge fails to build on core-updates.
<rekado>Fatal Python error: _Py_InitializeCore: main interpreter already initialized
<rekado>looks like it’s a bug in Python, not in Fontforge.
<rekado> https://bugzilla.redhat.com/show_bug.cgi?id=1595421
<rekado>mbakke: should we patch Python 3.7 in core-updates?
<mbakke>rekado: Yes, unless 3.7.1 is released soon (it was scheduled for end of July which is why I didn't bother).