IRC channel logs

2018-08-05.log

back to list of logs

<reepca-laptop>what's the status of GNU Ring packaging currently?
<roptat>hi guix!
<amz31>o/
<snape>\\o
<efraim>hi!
<kmicu>( ^_^)/
<reepca-laptop>how does one apply a patch to sources that have changed since the patch was generated? Specifically looking at these patches https://lists.gnu.org/archive/html/guix-patches/2017-06/msg00831.html for example, "git apply" fails with current master. Does one have to rewrite commit history from the point it was generated?
<efraim>sometimes, when both 'git am' and 'git apply' fail, I find myself manually applying the patch, staging the changes and running 'git apply --continue' so the by-line doesn't get messed up
<efraim>not an ideal situation at all
<zipper>Hey, I have this issue with guix. When I'm running say a guix pull or a guix install it causes my user to log out.
<zipper>Has anyone else exprienced that?
<zipper>I thought it was because my /tmp is a ramdisk but it does the same thing even when I set TMPDIR to an actual FS dir
<zipper>*disk dir
<roptat>zipper: I never had that issue
<roptat>how is it even possible?
<roptat>if you run a command, I expect that even if it fails, you get back to your shell...
<roptat>the filesystem in /tmp shouldn't matter much
<zipper>roptat: Ya it kills eveyrthing and exits the user
<zipper>tmux dies too
<roptat>do you run out of memory?
<reepca-laptop>agh, here's a great example of frustrating guile error messages: https://hastebin.com/raw/inobomahen. I came across that while trying to compile guix. It will happily tell us "oh yeah, the error happened somewhere in the code that evaluates stuff", but not, say, what code it was evaluating when the error happened. So we're back to good ol' print statement debugging to try to find where that is.
<rain1> https://blog.ungleich.ch/en-us/cms/blog/2018/08/04/mozillas-new-dns-resolution-is-dangerous/
<rain1>Mozilla has partnered up with Cloudflare and will resolve the domain names from the application itself via a DNS server from Cloudflare based in the United States. Cloudflare will then be able to read everyone's DNS requests.
<amz31>oh
<amz31>that's money!
***benny is now known as Guest70241
<efraim>Totally different than using yahoo as the default search provider
<efraim>$gods forbid they get some money for their foundation, its not like it can't be changed in the settings
<amz31>in french there is an expression that stroke the mind of people, talking about television, it said "we are selling people's brain attention life span"
<amz31>that's what is happening with this cloudflare dns, you can change it but you have to dedicate time for it
<roptat>zipper: if that's your error, TMPDIR must be set both for your user running guix and the process running guix-daemon
<mbakke>efraim: Did you get anywhere with that MariaDB test?
<zipper>roptat: Idk what my error is because I never get time to look into it
<zipper>but let me try it that way for a sec
<efraim>mbakke: sorry, I've been a bit busy over the past few days
<efraim>Also going on a family trip later this week for a bit
<mbakke>efraim: No worries. Do you have the link to the upstream bug?
<reepca-laptop>huh... apparently trying to build crypto++ causes a segfault in gcc.
<reepca-laptop>had to go all the way up to gcc 8 before it would get past blowfish.cpp...
<eilliot>The network speed is very slow when i using gunix. Its speed is 5KiB persecond on average. Any idea?
<mbakke>reepca-laptop: That's probably <https://bugs.gnu.org/31708>.
<mbakke>GCC8 works because it has the fixed patch.
<kmicu>Hi eilliot: wild guess: after GuixSD installation two machines in your network have the same IP assigned; a router has no idea what to do and that results in abysmal speed.
<aminb>has anyone looked into making a guix package for wireguard?
<eilliot>I am installing the GuixSD and also have the guix installed on my machine.
<eilliot>@kmicu Well, it is slow but it is very stable ....
<eilliot>Does guix have any way to configure the resource or any optional choice ?
<eilliot>clear
<reepca-laptop>heh... our argon2 package goes to the trouble of fixing up libargon2.pc, but is betrayed by the makefile, which actually doesn't even install it.
<reepca-laptop>(and later packages that depend on it specifically require pkg-config to confirm its existence or will refuse to build...)
<mbakke>reepca-laptop: Oops :)
<reepca-laptop>and then we've got ffmpeg over here randomly getting rid of one of their #defines and replacing it with another one with a slightly different name. Renaming I can understand, but getting rid of the old name... that's gotta be just to screw with people.
<reepca-laptop>which brings me to an actually relevant question, is the source field of packages thunked? That is, can I inherit from a package, change the version, and get a different source?
<reepca-laptop>would really reduce the amount of copy-pasting I need when all these libraries break backwards compatibility
<reepca-laptop>(assuming that the url depends on the version using, for example, string-append)
<reepca-laptop>although I suppose in light of the requirement to specify the hash it probably wouldn't help much anyway
<ison111>Is there any way to specify "guix environment" in a shebang?
<amz31>not really, except maybe with containers