IRC channel logs

2018-07-28.log

back to list of logs

<lfam>The Qt build... it takes forever
<kballou>when running `guix pull` I get the following error: `guile: warning: failed to install locale`. I'm running on guix on gentoo-hardened. is this something to be worried about? did I forget a step?
<pkill9>yeah Qt is a beast
<lfam>kballou: Did you get an answer about the locale warning?
<kballou>lfam: no, nothing yet
<lfam>Basically, you need to install a locales package and export the GUIX_LOCPATH variable. As described here: https://www.gnu.org/software/guix/manual/en/html_node/Application-Setup.html#Locales-1
<lfam>To get rid of the warning completely, this variable should be exported in the login shell of anyone using Guix, and also in the environment where the guix-daemon runs
<lfam>(I don't know how daemons are handled on Gentoo)
<kballou>lfam: let me give that a try, I had a suspicion I was leaving something out
<kballou>lfam: thanks, it appears to be working without the warning now
<kballou>though, I had to install both `glibc-locales` and `glibc-utf8-locales`
<lfam>kballou: You should only need one of them.
<lfam>glibc-locales is a superset of glibc-utf8-locales
<kballou>lfam: that's what I thought, but unininstalling one seems to bring the warning back
<kballou>and it doesn't seem to matter which one I remove, without both packages, I get the warning for my user account
<lfam>Remember that GUIX_LOCPATH needs to be exported in the login shell (.bash_profile rather than .bashrc, and similar for shells besides BASH). Where are you exporting the variable from, and did you log out and back in?
<lfam>You can simulate the log out / in by using `bash --login`
<kballou>I haven't logged in/out between `guix package` invocations. I load it via `.zshenv` though.
<lfam>My guess is there some tricky issue with adding a new environment variable where it seems to take effect inconsistently until truly logging out and back in
<lfam>I use Zsh but have never used .zshenv. If it's source only at login then it's good
<lfam>s/source/sourced
<lfam>I use ~/.zprofile and test changes with `zsh --login`. Anyways, if you really do need both locales packages, that's a bug
<reepca-laptop>where could I find a brief overview of how search-paths are supposed to work?
<reepca-laptop>I've been just sort of assuming "oh, each specification just says that this part of the output of this package should be accessible through this search path environment variable"
<kballou>lfam: hmm, okay. I didn't think there was a difference between `~/.zprofile` and `~/.zshenv`, but maybe there is something I'm missing. I'll test this a little more and report back.
<lfam>kballou: I'm not sure if there is, just trying to highlight trickiness around shells and environment variables
<kballou>lfam: gotcha
<lfam>reepca-laptop: There is a bit in the manual, Invoking guix package
<lfam>And another bit in the package reference
<apteryx>hello! to get proper bash completions (for example, for hosts defined in my ssh_config when using ssh), do I need to install both the 'bash' and 'bash-completion' packages, or is just the later supposed to be enough?
<tayirvadai>Hi, i recently installed guixsd and i am having trouble with wpa_supplicant
<tayirvadai>any help is appreciated.
<tayirvadai>wpa_supplicant -c /etc/supplicant.conf -i wlp3s0 -B
<tayirvadai>command after logging in says its successful
<tayirvadai>but it does not work
<tayirvadai>correctly. (i.e.) dhclient -v wlp3s0
<tayirvadai>keeps trying but cannot
<tayirvadai>connect to the wireless
<tayirvadai>the same seems to be working when booting using guixsd installation medium
<tayirvadai>installation was to a physical system
<tayirvadai>any help is appreciated
<g_bor[m]>Hello guix!
<roptat>hi guix!
<roptat>g_bor[m]: so from nhc you can build ghc, but only on 32bit platforms?
<roptat>maybe only i686?
<janneke>hi guix!
<rekado>roptat: this might be helpful for context: https://elephly.net/posts/2017-01-09-bootstrapping-haskell-part-1.html
<tune>icecat is still using an ancient firefox version, qutebrowser has been broken for weeks. what a sad state web browsing is in on guix... :(
<rekado>tune: I’m using epiphany.
<rekado>for GHC it probably makes more sense to modify an early GHC so that it can be interpreted with Hugs.
<tune>interesting, I don't think I have used it
<tune>ah, the GNOME browser... not sure I want that on my system
<tune>icecat is okay for most things, mainly I am often running into an addon I can't install because it uses the new webextension system that needs ff56 or newer
<rekado>roptat: I made some progress with that but I haven’t had the time to make progress.
<tune>and qutebrowser is built to use webengine which isn't packaged. it was configured for use with webkit in the past, but the last person to update it must have not done so
<ata2001_>Hi!
***ata2001_ is now known as ata2001
<ata2001>I saw a talk about guix in Budapest and now I'm considering installing GuixSD as my main OS on my new laptop. Do you think it's ready for everyday use?
<pkill9>ata2001: i'm using it on my laptop, however i have to compile nonfree linux kernel with nonfree wifi firmware for wifi, so keep that in mind
<pkill9>if you have a wifi card with FOSS drivers then you don't need to worry about that
<ata2001>Is there an easy way to manage my locally made packages as a separate repo?
<ata2001>like overlays in gentoo
<brendyn>ata2001: you can use the environment variable GUIX_PACKAGE_PATH to set a directory containing scheme code with your package definions in it
<pkill9>yeah, you can set the GUIX_PACKAGE_PATh environment variable which will include specified directories as package definitions
<pkill9>when you run the `guix` command with that environment variable set, and you can set that env variable in your ~/.profile
<ata2001>will it automatically build the packages?
<ata2001>if I put the recipes there
<pkill9>it depends
<pkill9>to be more specific, guix always automaticlaly compiles any needed dependencies whenever you tell it to builds or install something
<ata2001>sounds good
<pkill9>so if you ask it to build or install a package from those additional recipes, it will build it plus all the dependencies, but it won't for example automatically override native-guix dependencies if you try to build or install a native-guix package
<ata2001>what is your way of updating your nonfree kernel?
<pkill9>like, if i add a package definition for zlib (which is required by xorg-server) to my additional recipes, and then tell guix to build xorg-server, it won't automatically use the recipe for zlib that i put in my additional recipes, it will use the native-guix provided zlib
<pkill9>but, if i wrote a recipe for xorg-server in my additional package recipes, then i could tell it to use the zlib recipe in my additional packages instead of the native-guix zlib recipe
<pkill9>i update it by changing the version and specifying a new url to the source, and then guix will automatically rebuild it when i tell guix to upgrade my system
<brendyn>tune: someone has packaged chromium but it's not in master yet it seems
<pkill9>brendyn: where is chromium packaged?
<brendyn>pkill9: It's on the mailing list
<pkill9>in guix-patches?
<pkill9>oh, last message about that was posted in april :<
<ata2001>pkill9: cool thanks
<pkill9>i feel like Google's manage to put their privacy-violating stuff in chromium by making it so large and complex, and putting small privacy-violating things deep inside it, such that nobody will find them or be able to remove htem because of how large nad complex the project is
<pkill9>i have no evidence of that though lol
<pkill9>and*
<brendyn>i think they just dont particularly care
<brendyn>it's like torvolds leaves binary blobs in linux source code files because he doesn't care to make them optional
<brendyn>so he causes trouble for the linux-libre project which he doesn't care about
<rain1>it is very strange that linux is GPL but contains binary blobs
<brendyn>I don't really know how it works
<brendyn>rain1: https://yarchive.net/comp/linux/gpl_modules.html
<tune>I'm not really interested in using chromium. is there any progress on webengine? they're similar/related, I think
<pkill9>webengine is chromium in Qt
<ecbrown>when i first installed guix with gnome, i had a nice screen resolution. having done some updates and reconfigs etc. i've got low res... wondering where to start to get higher resolutions again
<brendyn>ecbrown: xrandr ?
<ecbrown>brendyn: yes, i've installed xrandr, i suppose i have to learn how to use it
<Formbi>hello
<brendyn>you just type xrandr
<Formbi>how to ignore a package?
<brendyn>to start with, or otherwise arandr and use the gui
<pkill9>`guix package --do-not-upgrade` Formbi
<ecbrown>brendyn: ok let me try this. i think i need to be on the console
<pkill9>there's also an environment variable you cna put htat in, can't remember which one
<Formbi>pkill9: tried this, doesn't work :/
<pkill9>what happens Formbi?
<pkill9>which package are you trying to prevent form upgrading?
<Formbi>I don't want texlive, but it gets downloaded and takes up all my disk space (it's a vm so I don't have much)
<pkill9>is it in a user profile or the system profile?
<roptat>it's probably needed to build another package that's part of a profile
<pkill9>wow it's source is 2.3Gb
<Formbi>dunno
<Formbi>how to check it?
<roptat>when you runthe guix command, add a "-n" option and if one of the packages you want is listed under "would be built", it's the culprit
<roptat>not sure if there's a better solution
<roptat>maybe guix weather?
<ecbrown>xrandr only shows 720x480. not sure why that changed
<ecbrown>(maybe i rebooted without monitor turned on or something)
<ecbrown>though i thought this would be a property of the ati radeon video card...
<g_bor[m]>roptat: It seems that rekado managed to do that. But I'm not sure.
<roptat>I've taken a patch from nixos for postgresql and was able to load postgis \\o/
<ecbrown>awesome! good to hear. i'm using postgis/pgRouting on centos and want to try in guix
<roptat>the patch disables postgresql's ability to follow symlinks, so it looks for extensions in the store directory it was launched from
<roptat>the issue is that postgresql is launched from its store directory, so I used trivial-build-system to build a package that's the union of postgresql and postgis
<Formbi>well, there is git, lynx, thunar, xorg-server, mpv and python-babel
<roptat>giving that to the postgresql field of the postgresql-configuration, I was able to create a database and load postgis
<Formbi>wonder what is the culprit
<roptat>Formbi: are you running on a recent version of guix?
<roptat>if it's very recent, the build farm probbly didn't have enough time to build substitutes
<roptat>do we have a procedure to help creating these unions?
<roptat>I'd like to have a list of extension packages we could pass to the postgresql configuration
<roptat>then it would build a union of postgresql and the extensions
<Formbi>guix --version gives 12e530… which is not very helpful
<roptat>looks like it's around mid-june
<roptat>you can try "guix build git -n" and other packages to see what they want to build
<roptat>you can also try to run guix pull now and hope that substitutes will be available in a few days
<roptat>or pull to a commit from yesterday
<Formbi>nothing shows texlive
<Formbi>strange
<roptat>what command do you want to run exactly?
<roptat>it could be texmf too
<ng0>apteryx: it used to "just work", but many commits ago some change in an /etc/ file broke it
<ecbrown>wondering if anyone is seeing that shepherd can't start user-homes, term-auto, avahi-daemon
<pkill9>is that after running `guix system reconfigure` ecbrown?
<ecbrown>pkill9: yup
<pkill9>i'm running that now, i'll tel you what mine says after it's finished building everything, i'm pretty sure i see that too
<ecbrown>cool thanks
<ecbrown>is there something to do after sudo -E guix system reconfigure config.scm? e.g. something to update herd
<ecbrown>(keep forgetting ... ./pre-inst-env ...)
<pkill9>ecbrown: my system reconfigure finished and it also said 'service user-homes could not be started', but it did say it unloaded those services: https://paste.debian.net/plain/1035551
<pkill9>i dunno if it's a problem, haven't had any problem so far
<pkill9>maybe it's normal and only 'succeeds' if any of the user's home directories are change din the config, or something
<ecbrown>pkill9: i see those messages at startup
<pkill9>oh hmm
<aminb>g_bor[m], kballou: thank you both for the reply. i'm very much a beginner myself but i'll keep an eye out for any changes. or might get involved myself as i learn more
<apteryx>ng0: I see, do we have a bug tracking it (the breaking of bash-completion)
<ng0>idk
<apteryx>checking
<apteryx>doesn't seem like
<ng0>there was one patch which introduced this a couple of weeks.. months.. ago
<ng0>or maybe not.. idk
<apteryx>OK
<ng0> https://git.savannah.gnu.org/cgit/guix.git/commit/?id=b19950a184a9b7506f9be4ecaa043e5a7e460b52 seems unlikely
<ng0>wrong commit
<apteryx>that's what I was looking at too
<ng0>but the one before that in the search was also not what I wanted
<apteryx>shouldn't break anything
<ng0>okay, old profiles "broke" with this as in that you need to put this now in your bashrc or whatever
<ng0>I see completion as optional.. but it's back when you source /etc/bashrc.. I didn't bother to look into why
<g_bor[m]>Hello guix!
<ecbrown>ACTION waves
<g_bor[m]>I need to modify several packages, all misses a native input after upgrading ant. Is it ok, if I create a separate commit for each package, or should I squash them? I feel the commit per package approach more consistent.
<roptat>hey g_bor[m], has wip-java8 been merged in staging?
<pkill9>is gst-plugins-base failing to build for anyone else?
<g_bor[m]>roptat: yes, I actually added the two commits directly.
<roptat>g_bor[m]: cool :)
<g_bor[m]>I will recreate it soon with the patches needed for switching ant.
<g_bor[m]>Also, as I've written I need to add a new native input to several packages. Is it acceptable to keep these as separate commits, or should I squash them?
<roptat>why do you need to do that?
<roptat>what input?
<g_bor[m]>It seems that ant-junit is needed if a package is build using ant/java8 and junit.
<roptat>can you make junit depend on ant/java8?
<roptat>ant-junit I men
<roptat>mean*
<roptat>or maybe it's more of a build-system dependency... maybe ant-build-system should add ant-junit as an implicit inpot
<roptat>input*
<g_bor[m]>roptat: I've been thinking about this for a while. It seems that adding this as a native input is the least intrusive way. If I make it a build system dependency, then we need junit before we can use ant-build-system. And I would rather not make junit depend on ant-junit, as this is only needed when we use ant, and in the prospect of a soon to be maven build system it just does not seems the right way to go.
<roptat>g_bor[m]: maybe make ant-junit optional in ant-build-system: it would be present by default, but setting it to #f will remove it
<roptat>so we can use ant-build-system for junit and don't have to add 100 times or so ant-junit as a native-input to every package
<g_bor[m]>That might work. Should we go that way instead?
<g_bor[m]>Actually it seems that we need to disable it on bootstrap packages, and a few more. I will have a look at guix graph.
<mbakke>Oh no, the running Hydra evaluation missed the last few commits that rebuilds GNOME and IceCat.
<roptat>g_bor[m]: maybe it requires more work than adding the native-input... I don't know
<g_bor[m]>Currently this way there are about 60 packages involved. Will have a look.
<roptat>maybe it's not that terrible
<g_bor[m]>roptat: It does not seem to be terrible, actually. And once we have a maven build system we can get rid of most of it.
<roptat>ok, then add the native-inputs directly
<g_bor[m]>I consulted with rekado about what should be the next step toward a working maven build system, and it seems that we should modify ant-build-system to include pom.xml in the jar files. Would you like to take a look at that?
<roptat>it seems to be the logical next step indeed
<atw>I had an idea on maven-build-system. https://lists.gnu.org/archive/html/guix-devel/2016-02/msg01396.html proposes having a maven-build-system create a maven repo populated with the input jars. What if there was a procedure that yielded a package object whose output was that repo?
<roptat>I can't promise i'll have anything but I can take a look
<g_bor[m]>roptat: ok, thanks. In the meanwhile rekado asked me to have a look at separating java bootstrap to a separate module. I will go on with that once I've finished with ant.
<g_bor[m]>atw: Actually it was instructive stuff. The way I think this will go is to use the maven install plugin to populate the local repo with inputs, and when the pom.xml is included in the jar files the install plugin creates the necessary structures within the repo for the give jar.
<g_bor[m]>Now I've got to go:) My son would like to take a walk :)
<atw>makes sense, g_bor[m]! have a good walk :)
<mbakke>Heh, the closure of IceCat contains libjpeg-8, libjpeg-9, openjpeg and libjpeg-turbo.
<civodul>hey mbakke!
<civodul>mbakke: IceCat is verrrry good at display JPEGs, all sorts of JPEGs
<mbakke>Sup civodul.
<civodul>*displaying, evne
<civodul>*even
<mbakke>Heheh :)
<civodul>damned, my keyboard must be broken
<mbakke>civodul: Are you able to ninja-restart the running Hydra evaluation? It would be good to get the libjpeg-turbo and dconf update!
<civodul>ACTION looks
<civodul>done!
<mbakke>Sweet, thanks! :)
<civodul>yw!
<roptat>when I try to define a package with (source (local-file "../test")), guix tells me "guix build: error: build failed: regular file expected"
<roptat>same with an absolute path
<civodul>roptat: you probably need #:recursive? #t
<civodul>perhaps we should make it the default
<roptat>oh yes, it work :)
<pkill9>what is the URL to the build server's queue again?
<mbakke>pkill9: Do you mean this one? https://hydra.gnu.org/jobset/gnu/master
<mbakke>You can see the entire queue by pressing the "status" menu at the top and follow the link.
<g_bor[m]>Anyone with some more insight on clojure, I've sent a patch yesterday to fix the build, but it would be nice if someone with clojure experience could assure me that this patch does not interfere with any usual usecases.
<mbakke>Perhaps atw is up for the task :)
<mbakke>Oh, he's not here.
<g_bor[m]>mbakke: I will contact them later anyways in the maven build system brainstorming, just don't I forget...
<g_bor[m]>sneek: botsnack!
<sneek>:)
<pkill9>yeah that one thanks, i keep losing the URL
<g_bor_>sneek: later tell atw: I would like you to have a look at my clojure patch. mbakke said that you are familiar with clojure stuff. It would be nice if you could confirm that this does not interfere with typical clojure usecases. It is here. https://debbugs.gnu.org/cgi/bugreport.cgi?bug=32295
<sneek>Got it.
<pkill9>looks like gst-plugins-base fails on i686-linux and armh, but not x86-64, wonder why that is
***florian__ is now known as pelzflorian
<efraim>In core-updates(?) one of the low-level users of libjpeg-8 gets switched to 9
<efraim>Of the few remaining are mame and qt4
<efraim>wow, lots of commits recently to core-updates and staging, looks like I have lots of testing to do
<mbakke>efraim: Agh, I forgot to add the AArch64 fixes to Python.
<efraim>mbakke: I have the patch still on my machine, I can just add it
<apteryx>sneek: later tell ng0 Will try it out (sourcing /etc/bashrc to get completion working). Thanks!
<sneek>Got it.
<pkill9>does anyone have any issues with wifi not automatically connecting to an available network?
<civodul>pkill9: with network-manager it just works for me
<pkill9>civodul: i found a fix for it :D https://www.linuxquestions.org/questions/slackware-14/network-manager-wireless-autoconnection-not-working-4175606533/#post5714573
<pkill9>was worried the driver is bugged, because sadly i need to use closed source driver >.<
<pkill9>would use atheros card but BIOS whitelist >.< >.<
<reepca-laptop>Hmmm, this is a tricky one. I've got an environment variable I need to use in order for a program to be able to find some other packages it uses, however when that environment variable is set, it replaces the install-time-configured search locations. Including "the current directory". I can add the built-in search locations with a search-path-specification except for the current working directory. Is there a way to add a literal string
<reepca-laptop>to a search path?
<civodul>like you always want "." to be on the search path?
<reepca-laptop>aye
<civodul>that's not possible, i think
<reepca-laptop>guess it's time for a discussion with the developers or a patch, then
<roptat>g_bor[m]: I've been working a bit on maven-build-system
<roptat>it seems we need maven-plugin-plugin to build some essential maven plugins
<roptat>there's still a lot of cyclic dependencies there, because maven-plugin-plugin is a plugin itself
<roptat>it generate META-INF/maven/plugin.xml
<roptat>and maven requires it to load a plugin
<janneke>civodul: did you get anywhere with mes-boostrap? i had to leave abruptly yesterday
<roptat>so we need maven-plugin-plugin, built with ant, some maven plugins and we need to change the ant-build-system to add the pom.xml file in META-INF and in another directory like share/pom/pom.xml
<roptat>then I think it will be possible to create a repository for maven to read
<civodul>janneke: not really! i had to leave as well (i'm about to go afk for a while and enjoy the summer in fact :-))
<civodul>i realized i had misunderstood things, i thought wip-bootstrap already had commencement.scm integration of sorts
<civodul>all the hard work is already done anyway, so AIUI it won't make much of a difference
<janneke>ok, good! brilliant timing, in a few days i'll be away for a bit of summer too :-)
<janneke>'twas a pretty heavy week, preparing for 0.17 and gnu...thanks for all your help
<mbakke>Heh, the TCL test suite actually ignores errors. There are 8 failing tests atm.
<pkill9>how can i go about debugging power management events?
<pkill9>specifically, i'm trying to fix an issue in which if i wake up my laptop from suspend by opening the lid and then immediately close it again within a few seconds of it waking up, it doesn't suspend
<aminb>hi all. does anyone here use guix to build latest emacs off of git master?
<aminb>i'd very much appreciate it if they could share their build recipe
<civodul>ACTION does not
<civodul>aminb: did you try inheriting from 'emacs' and changing the 'source' field?
<aminb>civodul: haven't tried that yet, but will be. (I'm preparing to install GuixSD)
<aminb>civodul: how can i specify a particular git commit for the source, instead of the gnu emacs mirror?
<civodul>aminb: you'd use (origin (method git-fetch) ...)
<civodul>there are examples in gnu/packages/*.scm
<civodul>alternately, you can make the checkout manually, and then use "guix build emacs --with-source=/path/to/checkout/emacs"
<civodul>janneke: BTW, congrats for GNU Mes! i just saw your message