IRC channel logs

2018-04-19.log

back to list of logs

<nckx>buenouanq: The mcron-not-running bug is fixed in master now :-)
<buenouanq>oh, that was a bug/problem?
<buenouanq>does anyone have an answer about my postgres question?
<nckx>buenouanq: Substitute ‘-’ for ‘@’.
<buenouanq>pulling the latest, will try in a moment
<buenouanq>thank you
<nckx>(With ‘@’ is a ‘package specification’ as used on the command line etc., with ‘-’ is the actual Scheme variable name.)
<buenouanq>can someone post an example of a simple custom shepherd service please
<vagrantcish>i think the recent perl upgrade borked irssi.
<vagrantcish>irssi
<vagrantcish>irssi: error while loading shared libraries: libperl.so: cannot open shared object file: No such file or directory
<vagrantcish>switching to the previous generation, and irssi works again
<vagrantcish>in other news, any idea how to temporarily disable suspend on lid close?
<nordstrom>Has anyone had any success getting smartcards to work? Specifically a Nitrokey? Something tells me this has something to do with udev rules, which I've attempted to add to my system config, to no avail. I get the 'ol "selecting openpgp failed: No such device".
<nordstrom>vagrantcish, are you using tlp? Because tlp can handle that nicely.
<vagrantcish>i have it installed
<nordstrom>But is it running?
<vagrantcish>i don't have a configured service for it, no
<vagrantcish>ACTION looks it up in the manual
<nordstrom>TLP is nice to add to the system config. However, xfce4-power-manager or similar can handle what you want if you prefer. I'm not sure how to do it without some sort of power manager.
<vagrantcish>i saw a setting to set the behavior on lid close, but it seems a bit excessive to reconfigure my system just to disable that feature
<nordstrom>Then using xfce's power manager may be a quick fix.
<vagrantcish>so the tlp service is running ... how do i disable suspend on lid close?
<vagrantcish>oh, interestingly enough, i did try using a smartcard as well, but no luck so far
<nordstrom>Yeah, udev is still not as automagic as I'm used to.
<nordstrom>Oh you know what, I've misled you.
<nordstrom> http://linrunner.de/en/tlp/docs/tlp-faq.html
<nordstrom>"Depends on the setting. TLP
<nordstrom> does not touch display brightness → no conflict,
<nordstrom> does not change suspend / hibernate settings → no conflict,"
<nordstrom>I use gnome-settings-daemon to handle all my power management and whatnot, but xfce or lxde's power manager would be my choice if I just needed a standalone solution.
<nordstrom>Sorry about the TLP rabbithole.
<Sleep_Walker>bavier`: that was also my tip, that's why I rebooted to GuixSD. If you know a way, how to prevent it, it might be good to add it into Makefile...
<Sleep_Walker>or should I clean '*.go' files in /usr?
<Sleep_Walker>or split it into another package?
<Sleep_Walker>well, clashing versions is not right anyway and should be prevented..
<snape>vagrantcish: I think suspend on lid close comes from one of the services from the D-Bus clique
<snape>maybe upower-service
<snape>there seems to be a way to prevent this behaviour (according to its Guix configuration), but my solution was to stop using it
<snape>buenouanq: what do you mean by "simple custom Shepherd service?"
<vagrantcish>yeah, maybe just disabling suspend-on-lid-close would be the way to go.
<vagrantcish>hrm. doesn't appear to be a cross-compiler for arm-linux-gnueabi.
<efraim>The arm cross compilers need a bit more standardization, but in general it should be arm-linux-gnueabihf
<vagrantcish>well, i'm trying to build a firmware that doesn't build with arm-linux-gnueabihf ... or at least, it claims to want arm-linux-gnueabi (that's what it's called in debian, at least)
<vagrantcish>i've got a few additional u-boot and arm-trusted-firmware builds
<civodul>Hello Guix!
<efraim>i'd love to see them
<efraim>what's the error for arm-linux-gnueabi? it could be a simple fix
<vagrantcish>efraim: it's my first work with scheme, so mostly cargo-culting what's already there and tweaking it ...
<efraim>its how I got started with guix :)
<vagrantcish>of course, there are countless vendor forks for this stuff
<vagrantcish>atf.scm: ("cross32-gcc" ,(cross-gcc "arm-linux-gnueabi" #:xgcc gcc-7))
<vagrantcish>atf.scm: ("cross32-binutils" ,(cross-binutils "arm-linux-gnueabi"))
<vagrantcish>and it fails with ...
<vagrantcish>dynamic linker name not known for this system "arm-linux"
<vagrantcish>in more detail: https://paste.debian.net/1020993/
<vagrantcish>but it seems like it might actually accept arm-linux-gnueabihf ... the build it just failing with something else
<vagrantcish>most of these build processors have you build atf and whatever other stuff, and then build u-boot and incorporate them ... but the espressobin does it all backwards
<vagrantcish>you build u-boot and some other tools, and then build atf which merges it all together
<efraim>maybe arm-linux-gnueabi would work if we added 'arm-linux' to gnu/packages/bootstrap.scm:163, but I'm not sure
<efraim>it does match the error message
<vagrantcish>fortunately the baremetal arm-none-eabi works
<vagrantcish>efraim: basically, i can add targets for a whole bunch of boards that i've tested, but i'm not actually using guix on them (yet)
<vagrantcish>i maintain u-boot in debian, so i test quite a few boards: https://wiki.debian.org/U-boot/Status
<efraim>I noticed :)
<vagrantcish>although now that i'm learning guix, testing new upstream versions seems much easier and quicker than messing with debian
<vagrantcish>and it's also easier to incorporate inputs from different vendors ...
<vagrantcish>notably, arm-trusted-firmware
<efraim>I should probably remove the odroid-c2 u-boot since i'm pretty sure it needs a blob to boot
<efraim>And one of these days I'm going to actually finish getting guixsd to boot on my pine64
<vagrantcish>there is https://github.com/afaerber/meson-tools for the odroid-c2, if i'm remembering correctly
<vagrantcish>but it still may require a blob
<vagrantcish>although maybe not
<vagrantcish>oh yeah, it's also got openssl/gpl incompatibilities, possibly
<efraim> https://sources.debian.org/src/u-boot/2018.05%7Erc2+dfsg-1/board/amlogic/odroid-c2/README/#L35
<vagrantcish>right
<vagrantcish>meson-tools might fix *some* but probably not all of those issues
<efraim>Right
<vagrantcish>oh, also based on your pine64 images, i could probably build a pinebook u-boot image too
<vagrantcish>needs a few patches not in mainline yet, but not a ton
<vagrantcish>one of the most complicated, but actually worked, was enabling ATF and u-boot for puma-rk3399
<vagrantcish>well, i'll try and submit a few new targets and see what happens :)
<vagrantcish>ACTION waves
<snape>buenouanq: Also, the Certbot service isn't a Shepherd service (i.e. it's not a daemon). It's a Guix service that includes two Sherherd services: Nginx and mcron.
<roptat>civodul: hi, I sent you a draft for a bolg post, did you receive it?
<roptat>blog*
<civodul>roptat: yep! it's on my to-do list, i'm just coming back from vacation + conference :-)
<civodul>roptat: BTW, did you commit the manual i18n thing?
<pkill9>i'm running xfce and my cursor keeps changing back to default on reboot, any ideas why?
<roptat>civodul: ok. re i18n, I'm almost done, but I think I can generate a .pot file that we can put on the TP
<civodul>roptat: awesome
<civodul>so when you feel you're done, i guess you can go ahead and commit :-)
<roptat>ok, I'll probably do that this evening or tomorrow then :)
<pkill9>does GuixSD do a bind-mount of /gnu/store onto itself with read-only set?
<pkill9>and if so, how does the guix daemon modify the store?
<siraben>What do I do about package collisions?
<rekado_>pkill9: how did you change your cursor in the first place?
<siraben>warning: collision encountered:
<siraben> /gnu/store/9j55362h2xgndjgy45f6283spjjx5990-glibc-2.26.105-g0890d5379c/bin/getent
<siraben> /gnu/store/qm98svilc62d4w7pd82gmr3303cfs725-gcc-toolchain-7.3.0/bin/getent
<siraben>
<rekado_>siraben: do you really need to install the glibc package?
<pkill9>rekado_: in Applications -> Settings -> Mouse and Touchpad -> Theme
<siraben>rekado_: Apparently it was needed to use glibc-locales
<siraben>I still have the "failed to install locale" error
<siraben>s/error/warning
<pkill9>hmm it's now changed to the correct cursor since i opened the Applications menu
<pkill9>altho not in this terminal
<pkill9>actually no it hasn't
<pkill9>just in Icecat
<siraben>Anyone know how to resolve the "failed to install locale" issue?
<siraben>Despite having the glibc-locales
<zybell_>pkill9 by having it open *before* mount (and never closing it,thats why it is a daemon).Then it sees the dir in the state under the mount aka rw.
<rekado_>siraben: you don’t need to install the glibc package.
<rekado_>siraben: you do need to have the glibc-locales package, though.
<pkill9>ah ok
<rekado_>you will need it in the environment of the guix-daemon itself, i.e. the daemon’s environment needs to have GUIX_LOCPATH set to the lib/locale directory of the glibc-locales package (or the profile containing it)
<siraben>rekado_: I did that, I set GUIX_LOCPATH but it still didn't work.
<siraben>I'm on Debian
<pkill9>zybell_: i want to bind-mount /home/gnu to /gnu before the daemon opens it
<rekado_>where did you set GUIX_LOCPATH?
<siraben>.bashrc
<pkill9>any idea how i could do that?
<siraben>Where should I be setting it?
<rekado_>siraben: the daemon does not read your user account’s bashrc.
<siraben>.profile ?
<rekado_>siraben: how do you start the daemon?
<siraben>systemctl
<rekado_>okay
<rekado_>siraben: does the service definition mention GUIX_LOCPATH?
<siraben>Where do I check that?
<zybell_>do it in the startscript of the daemon
<siraben>Environment=GUIX_LOCPATH=/root/.guix-profile/lib/locale
<siraben>
<rekado_>okay.
<pkill9>ok
<siraben>So maybe that's the issue
<siraben>?
<rekado_>does the *root* user have “glibc-locales” installed?
<siraben>How do I list installed packages?
<rekado_>guix package -I
<siraben>It has glibc and glibc-utf8-locales installed
<rekado_>okay
<siraben>I thought I wasn't supposed to use guix with root?
<siraben>Was I supposed to install the "hello" package as root the first time I set up Guix?
<rekado_>in this case you need to use guix with the root user because it’s the root user’s profile that is referenced by the daemon’s service file.
<rekado_>no
<siraben>Hmm... how people set up guix to work with foreign distros without root?
<zybell_>does the daemon use chroot("/gnu/store")? (If I would have written it, I would prolly put it in)
<siraben>Is there a way to reset Guix?
<rekado_>siraben: wait, this is not a useful thought :)
<siraben>I followed the tutorial
<siraben>manual*
<siraben>For setting up systemctl
<rekado_>siraben: the manual tells you to install it as root
<rekado_>so it’s all fine.
<siraben>Ok... but I want to use Guix as my user "siraben"
<rekado_>sure
<rekado_>it’s all fine
<rekado_>you set up Guix with root (because the daemon runs as root)
<siraben>Yes
<rekado_>and made it available for all users on the system
<rekado_>there’s nothing wrong with how you set it up
<siraben>Yes...
<rekado_>potential problems now are:
<rekado_>- the daemon is linked with a version of glibc that doesn’t match the version of the glibc-locales package
<rekado_>- or your locale is not included in the glibc-utf8-locales
<rekado_>glibc-utf8-locales is a subset of glibc-locales
<siraben>Right. I don't know how glibc-utf8-locales appeared, I should install glib-clocales
<siraben>glibc-locales*
<siraben>Unless they are the same, I'm confused.
<zybell_>rekdo_: or (silly question) does the daemon use chroot("/gnu/store")? (If I would have written it, I would prolly put it in)
<rekado_>as root do this: guix package -r glibc-utf8-locales -i glibc-locales
<rekado_>this replaces glibc-utf8-locales with the bigger glibc-locales package.
<siraben>Ok. I'll let you know once it's done.
<zybell_>rekado_: or (silly question) does the daemon use chroot("/gnu/store")? (If I would have written it, I would prolly put it in)
<rekado_>the first point I made above is more important, though
<dustyweb>davexunit: not sure if you saw the "guix based built tool" thread
<dustyweb>I'd be interested in your thoughts on it
<dustyweb>especially since I channeled you a bit :)
<pkill9>zybell_: where can I configure the guix-daemon start script? I can't see anything mentioned under the guix-configuration section here https://www.gnu.org/software/guix/manual/guix.html#Base-Services
<rekado_>siraben: it’s possible that you may need to upgrade the daemon to ensure that it is linked with the same version of glibc as the version of the glibc-locales package.
<siraben>rekado_: Does Guix have an automated way to set itself up?
<siraben>From the tarball
<rekado_>dustyweb: FWIW I agree with what you wrote on this build tool thread.
<rekado_>siraben: we have an installer script in the etc/ directory in the Guix source repository
<rekado_>siraben: all it does is automate the instructions from the manual.
<rekado_>I’m pretty sure that reinstalling won’t help.
<siraben>If I wanted to, how would I do it?
<siraben>Remove the /gnu directory?
<rekado_>people often have this impulse to destroy everything and start from scratch, but in the Guix world this is rarely a useful thing to do.
<siraben>Right.
<siraben>Guix was the first time I had to fiddle with environment variables, so it was a bit confusing at first
<zybell_>pkill9:I would first try manually if it works. That is emacs startscript
<siraben>Anyone using Guix on real hardware with Wireless and Sleep and other hardware working without any issues?
<siraben>Or as little issues as one can cope with ;)
<bavier`>yes :)
<siraben>How?
<siraben>What computer are you on?
<bavier`>siraben: I have an asus eeepc and a sony viao with usb wireless both running guixsd for several years now
<siraben>And sleep works fine?
<bavier`>yup, I think suspend on the eeepc even works
<siraben>IMO these two problems are the biggest on several linux distros I've tried on a MacBook Pro 2012 model, I need to switch
<siraben>Probably to one of Technoethical's ThinkPads
<siraben>bavier`: And this did not require any non-free firmware?
<bavier`>no
<siraben>Wow, can you link to what models you are using?
<pkill9>bavier`: when you say usb wireless, you mean using one of the USB wireless sticks you plug in?
<pkill9>i would love to get an older thinkpad and put Guix on it
<pkill9>would like to get it super cheap tho, lol
<bavier`>pkill9: yeah, it's one of thinkpenguin's https://www.thinkpenguin.com/gnu-linux/penguin-wireless-n-usb-adapter-w-external-antenna-gnu-linux-tpe-n150usbl
<siraben>Are there going to be any more good Linux compatible laptops?
<siraben>I know Purism is making them, but they're expensive.
<pkill9>unfortunately the state of newwer laptops and software freedom is meh
<bavier`>though lately it's been dropping connections frequently.
<pkill9>if you consider the CPU backdoors
<siraben>Debian on the MacBook Pro is fine, although Wi-Fi is prone to random dropping
<pkill9>not being able to instal libreboot
<bavier`>siraben: have you looked at the eoma68 laptop on crowdsupply?
<siraben>pkill9: Intel ME is neutralized on Purism's computers and Technoethicals etc
<siraben>bavier`: I have not.
<siraben>Interesting device
<pkill9>i saw that, looks interesting
<pkill9>imo the way forward
<bavier`>I'm on the list for a card and microdesktop, but I'm increasingly thinking about getting the laptop too
<siraben>We need modular systems, essentially.
<siraben>I wish my phone was made up of free software...
<siraben>Regarding the computing power of those Thinkpads https://tehnoetic.com/tet-t400s . It comes at 2.4 GHz and 8 GB RAM, should that be enough to replace a 2012 MacBook Pro?
<siraben>Don't know how long I would be able to use it without it being obsolete
<pkill9>interesting that they service smartphones to, especially samsung ones (tho leaving in nonfree modem)
<siraben>Is free software gaining more traction in the world? I see proprietary crap everywhere on everyone's screens all the time
<pkill9>i think so, not sure tho
<siraben>I support what the GNU project has done so far, but the general public still is oblivious to free software.
<siraben>Interesting, governments around the world are using Libreoffice to replace MS Office
<siraben>And Germany has been quick to adopt Linux for official uses
<pkill9>solid software that comes to mind is Blender and Krita
<siraben>Yes, Blender is amazing.
<siraben>Emacs, Blender, Firefox, GIMP, Inkscape, Libreoffice, Linux kernel, GNU distros
<siraben>+ Thunderbird
<pkill9>linux kernel has issues tho, hence the existence of linux-libre
<siraben>What's the difference between Icecat and Firefox?
<siraben>Why is Firefox not in the Guix repo?
<pkill9>same with firefox but not nearly as much
<siraben>Has anyone left LibreJS activated?
<pkill9>Firefox source code is fully free, but the software will recomend non-free plugins
<pkill9>also they by default have google search engine, it hink those are the reasons
<pkill9>says here in the first paragraph https://www.gnu.org/software/gnuzilla/
<pkill9>'While the Firefox source code from the Mozilla project is free software, they distribute and recommend non-free software as plug-ins and addons. Also their trademark license imposes requirements for the distribution of modified versions that make it inconvenient to exercise freedom 3.'
<siraben>pkill9: Well, free software is all about legal matters.
<rekado_>I’m using a Purism Librem 13 now. Before that I had a Thinkpad X200s with libreboot. (Flashed with the zerocat flasher.)
<siraben>How is the Purism Librem 13?
<siraben>What distro are you running?
<rekado_>GuixSD
<siraben>How is the wireless, sleep, etc?
<rekado_>works.
<siraben>Would recommend?
<rekado_>if you have money to spare or if somebody else pays: yes
<siraben>Ah, and how is battery life?
<pkill9>i heard there were some problems with their claims of freedom, I forgot what they were though
<rekado_>there are some problems with the display; it flickers for unknown reasons. Maybe related to the power saving features of the i915 driver.
<rekado_>the ME is said to have been disabled.
<rekado_>they come with coreboot installed.
<rekado_>for the things I’m doing an old Thinkpad would probably be sufficient.
<rekado_>it’s nice to be able to use 3D graphics things, though, which wasn’t possible on the old Thinkpad.
<rekado_>the bluetooth thing seems to require firmware blobs, so that’s not working with linux-libre.
<rekado_>wifi is working fine, though.
<rekado_>it’s pretty heavy and feels … dense.
<rekado_>at the same time I’m afraid to damage or scratch it.
<pkill9>yes i believe the issues raised are related to their use of coreboot, which includes binary blobs, and newer generation of Intel processors which come with the management engine, though you said they disabled it
<siraben>rekado_: It's heavy? I imagine the Thinkpad is heavier, no?
<rekado_>the Thinkpad was thicker, but the Librem feels very heavy for it’s size.
<siraben>rekado_: https://paste.debian.net/1021048/
<siraben>I tried installing glibc-locales
<rekado_>I can’t compare them now, unfortunately, because I no longer have all the parts of the Thinkpad.
<rekado_>siraben: there are two things I notice here
<rekado_>the first is that version 2.25 is old
<rekado_>so you’re using an old Guix.
<rekado_>the second is that you have glibc installed, which you really don’t need.
<siraben>Strangely enough, running "guix package -r glibc" is triggering a lot of package installs...
<siraben>What is the latest guix version
<siraben>Oh by the way, I keep getting 77 KB max download speeds for Guix
<siraben>Is there only one server or something?
<siraben>I'm in Thailand.
<buenouanq>snape: I'd like to run a Guile Web server service that comes up on boot and restarts if something goes wrong - Seems simple enough given what I've read about Shepherd services, but I have no examples to work from.
<siraben>rekado_: How come you don't have the parts of the Thinkpad? :p what did you do?
<nckx>siraben: hyda.gnu.org is just a single VM somewhere in the FSF area (Boston?). No fancy CDN. 77kB/s is quite slow, though; I get at least a few 100 in EU.
<siraben>Lol all the way, halfway around the world to Thailand
<pkill9>siraben: latest verison is 0.14.0
<pkill9>version*
<siraben>Shit Debian's wireless gave up on me without knowing it
<siraben>Did I miss anything?
<nckx>ACTION once updated Guix through a DNS tunnel that went from Paris to Miami to Brussels. That was fun. Also, never again.
<siraben>50 KiB/s now
<siraben>1 KiB is now many bits per second?
<siraben>1024?
<pkill9>siraben: i said latest version is 0.14.0
<pkill9>but it's always updated in git, so that's just the latest major version
<siraben>If I run "guix pull && guix package -u" as root does it update across the board?
<pkill9>`guix pull` will get the latest from git master
<rekado_>siraben: you can also add https://berlin.guixsd.org to the list of substitute servers
<pkill9>no it doesn't
<rekado_>that might be faster for you
<siraben>How do I update guix systemwide?
<pkill9>siraben: guix system reconfigure
<siraben>I'm running on Debian, though
<rekado_>no, that updates GuixSD
<pkill9>ah ok
<rekado_>siraben: every user potentially has their own version of Guix
<siraben>That complicates things
<siraben>I want to install glibc-locales on its latest version on root
<pkill9>i think you would have to do a for loop that updates each user's profiles, like in /var/guix/profiles/per-user/<user>/guix-profile
<siraben>rekado_: I still get the "failed to install locale" :/
<pkill9>siraben: then you just wanna run guix package -u as root
<siraben>pkill9: Don't I need to run guix pull first?
<pkill9>or if not isntalled then guix packag e-i glibc-locales as rot
<pkill9>yeah
<pkill9>sorry if im confusing
<siraben>What does installing "glibc-locales" do exactly?
<siraben>Apart from making the error go away
<rekado_>it installs the locales for glibc
<siraben>So I'm running "guix pull && guix package -u" on my own account and on root...
<siraben>And how is that helpful?
<siraben>I'm a complete noob to understanding the Linux architecture, so bear with me
<siraben>GNU/Linux *
<rekado_>pro-tip: if you want n accounts to use the same variant of Guix you only need to pull once and then link that user’s .config/guix/latest to all the other users’ home directories.
<rekado_>siraben: this is unrelated to GNU/Linux architecture. It’s pretty Guix-specific.
<siraben>siraben@debian:~$ which guix
<siraben>/usr/local/bin/guix
<siraben>
<snape>I wonder how guix works with a different version of guix-daemon
<rekado_>readlink -f /usr/local/bin/guix
<rekado_>snape: it usually works fine.
<siraben>/gnu/store/pii5cimi72lj5l7793h54g5sg0sr2apl-guix-0.14.0/bin/guix
<siraben>
<rekado_>the daemon protocol rarely ever changes
<rekado_>ls -l /usr/local/bin/guix
<snape>rekado_: ok good to know
<rekado_>that shows you that this “global” guix is actually just the root user’s guix.
<siraben>lrwxrwxrwx 1 root staff 54 Apr 16 21:23 /usr/local/bin/guix -> /var/guix/profiles/per-user/root/guix-profile/bin/guix
<siraben>
<siraben>So what does that mean, exactly?
<siraben>Can I run "guix pull && guix package -u" on my account "siraben" and have it propagate upwards to root?
<rekado_>what one user does will not affect another user.
<snape>(except for the root user)
<siraben>So...
<siraben>how do I safely update my guix?
<rekado_>what it means is that “/usr/local/bin/guix” is a link to “bin/guix” in the root user’s profile.
<rekado_>as root: “guix pull”
<rekado_>when you’re done you can link the root user’s .config/guix/latest to all other users’s home directories.
<siraben>What if I run "guix pull" as siraben?
<rekado_>this would do the same but only update /home/siraben/.config/guix/latest
<siraben_>This is mildly confusing
<rekado_>why?
<siraben_>It wasn't clear from the docs
<rekado_>“guix pull” as a particular user will only update that user’s .config/guix/latest.
<siraben_>I see, but if I run as root then it updates everyone's
<siraben_>?
<rekado_>no
<rekado_>but you asked for instructions on how to update everyone’s Guix, so I gave you the first step
<siraben_>In my case installing glibc-locales as root will fix the issue of no locale?
<snape>rekado_: could you please explain the relationship between ~/.config/guix/latest and /usr/local/bin/guix?
<snape>it's definitely not clear in my mind
<rekado_>the thing at /usr/local/bin/guix is a link
<rekado_>a link to the root user’s “bin/guix”
<rekado_>when Guix is executed it will *first* look for the current user’s .config/guix/latest
<rekado_>if that exists it will load Guile modules from there.
<rekado_>Since Guix is made up of a bunch of Guile modules this means that it effectively *becomes* the variant of Guix that is located at .config/guix/latest.
<rekado_>if it doesn’t exist it will use the modules that belong to this “bin/guix”, which in this case would be the root user’s Guix modules.
<snape>so the version of /usr/local/bin/guix doesn't matter, only ~/.config/guix/latest matters if it exists?
<rekado_>yes, it matters only in rare edge cases.
<siraben_>And why do I get a failed to installed locales error then?
<pkill9>rekado_: so you could just remove .config/guix/latest for the user and it will jsut use the latest one that root has?
<rekado_>pkill9: that’s right.
<siraben_>Even though I installed glibc-locales as siraben
<rekado_>siraben_: as I tried to explain: the daemon appears to be linked with a version of glibc for which there are no locales.
<rekado_>GUIX_LOCPATH is used to point the glibc to the locales.
<rekado_>the systemd service points GUIX_LOCPATH to a directory in the root user’s profile.
<snape>it's clearer, thanks rekado_
<rekado_>that directory is provided by the “glibc-locales” or “glibc-utf8-locales” package.
<rekado_>so by installing one of these packages the glibc that is used by the daemon ought to find the locales and everyone will be happy.
<rekado_>it is possible that the daemon is linked with a version of the glibc for which there are no locales; unfortunately, locale data are not compatible with different versions of the glibc.
<siraben_>Ah that's such a good explanation.
<siraben_>Thanks rekado_ for clarifying it
<rekado_>sure
<rekado_>ACTION needs to leave now
<siraben_>ACTION needs to sleep now
<siraben_>Good night everyone!
<snape>buenouanq: I can't think of any example right now, I'll think about it
<castilma>is nixos.org down?
<castilma>wrong chat
<snape> castilma: but there is https://downforeveryoneorjustme.com/nixos.org :-)
<snape>
<efraim>mbakke: thanks, glibc & compat strikes again
<mbakke>efraim: Yes, I'm afraid we'll have to deal with that for a long time still... Perhaps we should have kept the obsolete compat layer until the major distros migrate.
<pkill9>rekado_: i find that running `guix` under my user doesn't inherit root's .config/guix/latest, because the version reported by `guix --version` didn't match root's
<mbakke>Hmm, offlineimap have stopped processing messages for no good reason a couple of times recently.
<nckx>I've been away. What's the current dilation of core-updates?
<dustyweb>rekado_: got my purism laptop as well btw
<dustyweb>haven't gotten GuixSD on it yet, planning on testing my new backup strategy by moving it to the new device :)
<pkill9>what's the typical method used to remove guix system generations?
<pkill9>just remove them from /var/guix/profiles?
<mbakke>nckx: core-updates is semi-live. Currently we're still "bootstrapping", i.e. only doing the "core" subset on Hydra. It will be started fully once this is solved: https://lists.gnu.org/archive/html/guix-devel/2018-04/msg00157.html
<nckx>mbakke: Thanks!
<nckx>Is ‘core’ the same as ‘base’ here?
<mbakke>nckx: 'core' here is defined as (@@ (build-aux hydra gnu-system) %core-packages).
<mbakke>Actually, I don't think the variable is accessible that way. But you get the drift :P
<nckx>mbakke: I had no idea (I'd never ventured into build-aux/hydra before). Ta!
<nckx>lol @ the ‘hello’ package set.
<pkill9>i think i borked my install a bit by removing the first 5 system generation symlinks and then running `guix gc`
<pkill9>can anyone confirm it's borked?
<pkill9>fish is broken and my default xfce4 wallpaper is gone
<pkill9>and it's recompiling everything when running `guix system reconfigure`
<mbakke>pkill9: Sounds like some configuration files had picked up absolute references to those generations.
<mbakke>Can you look through the fish and xfce4 configs and see if you find them?
<mbakke>Please file a bug report for each :-)
<pkill9>the configs in my home directory?
<bavier`>we make an effort to put absolute references to binaries in some of our .desktop files
<pkill9>or default ones in the packages?
<pkill9>hmm well fish is working now
<pkill9>i removed it from my profile then ran `guix package --delete-generations`
<pkill9>i just ran fish from the store
<pkill9>i'm so confused lol
<pkill9>sorry i can't be much help
<pkill9>ah ok, i see, i've found the config that xfce4 is mistaken on
<pkill9>mbakke: what should i say in the bug report?
<pkill9>just that it used the absolute path in it's config?
<pkill9>i think i get it now, it should use a relative path when writing in config files, i.e. /run/current-system/share/whatever ?
<pkill9>yeah i see
<pkill9>oh, that bug has already been reported :) https://debbugs.gnu.org/cgi/bugreport.cgi?bug=25667
<pkill9>the issue with fish was also reported in january https://debbugs.gnu.org/cgi/bugreport.cgi?bug=30265
<roptat>I've just pushed my patches to make the manual translatable!
<vagrantc>hmmm... if i pass --substitute-urls on the commandlind, it seems like the guix builders only use those substitutes for certain things, but still use the default substitutes
<vagrantc>like, the thing i'm explicitly requesting a build for gets downloaded, and maybe the source files, for the initial build ... but ... transitive? inputs and such still seem to get downloaded from the default substitute