IRC channel logs

2018-04-05.log

back to list of logs

<mbakke>We should pick up the installer work to make things easier. One should not have to be a Unix expert to install GuixSD.
<pkill9>how do I specify a bind-mount?
<pkill9>oh nevermind I've worked out how
<caffe>is emacs broken on guixsd, or is there more i need to do than adding 'emacs' to use-modules and systemwide packages in config.scm?
<pkill9>oh, what 'type' do I specify for a bind-mount?
<zybell_>bind? rbind?
<bavier`>caffe: that should be enough, or let a user install it to a personal profile with 'guix package -i emacs'
<pkill9>from the output of running `mount` my bind-mount has a type 'none' so I'll put that
<dustyweb>ACTION looks at list
<dustyweb>systemd remains the godwin's law of free software
<dustyweb>or I should say, communication about systemd
<zybell_>what was that:godwins law about godwins law? Or didn't you just talk about ...?
<buenouanq>dustyweb: I loved that so much I saved it from last time.
<buenouanq> /https://u.teknik.io/rosLW.png
<buenouanq>Does anyone here use guile-squee? I need some help.
<buenouanq>ERROR: In procedure dynamic-link: file: "libpq", message: "file not found"
<buenouanq>I don't know how to trace these things is the problem.
<zybell_>strace
<dustyweb>buenouanq: hm, it didn't find it in the ./configure && make?
<dustyweb>anyway
<dustyweb>I don't use guile-squee anymore but you'd think I did ;D
<dustyweb>someone should take it over!
<zybell_>strace the execution and paste it.
<buenouanq>k, give me a minute
<zybell_>is postgres installed?
<buenouanq>yes
<buenouanq>zybell_: https://p.teknik.io/GRi6l
<buenouanq>squee-test.scm is just
<buenouanq>(add-to-load-path (dirname (current-filename)))
<buenouanq>(use-modules (guile-squee squee))
<buenouanq>and squee.scm is in ./guile-squee
<zybell_>ACTION looks at it
<zybell_>ok it does search only for libpq.{la,so}.Try 'find / -name "*libpq*"'
<buenouanq>zybell_: https://p.teknik.io/Wwwau
<zybell_>ACTION looks at it
<buenouanq>dustyweb: what do you use now then? is there something better I should know about?
<zybell_>which profile are you on? The hash pls.
<buenouanq>how do I do that?
<zybell_>echo $PATH could help
<buenouanq>I don't have a hash there.
<buenouanq>is it the thing under ~/.cache/guix/pull/ ?
<zybell_>it is part of the dir in /store that ends with -profile and is linked from your homedir.
<zybell_>part of it must be included in PATH
<zybell_>or a symlink to it
<dustyweb>buenouanq: well the application I wrote, Pubstrate, used guile-gdbm, but I think Pubstrate is a reasonable start and i did plan on extending it
<dustyweb>it's mostly that I'm spending more time in Racket these days, which ships with a Postgres (and other dbs) out of the box
<buenouanq>my $PATH is just
<buenouanq>/root/.guix-profile/bin:/root/.guix-profile/sbin:/run/setuid-programs:/run/current-system/profile/bin:/run/current-system/profile/sbin
<zybell_>ls -l /root/.guix-profile /run/current-sytem/profile would be the next step.
<buenouanq>/run/current-system/profile -> /gnu/store/z0dh057nvcxydcw68sa9ab17mn0nh1cl-profile
<buenouanq>z0dh057nvcxydcw68sa9ab17mn0nh1cl
<zybell_>first part of error found:postgres is not part of your system-profile. Can I get the other hash pls?
<buenouanq>/root/.guix-profile -> /var/guix/profiles/per-user/root/guix-profile
<buenouanq>/var/guix/profiles/per-user/root/guix-profile-14-link -> /gnu/store/6y3dmg8pgh74bhnskc2gm8njq9h2mris-profile
<buenouanq>6y3dmg8pgh74bhnskc2gm8njq9h2mris
<zybell_>ACTION looks at it
<buenouanq>I have the postgres service running as well as the postgres package installed to this user - I am actively using it...
<zybell_>postgres is part of your user profile. but sadly guile is not compiled to look into your profile for extensions. That is a bug in the recipe.There are two possible solutions to it.
<zybell_>First:Recompile guile and use a fixed recipe.
<zybell_>Second:make an environment where both guile and postgres are combined.
<zybell_>That depends how the path to /lib is set.
<buenouanq>could I add it to the global packages?
<buenouanq>Is this a known bug in the recipe?
<zybell_>Doesn't look like guile looks there either. Best chance is LD_LIBRARY_PATH. But if a wrapper sets it? 'set|grep ^LD_LIBRARY_PATH'could tell more.
<zybell_>It's at least unknown to me. Not anymore;-)
<buenouanq>You seem to actually understand what's going on, so can I leave reporting it to you?
<zybell_>No I don't have any accounts. I can't write.
<zybell_>Except in IRC,Pastebin and (Wikipedia).
<zybell_>You can try 'LD_LIBRARY_PATH=$HOME/.guix-profile/lib guile ...'. Could work. Or give interesting new errors. Or the same old. Of course replace the tree dots with a filename!
<zybell_>*three
<buenouanq>well I'll be zybell_
<buenouanq>that looks like it works
<buenouanq>is there a way to add that path from within a guile script itself?
<zybell_>No chance. except by exec env ... (dots are the cmd) but checking recursion can be a nightmare.
<zybell_>The idea would be to run the env program (not guile) with the cmdline if the environment doesn't match. env runs then guile again but now with matching environment.
<zybell_>How to represent that in scheme I let you work out. Thats not my bailiwick anymore.
<zybell_>Keep in mind you have to add the path to the running file to the command.
<zybell_>It may work with simple files where the executing file and the current file are the same. But extending it to modules will make problems.
<wxie>hi
<demotri>Hi
<wxie>How should I define my inferior lisp for emacs in guixSD if my installation is clisp: /gnu/store/wl4jcvp3njdh827kaj1hq34m0y2yqfh6-profile/bin/clisp?
<wxie>demotri: The path is so long and changing.
<demotri>wxie: What about ~/.guix-profile/bin/clisp?
<demotri>wxie: In that way, it is independent on package updates.
<demotri>wxie: Note: I'm not a heaxy Emacs user, so it could be that I miss some Emacs specific things here.
<rekado>wxie: you’re not supposed to use these long /gnu/store paths. That’s what profiles are for.
<civodul>Hello Guix!
<sneek>Welcome back civodul, you have 1 message.
<sneek>civodul, daviid says: right, thanks.
<thorwil>anyone here using smartparens in emacs, both installed via guix?
<thorwil>the sp-*slurp-sexp commands work, but sp-*barf-sexp doesn't, leaving me wondering if smartparens really does have such a defect, or if something is wrong about the guix version
<caffe>still no luck with emacs...
<caffe>tried via guix package -i emacs
<caffe>emacs just dies with fatal error 6
<thorwil>emacs toggle-debug-on-error is ... 0.o https://bpaste.net/raw/47ebbbff7e78
<caffe>what a jungle
<civodul>ACTION uses paredit
<thorwil>so did i, so far
<civodul>perhaps you should report the smartparens bug to bug-guix and whoever touched that package last
<rekado>caffe: it doesn’t start at all?
<thorwil>hmm, the copyright list in gnu/packages/emacs.scm does of course say nothing about who edited the emacs-smartparens definition
<civodul>no but you can C-x v g
<thorwil>a search on guix-patches does not bring up an "Add emacs-smartparens"
<rekado>thorwil: have you tried M-x magit-blame?
<thorwil>one digging out an actual git clone and disabling cua-mode, i found 2 names
<thorwil>ACTION sends to bug-guix and 2 authors in BCC
<thorwil>vc-annotate vs magit-blame ... hope i will recall both :)
<pkill9>i installed GuixSD \\o/
<buenouanq>yay~
<civodul>congrats pkill9_ :)
<g_bor>hello guix!
<civodul>howdy g_bor!
<pkill9_>hello g_bor :>
<g_bor>I have a question: I am under the impression, that on guixsd the only dotfiles touched by guix are under the guix profile. Is that correct, or is there any other file in the user home that is possibly modified?
<g_bor>I also have an I guess trivial question, but what way do you configure the keyboard layout for the graphical login screen? My keyboard layout on console, and inside the graphical environment is ok, but on the login screen I'm having problems.
<roptat>g_bor: you can't configure the keyboard layout for the login screen
<roptat>and guix doesn't touch any dotfile except for .config/guix and .guix-profile
<rekado>g_bor: you can change the keyboard layout for slim, but it requires changing X server settings.
<g_bor>rekado: ok, thanks for that. I will have a look at that.
<g_bor>I've also seen that several people here are using stow to manage user configuration. I'm thinking about if there is a good way to incorporate this to a GuixSD configuration? My typical use case goes like this: I have my user configuration stored somewhere in a git repository. I clone that, and then run stow on the clone, so populating my home. I was thinking about incorporating this into something like: under users have an optional stow-origin
<g_bor>filed, like we have origin for a package definition. We could reuse the download possibilites from there.
<roptat>rekado: oh I didn't know
<civodul> https://www.gnu.org/software/guix/blog/2018/guix--reproducible-builds-at-libreplanet-2018/
<g_bor>nice :)
<g_bor>I've recently received a mail that my talk on the Hungarian Free Software Conference had been accepted. This will be on 12. May. I will send the slides, as soon as I have the information about the duration of the talk.
<g_bor>Do you know anything about the status of #15549? That is hydra.gnu.org needs to declare its javascript licenses for LibreJS
<g_bor>?
<rekado>g_bor, roptat: http://paste.debian.net/1018818/
<rekado>g_bor: I wanted to work on this, but didn’t get around to it.
<rekado>it’s not a lot of work, but since the machine behind hydra.gnu.org is managed in a stateful way, I’m wary of touching it.
<roptat>rekado: where does read-string come from? guix suggests (sxml ssax input-parse) but I doubt that's it
<rekado>roptat: (ice-9 rdelim)
<thomassgn>rekado: good call on the systemd issue.
<pkill9>efraim_: how do you install all the packages in a manifest like yours https://gitlab.com/Efraim/guix-config/blob/master/GuixSD_GUI_manifest.scm
<pkill9>?*
<rekado>pkill9: guix package -m the-file.scm
<pkill9>cool thanks
<pkill9>can it be used to add packages to the system profile?
<pkill9>oh I don't think it adds the packages, just replaces the profile
<thomassgn>pkill9: Yes, that's my experience also.
<thomassgn>Would like a way to add manifest to profile, but haven't figured out how.
<pkill9>i would assume by piping list of package to xargs or something
<thomassgn>Would be really good for choosing what kind of packages to update/install and so on. one manifest for simple utilities that I want everywhere, one for libreoffice and other similar heavy-weighters and so on
<pkill9>yeah
<thomassgn>it's been on my list for a while, but the list just keeps growing... :P
<efraim_>I started with 'guix package -I | cut -f1 | sort'
<bavier`>hello guix
<civodul>heya bavier`
<pkill9>hi
<thomassgn>Hi
<bavier`>:)
<rcm>Hi Everyone. I am on GuixSD and gcc isn't working for me. When I run "gcc test.c -o test" I get the following error: "gcc: error trying to exec 'as': execvp: No such file or directory"
<rcm>I thought maybe my path was wrong, but all of the variables specified in "guix package --search-paths" are in my environment variables
<civodul>rcm: can you try "guix package -r gcc -i gcc-toolchain"?
<civodul>see the bottom of https://www.gnu.org/software/guix/manual/html_node/Application-Setup.html
<rcm>civodul: that fixed it. Thank you!
<civodul>yw!
<jlicht>hi guix!
<pkill9>hey
<jlicht>hello, pkill9
<pkill9>ng0: thanks for submitting a patch for Xonotic :3
<pkill9>is guix supposed to create *.cache files? I find a lot are created with graphical software and a lot of collision warnigns are shown
<pkill9>warnings*
<wigust->pkill9: What do you mean by *.cache files?
<wigust->pkill9: Collision warnings are OK most of the time.
<pkill9>like icon cache files
<pkill9>is it possible to change the display settings of the GuixSD grpahical login screen?
<caffe`>rekado: no, emacs doesn't start at all.
<caffe`>i mostly get the same output as posted here: https://lists.gnu.org/archive/html/help-guix/2017-11/msg00054.html
<axd-v>hey everyone, does anyone happen to use a vpn on their systems without the gtk frontend. I still am using the default choice of NetworkManager, however I use a window manager sans environment thus don't have the gnome plumbing preinstalled to use their applet. I installed the package `network-manager-openvpn` but fail to see how to make use of it using nmcli.
<caffe`>is it possible from nmtui?
<axd-v>caffe`: I can only figure out how to add new connections or edit existing ones using nmtui, don't see any other functionality exposed through it.
<bavier`>pkill9: it is, you can override the slim-service's default theme settings
<bavier`>I don't know that there are any examples of this anywhere
<axd-v>caffe`: actually, I'm taking a closer look at nmtui right now and there are some options when I try to add something manually. Would `Ip tunnel` or `vlan` be taken to mean vpn in their use? Doubt it, but not sure.
<caffe`>okay, i wasn't sure if vpn settings would appear there or not. I haven't installed that package
<axd-v>I tried running `nmcli connection import type openvpn file file.ovpn` after finding this line online, however I get `Error: failed to load VPN plugin: unknown VPN plugin "org.freedesktop.NetworkManager.openvpn".` back after running it.
<axd-v>caffe`: is there some other way people utilize VPNs on guixsd? I'm open to changing from networkmanager to something like connman as an alternative or others. I haven't really grokked the shephard for system services yet so haven't tried messing around with these daemons yet, but still plan to.
<caffe`>I don't know, I personally don't utilize them myself. Suggesting nmtui was just sort of a shot in the dark.
<pkill9>anyone know what package 'libgcc_s.so.1' belong to? i tried gcc and gcc-toolchain but they don't create it it seems
<pkill9>i'm trying to provide libs for a game
<civodul>pkill9: it's in gcc:lib
<pkill9>which assumes libraries are in normal FHS
<pkill9>cool thanks
<Sleep_Walker>I assume that mount capabilities are restricted for the build, right?
<Sleep_Walker>(otherwise one could mount something relevant inside of build job and influence system itself)
<ison111>Are there any matrix clients in the guix repository? The only option I can find is weechat + the plugin, but that plugin really eats up my cpu for some reason.
<pkill9>where is linux-vdso.so.1 ?
<pkill9>nevermind, got it working :D learnt a little about how linux programs work, it was looking for interpreter in /lib64/ld-linux-x86_64.so.2
<pkill9>so i made symlink there to my temproary profile's .so file and voila
<rin`>How do I change grub background in GuixSD? I don't find grubs config files in /etc. Should I change background in the GuixSD configuration file?
<pkill9>rin`: https://www.gnu.org/software/guix/manual/guix.html#Bootloader-Configuration
<pkill9>there's a theme option
<rin`>ohhh ok thanks
<bavier`>oh cool, fftw does runtime cpu detection
<jonsger[m]>Sleep_Walker: I think we only need to get guile-git and guile-charting to Leap 15, then we should have guix 0.14 working there https://build.opensuse.org/package/show/openSUSE:Leap:15.0:Staging:adi:32/guix
<Sleep_Walker>jonsger[m]: Leap 15 is not my interest but sure, go ahead
<Sleep_Walker>all the required packages are already in Factory
<Sleep_Walker>(together with 0.14)
<jonsger[m]>yeah
<Sleep_Walker>hm, so shepherd is already there?
<jonsger[m]>I think, but only 0.3.2
<Sleep_Walker>it's build dependency only anyway, it is not used at all
<civodul>bavier`: does it?
<civodul>which version?
<bavier`>civodul: 3.3.7 at least, and 3.3.5 afaict
<bavier`>I just built 3.3.7 on an older amd interlagos (sse2 support) using "--enable-avx --enable-avx" and it's 'make check' passed
<bavier`>I'm going to try moving the test binaries to a newer system to see if the performance checks out
<civodul>right, but --enable-avx is not "run time" :-)
<bavier`>civodul: the --enable-avx configure flag in this case just means the avx code is built into the library
<civodul>anyway, i'm interested in the result!
<civodul>oh, ok
<bavier`>at runtime the fftw planner is then able to select those avx kernels
<civodul>oooh
<bavier`>I'll do some more tests and send an email to the ML
<civodul>perhaps we can adjust in core-updates
<civodul>awesome
<basto> https://downforeveryoneorjustme.com/jxself.org
<sneek>Welcome back basto, you have 1 message.
<sneek>basto, wingo says: sure, with tricks you can get the asm version faster, hence "naively-coded" :)
<basto>The site is down
<jonsger[m]>when I try to reconfigure my guixsd in qemu I got this log http://susepaste.org/view/raw/69721817
<jonsger[m]>thats my config http://susepaste.org/view/raw/78635706
<jonsger[m]>ah works, just reboot and use "old configuration" which is actually the new one :P
<pkill9>I can't believe the Ranger file manager isn't packaged
<agaric>hello! i was wondering, all the standard output from my x session (via slim) gets output to tty1 by default; is there a way to save the output to a file instead?
<bavier`>pkill9: it's on the "wishlist" https://libreplanet.org/wiki/Group:Guix/Wishlist