IRC channel logs

2018-03-26.log

back to list of logs

<Apteryx>OK, it was my fault: emacs-guix environment option must be configured to create enviroment for packages using the '=p' (packages++) option, not '=='.
<Apteryx>how do I manually tell GDB I wanna track the file in a buffer for visual debugging? By default it will only show the file containing a "main" entry function.
<Apteryx>(GDB in Emacs)
<Apteryx>OK... that was a question of compiling using ./configure --enable-debug=yes (with debugging symbols).
<Apteryx>Now it shows the source file. Next issue: gdb complained about "permission denied" when attempting to run it with 'r'. I've chmod +x it, and it then complains that it "cannot execute binary file: Exec format error". I'm not very successful at this...
<Apteryx>Could it be because I don't have debug symbols available for all the libraries this file uses? (such as glib).
<Apteryx>hmm. I've recompiled and tried again... seems to work so far!
<Apteryx>Has anyone has tried compiling c++ inside GDB? Like... "compile code bool g_test_verbose (void) { return true; }"? It returns: No compiler support for language c++.
<Apteryx>nckx: fails on this for me: 21d 1810800 1814400
<Apteryx>took me a whole lot of time just figuring out how to debug using Emacs + GDB + Guix :D
***ryanprior[m] is now known as ryanprior
<Apteryx>seems the best bet was this: cd $failed_mu_build_dir && guix environment mu --ad-hoc emacs && ./configure --enable-debug=yes && emacs -> M-x gdb -> lib/parser/test-utils and it should allow you stepping the test.
<Apteryx>nckx: It's equal to 1h. Maybe summer time? :D
<bandrami>Guix SD question: how do I upgrade the packages installed via 'guix system init'. Do I just run guix system init again?
<bandrami>And does that need to be as root?
<buenouanq>init is only for the first time
<buenouanq>you would run guix system reconfigure
<bandrami>Ah thanks
<buenouanq>I'm actually not sure how and when packages declared there are upgraded...
<bandrami>Right, I thought guix package as root might do it, but root just has an individual profile like everybody else
<buenouanq>right
<buenouanq>so I think yeah, you would have to pull and reconfigure (with the same or different config.scm)
<bandrami>That's also AFAICT the only way to add e.g. another desktop environment for the dm to find
<buenouanq>yeah, that has to do with the slim/xorg ordering mess too
<bandrami>I could have sworn seat management worked 15 years ago without any of this complexity, but anyways....
<buenouanq>I'm just happy to have a trustably free OS that not only works but is a pleasure and breeze to use and set up (-‿‿ - )
<bandrami>Same. Parabola and Trisquel barfed on setting up UEFI. 10 years ago I would have tried to figure out why; as it is I just like that this works.
<efraim>rekado: I haven't checked to see if classpath@0.93 aka classpath-bootstrap fails on armhf, but looking at native/fdlibm/ieeefp.h it assumes arm that isn't armel is big endian
<efraim>rekado: don't forget to switch to invoke on classpath :)
<rekado>efraim: will do
<rekado>right now I’m struggling to get classpath-0.99 to compile *properly* on the rhel6 branch
<rekado>it doesn’t produce some class files that do appear on master
<efraim>fun times
<rekado>It all started to go wrong here: “No .class file created for file javax/sound/sampled/spi/MixerProvider.class in . because of an IOException: Regular file /tmp/guix-build-classpath-0.99.drv-0/classpath-0.99/lib/./javax/sound cannot be used as output directory”
<rekado>I get a bunch of these messages.
<rekado>but the class files clearly do exist…?
<efraim>looks like jammv-1.5.1 was built/tested against armv4 initially
<nckx>Apteryx: Hah... That's actually quite plausible.
<nckx>& would explain why I have a working mu from several days ago.
<efraim>looks like jamvm-2.0.0 was the last release, but it updated the arm support to v6&v7
<jboy>Has anyone ever tried contextualizing GuixSD for use with OpenNebula?
<civodul>Hello Guix!
<snape>o/
<efraim>hi!
<mubarak>hello!
<efraim>civodul: I rescued a computer with a working PSU this morning. Assuming I can get the overdrive set up before I go to the airport today, what ports do we need? Just ssh? A second port also?
<civodul>hey efraim
<civodul>efraim: just SSH
<civodul>that'd be awesome
<civodul>don't miss your plane, though ;-)
<baux>hi all
<baux>someone here with experience about texlive
<baux>?
<baux>latex give me an error: '! LaTeX Error: File `grffile.sty' not found.'
<baux>but package texlive-latex-oberdiek is installed
<baux>there's a way to specify or force a path?
<efraim>civodul: did the drive in the overdrive come preinstalled with a distro?
<rekado>baux: that’s a missing feature.
<rekado>baux: installing the texlive-* packages won’t do you any good. They are meant to be used as inputs to other packages.
<rekado>baux: for your texlive needs you currently need to install the massive “texlive” package until someone gets around to implementing the missing bits.
<rekado>(it just needs a profile hook, but I haven’t had the time to implement it yet.)
<baux>so, a simple 'guix install -i texlive' ?
<rekado>baux: yes.
<rekado>baux: it’s a very large package, though.
<rekado>implementing this is on my “do this before end of February” list :)
<baux>nice :-)
<rekado>it’s even all caps… I must have felt very strongly about this one.
<efraim>Ah I see it comes with opensuse. That'll be interesting, never really tried it
<civodul>efraim: yes, it's an openSuSE
<civodul>oh you found out :-)
<civodul>BTW you'll need to "guix archive --generate-key" and to authorize the key of berlin
<baux>rekado: it works! thanks
<jlicht>heya guix
***pkill9_ is now known as pkill9
***pkill9_ is now known as pkill9
<thorwil>hi! "Send a patch" on https://www.gnu.org/software/guix/contribute/ links to the mailman page for guix-patches.
<thorwil>meanwhile, you do have docs on that: https://www.gnu.org/software/guix/manual/html_node/Submitting-Patches.html#Submitting-Patches
<civodul>thorwil: perhaps we should fix the link, no? :-)
<thorwil>civodul: then again, that page refers to packages a lot.
<civodul>yes, we should generalize it a bit, or split it
<civodul>ACTION starts to think Fibers would come in handy for the mini-udev in the initrd
<davexunit>ooh that sounds interesting
<civodul>hey davexunit
<civodul>davexunit: how was LP?
<pkill9>is it possible to change an input to use one created with `--with-source`?
<pkill9>specifically i'm trying to install youtube-dl with the newest source, but mps-youtube has that as a propagated input
<pkill9>for now i've removed mps-youtube
<pkill9>but it refuses to install youtube-dl with that source because it conflicts with mps-youtube's propagated input of the package definition of youtube-dl
<pkill9>I suppose best option is to put youtube-dl in another profile and add that to my $PATH
<pkill9>before the other paths
<davexunit>civodul: LP was good!
<davexunit>people liked my talk and I met a couple guile/guix people in person for the first time
<ryanprior>I liked davexunit 's talk and was inspired to lurk here =D hi everybody.
<ryanprior>I'll be installing GuixSD on my laptop within weeks I'd estimate. Just gotta make time and ensure my backups are 100% first.
<davexunit>ryanprior: hi! welcome aboard
<ryanprior>A lot of the professional work I do is demos of Free software. My working set is bash, docker-compose, kubernetes, and vagrant/virtualbox. I'm interested in using guix for that purpose, so anybody who's interested in pushing the limits of declarative sandbox environment definitions, service orchestration, human readability of config files, etc........ hit me up!
<davexunit>ryanprior: ah you were the one that asked that question!
<davexunit>I think guix can totally be that tool... just needs "some" hacking...
<thomassgn>anyone understand why this doesnt work: https://notabug.org/thomassgn/guixsd-configuration/src/master/testing/minimal-httpd.scm
<thomassgn>guix system build minimal-httpd.scm gives me 'guix/scripts/system.scm:1061:28: In procedure process-action: In procedure struct_vtable: Wrong type argument in position 1 (expecting struct): #<unspecified>'
<thomassgn>but evaluating the buffer in emacs+guix-devel-mode with geiser gives me =>unspecified which usually means it evaluates fine... idk.
<thomassgn>strace doesn't show me any error with files, and I don't understand what struct/argument it means by pos. 1. I guess it's pointing at system.scm... Will read it
<thomassgn>hmm, system.scm:1061 is bootloader, doesn't the simple-os from testing have a bootloader?
<civodul>davexunit: oh that sounds good! i should plan for a deferred LP session to watch some of the talks
<civodul>thomassgn: you wrote (define httpd-os ...) but you should add "httpd-os" as the last line of your config file so that your config file returns an <operating-system>
<thomassgn>then I get "guix system: error: failed to load 'minimal-httpd.scm':" and something that looks like most of the config/drv in my console output. (I just added '(%httpd-os)'to the end of the file
<civodul>add "%httpd-os", without parentheses
<davexunit>civodul: chris lamb's talk was good, though I don't know if it was any different than any of his other reproducible builds talk.
<civodul>(foo) means "call function foo"
<davexunit>mostly introductory info
<davexunit>but learned some things about diffoscope that I didn't know before because I actually haven't used it yet
<civodul>i know those of Holger, not those of lamby, so i should check ;-)
<civodul>ok
<thomassgn>hahaha, shit. never thought about that. It says waiting for build slots, so I guess that works....
<thomassgn>Thank you
<davexunit>civodul: from talking to people it seems that a guix answer to 'docker compose' and the mythic 'guix deploy' are the most desired big features
<thomassgn>I seem to remember from civodul's talk at fosdem 2016 or so, that he/you just sent your config up to the server you were demoing against... was that a homebrewed hack or what was going on behind the scenes there?
<thomassgn>(it was very impressive I remember. I was with a few guys interested, but very sceptical of dogfooding++; but as far as I remember you pulled the rug out under us...)
<civodul>thomassgn: i don't think i did that :-)
<civodul>in 2016 i demos services in containers i think, perhaps that's what you had in mind?
<civodul>anyway, i agree davexunit: 'guix deploy' could be great
<davexunit>maybe one of these days I'll find a burst of inspiration and get something done
<civodul>heheh
<civodul>roptat: BTW, are we missing something for the translation of the manual?
<civodul>it seemed ready, no?
<thomassgn>civodul: probably, it was impressve anyway - downloading it now, maybe I'll understand/remember a bit more of it. :)
<bavier>hello guix
<efraim>Hi!
<rekado>on the rhel6 branch ghc-cryptonite fails its tests. The test log doesn’t tell me anything more than that it aborted abruptly while running the blake2b-160 tests.
<rekado>I upgraded to version 0.25 (from 0.20), but the same tests still fail.
<rekado>both versions built fine on master.
<rekado>I’m *so* close to building the pigx package on rhel6.
<efraim>Mark mentioned the 0 size file on improper shutdown and I've been having issues on my aarch64 build slave, switching to btrfs for the store is.nice
<thorwil>following https://www.gnu.org/software/guix/manual/html_node/Building-from-Git.html#Building-from-Git , is there a case where `./configure --localstatedir=/var` would be wrong in a guix environment?
<thorwil>as it suspiciously looks like that page could advice to do just that, when using guix evironment
<lfam>thorwil: If you want the Guix used in your Git checkout to share the /gnu/store with a Guix that may be installed system-wide, or some other way, then you want to use the same localstatedir.
<lfam>The localstatedir contains a database that Guix uses to track what is in the store
<thorwil>lfam: it is possible to access the hosts /gnu/store from within the environment?
<lfam>thorwil: By default, `guix environment` does not do any sort of containerization, filesystem separation, etc. It just changes some environment variables
<lfam>There are options that attempt to perform various levels of separation or segmentation, but by default it doesn't do that
<thorwil>i that case, the option to share /gnu/store should probably be mentioned on https://www.gnu.org/software/guix/manual/html_node/Building-from-Git.html#Building-from-Git
<lfam>thorwil: I'm a bit confused. Those instructions do lead one to share the store
<lfam>Can you clarify the issue you see?
<thorwil>lfam: the text regarding --localstatedir is rather ... opaque
<lfam>You are suggesting that it should explicitly suggest /var?
<thorwil>it left me puzzled why the default would be wrong in a simple environment
<thorwil>while you do get an error message that tells you to supply /var
<lfam>I agree that instruction is a little opaque, although I think the link to the store's documentation does give one enough info to check if the localtstatedir is in /var or not
<lfam>By not hard-coding the value of localstatedir, I think we are trying to keep the instructions portable to non-standard installation's, for example provided by another distro
<lfam>s/installation's/installations
<lfam>We could add some words saying that the value is *usually* /var, but to read the section on The Store for more info
<thorwil>lfam: which is why https://www.gnu.org/software/guix/manual/html_node/Building-from-Git.html#Building-from-Git should perhaps have sections: standard case, adaptable case
<thorwil>where for the standard case, it should be suggested to go with /var, also mentioning that it means to use the existing store
<lfam>If the motivation was solely to clarify the common value of localstatedir, I think creating two sets of instructions would be too much
<lfam>Using multiple stores is a pretty esoteric use case, I think. It means that you can't use substitutes, which rules out Guix for many people
<lfam>(that's because the store prefix of /gnu/store is "baked in")
<lfam>Can we step back a bit and talk about the problem you had? Is it that the instructions regarding ./configure are just too opaque confusing?
<lfam>opaque and confusing, I mean
<thorwil>lfam: sorry, i just had my system freeze
<thorwil>ubuntu, so no worries, folks ;)
<lfam>Yikes :o
<thorwil>ubuntu with guix in a chroot, busy with its `make check`. so maybe i was asking for it
<lfam>I've found that `make check` uses a ton of I/O (it's own store!)
<thorwil>lfam: primarily, the docs don't have to justify the existence of localstatedir, but rather guide users trying to accomplish something
<thorwil>btw, i went through several guix pull, package updates and reconfigures in a chroot and the guix sd installation is still bootable ^_^
<thorwil>looking at desktop.scm, emacs renders window-wide bars above the section headers. what (unicode?) magic is that?
<pkill9>hi
<pkill9>oops wc
<rekado>thorwil: do you mean ^L?
<thorwil>rekado: describe-char tells me C-l (displayed as C-l) (codepoint 12, #o14, #xc)
<thorwil>sheesh, always getting so late so fast. bye! :)