IRC channel logs

2017-11-20.log

back to list of logs

<ryanwatkins>Does anybody know how one might alias or create some kind of environment whereby /bin/bash actually links to whereever that is located in guix?
<ryanwatkins>Just for some configure files
<ryanwatkins>I'm trying to do stack setup for haskell development and it's giving me /bin/bash: bad intepreter: No such file or directory
<sturm>Is it possible to temporarily activate a generation of your profile for just one shell?
<janneke>sturm: possibly if you do somemthing like:
<janneke>. /var/guix/profiles/per-user/janneke/guix-profile-184-link/etc/profile
<sturm>Brilliant, thanks janneke !
<sturm>Have to say, the more I learn about how Guix works the more I'm impressed by the smart and robust design.
<mb[m]1>ryanwatkins: See the documentation for the 'special-files-service-type': https://www.gnu.org/software/guix/manual/guix.html#Base-Services
<vagrantc>hrm. latest guixsd install attempt ends with: guix system: error: build failed: | | | bind mounting `/dev/full' to `/gnu/store/q4fkgafq47007ksxq8040zbhncccqfwd-ca-certificate-bundle.drv.chroot/dev/full'
<vagrantc>arg... this new install has the broken "guix pull" referred to in https://debbugs.gnu.org/cgi/bugreport.cgi?bug=29274
<vagrantc>why does a fresh install, with a newly built image, still pull old versions? (e.g. guix, kernel)
<vagrantc>when guix pull is "compiling" ... what is it compiling? regardless of the number of packages installed, it seems to compile the same number of things, generally...
<brendyn>vagrantc: it's compiling the latest version of guix
<vagrantc>compiling from git?
<brendyn>yep
<vagrantc>maybe i'm not understanding the architecture, but the fact the guix downloads an unsigned git repo and executes code from that... is a little disconcerting
<brendyn>I guess it's another thing on the TODO list to improve
<vagrantc>oops
<brendyn>seems like it is not possible to have gtk2 and gtk3 installed at the same time
<mb[m]1>vagrantc: All commits to the repository are in fact signed, but currently no verification is performed by `guix pull`.
<vagrantc>mb[m]1: ah, that's something at least
<mb[m]1>If it's any consolation, Guix will warn you if the HTTPS certificate you are pulling from is not using Lets Encrypt, raising the MITM bar a little.
<mb[m]1>Provided you're pulling from the default "https://git.savannah.gnu.org" URL.
<vagrantc>mb[m]1: that's something, sure
<buenouanq>has any thought been given to small things like routers?
<buenouanq>a LibreCMC+Guix would be awesome
<buenouanq>better yet, a GuixSD geared specifically for this
<CharlieBrown>buenouanq: That sounds like a bad idea. Guix is a storage hog.
<brendyn>Guix is about 200 times bigger than pacman :(
<buenouanq>I just want my mcron and guile environment is all ( ._.)
<brendyn>I wonder if we can create a minimal Guix that removes build functionality and just uses substitues
<DusXMT>buenouanq: not to mention, guix is also heavy, because it's interpreterd; takes ages to use it on solow hardware, I tried
<CharlieBrown>DusXMT: Is it heavy because of Lisp?
<brendyn>CharlieBrown: Poor Lisp and it's reputation :(
<g_bor>Hello guix!
<g_bor>I need some help.
<g_bor>I have a package with debug output, but I get a crc mismatch when trying to run gdb.
<g_bor>Anyone seen that?
<efraim>i don't think i've ever tried running gdb
<brendyn>I'm having trouble hacking on Guix
<brendyn>When I open up a file in gnu/packages/, run run-geiser and then geiser-eval-buffer, all the definitions appear in the repl,
<brendyn>but when i open up guix/scripts/package.scm and do the same, it doesn't work at all
<brendyn>Why is that?
<rekado>brendyn: you always need to eval the buffer or ,use (guix scripts package)
<rekado>the REPL is only attached to the buffer but it won’t automatically load the buffer’s contents
<rekado>g_bor: what is reporting a crc mismatch?
<brendyn>rekado: as i said i already did that
<rekado>brendyn: Guix includes bootstrap binaries and the compiled go files are pretty large.
<rekado>oh, I missed “and do the same”
<rekado>sorry
<brendyn>it worked after i pasted the entire buffer into the repl
<brendyn>and guile shows scheme@(guix scripts package)> now
<brendyn>I'm trying to figure out how to run the equivalent of `guix package -s emacs' in the repl
<brendyn>But this code is too mysterious for me
<brendyn>I'd identified it's defined at the line with ('search _), but unlike the other options it has a _ instead of an actual argument
<rekado>don’t paste big chunks of code into the repl
<rekado>if the thing is on the %load-path you can just ,use (guix scripts package)
<rekado>or ,module (guix scripts package) to enter the module
<brendyn>I think I may have needed to use ,module
<brendyn>it was evaluating, but not entering
<brendyn>but with the gnu/packages/ files it would automatically enter
<g_bor>rekado: when loading the debug files for a customized gcc. I'm trying to track down the differences in the gcc-ddc.
<g_bor>Now I think I cna get around that by building a nostrip version.
<g_bor>I have a few question, if you could keep me updated.
<g_bor>I'd like to ask what the status of bootsrapping guile with mes. If I remember correctly you were working on that.
<g_bor>I'd also like to ask how to use the partial bootstrap path you have for ghc...
<g_bor>I'm thinking about to finish it like we were discussing, by bootstrapping a 32-bit ghc, the cross-building a 64-bit one.
<g_bor>I know that you would like to simplify that ulimately, but having a proof of concept one would be great.
<rekado>g_bor: I think it’s better to bootstrap a modified ghc directly with hugs instead of having nhc98 in between.
<rekado>we know that ghc can compile ghc, but we don’t know if nhc98 can do that.
<rekado>with the limitations of nhc98 I don’t think it’s worth pursuing that path.
<rekado>I outlined the work I did on hugs and nhc98 here: https://elephly.net/posts/2017-01-09-bootstrapping-haskell-part-1.html
<rekado>I intend to work on part 2 when I find more time.
<rekado>re bootstrapping guile with mes: there are still problems with macro expansion IIRC.
<rekado>janneke continued the work some more and ran into another problem.
<rekado>I’m not currently working on this. I’m doing Java work again, this time to build FastQC (a very popular tool for many bioinfo data processing pipelines) from source.
<g_bor>rekado: thanks on the update. I also lost track on the decision regarding python bytecode reproducibility. Was it decided to create a patch? Is anyone working on that?
<efraim>I think we're waiting for core-updates and python 3.6
<efraim>Currently icu4c fails on at least x86_64 and gtk+@2 fails on at least aarch64
<mb[m]1>Bah, the fix for signbit() worked, but icu4c still fails in a similar fashion later in the build process. Will have to dig some more in the glibc git log later today.
<mb[m]1>Apparently not a lot of testing was done with GCC <6 on glibc 2.26.
<efraim>(soffice:20257): GLib-GIO-ERROR **: Settings schema 'org.gtk.Settings.FileChooser' is not installed
<efraim>any idea what i'm missing?
<efraim>nautilus?
<civodul>efraim: i've seen that one long ago!
<civodul>it's one of these XDG-data-something
<civodul>if you see what i mean :-)
<efraim>looks like xfce-desktop or libreoffice is missing an input
<efraim>makes saving files hard :)
<civodul>saving files is overrated
<rekado>efraim: is it enough to set XDG_DATA_DIRS?
<efraim>i haven't figured out my printer yet though, so I was going to 'cat file | ssh other-computer lp'
<rekado>to the /share dir of gtk+
<efraim>XDG_DATA_DIRS=/run/current-system/profile/share:/home/efraim/.guix-profile/share:/run/current-system/profile/share:/gnu/store/yahp53x5149kv1k8x94drn5gx1bq3zaw-xfce4-session-4.12.0/share
<rekado>I needed to wrap the synfigstudio executable to make sure it doesn’t crash when trying to save a program.
<rekado>*a file
<civodul>efraim: is that on GuixSD?
<efraim>yeah
<civodul>uh
<efraim>here's the full dump: https://paste.pound-python.org/show/lbuzC5VhEFLosQ4tPAUh/
<efraim>saving in abiword didn't crash FWIW
<CharlieBrown>Hey Guix, I'm ttrying to learn JavaScript and all I find on GitHub are repositories with either no license or half the source code missing, or referring to file on a server somewhere. How do I get actual source and run a simple app and play with it?
<CharlieBrown>by half the source code missing, i mean there are a bunch of .min.js files
<CharlieBrown>also, are any npm packages in guix yet?
<CharlieBrown>i don't want to mess with npm
<CharlieBrown>davexunit: thanks for speaking up about the problem btw https://news.ycombinator.com/item?id=10339368
<efraim>... and now that I've saved something using abiword the save dialog works in libreoffice
<civodul>that's interesting
<civodul>it might be a problem about starting the right dbus service or something?
<civodul>rekado: would you be able to reconfigure berlin, or would you like me to do it?
<civodul>(so we get the 'guix publish' fix from yesterday)
<OnlyHuman>hi any advice simplest way to setup elogind so it works with sysvinit? thanks
<catonano>CharlieBrown: the time for npm packages in guix is way off. There's a mitigation, see here https://lists.gnu.org/archive/html/guix-devel/2017-07/msg00217.html
<rekado>civodul: oh, sure, I’ll reconfigure it.
<CharlieBrown>I just wanted to start checking out JavaScript, and all the code is convoluted and surrounded with mysterious .min.js's....
<brendyn>CharlieBrown: those are minified js files. not source files
<CharlieBrown>brendyn: I know, which is why I'm frustrated.
<CharlieBrown>When I download the source code, it's not really source code.
<CharlieBrown>And I'll have an even harder time running it all locally.
<CharlieBrown>They pull in stuff from the Web...
<brendyn>then the true source must be somewhere else
<brendyn>or its proprietary and not even provided
<OrangeShark>CharlieBrown: are these libraries?
<CharlieBrown>brendyn: The source is somewhere else, but I don't want to have to verify those binaries or hunt down the source.
<CharlieBrown>OrangeShark: Specifically, I'm looking at the Quickstart on https://github.com/quilljs/quill
<CharlieBrown>I just want to run the stuff directly from the source, like a Python program.
<brendyn>Does anyone else find that their pcmanfm is note saving settings that are changed?
<brendyn>not
<CharlieBrown>My Emacs isn't.
<CharlieBrown>I have to do "y y" every time I launch Emacs, so the Solarized Dark theme will load.
<brendyn>I've also got some lingering chinese directory names since before i changed my system to English.
<brendyn>So transmissions downloads to 下載 instead of Downloads. It's rather anyone and I can't find where to reset it
<CharlieBrown>~/.config/user-dirs.dirs invalid on guix?: is
<CharlieBrown>Sorry, the Riot Rich Text Editor is too smart and mangles my text when I Control-v in the middle of a sentence.
<CharlieBrown>brendyn: is ~/.config/user-dirs.dirs invalid on guix?
<brendyn>CharlieBrown: Genius. the Pictures directory is defined in there, but not the downloads one tho
<apteryx>I'm retrying Guix on a foreign distro (Ubuntu 16.04) at work. I'm a bit rusty with the process. I finished installing the base system and successfully did a 'guix pull' as root. Then I tried installing glibc-locales as root (I'm folling the Application Setup of the manual) but got that: error: directory `/var/guix/profiles/per-user/root' is not owned by you.
<apteryx>I'm not sure how I got into that situation, but "chown -R root:root /var/guix" seems to have fixed it.
<apteryx>I'm not getting: guix package: error: profile contains conflicting entries for linux-libre-headers:out
<apteryx>(see: https://hastebin.com/xejasopoca.sql)
<efraim>apteryx: I'd go with 'guix package -u' and then 'guix package -i glibc-locales' again, you have a conflict between the linux-libre-headers from something already installed as root
<apteryx>efraim: that's a good suggestion. I'm trying it now.
<brendyn>I had that same error and i'm also not sure how it happened
<quiliro>hello
<quiliro>i have to report a bug for openmolar
<quiliro>i know exactly where the problem is an what line to correct
<quiliro>but i don't know what to modify in the package definition
<quiliro>rekado: remember you made the package?
<quiliro>i never had a chance to test and find possible solutions for this error because i had a couple of months of illness
<quiliro>but now i have the error
<quiliro>and place to modify
<quiliro>but do not know where i have to modify medical.scm
<quiliro>i have the sent report already. but it gets bounced from bugs-guix@guix.org
<roelj>quiliro: I think it should be 'bug-guix@gnu.org'.
<civodul>roelj, rekado: do you mount the user's home dirs on the node that runs guix-daemon on the cluster
<roelj>civodul: Yes.
<civodul>ok
<civodul>this is needed anyway if you are to allow GC roots in "non-standard" locations
<roelj>civodul: About GC roots.. We have a set-up wherein 'root' cannot see all files. So guix-daemon cannot garbage collect because it cannot see everything.
<roelj>civodul: Could we keep track of files in the database, and assume anything that root can't see is still there? (A very conservative approach)
<civodul>roelj: that wouldn't scale well, no?
<civodul>you'd have more and more GC roots
<civodul>that said, we could extend "list-runtime-roots" to grab lists of GC roots through other means
<civodul>janneke: https://reproducible.alioth.debian.org/blog/posts/133/ mentions DDC efforts... by Ximin
<civodul>oh well
<apteryx>efraim: worked after the `guix package -u`. Thanks for refreshing my memory!
<roelj>civodul: I'm not sure why this wouldn't scale well.. If we just keep track of which files are "active" in a database instead of using symlinks. Then we could treat a "permissions denied" return from a stat-call to a file as "alive", instead of assuming it's gone.
<roelj>civodul: We just need to store the manifests in a database I guess. It needs to go over the same information, so it should be equal in speed.
<civodul>roelj: ah sure, i had misunderstood
<civodul>roelj: so it's about telling list-runtime-roots about new ways to find out GC roots
<civodul>one way would be "go check that database"
<civodul>does that make sense?
<roelj>civodul: Ahh I'm sorry, I probably didn't explain it well. And I haven't seen the code, so I don't know how list-runtime-roots works.
<roelj>civodul: But it sounds good to me.. as far as I can understand it.
<brendyn>Any development on Guix channels?
<civodul>brendyn: not directly on channels, but on the underlying issues in 'guix pull'
<brendyn>Cool. I think a decentralised Guix is the healthiest Guix.
<civodul>it's already possible, just less convenient
<civodul>and with the caveat about API compatibility
<brendyn>Well I want to build a convenient Guix :p
<civodul>which makes a lot of sense of course :-)
<DusXMT>ACTION 's convenient guix: `$ guix_pure.sh' launches a shell installed in the guix profile with only guix tools and env. vars available, and guix is a one-line script that runs `./pre-inst-env guix $@' in the git repository~
<DusXMT>I find that running Guix mixed with my main system results in odd issues
<DusXMT>(including the inability to install anything after the first "guix pull")
<civodul>DusXMT: inability to install anything?
<DusXMT>civodul: I think I posted an error log in a pastebin here about it, but my question got overlooked
<DusXMT>ACTION already "fixed" it by insulating guix from the main system
<brendyn>I think we need some more conventions. for example, a default os configuration file path, and then config to automatically change the system in simple ways, perhaps like how emacs manages custom-set-variables. How else can one create a basis for adding new system packages automatically and via a GUI?
<DusXMT>The packages would build just fine, but guix would fail at updating the profile
<civodul>brendyn: that sounds interesting
<civodul>DusXMT: do you still have the log?
<DusXMT>I have the link, but it already expired, sorry
<brendyn>civodul finally likes one of my ideas ^,^
<civodul>hm?
<civodul>i'm always open to new ideas, whoever writes them
<brendyn>nothing just joking. often when i suggest ideas on irc somebody just asks my why i would ever want it
<civodul>heheh
<DusXMT>Acctually, correction, it would fail to build new packages if I set .config/guix/latest to point at an up-to-date git repo; what would fail without that was a second "git pull" after the first (even with guile-git installed)
<jonsger>that covers also my experience. environment variables, path and that stuff on foreign distros is sometimes not much fun
<DusXMT>ACTION 's system is Devuan Jessie
<civodul>'guix package --search-paths' and ~/.guix-profile/etc/profile attempts to make that painless
<civodul>now, people recently reported issues with GTK+ programs
<civodul>not sure if that's what you're experiencing
<civodul>i encourage you to share your experience on help-guix anyway!
<DusXMT>I believe that it's most likely the fact that it uses the native guile interpreter that ships with the system instead of its own
<DusXMT>As it also showed this warning on each guix invocation (not my email): https://lists.gnu.org/archive/html/guix-devel/2015-11/msg00535.html
<civodul>what uses the native guile?
<DusXMT>guix
<civodul>when you build by hand, yes, though it shouldn't be a problem?
<civodul>locales are covered in https://www.gnu.org/software/guix/manual/html_node/Application-Setup.html#Locales but i keeps being an annoyance for some reason
<DusXMT>ACTION would love to reproduce the error, but he's kinda covered up with college thnings...
<quiliro>roelj: thank you
<quiliro>just sent the bug report
<quiliro>it is "openmolar looking in /usr/share/openmolar"
<rekado>civodul: berlin finished reconfiguration.
<quiliro>please confirm the reception
<civodul>rekado: awesome, thanks!
<civodul>i've restarted guix-publish from shepherd
<rekado>I stopped it before reconfiguring the second time.
<quiliro>found it at https://lists.gnu.org/archive/html/bug-guix/2017-11/msg00150.html
<rekado>civodul: about the release… are we just waiting for core-updates at this point?
<rekado>I think it’s a good time now to start collecting notable contributions and to add them to a new draft entry in the NEWS file.
<civodul>rekado: yes, i think we're ready
<civodul>so yes
<civodul>ACTION has to go
<civodul>let's talk about this tonight or via email!
<rekado>ACTION also leaves
<dogetest>Ive done a guix gc then guix pull && guix package -u and it seens that is downloading and building the whole system. shouldnt it just build whats new?
<efraim>it may need to build some extra packages that are needed in grafting
<efraim>if you already have a grafted git and its ungrafted counterpart, you also need the other 3 outputs from git so it can graft all 4 again
<dogetest>Ive installed virt-manager, which requires libvirtd (which has been installed), but I cant start/enable it within herd because its not avaliable
<dogetest>not avaliable to herd start
<dogetest>should I daemonize it?
<ng0>hi! I have half of emacs-jdee. Now I just need to package the server. Is anyone familar with it so that I can learn a bit 'insider' knowledge before starting with it, anything to avoid etc?
<apteryx>Hello! How would I set the setuid bit of a Guix package binary on a foreign distribution?
<apteryx>Can I just do chmod u+s on it?
<apteryx>(seems to work)
<luther9>hi, guys. i'm trying to install guix on trisquel. the `GUIX_PROFILE=$HOME/.guix-profile source $GUIX_PROFILE/etc/profile` command has no effect, and i can't run guix-deamon. any ideas?
<quiliro>would someone please take a look at bug#29365: openmolar looking in /usr/share/openmolar
<quiliro> https://lists.gnu.org/archive/html/bug-guix/2017-11/msg00150.html
<janneke>luther9: at which step of https://www.gnu.org/software/guix/manual/html_node/Binary-Installation.html are you now?
<janneke>or are you following a diffent path?
<luther9>step 4. i've already run the code at https://www.gnu.org/software/guix/manual/html_node/Build-Environment-Setup.html#Build-Environment-Setup. the guix-daemon command is not found.
<luther9>`GUIX_PROFILE=$HOME/.guix-profile source $GUIX_PROFILE/etc/profile` has no effect on the environment variables. I don't understand the interpolation syntax in that file, so i'm not sure what it's supposed to do.
<vagrantc>luther9: you put them sequentially?
<vagrantc>e.g. if all on one line, it wouldn't work correctly
<luther9>yes, though i put the useradd command on one line.
<luther9>IOW, i ommitted the slash-newline.
<janneke>luther9: have you looked what your $GUIX_PROFILE/etc/profile looks like?
<luther9>typing `cat $GUIX_PROFILE/etc/profile` shows contents of /etc/profile. $GUIX_PROFILE is not defined.
<janneke>ah, sure...yes use: cat ~/.guix-profile/etc/profile
<janneke>(or ... GUIX_PROFILE=$HOME/.guix_profile cat $GUIX_PROFILE/etc/profile ;-)
<luther9>i see the file with 'export PATH=' and 'export GUIX_LOCPATH=' with the weird ${} syntax.
<luther9>the GUIX_LOCPATH definition has '/lib/locale' outside of any braces, so i should see something, yet GUIX_LOCPATH ends up empty.
<janneke>luther9: can you paste your ~/.guix-profile/etc/profile in paste.debian.net?
<luther9>done: http://paste.debian.net/996777
<janneke>civodul: oh, but DDC of tinycc is pretty nice, right?
<janneke>luther9: ok; i saved that file as paste_996777
<janneke>luther9: when i do: (three commands)
<janneke>bash
<janneke>set -x
<janneke>. paste_996777
<civodul>janneke: it is!
<janneke>i see PATHh and GUIX_LOCPATH being set; what do you see?
<janneke>civodul: i dropped/paused my ddc work, but g_bor made great progress where i left it on gcc-4.7.4
<luther9>i see a report of what's being executed, and echoing the variables shows success, at least within this subshell. i'll have to look up what `set -x` does.
<janneke>good; set -x just shows what statements get executed
<janneke>if you then do: echo $PATH
<janneke>that should show /gnu/store/vy99py4x7l440y2bgc2bcvggjb5r7aa8-profile/bin at the start of your PATH
<luther9>janneke: i do see that. i'm exiting the subshell to try it for real.
<luther9>janneke: when i run `GUIX_PROFILE=$HOME/.guix-profile source $GUIX_PROFILE/etc/profile`, the 1st 2 lines are this:
<luther9>+ GUIX_PROFILE=/root/.guix-profile
<luther9>+ source /etc/profile
<luther9>so GUIX_PROFILE is somehow not set for that command.
<luther9>i'll try running that command the other way
<bms_>Hello.
<janneke>luther9: yeah, that's wrong
<janneke>you may just have found a bug in the manual
<luther9>janneke: any idea what's wrong there? the shell syntax in the manual looks correct to me.
<rekado_>hasn’t this been fixed very recently?
<janneke>luther9: i'm not sure...i think that as `source' is an internal command, this just doesn't work
<rekado_>the online manual doesn’t contain the fix yet
<rekado_>(this will happen once the next release is out)
<janneke>i think that: GUIX_PROFILE=$HOME/.guix_profile ; source $GUIX_PROFILE/etc/profile
<janneke>will work
<janneke>rekado_: ah, great...
<janneke>ACTION was just blaming doc/guix.texi to find out :-)
<janneke>rekado_, luther9: yeah: bd7e136d2 Add semicolon in commands that set GUIX_PROFILE.
<janneke>luther9: too bad you had to also trip on this documentation bug...; the semicolon fixes it
<luther9>janneke: yes, the `;` seems to have fixed the environment variables. thanks much for your help. i'll go back to installation work now...
<janneke>luther9: good luck, let us know how it goes for you if you want
<luther9>i don't use irc often, but yeah, i'll try to check back in here.
<janneke>luther9: as you wish, all the better you came here for help :-)
<janneke>too bad the M1 output looks like this
<janneke>:main
<janneke>\\tpush___%ebp
<quiliro>hello